Отображение только "своих" элементов в форме списка подчиненного справочника при отключении иерархии

05.03.11

Задачи пользователя - Адаптация типовых решений

В форме списка подчиненного справочника при отключении иерархии отображается весь его состав.

В некоторых случаях это неудобно...

Предлагается следующий вариант решения:

в модуле формы списка подчиненного справочника добавить две предопределенные процедуры следующего содержания:

 

//***********************************
Процедура ПриСменеИерархии(Способ)
      УстановитьОтбор(,);
      Если Способ = 0 Тогда
            ТекВладелец = ТекущийЭлемент().Владелец;
            Список = СоздатьОбъект("СписокЗначений");
            Спр = СоздатьОбъект("Справочник." + Вид());
            Спр.ИспользоватьВладельца(ТекВладелец);
            Спр.ВыбратьЭлементы();
            Пока Спр.ПолучитьЭлемент() = 1 Цикл
                  Список.ДобавитьЗначение(Спр.ТекущийЭлемент());
            КонецЦикла;
            ИспользоватьСписокЭлементов(Список);
      Иначе
            ИспользоватьСписокЭлементов();
      КонецЕсли;
КонецПроцедуры

//***********************************
Процедура ПриВыбореВладельца(Элемент)
      УстановитьОтбор(,);
      ИерархическийСписок(1); 
      ИспользоватьСписокЭлементов();
КонецПроцедуры

 

можно ещё в процедуре ПриОткрытии() добавить:

ИерархическийСписок(1);

 

См. также

Улучшенная обработка "Внешние печатные формы" для типовых конфигураций на базе 1С 7.7

Печатные формы Адаптация типовых решений Программист Платформа 1С v7.7 Конфигурации 1cv7 Абонемент ($m)

Приятное улучшение обработки "Внешние печатные формы" для типовых конфигураций на базе 1С 7.7 для более комфортной работы с "любимой семерочкой".

1 стартмани

04.02.2022    3235    1    igor7777    0    

3

Расчет страховых взносов в 1С 7.7 "Учет и отчетность предпринимателя, ред. 1.2" с апреля 2020

Адаптация типовых решений Программист Платформа 1С v7.7 Конфигурации 1cv7 Россия Бухгалтерский учет ФОМС, ЕФС Бесплатно (free)

В этой статье описано, какие небольшие изменения можно внести в модуль документа Начисление налогов с ФОТ, чтобы правильно рассчитывались страховые взносы с 1 апреля 2020 г.

09.04.2020    20013    Юджин58    39    

5

Дистрибьюция 7.7. Часть 1. Жизненный цикл заявки покупателя. Одна заявка покупателя, много адресов доставки.

Адаптация типовых решений Программист Платформа 1С v7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Управленческий учет Бесплатно (free)

Описан способ работы с учетом расписания с приоритетными покупателями - торговыми сетями (основными покупателями) в торговой или комплексной учетной системе на 1С 7.7. Множественная заявка покупателя на несколько торговых точек.

14.10.2019    6093    ksnik    14    

3

Как в торговле 7.7 печатать код ТНВЭД в счет-фактуре

Операции по ВЭД Адаптация типовых решений Программист Оперативный учет 7.7 1С:Торговля и склад 7.7 Россия Бухгалтерский учет НДС Бесплатно (free)

В данной статье хотел поделиться опытом, как в Торговле 7.7 ( релиз 994) сделать возможность выводить код ТНВЭД в печатную форму счета-фактуры. Сразу скажу, что нужно это только тем, кто осуществляет экспорт в страны таможенного союза. Остальные могут не волноваться.

15.11.2017    11870    AndKovalchuk    0    

1

Предельные базы взносов в ПФР, ФСС, ФФОМС 2015 в 1С: Бухгалтерия 7.7

Зарплата Адаптация типовых решений Программист Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет Абонемент ($m)

Реализация Постановления Правительства РФ 1316 от 04.12.14 для типовой конфигурации "Бухгалтерский учет 7.7" рел. 7.70.590

1 стартмани

31.12.2014    23974    9    Sergey1CSpb    2    

0
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Andzhej 05.03.11 16:29 Сейчас в теме
Еще можно запретить отключать иерархию в подчиненном справочнике.

Процедура ПриСменеИерархии(Способ)
      УстановитьОтбор(,);
      Если Способ = 1 Тогда
         СтатусВозврата(0);
     .....
3. 1с2с 53 06.03.11 14:27 Сейчас в теме
(1), (2) не равноценно..., задача состояла именно в том, чтобы не запретить, а отобразить...
2. Ёпрст 1064 06.03.11 09:59 Сейчас в теме
Вся поделка заменяется 1 строчкой кода:
ИерархическийСписок(1,0);
4. seakuban 11 06.03.11 14:34 Сейчас в теме
Нормально решение. Варианция использования не всем известного метода ИспользоватьСписокЭлементов(). Конечно при использовании такого метода стоит иметь в виду что ИспользоватьСписокЭлементов() - это нединамический фильтр и соответсвенно обновления списка элементов (если во время того когда на экране висит эта форма в справочнике другой пользователь создает элемент) не произойдет
5. seakuban 11 06.03.11 14:37 Сейчас в теме
+4 Ну и еще так...к слову. Если автор надумает использовать метод ИспользоватьСписокЭлементов() для других целей - например фильтр по аналогам, по остаткам (в форме подбора к примеру) то следует иметь в виду что по элементам отфильтрованным этим фильтром интерактивный поиск работает медленно. Возможно потому что в этом случае для поиска движок 1С не может использовать индексы
6. Andzhej 07.03.11 00:05 Сейчас в теме
У меня была задача, сортировать + отфильтровать список товаров по нескольким реквизитам сразу, приходилось использовать ИспользоватьСписокЭлементов(), т.к. 1С 7.7 стандартно сортирует/фильтрует только по одному реквизиту.
Прикол в том, что после использования метода ИспользоватьСписокЭлементов("список"), возвратится к динамичеким системным фильтрам невозвожно. Пришлось переоткрывать для этого форму.
Оставьте свое сообщение