Своя операция в закрытии месяца? Легко!

Публикация № 898002

Учет и отчетность - Закрытие периода - Закрытие периода

ERP закрытие месяца операции закрытия месяца реклассификация контроль операций своя операция закрытия месяца

Иногда приходится сталкиваться с задачей включения в пункты закрытия месяца своих операций. В данной статье будет показано – как с минимальными изменениями конфигурации, а также использованием расширений решить такую задачу.

Для решения задачи в качестве типовой конфигурации будем использовать «1С: ERP Управление предприятием 2». 

Это могут быть как обязательные операции, от которых зависит финансовый результат, так и необязательные, которые не влияют на финансовый результат, но, возможно, несут некую функцию проверки учета, сигнализирования о неких проблемах при ведении учета.

Пример №1: Необходим пункт, который бы показывал ответственному бухгалтеру, который выполняет процедуру закрытия, общую картину по различиям между остатками товаров в оперативном и финансовом учете без учета складов и номенклатуры. Но, если бухгалтер захочет увидеть детально по складам и номенклатуре расхождения – чтобы у него была такая возможность из закрытия месяца вызвать какой-то отчет, который ему все покажет и все расскажет.

Как реализовать такую «хотелку»? Все достаточно просто. В конфигурации уже есть отчет «Контроль оформления документов товародвижения». Отчет показывает то что нам необходимо. Осталось только сделать пункт в операциях закрытия месяца и прикрутить туда данный отчет.

Обратимся к дереву метаданных конфигурации. Нам необходимо использовать следующие объекты:

  1. Отчет: «КонтрольОформленияДокументовТовародвижений»
  2. Общий модуль: «ЗакрытиеМесяцаСервер»
  3. Перечисление: «ОперацииЗакрытияМесяца»

Наиболее существенными в части доработок являются первые 2 объекта. Они не несут в себе структурных изменений метаданных – их можно легко разместить в расширении и производить модификацию именно там. Как создавать расширения конфигурации и как добавлять туда объекты – в интернете достаточно информации, можно без труда найти. В данной статье я опишу наиболее значимые моменты. Итак, поехали:

  1. Добавим в конфигурацию новое значение перечисления: «КонтрольОформленияДокументовПоОрдернымСкладам»
  2. Поместим процедуру ЗаполнитьОписаниеЭтаповЗакрытияМесяца(...) общего модуля в расширение. Наш код будет выполняться после основного кода процедуры. Его выделим в отдельную область.
  3. Добавим функцию, которая будет отвечать за открытия отчета с указанными параметрами (период, организация).
  4. Добавим процедуру, которая анализирует корректность оформления товарных документов. По сути, внутри ее производится вызов функции, в которой выполняется запрос из отчета. Именно из-за этого я не буду приводить листинг данной функции. По результатам выполнения такого запроса мы устанавливаем состояние у нашей операции.
  5. Поместим в расширение модуль объекта отчета «КонтрольОформленияДокументовТовародвижений». Мы сделаем этого для того, чтобы обработать входные параметры из операции закрытия месяца, и использовать их как значения отбора для компоновщика отчета.

 

 Общий модуль «ЗакрытиеМесяцаСервер»

#Область ОписаниеЭтаповЗакрытияМесяца

&После("ЗаполнитьОписаниеЭтаповЗакрытияМесяца")
Процедура Расш_ЗаполнитьОписаниеЭтаповЗакрытияМесяца(ТаблицаЭтапов)
	#Область КонтрольПоОрдернымСкладам	
	// наша операция будет располагаться внутри группы операций, которые находятся на 
	// "ручном контроле"
	ТекущийРодитель = ИдентификаторГруппыРучныеОперации();

	// добавляем непосредственно в таблицу, которая содержит перечень операций
	НоваяСтрока = ДобавитьЭтапВТаблицу(ТаблицаЭтапов, ТекущийРодитель,
		Перечисления.ОперацииЗакрытияМесяца.КонтрольОформленияДокументовПоОрдернымСкладам,
		Истина, Ложь, Ложь);
		
	// так как наша операция по факту показывает что есть какие то отклонения в товародвижении 
	// но не выполняет никаких действий по автоматическому исправлению ситуации, то
	// основным действием - является интерактивный вызов отчета с нужными параметрами
	НоваяСтрока.ВыполняетсяВручную = Истина;
	НоваяСтрока.ТекстВыполнить     = НСтр("ru='Показать'");
	НоваяСтрока.ДействиеИспользование = ОписаниеДействия_СервернаяПроцедура(
		"ЗакрытиеМесяцаСервер.Использование_КонтрольОформленияДокументовПоОрдернымСкладам");
	
	// укажем что действием по нажатию гиперссылки будет являться открытие отчета с автоматическим формированием 
	НоваяСтрока.ДействиеВыполнить  = ОписаниеДействия_ОткрытьФормуОтчета("Отчет.КонтрольОформленияДокументовТовародвижений.Форма", Новый Структура("СформироватьПриОткрытии", истина));
	
	#КонецОбласти //КонтрольПоОрдернымСкладам		
	
КонецПроцедуры

#КонецОбласти

#Область КонтрольОформленияДокументовПоОрдернымСкладам

// Обработчики этапа.
//
// Параметры:
//  ПараметрыОбработчика - Структура, формируемая алгоритмом заполнения операций закрытия месяца, содержит основные параметры, такие как
// 							перечень организаций, период выполнения операции...
//
Процедура Использование_КонтрольОформленияДокументовПоОрдернымСкладам(ПараметрыОбработчика) Экспорт
	
	ПараметрыРасчета = ПараметрыОбработчика.ПараметрыРасчета;
	
	// формируем параметры, которые будут использоваться для установки параметров запроса,
	// который показывает картину с корректностью отражения товародвижения
	ПараметрыПроверки = Новый Структура;
	ПараметрыПроверки.Вставить("КонецПериода", КонецМесяца(ПараметрыРасчета.ПериодРегистрации));
	Если ПараметрыОбработчика.Свойство("ПараметрыРасчета") и ПараметрыОбработчика.ПараметрыРасчета.Свойство("МассивОрганизаций") Тогда
		ПараметрыПроверки.Вставить("Организации", ПараметрыОбработчика.ПараметрыРасчета.МассивОрганизаций);
	КонецЕсли;
	
	// возвращает результат выполнения запроса, который идентичен запросу, 
	// который содержится в отчете КонтрольОформленияДокументовТовародвижений
	Результат = ТоварноМатериальныеЦенностиСервер.ОперацииОрдерныеСкладыКВыполнению(ПараметрыПроверки);
	
	// Неопределено - если данные получить не удается
	// 1 строка - если все хорошо
	// В остальных случаях - необходимо обратить внимание на корректность оформления документов!
	Если Результат = Неопределено Тогда
		
		УстановитьСостояниеНеТребуется(
			ПараметрыОбработчика,
			НСтр("ru='Отсутствует информация о неоформленных документах.'"));

	ИначеЕсли Результат.Строки.Количество() = 1 Тогда
		
		УстановитьСостояниеНеТребуется(
			ПараметрыОбработчика,
			НСтр("ru='Нет неоформленных документов.'"));
		
	Иначе
				
		ИтоговаяСтрока = Результат.Строки[Результат.Строки.Количество() - 1];		
		ТекстПояснения = НСтр("ru='Требуется оформление документов по ордерным складам'");
		
		УстановитьСостояниеНеВыполнен(
			ПараметрыОбработчика,
			ТекстПояснения,
			,
			,
			Перечисления.ВариантыВажностиПроблемыСостоянияСистемы.Предупреждение);
		
	КонецЕсли;
	
КонецПроцедуры

// Описание действия "Открыть произвольную форму".
//
// Параметры:
//	ИмяФормы 				 - Строка - имя открываемой формы 
//	ПараметрыВСтруктуреОтбор - Булево - признак того, что параметры открываемой формы надо передать внутри параметра Отбор с типом Структура
//
// Возвращаемое значение:
//	Структура - см. СтруктураОписанияДействия()
//
Функция ОписаниеДействия_ОткрытьФормуОтчета(ИмяФормы, ПараметрыОткрытия) Экспорт
	Описание = СтруктураОписанияДействия();
	
	Описание.ВидДействия = Перечисления.ВидыДействийРасшифровкиОперацийЗакрытияМесяца.ОткрытьФорму;
	Описание.ИмяФормы    = ИмяФормы;
	Описание.НаКлиенте   = Истина;
	
	ПоляПараметровФормы = "Организация, МассивОрганизаций, ПериодРегистрации, Период, НачалоПериода, КонецПериода, ДатаОкончанияПериода";
	
	Описание.Вставить("ПараметрыФормы", Новый Структура(ПоляПараметровФормы));
	Описание.ПараметрыФормы.Вставить(ЗакрытиеМесяцаСервер.ИмяСлужебногоСвойстваОткрываемыхФорм(), Истина);
	
	Для каждого Элемент из ПараметрыОткрытия Цикл
		Описание.ПараметрыФормы.Вставить(Элемент.Ключ, Элемент.Значение);	
	КонецЦикла;
	
	Возврат Описание;
	
КонецФункции

#КонецОбласти

Модуль объекта «КонтрольОформленияДокументовТовародвижений»

#Если Сервер Или ТолстыйКлиентОбычноеПриложение Или ВнешнееСоединение Тогда
	
#Область СлужебныйПрограммныйИнтерфейс

&После("ПриСозданииНаСервере")
Процедура Расш_ПриСозданииНаСервере(ЭтаФорма, Отказ, СтандартнаяОбработка)
	Параметры = ЭтаФорма.Параметры;
	Если Параметры.Свойство("ДатаОкончанияПериода") И ЗначениеЗаполнено(Параметры.ДатаОкончанияПериода) Тогда
		ЭтаФорма.Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Период", Параметры.ДатаОкончанияПериода);				
		ЭтаФорма.Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("ТекущаяДата", Параметры.ДатаОкончанияПериода);
		ЭтаФорма.Отчет.КомпоновщикНастроек.Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("ПериодГраница", Новый Граница(Параметры.ДатаОкончанияПериода, ВидГраницы.Включая));	
		
		Параметры_ = Новый Массив;
		ПользовательскийПараметр = Новый Структура("Имя, Значение", "Период", Параметры.ДатаОкончанияПериода);
		Параметры_.Добавить(ПользовательскийПараметр);
		
		КомпоновкаДанныхКлиентСервер.ДобавитьПараметрыВПользовательскиеНастройки(ЭтаФорма.Отчет.КомпоновщикНастроек, Параметры_); 
	КонецЕсли;
	
КонецПроцедуры

&Перед("ПередЗагрузкойНастроекВКомпоновщик")
Процедура Расш_ПередЗагрузкойНастроекВКомпоновщик(Контекст, КлючСхемы, КлючВарианта, НовыеНастройкиКД, НовыеПользовательскиеНастройкиКД)
	Если ТипЗнч(Контекст) = Тип("Структура") Тогда
		Возврат;
	КонецЕсли;
	
	Параметры = Контекст.Параметры;
	Если Параметры.Свойство("ДатаОкончанияПериода") И ЗначениеЗаполнено(Параметры.ДатаОкончанияПериода) Тогда
		НовыеНастройкиКД.ПараметрыДанных.УстановитьЗначениеПараметра("Период", Параметры.ДатаОкончанияПериода);				
		
		МассивПараметров = Новый Массив;
		ПользовательскийПараметр = Новый Структура("Имя, Значение", "Период", Параметры.ДатаОкончанияПериода);
		МассивПараметров.Добавить(ПользовательскийПараметр);
		
		Для Каждого ЭлементКДобавлению Из МассивПараметров Цикл
			
			// поиск подходящего пользовательского параметра
			ИдентификаторПользовательскойНастройки = "";
			ЭлементыПараметровКомпоновщика = НовыеНастройкиКД.ПараметрыДанных.Элементы;
			Для Каждого ЭлементКомпоновщика Из ЭлементыПараметровКомпоновщика Цикл
				Если ЭлементКомпоновщика.Параметр = Новый ПараметрКомпоновкиДанных(ЭлементКДобавлению.Имя) Тогда
					ИдентификаторПользовательскойНастройки = ЭлементКомпоновщика.ИдентификаторПользовательскойНастройки;
					Прервать;
				КонецЕсли;
			КонецЦикла;
			
			// если пользовательский параметр найден, то редактируем его
			Если ЗначениеЗаполнено(ИдентификаторПользовательскойНастройки) И НовыеПользовательскиеНастройкиКД <> Неопределено Тогда
				Для Каждого ЭлементНастройки Из НовыеПользовательскиеНастройкиКД.Элементы Цикл
					Если ЭлементНастройки.ИдентификаторПользовательскойНастройки = ИдентификаторПользовательскойНастройки Тогда
						ЭлементПараметра = ЭлементНастройки;
						Прервать;
					КонецЕсли;
				КонецЦикла;
				ЭлементПараметра.Значение = ЭлементКДобавлению.Значение;
				ЭлементПараметра.Использование = Истина;
			КонецЕсли;
		КонецЦикла;		
	КонецЕсли;		

КонецПроцедуры

#КонецОбласти

#КонецЕсли

Вот как это выглядит в пользовательском режиме:

Рис. 1 Наша добавленная ручная операция «Контроль оформления документов по ордерным складам».

Если требуется расшифровка – по гиперссылке «Показать» открывается отчет.

Рис 2. Отчет, вызываемый из закрытия месяца.

В нашей конфигурации сделана небольшая доработка, в результате которой склады связаны с организациями. Поэтому отрабатывает отбор по складам организаций. В результате мы видим только нужные склады. Бухгалтеру нет необходимости открывать отчет вручную, указывать отборы – все делается из обработки закрытия месяца, если есть проблема - она увидит это, как и увидит проблемные документы с необходимыми рекомендациями.

Пример №2. Перед формированием финансового результата необходимо обязательно проводить реклассификацию договоров. То есть – нужна операция, которая является существенной для определения финансового результата. Как это реализовать? Легко. Алгоритм действий такой же. Но есть небольшое дополнение:

  1. Необходимо чтобы наша операция зависела от результата выполнения других операций, например, от отражения документов в регламентированном учете.
  2. Выполнялась автоматически, в том числе, если закрытие месяца вызывается регламентным заданием.

Дополним уже добавленную ранее в расширение процедуру. Приводить листинг процедуры реклассификации и ее актуальности я не буду. Здесь важен другой момент: у нас будет использоваться 3 "триггера": проверка ранее выполненной реклассификации и насколько она актуальна - "ДействиеИспользование", выполнение процедуры реклассификации - "ДействиеВыполнить", открытие перечня сформированных регламентных документов - "ДействиеПодробнее".

&После("ЗаполнитьОписаниеЭтаповЗакрытияМесяца")
Процедура Расш_ЗаполнитьОписаниеЭтаповЗакрытияМесяца(ТаблицаЭтапов)

	#Область РеклассификацияЗадолженности
	Индекс = Неопределено;
	// наша операция будет распологаться внутри группы операций, которые могут
	// выполняться как автоматически, так и вручную
	ТекущийРодитель = ИдентификаторГруппыРегламентированныйУчет();
	НоваяСтрока = ДобавитьЭтапВТаблицу(ТаблицаЭтапов, ТекущийРодитель, Перечисления.ОперацииЗакрытияМесяца.РеклассификацияДоговоровКредитаИДепозита);		
	
	// вклиниваем операцию после отражения документов в регл. учете
	Строка = ТаблицаЭтапов.Найти(Перечисления.ОперацииЗакрытияМесяца.ОтражениеДокументовВРегламентированномУчете, "Код");
	Если Не Строка = Неопределено Тогда
		Индекс = ТаблицаЭтапов.Индекс(Строка);
	КонецЕсли;
	
	Если Индекс <> Неопределено Тогда
		ИндексСтроки = ТаблицаЭтапов.Индекс(НоваяСтрока); 		
		ИндексСдвига = Индекс - ИндексСтроки;
		ИндексСдвига = ?(ИндексСдвига > 0, ИндексСдвига - 1, ИндексСдвига + 1);
		
		Если ИндексСдвига <> 0 Тогда
			ТаблицаЭтапов.Сдвинуть(ИндексСтроки, ИндексСдвига);
		КонецЕсли;		
	КонецЕсли;
	
	// ключевая строка!
	// наша операция не выполнится без предыдущих операций, в частности - 
	// отражения документов в регл. учете
	НоваяСтрока.ПредшествующиеЭтапы.Добавить(Перечисления.ОперацииЗакрытияМесяца.ОтражениеДокументовВРегламентированномУчете);
	НоваяСтрока.ВыполняетсяВручную = ложь;
	НоваяСтрока.ТекстВыполнить = НСтр("ru='Выполнить'");
	НоваяСтрока.ДействиеИспользование = ОписаниеДействия_СервернаяПроцедура(
		"ЗакрытиеМесяцаСервер.Использование_ВыполнитьРеклассификациюДоговоровКредитаИДепозита");
	НоваяСтрока.ДействиеВыполнить  = ОписаниеДействия_ВыполнитьРасчет(
		"ЗакрытиеМесяцаСервер.Выполнить_ВыполнитьРеклассификациюДоговоровКредитаИДепозита");
	
	// по действию "Подробнее" - открываем журнал документов "Реклассификация",
	// с отбором по периоду и организации.
	НоваяСтрока.ДействиеПодробнее = ОписаниеДействия_ОткрытьСписокДокументовРеклассификация();
	
	#КонецОбласти //РеклассификацияЗадолженности
		
КонецПроцедуры

 

Как это выглядит:

Рис 3. Добавленная операция «Реклассификации договоров кредита и депозита»

 

Если операция успешно выполнена, то по гиперссылке будет открыт список документов:

Рис 4. Список документов с отбором по организациям и периоду

 

Резюмируя все что было описано в статье:

  1. Добавить свои операции в закрытие месяца – достаточно легко и осуществляется с минимальными изменениями конфигурации.
  1. Мы описываем только необходимые «триггеры»: выполнения, расшифровки. А также алгоритмы выполнения операции. Все остальное берет на себя механизм закрытия месяца, который все это исполняет в фоновом режиме.
  1. Можно добавлять как информационные операции (например, как описанный выше вызов отчета), так и какие-либо сложные механизмы. Так же можно добавить, например, оповещение в виде sms или письма ответственным по результатам выполнения операции, да даже той же задачи будет достаточно. Тут возможности безграничны.

 

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. murzilka88 06.09.18 11:15 Сейчас в теме
А еще у нас в ERP РБП автоматически распределяются!
2. PerlAmutor 124 06.09.18 16:32 Сейчас в теме
А у нас франч добавил так свою операцию при внедрении, в результате операция закрытия месяца увеличилась на +8 часов, пока я не выявил причину спустя несколько месяцев и не исправил.
3. Shmell 351 06.09.18 19:47 Сейчас в теме
(2) Поэтому нужно добавлять операции, которые достаточно быстро выполняются по отношению ко всему закрытию месяца. Иначе есть смысл их выносить за контур закрытия месяца. Если нужно, чтобы это было в закрытии месяца, то код такой операции должен быть оптимальным, не перегруженым лишними действиями. Я так подозреваю - в Вашем случае сыграл злую шутку не оптимальный код или "перегруженная" логика самой операции.
G.Shatrov; Vladimir Litvinenko; zeegin; +3 Ответить
4. rpgshnik 2567 15.09.20 06:25 Сейчас в теме
Спасибо за точку входа и хорошие примеры реализации, очень помогло 👍

От себя добавлю, что ещё помогло мне при решение задачи:

ОперацииЗакрытияМесяца.ИнициализироватьТаблицуОписанияЭтапов() // описание параметров таблицы "ТаблицаЭтапов", а вообще конечно скудное описание у всех параметров :)

Пояснение вызовов:

ДействиеИспользование - Это процедура - проверка статусов при формирование дерева закрытие месяца, допустим можно заложить ошибку используя функцию УстановитьСостояниеВыполненСОшибками() или просто добавить информацию через ДобавитьПоясняющуюИнформациюКЭтапу().

ДействиеВыполнить - Это процедура фонового последовательного выполнения закрытия месяца.
Оставьте свое сообщение

См. также

Ошибки при расчете себестоимости в 1С: УНФ

Закрытие периода v8 УНФ Розничная и сетевая торговля (FMCG) Россия УУ Бесплатно (free)

Данная статья предназначена для помощи тем, у кого некорректно посчиталась себестоимость в 1С: УНФ при выполнении операции закрытия месяца.

12.05.2021    795    user1326339    0    

Исправление корректировки стоимости товаров (по средней) за расчетом себестоимости продукции в УПП 1.3

Закрытие периода Производство готовой продукции (работ, услуг) v8 УПП1 Россия БУ НДС Бесплатно (free)

В учетной политике установлена оценка стоимости МПЗ при выбытии - по средней стоимости. Учет по партиям не ведётся. Используются серии и характеристики номенклатуры. При выполнении корректировки стоимости товаров документом "Расчет себестоимости" не учитываются серии и характеристики товаров. Происходит попытка усреднить стоимость всего пёстрого многообразия различных позиций (SKU) с разными сериями и характеристиками, которые по факту не являются одним и тем же товаром и должны отличаться друг от друга стоимостью. Усугубляет проблему обстоятельство, что на выходе определенных комплектаций может получиться верная, уже имеющаяся в учетной системе карточка номенклатуры, встречающаяся исходными данными других комплектаций. Поэтому результат расчета себестоимости неудовлетворительный, необходимо исправление результата расчета.

20.03.2021    451    ksnik    0    

Схема закрытия месяца в УПП 1.3

Закрытие периода v8 УПП1 Россия БУ Налог на прибыль НДС Бесплатно (free)

Закрытие месяца в типовой конфигурации Управление производственным предприятием 1.3.

18.02.2021    1754    ksnik    5    

Медленно закрывается период по 20, 23, 25, 26 счетам в БП 2.0.42.5(6) Промо

Практика программирования Закрытие периода Закрытие периода v8 БП2.0 Россия БУ Бесплатно (free)

Медленно закрывается период по 20, 23, 25, 26 счетам в БП 2.0.42.5(6)

30.11.2012    13910    Brawler    2    

Ускорение расчета себестоимости УПП 1.3 в несколько раз

Закрытие периода Рефакторинг и качество кода v8 УПП1 БУ УУ Бесплатно (free)

Как определить причину медленного расчёта себестоимости в УПП 1.3, один из вариантов поиска проблем производительности с помощью инструментов 1С и ускорения расчёта средствами встроенного языка

02.02.2021    2882    RPGrigorev    19    

Механизмы расчета резервов по товарам организаций

Закрытие периода Учет ТМЦ v8 КА1 ERP2 УТ11 УУ Бесплатно (free)

Если Вы используете подсистему Интеркампани в конфигурациях УТ 11.4, КА 2.4 или ЕРП 2.4, и перед закрытием месяца обнаружили наличие отрицательных остатков по регистру накопления «ТоварыОрганизаций», это, как правило, говорит о том, что придется потратить значительное количество времени на устранение ошибок. Разумеется, величина проблемы зависит от количества организаций и складов, объема документов, наличия учета товаров в разрезе ГТД и других аспектов. Но в любом случае решить эту проблему быстро, получается далеко не всегда.

28.12.2020    2488    ids79    1    

Обзор новшеств редакции БП 2.0 по сравнению с 1.6 Промо

Закрытие периода Учет и отчетность v8 БП2.0 1С:Франчайзи, автоматизация бизнеса Россия НУ НДС УСН Бесплатно (free)

Чем отличается редакция БП 2.0 от редакции 1.6. На что нужно обратить внимание при переходе на новую редакцию.

13.12.2010    21019    KapasMordorov    30    

Бухгалтерия сельскохозяйственного предприятия. Учет в животноводстве

Закрытие периода Производство готовой продукции (работ, услуг) v8 1cv8.cf Сельское хозяйство и рыболовство Россия БУ Бесплатно (free)

Делюсь опытом работы в конфигурации "1С: Предприятие 8. Бухгалтерия сельскохозяйственного предприятия" от фирмы ООО "Агрософт", сделанной на базе БП 3.0. В статье подробно рассмотрен порядок закрытия 20.01.2 счета (Животноводство). Может быть полезна и для тех, кому интересен принцип расчета себестоимости при закрытии 20 счета безотносительно животноводства, так как в обычной Бухгалтерии 3.0 он похож.

01.12.2020    10224    niko11s    7    

Закрытие 90 и 91 счетов. Формирование финансового результата

Закрытие периода v8 v8::БУ БП3.0 БУ Бесплатно (free)

Закрытие 90 и 91 счетов. Формирование финансового результата. На примере Бухгалтерии 3.0, с объяснением смысла операций.

09.09.2020    28639    niko11s    6    

Нестандартное закрытие месяца в Бухгалтерии 3.0

Закрытие периода v8 v8::БУ БП3.0 Россия БУ Бесплатно (free)

Хотел бы рассказать вам об интересном опыте решения задачи по доработке штатного закрытия месяца (по 20,23,25,26 счету) в Бухгалтерии 3.0 и Корп.

14.05.2020    3282    user1114962    6    

Опыт перехода на БП 3 с БП 2. Амортизация ОС при УСН

Закрытие периода Учет ОС и НМА Бухгалтерский учет Перенос данных из 1C8 в 1C8 v8::БУ БП3.0 Россия БУ УСН Бесплатно (free)

УСН. В начеле 2019 года перешли с БП 2 на БП 3. В начале 2020 года пытались начислить амортизацию в конце года по правилам УСН. Амортизация "не пришла". Разобрались и поправили. 3.0.75.109.

24.03.2020    2451    Gasilin    2    

"Секреты" закрытия месяца в 1С:ERP

Закрытие периода v8 ERP2 Россия БУ НУ Бесплатно (free)

В рамках данной статьи мне хотелось обобщить в одном месте накопленную информацию по закрытию периода в 1С:ERP. Цель – дать консультанту, внедряющему регламентированный учет и расчет себестоимости в 1С:ERP, инструмент, с помощью которого он сможет понять, на основании чего в Закрытии месяца появляются те или иные операции, какие регистры анализирует система, какие действия должны быть выполнены по результатам.

22.01.2020    49998    1СERP    63    

Расчет себестоимости по средней: не так все просто, как кажется на первый взгляд

Закрытие периода Учетная политика Управление торговлей Бухгалтерия v8::БУ v8::ОУ БП2.0 УТ10 БП3.0 УТ11 Россия БУ УУ Бесплатно (free)

Статья предназначена для специалистов по внедрению 1С и бухгалтеров, у которых возникают следующие вопросы: Бухгалтерия 3.0,2.0 закрытие месяца операция Корректировка стоимости номенклатуры Управление торговлей 11.4 и 10.3, разные величины себестоимости при одинаковых списаниях по средней. И что нужно сделать, чтобы эти цифры были равны.

29.12.2019    15802    aurumm    6    

BAS ERP: Рекомендации по ведению учета для успешного закрытия месяца

Производство Закрытие периода v8 ERP2 1С:Франчайзи, автоматизация бизнеса Украина БУ УУ Бесплатно (free)

Данная публикация содержит перечень рекомендаций для устранения основных и часто попадающихся ошибок при ведении учета производства (и не только).

26.09.2019    7592    JohnGalt    10    

Закрытие остатков по регистрам накопления

Практика программирования Закрытие периода Закрытие периода v8 УПП1 УУ Бесплатно (free)

Гибкий способ закрытия остатков по регистрам накопления. ДЛЯ ПРОГРАММИСТОВ, НЕ ДЛЯ БУХГАЛТЕРОВ.

24.10.2018    7054    kosmo0    2    

Как исправить код 26 в книге продаж дополнительными листами (НЕОЧЕВИДНОСТИ КОРРЕКТИРОВКИ НДС)

Бухгалтерский учет Закрытие периода Закрытие периода v8 v8::БУ БП3.0 Россия БУ НДС Бесплатно (free)

Инструкция для Бухгалтерия Предприятия 3.0 по исправлению в разделе продаж декларации НДС кода 26 на 01 через доплист . (в 2.0 схема та же).

17.06.2017    22698    ansonat    0    

Определение финансового результата (учет на 90 - х счетах в 1С).

Бухгалтерский учет Закрытие периода Закрытие периода v8::БУ БП3.0 Россия БУ Бесплатно (free)

Учет на 90 - х счетах в 1С. Особенности учета и закрытие счетов в Бухгалтерии 8. Теория и практический пример.

17.04.2017    79651    niko11s    2    

Налог на прибыль и его расчет в 1С:Бухгалтерии 3.0

Бухгалтерский учет Закрытие периода Закрытие периода v8::БУ БП3.0 Россия НУ Налог на прибыль Бесплатно (free)

Давайте разберёмся, как рассчитывается налог на прибыль в программе 1С:Бухгалтерия.

28.02.2017    47205    human_new    34    

Расчет себестоимости и его Откат в ERP: практика применения

Практика программирования Закрытие периода Учет ТМЦ Закрытие периода Учет ТМЦ v8 ERP2 Россия УУ Бесплатно (free)

В системе erp отключен партионный учет, метод оценки по средней, учет по видам запаса отключен. Казалось бы, что может быть еще проще, но себестоимость упорно не закрывалась процедурой закрытия месяца

08.02.2017    51934    kristina    30    

Закрытие месяца (Управление торговлей 11) - решение проблемы ненулевой себестоимости при отсутствии товара

Закрытие периода Оптовая торговля Оптовая торговля v8::ОУ УТ11 Россия УУ Бесплатно (free)

Часто при запуске процедуры "Закрытие месяца" выскакивает ошибка следующего содержания: "По номенклатуре ... обнаружен некорректный остаток в регистре "Себестоимость товаров"" и обработка прекращается на пункте "Расчет себестоимости". Данная статья посвящена методам борьбы с указанной ошибкой.

12.12.2016    34032    Mortiferus    17    

Расчёт себестоимости в 1С УПП 1.3. Инструкция по подготовке

Управленческий учет (прочее) Бухгалтерский учет Закрытие периода Производство готовой продукции (работ, услуг) Учет ТМЦ Учетная политика Ценообразование, анализ цен Закрытие периода Производство готовой продукции (работ, услуг) Учет ТМЦ Учетная политика Ценообразование, анализ цен v8 КА1 УПП1 Россия БУ НУ УУ Бесплатно (free)

Подготовка к Закрытию месяца и непосредственно Расчёту себестоимости — самый трудный процесс, методических материалов по которому до сих пор недостаточно. Помнить обо всех тонкостях трудно, особенно когда закрытие периода производится не каждый месяц, а раз в квартал.

23.11.2015    83846    Vikki-di    12    

Учет сторонних работ для нужд фирмы

Управленческий учет (прочее) Бухгалтерский учет Закрытие периода Производство готовой продукции (работ, услуг) Учет ТМЦ Ценообразование, анализ цен Закрытие периода Производство готовой продукции (работ, услуг) Учет ТМЦ Ценообразование, анализ цен v8 КА1 УПП1 Россия БУ Бесплатно (free)

Какие-то работы наша фирма сама сделать не может, поэтому мы отдаём материалы и полуфабрикаты другим контрагентам, чтобы те сделали работу за нас и вернули уже готовые изделия. Иначе это ещё называют внешней кооперацией. Наглядная инструкция по учёту сторонних доработок в 1С УПП 1.3.

23.11.2015    16725    Vikki-di    2    

Как в УПП: установка плановой себестоимости по фактической для КА 1.1 (РАУЗ)

Практика программирования Закрытие периода Производство готовой продукции (работ, услуг) Закрытие периода Производство готовой продукции (работ, услуг) v8 КА1 БУ УУ Бесплатно (free)

В статье описано, как перенести обработку из УПП в КА (только для РАУЗ). Конечного файла обработки в статье нет (есть только описание необходимых изменений).

09.10.2015    11532    Cyberhawk    6    

Восстановление последовательности документов обработкой "Закрытие месяца". Бухгалтерия 3.0

Практика программирования Закрытие периода Закрытие периода v8 БП2.0 БУ Бесплатно (free)

Иногда попытка восстановления последовательности документов при закрытии месяца заканчивается "ничем". То есть нет ни ошибок, ни сообщений в журнале регистрации. Но граница последовательности так и не сдвигается (поле "Перепроведение документов за месяц" остается серым). В чем возможная причина и как это устранить правильно? - я расскажу вам чуть ниже.

01.09.2015    16913    director04    1    

Инструменты быстрого закрытия отчетного периода по УУ на примере 1С: Управление холдингом

Бухгалтерский учет Закрытие периода Закрытие периода v8 УХ УУ Бесплатно (free)

Статья делится на две части: • В первой части мы определимся в терминологии того, что будем обсуждать. • Во второй части мы уже рассмотрим концепции и подходы, реализованные в 1С:Управление холдингом, и я расскажу, как мы это поняли и приняли. Данная статья написана по материалам доклада, прочитанного автором на Конференции Инфостарта IE 2014 29-31 октября 2014 года.

19.05.2015    18125    Kaliinka    1    

Порядок выполнения процедуры закрытия периода

Бухгалтерский учет Закрытие периода Закрытие периода v8 УПП1 Россия БУ НУ УУ Бесплатно (free)

Порядок выполнения процедуры закрытия периода в программном продукте Управление производственным предприятием 1.3 в режиме расширенной аналитики учета затрат.

26.03.2015    9839    liberto    5    

Расчет курсовой разницы УТ, УТП

Бухгалтерский учет Закрытие периода Закрытие периода v8 УТ10 Украина УУ Бесплатно (free)

В связи с резкими прыжками курса валют, актуальным становится расчет курсовых разниц в 1с. Текущая статья не касается вычислений фактической себестоимости товара в связи с изменением курса валют, здесь будет описан алгоритм переоценки остатков сумм взаиморасчетов с контрагентами.

12.03.2015    29399    SlavikOnyx    4    

Разгон РАУЗ в 1С УПП 1.3 (платформа 8.2)

Закрытие периода Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8 УПП1 Россия БУ НУ Бесплатно (free)

В статье рассматривается вопрос повышения быстродействия расчета себестоимости в конфигурации 1С УПП 1.3 при включенном режиме РАУЗ и наличии большого количества материальных затрат. Глубокого погружения в теорию тут ждать не стоит, для этого есть другие хорошо написанные книги и статьи. Тут будет рассмотрен метод "по быстрому".

07.10.2014    29849    DNSokol    56    

Автоматическое перепроведение документов в Бухгалтерии 3.0

Закрытие периода Закрытие периода Закрытие периода v8 БП2.0 БУ Бесплатно (free)

Регламентное задание позволяет запускать перепроведение документов по расписанию. Разрабатывалось в Бухгалтерии КОРП 3.0.32.7

06.09.2014    23183    kholkin    7    

Инструкция по закрытию месяца в 1С: Комплексная автоматизация

Бухгалтерский учет Закрытие периода Закрытие периода v8 КА1 УПП1 Россия БУ НУ УУ Бесплатно (free)

Как показала практика, инструкции по закрытию месяца есть только для БП, а для КА и УПП нет. Я решил исправить эту ситуацию.

21.07.2014    71650    Samandar    24    

Несколько слов про закрытие 20.01 в случае производства (43 счет)

Анализ учета Бухгалтерский учет Закрытие периода Закрытие периода v8 БП2.0 Россия БУ Бесплатно (free)

Анамнез: в БП 2.0 было такое...Было простое производство (отчет производства за смену) и реализация, как услуг, так и готовой продукции. И было всё прекрасно, всё закрывалось, но однажды перестало и никто не знал почему... Случай показателен двойной ошибкой пользователя, причем, первая ошибка компенсировала вторую...

15.07.2014    16822    1cspbru    6    

Советы по Закрытию месяца в Бухгалтерии предприятия 2.0

Бухгалтерский учет Закрытие периода Закрытие периода v8 БП2.0 БУ Бесплатно (free)

Добрый день, уважаемые читатели, в этой статье мы c Вами уделим особое внимание подготовке к закрытию месяца, непосредственно самой процедуре закрытия, рассмотрим наиболее часто встречаемые ошибки и пути их решения, а также, познакомимся с разнообразными сервисами и отчетами, предоставляемыми программой «1С: Бухгалтерия предприятия 8», редакции 2.0.

12.05.2014    78901    OV_GCompany    10    

Ошибка: "Организация не уплачивает ЕНВД, но отражены расходы по видам деятельности, облагаемым ЕНВД" при закрытии месяца в БП 3.0.

Пользователю системы Закрытие периода Закрытие периода v8::БУ БП3.0 БУ Бесплатно (free)

Статья объясняет как исправить ошибку "Организация не уплачивает ЕНВД, но отражены расходы по видам деятельности, облагаемым ЕНВД", возникающую при закрытии месяца в БП 3.0.

27.04.2014    18144    elian    11    

Встречные потоки затрат в РАУЗ -"ну не виноватая я ..."

Управленческий учет (прочее) Бухгалтерский учет Закрытие периода Закрытие периода v8 УПП1 БУ УУ Бесплатно (free)

В статье рассмотрен пример закрытия затрат для случая, когда на предприятии присутствуют встречные потоки вторичных затрат. Получены очень большие, можно даже сказать, неадекватно большие стоимости потоков встречных вторичных затрат. Сделан вывод о том, что обвинять РАУЗ в том, что именно она является причиной возникновения таких ситуаций - некорректно.

17.04.2014    15440    Polav    19    

Расчеты по налогу на прибыль в УПП: порядок, особенности и типовые ошибки

Бухгалтерский учет Закрытие периода Закрытие периода v8 УПП1 БУ Налог на прибыль Бесплатно (free)

Классический вопрос бухгалтеров: "Почему начислился отрицательный налог на прибыль?" или "Откуда взялся налог, если у нас убыток?" В статье подробно разбирается типовой алгоритм расчетов по налогу на прибыль (по ПБУ 18/02), часто возникающие проблемы и пути их решения.

25.03.2014    97071    vvr908    23    

Закрытие месяца. Регламентные действия

Пользователю системы Закрытие периода Бухгалтерский учет Закрытие периода v8 КА1 БП2.0 УПП1 Россия БУ НУ Бесплатно (free)

Закрытие месяца. Регламентные действия и операции в зависимости от режима налогообложения.  Сопоставление конфигураций Бухгалтерия 2.0, Управление производственным предприятием 8, Комплексная автоматизация 8.

03.03.2014    52430    campa_vol    10    

Ускорение расчета себестоимости в УПП (партионный учет)

Производительность и оптимизация (HighLoad) Закрытие периода Закрытие периода v8 УПП1 Россия БУ УУ Бесплатно (free)

Не секрет, что в момент закрытия периода в УПП приходится неоднократно перепроводить регламентный документ «Расчет себестоимости» для устранения ошибок в учете и получения корректной себестоимости выпуска. И здесь ключевую роль играет время, за которое выполняется полный расчет себестоимости.

31.01.2014    15801    vitrac    7    

Раздельный учет "прочих доходов" при совмещении ОСНО и ЕНВД у ИП

Пользователю системы Закрытие периода Управленческий учет (прочее) Закрытие периода v8 БП2.0 Россия БУ ЕНВД Бесплатно (free)

Вкратце рассматривается механизм распределения прочих расходов при совмещении ОСНО и ЕНВД у индивидуального предпринимателя.

21.11.2013    23036    Birby    4