Печать штрихкода из неуправляемых форм по новой технологии на платформе 8.3.16 (пример получения картинки через внешнюю компоненту)

10.02.20

Разработка - Разработка внешних компонент

Рабочий пример получения картинки ШК через внешнюю компоненту. После перехода на платформу 8.3.16 в старых конфигурациях перестали печататься ШК на принтере этикеток, пришлось переделывать процедуру печати, может, кому пригодится. Проверялось на УТ 10.3 и КА 1.1.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки для того, чтобы самостоятельно ее доработать для вашей базы данных. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в вашей базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке Купить один файл
Печать штрихкода из неуправляемых форм по новой технологии на платформе 8.3.16:
.epf 2,92Mb
29
29
1 SM
Скачать Купить за 1 850 руб.

функционал взял из УНФ 1.6, оттуда же - компоненту и эталон макета, реализована печать ШК только EAN13, другие типы закомментированы, если кому надо, то придется добавить из унф еще несколько процедур по распознаванию типа ШК, ну или прописать свой тип непосредственно в строке ВнешняяКомпонента.ТипКода = 1;

Привожу код обработки печати, в обработке 3 макета

Макет - сам макет с картинкой, куда выводится шк

Эталон и КомпонентаПечатиШтрихкодов - макеты взятые из УНФ 1.6

Процедура КнопкаВыполнитьНажатие(Кнопка)
    
    Таб                     = Новый ТабличныйДокумент;
    Таб.ИмяПараметровПечати =     "ПАРАМЕТРЫ_ПЕЧАТИ_Этикетка1";
    макет = получитьМакет("Макет");
    
    ЭтикеткаОбласть         = Макет.ПолучитьОбласть(1,1,1,1);            
    
    Эталон = ПолучитьМакет("Эталон");
    
    КоличествоМиллиметровВПикселе = Эталон.Рисунки.Квадрат100Пикселей.Высота / 100;
    Рисунок = ЭтикеткаОбласть.Рисунки.Штрихкод;
    
    параметрыШК = новый структура;
    параметрыШК.Вставить("ОтображатьТекст",истина);
    параметрыШК.Вставить("РазмерШрифта",16);    
    параметрыШК.Вставить("СохранятьПропорции",истина);
    параметрыШК.Вставить("Штрихкод",штрихкод);
    параметрыШК.Вставить("Ширина",Окр(Рисунок.Ширина / КоличествоМиллиметровВПикселе));
    параметрыШК.Вставить("Высота",Окр(Рисунок.Высота / КоличествоМиллиметровВПикселе));    
    ЭтикеткаОбласть.Рисунки.Штрихкод.Картинка = ПолучитьКартинкуШтрихкода(параметрыШК);    
    Таб.Вывести(ЭтикеткаОбласть);
    Таб.Показать();
            
КонецПроцедуры

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)
    штрихкод = "2900000021778";
КонецПроцедуры

// Функция выполняет формирование изображения штрихкода.
// Параметры: 
//   ПараметрыШтрихкода 
// Возвращаемое значение: 
//   Картинка - Картинка со сформированным штрихкодом или НЕОПРЕДЕЛЕНО.
Функция ПолучитьКартинкуШтрихкода(ПараметрыШтрихкода) Экспорт
    
    ВнешняяКомпонента = ПодключитьВнешнююКомпонентуПечатиШтрихкода();
    
    Если ВнешняяКомпонента = Неопределено Тогда
        ВызватьИсключение НСтр("ru = 'Ошибка подключения внешней компоненты печати штрихкода.'");
    КонецЕсли;
    
    // Зададим размер формируемой картинки.
    ВнешняяКомпонента.Ширина = Окр(ПараметрыШтрихкода.Ширина);
    ВнешняяКомпонента.Высота = Окр(ПараметрыШтрихкода.Высота);
    
    ВнешняяКомпонента.АвтоТип = Ложь;
    
    //Если ПараметрыШтрихкода.ТипКода = 99 Тогда
    //    ТипШтрихкодаВрем = ОпределитьТипШтрихкода(ПараметрыШтрихкода.Штрихкод);
    //    Если ТипШтрихкодаВрем = "EAN8" Тогда
    //        ВнешняяКомпонента.ТипКода = 0;
    //    ИначеЕсли ТипШтрихкодаВрем = "EAN13" Тогда
            ВнешняяКомпонента.ТипКода = 1;
    //        // Если код содержит контрольный символ, обязательно указываем.
    //        ВнешняяКомпонента.СодержитКС = СтрДлина(ПараметрыШтрихкода.Штрихкод) = 13;
    //    ИначеЕсли ТипШтрихкодаВрем = "EAN128" Тогда
    //        ВнешняяКомпонента.ТипКода = 2;
    //    ИначеЕсли ТипШтрихкодаВрем = "CODE39" Тогда
    //        ВнешняяКомпонента.ТипКода = 3;
    //    ИначеЕсли ТипШтрихкодаВрем = "CODE128" Тогда
    //        ВнешняяКомпонента.ТипКода = 4;
    //    ИначеЕсли ТипШтрихкодаВрем = "ITF14" Тогда
    //        ВнешняяКомпонента.ТипКода = 11;
    //    ИначеЕсли ТипШтрихкодаВрем = "QR" Тогда
    //        ВнешняяКомпонента.ТипКода = 16;
    //    ИначеЕсли ТипШтрихкодаВрем = "EAN13Addon2" Тогда
    //        ВнешняяКомпонента.ТипКода = 14;
    //    ИначеЕсли ТипШтрихкодаВрем = "EAN13Addon5" Тогда
    //        ВнешняяКомпонента.ТипКода = 15;
    //    Иначе
    //        ВнешняяКомпонента.АвтоТип = Истина;
    //    КонецЕсли;
    //Иначе
    //    ВнешняяКомпонента.АвтоТип = Ложь;
    //    ВнешняяКомпонента.ТипКода = ПараметрыШтрихкода.ТипКода;
    //КонецЕсли;
    
    //Если ПараметрыШтрихкода.Свойство("ПрозрачныйФон") Тогда
    //    ВнешняяКомпонента.ПрозрачныйФон = ПараметрыШтрихкода.ПрозрачныйФон;
    //КонецЕсли;
    //
    //Если ПараметрыШтрихкода.Свойство("GS1DatabarКоличествоСтрок") Тогда
    //    ВнешняяКомпонента.GS1DatabarКоличествоСтрок = ПараметрыШтрихкода.GS1DatabarКоличествоСтрок;
    //КонецЕсли;
    
    //ВнешняяКомпонента.ОтображатьТекст = ПараметрыШтрихкода.ОтображатьТекст;
    ВнешняяКомпонента.ОтображатьТекст = ПараметрыШтрихкода.ОтображатьТекст;
    
    // Формируем картинку штрихкода.
    ВнешняяКомпонента.ЗначениеКода = ПараметрыШтрихкода.Штрихкод;
    // Угол поворота штрихкода.
    //ВнешняяКомпонента.УголПоворота = ?(ПараметрыШтрихкода.Свойство("УголПоворота"), ПараметрыШтрихкода.УголПоворота, 0);
    // Уровень коррекции QR кода (L=0, M=1, Q=2, H=3).
    //ВнешняяКомпонента.УровеньКоррекцииQR = ?(ПараметрыШтрихкода.Свойство("УровеньКоррекцииQR"), ПараметрыШтрихкода.УровеньКоррекцииQR, 1);
    
    // Для обеспечения совместимости с предыдущими версиями БПО.
    Если Не ПараметрыШтрихкода.Свойство("Масштабировать")
        Или (ПараметрыШтрихкода.Свойство("Масштабировать") И ПараметрыШтрихкода.Масштабировать) Тогда
        
        Если Не ПараметрыШтрихкода.Свойство("СохранятьПропорции")
                Или (ПараметрыШтрихкода.Свойство("СохранятьПропорции") И Не ПараметрыШтрихкода.СохранятьПропорции) Тогда
            
            // Если установленная нами ширина меньше минимально допустимой для этого штрихкода.
            Если ВнешняяКомпонента.Ширина < ВнешняяКомпонента.МинимальнаяШиринаКода Тогда
                ВнешняяКомпонента.Ширина = ВнешняяКомпонента.МинимальнаяШиринаКода;
            КонецЕсли;
            
            // Если установленная нами высота меньше минимально допустимой для этого штрихкода.
            Если ВнешняяКомпонента.Высота < ВнешняяКомпонента.МинимальнаяВысотаКода Тогда
                ВнешняяКомпонента.Высота = ВнешняяКомпонента.МинимальнаяВысотаКода;
            КонецЕсли;
            
        ИначеЕсли ПараметрыШтрихкода.Свойство("СохранятьПропорции") И ПараметрыШтрихкода.СохранятьПропорции Тогда
            
            Пока ВнешняяКомпонента.Ширина < ВнешняяКомпонента.МинимальнаяШиринаКода 
                Или ВнешняяКомпонента.Высота < ВнешняяКомпонента.МинимальнаяВысотаКода Цикл
                
                // Если установленная нами ширина меньше минимально допустимой для этого штрихкода.
                Если ВнешняяКомпонента.Ширина < ВнешняяКомпонента.МинимальнаяШиринаКода Тогда
                    ВнешняяКомпонента.Ширина = ВнешняяКомпонента.МинимальнаяШиринаКода;
                    ВнешняяКомпонента.Высота = (ВнешняяКомпонента.МинимальнаяШиринаКода / Окр(ПараметрыШтрихкода.Ширина)) * Окр(ПараметрыШтрихкода.Высота);
                КонецЕсли;
                
                // Если установленная нами высота меньше минимально допустимой для этого штрихкода.
                Если ВнешняяКомпонента.Высота < ВнешняяКомпонента.МинимальнаяВысотаКода Тогда
                    ВнешняяКомпонента.Высота = ВнешняяКомпонента.МинимальнаяВысотаКода;
                    ВнешняяКомпонента.Ширина = (ВнешняяКомпонента.МинимальнаяВысотаКода / Окр(ПараметрыШтрихкода.Высота)) * Окр(ПараметрыШтрихкода.Ширина);
                КонецЕсли;
                
            КонецЦикла;
            
        КонецЕсли;
    КонецЕсли;
    
    // ВертикальноеВыравниваниеКода: 1 - по верхнему краю, 2 - по центру, 3 - по нижнему краю.
    
    ВнешняяКомпонента.ВертикальноеВыравниваниеКода = 1;
    //Если ПараметрыШтрихкода.Свойство("ВертикальноеВыравнивание") И (ПараметрыШтрихкода.ВертикальноеВыравнивание > 0) Тогда
    //    ВнешняяКомпонента.ВертикальноеВыравниваниеКода = ПараметрыШтрихкода.ВертикальноеВыравнивание;
    //КонецЕсли;

    Если ПараметрыШтрихкода.Свойство("РазмерШрифта") И (ПараметрыШтрихкода.РазмерШрифта > 0) 
        И (ПараметрыШтрихкода.ОтображатьТекст) И (ВнешняяКомпонента.РазмерШрифта <> ПараметрыШтрихкода.РазмерШрифта) Тогда
        ВнешняяКомпонента.РазмерШрифта = ПараметрыШтрихкода.РазмерШрифта;
    КонецЕсли;
    ВнешняяКомпонента.РазмерШрифта = 16;
    
    Если ПараметрыШтрихкода.Свойство("РазмерШрифта") И ПараметрыШтрихкода.РазмерШрифта > 0
        И ПараметрыШтрихкода.Свойство("МонохромныйШрифт") Тогда
        
        Если ПараметрыШтрихкода.МонохромныйШрифт Тогда
            ВнешняяКомпонента.МаксимальныйРазмерШрифтаДляПринтеровНизкогоРазрешения = ПараметрыШтрихкода.РазмерШрифта + 1;
        Иначе
            ВнешняяКомпонента.МаксимальныйРазмерШрифтаДляПринтеровНизкогоРазрешения = -1;
        КонецЕсли;
        
    КонецЕсли;
    
    // Сформируем картинку
    ДвоичныеДанныеКартинки = ВнешняяКомпонента.ПолучитьШтрихкод();
    
    // Если картинка сформировалась.
    Если ДвоичныеДанныеКартинки <> Неопределено Тогда
        // Формируем из двоичных данных.
        Возврат Новый Картинка(ДвоичныеДанныеКартинки);
    КонецЕсли;
    
    Возврат Неопределено;

КонецФункции

Функция ПодключитьВнешнююКомпонентуПечатиШтрихкода() Экспорт
    
    
    макет  = ПолучитьМакет ("КомпонентаПечатиШтрихкодов");
    адрес = ПоместитьВоВременноеХранилище( макет );
    ПодключениеВыполнено = ПодключитьВнешнююКомпоненту(адрес, "КартинкаШтрихкода", ТипВнешнейКомпоненты.Native);
    
    // Создадим объект внешней компоненты.
    Если ПодключениеВыполнено Тогда
        ВнешняяКомпонента = Новый("AddIn.КартинкаШтрихкода.Barcode");
    Иначе
        Возврат Неопределено;
    КонецЕсли;
    
    // Если нет возможности рисовать.
    Если НЕ ВнешняяКомпонента.ГрафикаУстановлена Тогда
        // То картинку сформировать не сможем.
        Возврат Неопределено;
    Иначе
        // Установим основные параметры компоненты.
        // Если в системе установлен шрифт Tahoma.
        Если ВнешняяКомпонента.НайтиШрифт("Tahoma") Тогда
            // Выбираем его как шрифт для формирования картинки.
            ВнешняяКомпонента.Шрифт = "Tahoma";
        Иначе
            // Шрифт Tahoma в системе отсутствует.
            // Обойдем все доступные компоненте шрифты.
            Для Сч = 0 По ВнешняяКомпонента.КоличествоШрифтов -1 Цикл
                // Получим очередной шрифт, доступный компоненте.
                ТекущийШрифт = ВнешняяКомпонента.ШрифтПоИндексу(Сч);
                // Если шрифт доступен
                Если ТекущийШрифт <> Неопределено Тогда
                    // Они и будет шрифтом для формирования штрихкода.
                    ВнешняяКомпонента.Шрифт = ТекущийШрифт;
                    Прервать;
                КонецЕсли;
            КонецЦикла;
        КонецЕсли;
        // Установим размер шрифта
        ВнешняяКомпонента.РазмерШрифта = 12;
        
        Возврат ВнешняяКомпонента;
    КонецЕсли;
    
КонецФункции

 

печать штрихкод внешняя компонента неуправляемые формы

См. также

Этикетки, ценники Программист Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Россия Управленческий учет Платные (руб)

Решение позволяет в шаблон этикетки с типом "Этикетка (обувь, одежда, табак...)" добавлять штрих-коды другого типа, например, GTIN в Code128.

4000 руб.

09.06.2021    15512    8    6    

12

Этикетки, ценники Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Беларусь Украина Россия Управленческий учет Платные (руб)

Простая в использовании обработка для формирования и печати ценников и этикеток со штрих-кодом, с дополнительной ценой, для 1С8.х любой конфигурации. Большое разнообразие шаблонов печатных форм. Управляемая форма (Такси) + Обычный режим.

3588 руб.

11.11.2020    48523    56    44    

67

Разработка внешних компонент Программист Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Внешняя компонента позволяет печатать PDF файлы непосредственно из 1С, не используя при этом сторонних программ. Прекрасно работает на сервере, тонком клиенте и веб-клиенте. Основана на проекте PDFium из состава проекта Chromium/Chrome

1500 руб.

17.09.2018    35646    110    127    

113

Разработка внешних компонент Программист Платформа 1С v8.3 Конфигурации 1cv8 1С:Управление нашей фирмой 1.6 1С:Бухгалтерия 3.0 Платные (руб)

Внешняя компонента позволяет работать c TWAIN-совместимым оборудованием (сканерами, камерами) . Полностью совместима со стандартной TWAIN-компонентой из БСП и может применяться как ее замена без изменения вызовов, при этом может работать с 64-разрядной платформой, а так же имеет расширенную функциональность, например, сохранение результата непосредственно в PDF без использования сторонних утилит. Прекрасно работает на сервере, тонком клиенте и веб-клиенте (проверена работа в браузерах Google Chrome, Mozilla Firefox и Microsoft Internet Explorer).

3000 руб.

12.05.2020    26888    133    98    

85

Разработка внешних компонент Программист Платформа 1С v8.3 Конфигурации 1cv8 Платные (руб)

Позволяет автоматизировать работу с картинками. С помощью компоненты можно измерять размер изображений, поворачивать их, наносить водяные знаки, конвертировать из одного формата в другой. Будет очень полезна для интернет-магазинов и всех, кому постоянно требуется работать с различными графическими форматами. Выполнена по технологии NativeAPI. Работает с форматами: jpg (jpeg), png, bmp, gif, tif

3600 руб.

02.09.2010    76435    71    255    

189

Разработка внешних компонент Телефония, SIP Программист Платформа 1С v8.3 Конфигурации 1cv8 Россия Платные (руб)

Внешняя компонента выполнена по технологии Native API для 1С 8.х, обеспечивает доступ к программным АТС Asterisk (FreePBX, Elastix) через AMI интерфейс. Через него можно управлять многими функциями Asterisk (определение номеров, перевод звонков, набор телефона и т. д.)

2400 руб.

04.05.2018    45756    117    66    

62

Разработка внешних компонент Механизмы платформы 1С Программист Стажер Платформа 1С v8.3 Бесплатно (free)

Некоторые практические аспекты создания внешних компонент на языке С++ для платформы 1С 8.3++.

26.01.2024    5490    starik-2005    32    

40
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. dandykry 10 10.02.20 11:06 Сейчас в теме
Просто код типовых конфигураций? Ничего своего?
2. karamazoff 101 10.02.20 11:07 Сейчас в теме
3. unknown181538 157 16.03.20 00:16 Сейчас в теме
4. SONICUS 21.05.20 14:50 Сейчас в теме
Не знаю как тут, а у меня качество отстой полный.
5. karamazoff 101 21.05.20 15:40 Сейчас в теме
(4)а вы использовали приведенные выше процедуры и макеты из УНФ, или скачали обработку?
6. SONICUS 21.05.20 17:57 Сейчас в теме
использовал код. Кстати, в нем есть 2 места где в непосредственно присваивается размер шрифта и нет ни какого смысла его в параметрах передавать. Саму компоненту я тоже выдрал с унф и даже пробовал с ут11. Сканеры такое отказываются считывать и на вид мыло сплошное. Погуглил в интернете и понял, что я не одинок в этом. Возможно большие штрих коды он более менее печатает, а вот меньше ужас один. Прикреплю скрин, где показано как было в 8,2 и как стало на 16 платформе.
Прикрепленные файлы:
7. karamazoff 101 22.05.20 09:43 Сейчас в теме
(6)то что он менее четкий, чем был раньше, это да (раньше то это просто шрифт был), но у меня 2*4 см читается сканером хорошо. Да и у вас на правой картинке не так все плохо,мой телефон его распознал с такой-же скоростью как и левый.
До того как догадался использовать макет "Эталон" и код установки размеров по нему, тоже были пляски с бубнами с подгоном размеров, шрифтов и т.п.
Это ж типовой функционал, если бы он плохо работал юзеры давно бы уже взвыли...
8. SONICUS 22.05.20 13:28 Сейчас в теме
Они и воют. В унф всего 2 места, где можно печатать штрихкод и то ими ни кто не пользуется. Этот шрихкод читается, т.к он не выведен на печать. Я если попробовать например в пдф на виртуальный принтер распечатать, то он не читаемый уже. У нас многие клиенты например могут с пдф в телефоне прийти и вот у таких он не прочитается. прикреплю скрин из пдф. попробуйте прочтите сканером.
Прикрепленные файлы:
9. karamazoff 101 23.05.20 11:50 Сейчас в теме
(8)этот, да, не читается, но у меня 3 конторы на унф где на складе ведут учет по ШК, печатают клеют, сканируют, проблем нигде нет...
10. SONICUS 25.05.20 09:43 Сейчас в теме
Тогда я не понимаю что не так у меня. почему такое качество фиговое при печати.
11. user1274052 04.11.20 19:12 Сейчас в теме
У меня УНФ на mac при печати этикеток со штрихкодами выдает след.ошибку "ошибка подключения внешней компоненты печати штрихкода "
Подскажите есть ли решение данной проблемы?
12. karamazoff 101 04.11.20 20:35 Сейчас в теме
(11)про mac не подскажу, если даже типовая унф не выводит штрих, то это к разработчикам
13. Светлый ум 406 02.07.21 07:58 Сейчас в теме
+1 Пригодилось на последнем релизу УНФ.
Причины отвалившейся печати баркода:

- Использование 64 битной платформы (под 32 все работает)
- Патченная платформа (там вообще не угадаешь из-за чего)
Оставьте свое сообщение