Печать прайс-листа с картинками для 1С Предприятие 7.7 Торговля и Склад 9.2 - пример реализации

29.06.14

Задачи пользователя - Прайсы

Задача: требуется вывести в прайс фотографии товаров. Фотографии не хранятся в БД, ссылки на файлы генерируются в момент формирования прайса.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
ПрайсСКартинками.ert
.ert 205,00Kb
53
53
1 SM
Скачать Купить за 1 850 руб.

При создании статьи за основу взят материал aleksdbs из темы http://forum.infostart.ru/forum11/topic110387/.

Берем стандартную обработку "Печать прайс-листа".

Добавляем в модуль формы следующую процедуру:

Процедура ВывестиРисунок(ОбъектКартинка, Путь)
	Картинка = СоздатьОбъект("Картинка");
    Картинка.Загрузить(Путь);
	
	ОбъектКартинка.РежимРисования(3);
    ОбъектКартинка.УстановитьКартинку(Картинка);
КонецПроцедуры

В макет прайса добавляем 2 колонки "Фото" и "БезФото". В колонку "Фото" вставляем Объект "Картинка" ("Таблица" -> "Вставить рисунок" - > "Картинка"), нажимаем "Отмена" в диалоговом окне загрузки картинки. В свойствах объекта картинки в поле "Текст" пишем

ВывестиРисунок(ИсхТабл.ТекущийОбъект, Путь)

Должно получиться примерно следующее:

Макет

В процедуру Сформировать() после вывода цен добавляем

//Путь к картинке формируется на основе кода номенклатуры
	//возможны варианты: наименования картинок формируются на основе
	//артикулов или при необходимости, добавляем реквизит в справочник
	//Номенклатура и храним путь к картинке в нем

	Путь = "D:\1SBase\ПрайсСКартинками\"+ТекЭлем.Код+".jpg";
			
	Если ФС.СуществуетФайл(Путь)=0 Тогда
		Путь = "";
		ИсхТабл.ПрисоединитьСекцию("Номенклатура|БезФото");
	Иначе
		ИсхТабл.ПрисоединитьСекцию("Номенклатура|Фото");
	КонецЕсли;

Готово!

Прайс-лист с картинками

См. также

Прайсы Бухгалтер Пользователь Платформа 1С v7.7 1С:Производство+Услуги+Бухгалтерия Украина Бухгалтерский учет Управленческий учет Абонемент ($m)

Прайс-лист для конфигурации "Производство+Услуги+Бухгалтерия" 7.7 для Украины . Позволяет выводить  прайс-листы с выбранными типами цен (в том числе, в Excel) с комментариями к номенклатуре (если они сформированы), а также устанавливать новые цены на выбранную дату и комментарии. Это доработанная версия https://infostart.ru/public/117389/ этого под украинскую конфигурацию. Тестировалось на платформе 7.70.027

1 стартмани

14.05.2020    4635    0    byshchenko    0    

3

Прайсы Ценообразование, анализ цен Бухгалтер Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет НДС Абонемент ($m)

Автоматическое обновление цен номенклатуры (переоценка) с 01.01.2019 для цен, включающих НДС. Позволяет выбрать тип цен для изменения.

1 стартмани

09.01.2019    11096    0    Sergey1CSpb    0    

0

Прайсы Оптовая торговля Ценообразование, анализ цен Бухгалтер Пользователь Оперативный учет 7.7 1С:Торговля и склад 7.7 Управленческий учет НДС Абонемент ($m)

Рассчитывает и устанавливает цены по формуле: НоваяЦена=Цена/1.18*1.2. Имеется фильтр по группе и фильтр по типу цен (без него не работает).

1 стартмани

09.01.2019    10012    2    zoeh    0    

1

Прайсы Логистика, склад и ТМЦ Ценообразование, анализ цен Программист Бухгалтер Пользователь Оперативный учет 7.7 1С:Торговля и склад 7.7 Россия Управленческий учет Абонемент ($m)

Модификация типового отчета является фактически прайс-листом при формировании по цене продажи на текущие сутки. Может использоваться для грубого анализа себестоимости продукции и как отчет по стоимостной оценке склада. В типовой отчет добавлена колонка "цена" на конечную дату отчета с возможностью указания типа цены и валюты (при управленческом "многовалютном" учете в ТиС 9.2). Проверялась на отраслевой конфигурации 1С 7.7 "Агент плюс" на базе ТиС 9.2 Также показана методика разработки для начинающих программистов, кто столкнулся с устаревшей Торговля+склад 9.2 (или отраслевых аналогов типа Агент-Плюс...).

1 стартмани

05.11.2015    28431    27    jobkostya1c_ERP    3    

2
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. user629924_info 29.11.16 00:14 Сейчас в теме
//Путь к картинке формируется на основе кода номенклатуры
//возможны варианты: наименования картинок формируются на основе
//артикулов или при необходимости, добавляем реквизит в справочник
//Номенклатура и храним путь к картинке в нем


чет у меня в этой фразе не сходится мысли
9. Chaotic 40 30.01.17 00:04 Сейчас в теме
(1) путь к картинке формируется на основе кода номенклатуры

ниже есть пример
"D:\1SBase\ПрайсСКартинками\"+ТекЭлем.Код+".jpg";
то есть, например:
D:\1SBase\ПрайсСКартинками\00011123.jpg

Возможны варианты - наименования (имена файлов) картинок могут формироваться на основе артикула, то есть, например:
D:\1SBase\ПрайсСКартинками\112S-35.jpg

или можно добавить реквизит в справочник Номенклатура, обозвать его ПутьККартинке и писать туда путь к файлу.
2. корум 288 29.11.16 09:28 Сейчас в теме
(0)
Фотографии не хранятся в БД

Сколько работал с 7.7, ни разу не видел, чтобы фотографии хоть кто-то хранил в БД, которая не приспособлена для этого от слова совсем.
4. MadDAD 154 05.12.16 08:44 Сейчас в теме
(2) Ну если база на скуле, то ничего не мешает хранить картинки в ней, для Dbf тоже вариантов есть. Конечно без внешних объектов не обойтись но дело то не в базе.
6. Иваныч 23 29.12.16 16:43 Сейчас в теме
(2)
А у меня в каталоге базы есть папка PIC, в ней все картинки, привязка по коду. Если неправильно понял ваш ответ, поправьте.
7. корум 288 30.12.16 09:11 Сейчас в теме
(6)
в каталоге базы есть папка PIC, в ней все картинки

так неспортивно. Это рядом, но не в базе :)
"внутри базы" = как в 1с8, прямо внутри.
3. user629924_info 02.12.16 22:28 Сейчас в теме
Вот немного допилил форму,
а вот по артикулу цеплять, так не получилось((
(пока что учусь)
Прикрепленные файлы:
Price.ert
10. dimka7let 13.11.18 18:00 Сейчас в теме
(3) Я понимаю, что прошло 2 года почти, но в итоге получилось привязать к артикулу? Если до, то как? У меня тоже только по коду цепляет...
user629924_info; +1 Ответить
11. user629924_info 13.11.18 19:18 Сейчас в теме
14. dimka7let 14.11.18 08:26 Сейчас в теме
(11) буду рад если получится подсказать как подвязаться к артикулу
15. user629924_info 14.11.18 12:13 Сейчас в теме
(14)
Путь = КаталогИБ() + "IMAGE.DIR\" + СокрЛП(ТекЭлем.Артикул)+".jpg";

Если ФС.СуществуетФайл(Путь)=0 Тогда
Путь = "";
ИсхТабл.ПрисоединитьСекцию("Номенклатура|БезФото");
Иначе
ИсхТабл.ПрисоединитьСекцию("Номенклатура|Фото");
КонецЕсли;
и вот еще кусочек кода:
Наименование = ТекЭлем.ПолнНаименование + ?(Константа.ПоказыватьАртикул = 1, " " + СокрЛП(ТекЭлем.Артикул), "");
//Наименование = ТекЭлем.ПолнНаименование;
Артикул = ТекЭлем.Артикул;
ИсхТабл.ВывестиСекцию("Номенклатура|Название");
Прикрепленные файлы:
16. user629924_info 14.11.18 12:17 Сейчас в теме
(15)
картинки у меня лежат в папке c:\Program Files (x86)\1Cv77\DB\IMAGE.DIR\
17. dimka7let 14.11.18 15:08 Сейчас в теме
(15)
СокрЛП(ТекЭлем.Артикул)

Большое спасибо, заработало!
user629924_info; +1 Ответить
12. user629924_info 13.11.18 19:19 Сейчас в теме
(10) я еще сайт помоему научил печатать прайсы с картинками
18. user1237597 12.06.19 19:55 Сейчас в теме
Ошибка
Процедура ВывестиРисунок(ОбъектКартинка, Путь)
...
    
    ОбъектКартинка.РежимРисования(3); - Тут ошибка
    Картинка.РежимРисования(3); - Так надо, иначе картинка будет искажаться
..

КонецПроцедуры
5. CheBurator 3126 05.12.16 17:15 Сейчас в теме
прайс с картинками сожоет при формировании оперативу, а при сохранении в эксель будет весить сотни мегабайт
13. user629924_info 13.11.18 20:24 Сейчас в теме
(5) это да, шибко много позиций не стоит формировать, при сохранении файла в более новом формате, ексель сжимает нормально файлик прайса, если сохранять в 95 формате, то пол гига запросто может весить прайс, хоть картинки у меня все да 50 000кб
8. Иваныч 23 30.12.16 14:52 Сейчас в теме
понятно, но пока на 8 переходить не думаю.
19. SananCelilli 24.05.24 12:33 Сейчас в теме
Здравствуйте! Сделал как в этом рекомендации. Программа выдает сообщение :
ВывестиРисунок<<?>>(Таб.ТекущийОбъект, Путь)
Процедура не обнаружена (ВывестиРисунок)
Помогите устранить
Спасибо заранее.
Оставьте свое сообщение