Печать ценников с подписью ответственного лица

09.04.16

Задачи пользователя - Этикетки, ценники

Сегодня я расскажу, как сделать печать ценников с подписью ответственного лица в вашей конфигурации

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Внешняя обработка печати ценников с подписью
.epf 28,05Kb
2
2
1 SM
Скачать Купить за 1 850 руб.

1С Розница 1.0, в т.ч  решения от компании "Рарус".

Все решения Розница в 1.0 на обычных формах.

 !!! Небольшой комментарий !!!

Итак, Начнем. когда вы открываете обработку и вводите параметры для отбора при печати ценников, то подпись вы сразу не увидите, как не увидите и ФИО. Но если мы создадим новые реквизиты в справочнике "Физические лица", то мы сразу же сможем выводить на печать Подпись и ФИО.

 

Документация по интеграции расположена как в самой справочной информации, так и в самой статье.

В справочнике "Физические Лица" создаем следующие реквизиты:

1 "СотрАвтограф", заходим в свойства и указываем Тип "ХранилищеЗначения"

2. "ФамилияИО", заходим в свойства и указываем Тип "Строка"  (длину можно до 55 символов, это Фамилия и инициалы для печати на ценнике)

 

В справочнике "Физические Лица" в форме элемента мы сооздаем "Поле картинки" с именем "Подпись"

заходим в свойства и указываем в разделе Характеристики в поле ТекстНевыбраннойКартинки:

Подпись не добавлена , а после заходим в раздел События и в специальном поле НАЖАТИЕ создаем

Следующую процедуру "ПодписьНажатие"

Вот ее текст

 

Процедура ПодписьНажатие(Элемент)
      Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
      Диалог.Заголовок = "Выберите файл с подписью";
      Диалог.ПолноеИмяФайла = "";
      Диалог.ПредварительныйПросмотр = Истина;
      Диалог.Фильтр = "Все картинки (*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf)|*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf|"
      + "Формат bmp (*.bmp;*.dib;*.rle)|*.bmp;*.dib;*.rle|"
      + "Формат JPEG (*.jpg;*.jpeg)|*.jpg;*.jpeg|"
      + "Формат TIFF (*.tif)|*.tif|"
      + "Формат GIF (*.gif)|*.gif|"
      + "Формат PNG (*.png)|*.png|"
      + "Формат icon (*.ico)|*.ico|"
      + "Формат метафайл (*.wmf;*.emf)|*.wmf;*.emf|";// картинки
      Если Диалог.Выбрать() Тогда
           ВыбранноеФото = Новый Картинка(Диалог.ПолноеИмяФайла,Ложь);
           ЭлементыФормы.Подпись.Картинка = ВыбранноеФото;
           СправочникОбъект.СотрАвтограф =  новый ХранилищеЗначения(ВыбранноеФото,Новый СжатиеДанных(9))
      КонецЕсли;
  КонецПроцедуры


А в событиях формы "ПередОткрытием" создаем следующий код:

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)

ВыбранноеФото = СправочникОбъект.СотрАвтограф.Получить();
           Если ЗначениеЗаполнено(ВыбранноеФото) Тогда
                   ЭлементыФормы.Подпись.Картинка = ВыбранноеФото;
            КонецЕсли;

КонецПроцедуры

 

После этого добавляем на форму поле "ФамилияИО"  и ссылаемся на данные реквизита спр. ФЛ. "ФамилияИО"


А теперь нам с вами остается обновить конфигурацию (F7) и начать отладку (F5)


Если все правильно сделано то в справочнике "Физические лица" мы сможем выбрать автограф для нашего ответственного лица кликнув для этого на поле с картинкой и выбрать нужное изображение с автографом. (желательно с прозрачным фоном)

!!! Примечание !!!

Сервис для создания автографов можно найти в интернете. там их полным полно, большинство из них абсолютно и полностью бесплатные, позволяют создать автограф с нужными вам инициалами. Называется он примерно как то так "Онлайн генератор автографов или подписей"


При выборе картинки с автографом ошибок возникнуть не должно, так как код проверял на своей конфигурации и у меня он полностью работоспособный.

После выбора картинки можно вписать фамилию и инициалы в новое созданное нами поле.

После записать изменения и сохранить.

 

Если у вас уже набитая номенклатура со ШК и ценами, вы сможете смело попробовать напечатать новые первые ценники с вашей подписью. Другие сотрудники тоже смогут сделать себе личный автограф и выводить его на печать прямо на ценник, как лицо, ответственное за печать конкретного документа (Ценника)

Желаю вам приятного пользования.

Если вы обладаете знаниями языка запросов, вы смело сможете внедрить дополнительные колонки и выводить на печать гораздо больше информации, или если нет, то заказать внедрение.

Только для Розница в. 1.0.

Ценник подпись

См. также

Этикетки, ценники Программист Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Россия Управленческий учет Платные (руб)

Решение позволяет в шаблон этикетки с типом "Этикетка (обувь, одежда, табак...)" добавлять штрих-коды другого типа, например, GTIN в Code128.

4000 руб.

09.06.2021    15637    10    8    

14

Этикетки, ценники Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Беларусь Украина Россия Управленческий учет Платные (руб)

Простая в использовании обработка для формирования и печати ценников и этикеток со штрих-кодом, с дополнительной ценой, для 1С8.х любой конфигурации. Большое разнообразие шаблонов печатных форм. Управляемая форма (Такси) + Обычный режим.

3588 руб.

11.11.2020    48684    55    44    

66

Этикетки, ценники Пользователь Платформа 1С v8.3 Управляемые формы 1С:Розница 2 1С:Управление нашей фирмой 1.6 Платные (руб)

Встроенная в конфигурации Розница 2.3 и УНФ 1.6 подсистема печати ценников по мне слишком неповоротлива и с усилиями поддается тонкой настройке, решил с нуля написать свою универсальную печать ценников для этих конфигураций.

2000 руб.

04.11.2019    28679    114    87    

53

Логистика, склад и ТМЦ Этикетки, ценники Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Абонемент ($m)

Выводит при печати этикетки складской ячейки в качестве штрихкода адрес ячейки вместо уникального идентификатора

1 стартмани

20.06.2024    538    2    Alexei_Siva    4    

6

Этикетки, ценники Программист Мобильная платформа Бесплатно (free)

Печать этикеток на принтер WiFi без драйвера.

20.01.2023    2167    aldar    0    

9

Этикетки, ценники Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Абонемент ($m)

Внешняя печатная форма для принтера этикеток. В отличие от базовой обработки для печати этикеток эта может выводить на печать дополнительные свойства справочника Номенклатура, а также в ней несложный программный код, что позволяет легко дорабатывать обработку под свои нужды.

2 стартмани

03.01.2023    3517    23    AndreyPonom    7    

11

Этикетки, ценники Пользователь Платформа 1С v8.3 1С:Розница 2 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Абонемент ($m)

Архив с экспортными шаблонами этикеток (ценников) формата 58х40. Для тех, кто не хочет сам рисовать их.

2 стартмани

04.05.2022    13528    46    aximo    3    

12
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. v.l. 435 22.04.16 12:54 Сейчас в теме
Ужас, какое вырвиглазное оформление шрифтов.
Меньше жирного и восклицательных знаков.
2. Razrabotka1C125 24.04.16 12:07 Сейчас в теме
Здравствуйте, Александр, а вы сможете сделать не только печать ценников но и этикеток?
3. goldencity178 8 24.04.16 12:13 Сейчас в теме
Да, Екатерина, приветствую, конечно смогу. под какую конкретно конфигурацию Розница хотели бы видеть публикацию. Я могу сделать универсальные и встраиваемые обработки под конфигурацию Розница 1.0, которая спокойно справляются с печатью и несколько видов ценников и несколько видов этикеток, чтобы готовое решение могло подойти для всех стандартных и отраслевых решений Розница.
4. goldencity178 8 24.04.16 12:16 Сейчас в теме
Версия Разработки 2.0 готовится к выходу с 15 мая. Там будет в комплекте обработки, которые способны печатать и ценники разных форм и этикетки разных размеров. я хочу сделать свои обработки универсальными и удобными в использовании
Оставьте свое сообщение