INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Бухонин Юрий | Индивидуальный предприниматель | Индивидуальный предприниматель

«Бизнес и "автоматизаторы". Проблемы взаимопонимания или как договориться?»

Что нужно делать, как объяснять и ставить задачи, чтобы то, что получилось в результате внедрения информационной системы было похоже на то, что представлял в своей голове предприниматель и хозяин бизнеса. Бизнес-процессы и их эффективность – НАШЕ ВСЕ! Так ли это? • Свойство человеческого мышления сосредотачиваться на процессе или действии и не уделять до-статочно внимания цели этого действия. К чему это приводит? • Бизнес-процессы – это важная вещь в работе предприятия, но они стоят на последнем месте трех-ступенчатого процесса систематизации предприятия. • Построение картины предприятия с точки зрения «что люди производят» вместо обычного взгляда «что люди делают». • Как договориться «о терминах» или что делать, когда под одними и теми же словами каждый понима-ет свое? • Бизнес-процессы. Что от них действительно нужно? • Бизнес-процессы, о которых почти никто почти никогда не думает. Принятие решений и сдача/приемка чего-то между сотрудниками и подразделениями. Прямая дорога к цели и «призраки». Где они прячутся и чем могут грозить? • Свойство человеческого мышления видеть, продумывать и планировать только прямую дорогу к це-ли, не думая о возможных «форс-мажорах». Сосредотачиваться на том что надо делать и пропускать контроль того, что делать НЕ надо. • Восприятие человеком времени как универсального ресурса, добавление которого достаточно для решения любых возникающих в проекте проблем. Это не так! • «Левый» и «Правый» призраки прямой дороги или как может получиться «недоделал» и «переде-лал»? Важность построения систем контроля возникновения «призраков» и выработки понимания, что делать в таких случаях • Невнимание к «призракам» приводит к нереально оптимистичному восприятию проектов, ресурсов, времени и т.д. В результате – срыв сроков и превышения бюджета. Превращение «нужно от меня» в «нужно мне» или как заставить людей выполнять работу, которая никому не нравится? • Привычка ставить задачи в формулировке «Что нужно сделать». Нужно переходить к формулировке «Что ты должен выдать». • Связь «работа -> результат». Пока работу делает один, а результатом пользуется другой – работа будет делаться не «как лучше», а «как проще». Это приводит к нерешаемым конфликтам с выполне-нием обязательной, но «никому не нужной» работы. • KPI, премии и штрафы. Закон «хрюшки Доси» - фундаментальный закон жизни и деятельности любого коллектива. • Важность понимания, что именно предприятие покупает у сотрудников за их зарплату? Как и по каким критериям это оценивается? «Социализм» и «Капитализм» в построении предприятия или что и как нужно контролировать? • Развитие предприятия. Пути «в ширь» и «в глубь». • Конкуренция и кооперация – два противоположных по сути подхода к эффективности системы. • Плюсы, минусы, условия и рамки применимости каждого.

Печать ценников с подписью ответственного лица

Печать - Ценники

4
Сегодня я расскажу, как сделать печать ценников с подписью ответственного лица в вашей конфигурации

1С Розница 1.0, в т.ч  решения от компании "Рарус".

Все решения Розница в 1.0 на обычных формах.

 !!! Небольшой комментарий !!!

Итак, Начнем. когда вы открываете обработку и вводите параметры для отбора при печати ценников, то подпись вы сразу не увидите, как не увидите и ФИО. Но если мы создадим новые реквизиты в справочнике "Физические лица", то мы сразу же сможем выводить на печать Подпись и ФИО.

 

Документация по интеграции расположена как в самой справочной информации, так и в самой статье.

В справочнике "Физические Лица" создаем следующие реквизиты:

1 "СотрАвтограф", заходим в свойства и указываем Тип "ХранилищеЗначения"

2. "ФамилияИО", заходим в свойства и указываем Тип "Строка"  (длину можно до 55 символов, это Фамилия и инициалы для печати на ценнике)

 

В справочнике "Физические Лица" в форме элемента мы сооздаем "Поле картинки" с именем "Подпись"

заходим в свойства и указываем в разделе Характеристики в поле ТекстНевыбраннойКартинки:

Подпись не добавлена , а после заходим в раздел События и в специальном поле НАЖАТИЕ создаем

Следующую процедуру "ПодписьНажатие"

Вот ее текст

 

Процедура ПодписьНажатие(Элемент)
      Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
      Диалог.Заголовок = "Выберите файл с подписью";
      Диалог.ПолноеИмяФайла = "";
      Диалог.ПредварительныйПросмотр = Истина;
      Диалог.Фильтр = "Все картинки (*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf)|*.bmp;*.dib;*.rle;*.jpg;*.jpeg;*.tif;*.gif;*.png;*.ico;*.wmf;*.emf|"
      + "Формат bmp (*.bmp;*.dib;*.rle)|*.bmp;*.dib;*.rle|"
      + "Формат JPEG (*.jpg;*.jpeg)|*.jpg;*.jpeg|"
      + "Формат TIFF (*.tif)|*.tif|"
      + "Формат GIF (*.gif)|*.gif|"
      + "Формат PNG (*.png)|*.png|"
      + "Формат icon (*.ico)|*.ico|"
      + "Формат метафайл (*.wmf;*.emf)|*.wmf;*.emf|";// картинки
      Если Диалог.Выбрать() Тогда
           ВыбранноеФото = Новый Картинка(Диалог.ПолноеИмяФайла,Ложь);
           ЭлементыФормы.Подпись.Картинка = ВыбранноеФото;
           СправочникОбъект.СотрАвтограф =  новый ХранилищеЗначения(ВыбранноеФото,Новый СжатиеДанных(9))
      КонецЕсли;
  КонецПроцедуры


А в событиях формы "ПередОткрытием" создаем следующий код:

Процедура ПередОткрытием(Отказ, СтандартнаяОбработка)

ВыбранноеФото = СправочникОбъект.СотрАвтограф.Получить();
           Если ЗначениеЗаполнено(ВыбранноеФото) Тогда
                   ЭлементыФормы.Подпись.Картинка = ВыбранноеФото;
            КонецЕсли;

КонецПроцедуры

 

После этого добавляем на форму поле "ФамилияИО"  и ссылаемся на данные реквизита спр. ФЛ. "ФамилияИО"


А теперь нам с вами остается обновить конфигурацию (F7) и начать отладку (F5)


Если все правильно сделано то в справочнике "Физические лица" мы сможем выбрать автограф для нашего ответственного лица кликнув для этого на поле с картинкой и выбрать нужное изображение с автографом. (желательно с прозрачным фоном)

!!! Примечание !!!

Сервис для создания автографов можно найти в интернете. там их полным полно, большинство из них абсолютно и полностью бесплатные, позволяют создать автограф с нужными вам инициалами. Называется он примерно как то так "Онлайн генератор автографов или подписей"


При выборе картинки с автографом ошибок возникнуть не должно, так как код проверял на своей конфигурации и у меня он полностью работоспособный.

После выбора картинки можно вписать фамилию и инициалы в новое созданное нами поле.

После записать изменения и сохранить.

 

Если у вас уже набитая номенклатура со ШК и ценами, вы сможете смело попробовать напечатать новые первые ценники с вашей подписью. Другие сотрудники тоже смогут сделать себе личный автограф и выводить его на печать прямо на ценник, как лицо, ответственное за печать конкретного документа (Ценника)

Желаю вам приятного пользования.

Если вы обладаете знаниями языка запросов, вы смело сможете внедрить дополнительные колонки и выводить на печать гораздо больше информации, или если нет, то заказать внедрение.

Только для Розница в. 1.0.

4

Скачать файлы

Наименование Файл Версия Размер
Внешняя обработка печати ценников с подписью
.epf 28,05Kb
09.04.16
2
.epf 1.0.0.0 28,05Kb 2 Скачать

См. также

Комментарии
Сортировка: Древо
1. Vladal 416 22.04.16 12:54 Сейчас в теме
Ужас, какое вырвиглазное оформление шрифтов.
Меньше жирного и восклицательных знаков.
2. Razrabotka1C125 24.04.16 12:07 Сейчас в теме
Здравствуйте, Александр, а вы сможете сделать не только печать ценников но и этикеток?
3. goldencity178 7 24.04.16 12:13 Сейчас в теме
Да, Екатерина, приветствую, конечно смогу. под какую конкретно конфигурацию Розница хотели бы видеть публикацию. Я могу сделать универсальные и встраиваемые обработки под конфигурацию Розница 1.0, которая спокойно справляются с печатью и несколько видов ценников и несколько видов этикеток, чтобы готовое решение могло подойти для всех стандартных и отраслевых решений Розница.
4. goldencity178 7 24.04.16 12:16 Сейчас в теме
Версия Разработки 2.0 готовится к выходу с 15 мая. Там будет в комплекте обработки, которые способны печатать и ценники разных форм и этикетки разных размеров. я хочу сделать свои обработки универсальными и удобными в использовании
Оставьте свое сообщение