Универсальный подбор и обработка объектов, Управляемые формы, 8.2 - 8.3 FIX

13.10.15

Задачи пользователя - Подбор и обработка объектов

Универсальный отбор и обработка объектов для управляемого приложения.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Универсальные подбор и обработка объектов
.epf 83,26Kb
1057
1057
1 SM
Скачать Купить за 1 850 руб.

Исходный материал автора Василий Демидов (Душелов)

2012-03-12

Поправил баги на которые напоролся:

1) Не сохранялся редактируемый объект и настройки отбора

2) Не работал отбор по значению ("Объект")

3) Искажались настройки отбора при нажатии на кнопку "Найти ссылки"

Добавил:

1) Возможность использовать обработку в механизми "Дополнительных печатных форм и обработок"

В планах:

- сделать нормальную форму выбора объекта метаданных 

- Автоматический вызов окна выбора реквизита отбора при добавлении строки отбора.

См. также

Поиск данных Корректировка данных Подбор и обработка объектов Программист Пользователь Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Обработка позволяет найти и заменить битые ссылки справочников. Для всех конфигураций. Обработка универсальная! Незаменимая вещь как для IT-специалистов, так и для обычных пользователей!

10 стартмани

04.07.2024    574    1    user1527257    0    

5

Корректировка данных Подбор и обработка объектов Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Универсальная обработка! Подходит для всех конфигураций! На одном экране можно видеть как все справочники, так и детальную информацию по каждому из них (реквизиты и табличные части). Удобно! Присутствует возможность редактирования справочника.

10 стартмани

28.06.2024    547    3    user1527257    0    

9

Журналы и реестры данных Подбор и обработка объектов Бухгалтер Пользователь Платформа 1С v8.3 1С:Документооборот 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Управление торговлей 11 1С:Управление холдингом 1С:Комплексная автоматизация 2.х 1С:Зарплата и Управление Персоналом 3.x 1С:CRM ПРОФ, КОРП 1С:Управление нашей фирмой 3.0 1С:Розница 3.0 Абонемент ($m)

Универсальный реестр документов! Журнал документов для всех конфигураций! На одном экране можно видеть как все документы, так и детальную информацию по каждому из них (реквизиты, движения и табличные части). Удобно! Присутствует возможность редактирования документа. Универсальный редактор документов!

10 стартмани

20.06.2024    679    10    user1527257    2    

10

Подбор и обработка объектов Программист Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Нужно быстро обработать какие-то данные, а подходящей многопоточной обработки нет?

2 стартмани

13.06.2024    4702    35    maslyann    5    

34

Подбор и обработка объектов Программист Пользователь Платформа 1С v8.3 Конфигурации 1cv8 1С:Управление торговлей 11 Абонемент ($m)

Возникла задача от категорийного менеджера. Требовалось работать с основными и дополнительными реквизитами номенклатуры в одном динамическом списке. Требовался произвольный настраиваемый набор реквизитов. Требовалось фильтровать по любому полю списка. Требовалось устанавливать новые значения любых реквизитов как групповым способом, так и индивидуально. Реализовал. В процессе написания стало понятно, что так можно работать с любым справочником. Возможно, кому то такое актуально.

1 стартмани

20.05.2024    489    11    user1374747    2    

9
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. пользователь 12.03.12 23:20
Сообщение было скрыто модератором.
...
2. ITEkb 14.03.12 10:03 Сейчас в теме
Да, Была эта новость на главной.
Я тоже был расстроен этим событием.
Толковые разработки парень делал.
Лично не был знаком.

По этому отчету те же ошибки нашел, поправил,
но дальше не знал, как выложить.

Под своим именем вроде как нехорошо.

А добавить к другому профилю прав нет.

Спасибо за отчет, гляну.
3. klel 14.03.12 22:03 Сейчас в теме
Обработка вполне ничего можно на досуге посмотреть
4. panam 58 20.03.12 11:54 Сейчас в теме
Спасибо, давно ждал под управляемые формы. С ошибкой в отборе по объекту пользоваться было невозможно.
5. sergb1979 21.03.12 12:03 Сейчас в теме
Главный плюч универсальность. Спасибо
6. elena_77 23.03.12 13:44 Сейчас в теме
Спасибо за обработку. Нужна была управляемая форма. Обязятельно скачаю попробовать.
7. Moll 23.03.12 15:15 Сейчас в теме
Большое спасибо за доработку данной обработки, очень полезная вещь, особенно когда уже привых на обычных приложених юзать подобное, не приходится каждый раз изобретать велосипед x]
За исправление и настройку отбора ещё большее спасибо.
А так же ждём выполнения данного пункта:
- сделать нормальную форму выбора объекта метаданных.
8. electronik 26.03.12 17:16 Сейчас в теме
Большое спасибо за доработку данной обработки, очень полезная вещь,
9. Little-ann 15 28.03.12 10:02 Сейчас в теме
Долго искала рабочую под управляемый формы.
10. USER--1C 60 31.03.12 19:06 Сейчас в теме
необходимо многие используемые обработки адаптировать под управляемое приложение. Уже актуально, а в УП иногда невозможно запустить обычные обработки, не влезая в конфигуратор.
11. free-lancer-2018 190 03.04.12 21:35 Сейчас в теме
12. free-lancer-2018 190 04.04.12 13:19 Сейчас в теме
В целом удобная обработка, только что использовал...
При открытии на третий раз выскочила ошибка типа "неверный тип данных..." и форма не открылась...
Видимо в ней якой-то глюк с сохранением настроек... Лечится закрытием БД и открытием снова.
13. пользователь 04.04.12 13:51
Сообщение было скрыто модератором.
...
14. electronik 12.04.12 13:32 Сейчас в теме
Будем тестировать. Если по описанию то класная, прокатаю на рабочей конфигурации отпишусь
15. пользователь 13.04.12 08:06
Сообщение было скрыто модератором.
...
16. karakozov 27.04.12 11:00 Сейчас в теме
Неплохое развитие популярного механизма.Инструмент который нужен каждый день.Посмотрим.Нужно тестировать перед тем как он попадет в папку инструментов под рукой.
17. fibrsb 02.07.12 11:27 Сейчас в теме
>В целом удобная обработка, только что использовал...
>При открытии на третий раз выскочила ошибка типа "неверный тип данных..." и форма не открылась...
>Видимо в ней якой-то глюк с сохранением настроек... Лечится закрытием БД и открытием снова.

Тоже такое было, а вообще очень нужная обработка. Странно что 1с не оставила ее в конфигурациях.
18. NTLy 21.03.13 06:29 Сейчас в теме
Спасибо огромное!
Обработка работает в БП редакции 3.0
19. gubanoff 63 09.07.13 12:48 Сейчас в теме
У себя поправил следующее:
  • сортировку объектов по их представлению в поле выбора объектов (то есть вначале идут все справочники по алфавиту, затем все документы по алфавиту и т.п., так удобнее искать и выглядит приятней);
  • проверку на "Предопределенный" при выполнении действий с объектами (чтобы не вылетало, если у справочника есть какие-то предопределенные элементы.
20. gamaliaka 4 28.07.13 20:27 Сейчас в теме
Попробовал использовать в 1С:Документооборот 1.3, столкнулся с ошибками:
1. При перетаскивании из доступные обработки в выбранные - несоответствие типов (параметр номер "1")
2. При сохранении настройки - Поле объекта недоступно для записи (Родитель) - но настройку сохраняет
3. Нашел несколько документов, отметил галками, нажимаю установка реквизитов - корреспондент - выбрал нужного - нажал выполнить - "Обработка ... завершена! Обработано объектов: 15." Захожу в документы - корреспонденты не заполнены/не изменены.

Подскажите пожалуйста, как це лечить?
21. 3762515 06.09.13 17:26 Сейчас в теме
А можно и мне такую? Кому не сложно, пришлите пожалуйста на мыло: 3762515(цобака)маил ру
22. lisma9 28.12.13 15:52 Сейчас в теме
Не работает в Бухгалтерии 3.0.28.7
leonidt84; scape; Tangram; Dimyla; fvr2000; amateos; @Sonya; +7 Ответить
23. 3762515 19.02.14 17:11 Сейчас в теме
24. dimazzz84 30 13.03.14 09:17 Сейчас в теме
25. Tangram 160 27.03.14 23:05 Сейчас в теме
УНФ: на 8.2 работало ОК, перешел на платформу 8.3, 1.4.8.3, перестала работать.
26. Tangram 160 27.03.14 23:18 Сейчас в теме
Внес исправления, заработало:
Форма ПодборИОбработка, поле ПолеОбъектПоиска, КнопкаВыпадающегоСписка = Да
Модуль формы ПодБорИОбработка:

в 2х функциях меняем ЭтотОбъект на ВотЭтотОбъект
&НаСервере
Функция ПолучитьПолноеИмяФормы(ИмяНужнойФормы)
	ВотЭтотОбъект = РеквизитФормыВЗначение("Объект");
	
	МассивСтрок = ВотЭтотОбъект.РазложитьСтрокуВМассивПодстрок(ЭтаФорма.ИмяФормы, ".");
	МассивСтрок[МассивСтрок.Количество() - 1] = ИмяНужнойФормы;
	
	Возврат ВотЭтотОбъект.ПолучитьСтрокуИзМассиваПодстрок(МассивСтрок, ".");
КонецФункции

&НаСервере
Процедура НайтиСсылкиПоОтбору()
	
	ВотЭтотОбъект = РеквизитФормыВЗначение("Объект");
	
	Запрос = Новый Запрос;
		
	Если РежимПоиска = 1 Тогда
		Запрос.Текст = ТекстПроизвольногоЗапроса;
		Для Каждого СтрокаПараметров Из ПараметрыЗапроса Цикл
			Если СтрокаПараметров.ЭтоВыражение Тогда
				Запрос.УстановитьПараметр(СтрокаПараметров.ИмяПараметра, Вычислить(СтрокаПараметров.ЗначениеПараметра));
			Иначе
				Запрос.УстановитьПараметр(СтрокаПараметров.ИмяПараметра, СтрокаПараметров.ЗначениеПараметра);
			КонецЕсли;
		КонецЦикла;
	Иначе
		Запрос.Текст = ТекстЗапроса;
		УсловиеПоискаПоСтроке = СформироватьУсловиеПоискаПоСтроке();
		СписокУсловий = УсловиеПоискаПоСтроке;
	
		Если ОтборДанных <> Неопределено Тогда
			Для Каждого ЭлементОтбора Из ОтборДанных.Отбор.Элементы Цикл
				Если НЕ ЭлементОтбора.Использование Тогда
					Продолжить;
				КонецЕсли;
				
				Индекс = ОтборДанных.Отбор.Элементы.Индекс(ЭлементОтбора);
				ИмяПараметра = СтрЗаменить(Строка(ЭлементОтбора.ЛевоеЗначение) + Индекс, ".", "");
				
				СписокУсловий = СписокУсловий + ?(СписокУсловий = "", "", "
				|	И ") + ВотЭтотОбъект.ПолучитьВидСравнения(ЭлементОтбора.ЛевоеЗначение, ЭлементОтбора.ВидСравнения, ИмяПараметра);
				
				Если ТипЗнч(ЭлементОтбора.ПравоеЗначение) = Тип("СтандартнаяДатаНачала") Тогда
					Запрос.УстановитьПараметр(ИмяПараметра, ЭлементОтбора.ПравоеЗначение.Дата);
				Иначе
					Запрос.УстановитьПараметр(ИмяПараметра, ЭлементОтбора.ПравоеЗначение);
				КонецЕсли;
			КонецЦикла;
		КонецЕсли;
		
		Если СписокУсловий <> "" Тогда
			Запрос.Текст = Запрос.Текст + "
			|ГДЕ 
			|	" + СписокУсловий;
		КонецЕсли;
	КонецЕсли;
	
	Попытка
		ТЗ = Запрос.Выполнить().Выгрузить();
	Исключение
		Сообщить(ОписаниеОшибки());
		Возврат;
	КонецПопытки;
	
	МассивРеквизитов = Новый Массив;
	МассивРеквизитов.Добавить("Объект");
	МассивРеквизитов.Добавить("Картинка");
	МассивРеквизитов.Добавить("Выбрать");
	
	СоздатьКолонки(ТЗ, МассивРеквизитов);
	
КонецПроцедуры
Показать


Возможно проявятся еще какие-то косяки,
мне надо было снять пометку удаления с ВариантыОтчетов, после исправления сработало.
27. Myst_ 65 16.09.14 10:40 Сейчас в теме
По событию "найти ссылки"
Ошибка
Поле объекта не доступно для записи ЭтотОбъект.
Бухгалтерия предприятия (базовая), редакция 3.0 (3.0.34.11) (http://v8.1c.ru/buhv8/)

Платформа 1С:Предприятие 8.3 (8.3.5.1119)
28. de0nis 466 08.12.14 02:39 Сейчас в теме
(27) Myst_, это из-за включенной совместимости с 8.2 в бух 3.0. Сделай замену во всем модуле ЭтотОбъект на Объект1, на пример, и все заработает.
29. de0nis 466 08.12.14 02:42 Сейчас в теме
Но у меня тоже пара вопросов при работе в бух 3.0:
1. При подборе документов по реквизитам, нет упорядочивания, при этом документы могут упорядочены не по дате. При перенумерации они перенумеровываются в том же порядке как были выбраны, т.е. в хронологии создания, а не в хронологи по дате (как хотелось бы). Это ошибка или я что-то не нашел??
пока сделал костыль в процедуре НайтиСсылкиПоОтбору() добавил после добавления условий код:
Если Найти(Запрос.Текст, "Документ.") > 0 Тогда
	Запрос.Текст = Запрос.Текст + "
	|
       	|УПОРЯДОЧИТЬ ПО
       	|	_Таблица.Дата
	|	";		
КонецЕсли;
Показать

2. Для документов не очень удобно сделан отбор по дате, нельзя выбрать дату сразу, только через Объект. Нельзя выбрать вид сравнения даты в периоде, хотя для даты это самый актуальный.
А так огромное спасибо за обработку.
30. ufo58 161 03.01.15 11:55 Сейчас в теме
Скачал. Запустил в 3-ке. Внес корректировки для совместимости.
Задача проста - перекодировка справочника Номенклатура.
.... Не работает ...
А жаль
33. dj_serega 393 13.05.15 10:08 Сейчас в теме
(30) ufo58, Возможно решение.
]//СтрДоступных = ДоступныеОбработки.НайтиПоИдентификатору(СтрВыбранных);
СтрДоступных = ДоступныеОбработки.НайтиПоИдентификатору(СтрВыбранных.ПолучитьИдентификатор());
[/1C-CODE]
(31) m-sla, в методе "ОткрытьФорму()" есть новые параметры (они последние). Поковыряйте там.
31. m-sla 5 26.02.15 13:11 Сейчас в теме
Добрый день! А отбор только у меня не работает? Конфигурация розница 2.1 сначала была ошибка что не может открыть модально РезультатОтбора = ОткрытьФормуМодально(ФормаОтбора); заменила на РезультатОтбора = ОткрытьФорму(ФормаОтбора); . Форма открывается но при нажатии на кнопку применить ничего не происходит
32. zvERP1c 08.04.15 16:41 Сейчас в теме
При попытке сохранить настройки Установки реквизитов вылетает ошибка:
{Форма.УстановкаРеквизитов.Форма(94)}: Поле объекта недоступно для записи (Родитель)
			ЭтаФорма.ВладелецФормы.Элементы.ДоступныеОбработки.Родитель = НоваяСтрока.ПолучитьИдентификатор();
.
34. igor.grinin 21.12.15 08:52 Сейчас в теме
35. igor.grinin 21.12.15 08:52 Сейчас в теме
36. user622533_y.yukaeva 25.01.17 16:03 Сейчас в теме
Не работает отбор "Объект поиска".
Прикрепленные файлы:
37. Elected 22 16.06.21 11:01 Сейчас в теме
Не работает на последнем релизе конфигурации :(
Оставьте свое сообщение