Выбор цвета для 1С 7.7

09.06.20

Разработка - Работа с интерфейсом

Простая и удобная внешняя обработка для выбора цвета без применения внешних компонент.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Внешняя обработка для выбора цвета:
.ert 133,00Kb
4
4
1 SM
Скачать Купить за 1 850 руб.

Как известно, в 1С 7.7 используется фиксированный набор из 56 цветов. Предлагаемая обработка представляет собой диалог выбора цвета из этого фиксированного набора при помощи всего одного нажатия: все 56 образцов цвета выполнены в виде кнопок на форме диалога, одно нажатие по которым приводит к выбору нужного цвета - он возвращается в виде числа в Форма.Параметр. Также предусмотрен выбор цвета "Авто" - возвращает -1 и отказ от выбора - возвращает -2.

Обработка выполнена на штатных средствах 1С 7.7 без применения внешних компонент.

Протестировано на платформе 1С 7.7 25 и 27 релиз.

выбор цвета

См. также

Работа с интерфейсом Программист Платформа 1С v7.7 Конфигурации 1cv7 Абонемент ($m)

Создание и использование на формах в среде 1С 7.7 прогрессбара, индикатора, как в 1С 8.Х для контроля над длительными процессами. Реализовано средствами языка программирования 1С 7.7.

1 стартмани

06.06.2024    487    1    user1416274    17    

2

Работа с интерфейсом Логистика, склад и ТМЦ Системный администратор Программист Пользователь Платформа 1С v7.7 1С:Торговля и склад 7.7 Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Решение для разработчика и конечного пользователя для работы с фотографиями номенклатуры: систематизация, хранение, отображение, а также выгрузка на Яндекс-Диск и FTP (кроме версии лайт). Поддерживаются графические форматы: bmp, jpg, gif, tiff, а также png - не поддерживаемый штатными средствами 1С. Выполнено без использования внешних компонент (кроме функции выгрузки на FTP). Поставляется как в виде пустой конфигурации с набором объектов и модулей для работы с фото, так и в виде обновления к 1С:Торговля и склад 7.7. Выполнено в двух версиях: "полная" и "лайт".

5000 руб.

18.10.2022    5497    1    45    

4

Инструментарий разработчика Работа с интерфейсом Программист Платформа 1С v7.7 Абонемент ($m)

Обработка с фрагментами кода для программного использования набора цветов из коллекции WebЦвета 1с версии 8+ в 1с версии 77. Требуется предварительное подключение сторонней библиотеки FormEх. Будет полезно программистам 1с 77, 1с 8. Да и вообще при программировании на любом языке при потребности использовать коллекцию цветов WebЦвета.

1 стартмани

30.03.2022    4707    2    igor7777    4    

6

Работа с интерфейсом Программист Платформа 1С v7.7 Конфигурации 1cv7 Бесплатно (free)

Публикация имеет цель обратить внимание на возможность улучшения интерфейса.

15.12.2021    4624    63    Cерый    13    

7

Учет рабочего времени Работа с интерфейсом Программист Бухгалтер Пользователь Платформа 1С v7.7 Конфигурации 1cv7 Россия Абонемент ($m)

Обработка производственного календаря с возможностью импорта и экспорта xls для 1С 7.7 (7.70.027) без изменения конфигурации.

1 стартмани

18.09.2019    12805    6    Jill    8    

3

Работа с интерфейсом Программист Платформа 1С v7.7 Конфигурации 1cv7 Абонемент ($m)

При программировании на платформе V7 достаточно часто возникает задача создать несколько табличных частей документа (или справочника). Традиционно эта задача имеет несколько решений..

1 стартмани

01.05.2018    22732    27    Gkmy    11    

5
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. CheBurator 3126 11.06.20 21:06 Сейчас в теме
Что-то как-то была уже такая разработка. чуть ли не 1-в-1
4. vap_pig 83 12.06.20 11:47 Сейчас в теме
(1) Не один в один - у меня удобнее. ;-)
2. CheBurator 3126 11.06.20 21:08 Сейчас в теме
хорошо бы чтобф цвет еще мог возвращаться в формате формекса
[0xBGR], например [0xFFCCDD]
5. vap_pig 83 12.06.20 11:50 Сейчас в теме
(2) Функция IntToHex в помощь:

Функция IntToHex(Знач Ч, Длина = 0)
	Перем Рез, Ц;
	Рез = "";
	Ч = Цел(Ч);
	Если Ч <= 0 Тогда
		Ч = 0;
	КонецЕсли;
	Пока 1 = 1 Цикл
		Ц = Ч % 16;
		Ч = Цел(Ч / 16);
		Если Ц < 10 Тогда
			Ц = Симв(Ц + 48);
		Иначе
			Ц = Симв(Ц + 87);
		КонецЕсли;
		Рез = Ц + Рез;
		Если Ч = 0 Тогда
			Прервать;
		КонецЕсли;
	КонецЦикла;
	Если Длина = 0 Тогда
		Возврат Рез;
	КонецЕсли;
	Пока СтрДлина(Рез) < Длина Цикл
		Рез = "0" + Рез;
	КонецЦикла;
	Возврат Прав(Рез, Длина);
КонецФункции //IntToHex
Показать
3. CheBurator 3126 11.06.20 21:09 Сейчас в теме
Сделать что при открытии с параметром - диалог выбора цвета, апри открытии без параметра - интерактивно - еще были видны и настрочные параметры - наприемр вариант возврата цвета (как миниум три варианта, числомЮ триадойдесятичной, формексовый)
Оставьте свое сообщение