Добавление стран из классификатора, сохраненного в таблице значений

16.05.24

Задачи пользователя - Адаптация типовых решений

В связи с тем, что в новой форме счет-фактуры указываются коды стран-производителей товара, столкнулся с ситуацией, когда в классификаторе стран находится много стран-дублей, а коды стран не соответствуют общероссийскому классификатору. Чтобы в дальнейшем, при добавлении стран, ситуация не повторялась решено было реализовать механизм позволяющий только выбирать страну из классификатора (предварительно сохраненного в ТаблицеЗначений).

Скачать исходный код

Наименование Файл Версия Размер
KLCOUNTR.dat
.dat 10,52Kb
9
.dat 10,52Kb 9 Скачать
  1. Был взят классификатор стран со страницы https://classifikators.ru/oksm

  2. Скопированный классификатор вставлен в Excel, затем загружен в ТаблицуЗначений в 1C

  3. ТаблицаЗначений сохранена в файл 

  4. В базу добавлена константа - "Путь к классификатору стран мира" (Константа.ПутьОКСМ)

  5. В форму списка справочника ОКСМ добавлена кнопка "Добавить из классификатора стран мира" с формулой "ПриВводеСтроки()"

  6. В модуль формы списка добавлен следующий код:

Процедура ПриВводеСтроки()
    
    Если ФС.СуществуетФайл(Константа.ПутьОКСМ) = 0 Тогда
        
        Сообщить("Не найден классификатор стран!");
        СтатусВозврата(0);
        Возврат;
        
    КонецЕсли;
    
    
    ТабЗнач = СоздатьОбъект("ТаблицаЗначений");
    ЗначениеИзФайла(Константа.ПутьОКСМ, ТабЗнач, 0);
    СпрСтрана = СоздатьОбъект("Справочник.ОКСМ");
    СпрСтрана.ВыбратьЭлементы();
    
    
    Пока СпрСтрана.ПолучитьЭлемент() = 1 Цикл
        
        Стр = "";
        Если ТабЗнач.НайтиЗначение(СпрСтрана.Код, Стр, "Код") <> 0 Тогда
            
            ТабЗнач.УдалитьСтроку(Стр);
            
        КонецЕсли;
        
    КонецЦикла;
    
    
    ВыбСтрока = "";
    Если ТабЗнач.ВыбратьСтроку(ВыбСтрока, "Выберите страну для добавления") <> 1 Тогда
        
        СтатусВозврата(0);
        Возврат;
        
    КонецЕсли;
    
    
    Если ВыбСтрока = 0 Тогда
        
        СтатусВозврата(0);
        Возврат;
        
    КонецЕсли;
    
    
    СпрСтрана.Новый();
    СпрСтрана.Код = ТабЗнач.ПолучитьЗначение(ВыбСтрока, "Код");
    СпрСтрана.Наименование = ТабЗнач.ПолучитьЗначение(ВыбСтрока, "Страна");
    СпрСтрана.Записать();
    
    Форма.Обновить();
    
КонецПроцедуры

 

Теперь пользователи могут добавлять страны только из классификатора:

 

Из открывающейся для выбора таблицы убраны уже присутствующие в справочнике страны - для исключения добавления повторов. 

Прилагаю таблицу значений, выгруженную в файл.

Надеюсь, кому-нибудь поможет.

См. также

Улучшенная обработка "Внешние печатные формы" для типовых конфигураций на базе 1С 7.7

Печатные формы Адаптация типовых решений Программист Платформа 1С v7.7 Конфигурации 1cv7 Абонемент ($m)

Приятное улучшение обработки "Внешние печатные формы" для типовых конфигураций на базе 1С 7.7 для более комфортной работы с "любимой семерочкой".

1 стартмани

04.02.2022    3237    1    igor7777    0    

3

Расчет страховых взносов в 1С 7.7 "Учет и отчетность предпринимателя, ред. 1.2" с апреля 2020

Адаптация типовых решений Программист Платформа 1С v7.7 Конфигурации 1cv7 Россия Бухгалтерский учет ФОМС, ЕФС Бесплатно (free)

В этой статье описано, какие небольшие изменения можно внести в модуль документа Начисление налогов с ФОТ, чтобы правильно рассчитывались страховые взносы с 1 апреля 2020 г.

09.04.2020    20030    Юджин58    39    

5

Дистрибьюция 7.7. Часть 1. Жизненный цикл заявки покупателя. Одна заявка покупателя, много адресов доставки.

Адаптация типовых решений Программист Платформа 1С v7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Управленческий учет Бесплатно (free)

Описан способ работы с учетом расписания с приоритетными покупателями - торговыми сетями (основными покупателями) в торговой или комплексной учетной системе на 1С 7.7. Множественная заявка покупателя на несколько торговых точек.

14.10.2019    6098    ksnik    14    

3

Как в торговле 7.7 печатать код ТНВЭД в счет-фактуре

Операции по ВЭД Адаптация типовых решений Программист Оперативный учет 7.7 1С:Торговля и склад 7.7 Россия Бухгалтерский учет НДС Бесплатно (free)

В данной статье хотел поделиться опытом, как в Торговле 7.7 ( релиз 994) сделать возможность выводить код ТНВЭД в печатную форму счета-фактуры. Сразу скажу, что нужно это только тем, кто осуществляет экспорт в страны таможенного союза. Остальные могут не волноваться.

15.11.2017    11873    AndKovalchuk    0    

1

Предельные базы взносов в ПФР, ФСС, ФФОМС 2015 в 1С: Бухгалтерия 7.7

Зарплата Адаптация типовых решений Программист Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 Россия Бухгалтерский учет Абонемент ($m)

Реализация Постановления Правительства РФ 1316 от 04.12.14 для типовой конфигурации "Бухгалтерский учет 7.7" рел. 7.70.590

1 стартмани

31.12.2014    23977    9    Sergey1CSpb    2    

0
Оставьте свое сообщение