Использование функций внешнего отчета в вычисляемых полях системы компоновки данных. Добавлена поддержка расшифровки.

01.01.13

Разработка - СКД

Нужно ли при необходимости использования новой функции в вычисляемых полях СКД  всякий раз описывать её в общем модуле ?
НЕТ ! Если один раз описать в общем модуле универсальную функцию.
По предложению sam441 добавлена поддержка расшифровки в отчете.
В демонстрационном примере расшифровка открывается для всех полей отчета.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Архив с демонстрационным материалом
.rar 72,91Kb
136
136
1 SM
Скачать Купить за 1 850 руб.

Отмазка

Некоторым эта статья покажется диким баяном - бабаяном ... но не все же являются матерыми одинэсниками в седьмом поколении. Так что эта статья для тех, кто не является.

Преамбула

Зачем это нужно ? При сопровождении больших проектов, как правило, новые релизы конфигураций выпускаются намного реже, чем новые внешние отчеты  и печатные формы. А обновляются у заказчика еще реже, особенно если баз данных у него много :)  Поэтому часто возникают ситуации, когда отчет заказчику нужен срочно, а конфигурации, установленные у него, не имеют нужной прямо сейчас функции общего модуля. Можно, конечно, выкрутиться, если передать в отчет объект (например - таблицу значений), который можно вычислить как душе угодно. Но зачем выкручиваться, если можно использовать экспортные функции этого же отчета в вычисляемых полях СКД ? Статья как раз о том, как это сделать.

Амбула

Собственно, всё достаточно просто:

  1. в сопровождаемую конфигурацию внедряем экспортную функцию общего модуля;
  2. добавляем параметр со своим любимым именем в макет СКД отчета (в примере это имя "Отчет");
  3. в модуле формы этому параметру при запуске отчета присваиваем значение объекта;
  4. в вычисляемом поле вызываем функцию модуля отчета через посредника - функцию общего модуля, например: ом.Фу(&Отчет,"Ф2",Наименование,5) . В этом вызове &Отчет - это введенный нами параметр, Ф2 - имя функции, размещенной в модуле отчета, Наименование и 5 - это аргументы, которые будут переданы в Ф2.

Небольшой пример: демо-база и демонстрационный внешний отчет для управляемого приложения прилагаются. Но и для обычного нет преград. Тоже всё работает. Представленная технология позволяет вызывать экспортные функции модулей внешних отчетов и обработок.        

Внедрение одной небольшой универсальной экспортной функции-посредника в общий модуль конфигурации позволяет забыть об ограничении платформы - разрешении на использование в вычисляемых полях СКД только экспортных функций общих модулей конфигурации.

Замечания:

В ходе тестирования обнаружилось различное поведение конфигурации при запуске под платформой 8.3, несмотря на то, что установлен режим совместимости с версией 8.2.16.

Сравнивались версии платформы 1С:Предприятие 8.3 (8.3.2.172) и 1С:Предприятие 8.2 (8.2.17.153)
Тестирование для режимов запуска "Тонкий клиент" и "Толстый клиент (управляемое приложение).

В серверной функции модуля формы внешнего отчета в платформе 8.2 успешно работает метод
 ПоместитьВоВременноеХранилище(ЭтотОбъект,УникальныйИдентификатор)  и в "Толстом" и в "Тонком" клиентах.

При запуске под платформой 8.3 метод не работает (и в "Толстом" и в "Тонком"), отображается сообщение об ошибке:
"Переданное значение не может быть помещено во временное хранилище".

Пока не знаю - это баг 8.3 или запланированное изменение поведение системы. Странно, что это проявляется в режиме совместимости с 8.2. На всякий случай отправил письмо на v8@1c.ru с описанием ситуации.

 

См. также

Инструментарий разработчика Роли и права Запросы СКД Программист Платформа 1С v8.3 Управляемые формы Запросы Система компоновки данных Конфигурации 1cv8 Платные (руб)

Набор инструментов программиста и специалиста 1С для всех конфигураций на управляемых формах. В состав входят инструменты: Консоль запросов, Консоль СКД, Консоль кода, Редактор объекта, Анализ прав доступа, Метаданные, Поиск ссылок, Сравнение объектов, Все функции, Подписки на события и др. Редактор запросов и кода с раскраской и контекстной подсказкой. Доработанный конструктор запросов тонкого клиента. Продукт хорошо оптимизирован и обладает самым широким функционалом среди всех инструментов, представленных на рынке.

10000 руб.

02.09.2020    141387    775    391    

804

Запросы СКД Программист Стажер Система компоновки данных Россия Бесплатно (free)

Часто при разработке отчетов в СКД возникает ситуация, когда не совсем понятно, почему отчет выводит не те данные, которые нужны, либо не выводит вовсе. Возникает потребность увидеть конечный запрос, который формирует СКД. Как это сделать, рассмотрим в этой статье.

15.05.2024    5377    implecs_team    6    

44

Инструментарий разработчика СКД Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

По выбранной схеме компоновки данных генерирует программный код, который генерирует СКД, аналогичную исходной схеме. Есть дополнительные инструменты для просмотра дерева схемы, сравнение исходной схемы и полученной по коду, а также сравнение изменений в сгенерированном коде для исходной схемы и для измененной.

3 стартмани

05.02.2024    5655    43    obmailok    21    

78

Запросы СКД Программист Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Есть список полей в виде текста, или запрос - закидываем в набор СКД.

1 стартмани

31.01.2024    2628    2    Yashazz    0    

33

СКД WEB-интеграция Программист Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Долгое время поддерживаю web-портал, в котором появилась необходимость создавать отчеты. Просмотрев различные фреймворки на js, я решил сделать свое решение, которое позволяло бы быстро разрабатывать и добавлять новые отчеты на web-портал.

2 стартмани

11.12.2023    9536    21    John_d    25    

124

СКД Программист Платформа 1С v8.3 Система компоновки данных Конфигурации 1cv8 Бесплатно (free)

Рассмотрим еще не получивший широкого распространения способ работы с внешними данным в СКД. В процессе обсуждения работы с СКД выяснилось, что многие не знакомы со способом помещения туда временной таблицы, полученной предварительно. Статья будет полезна разработчикам, знакомым с программным созданием СКД.

05.12.2023    6306    PROSTO-1C    13    

67
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. fixin 4262 29.07.12 00:05 Сейчас в теме
(0) Блжад, а ведь к этому методу я пришел самостоятельно... ;-)
Но рад что молодёжь тоше открыла его.
2. пользователь 01.08.12 12:47
Сообщение было скрыто модератором.
...
3. vec435 15 01.08.12 15:02 Сейчас в теме
вообще все не основные функ/проц можно вынести во внешнюю обработку. тогда в общем модуле получим код для вызова функ внешней обработки общиймодуль.во().внешняяфунк(парам1)
4. Flashback1979SE 15.08.12 04:15 Сейчас в теме
Вообще, клевый обход ограничения)). Спасибо за статью, теперь не придется "придумывать велосипед"). Побольше бы таких фишек, особенно для СКД.
5. powerpc 225 15.08.12 09:12 Сейчас в теме
Сорри, почему у меня ошибка как на скриншоте ???
Прикрепленные файлы:
6. sam441 219 23.08.12 09:18 Сейчас в теме
Спасибо, получилось, но есть момент не получается добавить расшифровку, формирование делаю так:
в модуле отчета процедура

Процедура ПриКомпоновкеРезультата(ДокументРезультат, ДанныеРасшифровки, СтандартнаяОбработка)
	
	СтандартнаяОбработка = Ложь;
	
	Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;
	ЭлементыНастроек = Настройки.ПараметрыДанных.Элементы;
	Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Отчет", ЭтотОбъект);
	
	КомпановщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпановки = КомпановщикМакета.Выполнить(СхемаКомпоновкиДанных,Настройки,ДанныеРасшифровки);
	
	ПроцессорКомпановки = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКомпановки.Инициализировать(МакетКомпановки,,ДанныеРасшифровки,Истина);
	
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
	ПроцессорВывода.УстановитьДокумент(ДокументРезультат);
	ПроцессорВывода.Вывести(ПроцессорКомпановки);
	
КонецПроцедуры
Показать

Выходит: Ошибка отображения типов:
Отсутствует отображение для типа 'ВнешнийОтчетОбъект.Тест'

Без параметра ДанныеРасшифровки работает, но ес-но расшифровка нет
10. hobi 616 01.01.13 13:44 Сейчас в теме
(6) sam441, (7) powerpc, публикацию поправил.
В последней выгрузке была ошибка с вызовом экспортной функции менеджера справочника.
Разбираться особо не стал, поскольку это экзотический вариант использования, на практике
нужны вызовы функций из модуля самого внешнего отчета. Просто убрал вызов функции менеджера
справочника.
Но прикрутил работу с расшифровкой , спасибо sam441 за замечания.
Отчет тоже слегка изменил - изменил источник данных с запроса на объект и использовал макет.
По поводу источника: с объектом,по моему мнению,работать удобнее, поскольку полностью контролируется процесс
получения данных (можно посмотреть ТЗ, временные таблицы и пр.). А запрос в схеме компоновки данных -
своего рода "черный ящик", внутрь которого особо не заглянешь.
И еще один нюанс - столкнулся в ЗУПе как-то с ситуацией, когда в обычном приложении, на SQL базе были проблемы
с правами при исполнении запроса внутри схемы компоновки данных. Поскольку (цитата из справки к платформе по методу УстановитьПривилегированныйРежим): "В клиент-серверном варианте при выполнении на клиенте данный метод не выполняет никаких действий"). Так вот, запрос внутри схемы компоновки данных, выполняется именно на клиенте (если клиент - толстый, обычное приложение).
После переноса запроса в модуль отчета и передачи результата (ТЗ) в виде объекта, всё чудесным
образом разрешилось. Это я все к тому, зачем изменил источник на объект.
7. powerpc 225 18.10.12 11:01 Сейчас в теме
У меня не работает все равно
8. powerpc 225 18.10.12 11:05 Сейчас в теме
9. hobi 616 18.10.12 21:52 Сейчас в теме
С расшифровкой отчет не пробовал, надо посмотреть, как прикрутить.
11. nanik 6 19.03.13 14:23 Сейчас в теме
С коллегами разбираем как раз вопросы об вычисляемых полях в компоновке данных, вернее ограничения (минимум функций, которые можно использовать). В Платформе 8.3 их уже конечно больше, но переходим на 8.2, да и 8.3 не покроет потребности, а выносить каждый раз их в общий модуль не выход.
12. nanik 6 19.03.13 14:25 Сейчас в теме
Подобная мысль была, а теперь есть и факт и реализация.
13. legrey 67 26.04.13 16:25 Сейчас в теме
Просто бобмба ! Очень кстати. Сэкономил кучу времени
14. Svb84 47 21.03.14 09:48 Сейчас в теме
Как в функции-посреднике вызывается функция модуля отчета?
15. Патриот 453 04.04.14 15:31 Сейчас в теме
(14) Svb84, я так написал:
//Данная функция позволяет использовать в вычисляемых полях СКД экспортные функции самого отчета
//Объект - ОтчетОбъект
//НаименованиеФункции - Имя экспортной функции этого объекта
//Парам1 - Парам9 - Параметры, которые будут переданы в эту функцию
Функция _Фу(Объект, НаименованиеФункции, Парам1 = Неопределено, Парам2 = Неопределено, Парам3 = Неопределено, Парам4 = Неопределено, Парам5 = Неопределено, Парам6 = Неопределено, Парам7 = Неопределено, Парам8 = Неопределено, Парам9 = Неопределено)Экспорт
	Результат = Неопределено;
	Если Не Объект = Неопределено Тогда 
		Попытка
			СписокПараметров = "";
			Для Итератор = 1 По 9 Цикл
				Если Не Вычислить("Парам" + Итератор + " = Неопределено") Тогда
					СписокПараметров = СписокПараметров + "Парам" + Итератор + ",";	
				КонецЕсли;
			КонецЦикла;
			СписокПараметров = Лев(СписокПараметров, СтрДлина(СписокПараметров) - 1);
			Результат = Вычислить("Объект." + НаименованиеФункции + "(" + СписокПараметров + ")");
		Исключение
			Сообщить("Ошибка при попытке нахождения вычисляемого поля. Ошибка в функции """ + НаименованиеФункции + """" + Символы.ПС + ОписаниеОшибки());
		КонецПопытки;
	Иначе
		Сообщить("Ошибка при попытке нахождения вычисляемого поля. Не задан Объект.");	
	КонецЕсли;
	Возврат Результат; 	
КонецФункции	
Показать
16. Патриот 453 04.04.14 15:46 Сейчас в теме
(0) Штука очень полезная, автору однозначно плюс. Но нужно было указать один важный момент - при закрытии отчета ссылку на объект (которую мы поместили в параметр компоновщика настроек) надо убить (присвоить этому параметру "неопределено"), иначе, после закрытия отчета, старый объект будет жить вплоть до завершения сеанса 1С. Кроме того, что это в принципе зло, это может помешать отладке отчета, т.к. все время будет запускаться старая версия (т.к. по факту отчет не будет перезапускаться).
user712426; +1 Ответить
17. user1004898 28 28.08.21 11:00 Сейчас в теме
я то думал обращение напрямую в экспортную функцию модуля отчета....
а так, не новинка по моему.
18. manny85 22.12.21 15:09 Сейчас в теме
Подскажите, можно ли в функцию общего модуля передать реквизит самого отчета? Или только описанной вами реализацией?
Спасибо.
19. nick_e 2 22.08.22 07:11 Сейчас в теме
Подскажите как это сделать?

в модуле формы этому параметру при запуске отчета присваиваем значение объекта;
20. hobi 616 25.08.22 15:31 Сейчас в теме
(19)
В архивном файле готовый пример. 10 лет назад публикацию разместил, всех подробностей не вспомню уже.
21. nick_e 2 29.08.22 06:37 Сейчас в теме
(20)Для платформы 8.3 выдает ошибку "переданное значение не может быть помещено во временное хранилище" связано с сериализуемыми значениями, в общем можно обойти поместив Объект в Соответствие, выглядит так.

во внешнем отчете

&НаСервере
Функция СоздатьСоответствие(Значение)

СоотвПараметр = Новый Соответствие;
// Ключ (произвольный тип) - Значение (произвольный тип)
СоотвПараметр.Вставить("ВнешнийОтчет", Значение);
Возврат СоотвПараметр ;
КонецФункции

&НаСервере
Процедура СформироватьОтчетНаСервере()
Результат.Очистить();
ЭтотОбъект=РеквизитФормыВЗначение("Отчет");

СхемаКомпоновкиДанных = ЭтотОбъект.ПолучитьМакет("ОсновнаяСхемаКомпоновкиДанных");
Настройки = СхемаКомпоновкиДанных.НастройкиПоУмолчанию;
ЭлементыНастроек = Настройки.ПараметрыДанных.Элементы;

Настройки.ПараметрыДанных.УстановитьЗначениеПараметра("Отчет", ПоместитьВоВременноеХранилище(СоздатьСоответствие(ЭтотОбъект),УникальныйИдентификатор));

ДанныеРасшифровкиСКД = Новый ДанныеРасшифровкиКомпоновкиДанных;
// Получим в ТЗ результат запроса
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| Банки.Ссылка,
| Банки.Наименование
|ИЗ
| Справочник.Банки КАК Банки";
ТЗ = Запрос.Выполнить().Выгрузить();
ВнешниеНаборыДанных = Новый Структура;
ВнешниеНаборыДанных.Вставить("ДанныеОтчета",ТЗ);

КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
МакетКомпоновки = КомпоновщикМакета.Выполнить(СхемаКомпоновкиДанных,Настройки,ДанныеРасшифровкиСКД);
ПроцессорКомпоновкиДанных = Новый ПроцессорКомпоновкиДанных;
ВозможностьИспользованияВнешнихФункций = Истина;
ПроцессорКомпоновкиДанных.Инициализировать(МакетКомпоновки,ВнешниеНаборыДанных ,ДанныеРасшифровкиСКД,ВозможностьИспользованияВнешнихФункций);
ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВТабличныйДокумент;
ПроцессорВывода.УстановитьДокумент(Результат);
ПроцессорВывода.Вывести(ПроцессорКомпоновкиДанных);

Отчет.ДРасш = ПоместитьВоВременноеХранилище(ДанныеРасшифровкиСКД,УникальныйИдентификатор);
Результат.ОтображатьСетку = Ложь;
Результат.ОтображатьЗаголовки = Ложь;
КонецПроцедуры

Показать


в общем модуле


&НаСервере
Функция ПолучитьСоответствие(Значение)

СоотвПараметр =Значение.Получить("ВнешнийОтчет");
Возврат СоотвПараметр ;
КонецФункции

&НаСервере
Функция Фу(Отчет,ИмяОтчета,
Пар0 = Неопределено,
Пар1 = Неопределено,
Пар2 = Неопределено,
Пар3 = Неопределено,
Пар4 = Неопределено,
Пар5 = Неопределено,
Пар6 = Неопределено,
Пар7 = Неопределено,
Пар8 = Неопределено,
Пар9 = Неопределено) Экспорт

Перем Результат;

Отч = ПолучитьСоответствие(ПолучитьИзВременногоХранилища(Отчет));
Выполнить("Результат = Отч."+СокрЛП(ИмяОтчета)+"(Пар0,Пар1,Пар2,Пар3,Пар4,Пар5,Пар6,Пар7,Пар8,Пар9)");
Возврат Результат;
КонецФункции

Показать
Оставьте свое сообщение