Чтение задачи с Битрикс24 (Reading task with Bitrix24)

06.11.21

Интеграция - WEB-интеграция

Обработка используется для чтения "Задач" из "Bitrix24" через встроенные "WebHook".

Скачать исходный код

Наименование Файл Версия Размер
Чтение задачи с Битрикс24 (Reading task with Bitrix24):
.epf 11,52Kb
11
.epf 11,52Kb 11 Скачать

Цель:

Автоматизировать процессы, создать документы в 1С (создания самого документа не будет описан) на основания задач CRM в"Bitrix24".

Платформа 8.3.17.1386, любая конфигурация, обычные формы.

Описания подсистемы и требования:

  1. В «Bitrix24» создаем «WebHook» описав соответствующие роли, доступы к подсистемам.

Пример:

 

 

  1. В «Bitrix24» создаем группу. Я это использую в качестве фильтра для тех заданий которые нужно переносить в 1С.
  2. В 1С создаем регистр сведение, например, «СоответсвиеИдБ24», он нужен для идентификации данных по ИД из Б24 с данными в 1С и для проверки, был ли уже создан документ или нет.

Измерения регистра:

            ИДБ24 - (Тип строка)

            ОсновнойКонтрагент – (тип Булево)

            Значение1С – (тип «Пользователь», «Контрагент», «Документ» вы можете

расширить количество типов по мере необходимости)

  1. В 1С для автоматизации можете создать «Регламентированное задания» - у меня периодичность 5 мин.
  2. В 1С создайте обработку для взаимодействия с «Bitrix24»

 

Инструкция к созданию задания в «Bitrix24»

  1. Создайте задания (Плюс или на основания «Компании» из CRM)
  2. Укажите заголовок
  3. Сделайте описания задачи
  4. Прикрепите картинки или вставьте их в текст задания
  5. Укажите «Создателя»
  6. Укажите «Исполнителя»
  7. Укажите группу по которой будет проходить идентификация наших заданий

Нюансы при создании:

  1. В нашем р.с.: «СоответсвиеИдБ24» вы можете указать ИД любой группы при создания документа система буде подтягивать «Контрагента» по данному ИД (Отбор всех контрагентов строго по типу справочник «Контрагент») Так система понимает какие задания затягивать в 1С
  2. При создание задания в «Bitrix24» если прописать в «Заголовке» - «Любой текст, плюс 'КодПоЕДРПОУ' клиента» то система создаст задания в 1С с контрагентом которого найдет по данному 'КодПоЕДРПОУ' такой контрагент имеет больше приоритет.
  3. Задания в Б24 можно создавать на основания «Компании» из CRM системы, в 1С подставиться соответствующий контрагент (Одно условия CRM в Б24 должно было наполнено выгрузкой из 1С, поиск по GUID)

Описание обработки:

Методы,  которые использовались из «Bitrix24» API (Документация «https://dev.1c-bitrix.ru/rest_help/»)

 

- task.item.list  - https://dev.1c-bitrix.ru/rest_help/tasks/task/tasks/tasks_task_list.php

Описания: Возвращает массив задач, каждая из которых содержит массив полей. В отличие от task.item.list параметры в запросе tasks.task.list можно указывать в любом порядке, а также можно не указывать ненужные параметры.

 

- disk.attachedObject.get - https://dev.1c-bitrix.ru/rest_help/disk/attachedobject/disk_attachedobject_get.php

Описания: Возвращает информацию о прикрепленном файле через пользовательское свойство по идентификатору привязки.

 

- task.item.getfiles - https://dev.1c-bitrix.ru/rest_help/tasks/task/item/getfiles.php

Описания: Возвращает массив, содержащий ссылки на файлы, прикрепленные к задаче.

 

- crm.company.list - https://dev.1c-bitrix.ru/rest_help/crm/company/crm_company_list.php

Описания: Возвращает список компаний по фильтру. Является реализацией списочного метода для компаний.

 

1. Соединения
 

//Создаем соединения с Б24
Попытка
	
	HTTPСоединение = Новый HTTPСоединение("bitrix24.com", ,Логин, Пароль,,,Новый ЗащищенноеСоединениеOpenSSL());	
	
Исключение
	ТекОшибка = ОписаниеОшибки();
	ЗаписьЖурналаРегистрации("ОшибкаОбменаСБитрикс",,Метаданные.РегламентныеЗадания.ЗагрузкаЗадачИзБ24,ТекОшибка);
	Сообщить(ОписаниеОшибки());
	Возврат;
КонецПопытки;

2. Общая процедура, куда передают метод для запроса (КОД ЧАСТИЧНО ИЗМЕНЕН)

Функция HTTPСоед(Н, Група, НачПериода, СоотПол, HTTPСоединение, СтрНомер = Неопределено, Metod)	
	ТекОшибка = "Произошла сетевая ошибка!";

	//Метод с АПИ для получения задач с фильтром
	Если Metod = "task.item.list" Тогда
		ID 			= "?0[ID]=desc";
		GROUP_ID    = "&1[GROUP_ID]="+Група;
		CREATED_DATE= "&1[>CREATED_DATE]="+НачПериода;
		NAV_PARAMS  = "&2[NAV_PARAMS][nPageSize]=50&2[NAV_PARAMS][iNumPage]="+Н;
		ALL			= "&3[0]=*";
		
		HTTPЗапрос    = Новый HTTPЗапрос(Metod+ID+CREATED_DATE+GROUP_ID+NAV_PARAMS+ALL);
		
	//Работа с файлами
	ИначеЕсли Metod = "disk.attachedObject.get" ИЛИ Metod = "task.item.getfiles" Тогда
		
	    ID			= "?id=";

		HTTPЗапрос  = Новый HTTPЗапрос(Metod+ID+СтрНомер);
		
	//Для получения компаний	
	ИначеЕсли Metod = "crm.company.list" Тогда
		
	    ID			= "?filter[ID]=";

		HTTPЗапрос  = Новый HTTPЗапрос(Metod+ID+СтрНомер);

	КонецЕсли;
	
	Попытка
		Результат =  HTTPСоединение.Получить(HTTPЗапрос);
	Исключение
		// исключение здесь говорит о том, что запрос не дошел до HTTP-Сервера
		ЗаписьЖурналаРегистрации("ОшибкаОбменаСБитрикс",,Метаданные.РегламентныеЗадания.ЗагрузкаЗадачИзБ24, ТекОшибка);
		Сообщить(ОписаниеОшибки());
		Возврат Неопределено;
	КонецПопытки;
	
	Возврат Результат;
	
КонецФункции

3. Чтение результата и наполнение таблицы значений

4. Создание документов 
       4.1. Поиск контрагентов

       4.2. Поиск картинок и подключение их к документам или к справочникам

Процедура СоздатьДокументы(Строка, СоотКонт, СоотПол, HTTPСоединение) 
	ТекОшибка = "Произошла сетевая ошибка!";

	//Вычитаем КодЕДРПОУ из заголовка, ищем контрагента
	пКонтрагент = ПоискатьКодЄДРПОУ(Строка.TITLE);
	Если пКонтрагент = Неопределено Тогда
		//Ищем контрагента если задания было создано на основании Клиента ИЗ СРМ системи Битрикс24
		пКонтрагент = ПолучитьКонтрагентаПоДанихСРМБ24(Строка.DESCRIPTION, HTTPСоединение);
	КонецЕсли;
	
	//Создаем массив с файлами
	МассивКартинок = Новый Массив;
	ПолучитьПрикрепленныеФайлы(Строка.ID, МассивКартинок, HTTPСоединение);
	
	УдалитьЛишниеЗнаки(Строка.TITLE);
	УдалитьЛишниеЗнаки(Строка.DESCRIPTION);
	
	//Добавляем ссылку на задачу в Б24
	Строка.DESCRIPTION = "Ссылка к заданию в Б24:"+ Символы.ПС
	+ "https://bitrix24.com/company/personal/user/26/tasks/task/view/"+Строка.ID+"/"+Символы.ПС
	+ "------------------------------------------------------------------------------"
	+ Символы.ПС
	+ Строка.DESCRIPTION;
	
	
	//Посик контрагента в Соответствие
	пКонтр = Неопределено;
	Если ТипЗнч(СоотКонт) = Тип("Соответствие") Тогда
		пКонтр = СоотКонт.Получить(Строка.CODE_PARTNER);
	ИначеЕсли ТипЗнч(СоотКонт) = Тип("СправочникСсылка.Контрагенты") И ЗначениеЗаполнено(СоотКонт) Тогда
		пКонтр = СоотКонт;
	КонецЕсли;

	//ПРИМЕР СОЗДАНИЯ ДОКУМЕНТА (Подставте свой)
	пДокумент = Документы.РеализацияТоваровУслуг.СоздатьДокумент();	
	пДокумент.Контрагент = пКонтр;
	
	пНаименование   	 = Строка.TITLE;
	пОписание       	 = Строка.DESCRIPTION;
	
	Попытка
		пДокумент.Записать(РежимЗаписиДокумента.Проведение);
	Исключение
		пДокумент.Записать(РежимЗаписиДокумента.Запись);
	КонецПопытки;
	
	ПрикрепитьКартинку(пДокумент.Ссылка, МассивКартинок, HTTPСоединение);
			
	ЗаписатьРВСоответсвиеИдБ24(пДокумент, Строка);
КонецПроцедуры

 

См. также

Интеграция Альфа Авто 5 / Альфа Авто 6 и AUTOCRM / Инфотек

Сайты и интернет-магазины WEB-интеграция Системный администратор Программист Пользователь Платформа 1С v8.3 Конфигурации 1cv8 1С:Управление торговлей 11 Автомобили, автосервисы Россия Управленческий учет Платные (руб)

Интеграционный модуль обмена между конфигурацией Альфа Авто 5 и Альфа Авто 6 и порталом AUTOCRM. Данный модуль универсален. Позволяет работать с несколькими обменами AUTOCRM разных брендов в одной информационной базе в ручном и автоматическом режиме.

36000 руб.

03.08.2020    16262    14    18    

14

Интеграция 1С и Битрикс 24 — модуль синхронизации для обмена задачами

Сайты и интернет-магазины Интеграция WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Управленческий учет Платные (руб)

Интеграция 1С и Битрикс 24. Разработка имеет двухстороннюю синхронизацию 1С и Bitrix24 задачами. Решение позволяет создавать пользователя в 1С из Битрикс24 и наоборот. Данная разработка технически подходит под все основные конфигурации линейки продуктов 1С:Предприятие 8.3 (платформа начиная с 8.3.23). При приобретении предоставляется 1 месяц бесплатных обновлений разработки. Доступна демо-версия продукта с подключением Вашего Битрикс24

5040 руб.

04.05.2021    18446    10    15    

16

Модуль для обмена "1С:Предприятие 8. УАТ. ПРОФ" с FortMonitor

WEB-интеграция 8.3.8 Конфигурации 1cv8 Автомобили, автосервисы Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Расширение предназначено для конфигурации "1С:Предприятие 8. Управление Автотранспортом. ПРОФ". Функционал модуля: 1. Заполнение регистров сведений по подсистеме "Мониторинг", а именно: события по мониторингу, координаты по мониторингу, пробег и расход по мониторингу, текущее местоположение ТС по мониторингу 2. Заполнение путевого листа: пробег по мониторингу, время выезда/заезда, табличная часть ГСМ, места стоянок по геозонам. 3. Отчеты по данным загруженным в регистры сведений. 4. Предусмотрена автоматическая загрузка данных в фоновом режиме (условия работы данной загрузке читайте в описании товара) Модуль работает без включенной константы по настройкам мониторинга. Модуль формы предоставляется с открытым кодом, общий модуль защищен. Любой заинтересованный пользователь, имеет возможность скачать демо-версию расширения.

22656 руб.

25.05.2021    13109    34    8    

13

Автоматическая загрузка файлов (например, прайс-листов) из электронной почты, FTP, HTTP, их обработка и выгрузка на FTP (на сайт) и для других целей

Прайсы WEB-интеграция Ценообразование, анализ цен Файловый обмен (TXT, XML, DBF), FTP Системный администратор Программист Автомобили, автосервисы Оптовая торговля, дистрибуция, логистика Управленческий учет Платные (руб)

Программа с заданным интервалом времени (или по ручной команде) скачивает файлы (например, прайс-листы поставщиков) из различных источников: письма электронной почты, FTP или HTTP-адреса, и сохраняет их в каталог упорядоченной структуры. При этом извлекает файлы из архивов, может переименовывать файлы и менять их формат (csv, xls, txt). Можно настроить выгрузку обработанных файлов на сайт (через FTP-подключение). Программа будет полезна компаниям, у которых есть большое количество поставщиков и/или прайс-листы поставщиков обновляются часто (необязательно прайс-листы, файлы могут быть любого назначения). Собранные таким образом актуальные версии прайс-листов можно выгрузить с помощью программы себе на сайт (или на любой FTP-сервер) или выполнить другие необходимые задачи.

25200 руб.

28.05.2015    85773    26    51    

50
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. novatrade 03.12.21 22:25 Сейчас в теме
Насколько я помню, для использования вебхука не нужен ни логин, ни пароль. Есть ключ ведхука, которій используется для подключения.
2. ArvidasSabonisaBE 13 01.02.22 16:02 Сейчас в теме
Оставьте свое сообщение