Подсистема настройки отображения штрих-кода

14.11.17

Задачи пользователя - Этикетки, ценники

При работе сталкивался с задачей настройки отображения штрих-кодов в нескольких ситуациях, например, этикетках и ценниках, произвольных печатных формах клиентов для их поиска сканером. При этом необходимо учесть множество нюансов - размер, кодировка, макет. Например для кодирования договоров клиент очень не хотел цифры и тысячи раз просил "немного" подвинуть и поменять шрифт.

Скачать исходный код

Наименование Файл Версия Размер
НастройкаШтрихкода.cf
.cf 4,85Mb
7
.cf 4,85Mb 7 Скачать
Демо настройка ШК 0.2.dt
.dt 8,85Mb
8
.dt 8,85Mb 8 Скачать

Для упрощения реализован справочник для настройки отображения штрих-кода и процедура получения изображения по настройке.

Далее этот шаблон можно использовать в обработке печати этикеток и ценников, для печати в любом вашем макете. Легко интеигрируется  и адаптируется под любые конфигурации.

Я всего лишь программист, поэтому поставляется "как есть" и способы использования и применение полностью на ваше усмотрение. Надеюсь, пригодится для основы.

 

UPD 2013/11/01

Версия для управляемых форм. Мелкие правки для удобства использования. Добавлен пример использования.

 

Как же все таки этим воспользоваться? Очень просто. Объедините три объекта приложенной конфигурации с вашей и в необходимых местах и печатных формах добавьте картинку. Код для вывода изображения штрих-кода картинки:

 

&НаСервере
Процедура УстановитьШтрихкод(Знач Штрихкод, Рисунок, ВнешняяКомпонента)

	Если НЕ ЗначениеЗаполнено(Штрихкод) Тогда 
		Возврат;
	КонецЕсли;	
	
	Справочники.ШаблоныШтрихкодов.УстановитьРисунокШтрихкода(Рисунок, Объект.ШаблонШтрихкода, ВнешняяКомпонента, Штрихкод);

КонецПроцедуры

&НаСервере
Процедура СформироватьСервер(ТабДок = Неопределено)
	
	Если ТабДок = Неопределено Тогда 
		ТабДок = Новый ТабличныйДокумент;
	КонецЕсли;	
....

// шаблон искать по наименованию или где-то хранить в разрезе ПФ
	Если ЗначениеЗаполнено(Объект.ШаблонШтрихкода)
Тогда 
		
		ВнешняяКомпонента = Неопределено;
		Для Каждого Рисунок Из ТабДок.Рисунки Цикл 
			Если Найти(Рисунок.Имя, "Штрихкод") > 0 Тогда 
				Штрихкод = ""; // его надо хранить для печатной формы
				УстановитьШтрихкод(Штрихкод, Рисунок, ВнешняяКомпонента);
			КонецЕсли;	
		КонецЦикла;
		
	КонецЕсли;


КонецПроцедуры// СформироватьРисунок()

 

штрихкод штрих-код печать шк печатные формы

См. также

Штрих-коды в шаблоне этикетки

Этикетки, ценники Программист Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Россия Управленческий учет Платные (руб)

Решение позволяет в шаблон этикетки с типом "Этикетка (обувь, одежда, табак...)" добавлять штрих-коды другого типа, например, GTIN в Code128.

4000 руб.

09.06.2021    15318    8    6    

12

Ценники и этикетки со штрих-кодом для 1С 8.х любой конфигурации

Этикетки, ценники Пользователь Платформа 1С v8.3 Конфигурации 1cv8 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Беларусь Украина Россия Управленческий учет Платные (руб)

Простая в использовании обработка для формирования и печати ценников и этикеток со штрих-кодом, с дополнительной ценой, для 1С8.х любой конфигурации. Большое разнообразие шаблонов печатных форм. Управляемая форма (Такси) + Обычный режим.

3588 руб.

11.11.2020    48236    55    44    

65

Печать ценников. (Розница 2.3, УНФ 1.6, две цены + серийные номера) + УНФ 3.0

Этикетки, ценники Пользователь Платформа 1С v8.3 Управляемые формы 1С:Розница 2 1С:Управление нашей фирмой 1.6 Платные (руб)

Встроенная в конфигурации Розница 2.3 и УНФ 1.6 подсистема печати ценников по мне слишком неповоротлива и с усилиями поддается тонкой настройке, решил с нуля написать свою универсальную печать ценников для этих конфигураций.

2000 руб.

04.11.2019    28507    113    87    

52

Печать из Андроид

Этикетки, ценники Программист Мобильная платформа Бесплатно (free)

Печать этикеток на принтер WiFi без драйвера.

20.01.2023    2023    aldar    0    

8

Ценники (этикетки) для термопринтера

Этикетки, ценники Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Абонемент ($m)

Внешняя печатная форма для принтера этикеток. В отличие от базовой обработки для печати этикеток эта может выводить на печать дополнительные свойства справочника Номенклатура, а также в ней несложный программный код, что позволяет легко дорабатывать обработку под свои нужды.

2 стартмани

03.01.2023    3297    21    AndreyPonom    7    

10

Набор готовых макетов этикеток (ценников) для Розницы 2.3

Этикетки, ценники Пользователь Платформа 1С v8.3 1С:Розница 2 Розничная и сетевая торговля (FMCG) Россия Управленческий учет Абонемент ($m)

Архив с экспортными шаблонами этикеток (ценников) формата 58х40. Для тех, кто не хочет сам рисовать их.

2 стартмани

04.05.2022    12798    44    aximo    3    

11

Шаблон этикетки для УНФ (1С:Фреш)

Этикетки, ценники Программист Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Описан механизм создания этикетки для термопринтера ТSC TDP-225 в подробностях. Приложен XML-файл с самим шаблоном.

1 стартмани

01.05.2022    11774    6    zemskov    7    

5
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. seermak 665 31.10.13 12:40 Сейчас в теме
Уже рисунки за стартмани пошли? Круто....
2. fuxic 297 31.10.13 14:26 Сейчас в теме
3. Vyacheslav56 13 01.11.13 07:35 Сейчас в теме
Будет ли работать в УНФ?
4. kovaleks78 4 01.11.13 07:51 Сейчас в теме
(3) Vyacheslav56, без доработки, как я понимаю - не будет.
5. fuxic 297 05.11.13 10:40 Сейчас в теме
(3) Интегрируется с помощью программиста. Квалификация не играет большой роли, в публикации и демо-базе приведен пример и описание.

(4) Не будет. Но на основании этого можно встроить в систему механизм штрих-кодирования любых печатных форм в вашей учетной системе.
Оставьте свое сообщение