Исправление ошибки при сканировании штрихкода в рабочем месте кассира (по патчу EF_00_00631982). Ошибка и в патче, и в типовом коде

20.05.24

Задачи пользователя - Корректировка данных

После обновления Розницы на версию 3.0.8.40, платформа 8.3.24.1548, в рабочем месте кассира не сканируется товар (выбивает ошибку), но при этом можно можно подобрать товар через стандартное окно поиска (лупа в верхней части экрана). При подборе через плиточный интерфейс также ошибка. Был выпущен патч, где через директиву &Вместо пытались решить проблему, но не вышло. Решение: выключаем пачт, загружаем расширение

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки для того, чтобы самостоятельно ее доработать для вашей базы данных. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в вашей базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке Купить один файл
При сканировании штрихкода в рабочем месте кассира выбивает ошибку EF_00_00631982:
.cfe 8,03Kb
0
0
1 SM
Скачать Купить за 1 850 руб.

Прикладываю исправленный патч(загрузить вместо исходного через конфигуратор)

Или же можно вписать исправление самостоятельно

Перед  строками:

Если НайденаНоменклатура Тогда
            ПараметрыПоискаРМК.ФильтрПоискаПоШтрихкоду.Вставить("ЗаданнаяТаблицаНоменклатуры", ДанныеПоШтрихкодамРезультат);
КонецЕсли;


Вставить:
   

 Если НЕ ПараметрыПоискаРМК.Свойство("ФильтрПоискаПоШтрихкоду") Тогда        
            ФильтрПоискаПоШтрихкоду = Новый Структура;
            ПараметрыПоискаРМК.Вставить("ФильтрПоискаПоШтрихкоду",ФильтрПоискаПоШтрихкоду);
 КонецЕсли;

Если ПараметрыПоискаРМК.ФильтрПоискаПоШтрихкоду = Неопределено Тогда
			ФильтрПоискаПоШтрихкоду = Новый Структура;
			ПараметрыПоискаРМК.Вставить("ФильтрПоискаПоШтрихкоду",ФильтрПоискаПоШтрихкоду);
КонецЕсли;


Но обратите внимание, в исходном коде используется имя "ПарамтерыПоискаРМК". Мне глаз резало, поправил опечатку, соответственно и вам нужно будет при ручном изменении кода либо писать с опечаткой как у 1С, либо исправить в модуле через замену значений(ctrl + h).

Проверено на следующих конфигурациях и релизах:

  • Розница, редакция 3.0, релизы 3.0.8.40

Розница 3 РМК ошибка при сканировании товара

См. также

Закрытие периода Инструменты администратора БД Корректировка данных Бухгалтер Пользователь Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Расширение «Оперативное проведение» в 4 раза уменьшает время проведения документов и закрытия месяца. Является комплексным решением проблем 62 и 60 счетов. Оптимизирует проведение при включенной функциональной опции «Раздельный учет НДС». Используется в более 10 организациях уже 2 года. Совместимо с конфигурацией Бухгалтерия 3.0 (+КОРП).

14400 руб.

29.04.2020    29593    87    151    

63

Адаптация типовых решений Платформа 1С v8.3 1С:Документооборот Россия Платные (руб)

Расширение конфигурации для «1С:Документооборот КОРП», редакция 3.0. позволяет: 1.использовать произвольные табличные части в качестве дополнительных реквизитов к документу; 2 использовать произвольные табличные части в шаблонах в формате docx для автоматического заполнения таблиц.

29400 руб.

29.06.2023    5037    11    5    

20

Корректировка данных Системный администратор Программист Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Платные (руб)

Незаменимая обработка для сопровождения конфигураций: ERP, УТ, КА. Позволяет вычистить многие ошибки в ключах аналитики, в ключевых справочниках конфигурации.

3600 руб.

10.02.2017    108415    645    173    

686

Корректировка данных Зарплата Бухгалтер Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и Управление Персоналом 3.x Россия Бухгалтерский учет НДФЛ Платные (руб)

Обработка исправляет технические ошибки по НДФЛ, взаиморасчетам с сотрудниками в 1С:ЗУП (1С:ЗКГУ) на начало года. Фактически все ошибки, которые проявляются в ведомостях на выплату, расчетных листках, при заполнении ведомостей на выплату и отчетах 6-НДФЛ и т.д. нужно начинать исправлять с начала расчетного года. Это позволит быть уверенными, что после завершения расчетов предыдущего года, начали работать с «чистого листа» без ошибочных остатков.

4800 руб.

06.10.2023    3315    33    17    

40

Логистика, склад и ТМЦ Адаптация типовых решений Пользователь Платформа 1С v8.3 1С:Управление нашей фирмой 1.6 1С:Управление нашей фирмой 3.0 Россия Управленческий учет Платные (руб)

Чтобы не допустить путаницы с обещаниями клиентам и для четкого контроля исполнения заказов мы используем резервирование товаров. Мы доработали УНФ, чтобы она автоматически отменяла старые резервы и не мешала эффективно продавать.

7200 руб.

02.08.2023    3404    7    0    

26

Корректировка данных Зарплата Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Платные (руб)

Внешняя обработка предназначена для исправления самых различных ошибок, возникших по самым разным причинам. Общее проявление этих ошибок видно в различии данных между: проводками и различными отчетами по НДФЛ, заполнении ведомостей на выдачу зарплаты, неверным расчетом НДФЛ при начислении ЗП и т.д.

3600 руб.

09.02.2024    1172    6    5    

9

Закрытие периода Корректировка данных Бухгалтер Пользователь Платформа 1С v8.3 Оперативный учет 1С:Управление торговлей 11 Управленческий учет Платные (руб)

Закрытие месяца - важный процесс в современных конфигурациях, таких как УТ 11.4, УТ 11.5, КА 2.4, КА 2.5 ERP 2.4,ERP 2.5, КА 2 Казахстан, УТ 3 Казахстан регламентные операции влияют на расчет себестоимости, и ошибки в данном расчете не дают картины деятельности организации.

2400 руб.

27.10.2021    23238    304    35    

76
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Zombee-Nations 21.05.24 10:51 Сейчас в теме
Почему такие важные вещи разработчики не проверяют. Периодически после обновлений эта маркировка отваливается. Как продать клиенту тот же фреш не знаю.
2. fixman 1 21.05.24 15:02 Сейчас в теме
(1)Порой кажется что за выпуск релизов розницы/1с РМК отвечает вчерашний студент-стажер, которого перегрузили задачами. Очередная обнова как рулетка, что отвалится в этот раз.
Оставьте свое сообщение