Массовая загрузка контрагентов в базу по ИНН

29.05.24

Интеграция - WEB-интеграция

Данная обработка позволит вам загрузить контрагентов списком по ИНН, используя сервис DADATA.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
Массовая загрузка контрагентов в базу по ИНН:
.epf 13,09Kb
1
1
9 SM
Скачать Купить за 4 250 руб.

Введение

Эта небольшая обработка родилась совершенно случайно - мне необходимо было перенести некоторые данные из старой базы 7.7 (с кучей ошибок). По контрагентам - я решил выгрузить список ИНН из старой базы и актуализировать его через бесплатный сервис dadata.

При разработке я использовал типовую конфигурацию Бухгалтерия ПРОФ 3.0.151.38 и 1С:Предприятии 8.3.22.2411. Дополнительных условий - кроме ключа API для сервиса dadata не требуется. В современных типовых должна работать.

 

Содержание

Принцип работы такой - вы вводите ключ API в форме обработки, выбираете каталог, куда должны быть сохранены новые контрагенты и добавляете список ИНН в табличную часть. Далее, нажимаете "Загрузить контрагентов" и они сохраняются в ваш каталог. Все это демонстрируется на рисунке:

 

Рис.1 Обработка загрузки контрагентов по ИНН массовым списком.

 

Заключение

В текущем материале приведена рабочая обработка для конфигурации Бухгалтерия ПРОФ 3.0.151.38. Стоимость скачки демофайла - 9СМ (в качестве меры поддержки автора).

 

Обратите Ваше внимание на полезные обработки автора:

Пример внешней печатной формы с предварительным выводом параметров

Длительные операции - использование в БСП 3.1.8. Актуализация на июнь 2023

Гибкие отборы через СКД на управляемых формах. Демо-обработка

Базовые принципы работы с регламентными заданиями подсистем БСП

 

Все материалы автора на портале бесплатны и в открытом доступе. Более интересные материалы и обработки - вы можете найти в телеграмм канале автора (по нику) - это бесплатные обмены, обработки, универсальные отчеты, моментальные обмены (переносы данных), работа с планами управленческих и бухгалтерских счетов, бухгалтерские отчеты, разные хитрости и другие полезные "фичи". Присоединяйтесь на канал - поддержите автора.

 

Все, кто хочет связаться с автором, - можете связаться со мной через личный профиль, а также мой телеграмм-канал (по нику автора).

Проверено на следующих конфигурациях и релизах:

  • Бухгалтерия предприятия, редакция 3.0, релизы 3.0.151.38

загрузка контрагентов инн массово бухгалтерия dadata

См. также

Сайты и интернет-магазины Интеграция WEB-интеграция Платформа 1С v8.3 Конфигурации 1cv8 Управленческий учет Платные (руб)

Интеграция 1С и Битрикс 24. Разработка имеет двухстороннюю синхронизацию 1С и Bitrix24 задачами. Решение позволяет создавать пользователя в 1С из Битрикс24 и наоборот. Данная разработка технически подходит под все основные конфигурации линейки продуктов 1С:Предприятие 8.3 (платформа начиная с 8.3.23). При приобретении предоставляется 1 месяц бесплатных обновлений разработки. Доступна демо-версия продукта с подключением Вашего Битрикс24

5040 руб.

04.05.2021    18995    10    16    

17

Управление взаимоотношениями с клиентами (CRM) WEB-интеграция Анализ продаж Системный администратор Программист Пользователь Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 1С:Комплексная автоматизация 2.х Управленческий учет Платные (руб)

Подсистема интеграции Amo CRM с 1С: технические требования, порядок работы, возможности, доработки и обновления. Бесплатный период техподдержки - 1 месяц.

60000 руб.

07.05.2019    31867    62    40    

23

Сайты и интернет-магазины WEB-интеграция Системный администратор Программист Пользователь Платформа 1С v8.3 Конфигурации 1cv8 1С:Управление торговлей 11 Автомобили, автосервисы Россия Управленческий учет Платные (руб)

Интеграционный модуль обмена между конфигурацией Альфа Авто 5 и Альфа Авто 6 и порталом AUTOCRM. Данный модуль универсален. Позволяет работать с несколькими обменами AUTOCRM разных брендов в одной информационной базе в ручном и автоматическом режиме.

36000 руб.

03.08.2020    16743    15    19    

15

WEB-интеграция Программист Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бытовые услуги, сервис Платные (руб)

Внешняя обработка разрабатывалась для загрузки документов из Ветменеджер в 1С: Бухгалтерия 3.0

12000 руб.

02.02.2021    16998    45    49    

26

WEB-интеграция 8.3.8 Конфигурации 1cv8 Автомобили, автосервисы Беларусь Украина Россия Казахстан Управленческий учет Платные (руб)

Расширение предназначено для конфигурации "1С:Предприятие 8. Управление Автотранспортом. ПРОФ". Функционал модуля: 1. Заполнение регистров сведений по подсистеме "Мониторинг", а именно: события по мониторингу, координаты по мониторингу, пробег и расход по мониторингу, текущее местоположение ТС по мониторингу 2. Заполнение путевого листа: пробег по мониторингу, время выезда/заезда, табличная часть ГСМ, места стоянок по геозонам. 3. Отчеты по данным загруженным в регистры сведений. 4. Предусмотрена автоматическая загрузка данных в фоновом режиме (условия работы данной загрузке читайте в описании товара) Модуль работает без включенной константы по настройкам мониторинга. Модуль формы предоставляется с открытым кодом, общий модуль защищен. Любой заинтересованный пользователь, имеет возможность скачать демо-версию расширения.

22656 руб.

25.05.2021    13370    36    8    

15
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. ISStill 29.05.24 11:35 Сейчас в теме
через бесплатный сервис dadata

а в каком варианте он бесплатный?
fort13; kasper076; +2 Ответить
2. svbel85 59 29.05.24 13:37 Сейчас в теме
адреса заполнит по классификатору ?
3. quazare 3728 29.05.24 13:47 Сейчас в теме
Адреса заполняет в на том уровне, который нужен был мне…. Можете доработать - БСП в помощь - код открыт!
4. quazare 3728 31.05.24 11:54 Сейчас в теме
(1) я думаю, что вам стоит зарегистрироваться на данном сервисе и определить самостоятельно. В крайнем случае - почитать мануалы по их апи
5. andrew.ab 220 01.06.24 23:38 Сейчас в теме
Что-то дорого 9ФМ.

Процедура ЗагрузитьКонтрагентаИзDaData(ИНН)
// Ваш API-ключ DaData
APIКлюч = "ВАШ_API_КЛЮЧ";

// URL для запроса к API DaData
URL = "https://suggestions.dadata.ru/suggestions/api/4_1/rs/findById/party";

// Формируем тело запроса
ТелоЗапроса = Новый Структура("query", ИНН);

// Создаем HTTP-запрос
Запрос = Новый HTTPЗапрос(URL);
Запрос.УстановитьЗаголовок("Content-Type", "application/json");
Запрос.УстановитьЗаголовок("Authorization", "Token " + APIКлюч);
Запрос.УстановитьТелоЗапроса(СтрФорматJSON(ТелоЗапроса));

// Выполняем запрос
HTTPСоединение = Новый HTTPСоединение();
Ответ = HTTPСоединение.Выполнить(Запрос);

// Обрабатываем ответ
Если Ответ.КодСостояния = 200 Тогда
ТекстОтвета = Ответ.ПолучитьТелоКакСтроку();
JSONОтвет = ПрочитатьJSON(ТекстОтвета);

// Извлекаем данные о контрагенте
Если JSONОтвет.Тип = Тип("Структура") И JSONОтвет.Свойства.Содержит("suggestions") Тогда
Контрагенты = JSONОтвет.suggestions;
Если Контрагенты.Количество() > 0 Тогда
Контрагент = Контрагенты[0];
// Пример извлечения данных
Наименование = Контрагент.value;
ПолноеНаименование = Контрагент.data.name.full_with_opf;
Адрес = Контрагент.data.address.value;

// Создание нового контрагента в 1С
НовыйКонтрагент = Справочники.Контрагенты.СоздатьЭлемент();
НовыйКонтрагент.Наименование = Наименование;
НовыйКонтрагент.ПолноеНаименование = ПолноеНаименование;
НовыйКонтрагент.ЮридическийАдрес = Адрес;
НовыйКонтрагент.ИНН = ИНН;
НовыйКонтрагент.Записать();
Иначе
Предупреждение("Контрагент с указанным ИНН не найден.");
КонецЕсли;
КонецЕсли;
Иначе
Сообщить("Ошибка при выполнении запроса: " + Ответ.КодСостояния + " " + Ответ.ТекстСостояния);
КонецЕсли;
КонецПроцедуры

Функция СтрФорматJSON(СтруктураJSON)
Возврат ЗаписатьJSON(СтруктураJSON, Ложь);
КонецФункции

Функция ПрочитатьJSON(ТекстJSON)
ЧтениеJSON = Новый ЧтениеJSON;
ЧтениеJSON.УстановитьСтроку(ТекстJSON);
Возврат ЧтениеJSON.Прочитать();
КонецФункции
klaus38; SirStefan; quazare; +3 Ответить
6. paramedic 03.06.24 09:34 Сейчас в теме
РаботаСКонтрагентами.РеквизитыПредпринимателяПоИНН(ИННКонтрагента)
РаботаСКонтрагентами.СведенияОЮридическомЛицеПоИНН(ИННКонтрагента)
Оставьте свое сообщение