Обработка обслуживания для ККТ ШтрихОнлайн, 1С:7.7

22.02.17

Интеграция - ККМ

Данная обработка содержит основные команды для работы с ККТ Штрих онлайн

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
ОбработкаОбслуживанияШтрихОнлайн-1С77.zip
.zip 495,43Kb
52
52
10 SM
Скачать Купить за 4 550 руб.

Данная обработка содержит основные команды для работы с ККТ Штрих онлайн. Обработка чуток корявая, но время вам сэкономит. На универсальность не претендую

Собственно состав:

  • smDrvFR1CLib20.dll - интеграционная библиотека штриха с 1С, необходимо скопировать в папку базы
  • FR_KKM54FZ.efd и FR_KKM54FZ.ERT - собственно обработка обслуживания и описание AddIn
  • FR_KKM54FZ.ini - файл настроек подключения (так как долго под 1С7.7 переписывать все, что наворотили в снеговике)
  • 54FZ-FhEm.ERT  - файл - обработка ввода телефона и мейла для чека

Эти файлы надо положить в папку обработок обслуживания оборудования \EXTFORMS\EQUIP информационной базы ЗакрытиеОткрытиеКассовойСмены.ert - некоторые команды вывел в форму, такие как открыть-закрыть смену, тест устройства, получение параметров ККТ (параметры выводятся как сообщение).

Использование обработки полностью на ваш страх и риск. 

Тестировалось на Бухгалтерии 7.7, печать чека из ПКО прошла нормально.

Дорабатывать и так далее не буду. Все - самостоятельно.

Обработка обслуживания ККТ 1С7.7 Штрих онлайн.

См. также

Оптовая торговля Розничная торговля ККМ ЭДО и ОФД Обмен с ГосИС Системный администратор Программист Оперативный учет 7.7 Бухгалтерский учет 7.7 1С:Бухгалтерия 7.7 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия Платные (руб)

Подключение фискального регистратора к 1С 7.7 в режиме онлайн-кассы (в соответствии с 54-ФЗ). Поддержка крайних версий драйверов ККТ: ДТО 10 и ДТО 8 для Атол, 4.15, 5.16 для Штрих-М. Поддержка протоколов ФФД 1.0, 1.05, 1.1 и 1.2, развитые настройки для применения частичных оплат и авансов в оптовой и розничной торговле. Поддержка чеков коррекции всех версий. Поддержка розничной продажи маркированной продукции (ЕГАИС, табак, обувь, лекарства, шины, одежда, белье, парфюмерия, молочная продукция, вода и пр.). Вывод электронного чека (на е-майл, телефон) по требованию покупателя, поддерживаются комбинированные типы оплаты, режим эмуляции печати чека на ФР. Полный цикл работы из 1С 7.7 с маркировкой Честный ЗНАК (ГИСМТ, ЦРПТ) из 1С 7.7. ЭДО (табак, обувь, шины, одежда, молочная продукция, вода и прочие группы товаров) для розницы и опта (приемка и оптовая отгрузка маркированной продукции). Поддерживается как объемно-сортовой учет (ОСУ) так и поштучный (поэкземплярный) учет.

2000 руб.

28.03.2017    471832    4331    3473    

2443

Кассовые операции ККМ Системный администратор Программист Бухгалтер Платформа 1С v7.7 Платформа 1С v8.3 Конфигурации 1cv8 Конфигурации 1cv7 Россия Бухгалтерский учет Управленческий учет Платные (руб)

Программа для управления ККМ Атол и Штрих нового поколения (он-лайн ККТ под 54-ФЗ) с помощью текстового файла (ini файла) с изменениями включена 1 лицензия Для любых программ, которые умеют работать с текстовыми файлами. Внутри комплекта есть готовые к использованию обработки

4800 руб.

31.07.2017    168303    577    605    

199

ККМ Эквайринг/ридер магнитных карт Системный администратор Программист Оперативный учет 7.7 1С:Торговля и склад 7.7 Оптовая торговля, дистрибуция, логистика Россия Управленческий учет Платные (руб)

Данная обработка предназначена для работы с ККТ АТОЛ на платформе 5.0 с драйверами АТОЛ версии 10.7.0.0 и выше для 1С:Торговля и Склад 9.2 (в соответствии с 54-ФЗ). Проста в установке и настройке. Реализован учет маркируемой продукции по ФФД 1.2. В поставку включена поддержка эквайринга на уровне драйверов (в данный момент – Сбер), реализован учет частичных оплат, добавлены эмуляторы кассы и эквайрингового терминала, добавлена обработка генерации тестовых кодов маркировки.

2000 руб.

20.08.2020    27067    57    78    

56

ККМ Кассовые операции Системный администратор Программист Платформа 1С v7.7 Конфигурации 1cv7 Россия Платные (руб)

Для тех, у кого остались не типовые конфигурации или сильно доработанные. Не все заказчики согласны платить за перенос конфигурации c V1С 7.7  на V1С 8 в связи с новым применением ККМ нового поколения ( 54-ФЗ ). Код обработки полностью открыт, поэтому разработчику не составит труда использовать методы данной обработки для привязки фискального регистратора Атол любых моделей к конфигурации Заказчика.

1200 руб.

31.03.2017    52362    34    36    

38

Кассовые операции Розничная торговля ККМ Программист Платформа 1С v7.7 1С:Торговля и склад 7.7 Бухгалтерский учет Управленческий учет Абонемент ($m)

Обработка позволяет печатать чеки для кассы Штрих Online из 1С 7.7 (Торговля и склад). Есть возможность печать чеков из разных касс. Также можно подставить функционал в любую конфигурацию.

1 стартмани

18.02.2021    9198    4    Drfreeman    10    

1

ККМ Обмен с ГосИС Бухгалтер Пользователь Оперативный учет 7.7 1С:Торговля и склад 7.7 Розничная и сетевая торговля (FMCG) Россия Бухгалтерский учет Управленческий учет Абонемент ($m)

Обработка для загрузки базы кодов цен в ККТ "Меркурий" с помощью программы-конфигуратора MercConfig из базы Торговля и склад 9.2 1С: Предприятие 7.7.

1 стартмани

25.01.2021    8629    1    aleksandr_leiman    0    

2
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. Kolunya 6 27.02.17 12:27 Сейчас в теме
Есть ли в вашей обработке поддержка отправки тегов с данными ФИОКассира, ВариантНалогообложения, АдресПокупателя ?
Или только стандартный набор Открыть смену, пробить чек, Закрыть смену?
Так все это есть и в стандартных обработках работы с DrvFR.dll
2. AlexY 10 27.02.17 16:12 Сейчас в теме
Если посмотите в модуль самой обработки, то там ввозможно указание и фио кассира (из константы) и по умолчанию стоит режим ОСН.
а насчет DrvFR.dll - не уверен что она поддерживает 54фз. пробовал пробить - ФР зависает.
3. Kolunya 6 28.02.17 16:44 Сейчас в теме
(2) DrvFR.dll - все стандартные операции отрабатывает.
вопрос только в "новшествах" от 54ФЗ...
В руководстве программиста к драйверу ФР от Штрих-М 4.13 перечислены все методы и свойства
Правда нет нигде явного примера - как именно это должно работать со стороны 1С 7.7
13. ut11 2 02.04.17 23:06 Сейчас в теме
(2) Возможно, проблема в одновременном использовании. У меня после подключения DrvfFr.dll вперемешку с smDrvFR1CLib20.dll драйвера вообще слетели, даже "Тест драйвера" при запросе состояния стал выдавать какие-то левые ошибки типа "поле не обнаружено, не смотря на перезагрузку. Пришлось заново переустанавливать.
4. AlexY 10 01.03.17 11:32 Сейчас в теме
я переписывал по http://its.1c.ru/db/metod8dev/content/4829/hdoc Требования к разработке драйверов для ККТ с функцией передачи в ОФД
5. rebus56 24.03.17 16:57 Сейчас в теме
А продажа со скидкой корректно отрабатыватся? Получатся вместо DrvFR.dll надо пользоваться smDrvFR1CLib20.dll?
6. AlexY 10 25.03.17 14:36 Сейчас в теме
скидка не отрабатывается. Все данные сразу с конечной ценой (с учетом скидки) передаются в таблицу
из 1с идет таблица
СписокТоваров = СоздатьОбъект("ТаблицаЗначений");
СписокТоваров.НоваяКолонка("ТовНаим" , "Строка");
СписокТоваров.НоваяКолонка("Цена" , "Число");
СписокТоваров.НоваяКолонка("Количество", "Число");
СписокТоваров.НоваяКолонка("НДС" , "Число");
Цена там должна указываться конечная, с учетом всех скидок..
вместо DrvFR.dll да, используется smDrvFR1CLib20.
теоретически возможно также неаерное и с атол работать, так как обработка по принципу универсальной писалась, только параметры подключения адаптировать, и все.
7. ut11 2 26.03.17 13:04 Сейчас в теме
Процедура открытия смены не работает с пустым значением переменной "Кассир", надо обязательно писать имя.
Версия драйвера 4.13_538
8. AlexY 10 27.03.17 10:47 Сейчас в теме
вообще то странно. в описании метода в https://its.1c.ru/db/metod8dev/content/4829/hdoc
ОткрытьСмену (OpenShift) ИДУстройства (DeviceID) STRING [IN] Идентификатор устройства BOOL Открывает новую смену.
нет указания кассира.
9. AlexY 10 27.03.17 10:48 Сейчас в теме
упс сорри.
ОткрытьСмену (OpenShift)
ИДУстройства (DeviceID) STRING [IN] Идентификатор устройства BOOL Открывает новую смену и печатает на ККТ отчет об открытии смены.
Кассир (CashierName) STRING [IN] ФИО уполномоченного лица для проведения операции
НомерСмены (SessionNumber) LONG [OUT] Номер смены
НомерДокумента(DocumentNumber) LONG [OUT] Номер отчета об открытии смены
есть кассир.
10. AlexY 10 27.03.17 10:53 Сейчас в теме
но у меня с тем же драйвером 4.13_538 проходило открытие смены.
11. ut11 2 02.04.17 22:59 Сейчас в теме
может, от модели железки зависит
12. ut11 2 02.04.17 23:02 Сейчас в теме
Столкнулся с тем, что не работает НапечататьНефискСтроку, драйвер отвечает, что нет такого метода
Не в курсе, это проблема общая? или у меня какой-то глюк?

Попробовал напечатать чек без фискальных позиций - отказывается пробивать с нулевой суммой. Как слипы к терминалу печатать?
14. AlexY 10 03.04.17 08:49 Сейчас в теме
НапечататьНефискСтроку - этот метод не тестировал, только переписал по https://its.1c.ru/db/metod8dev/content/4829/hdoc
15. victuan 4250 12.04.17 19:58 Сейчас в теме
Вот здесь все методы для 54-ФЗ реализованы http://infostart.ru/public/603118/
16. Palich53 16.05.17 13:50 Сейчас в теме
Здравствуйте. Не получается напечатать отчет без гашения.

Попытка
		Результат = ОбъектДрайвера.НапечататьОтчетБезГашения(ИДУстройства); 
	Исключение
		Результат = 0;
		ВыходныеПараметры.Установить("ОписаниеОшибки","Ошибка вызова метода <ОбъектДрайвера.НапечататьОтчетБезГашения>.");
		Возврат Результат;
	КонецПопытки;

Уходит в исключение. Метод ОтчетОТекущемСостоянииРасчетов() - Работает.
17. melis 96 15.08.20 14:11 Сейчас в теме
Доброго дня

Может кто-нибудь подскажет, что нужно нужно подправить в обработке для ТиС 7.7 для отбития чека на возврат в другой день за нал и безнал (по платиковой карте)?

Вроде все верно передаю, но чек не отбивается - выдает ошибку.
Может надо сначала внесение денег на эту сумму в ФР штрих онлайн сделать?
Или еще что-то - может кто-то подсказать?

Есть уже на 10 раз переписанная обработка работы с драйвером штрих онлайн.
Есть созданный программно в 1С77 объект на dll версии 4.14

и соединение к ней:
Объект.Password=Пароль;
Объект.Connect();

Объект.GetDeviceMetrics();

и т.д.

прямой чек и возврат в тот же день отбиваются нормально. Код примерно такой:

Пока СписокТоваров.ПолучитьСтроку() = 1 Цикл //передача списка товаров с суммами в чек (в т.ч. для ОФД)
Объект.Password = Пароль; // Приход Расход
Объект.CheckType = ?(ПризнВозврата = 0,1,2); //ПризнВозврата = 0 - продажа, иначе возврат
Объект.StringForPrinting = СписокТоваров.ТовНаим;
Объект.Price = ЦенаСоСкд; //тщи 54ФЗ
Объект.Quantity = СписокТоваров.Количество;
Объект.Department = НомерСекции;
Если НДС = 18 Тогда
Объект.Tax1 = 1;
ИначеЕсли НДС = 10 Тогда
Объект.Tax1 = 2;
ИначеЕсли НДС = 20 Тогда
Объект.Tax1 = 1; //??? не предусмотрено
Иначе
Объект.Tax1 = 3;
КонецЕсли;
// если ЕНВД, то Объект.Tax1 = 4;
Объект.PaymentItemSign = PaymentItemSign;

Объект.FNOperation();

Объект.StringForPrinting = ?(PaymentTypeSign=4,"Полный расчет","Предоплата 100%");
Объект.PrintString();
Объект.StringForPrinting = ?(PaymentItemSign = 1,"Товар","Услуга");
Объект.PrintString();
КонецЦикла;
Если сокрлп(ИННкассира) <> "" Тогда
Объект.Password = Пароль;
Объект.TagNumber = 1203;
Объект.TagType = 7;
Объект.TagValueStr = сокрлп(ИННкассира);
Объект.FNSendTag();
КонецЕсли;

Объект.Password = Пароль;

Далее суммы заполняем общие по чеку:

Если Нал = 1 Тогда
Объект.Summ1 = СуммаЧека; //если наличными
Объект.Summ2 = 0; //если оплата пласт. картой
Объект.Summ3 = 0; //если оптала оп счету фз.лицом
ИначеЕсли БезНал = 1 Тогда
Объект.Summ1 = 0; //если наличными
Объект.Summ2 = СуммаЧека; //если оплата пласт. картой
Объект.Summ3 = 0; //если оптала оп счету фз.лицом
Иначе
Объект.Summ1 = 0; //если наличными
Объект.Summ2 = 0; //если оплата пласт. картой
Объект.Summ3 = СуммаЧека; //если оптала оп счету фз.лицом
КонецЕсли;

Если Объект.ResultCode <> 0 Тогда
ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
АннулированиеЧека(Объект, Пароль);
ОтключитьсяОтФР(Объект, Пароль, 0);
Возврат 0;
КонецЕсли;
Объект.FNCloseCheckEx();

Если Объект.ResultCode <> 0 Тогда
Попытка
Объект.Password = Пароль; //\\//\\+
Объект.Гудок();
Исключение
КонецПопытки;

ОписаниеРезультата = ПолучитьОписаниеРезультата(Объект);
АннулированиеЧека(Объект, Пароль);
ОтрезатьЧек(Объект, Пароль);
ОтключитьсяОтФР(Объект, Пароль, 0);
Возврат 0;
КонецЕсли;

Объект.Password = Пароль;
Объект.GetECRStatus();
Оставьте свое сообщение