Кредитный калькулятор

27.11.10

Учетные задачи - Займы, кредит, лизинг

Расчет платежей по кредиту 2-мя методами:
1) простой процент
2) аннуитетные платежи

Скачать исходный код

Наименование Файл Версия Размер
КредитныйКалькулятор.epf
.epf 10,63Kb
271
.epf 10,63Kb 271 Скачать

Еще одна "житейская мелочь" - поможет принять решение как лучше платить равными платежами и большей переплатой, или с большей "нагрузкой" в начале...

См. также

Начисление процентов по кредитам и займам для БП 3.0, БП КОРП 3.0 и конфигураций на их основе

Займы, кредит, лизинг Бухгалтер Пользователь Бухгалтерский учет 1С:Бухгалтерия 3.0 Россия Бухгалтерский учет Налоговый учет Платные (руб)

Внешняя обработка "Начисление процентов по кредитам и займам" предназначена для бухгалтеров, перед которыми стоит задача по расчету процентов по кредитам и займам и формированию операций по отражению начисленных процентов в бухгалтерском и налоговом учете. В своей работе обработка использует только бухгалтерские итоги по счетам учета договоров займа (66, 67, 58.03)

2400 руб.

13.01.2014    81136    438    91    

135

Сигнальные кредитные отчеты НБКИ

WEB-интеграция Займы, кредит, лизинг Программист Платформа 1С v8.3 1С:Бухгалтерия 2.0 1С:Бухгалтерия 1.6 1С:Бухгалтерия 3.0 1С:Комплексная автоматизация 2.х Россия Абонемент ($m)

Данный механизм позволяет направлять в НБКИ и получать по переданным пакетам все движения по кредитной истории клиентов в режиме онлайн. Теперь информация о любых важных изменениях в процессе обслуживания заемщиками своих кредитных обязательств поступает из Национального бюро кредитных историй (НБКИ) максимально оперативно, улучшая качество управления его портфелем.

10 стартмани

20.05.2024    245    1    itserve    0    

1

Отчетность по договорам лизинга в программе 1С:Бухгалтерия лизинговой компании

Займы, кредит, лизинг Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет Конфигурации 1cv8 Финансовые услуги, инвестиции Бухгалтерский учет Бесплатно (free)

Данная статья поможет разобраться в том, что такое лизинг и договоры лизинга, а также как работает программное решение 1С:Бухгалтерия лизинговой компании. Помимо этого, отдельно подробно будет рассмотрено то, как внутри данного программного решения можно вести отчёты относительно лизинговых договоров лизинга и какими эти отчёты бывают, за что отвечают.

25.03.2024    366    Koder_Line    0    

1

Контроль схемы кредитования для Ломбард 4 от Рарус

Займы, кредит, лизинг Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Финансовые услуги, инвестиции Россия Бухгалтерский учет Управленческий учет Абонемент ($m)

Расширение: Контроль схемы кредитования для Ломбард 4 от Рарус, сводит к минимуму ошибки при выборе схемы кредитования при оформлении залоговых операций.

1 стартмани

08.02.2024    371    0    DENSKR    0    

2

Какой взять кредит, чтобы не платить проценты?

Математика и алгоритмы Займы, кредит, лизинг Платформа 1С v8.3 Конфигурации 1cv8 Бесплатно (free)

На примере рассмотрения математического парадокса показаны возможности решения таких задач на 1С с использованием технологий: консоль кода, абстрактный массив, рекурсия, ChatGPT

19.01.2024    1239    kalyaka    16    

9

Учет операций по арендным договорам на примере конфигурации УПП 1.3

Учет ОС и НМА Займы, кредит, лизинг Регламентированный учет и отчетность Бухгалтер Платформа 1С v8.3 1С:Управление производственным предприятием Россия Бухгалтерский учет Налоговый учет Налог на прибыль Абонемент ($m)

Учет аренды по ФСБУ 25/2018 «Бухгалтерский учёт аренды». В статье описана методика составления справки-расчета дисконтированной стоимости прав пользования активом (ППА) и приведены примеры отражения операций по арендованному имуществу на примере конфигурации УПП 1.3.

1 стартмани

04.12.2023    1411    shmuylovich    0    

2

Учет процентов по полученным/выданным займам

Займы, кредит, лизинг Бухгалтер Пользователь Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Бухгалтерский учет Абонемент ($m)

Благодаря данному решению, в конфигурации 1С:Бухгалтерия 3.0 реализована возможность начислять проценты по полученным/выданным займам.

2 стартмани

24.11.2023    1026    27    Cab-dv    17    

13
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. KurchataD 03.04.10 09:45 Сейчас в теме
Здорово, классная вещь. Вот бы такое для 7.7 Бух сделать.
2. wguki@yandex.ru 03.04.10 15:45 Сейчас в теме
"Сумма по кредиту гаситЬся равными суммами" :o
3. AnryMc 849 04.04.10 02:35 Сейчас в теме
(2) А можно подробней - где именно лишнее или не хватает (Ь)

"Всю жизнь не может смириться с тем, что ветер ГАСИТ огонь надежды."
Из греческих тетрадей. Записки детского поэта / Агния Барто

"электромагнитные волны могут, накладываясь, усиливать или ослаблять и даже полностью «ГАСИТЬ» друг друга (интерференция волн)..."
Квантовая теория поля - Большая Советская Энциклопедия

+ см. рис. прикрепл. файл
Прикрепленные файлы:
5. Abadonna 3961 04.04.10 04:52 Сейчас в теме
(3)
А можно подробней - где именно лишнее или не хватает (Ь)

Да запросто! Проверка: кредит что делаеТ? - га'сиТСя.
Что будет делатьТЬ кредит? - гаси'ТЬся
На вскидку не скажу в каком именно классе начальной школы...
На форме отчета - АБСОЛЮТНО ВЕРНО написано.
Прикрепленные файлы:
6. AnryMc 849 04.04.10 09:04 Сейчас в теме
(5) Так в каком месте ошибка? Не могу найти.
7. Abadonna 3961 04.04.10 09:30 Сейчас в теме
(6) Непонятки возникают в связи с глюками сайта ;)
НЕТ ОШИБКИ.
16. RayCon 785 30.04.10 23:01 Сейчас в теме
(6)
>Так в каком месте ошибка? Не могу найти.

На верхнем скриншоте в двух местах:
Основной долг по кредиту гаситЬся равными суммами... (зелёный шрифт в шапке)
Сумма долга по кредиту гаситЬся равными сумммами (нижняя строка в заголовке)


(13) Я бы рекомендовал дополнить сию полезную разработку пакетным формированием документов по автоматическому начислению процентов с одной стороны и платёжных поручений по погашению кредита - с другой. Вся информация для этого есть: график платежей, суммы процентов и основного долга, наименования контрагентов, договоров и т.д.
8. AnryMc 849 04.04.10 09:47 Сейчас в теме
(5) Мне уже 25 минут назад пришло на почту сообщение № 6, а я его пока не вижу на сайте :-(
Какое тут живое общение?
4. пользователь 04.04.10 02:43
Сообщение было скрыто модератором.
...
9. wguki@yandex.ru 04.04.10 12:21 Сейчас в теме
Откройте прикрепленное изображение на этой страничке в описании обработки. Там в отчете написано следующее:
"Основной долг по кредиту гаситься равными суммами, на остаток начисляются проценты" - зеленым шрифтом.

Читаем дальше:
"Сумма по кредиту гаситься равными суммами" - это сразу над таблицей

Понимаю, что это не грамота.ру, но знание азов грамматики никто не отменял :)
10. wguki@yandex.ru 04.04.10 12:23 Сейчас в теме
Повторю изображение :)
Прикрепленные файлы:
11. Abadonna 3961 04.04.10 17:46 Сейчас в теме
(10) Прикольно, но та версия, которую я скачал (4 апреля, утром по Москве)
НЕ СОДЕРЖИТ ошибок
Прикрепленные файлы:
12. Amedis 122 07.04.10 06:18 Сейчас в теме
Вопрос автору:
скажите для кого предназначается эта разработка?

Для обычного человека, желающего расчитать, например, потребительский кредит сроком 10 месяцев? Но даже в этом случае пользователю придется напрягать могз и думать, а что же за период №8???? Какой это месяц???? А попробуйте расчитать например ипотечный кредит на 25 лет или 300 месяцев!!!!! Вобщем я бы заменил номер периода на дату или представление месяца (апрель 2010)... Кроме того мне как человеку взявшему кредит наверняка понадобится сделать перерасчет и посмотреть что же будет если я заплачу больше чем рекомендует банк. Неплохо было бы так же учитывать возможность изменения процентной ставки.

Что касается предприятий, то подобные кредиты там вообще редкость. В основном открываются возобновляемые кредитные линии и процентов одних там видов пять....
Сейчас сам пишу подобную штуковину для расчета процентов по кредитным линиям.
Прикрепленные файлы:
13. AnryMc 849 07.04.10 07:47 Сейчас в теме
(12) Еще можно добавить страховку кредита, проценты или фиксированную плату за ежемесячное обслуживание (комиссия ежемесячная), единоразовый платеж за открытие (комиссия одноразовая), штраф за досрочное погашение, проценты на проценты и пр. пр. - что только наши банки не придумают, для того что бы скрыть эффективную ставку.
Можно вычислять Процентные расходы по кредиту, Средневзвешенную сумму кредита, Эффективную ставку, Пеню за просрочку...

Но как писалось в сказках - это уже другая история

И если ваша разработка появиться в свободном доступе с удовольствием ею воспользуюсь
14. AhtungG 08.04.10 06:04 Сейчас в теме
15. AnryMc 849 08.04.10 06:45 Сейчас в теме
17. mctsimco 01.12.10 17:48 Сейчас в теме
KurchataD пишет:

Здорово, классная вещь. Вот бы такое для 7.7 Бух сделать.


//*****************************
Процедура СформироватьАннуитет()
тз.видимостьколонки("Комиссия",?(КомиссияМес=0,0,1));
Форма.фКомиссия.Видимость(?(КомиссияМес=0,0,1));
Форма.сКомиссия.Видимость(?(КомиссияМес=0,0,1));
НачСумма = СуммаКредита;
ставкаМес = (ставкаГод / 12) / 100;
Игого = 0;
ИгогоПроц = 0;
суммаМесВсего = СуммаКредита *(ставкаМес)/(1-1/вСТЕПЕНЬ((1+ставкаМес), срокКредита));
Для й = 1 По СрокКредита Цикл
суммаПроцентов = НачСумма * ставкаМес;
СуммаМес = суммаМесВсего - суммаПроцентов;
НачСумма = НачСумма - суммаМес;
Игого = Игого + суммаМесВсего;
ИгогоПроц = ИгогоПроц + суммаПроцентов;
//Таб.ВывестиСекцию("Строка");
тз.НоваяСтрока();
тз.Мес= й;
тз.СуммаОсн = СуммаМес;
тз.СуммаПроц = суммаПроцентов;
тз.комиссия = суммакредита / 100 * комиссияМес;
тз.Сумма = суммаМесВсего + тз.комиссия;
КонецЦикла;
Переплата = Игого - СуммаКредита;
сПРЦ = тз.Итог("СуммаПроц");
сВсего = тз.Итог("Сумма");
скомиссия = тз.итог("Комиссия");
КонецПроцедуры

//*****************************
Процедура СформироватьСтандартный()
Перем МесячнаяСумма;
тз.видимостьколонки("Комиссия",?(КомиссияМес=0,0,1));
Форма.фКомиссия.Видимость(?(КомиссияМес=0,0,1));
Форма.сКомиссия.Видимость(?(КомиссияМес=0,0,1));

НачСумма = СуммаКредита;
ставкаМес = (ставкаГод / 12) / 100;
Игого = 0;
ИгогоПроц = 0;
ИгогоОсн = 0 ;
МесячнаяСумма = Окр(СуммаКредита / срокКредита,2);
Для й = 1 По СрокКредита Цикл
Если й = срокКредита Тогда
НачСумма = СуммаКредита - ИгогоОсн;
СуммаМес = НачСумма;
Иначе
СуммаМес = МесячнаяСумма;
КонецЕсли;
суммаПроцентов = НачСумма * ставкаМес;
СуммаМесВсего = СуммаМес + суммаПроцентов;
НачСумма = НачСумма - суммаМес;
Игого = Игого + суммаМесВсего;
ИгогоПроц = ИгогоПроц + суммаПроцентов;
ИгогоОсн = ИгогоОсн + СуммаМес;
тз.НоваяСтрока();
тз.Мес= й;
тз.СуммаОсн = СуммаМес;
тз.СуммаПроц = суммаПроцентов;
тз.комиссия = суммакредита / 100 * комиссияМес;
тз.Сумма = суммаМесВсего + тз.комиссия;

КонецЦикла;
Переплата = Игого - СуммаКредита;
сПРЦ = тз.Итог("СуммаПроц");
сВсего = тз.Итог("Сумма");
скомиссия = тз.итог("Комиссия");
КонецПроцедуры
//*****************************
18. freek 28.12.11 14:08 Сейчас в теме
19. Гость 28.12.11 14:09
Оставьте свое сообщение