Переход на НДС 20% для 1С:7.7

24.12.18

Задачи пользователя - Корректировка данных

Для 1С:Предприятия 8 переход на НДС 20% сделан, а для 7.7 я не нашел. Выкладываю.

Скачать файл

ВНИМАНИЕ: Файлы из Базы знаний - это исходный код разработки. Это примеры решения задач, шаблоны, заготовки, "строительные материалы" для учетной системы. Файлы ориентированы на специалистов 1С, которые могут разобраться в коде и оптимизировать программу для запуска в базе данных. Гарантии работоспособности нет. Возврата нет. Технической поддержки нет.

Наименование SM По подписке [?] Купить один файл
7.7 Переход на НДС 20%:
.ert 55,50Kb
34
34
1 SM
Скачать Купить за 1 850 руб.

Для 1С:Предприятия 8 переход на НДС 20% сделан, а для 7.7 я не нашел. Выкладываю.

Для УСН обработку следует запускать в первый рабочий день после 01.01.2019

Обработка:

- дополняет справочники "Ставки НДС" и "Варианты учета налогов" (для Бухгалтерии 7.7).

- устанавливает ставку НДС 20% в справочнике "Номенклатура" (для Бухгалтерии 7.7 с 01.01.2019)

- при запуске обработки после 01.01.2019 устанавливает константы "Основная ставка НДС". Для Бухгалтерия 7.7 и константы "Основной вариант расчета налогов в документах поступления" и "Основной вариант расчета налогов в документах отгрузки"

Проверено на релизах 7.70.645 и 7.70.287.

НДС 20%

См. также

Чистка данных Корректировка данных Программист Пользователь Платформа 1С v7.7 Конфигурации 1cv7 Абонемент ($m)

Архив различных обработок 1С 7.7 с открытым исходным кодом для работы с данными при свертке, выгрузке, исправлении, модификации информационной базы. Можно использовать любую обработку в качестве заготовки для добавления собственных функций.

1 стартмани

13.05.2021    7989    11    etmarket    0    

3

Корректировка данных Акт сверки Программист Платформа 1С v7.7 Платформа 1С v8.3 1С:Управление торговлей 10 1С:Комплексная 7.7 1С:Торговля и склад 7.7 Россия Бухгалтерский учет Управленческий учет НДС Абонемент ($m)

Пример реализации сверок между базами и исправления расхождений в обе стороны, из 7.7 -> в 8.3 и из 8.3 -> в 7.7 на обычных формах. Фундаментальные обработки, которые работают на постоянной основе и поддерживают идентичность данных между базами основных поставщиков и основных покупателей (их соответствие прописано в модуле). Используется Новый COMОбъект("V77.Application"), пример использования внешнего источника данных. Реализация в поступление. Поступление в поступление. Корректировка поступления в корректировку отгрузки. СчФ выданный в СчФ полученный. Исправление СчФ полученного в исправление СчФ выданного. Перенос документа Реализация 7.7 в Поступление 8, Перемещение 7.7 в Поступление 8. Акт сверки взаиморасчетов (несколько организаций). Все обработки запускаются в базе 1С Предприятие 8 (обычные формы).

1 стартмани

03.10.2019    14817    31    ksnik    6    

4

Корректировка данных Программист Пользователь Платформа 1С v7.7 Конфигурации 1cv7 Абонемент ($m)

Универсальная обработка 7.7, представленная здесь, до сих пор почему-то по функционалу гораздо беднее, чем общеизвестная типовая "Универсальный подбор и обработка объектов" (UNIREPS82\UniversalSelection) 8.2-8.3", мне не хватило возможности выполнить произвольный код обработчика объектов. Данная обработка "UChoice.ert" является полным аналогом "UniversalSelection", представляет собой консоль выполнения произвольного кода, позволяет делать с объектами информационной базы 1С 7.7 абсолютно все, что угодно, а не узкий, сложно настраиваемый набор команд, на мой взгляд, она существенно превосходит имеющиеся аналоги, поэтому ничем другим кроме нее я не пользуюсь.

1 стартмани

04.04.2019    16548    29    ksnik    9    

4

Корректировка данных Программист Бухгалтер Платформа 1С v7.7 Конфигурации 1cv7 Абонемент ($m)

Обработка, исправляющая ситуацию с отрицательными номерами строк в табличной части

1 стартмани

31.08.2017    13439    1    C0mmander_Alex    1    

3

Корректировка данных Платформа 1С v7.7 Конфигурации 1cv7 Россия Абонемент ($m)

1. Обработка позволяет совершать следующие действия над объектами: а. СПРАВОЧНИКИ: удаление; пометка на удаление; снятие пометки на удаление. б. ДОКУМЕНТЫ: удаление; пометка на удаление; снятие пометки на удаление; проведение; отмена проведения; выключить проводки; включить проводки. 2. Действия могут быть ограничены некоторыми условиями. 3. Существует отбор по видам объектов. 4. Есть возможность обработать подчиненные справочники.

1 стартмани

30.04.2017    22443    81    DUH    0    

5

Корректировка данных Программист Пользователь Платформа 1С v7.7 Конфигурации 1cv7 Россия Абонемент ($m)

Обработки можно использовать в любой конфигурации 1С-Предприятия 7.7. Обработки позволяют просмотреть/изменить значения любого реквизита документов/справочников, существующих в базе. В обработках реализован множественный отбор по значениям реквизитов (для табличной части документов тоже). В обработке документов реализованы следующие действия: Перенумерация; проведение; отмена проведения; пометка на удаление; непосредственное удаление; снятие пометки удаления; изменение реквизитов; очистка реквизитов; удаление строк табличной части; вывод на печать и в файлы *.xls,*.csv,*.dbf,*.xml реквизитов шапки и табличной части. В обработке справочников реализованы следующие действия: Перенумерация; пометка на удаление; непосредственное удаление; снятие пометки удаления; изменение реквизитов; очистка реквизитов; очистка истории значений периодического реквизита; перенос справочника в другую базу подобной конфигурации по OLE; вывод на печать реквизитов и истории значений периодических реквизитов; вывод реквизитов в файлы *.xls,*.csv,*.dbf,*.xml; отчет по структуре справочников, вывод и обработка ссылок на выбранные элементы.

1 стартмани

23.11.2016    38507    217    SanchoD    15    

13

Корректировка данных Системный администратор Программист Платформа 1С v7.7 Конфигурации 1cv7 Абонемент ($m)

База данных помечается Suspect, когда SQL Server не может читать файлы данных, связанные с базой данных с жесткого диска. В этом случае сделать бекап базы нельзя, но можно попробовать образ диска. После того как возможность читать файлы данных восстановлена, вы можете перезапустить службу SQL Server, и если возможно, произойдет автоматическое восстановление. Что делать, если информационная база 1С7.7 на SQL Server 2000 перешла в состояние suspect? Если это произошло утром и бекап сделан, Вы, конечно, можете грохнуть и раскатать базу заново (вечером это проблематичнее), но не торопитесь - возможно, поможет detach+attach или другие методы, изложенные в данной публикации.

1 стартмани

08.11.2016    23023    ksnik    5    

5

Корректировка данных Платформа 1С v7.7 Конфигурации 1cv7 Абонемент ($m)

Обработка Подмена значений в документах и справочниках 7.7, с отборами по справочникам и документам, с возможностью отсеять по периоду

1 стартмани

04.07.2016    15594    10    Turn123    3    

3
Комментарии
Подписаться на ответы Инфостарт бот Сортировка: Древо развёрнутое
Свернуть все
1. pentanom 25 24.12.18 11:16 Сейчас в теме
Если у кого-нибудь будут пожелания, исправлю и дополню.
2. user1125368 09.01.19 11:23 Сейчас в теме
Добрый день, напишите, пожалуйста, каким образом и что запускать из архива?
3. pentanom 25 10.01.19 20:16 Сейчас в теме
(2)
Добрый день, напишите, пожалуйста, каким образом и что запускать из архива?
Никакого архива нет. Нужно просто запустить обработку.
Но можно просто обновить релизы до 7.70.646 (ОСНО) и 7.70.288 (УСН). Там это встроено.
4. natoptic 11.01.19 08:15 Сейчас в теме
я до 646 обновила .2019 работает нормально , а в 2018 книга продаж и печатные формы по валютным счетам вместо 18 % считает 20% ндс.причем проводки и экранная форма остается правильной. в чем может быть проблема?
5. natoptic 11.01.19 08:17 Сейчас в теме
6. pentanom 25 11.01.19 13:14 Сейчас в теме
(5)Это на базу нужно посмотреть. Она у вас типовая или с дописками ?
7. пользователь 11.01.19 18:09
Сообщение было скрыто модератором.
...
8. natoptic 11.01.19 19:12 Сейчас в теме
Типовая, но есть несколько подключенных ert отчетов
9. pentanom 25 11.01.19 19:14 Сейчас в теме
(8)Ну и как посмотреть на базу ?
10. natoptic 11.01.19 23:24 Сейчас в теме
а какие варианты возможны?
11. pentanom 25 12.01.19 05:47 Сейчас в теме
(10)в зависимости от величины базы. Можно, например, выложить в облако.
12. user853631 14.01.19 10:09 Сейчас в теме
пришлите пожалуйста обработку, не хватает sm на dsl85{Собака}mail.ru
13. pentanom 25 14.01.19 15:33 Сейчас в теме
14. tn55 15.01.19 20:39 Сейчас в теме
Обновила базу до 646 релиза. Чуда не свершилось. В Номенклатуре как было 18% так и осталось, в константах тоже ничего не поменялось. Запустила обработку "Установка ставок налогов в справочнике Номенклатура", вручную изменила ставку НДС в Константах. Вроде все работает, но полной уверенности нет.. Только у меня "чудеса"? Поделитесь опытом.

Спасибо!
15. pentanom 25 15.01.19 21:00 Сейчас в теме
(14)В обновлении ИБ есть такой кусок:
	ИначеЕсли Номер = 770646 Тогда
		
		// Если в справочнике "Ставки НДС" нет, ставки 20%, то добавим ее
		Состояние("Обновление ставки НДС");
		
		СтавкаНДС20Существует = 0;
		СтавкаНДС20 = "";
		
		СтавкиНДС = СоздатьОбъект("Справочник.СтавкиНДС");
		СтавкиНДС.ВыбратьЭлементы();
		Пока СтавкиНДС.ПолучитьЭлемент() = 1 Цикл
		    Если СтавкиНДС.Ставка = 20 Тогда
		        СтавкаНДС20Существует = 1;
				СтавкаНДС20 = СтавкиНДС.ТекущийЭлемент();
				Прервать;
		    КонецЕсли;
		КонецЦикла;
		
		Если СтавкаНДС20Существует = 0 Тогда
			СтавкиНДС.Новый();
			СтавкиНДС.Ставка = 20;
			СтавкиНДС.Наименование = "20%";
			СтавкиНДС.Записать();
			СтавкаНДС20 = СтавкиНДС.ТекущийЭлемент();
			СтавкаНДС20Существует = 1;
		КонецЕсли;
		                                    
		// Если в справочнике "Варианты расчета налогов" нет
		// вариантов со ставками 20%, то добавим их.
		Состояние("Обновление справочника  ""Варианты расчета налогов""");
		НайденВариант20ВСумме = 0;
		НайденВариант20Сверху = 0;
		Вариант20ВСумме = "";
		Вариант20Сверху = "";
		
		ВариантыНалогов = СоздатьОбъект("Справочник.ВариантыРасчетаНалогов");
		ВариантыНалогов.ВыбратьЭлементы();
		Пока ВариантыНалогов.ПолучитьЭлемент() = 1 Цикл
		    Если ВариантыНалогов.СтавкаНДС.Ставка = 20 Тогда
				Если ВариантыНалогов.СтавкаНП.Ставка = 0 Тогда
				    Если ВариантыНалогов.СуммаВключаетНДС = 1 Тогда
				        НайденВариант20ВСумме = 1;
						Вариант20ВСумме = ВариантыНалогов.ТекущийЭлемент();
					Иначе
						НайденВариант20Сверху = 1;
						Вариант20Сверху = ВариантыНалогов.ТекущийЭлемент();
				    КонецЕсли;
				КонецЕсли;
		    КонецЕсли;
		КонецЦикла;
		
		Если НайденВариант20ВСумме = 0 Тогда // не найден вариант 20% в сумме
			ВариантыНалогов.Новый();
			ВариантыНалогов.СуммаВключаетНДС = 1;
			ВариантыНалогов.СуммаВключаетНП = 0;
			ВариантыНалогов.СтавкаНДС = СтавкиНДС.ТекущийЭлемент();
			ВариантыНалогов.СтавкаНП = глБезНалога("НП");
			ВариантыНалогов.Наименование = НаименованиеВариантаРасчетаНалогов(ВариантыНалогов);
			ВариантыНалогов.Записать();
			Вариант20ВСумме = ВариантыНалогов.ТекущийЭлемент();
		КонецЕсли;
		
		Если НайденВариант20Сверху = 0 Тогда // не найден вариант 20% сверху
			ВариантыНалогов.Новый();
			ВариантыНалогов.СуммаВключаетНДС = 0;
			ВариантыНалогов.СуммаВключаетНП = 0;
			ВариантыНалогов.СтавкаНДС = СтавкиНДС.ТекущийЭлемент();
			ВариантыНалогов.СтавкаНП = глБезНалога("НП");
			ВариантыНалогов.Наименование = НаименованиеВариантаРасчетаНалогов(ВариантыНалогов);
			ВариантыНалогов.Записать();
			Вариант20Сверху = ВариантыНалогов.ТекущийЭлемент();
		КонецЕсли;
		
		СтавкаНДС18Существует = 0;
		СтавкаНДС18 = "";
		
		СтавкиНДС.ВыбратьЭлементы();
		Пока СтавкиНДС.ПолучитьЭлемент() = 1 Цикл
			Если СтавкиНДС.Ставка = 18 Тогда
				СтавкаНДС18Существует = 1;
				СтавкаНДС18 = СтавкиНДС.ТекущийЭлемент();
				Прервать;
			КонецЕсли;
		КонецЦикла;
		
		Если (СтавкаНДС18Существует = 1) И (СтавкаНДС20Существует = 1) Тогда
			СпрНоменклатура = СоздатьОбъект("Справочник.Номенклатура");
			СпрНоменклатура.ВыбратьЭлементы();
			Пока СпрНоменклатура.ПолучитьЭлемент() = 1 Цикл
				Если СпрНоменклатура.СтавкаНДС.Получить('01.01.2019') = СтавкаНДС18 Тогда 
					СпрНоменклатура.СтавкаНДС.Установить('01.01.2019', СтавкаНДС20); 
				КонецЕсли;
			КонецЦикла;
			Если Константа.ОсновнаяСтавкаНДС = СтавкаНДС18 Тогда
				Константа.ОсновнаяСтавкаНДС = СтавкаНДС20;
			КонецЕсли;
			Если Константа.ОсновнойВариантРасчетаНалогов.Выбран() = 1 Тогда
				Если Константа.ОсновнойВариантРасчетаНалогов.СтавкаНДС = СтавкаНДС18 Тогда
					Если Константа.ОсновнойВариантРасчетаНалогов.СуммаВключаетНДС = 1 Тогда
						Константа.ОсновнойВариантРасчетаНалогов = Вариант20ВСумме;
					Иначе
						Константа.ОсновнойВариантРасчетаНалогов = Вариант20Сверху;
					КонецЕсли;
				КонецЕсли;
			КонецЕсли;
		КонецЕсли;
		
		Константа.СтавкаРефинансирования.Установить('17.09.2018', 7.5); 
		Константа.СтавкаРефинансирования.Установить('17.12.2018', 7.75); 
		
		
		ОбновитьТарифыСтраховыхВзносов();
		
		Константа.ПредельнаяВеличинаБазыСтраховыхВзносов.Установить('01.01.2019', 1150000); 
		Константа.ПредельнаяВеличинаБазыФСС.Установить('01.01.2019', 865000); 
		
		Таб.ВывестиСекцию(Строка(Номер));
		
	КонецЕсли;	
Показать

Видно, что на 01.01.2019 для всей номенклатуры, у которой на эту дату была ставка 18 %, должно установиться 20%. Вы на какую дату смотрите ставку НДС ?
16. tn55 16.01.19 07:26 Сейчас в теме
17. pentanom 25 16.01.19 11:36 Сейчас в теме
(16)Я бы еще просто посмотрел историю ставки НДС для какой-нибудь номенклатуры. И историю Константы "Предельная Величина Базы Страховых Взносов".
Если обработкой обновления ИБ они не изменились, то значит она не сработала. Я бы, на вашем месте, разобрался с этим.
Из того куска кода, который я выложил (15), можно сделать внешнюю обработку и запустить ее.
18. tn55 16.01.19 15:20 Сейчас в теме
Проверяла на номенклатуре с единственной ставкой 18 в истории. Константу не смотрела. Предельная величина базы Страховых взносов как могут влиять? С обратной сложнее, я не программист.
Спасибо
19. pentanom 25 16.01.19 16:31 Сейчас в теме
(18)
Предельная величина базы Страховых взносов как могут влиять?
Посто новое значение константы "Предельная Величина Базы Страховых Взносов" тоже должно было установиться на 01.01.19
А конфигурация типовая ? Или с доработками ? Кто делает обновление ?
20. tn55 16.01.19 19:55 Сейчас в теме
Предельная база 1150000 установилась. Конфигурация типовая без доработок. В справочнике ставок НДС обнаружила три записи со ставкой 18. Может в этом причина?
Спасибо
21. pentanom 25 16.01.19 20:23 Сейчас в теме
(20)
три записи со ставкой 18. Может в этом причина?
Может быть и в этом. Лишнее конечно нужно удалить. А потом попробуйте запустить прилагаемую обработку.
КОПИЮ БАЗЫ СДЕЛАТЬ ОБЯЗАТЕЛЬНО !!!

При обновлении должны были обновиться страховые взносы. Проверьте.
Прикрепленные файлы:
НДС_20.ert
22. tn55 17.01.19 00:00 Сейчас в теме
Причина именно в этом. Проверила все документы и справочники, "привязала" их все к одной записи ставки НДС. Лишние записи ставок удалила. Обновила базу до 646 релиза. Все обновилось. Все нормально. Огромное спасибо за помощь.
23. pentanom 25 17.01.19 07:44 Сейчас в теме
(22)Поздравляю с победой,
24. tn55 17.01.19 11:09 Сейчас в теме
Ещё раз огромное спасибо за поддержку!!! В таких ситуациях это очень важно, что ты не один со своей проблемой.
25. user1139919 28.01.19 06:23 Сейчас в теме
Добрый день подскажите пожалуйста стоимость обработки.
26. pentanom 25 28.01.19 18:36 Сейчас в теме
Оставьте свое сообщение