Снятие блокировки элементов управляемой формы для редактирования

Публикация № 1025338

Обработки - Универсальные обработки

11
Внешняя обработка + код с одной функций разблокировки элементов управляемой формы владельца для редактирования в любых конфигурациях с использованием БСП. Тестировалось на платформе 8.3.10.2667 и выше

Обычно разрешение редактирования реквизитов делается через меню Еще - редактирование реквизитов, и в зависимости от сложности/связей элементов/реквизитов формы эта процедура может занять некоторое, а то длительное время. Предложенная ниже обработка и код позволяют открыть на редактирование доступные на форме элемента без лишних вопросов и ожидания.

Обработка состоит из одной формы и с одной только процедурой в модуле формы

&НаКлиенте
Процедура ПриОткрытии(Отказ)
	
	ВладелецФормы.ТолькоПросмотр=Ложь;
	ВладелецФормы.РазблокироватьДанныеФормыДляРедактирования();
	
	Для каждого Эл из ВладелецФормы.Элементы Цикл
		
		Попытка
			Эл.Доступность=Истина;
		Исключение
		КонецПопытки;
		
		Попытка
			Эл.ТолькоПросмотр=Ложь;
		Исключение
		КонецПопытки;
	
	КонецЦикла;	
	
	Закрыть();
		
КонецПроцедуры

В модуле объекта можно прописать нужные назначения или указать размещение после подключения в справочнике Дополнительные отчеты и обработки

Функция СведенияОВнешнейОбработке() Экспорт
	
	ПараметрыРегистрации = ДополнительныеОтчетыИОбработки.СведенияОВнешнейОбработке("1.0.0.0");
    ПараметрыРегистрации.Вид = ДополнительныеОтчетыИОбработкиКлиентСервер.ВидОбработкиЗаполнениеОбъекта();
    ПараметрыРегистрации.Версия = "1.0";
	ПараметрыРегистрации.Назначение.Добавить("Справочник.Номенклатура");
	Команда = ПараметрыРегистрации.Команды.Добавить();
    Команда.Представление = "Разблокировать элементы формы";
    Команда.Идентификатор = Команда.Представление;
    Команда.Использование = ДополнительныеОтчетыИОбработкиКлиентСервер.ТипКомандыОткрытиеФормы();
    Команда.ПоказыватьОповещение = Истина;
    Возврат ПараметрыРегистрации; 
	
КонецФункции	

 

11

Скачать файлы

Наименование Файл Версия Размер
Разблокировать элементы управляемой формы для редактирования:
.epf 6,38Kb
20.03.19
0
.epf 6,38Kb Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. user662565_gleb.nikolaev 21.03.19 18:52 Сейчас в теме
Не подскажете чего это она ругается? 1С:Предприятие 8.3 (8.3.14.1630) Розница, редакция 2.2 (2.2.11.30)

{ВнешняяОбработка.РазблокироватьЭлементыФормы.Форма.Форма.Форма(5)}: Значение не является значением объектного типа (ТолькоПросмотр)
ВладелецФормы.ТолькоПросмотр=Ложь;
2. independ 400 21.03.19 19:54 Сейчас в теме
(1) а в какой форме используется? Имя справочника или документа?
user662565_gleb.nikolaev; +1 Ответить
3. user662565_gleb.nikolaev 21.03.19 20:27 Сейчас в теме
Забыл самое главное - Значение не является значением объектного типа (ТолькоПросмотр). Ошибку выдаёт при попытке открыть через меню Файл-Открыть.
4. user662565_gleb.nikolaev 21.03.19 20:42 Сейчас в теме
Всё понял, она работает в двух актах. Извините за беспокойство.
Прикрепленные файлы:
5. independ 400 21.03.19 20:47 Сейчас в теме
(4) она может работать в любой форме справочника или документа, где можно использовать внешние обработки заполнения/печати и проч.
нужно нажать гиперссылку рядом с размещением и выбрать к примеру все справочники и документы
Прикрепленные файлы:
user662565_gleb.nikolaev; +1 Ответить
6. user662565_gleb.nikolaev 21.03.19 21:03 Сейчас в теме
Я уже туда потыкал. В справочнике Номенклатура не заработало чего то. После закрытия магазина попробую, когда подключений к базе не будет.
Оставьте свое сообщение