Поле "Отбор" в управляемой форме используя СКД

Публикация № 1061866

Программирование - Практика программирования

Отбор форма СКД пример программно схема компоновки данных УФ управляемые

6
Пример, который осуществляет отбор ссылок при помощи СКД, макет компоновки создается программно.

Несмотря на опыт работы, такая задача, как вытащить отбор СКД на управляемую форму, часто становится многочасовой потерей времени.

Поэтому реализовал пример, который осуществляет отбор ссылок при помощи СКД.

Для выбора объекта метаданных используется БСП 2.1  - 2.4, но имя объекта метаданных можно написать текстом.

Работает, например, в УТ 11.4.

Для реализации примера достаточно добавить поля в новую обработку согласно изображениям. У поля "ОбъектНазначения" 2 события:

"ОбъектНазначенияОкончаниеВводаТекста" И "ОбъектНазначенияНачалоВыбора", параметр кнопка выбора "Да"

И добавлена одна команда "Отобрать" с одноименным событием.

Привожу модуль формы:

// СКД программно

// Процедура удаляет все элементы настроек СхемыКД 
//
&НаСервереБезКонтекста
Процедура ОчиститьНастройкиСКД(Настройки)
	
	Если Настройки = Неопределено ИЛИ Тип(Настройки) <> Тип("НастройкиКомпоновкиДанных") Тогда
		Возврат;
	КонецЕсли;
	
	Для Каждого Параметр Из Настройки.ПараметрыДанных.Элементы Цикл
		Параметр.Значение = Неопределено;
		Параметр.Использование = Ложь;
	КонецЦикла;
	
	Настройки.ПользовательскиеПоля.Элементы.Очистить();
	Настройки.Отбор.Элементы.Очистить();
	Настройки.Порядок.Элементы.Очистить();
	Настройки.Структура.Очистить();
	Настройки.Выбор.Элементы.Очистить();
	
КонецПроцедуры

// Добавляет отбор в набор отборов компоновщика или группы отборов.
// 
&НаСервереБезКонтекста
Функция ДобавитьОтбор(ЭлементСтруктуры, Знач Поле, Значение, ВидСравнения = Неопределено, Использование = Истина) Экспорт
	
	Если ТипЗнч(Поле) = Тип("Строка") Тогда
		Поле = Новый ПолеКомпоновкиДанных(Поле);
	КонецЕсли;
	
	Если ТипЗнч(ЭлементСтруктуры) = Тип("КомпоновщикНастроекКомпоновкиДанных") Тогда
		Отбор = ЭлементСтруктуры.Настройки.Отбор;
	Иначе
		Отбор = ЭлементСтруктуры;
	КонецЕсли;
	
	Если ВидСравнения = Неопределено Тогда
		ВидСравнения = ВидСравненияКомпоновкиДанных.Равно;
	КонецЕсли;
	
	НовыйЭлемент = Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
	НовыйЭлемент.Использование  = Использование;
	НовыйЭлемент.ЛевоеЗначение  = Поле;
	НовыйЭлемент.ВидСравнения   = ВидСравнения;
	НовыйЭлемент.ПравоеЗначение = Значение;
	Возврат НовыйЭлемент;
	
КонецФункции

// Создает и сохраняет компоновку данных во временном хранилище.
// Важно то что настройки не могут существовать без схемы компоновки.
&НаСервере
Процедура УстановитьКомпоновку()
	
	Если НЕ ЗначениеЗаполнено(ОбъектНазначения) Тогда
		Возврат;
	КонецЕсли;
	
	
	ОчиститьНастройкиСКД(КомпоновщикНастроек.Настройки);
	СхемаКомпоновки = Новый СхемаКомпоновкиДанных();		
	
	Источник = СхемаКомпоновки.ИсточникиДанных.Добавить();
	Источник.Имя = "ИсточникДанных";
	Источник.СтрокаСоединения="";
	Источник.ТипИсточникаДанных = "local";
	
	
	НаборДанных = СхемаКомпоновки.НаборыДанных.Добавить(Тип("НаборДанныхЗапросСхемыКомпоновкиДанных"));
	НаборДанных.Запрос = "Выбрать * из "+ОбъектНазначения;
	НаборДанных.Имя = "НаборДанныхЗапроса";
	НаборДанных.ИсточникДанных = Источник.Имя;
	НаборДанных.АвтоЗаполнениеДоступныхПолей = Истина;
	
	АдресСхемы = ПоместитьВоВременноеХранилище(СхемаКомпоновки, УникальныйИдентификатор);
	
	КомпоновщикНастроек.Инициализировать(Новый ИсточникДоступныхНастроекКомпоновкиДанных(АдресСхемы)); 
	
	ГруппировкаСКД = КомпоновщикНастроек.Настройки.Структура.Добавить(Тип("ГруппировкаКомпоновкиДанных"));
	ГруппировкаСКД.Использование = Истина;
	
	ПолеОбъект = Новый ПолеКомпоновкиДанных("Ссылка");
	
	ВыбранноеПоле = ГруппировкаСКД.Выбор.Элементы.Добавить(Тип("ВыбранноеПолеКомпоновкиДанных"));
	ВыбранноеПоле.Использование = Истина;
	ВыбранноеПоле.Поле = ПолеОбъект;
	
	Для каждого ЭлементДоступногоОтбора Из КомпоновщикНастроек.Настройки.ДоступныеПоляОтбора.Элементы Цикл
		ДобавитьОтбор(КомпоновщикНастроек.Настройки.Отбор, ЭлементДоступногоОтбора.Поле, , ВидСравненияКомпоновкиДанных.Равно, Ложь);
	КонецЦикла;
	
КонецПроцедуры


// Команда Отобрать на сервере.
&НаСервере
Процедура КомандаНаСервере()
	
	СКД = ПолучитьИзВременногоХранилища(АдресСхемы);
	
	КомпоновщикМакета = Новый КомпоновщикМакетаКомпоновкиДанных;
	МакетКомпоновки = КомпоновщикМакета.Выполнить(СКД, КомпоновщикНастроек.ПолучитьНастройки(),,,Тип("ГенераторМакетаКомпоновкиДанныхДляКоллекцииЗначений"));
	
	ПроцессорКД = Новый ПроцессорКомпоновкиДанных;
	ПроцессорКД.Инициализировать(МакетКомпоновки);
	
	ПроцессорВывода = Новый ПроцессорВыводаРезультатаКомпоновкиДанныхВКоллекциюЗначений;
	ПроцессорВывода.ОтображатьПроцентВывода = Истина;
	Результат = Новый ТаблицаЗначений;
	ПроцессорВывода.УстановитьОбъект(Результат);
	ПроцессорВывода.Вывести(ПроцессорКД);
	
	
	ТаблицаРезультата.Загрузить( Результат);
	
КонецПроцедуры

// Команда Отобрать
&НаКлиенте
Процедура Отобрать(Команда)
	КомандаНаСервере()
КонецПроцедуры

// выбор метаданного

&НаКлиенте
Процедура ОбъектНазначенияОкончаниеВводаТекста(Элемент, Текст, ДанныеВыбора, СтандартнаяОбработка)
	Оповестить("УстановитьКомпоновку",Текст,Этаформа);
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаОповещения(ИмяСобытия, Параметр, Источник)
	Если ИмяСобытия = "ВыборОбъектовМетаданных" Тогда
		ОбъектНазначения = Параметр[0].Значение;
		УстановитьКомпоновку();
	ИначеЕсли ИмяСобытия = "УстановитьКомпоновку" Тогда
		ОбъектНазначения = Параметр;
		УстановитьКомпоновку();
	КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура ОбъектНазначенияНачалоВыбора(Элемент, ДанныеВыбора, СтандартнаяОбработка)
	ПараметрыФормы = ПодготовитьПараметрыФормыВыборОбъектовМетаданных();
	ОткрытьФорму("ОбщаяФорма.ВыборОбъектовМетаданных", ПараметрыФормы,Элемент);
	СтандартнаяОбработка = Ложь;
КонецПроцедуры

&НаСервере
Функция ПодготовитьПараметрыФормыВыборОбъектовМетаданных()
	
	ФильтрПоОбъектамМетаданных = Новый СписокЗначений;
	
	Запрос = Новый Запрос;
	Запрос.Текст = 
	"ВЫБРАТЬ
	|	ИдентификаторыОбъектовМетаданных.ПолноеИмя
	|ИЗ
	|	Справочник.ИдентификаторыОбъектовМетаданных КАК ИдентификаторыОбъектовМетаданных
	|ГДЕ
	|	ИдентификаторыОбъектовМетаданных.Родитель В(&Родитель)";
	
	Родитель = Новый Массив;
	Родитель.Добавить(Справочники.ИдентификаторыОбъектовМетаданных.НайтиПоНаименованию("Документы"));
	Родитель.Добавить(Справочники.ИдентификаторыОбъектовМетаданных.НайтиПоНаименованию("Справочники"));
	
	Запрос.УстановитьПараметр("Родитель", Родитель);
	
	Результат = Запрос.Выполнить();
	
	ВыборкаДетальныеЗаписи = Результат.Выбрать();
	
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		ФильтрПоОбъектамМетаданных.Добавить(ВыборкаДетальныеЗаписи.ПолноеИмя);
	КонецЦикла;
	
	ПараметрыФормы = Новый Структура;
	ПараметрыФормы.Вставить("ФильтрПоОбъектамМетаданных", ФильтрПоОбъектамМетаданных);
	ПараметрыФормы.Вставить("ВыборЕдинственного", Истина);
	ПараметрыФормы.Вставить("РежимВыбора", Истина);
	ПараметрыФормы.Вставить("Заголовок", НСтр("ru = 'Назначение дополнительной обработки'"));
	
	Возврат ПараметрыФормы;
КонецФункции


 

6

Скачать файлы

Наименование Файл Версия Размер
:Отбор кодом
.epf 8,33Kb
16.05.19
1
.epf 8,33Kb 1 Скачать

См. также

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение