Базомер (показывает количество записей в таблицах)

Публикация № 1070411

Администрирование - Администрирование данных 1С - Статистика базы данных

Количество записей таблицы таблицах Базомер объем базы

6
Базомер показывает количество записей во всех регистрах сведений, регистрах накопления, документах и справочниках.

Есть возможность сформировать список всех объектов метаданных и отметить нужные к замеру. Результат замера выводится в таблицу. Имеется возможность сортировки объектов по количеству записей и вывода результата в Excel. Обработка легко подключается к базе в качестве дополнительной глобальной обработки. Работает в небезопасном режиме (для чтения объектов метаданных без права администрирования).

Писалась для ERP 2.4.7.151, платформу 8.3.13.1644. Работает в ЗУП 3.1.9.159. По идее должна работать и в других конфигурациях на БСП.

 

&НаСервере
Процедура НачатьЗамерНаСервере()
	
	УстановитьПривилегированныйРежим(Истина);
	
	Для каждого ОбъектКЗамеру Из Объект.ВыбранныеОбъектыМетаданных Цикл
		Если Не ОбъектКЗамеру.Отметка Тогда
			Продолжить;
		КонецЕсли;
		
		ТипЗнчВыбранныйСтрокой 	= ОбъектКЗамеру.ПолноеИмяОбъектаМетаданных;
		МетаданныеКЗамеру 		= Метаданные.НайтиПоПолномуИмени(ТипЗнчВыбранныйСтрокой);
		
		Если СтрНайти(МетаданныеКЗамеру.ПолноеИмя(), "РегистрСведений") > 0 Тогда
			Попытка
				НаборЗаписей = РегистрыСведений[МетаданныеКЗамеру.Имя].СоздатьНаборЗаписей();
				НаборЗаписей.Прочитать();
				КоличествоЗаписей = НаборЗаписей.Количество();
				
				Строка = Объект.Результат.Добавить();
				Строка.ОбъектМетаданных 	= ОбъектКЗамеру.ПолноеИмяОбъектаМетаданных;
				Строка.КоличествоЗаписей	= КоличествоЗаписей;
			Исключение
				Сообщить("ОшибкаОбработкиОбъекта "+МетаданныеКЗамеру.ПолноеИмя()+" "+ОписаниеОшибки());
				Продолжить;
			КонецПопытки;
		КонецЕсли;
		
		Если СтрНайти(МетаданныеКЗамеру.ПолноеИмя(), "РегистрНакопления") > 0 Тогда
			Попытка
				НаборЗаписей = РегистрыНакопления[МетаданныеКЗамеру.Имя].СоздатьНаборЗаписей();
				НаборЗаписей.Прочитать();
				КоличествоЗаписей = НаборЗаписей.Количество();
				
				Строка = Объект.Результат.Добавить();
				Строка.ОбъектМетаданных 	= ОбъектКЗамеру.ПолноеИмяОбъектаМетаданных;
				Строка.КоличествоЗаписей	= КоличествоЗаписей;
			Исключение
				Сообщить("ОшибкаОбработкиОбъекта "+МетаданныеКЗамеру.ПолноеИмя()+" "+ОписаниеОшибки());
				Продолжить;
			КонецПопытки;
		КонецЕсли;
		
		Если СтрНайти(МетаданныеКЗамеру.ПолноеИмя(), "Документ") > 0 Тогда
			Попытка
				ВыборкаДокументов = Документы[МетаданныеКЗамеру.Имя].Выбрать();
				КоличествоЗаписей = 0;
				Пока ВыборкаДокументов.Следующий() Цикл
					КоличествоЗаписей = КоличествоЗаписей + 1;
				КонецЦикла;
				
				Строка = Объект.Результат.Добавить();
				Строка.ОбъектМетаданных 	= ОбъектКЗамеру.ПолноеИмяОбъектаМетаданных;
				Строка.КоличествоЗаписей	= КоличествоЗаписей;
			Исключение
				Сообщить("ОшибкаОбработкиОбъекта "+МетаданныеКЗамеру.ПолноеИмя()+" "+ОписаниеОшибки());
				Продолжить;
			КонецПопытки;
		КонецЕсли;

		Если СтрНайти(МетаданныеКЗамеру.ПолноеИмя(), "Справочник") > 0 Тогда
			Попытка
				ВыборкаСправочников = Справочники[МетаданныеКЗамеру.Имя].Выбрать();
				КоличествоЗаписей = 0;
				Пока ВыборкаСправочников.Следующий() Цикл
					КоличествоЗаписей = КоличествоЗаписей + 1;
				КонецЦикла;
				
				Строка = Объект.Результат.Добавить();
				Строка.ОбъектМетаданных 	= ОбъектКЗамеру.ПолноеИмяОбъектаМетаданных;
				Строка.КоличествоЗаписей	= КоличествоЗаписей;
			Исключение
				Сообщить("ОшибкаОбработкиОбъекта "+МетаданныеКЗамеру.ПолноеИмя()+" "+ОписаниеОшибки());
				Продолжить;
			КонецПопытки;
		КонецЕсли;

	КонецЦикла;
	
	УстановитьПривилегированныйРежим(Ложь);
КонецПроцедуры

 

6

Скачать файлы

Наименование Файл Версия Размер
Базомер (показывает количество записей в таблицах):
.epf 10,53Kb
31.05.19
6
.epf 10,53Kb 6 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. alex-l19041 8 31.05.19 17:11 Сейчас в теме
вот это
ВыборкаДокументов = Документы[МетаданныеКЗамеру.Имя].Выбрать();
КоличествоЗаписей = 0;
Пока ВыборкаДокументов.Следующий() Цикл
КоличествоЗаписей = КоличествоЗаписей + 1;
КонецЦикла;


лучше заменить на Запрос который вернет количество

"ВЫБРАТЬ
		|	КОЛИЧЕСТВО(ТаблицаДанных.Ссылка) КАК Количество,
			|ИЗ
		|	Документ." + ИмяТаблицы + " КАК ТаблицаДанных
2. alex-l19041 8 31.05.19 17:19 Сейчас в теме
и для справочников можно аналогично

"ВЫБРАТЬ
		|	КОЛИЧЕСТВО(ТаблицаДанных.Ссылка) КАК Количество,
		|ИЗ
		|	Справочник." + ИмяТаблицы + " КАК ТаблицаДанных
3. cool99 03.06.19 08:11 Сейчас в теме
"Рука лицо" - в то время как наши кОрабли бороздят просторы вселенной, в 2019 году мы считаем количество записей в таблицах через чтение набора записей и выборки, а если там миллионов 10 записей?
Писалась для ERP 2.4.7.151

Бедная ERP
4. ВикторП 199 05.06.19 12:42 Сейчас в теме
(3) зачем ? уже написали в (1) и (2) , не на мисте .
5. cool99 05.06.19 16:55 Сейчас в теме
(4) Просто с таким уровнем представляю, что в ЕРП они нашкодили - эта мысль основная (Как говорил Штирлиц, запоминается только последняя часть разговора, а у вас наоборот :))
С ее требованиями и подобными разработками никаких серверов не хватит. И Вас не смущает, что автор мало того, что "денюшку" просит, да еще и не отписался по комментариям 1/2? Вот зайдет какой-нибудь неокрепший ум и возьмет данный код (не читая комментов) на вооружение и пополнит ряды сами знаете кого.
6. ВикторП 199 06.10.19 12:28 Сейчас в теме
Подарок
Прикрепленные файлы:
БазомерНовый.epf
ActionBlog; +1 Ответить
7. ActionBlog 28.12.19 10:43 Сейчас в теме
Оставьте свое сообщение

См. также

Анализ трудозатрат пользователей. Подсчет количества введенных документов с учетом табличных частей 4

Отчеты и формы Бухгалтер Пользователь Внешний отчет (ert,erf) v8 БП2.0 БП3.0 Россия БУ Учет рабочего времени Абонемент ($m) Анализ учета Статистика базы данных

Данная обработка предназначена для подсчета введенной информации работниками организации. Будет полезна руководителю организации, главному бухгалтеру.

1 стартмани

04.01.2020    562    5    kj6370    2       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Количество документов (каждого вида) в базе и элементов справочников (каждого вида) 1

Отчеты и формы Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ УПП1 КА2 Россия Windows Абонемент ($m) Статистика базы данных

Обработка показывает количество элементов справочников и документов каждого вида с отбором по организации или по всей базе, обычное и управляемое приложение.

1 стартмани

24.12.2019    602    3    user1233211    3       

Данные в хранилище значений 8

Отчеты и формы Системный администратор Программист Внешний отчет (ert,erf) v8 v8::СКД 1cv8.cf Россия Абонемент ($m) Статистика базы данных

Обработка, показывающая размер, занимаемый данными типа Хранилище значения.

1 стартмани

11.12.2019    920    1    kosmo0    0       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Количество данных в базе (1С 8.3 Управляемые формы) 1

Инструменты и обработки Системный администратор Программист Пользователь Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Статистика базы данных

Количество данных в базе 1С на управляемых формах. Количество записей в регистрах сведений, накоплений, расчета, бухгалтерии, количество документов, справочников, значения констант.

1 стартмани

25.10.2019    2171    d.saladin    0       

22 января состоится вебинар "Использование технологии блокчейн в 1С" Промо

На вебинаре вы узнаете как использовать современную технологию блокчейн при проектировании и создании учетных систем, почему эту технологию следует рассматривать как одну из базовых. Ведущий Михаил Калимулин поделится своими знаниями основ технологии и опытом внедрения.

990 рублей

Журнал данных информационной базы 1

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Абонемент ($m) Статистика базы данных

Обработка для получения информации о структуре и количестве объектов информационной базы.

2 стартмани

25.08.2019    1810    1    AleSSandre    0       

Статистика объектов информационных баз 1C 8.x (обычные и управляемые формы, СКД) 5

Отчеты и формы Системный администратор Программист Внешний отчет (ert,erf) v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m) Статистика базы данных

Внешний универсальный отчет по статистике объектов информационных баз 1C 8.x для обычных и управляемых форм с возможностью группировки по периодам.

1 стартмани

08.08.2019    2057    8    as.1c.nik    0       

PgConf.Russia 2020. 3-5 февраля 2020 г. Москва. Промо

PGConf.Russia – международная техническая конференция по открытой СУБД PostgreSQL, ежегодно собирающая более 700 разработчиков, администраторов баз данных и IT-менеджеров для обмена опытом и профессионального общения. Для участников сообщества infostart.ru скидка 5% на участие в конференции.

от 12350 рублей

Количество активных пользователей 2

Отчеты и формы Системный администратор Внешний отчет (ert,erf) v8 v8::СКД 1cv8.cf Абонемент ($m) Статистика базы данных

Отчет СКД в форме таблицы на основе регистров сведений ЗамерыВремени, ЗамерыВремениТехнологические.

1 стартмани

07.08.2019    1678    Mari_Kuznetzova    0       

Свойства объектов 1С в SQL (и сравнение баз) 70

Отчеты и формы Системный администратор Программист Внешний отчет (ert,erf) v8 v8::СКД 1cv8.cf Абонемент ($m) Статистика базы данных

Подключаемый отчет на системе компоновки данных по типам объектов 1С показывает: 1) Совокупности таблиц SQL для хранения объекта 1С и их предназначение; 2) Число объектов данного типа; 3) Размеры хранения данных и индексов в MB (мегабайтах); 4) Сравнение данных двух баз

1 стартмани

15.07.2019    6661    171    sapervodichka    0       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Количество документов за период 0

Отчеты и формы Программист Пользователь Внешний отчет (ert,erf) v8 v8::УФ v8::СКД 1cv8.cf Россия Абонемент ($m) Специальные

Отчет показывает типы используемых документов в информационной базе за выбранный период и их количество по месяцам. Есть отбор по признаку документа ("проведен"/"распроведен"/"помечен на удаление"). Отчет универсальный подойдет для любой конфигурации.

2 стартмани

12.07.2019    2008    7    trntv    4       

Количество элементов в базе по метаданным и их размер для файловой информационной базы 16

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Статистика базы данных

В версии платформы 8.3.15, вышедшей 26.06.2019 (8.3.15.1489), была реализована возможность получить (оценить) размер данных, которые они занимают в таблицах СУБД - метод глобального контекста ПолучитьРазмерДанныхБазыДанных(). В данной обработке реализована данная возможность.

1 стартмани

27.06.2019    2529    27    BurlakovIvan    0       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Количество документов за период (Управляемые + Обычные формы, все конфигурации) 0

Отчеты и формы no Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Статистика базы данных

Представляю вашему вниманию маленькую но быструю и полезную обработку. Эта обработка выводит количество документов за произвольный период. Берутся все документы конфигурации. В сообщения выводятся: Представление документа, имя документа (в конфигураторе), количество документов за выбранный период. Обработка работает в обычных формах и управляемых формах. Для запуска в обычном приложении, а также в управляемом приложении (толстый клиент) достаточно открыть файл обработки. Для запуска в тонком клиенте, обработку необходимо регистрировать в конфигурации как встроенную обработку.

1 стартмани

20.06.2019    2102    4    pvlunegov    1       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 17 февраля по 13 марта 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Размер файлов хранилища 1

Отчеты и формы Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Статистика базы данных

Обработка предназначена для вычисления объема информации, расположенного в справочнике ХранилищеДополнительнойИнформации для обычных форм.

1 стартмани

11.06.2019    2307    3    needmic    4       

Количество документов и справочников с отбором по организации для обычных и управляемых форм 2

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Статистика базы данных

Обработка позволяет вывести количество документов и справочников информационной базы с отбором по организации для обычных и управляемых форм.

1 стартмани

08.06.2019    2254    3    Dadriel619960    2       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Количество элементов в справочниках и документах системы 0

Отчеты и формы Программист Внешний отчет (ert,erf) v8 v8::СКД 1cv8.cf Россия Абонемент ($m) Статистика базы данных

Отчет для любой конфигурации на платформе 8.х по количеству элементов в справочниках и документах системы Открывается как внешний файл (меню Файл - Открыть) на любом релизе платформы 8.х Формируется по кнопке Сформировать - см. скриншот

1 стартмани

21.05.2019    2340    5    denis_r    0       

Подсчёт общего количества объектов (справочников и документов) в базе данных 1

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Статистика базы данных

Обработка подсчитывает количество всех типов документов и справочников в базе 1С и выводит в таблицу. Ведёт подсчёт общего количества документов, проведённых, не проведённых и помеченных на удаление. Подсчитывает общее количество элементов каждого справочника, помеченные на удаление и предопределённые элементы. Предназначена для общих целей анализа базы, особенно для прогнозирования времени свёртки/тестирования/обновления/синхронизации базы данных, а также для сравнения двух баз по количеству объектов (например, источник и приёмник при конвертации). Есть возможность выбора периода, выбора сортировки по количеству/наименованию и скрывать/показывать нулевые.

1 стартмани

22.04.2019    2654    2    Aleksandr55555    3       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Количество элементов справочников и документов для 1С 8.x (обычные и управляемые формы) 1

Отчеты и формы Программист Пользователь Внешний отчет (ert,erf) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Статистика базы данных

Отчет позволяет быстро оценить количество элементов справочников и документов в базах 1С 8.x (обычные и управляемые формы).

1 стартмани

26.03.2019    2209    3    black.nik    0       

Отчет по метаданным. Количество элементов справочников, документов, регистров. Отбор по периоду 2

Отчеты и формы Системный администратор Программист Внешний отчет (ert,erf) v8 v8::СКД 1cv8.cf Россия Абонемент ($m) Статистика базы данных

Отчет по метаданным. Количество элементов справочников, документов, регистров. Есть отбор по периоду для периодических метаданных. Можно использовать для анализа при переносе данных. 8.3.13.1644.

1 стартмани

27.02.2019    2839    3    serg.7x    0       

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

Подсчет количества документов в конфигурации 2

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Украина Абонемент ($m) Статистика базы данных

Как-то всё руки не доходили, но вот написал для себя, и делюсь с другими, обработку для подсчета количества документов в конфигурации. Может, кому-то будет полезной.

1 стартмани

23.02.2019    2935    2    forwork1c    1       

Анализ документов базы по пользователям 0

Отчеты и формы Системный администратор Внешний отчет (ert,erf) v8 1cv8.cf Россия Абонемент ($m) Статистика базы данных

Анализ документов, введённых пользователями: внешний отчёт, позволяющий увидеть количество документов каждого вида, введённых каждым пользователем (количественные показатели работы).

1 стартмани

16.02.2019    2679    4    Fantasisto    0       

Открыто голосование за доклады на INFOSTART MEETUP Krasnodar Промо

Выбирайте и голосуйте за самые интересные доклады, лучшие из них попадут в окончательную программу митапа. Голосование продлится до 30 января 2020 года.

INFOSTART MEETUP Krasnodar. 14 февраля 2020 г. Промо

Краснодар станет первым в 2020 году местом, где пройдет региональная встреча IT-специалистов сообщества Инфостарт. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Стоимость участия - 5000 рублей. Цена действительна до 26.12.2019.

Отчет по базе данных 3

Отчеты и формы Системный администратор Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Статистика базы данных

Внешний отчет по содержимому базы данных, формирует структуру базы данных, а также по конкретным объектам конфигурации можно посмотреть поля СУБД и индексы. (УФ)

1 стартмани

12.01.2019    3506    9    user5300    0