Мобильное приложение 1С: Список покупок и анализ расходов

Публикация № 1071075

Управление - Финансовый учет и бюджетирование (FRP)

мобильное приложение android список покупок анализ расходов сканирование штрихкодов встроенной камерой загрузка чеков ФНС Налоговая наименование товара по штрихкоду PUSH

В публикации рассмотрено небольшое домашнее мобильное приложение для составления списка покупок и анализа расходов. В приложении реализованы: работа с штрихкодами (сканирование встроенной камерой), поиск наименования товара по штрихкоду из интернета, загрузка чеков из ФНС по QR-коду, вывод QR-кода ранее загруженного чека и др.

В мобильном приложении всего один документ Заказ, зато реализованы следующие механизмы:
- обмен с центральной базой (подробно описано здесь http://its.1c.ru/db/pubintromobile);
- отправка PUSH-уведомлений (подробно описано здесь http://its.1c.ru/db/pubintromobile);
- сканирование штрихкодов встроенной камерой;
- загрузка наименования товара по штрихкоду из интернета при создании товара (описание сервиса здесь https://barcodes.olegon.ru/);
- получение чека из ФНС по QR-коду (API здесь https://habr.com/ru/post/358966/);
- вывод QR-кода уже загруженных чеков для возможности получить чек на другом устройстве.

Кому интересно, выкладываю куски кода некоторых механизмов.

 

Сканирование штрихкодов встроенной камерой смартфона (объект СредстваМультимедиа)

Модуль формы документа или справочника, где нужно сканировать штрихкод:

// Кнопка Сканировать на форме
&НаКлиенте
Процедура Сканировать(Команда)
	ДополнительныеПараметры = Новый Структура;
	ДополнительныеПараметры.Вставить("Форма", ЭтотОбъект);
	ДополнительныеПараметры.Вставить("ИмяОбработчикаЗакрытияСканирования", "ОбработкаЗакрытияСканирования");
	ПодключаемоеОборудованиеКлиент.ПолучитьШтрихкод(ДополнительныеПараметры);
КонецПроцедуры

&НаКлиенте
Процедура ОбработкаЗакрытияСканирования(ДополнительныеПараметры) Экспорт
	Возврат;
КонецПроцедуры

// Здесь обрабатываем полученный штрихкод, QR-код и т.п.
&НаКлиенте
Процедура ОбработатьПолученныйШтрихкод(ПолученныйШтрихкод, Параметры) Экспорт
	Сообщить(ПолученныйШтрихкод);
КонецПроцедуры

Общий модуль ПодключаемоеОборудованиеКлиент:

Процедура ПолучитьШтрихкод(ДополнительныеПараметры) Экспорт
	ЗаголовокСканирования = НСтр("ru = 'Считайте штрихкод'");
	Если ДополнительныеПараметры.Свойство("ЗаголовокСканирования") Тогда
		ЗаголовокСканирования = ДополнительныеПараметры.ЗаголовокСканирования;
	КонецЕсли;
	#Если МобильноеПриложениеКлиент Тогда
		ОбработчикСканирования = Новый ОписаниеОповещения("ОбработкаСканирования", ПодключаемоеОборудованиеКлиент, ДополнительныеПараметры);
		ОбработчикЗакрытияСканирования = Новый ОписаниеОповещения(ДополнительныеПараметры.ИмяОбработчикаЗакрытияСканирования, 
			ДополнительныеПараметры.Форма, ДополнительныеПараметры);
		СредстваМультимедиа.ПоказатьСканированиеШтрихКодов(ЗаголовокСканирования, ОбработчикСканирования, ОбработчикЗакрытияСканирования);
	#КонецЕсли
КонецПроцедуры

Процедура ОбработкаСканирования(Штрихкод, Результат, Сообщение, ДополнительныеПараметры) Экспорт
	Если НЕ ДополнительныеПараметры.Свойство("ПотоковоеСканирование") Тогда
	#Если МобильноеПриложениеКлиент Тогда
		СредстваМультимедиа.ЗакрытьСканированиеШтрихКодов();
	#КонецЕсли
	КонецЕсли;
	Если Результат = Неопределено Тогда
		Возврат;
	КонецЕсли;
	ДополнительныеПараметры.Форма.ОбработатьПолученныйШтрихкод(Штрихкод, ДополнительныеПараметры);
КонецПроцедуры

 

Загрузка наименования товара по штрихкоду из интернета

Поиск наименований товара по штрихкоду реализован через сервис https://barcodes.olegon.ru/. Сервис возвращает массив имен, я беру первое имя ТекМассив.names[0]. Модуль формы элемента справочника товаров:

&НаКлиенте
Процедура ОбработатьПолученныйШтрихкод(ПолученныйШтрихкод, Параметры) Экспорт
	Объект.Штрихкод = СокрЛП(ПолученныйШтрихкод);
	ssl4 = Новый ЗащищенноеСоединениеOpenSSL( неопределено, неопределено );
	HTTPСоединение = Новый HTTPСоединение("barcodes.olegon.ru", 443,,,,,ssl4,); 
	HTTPЗапрос = Новый HTTPЗапрос("/api/card/name/" + Объект.Штрихкод + "/B644542640852064273024635143606"); 
	Результат =  HTTPСоединение.Получить(HTTPЗапрос);
	Если Результат.КодСостояния = 200 Тогда 
		СтрокаРезультат = Результат.ПолучитьТелоКакСтроку(КодировкаТекста.UTF8);
		ЧтениеJSON = Новый ЧтениеJSON;
		ЧтениеJSON.УстановитьСтроку(СтрокаРезультат);
		ТекМассив = ПрочитатьJSON(ЧтениеJSON);
		ЧтениеJSON.Закрыть();
		Если СтрДлина(Объект.Наименование) = 0 Тогда
			Объект.Наименование = ТекМассив.names[0];
		КонецЕсли;	
	Иначе
		Сообщить("Статус ответа:" + Результат.КодСостояния);
	КонецЕсли;
КонецПроцедуры

 

Получение чека из ФНС по QR-коду

QR-код чека является строкой вида t=20190602T2026&s=1854.00&fn=9282000100073930&i=74555&fp=3968601409&n=1, содержащей дату, сумму, номер фискального накопителя, номер чека, фискальный признак и вид операции. Используя эти данные можно получить сам чек из ФНС. Для получения чека в заголовке HTTP-запроса необходимо указать номер телефона и пароль, которые можно получить при регистрации в мобильном приложении Проверка кассового чека https://play.google.com/store/apps/details?id=ru.fns.billchecker&hl=ru.

&НаКлиенте
Процедура ЗагрузитьЧек(Команда)
	ВидЧека = "1";
	ДатаВремя = "20190602T1150";
	Сумма = "299.00";
	ФН = "8710000101180608";
	ФД = "98325";
	ФП = "309098793";
	Заголовки = Новый Соответствие;
	Заголовки.Вставить("Authorization", "Basic " + ЗашифроватьBase64("+79637413216:702187", "US-ASCII"));
	Заголовки.Вставить("Device-Id", "Android");
	Заголовки.Вставить("Device-OS", "Android");
	HTTPСоединение = Новый HTTPСоединение("proverkacheka.nalog.ru", 8888);
	HTTPЗапрос = Новый HTTPЗапрос("/v1/ofds/*/inns/*/fss/" + СокрЛП(ФН) + "/operations/" + СокрЛП(ВидЧека) + "/tickets/" + СокрЛП(ФД) + "?fiscalSign=" + СокрЛП(ФП) + "&date=" + СокрЛП(ДатаВремя) + "&sum=" + СокрЛП(СтрЗаменить(Сумма,".","")), Заголовки); 
	Ответ = HTTPСоединение.Получить(HTTPЗапрос);   
	Если Ответ.КодСостояния = 204 Тогда
		//Сообщить("Чек корректен");
	    ИмяВременногоФайла = ПолучитьИмяВременногоФайла();
		HTTPЗапрос = Новый HTTPЗапрос("/v1/inns/*/kkts/*/fss/" + СокрЛП(ФН) + "/tickets/" + СокрЛП(ФД) + "?fiscalSign=" + СокрЛП(ФП) + "&sendToEmail=no", Заголовки); 
		Ответ = HTTPСоединение.Получить(HTTPЗапрос, ИмяВременногоФайла);
		Если Ответ.КодСостояния = 200 Тогда
			//Сообщить("Чек получен");
			Форма = ПолучитьФорму("Документ.Заказ.Форма.ФормаДокумента");
			ДанныеФормы = Форма.Объект;
			ОбработатьФайлОтвета(ИмяВременногоФайла, ДанныеФормы);
			КопироватьДанныеФормы(ДанныеФормы, Форма.Объект); 
			Форма.Открыть();
		Иначе
			Сообщить("Получение чека: " + Ответ.КодСостояния);
		КонецЕсли;
	Иначе
		Сообщить("Проверка корректности: " + Ответ.КодСостояния);
	КонецЕсли; 
КонецПроцедуры

&НаСервере
Функция ЗашифроватьBase64(Строка, Кодировка) Экспорт
	ИмяВременногоФайла = ПолучитьИмяВременногоФайла();
	ЗаписьТекста = Новый ЗаписьТекста(ИмяВременногоФайла, Кодировка);
    ЗаписьТекста.Записать(Строка);
    ЗаписьТекста.Закрыть();
    Двоичные = Новый ДвоичныеДанные(ИмяВременногоФайла);
    Результат = Base64Строка(Двоичные);
	Если Лев(Результат, 4) = "77u/" Тогда
		Результат = Сред(Результат, 5);
	КонецЕсли; 
	Результат = СтрЗаменить(Результат, Символы.ПС, "");
    УдалитьФайлы(ИмяВременногоФайла);
    Возврат Результат;
КонецФункции

&НаСервере
Процедура ОбработатьФайлОтвета(ИмяФайла, ДанныеФормы)
	ЧтениеJSON = Новый ЧтениеJSON;
	ЧтениеJSON.ОткрытьФайл(ИмяФайла, "UTF-8");
	Результат = ПрочитатьJSON(ЧтениеJSON,,"dateTime");
	Организация = Результат.document.receipt.user;
	ИНН = Результат.document.receipt.userInn;
	СтрокиТовары = Результат.document.receipt.items;
		Для каждого СтрокаТовар Из СтрокиТовары Цикл
			Сообщить(СтрокаТовар.name);
			Сообщить(СтрокаТовар.price / 100);
			Сообщить(СтрокаТовар.quantity);
			Сообщить(СтрокаТовар.sum / 100);
		КонецЦикла; 
КонецПроцедуры

 

Вывод QR-кода

Для возможности вывода QR-кода чека строка QR-кода сохраняется в реквизите документа Заказ. Для вывода QR-кода в табличный документ используется типовая компонента 1С КомпонентаПечатиQRКода, которая есть в общих макетах типовых конфигураций 1С. Правда в мобильном приложении компонента не работает, поэтому приходится запрашивать QR-код из центральной базы.

&НаСервере
Функция ПолучитьКартинкуQR(QRКод)
	Макет = ПолучитьОбщийМакет("КомпонентаПечатиQRКода");
	Адрес = ПоместитьВоВременноеХранилище(Макет);
	
	КодВозврата = ПодключитьВнешнююКомпоненту(Адрес, "QRCodeExtensionSymbolicName");
	Если Не КодВозврата Тогда
		Сообщить("Проблема подключения внешней компоненты!");
	КонецЕсли;
	ГенераторQRКода = Новый("AddIn.QRCodeExtensionSymbolicName.QRCodeExtension");	

	ДанныеQRКода = ГенераторQRКода.GenerateQRCode(QRКод, 1, 190);
	
	Если ДанныеQRКода = Неопределено Тогда
		КартинкаQRКода = Новый Картинка();
	Иначе
		КартинкаQRКода = Новый Картинка(ДанныеQRКода);
	КонецЕсли;
	
	Макет = ПолучитьОбщийМакет("Макет");
	Макет.Рисунки.ШК.Картинка = КартинкаQRКода;
	ТабДок = Новый ТабличныйДокумент;
	ТабДок.Вывести(Макет);
	Возврат ТабДок;	
КонецФункции

 

О мобильном приложении

Центральную базу необходимо опубликовать на web-сервере, например http://192.168.103.28/BuyCentr. В центральной базе заполнить узлы плана обмена Мобильные устройства (предопределенный Ц - Центральный, второй К - Константин, третий Н - Николай и т.п.) и константу Ключ доступа отправителя PUSH, например PUSH_SRV_API_KEY_F55C7685_602D_4F06_BD4B_727CFBFAA85F (можно получить здесь https://pushnotifications.1c.com/). Также через консоль заданий можно настроить расписание регламентного задания, которое оповещает сколько денег потрачено сегодня.

Мобильное приложение необходимо собрать в Сборщике приложений, запустить на телефоне, заполнить узлы плана обмена (предопределенный К - Константин, второй  Ц - Центр), константу Адрес центральной базы, например http://192.168.103.28/BuyCentr, константу Код центральной базы - Ц, Номер проекта мобильного приложения, например 797785657074 (можно получить здесь https://pushnotifications.1c.com/), Номер и пароль для проверки чеков, например +79637413216 и 702187 (можно получить зарегистрировавшись в мобильном приложении ФНС https://play.google.com/store/apps/details?id=ru.fns.billchecker&hl=ru).

Проверялось на платформе 1С версии 8.3.14.1630 и мобильной платформе 1С версии 8.3.14.53.

Скачать файлы

Наименование Файл Версия Размер
Мобильное приложение

.cf 477,56Kb
06.06.19
13
.cf 477,56Kb 13 Скачать
Центральная база

.cf 475,87Kb
06.06.19
12
.cf 475,87Kb 12 Скачать
Мобильное приложение для Android

.apk 35,60Mb
06.06.19
5
.apk 35,60Mb 5 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. capitan 1682 06.06.19 17:37 Сейчас в теме
2. coollerinc 40 11.06.19 21:52 Сейчас в теме
3. coollerinc 40 12.06.19 19:32 Сейчас в теме
Частенько веб сервис валится в 202 ошибку, да и сканер на моем телефоне как то сложно распознает на реальных мятых чеках штрихкод. Даже поэксперементировал с стророниим сканером, чуть лучше, но все равно долго.
4. user_gea 14.06.19 11:28 Сейчас в теме
Спасибо за фрагменты кода! Взяты на заметку !
5. Derushev 5 10.04.20 13:52 Сейчас в теме
Спасибо! Но пуши не доходят. Вываливается ошибка: gcm has been deactivated and remove from google api
UPD: Простите, увидел. https://forum.infostart.ru/forum92/topic223641/
Оставьте свое сообщение

См. также

Анализ отсутствия товара на складе (складские провалы) Промо

Финансовый учет и бюджетирование (FRP) Оптовая торговля Учет ТМЦ Управленческие Оптовая торговля Учет ТМЦ v8::ОУ УТ10 Россия УУ Абонемент ($m)

Отчет с периодичностью в месяц выводит, сколько дней товар отсутствовал на складе, сколько его продали в этом месяце и сколько бы заработали, если бы товар был в наличии весь месяц.

2 стартмани

17.03.2015    18596    6    taurus__    4    

Бюджетирование БДР и БДДС

Финансовый учет и бюджетирование (FRP) v8 БП3.0 Россия УУ Абонемент ($m)

Представлено расширение, которое подойдет для типовой бухгалтерии, и позволяет формировать 2 вида бюджета, БДР и БДДС

1 стартмани

28.05.2020    4463    34    human_new    11    

Бюджетирование движения денежных средств для Бухгалтерии 3.0

Финансовый учет и бюджетирование (FRP) v8 v8::БУ БП3.0 Россия БУ УУ Абонемент ($m)

Самые востребованные бюджеты в организациях, это Бюджет движения денежных средств, далее БДДС, и Бюджет доходов и расходов (БДР). Это первая публикация, в которой речь пойдет про БДДС, он же денежный поток, он же "cash flow".

2 стартмани

17.04.2020    2511    11    human_new    12    

Бюджетная смета (форма 0501012) и Изменение бюджетной сметы (форма 0501013) для БГУ1

Финансовый учет и бюджетирование (FRP) Бухгалтерские v8 v8::БУ БГУ Россия БУ Госбюджет Абонемент ($m)

Отчеты "Бюджетная смета (форма 0501012)" и "Изменение бюджетной сметы (форма 0501013)" с выбором данных по КПС и счетам 501.13 501.23 501.33 и для конфигурации "Бухгалтерия государственного учреждения" редакция 1.0

1 стартмани

17.02.2020    2049    5    dendzu    0    

Платежный календарь Промо

Бухгалтерские Финансовые Управленческие Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 КА1 УПП1 Россия Госбюджет УУ Абонемент ($m)

Красивый, удобный и функциональный календарь для планирования поступления и расходования денежных средств.

3 стартмани

19.07.2013    29379    17    pizhenkov    48    

Пример реализации HTML-формы календаря для мобильного приложения

Работа с интерфейсом Мобильная разработка v8::Mobile Абонемент ($m)

Реализация функциональной мобильной формы календаря, которая красиво трансформируется в список задач.

5 стартмани

13.02.2020    2859    10    ingeneerz@gmail.com    0    

Расчет статей оборотов бюджетирования по формулам для БИТ.ФИНАНС

Финансовый учет и бюджетирование (FRP) v8 ERP2 Россия Госбюджет Абонемент ($m)

Предлагается расширение с альтернативным вариантом расчета статей оборотов бюджетирования по формулам для решения БИТ.ФИНАНС. Доработка представляет из себя справочник, в котором описываются формулы, и документ, который производит расчет по формулам.

1 стартмани

06.02.2020    2184    3    naam    0    

Мой помощник и бухгалтер

Учет доходов и расходов Мобильная разработка v8::Mobile Домашние учет и финансы Россия УУ Абонемент ($m)

Домашняя бухгалтерия, записная книжка, контакты, напоминания, сканер штрих-кода, матрица Эйзенхауэра - все в твоём телефоне.

1 стартмани

26.09.2019    4615    2    user-sergey    10    

Отчет для руководителя. УПП 1.3

Управленческие Финансовый учет и бюджетирование (FRP) Оптовая торговля Учет доходов и расходов Финансовый учет и бюджетирование (FRP) Оптовая торговля Учет доходов и расходов v8 v8::СКД УПП1 УУ Абонемент ($m)

Понадобился отчёт для начальства, где он мог бы посмотреть продажи, будущие продажи, поступление и расход денег, поступление и заказ товаров за день. Выкладываю, вдруг кому тоже нужно.

1 стартмани

11.09.2019    4766    5    Nefilimus    0    

Подсистема Яндекс.Деньги

WEB Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 1cv8.cf Домашние учет и финансы УУ Абонемент ($m)

Подсистема полноценного учёта денежных средств для яндекс кошелька.

2 стартмани

09.09.2019    3736    2    CeHbKA    0    

Мобильный терминал - универсальное мобильное решение для автоматизации учета на складских предприятиях, в торговых залах и складах при магазинах с применением технологии Штрих-кодирования

Сканер штрих-кода Терминал сбора данных Мобильная разработка Управление торговлей Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 1cv8.cf Россия УУ Абонемент ($m)

Мобильное приложение предназначено для проведения инвентаризаций, сбора заказов, проверки накладных, проверки ценников, просмотра информации об остатках и ценах на смартфоне или терминале сбора данных под управлением Android.

1 стартмани

09.09.2019    1821    3    @lexandr    7    

Интерактивная оборотно-сальдовая ведомость 2.0 Промо

Бухгалтерские Анализ учета Налоговые Финансовый учет и бюджетирование (FRP) Дебиторская и кредиторская задолженность Закрытие периода Оборотно-сальдовая ведомость, Анализ счета Учет доходов и расходов Учет ОС и НМА Учет ТМЦ Дебиторская и кредиторская задолженность Закрытие периода Оборотно-сальдовая ведомость, Анализ счета Учет ОС и НМА Учет ТМЦ v8 v8::БУ КА1 БП2.0 УПП1 УНФ БУ НУ Абонемент ($m)

Полностью универсальная Оборотно-сальдовая ведомость, также включающая возможности ОСВ по счету, Анализа счета и другие. С возможностью интерактивных разворотов в пару кликов по любым разрезам регистра бухгалтерии с подключением к типовым механизмам конфигураций расшифровки.

1 стартмани

23.07.2009    113697    52    Леонов Александр    491    

Пример простого и приятного внешнего HTML интерфейса для мобильного приложения

Работа с интерфейсом Мобильная разработка v8::Mobile Абонемент ($m)

Реализация простого и приятного внешнего HTML интерфейса для мобильного приложения. Делимся исходниками, чтобы разработчики мобильных приложений разрабатывали больше приятных интерфейсов для приложений.

5 стартмани

05.09.2019    6589    57    Baksheev-Nikita    13    

График платежей с отбором по контрагентам. УПП 1.3

Управленческие Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 УПП1 Россия УУ Абонемент ($m)

График платежей с отбором по контрагентам УПП 1.3 позволяет делать отбор, по нескольким контрагентам, так же и по группе контрагентов. Стандартный отчет в УПП этого не делает.

2 стартмани

30.08.2019    1927    1    MARISHA_Viktoria    0    

Сравнительный анализ затрат предприятия по годам для 1С:Бухгалтерии 3.0

Бухгалтерские Финансовые Управленческие Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Финансовый учет и бюджетирование (FRP) Учет доходов и расходов v8 v8::БУ БП3.0 Россия БУ УУ Абонемент ($m)

Внешний отчет управленческого характера показывает затраты предприятия по статьям затрат и подразделениям в сравнении с предыдущим годом.

1 стартмани

25.08.2019    5346    10    accounting_cons    9    

Универсальная система планирования ресурсов, URP Промо

Финансовый учет и бюджетирование (FRP) Управление холдингом (CPM) Учет доходов и расходов Производство Финансовый учет и бюджетирование (FRP) Управление холдингом (CPM) Учет доходов и расходов v8 1cv8.cf 1С:Франчайзи, автоматизация бизнеса УУ Абонемент ($m)

Представляю очень простое и универсальное решение для сквозного планирования всех ресурсов предприятия от продаж до производства, логистики, HR, финансов и т.д. Система позволяет создавать расписания для любых ресурсов и планировать календарные потребности всех ресурсов предприятия, включая отражение в бюджетах рамках одного цикла планирования (например, планировать платежный календарь сразу к поставкам сырья к календарным потребностям производства одним нажатием кнопки). Также данный подход и система пригодны для задач моделирования и прогнозирования, например, для задач моделирования прибыли, нахождения точки безубыточности, ценообразования.

1 стартмани

25.11.2015    27383    50    informa1555    8    

Планирование расхода денежных средств для УНФ 1.6

Печатные формы документов Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 УНФ УУ Абонемент ($m)

Внешняя печатная форма Планирование расхода денежных средств для УНФ 1.6 к документу Планирование расходов денежных средств.

1 стартмани

14.06.2019    3299    1    prime9    0    

Мобильное приложение "Сбор заказов" версия 2.0.1

Мобильная разработка Монитор заказов v8 v8::Mobile 1cv8.cf Украина УУ Абонемент ($m)

Приложение «Сбор заказов» разрабатывалось и разрабатывается для хранения и накопления данных от торговых представителей и автоматического обмена данными с программой учёта на базе платформы 1С:Предприятие. Мобильное приложение написано на технологии мобильной платформы 1С:Предприятие. Механизм обмена данных происходит посредством почтового сервера. В дальнейшем будет реализован механизм непосредственного доступа приложения к учётной системе через прямое интернет-соединение. FTP-соединение не работает как надо, так что будем довольствоваться тем, что есть... :)

4 стартмани

06.06.2019    6406    2    yarsort    10    

Планирование закупок с ручным редактированием количества в макете (с учетом страховых запасов и т.д.) Промо

Финансовый учет и бюджетирование (FRP) Оптовая торговля Розничная торговля Управленческие Финансовый учет и бюджетирование (FRP) Оптовая торговля Розничная торговля v8 УТ10 Россия УУ Абонемент ($m)

Планирование закупок с ручным редактированием количества в сформированном отчете на макете (расчет с учетом страховых запасов и значений точки заказа) и переносом отредактированных данных в заказы!

1 стартмани

16.11.2013    11815    12    sergik444    2    

Event Management - мобильное приложение для управления мероприятиями (Android)

Мобильная разработка Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8::Mobile Развлечения, искусство, спорт УУ Абонемент ($m)

Event Management - мобильное приложение для управления мероприятиями. Отлично подойдет event-агентствам, свадебным организаторам, а также тем, кто проводит консультации, тренинги и т.д. Работает на Android (проверено на версии 5.1).

4 стартмани

31.05.2019    5374    3    yuriy_lokhonya    1    

Мобильное приложение по учету личных финансов Android 7.0

Мобильная разработка Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 Домашние учет и финансы УУ Абонемент ($m)

Мобильное приложение по учету личных финансов, имеется возможность вести учет по банкам, по валюте сканировать чеки, вести учет по статьям движения денежных средств, реализована возможность резервного сохранения данных и синхронизации с приложением на ПК. Имеется демо-версия и собранный apk файл. Тестирование производилось Android 7.0 1С:Предприятие 8.3 (8.3.14.1694) Мобильная платформа 1С:Предприятия 8.3.14.53.

1 стартмани

26.05.2019    5836    2    o.kovalev    4    

Управление задачами (мобильное приложение)

Мобильная разработка v8 1cv8.cf Абонемент ($m)

Конфигурация "Управление задачами" для мобильного приложения.

2 стартмани

29.04.2019    5749    11    noprogrammer    0    

Задолженность поставщикам по срокам долга для "1С:Бухгалтерии 3.0"

Бухгалтерские Финансовый учет и бюджетирование (FRP) Дебиторская и кредиторская задолженность Учет доходов и расходов Финансовый учет и бюджетирование (FRP) Дебиторская и кредиторская задолженность Учет доходов и расходов v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Внешний отчет управленческого характера, показывающий долги поставщикам в валюте и рублях с группировкой по подразделениям, контрагентам, договорам, документам расчета и с разворотом по периодам задолженности. Помимо отчета, результаты выводятся в таблицу, которую можно сохранить в Excel для последующей обработки.

1 стартмани

22.04.2019    8393    53    accounting_cons    23    

Мобильный менеджер

Мобильная разработка Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf Россия УУ Абонемент ($m)

Предлагаю вашему вниманию обновленную программу для менеджеров. Делюсь с надеждой, чтобы пользователи поделились своими наблюдениями, пожеланиями, или проблемами, с которыми они столкнулись.

1 стартмани

09.04.2019    4220    1    ziercool    1    

Анкеты для проведения обследования по подсистемам 1С:ERP

Управление проектом Финансовый учет и бюджетирование (FRP) Производство готовой продукции (работ, услуг) Учет ТМЦ Финансовый учет и бюджетирование (FRP) Производство готовой продукции (работ, услуг) Учет ТМЦ v8 ERP2 1С:Франчайзи, автоматизация бизнеса Россия УУ Абонемент ($m)

Предлагаем вниманию анкеты, используемые для оценки объема проекта внедрения. Анкеты могут использоваться на этапе экспресс-обследования. На более поздних этапах требуется углублять собираемую с клиента информацию для проектирования системы на базе 1С:ERP Управление предприятием 8.

1 стартмани

03.04.2019    18222    937    1СERP    38    

Укрупненное планирование в КА по группам номенклатуры

Финансовый учет и бюджетирование (FRP) Загрузка и выгрузка в Excel Управленческие Финансовый учет и бюджетирование (FRP) v8 КА2 Россия УУ Абонемент ($m)

Обработка загрузки файлов Excel в документ План продаж на год и несложный отчет помогут решить нерешаемую стандартными средствами простую задачу укрупненного товарного планирования. Работает на релизе 1С:Комплексная автоматизация 2, версия 2.4.6.200.

1 стартмани

26.03.2019    3656    4    dobrygin2000    0    

Анализ точки заказа с резервом и свободным остатком

Управленческие Финансовый учет и бюджетирование (FRP) Оптовая торговля Финансовый учет и бюджетирование (FRP) Оптовая торговля v8 КА1 УТ10 УПП1 УУ Абонемент ($m)

Доработанный отчет "Анализ точки заказа", в котором добавлены колонки "Резерв" и "Свободный остаток".

5 стартмани

20.03.2019    4070    3    Torin    1    

"Учет активов и обязательств", ред 1.0 (для дома и бизнеса). Управляемое приложение (8.2). Промо

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Домашние учет и финансы Россия УУ Абонемент ($m)

Простой и удобный способ учета доходов, расходов, кредитов, вкладов, наличных и прочих активов.

1 стартмани

03.09.2012    15556    5    Lighthouse    3    

Рейтинг продаж двух периодов (УТ 11.4)

Управленческие Финансовый учет и бюджетирование (FRP) Оптовая торговля Розничная торговля Финансовый учет и бюджетирование (FRP) Оптовая торговля Розничная торговля v8 v8::ОУ УТ11 УУ Абонемент ($m)

Отчет сравнивает группировки отчета по рейтингу (месту по сумме выручки за выбранные два периода) и если рейтинг вырос, то выделяет его зеленым, если уменьшился, то красным.

1 стартмани

18.03.2019    4894    14    user834357    2    

Валовая прибыль в сравнении цен на дату продажи (УТ 11.4)

Управленческие Финансовый учет и бюджетирование (FRP) Оптовая торговля Розничная торговля Ценообразование, анализ цен Финансовый учет и бюджетирование (FRP) Оптовая торговля Розничная торговля Ценообразование, анализ цен v8 v8::ОУ УТ11 УУ Абонемент ($m)

Отчет показывает валовую прибыль как разницу между суммой продаж и суммой проданного товара в выбранном виде цен (виде цен закупа) на дату продажи.

1 стартмани

14.03.2019    6230    61    user834357    4    

План продаж для УТ 10.3 / УТ 11

Печатные формы документов Финансовый учет и бюджетирование (FRP) Оптовая торговля Финансовый учет и бюджетирование (FRP) Оптовая торговля v8 v8::ОУ УТ10 УТ11 УУ Абонемент ($m)

Внешние печатные формы: План продаж для УТ 10.3 / УТ 11 к документу План продаж.

1 стартмани

01.03.2019    5880    0    prime9    0    

Мои деньги (2.0 beta) Промо

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Домашние учет и финансы Абонемент ($m)

Простая и удобная программа для учета личных финансов. Платформа 8.3.3. Интерфейс Такси.

1 стартмани

15.04.2013    18281    7    nesergey    14    

План продаж по категориям для УТ 11

Печатные формы документов Финансовый учет и бюджетирование (FRP) Оптовая торговля Финансовый учет и бюджетирование (FRP) Оптовая торговля v8 v8::ОУ УТ11 УУ Абонемент ($m)

Внешняя печатная форма: План продаж по категориям для УТ 11 к документу План продаж по категориям.

1 стартмани

28.02.2019    5107    0    prime9    0    

Составление бюджета для заказа номенклатуры

Финансовый учет и бюджетирование (FRP) Управленческие Финансовый учет и бюджетирование (FRP) v8 ERP2 Россия УУ Абонемент ($m)

Отчет предназначен для анализа бюджета на заказ номенклатуры у поставщиков.

2 стартмани

21.02.2019    3008    1    go_margaret    0    

Анализ операционной прибыли в разрезе заказов клиентов

Управленческие Финансовый учет и бюджетирование (FRP) Оптовая торговля Финансовый учет и бюджетирование (FRP) Оптовая торговля v8 v8::ОУ УТ11 УУ Абонемент ($m)

Показывает себестоимость, расходы при продаже (доставка и.т.д), долги, маржинальность, рентабельность в разрезе заказов клиентов + детализация

1 стартмани

08.02.2019    4928    13    Angealtor    1    

УЛФин - Бесплатная конфигурация для Управления Личными Финансами Промо

Финансовый учет и бюджетирование (FRP) Дебиторская и кредиторская задолженность Учет доходов и расходов Управленческий учет (прочее) v8 1cv8.cf Домашние учет и финансы УУ Абонемент ($m)

Конфигурация «Управление личными финансами» является развитием проекта «Домашняя бухгалтерия (на базе 1С 8.0)», но уже на платформе 1С:Предприятие 8.1 «Управление Личными Финансами» - это мощный инструмент для учета личных финансов. Благодаря функции планирования и наглядным отчетам – Вы можете не просто учитывать доходы и расходы, а анализировать их изменение, производить сравнительный анализ по периодам и многое другое.

1 стартмани

19.02.2008    47113    47    z-alexey    529    

Плановое начисление зарплаты на будущие периоды для планирования расходов

Финансовый учет и бюджетирование (FRP) Зарплата Бухгалтерские Управленческие Финансовый учет и бюджетирование (FRP) Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x Россия БУ УУ Абонемент ($m)

Внешний отчет "Плановое начисление зарплаты" предназначен для вывода сведений о начислении зарплаты по сотрудникам и вакантным ставкам на будущие периоды (например, на следующий год для планирования затрат по зарплате). В плановых начислениях можно рассчитать плановые отпуска, премии и вакантные ставки. Тестировал на платформе 1С:Предприятие 8.3 (8.3.13.1513), работает на конфигурации Зарплата и управление персоналом, редакция 3.1, релиз не ниже 3.1.8.137 и Зарплата и кадры государственного учреждения, редакция 3.1, релиз не ниже 3.1.8.137.

10 стартмани

11.01.2019    6678    17    APTEM_SLV    25    

Мобильное приложение для Android по учету выполненных работ/услуг и отслеживанию состояния расчетов с клиентами

Мобильная разработка Производство готовой продукции (работ, услуг) Производство готовой продукции (работ, услуг) v8::Mobile УУ Абонемент ($m)

Мобильное приложение для Android по учету выполненных работ/услуг. Позволяет вести почасовой учет выполненных работ/услуг, их закрытие, а так же отражение оплаты за выполненные работы и услуги. Позволяет сформировать отчеты о выполненных работах и услугах и о состоянии расчетов с клиентами, а так же отправлять результаты формирования отчетов в pdf формате на электронную почту.

1 стартмани

31.12.2018    5739    0    alevpe_1c    12    

График платежей для Бухгалтерии Предприятия 2.0 Промо

Финансовый учет и бюджетирование (FRP) Управленческие Финансовый учет и бюджетирование (FRP) v8 БП2.0 Россия БУ Абонемент ($m)

Отчет "график платежей" показывает платежи, которые требуется совершить в соответствии с остатками на счетах и условиями договора

1 стартмани

13.05.2013    12535    15    poligraff    5    

Конфигурация "Учет финансов"

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 УУ Абонемент ($m)

Предназначена для учета и планирования личных (а может, и не только личных) финансов. Имеет функцию резервирования денежных средств в разрезе статей. Реализованы все необходимые отчеты, а также диаграммы.

5 стартмани

16.12.2018    5278    2    Aphanas    4    

Мобильное приложение: Терминал сбора данных (Автоматизация работы склада в режиме он-лайн)

Терминал сбора данных Мобильная разработка Оптовая торговля Розничная торговля Учет ТМЦ Оптовая торговля Розничная торговля Учет ТМЦ v8::ОУ v8::Mobile ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Мобильное приложение предназначено для автоматизации работы склада в режиме он-лайн. Программа работает на ТСД (или на смартфоне) под управлением Android. Для работы необходим постоянный доступ к веб-публикации центральной базы данных через интернет.

1 стартмани

10.12.2018    15510    70    prof-it60    26    

Отчет о движении денежных средств по месяцам для "1С:Бухгалтерии 3.0"

Бухгалтерские Финансовые Управленческие Банковские операции Финансовый учет и бюджетирование (FRP) Кассовые операции Банковские операции Финансовый учет и бюджетирование (FRP) Кассовые операции v8 v8::БУ v8::СКД БП3.0 Россия БУ УУ Абонемент ($m)

Внешний отчет управленческого характера, показывающий поступления и списания денежных средств предприятия на расчетных счетах и в кассе за произвольный период с разворотом по месяцам.

1 стартмани

06.12.2018    14622    67    accounting_cons    44    

Операционное планирование движения денежных средств или как построить систему контроля расходования денежных средств Промо

Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Управленческий учет (прочее) Бухгалтерский учет Анализ учета Финансовые Управленческие Финансовый учет и бюджетирование (FRP) Учет доходов и расходов v8 КА1 УПП1 Госбюджет УУ Абонемент ($m)

Данная статья посвящена операционному планированию движения денежных средств и будут раскрыты следующие аспекты этой деятельности: 1. роль операционного планирования ДС в жизни компании; 2. подсистема операционного планирования ДС в типовой конфигурации «1С:Управление производственным предприятием ред. 1.3 (релиз 1.3.32.1)» (далее по тексту УПП); 3. особенности и ошибки типовой подсистемы УПП; 4. практический опыт внедрения подсистемы операционного планирования ДС; 5. возможные варианты доработок, исправления ошибок типовой подсистемы УПП;

1 стартмани

24.12.2012    75630    30    Vladimir_Konyrev    36    

Изменение показателей бюджетной сметы (ф. 0501013)

Печатные формы документов Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 v8::БУ БГУ Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m)

Печатная форма "Изменение показателей бюджетной сметы (ф. 0501013)" в соответствии с изменениями и дополнениями Приказа Минфина РФ от 20 ноября 2007 г. N 112н от 30 сентября 2016 г., 23 марта 2018 г.

1 стартмани

22.11.2018    5802    1    dp_bs21    0    

Бюджет семьи (конфигурация)

Финансовый учет и бюджетирование (FRP) Управленческий учет (прочее) v8 Домашние учет и финансы УУ Абонемент ($m)

Простая конфигурация на платформе 8.3, позволяющая вести учет семейного бюджета. Бюджет семьи у нас общий, ведется в разрезе "счетов" - например Кредитная карта, кошелек, шкатулка и т.д. Работает на платформе 8.3.13.1513

1 стартмани

19.11.2018    6913    2    vln    10    

Мобильное приложение "Вслух"

Мобильная разработка v8 Обучение, бизнес-тренинг, курсы Россия Абонемент ($m)

Не с кем учить уроки? Говорящий репетитор в твоём мобильном! Обучающее мобильное приложение для детей и слабовидящих.

1 стартмани

16.11.2018    6434    3    RSConsulting    4    

Отчет о движении денежных средств с план/факт анализом, возможностью корректировки плановых показателей

Финансовые Управленческие Финансовый учет и бюджетирование (FRP) Финансовый учет и бюджетирование (FRP) v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Отчет о движении денежных средств с возможностью ввода плановых показателей и дальнейшего контроля выполнения плана. Внешний отчет для типовой конфигурации "Бухгалтерия предприятия"

10 стартмани

25.10.2018    5688    7    Miracle180882    4