Выгрузка номенклатуры в социальную сеть Вконтакте

Публикация № 1107865

Обмен - Интеграция с WEB

обработка публикация товары номенклатура вконтакте вк vk

29
Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

Описание

Обработка предназначена для публикации ваших товаров(номенклатуры) в социальной сети Вконтакте, при помощи обработки можно опубликовать товары в следующих разделах сайта:

  • Стена пользователя
  • Альбом пользователя
  • Стена группы/сообщества
  • Альбом группы/сообщества
  • Магазин группы(раздел товары)

Обязательно посмотрите видеообзор - объясняется принцип работы обработки и описываются ее настройки, и преимущества.

P.S. В дальнейшем планирую переводить на расширение и сильно оптимизировать функционал. Кому интересно ставьте "лайки" ;)

Примечания

Обработку можно использовать отдельно и можно подключить через стандартный механизм "Дополнительные отчеты и обработки".

Совместимость

Платформа:

  • должна работать на всех релизах 8.3
  • тестировалась на релизах:
    • 8.3.9.2033
    • 8.3.10.2639
    • 8.3.14.1565
    • 8.3.15.1489

Конфигурации:

  • BAS Управление торговлей для Украины
    • тестировалась на релизах:
      • 3.2.9.4
  • BAS Розничная торговля для Украины
    • тестировалась на релизах:
      • 2.2.8.2
  • Управление небольшой фирмой для Украины
    • тестировалась на релизах:
      • 1.6.9.1
  • Управление торговлей
    • тестировалась на релизах:
      • 11.4.8.68
  • Розница
    • тестировалась на релизах:
      • 2.2.9.20
  • Управление небольшой фирмой
    • тестировалась на релизах:
      • 1.6.18.145

Обзор обработки

 

Причины купить

Данная обработка дешевле аналогичных и на порядок лучше.

Сравнение версий

Версия 1.0.0

  • Текущее описание обработки
29

Скачать файлы

Наименование Файл Версия Размер
Выгрузка номенклатуры в социальную сеть Вконтакте:
.epf 50,63Kb
14.08.19
10
.epf 1.0.0 50,63Kb 10 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. spy-83 183 14.08.19 15:41 Сейчас в теме
Очень неплохое решение.
Отличная работа!
2. kalyuzhny 41 14.08.19 15:49 Сейчас в теме
(1) О, это моя первая похвала на инфостарте ;) Спасибо.
SinglCOOLer; +1 Ответить
3. kalyuzhny 41 14.08.19 16:40 Сейчас в теме
Товарищи!
Если обнаружите косяки в работе обработки - пишите.
Будем исправлять ;)
4. Dzenn 323 15.08.19 17:44 Сейчас в теме
Выглядит с первого взгляда, как что-то интересное :-) Правда, лично у меня есть сомнения в её востребованности, по той простой причине, что ВКонтакте не воспринимается большинством людей как торговая площадка, по моему скромному мнению.
5. kalyuzhny 41 15.08.19 17:58 Сейчас в теме
(4) Отчасти, согласен. Лично я тоже не особо воспринимаю магазин(категория - товары, в группе). Однако у нас в ДНР, очень много розничных предприятий которые заводят группы и публикуют там свои товары, вот и подумал может кроме "наших", в мире тоже кто-то так делает))) Ну, за одно и познакомился с API ВКонтакте...
6. Dzenn 323 15.08.19 18:02 Сейчас в теме
(5) осталось правильно оформить, подробно расписать возможности, и выложить на продажу :-) Вот моё, например https://infostart.ru/public/627500/ - если бы не моя лень, продаж было бы раз в пять больше, но и то, что продаётся, тоже приятно ;-)
7. kalyuzhny 41 15.08.19 18:03 Сейчас в теме
Сейчас кстати поступила задачка сделать аналогичное для facebook. Так, что кому интересно - следите... А потом вернусь к этой обработке, и переделаю, так как там ещё нужно код оптимизировать...
8. user1267557 15.08.19 21:04 Сейчас в теме
9. Yashazz 2505 16.08.19 00:04 Сейчас в теме
У всех таких публикаций есть общая беда - они косячат при попытке подключиться к ВК. На этапе авторизации. Я 2-3 таких скачал, обломался и плюнул. Автор, если не сложно, можете подробнее описать, как в вашем случае сделана авторизация?
10. kalyuzhny 41 16.08.19 00:27 Сейчас в теме
(9)
Доброй ночи. Авторизацию, а именно получение "токена", делал просто:
На форме создаем поле HTML документа, указываем у него ПутьКДанным - ссылаемся на реквизит формы/объекта(не важно с типом строка).
Ну далее отправляем по нужно url, а короче вот код, думаю разберешься:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
	ПЕРЕМ ИДПриложения;
	
	//
	Если НЕ Параметры.Свойство("ИДПриложения", ИДПриложения)
		ИЛИ НЕ ЗначениеЗаполнено(ИДПриложения) Тогда
		Отказ = Истина;
	КонецЕсли;
	
	//
	АдресURL = "https://oauth.vk.com/authorize"
			 + "?client_id=" + ИДПриложения + "" // Идентификатор Вашего приложения.
			 + "&redirect_uri=https://api.vk.com/blank.html" // Адрес, на который будет переадресован пользователь после прохождения авторизации
			 + "&display=page" // Указывает тип отображения страницы авторизации. (page — форма авторизации в отдельном окне; popup — всплывающее окно; mobile — авторизация для мобильных устройств (без использования Javascript))
			 + "&scope=wall,groups,photos,market,offline" // Битовая маска настроек доступа приложения (https://vk.com/dev/permissions)
			 + "&response_type=token" // Тип ответа, который необходимо получить. Укажите token.
			 + "&state=" // Произвольная строка, которая будет возвращена вместе с результатом авторизации.
			 + "&revoke=1" // Параметр, указывающий, что необходимо не пропускать этап подтверждения прав, даже если пользователь уже авторизован.
			 + ""
			 ;
	
КонецПроцедуры // ПриСозданииНаСервере

&НаКлиенте
Процедура HTMLДокументСформирован(Элемент)
	ПЕРЕМ КлючДоступаПользователя;
	
	//
	Если Элемент.Документ.Location.host = "api.vk.com" Тогда

		//маПараметры = СтроковыеФункцииКлиентСервер.РазложитьСтрокуВМассивПодстрок(Сред(Элемент.Документ.Location.hash, 2), "&");
		маПараметры = СтрРазделить(Сред(Элемент.Документ.Location.hash, 2), "&");
        Для Каждого Параметр ИЗ маПараметры Цикл
            Сообщить(Параметр);
			Позиция = СтрНайти(Параметр, "=");
			Если Позиция > 0
				И НРег(СокрЛП(Лев(Параметр, Позиция - 1))) = "access_token" Тогда

				КлючДоступаПользователя = СокрЛП(Сред(Параметр, Позиция + 1));
				Прервать;
			КонецЕсли;

        КонецЦикла;
		
        Закрыть(КлючДоступаПользователя);

    КонецЕсли;
	
КонецПроцедуры // HTMLДокументСформирован
Показать


P.S. У меня кстати тоже не сразу, вышло... Но голова уже забита другим, не помню в чем была проблема, а не кажись вспомнил, где-то я подглядел и там был в url указан такой параметр &redirect_uri=http://api.vk.com/blank.html, а нужно указать так - &redirect_uri=https://api.vk.com/blank.html, как говорится найди 10 отличий :D
11. Yashazz 2505 16.08.19 12:26 Сейчас в теме
(10) Блин, да, точно, там от секьюрности могло зависеть... Спасибо, попробую!
Оставьте свое сообщение