Black Friday: Cashback 35% при покупке 1С лицензий на счет INFOSTART.RU

Ввод остатков по 76.ВА в 1С ПУБ

Публикация № 126650

Разработка - Практика программирования

2
Статья посвящена найденному мной недостатку в конфигурации 1С 7.7 "Производство-услуги-бухгалтерия", связанному с вводом начальных остатков по 76.ВА.

При попытке настроить соответствующий документ ввода остатков должным образом и провести, программа выдает ошибку и в общем итоге ввести остатки не получается.Итак, что нужно сделать.

Во-первых, если по контрагенту есть остаток по 76.ВА, то по нему же должен быть остаток по 60.2
Находим, как мы ввели остаток по 60.2. Для этого мы использовали документ "Ввод остатков по расчетам с поставщиками" с видом остатка
"Ввод остатка выданных авансов". В строке этого документа, по которой вводится остаток также указывается документ списания денежных средств,
которым, собственно аванс и был порожден. Запомним, что это за документ (выпишем на листок).
Далее: для ввода остатков по 76.ВА используем  документ "Ввод остатков НДС" (Ввод остатков НДС по приобретенным ценностям).
В каждой строке т.ч. документа вводим Контрагента, Ставку НДС, Тип НДС (тут предусмотрен специальный тип="НДС по выплаченным авансам"),
База НДС (она должна соответствовать сумме долга по 60.2 по одной строке т.ч. документа ввода остатков по авансу поставщика), НДС рассчитается
автоматически, при необходимости сумму НДС можно откорректировать вручную.
Заметим, что с/ф мы не заполняли.
Ставим галочку "Формировать проводки...", записываем (не проводим!) документ
Теперь вносим изменения в модуль проведения документа.
Меняем целиком приведенную ниже процедуру (правки обозначены блоками //яяя //яяя!)
Правился изначально 329 релиз, возможно в более поздних релизах было все исправлено.
В 

	Процедура ОбработкаПроведения() // Предопределенная процедура

	    Если СоздаватьОперацию = 1 Тогда

	        глИнициализацияТаблицыПроводок();

	    КонецЕсли;

	    

	    Сч68_2 = СчетПоКоду("68.2");



	    ТаблицаАвтоДокументов = СоздатьОбъект("ТаблицаЗначений");

	    ТаблицаАвтоДокументов.НоваяКолонка("Контрагент", "Справочник");

	    ТаблицаАвтоДокументов.НоваяКолонка("СчетФактура", "Документ");



	    ВыбратьСтроки();

	    Пока Получитьстроку() = 1 Цикл

	        Если ПустоеЗначение(Контрагент) = 1 Тогда

	            глНеПроводить(Контекст,"Строка:" + СокрЛП(НомерСтроки) + ", необходимо указать контрагента. Строка НЕ обработана!");

	        КонецЕсли;

	        Если ПустоеЗначение(СтавкаНДС) = 1 Тогда

	            глНеПроводить(Контекст,"Строка:" + СокрЛП(НомерСтроки) + ", необходимо указать ставку НДС. Строка НЕ обработана!");

	        КонецЕсли;

	        Если ПустоеЗначение(ТипНДС) = 1 Тогда

	            глНеПроводить(Контекст,"Строка:" + СокрЛП(НомерСтроки) + ", необходимо указать тип НДС. Строка НЕ обработана!");

	        КонецЕсли;

	        Если (ПустоеЗначение(СчетФактура) = 1) и (ТипХозОперации = 1) Тогда

	            глНеПроводить(Контекст,"Строка:" + СокрЛП(НомерСтроки) + ", необходимо указать счет-фактуру. Строка НЕ обработана!");

	        КонецЕсли;

	        Если СтатусВозврата() = 0 Тогда

	            Продолжить;

	        КонецЕсли;

	        ПривязыватьСтроку(НомерСтроки);



	        Если ПустоеЗначение(СчетФактура) = 1 Тогда

	            Стр = 0;

	            Если ТаблицаАвтоДокументов.НайтиЗначение(Контрагент, Стр, "Контрагент") = 0 Тогда

	                АвтоДокумент = СоздатьОбъект("Документ.СчетФактураПолученный");

	                АвтоДокумент.Новый();

	                АвтоДокумент.ДатаДок = ДатаДок;

	                АвтоДокумент.УстановитьНовыйНомер();

	                АвтоДокумент.Контрагент = Контрагент;

	                АвтоДокумент.Комментарий = "Фиктивный документ для ввода начальных остатков";

	                АвтоДокумент.Записать();



	                ТаблицаАвтоДокументов.НоваяСтрока();

	                ТаблицаАвтоДокументов.Контрагент = Контрагент;

	                ТаблицаАвтоДокументов.СчетФактура = АвтоДокумент.ТекущийДокумент();

	                глСообщениеПроведения("Создан фиктивный документ для ввода начальных остатков - " + глПредставлениеДокумента(АвтоДокумент), ТекущийДокумент());

	            Иначе

	                ТаблицаАвтоДокументов.ПолучитьСтрокуПоНомеру(Стр);

	            КонецЕсли;

	            СчетФактура = ТаблицаАвтоДокументов.СчетФактура;

	            глСообщениеПроведения("Строка:" + СокрЛП(НомерСтроки) + ", не указан счет-фактура. Автоматически подставлен документ - " + глПредставлениеДокумента(СчетФактура), ТекущийДокумент());

	        КонецЕсли;

	        

	        Регистр.НДСпоПриобретеннымЦенностям.Контрагент = Контрагент;

	        Регистр.НДСпоПриобретеннымЦенностям.СчетФактура = СчетФактура;

	        Регистр.НДСпоПриобретеннымЦенностям.СтавкаНДС = СтавкаНДС;

	        Регистр.НДСпоПриобретеннымЦенностям.ТипНДС = ТипНДС;

	        Регистр.НДСпоПриобретеннымЦенностям.БазаНДС = БазаНДС;

	        Регистр.НДСпоПриобретеннымЦенностям.НДС = НДС;

	        Регистр.НДСпоПриобретеннымЦенностям.КодОперации = "";

	        Регистр.НДСпоПриобретеннымЦенностям.ЗаписьДопЛиста = "";

	        Регистр.НДСпоПриобретеннымЦенностям.ДатаДопЛиста = "";

	        //яяя

	        Если ТипНДС<>Перечисление.ТипыНДС.Аванс Тогда

	            Если ТипХозОперации = 0 Тогда

	                Регистр.НДСпоПриобретеннымЦенностям.ВключатьВКнигуПокупок = 0;

	                Регистр.НДСпоПриобретеннымЦенностям.ДвижениеПриходВыполнить();

	            Иначе

	                Регистр.НДСпоПриобретеннымЦенностям.ВключатьВКнигуПокупок = 1;

	                Регистр.НДСпоПриобретеннымЦенностям.ДвижениеРасходВыполнить();

	            КонецЕсли;

	        Иначе

	            Регистр.НДСпоПриобретеннымЦенностям.ВключатьВКнигуПокупок = 1;

	            Регистр.НДСпоПриобретеннымЦенностям.ДвижениеПриходВыполнить();

	        КонецЕсли;

	        //яяя!

	        Если (СоздаватьОперацию = 1) или (ТипХозОперации = 1) Тогда

	            

	            Если ТипНДС = Перечисление.ТипыНДС.ОС Тогда

	                СчетНДС = СчетПоКоду("19.1");

	            ИначеЕсли ТипНДС = Перечисление.ТипыНДС.НМА Тогда

	                СчетНДС = СчетПоКоду("19.2");

	            ИначеЕсли ТипНДС = Перечисление.ТипыНДС.МПЗ Тогда

	                СчетНДС = СчетПоКоду("19.3");

	            ИначеЕсли ТипНДС = Перечисление.ТипыНДС.Таможня Тогда

	                СчетНДС = СчетПоКоду("19.4");   

	                //яяя

	            ИначеЕсли ТипНДС=Перечисление.ТипыНДС.Аванс Тогда

	                СчетНДС=СчетПоКоду("76.ВА");

	                //яяя!

	            КонецЕсли;

	            



	            Если ТипХозОперации = 0 Тогда   

	                //яяя  

	                Если   ТипНДС<>Перечисление.ТипыНДС.Аванс Тогда

	                    глПроводка(СчетНДС, Контрагент, , ,

	                    СчетПоКоду("00"), , , ,

	                    НДС, "Ввод ост. НДС", "ВО");  

	                Иначе   

	                    глПроводка(СчетПоКоду("00"), , , ,

	                    СчетНДС,Контрагент , , ,

	                    НДС, "Ввод ост. НДС аванса", "ВО");  

	                КонецЕсли;

	                //яяя!

	            Иначе

	                Если СчетФактура.Вид() = "ПоступлениеМПЗИмпорт" Тогда

	                    Контрагент = СчетФактура.Таможня;

	                Иначе

	                    Контрагент = СчетФактура.Контрагент;

	                КонецЕсли;

	                

	                глПроводка(Сч68_2, Перечисление.ВидыПлатежейВБюджет.Налог, , ,

	                           СчетНДС, Контрагент, , ,

	                           НДС, "Вычет НДС, предъявлен. до 2006г.", "ПС");

	            КонецЕсли;

	        КонецЕсли;

	    КонецЦикла;



	        Если (СоздаватьОперацию = 1) и (СтатусВозврата() = 1) Тогда

	        глСформироватьПроводки(Операция, 2);

	        Операция.Записать();

	    КонецЕсли;

	    

	    глПриПроведении(Контекст);



	КонецПроцедуры // ОбработкаПроведения()


Теперь, сохранив конфигурацию, можно вернуться в документ и провести его.
В т.ч. будут созданы фиктивные счета-фактуры.
Нужно зайти в каждого из них (прямо из документа ввода остатков) и в качестве документа-основания выбрать тот самый документ списания, породивший аванс поставщика (мы должны были выписать информацию по нему на листок :))
Также лучше указать договор (не проверял, насколько это принципиально)
После этого запишите с/ф без проведения. Заметим также, что с/ф примет новый вид "на аванс".В принципе все.
Ну на всякий случай можно еще раз перепровести документ ввода остатков по НДС.

2

Специальные предложения

Избранное Подписка Сортировка: Древо
В этой теме еще нет сообщений.
Оставьте свое сообщение

См. также

Как в торговле 7.7 печатать код ТНВЭД в счет-фактуре 0

Статья Программист Нет файла v77::ОУ 1С7:ТиС Россия БУ Внешнеэкономическая деятельность (ВЭД) НДС Бесплатно (free) Практика программирования

В данной статье хотел поделиться опытом, как в Торговле 7.7 ( релиз 994) сделать возможность выводить код ТНВЭД в печатную форму счета-фактуры. Сразу скажу, что нужно это только тем, кто осуществляет экспорт в страны таможенного союза. Остальные могут не волноваться.

15.11.2017    8789    AndKovalchuk    0       

Перенос данных КА 1.1 => ERP 2 (ЕРП) (обработка переноса документов, остатков и справочной информации из "1С:Комплексная автоматизация, ред. 1.1" в "1С:ERP Управление предприятием, ред 2"). Обновлен до КА 1.1.115.х и ERP 2.4.10.х Промо

Обработка позволяет переносить из КА 1.1 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления в случае выхода новых релизов конфигураций 1С.

29700 руб.

.Net в 1С. На примере использования HTTPClient, AngleSharp. Удобный парсинг сайтов с помощью библиотеки AngleSharp, в том числе с авторизацией аля JQuery с использованием CSS селекторов. Динамическая компиляция 111

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования WEB

Часто приходится парсить сайты, в том числе с авторизацией, перескакивая со страницы на страницу по ссылкам. Тот, кто занимался вэб программированием, знает, как удобно использовать JQuery и CSS селекторы. На .Net написана очень удобная библиотека AngleSharp. Я покажу, как с её помощью можно значительно облегчить себе труд.

10.03.2016    49543    Serginio    33       

Перенос данных БП 3.0 => УТ 11 / КА 2 / ERP 2 (ЕРП) (перенос остатков, документов и справочной информации из "1С:Бухгалтерия предприятия 8", ред.3.0). Обновлено до БП 3.0.73.х, УТ 11.4.10.х, КА 2.4.10.х., ERP 2.4.10.х! Промо

Переносятся документы за выбранный период, справочная информация и остатки по счетам бух. учета в программу УТ 11 / КА 2 / ЕРП 2 (ERP). Переносятся все возможные виды операций ввода остатков на нужную дату. Есть отбор по периоду переноса документов и фильтр по организации, доступен выбор даты ввода остатков. Если нужно переносить что-то дополнительно, то обычно бесплатно добавляем это в перенос . Смотрите видеодемонстрацию со звуком - советами по переносу и рекомендациями настройки программ.

29700 руб.

.Net в 1С. Асинхронные HTTP запросы, отправка Post нескольких файлов multipart/form-data, сжатие трафика с использованием gzip, deflate, удобный парсинг сайтов и т.д. 37

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Разработка внешних компонент WEB

Очень часто нужно при работе с HTTP сервисами или сайтами использовать Асинхронные HTTP запросы, отправку на сервер нескольких файлов, использование сжатия трафика. Эта статья про то, как этого легко добиться.

09.03.2016    26470    Serginio    22       

Использование классов .Net в 1С для новичков 148

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Разработка внешних компонент Универсальные функции

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    64550    Serginio    104       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Хитрости сохранения табличного документа в Excel для дальнейшей работы с ним 78

Статья Программист Нет файла v7.7 v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Все пользователи 1С всех версий (начиная с 7-й) сталкиваются с проблемой нормальной работы с данными, сохраненными в Excel файл. Есть некоторые хитрости, которые позволяют облегчить работу с сохраненными данными из 1С в формат Excel.

16.01.2015    73395    shmellevich    35       

Специальное предложение по 1С:Документооборот 8! Промо

Оперативно навести порядок в документообороте? Легко! Воспользуйтесь специальным предложением! Внедрение за 2 недели! Фиксированная цена и гарантия результата!

Онлайн-интенсив "Бизнес-процессы для подготовки к экзамену 1С:Специалист по платформе" 12 декабря 2019 г. Промо

На интенсиве будут рассмотрены все теоретические вопросы, связанные с устройством механизма бизнес-процессов – это необходимо для успешной сдачи экзамена 1С:Специалист по платформе. Также, в качестве практического примера, будет решена задача, аналогичная экзаменационной.

777 рублей

Скрытие помеченных на удаление в справочнике 5

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Корректно скрываем помеченных на удаление в справочнике, с иерархией и без. Вроде простая и нужная вещь, но почему-то нигде не встречалась

08.08.2012    11628    mikukrnet    7       

Исправление и проведение документов 5

Статья Программист Нет файла v77::БУ 1С7:ПУБ Россия Бесплатно (free) Практика программирования

Исправление и проведение документов, например, счетов-фактур, введенных на основании документов реализации, можно организовать многими способами. Описан сравнительно простой подход, реализованный и работающий несколько лет в реальной бухгалтерии 1Cv7.7. Без внешних компонентов.

23.07.2012    11793    BorisBelov    11       

Перенос документов, остатков и справочников КА 1.1 => КА 2 / УТ 11. Обновлено до КА 2.4.10.х и УТ 11.4.10.х! Промо

Более 130 компаний выполнили переход на КА 2 или УТ 11 с помощью нашей разработки! Позволяет перенести не только остатки и справочники (как типовая обработка), но и документы за нужный период времени. Предоставляем техподдержку, оперативно исправляем замечания, выпускаем обновления при выходе новых релизов программ 1С. Вы можете проверить разработку до покупки: сделаем бесплатный тестовый перенос из вашей базы КА 1.1 и предоставим доступ к базе-результату через веб-клиент!

29700 руб.

Продажа собственной фирме (интеркомпани) - заполнение отрицательными остатками 9

Статья Программист Нет файла v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Учет ТМЦ Бесплатно (free) Практика программирования

В документе "Продажа собственной фирме" приходится добавлять номенклатуру вручную через подбор. А ведь можно сэкономить время и заполнить спецификацию документа на основании отрицательных остатков фирмы. Все просто...

06.05.2012    11484    2sw    4       

Cashback 35% при покупке 1С лицензий на счет INFOSTART.RU с 27.11 по 04.12 Промо

Оформляете заказ на 1С лицензии или конфигурации. Получаете 35% от стоимости на счет в профиле INFOSTART.RU. Выбираете сервисы и продукты на сумму кэшбэка.

Обновление базы 1с 7.7. с помощью движка 1с 8.х 92

Статья Системный администратор Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования Администрирование данных 1С

Если Вас угораздило в стандартную типовую конфу внести правки, причем в самый большой модуль, а именно глобальный. Если к тому же Вы внесли изменение в какую-то стандартную функцию, в которой 1с сама регулярно чего-то меняет, то любое обновление начинает доставать. Используя возможности движка платформы 1с 8.х можно существенно сэкономить себе время и нервы.

28.04.2012    16388    Valerich    31       

Ошибка при формировании отчета Авансы по налогу на имущество. В 1С:Предприятие 7.7. Регламентированная отчетность за I квартал 2012 года Обновление 12q1009 от 18.04.2012 г. 18

Статья Программист Нет файла v77::ОУ v77::БУ 1cv7.md Россия Бесплатно (free) Практика программирования

При формировании отчета NIMAVP1.ERT Авансы по налогу на имущество (версия 5.03) в разделе № 1-3 не сохраняет номера Страниц при выборе, что ведет к не сохранению и выводу печати двухмерного кода.

24.04.2012    7584    leo072    7       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.127.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Ошибка при формировании отчета 4-ФСС для УСН 7,7 12q1007 6

Статья Программист Нет файла v77::БУ 1С7:Бух Россия НУ Бесплатно (free) Практика программирования

При формировании таблицы 6,7 раздела 2 возникает ошибка ИтАн.ИспользоватьСубконто(ВидыСубконто.ВидыПлатежейВФонды, Перечисление.ВидыПлатежей.Штраф); {C:\PROGRAM FILES\1CV77\SSTDEMO\EXTFORMS\RP12Q1.GRP\FSS4_1212.ERT(2330)}: Поле агрегатного объекта не обнаружено (ВидыПлатежейВФонды)

11.04.2012    9517    *Zed*    1       

v77. Робот 43

Инструменты и обработки no Внешняя обработка (ert,epf) v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

Исполнитель Робот. Учебное пособие по программированию для детей дошкольного возраста. Без внешних компонент.

09.04.2012    10587    54    item    18       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Запуск внешней обработки по расписанию v7.7 39

Статья Программист Нет файла v7.7 1cv7.md Россия Windows Бесплатно (free) Практика программирования Администрирование данных 1С

Неоднократно возникали задачи организовать, например ежедневную выгрузку и отправку отчетов по эл.почте, и вот…

20.03.2012    40384    Yury1001    17       

v77. Паинт 53

Инструменты и обработки Программист Внешняя обработка (ert,epf) v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

v77. 1С:Паинт :) Такая вот игрушка. Без внешних компонент.

06.03.2012    12536    81    item    38       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Быстрый отбор в журнале на конкретную дату 7

Статья Программист Нет файла v77::ОУ 1cv7.md Россия Бесплатно (free) Практика программирования

Лень - двигатель прогресса. Полезная фича для быстрого отбора документов в любом журнале на конкретную дату.

27.02.2012    9468    avers007    16       

ЗиК 321, в отчетах пропадает проводка по ПФР_страховая 25

Статья Программист Нет файла v77::ОУ v77::Расчет 1С7:ЗиК Россия ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

При формировании отчета "Свод проводок" с галкой "Учет начисления налогов с ФОТ, включаемых в состав расходов" в отчет не выходит ПФР_страх

10.02.2012    5056    filh    19       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.127.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Ошибка в 1С:Бух77 ред.533 Начисление ФФОМС при ЕНВД 11

Статья Программист Нет файла v77::БУ 1С7:Бух Россия Зарплата Бесплатно (free) Практика программирования

При начислении налогов с ФОТ (док.ЗакрытиеМесяца) не расчитываются налоги ФФОМС, если начисление зарплаты проводится как "облагаемые ЕНВД".

22.01.2012    8284    lelbraun    3       

Как уменьшить количество заблокированных объектов 26

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

История о том как я решил пересобрать форму справочника клиентов и чем это все закончилось...

12.01.2012    13638    ShEvOvIcH    18