Продажа собственной фирме (интеркомпани) - заполнение отрицательными остатками

Публикация № 127253

Разработка - Практика программирования

В документе "Продажа собственной фирме" приходится добавлять номенклатуру вручную через подбор. А ведь можно сэкономить время и заполнить спецификацию документа на основании отрицательных остатков фирмы. Все просто...


1. Открываем конфигуратор. Документы --> Быстрая продажа --> Форма --> Модуль
2. Идем в конец модуля, после последней строки вставляем код

	 // Предопределенная процедура
//sw
Процедура ОбработкаПодбора(ВыбЗнач, КонтФормыПодбора)
   //есть ставки налогов, есть скидка
   глОбработкаПодбора(Контекст, ВыбЗнач, 1, 1, 1);
КонецПроцедуры // ОбработкаПодбора()

	 Процедура ЗаполнитьПоОстаткам()
   //проверки
   Если Форма.Параметр <> "Перемещение" Тогда
      Предупреждение("Только для внутрифирменных продаж");
      Возврат;
   ИначеЕсли КоличествоСтрок() <> 0 Тогда
      Если Вопрос("Заполнить по отрицательным остаткам склада покупателя (перед заполнением табличная часть будет очищена)?", "Да+Нет", 60) <> "Да" Тогда
         Возврат;
      КонецЕсли;
      Сообщить("заполняю");
      УдалитьСтроки();
   КонецЕсли;
   //конец проверок

   ТекстЗапросаОстатков="
   |ФирмаПокупат = Регистр.ОстаткиТМЦ.Фирма;
   |Номенклатура = Регистр.ОстаткиТМЦ.Номенклатура;
   |СкладПокупат = Регистр.ОстаткиТМЦ.Склад;
   |Количество = Регистр.ОстаткиТМЦ.Количество;
   |Функция КоличествоКонОст = КонОст(Количество);
   |Группировка Номенклатура без групп;
   |Условие(ФирмаПокупат=ФирмаПокупателя);
   |Условие(СкладПокупат=СкладПокупателя);";

   ЗапросПоОстаткам = СоздатьОбъект("Запрос");
   Если ЗапросПоОстаткам.Выполнить(ТекстЗапросаОстатков) = 0 Тогда
      Возврат;
   КонецЕсли;
   флаг=0; // для отслеживания того что отбор был

   СписокНоменклатуры =СоздатьОбъект("СписокЗначений"); // думаю пригодится.

   Пока ЗапросПоОстаткам.Группировка(1) = 1 Цикл
      Если ЗапросПоОстаткам.КоличествоКонОст < 0 Тогда //нам нужны отрицательные остатки
         флаг=1;
         НоваяСтрока();
         Номенклатура=ЗапросПоОстаткам.Номенклатура;
         Количество=-ЗапросПоОстаткам.КоличествоКонОст;
         глПересчетТаблЧасти(Контекст,"Номенклатура");
         глПересчетТаблЧасти(Контекст,"Количество");
      КонецЕсли;
   КонецЦикла;

   Если флаг=0 Тогда
      Сообщить("У организации " + ФирмаПокупателя + " по складу " + СкладПокупателя + " не найдено отрицательных остатков");
      Возврат;
   КонецЕсли;
КонецПроцедуры

3. Переходим в диалог формы (слой табличная часть). Вставляем кнопку (Главное меню --> Вставка --> Кнопка).

4. Переходим на кнопке на вкладку "Дополнительно" и заполняем формулу вписанной в модуль процедурой: ЗаполнитьПоОстаткам()

 Заполнить по остаткам
5. Сохраняем изменения конфигурации. Запускаем 1С.

Кнопка заполнить работает и экономит время. 5 минут работы ))

 

зы. спасибо этим публикациям

http://1c.proclub.ru/modules/mydownloads/personal.php?cid=5&lid=3432 

http://forum.infostart.ru/forum11/topic42164/

 

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Фред 09.05.12 08:27 Сейчас в теме
Эх! Опять куда-то в модуль послали...)) Я в модуль ходить давно боюсь....как за три месяца первичку ручками восстановил...((
2. eleonora 02.12.14 23:54 Сейчас в теме
Спасибо! А можно получить остатки на определенную дату?
3. Vesna789 07.12.15 22:47 Сейчас в теме
Добрый вечер, не могли помочь? Сделала все как вы описали, работает но выдает ошибку:
ЗаполнитьПоОстаткам<<?>>()
Процедура вызывается как функция (ЗаполнитьПоОстаткам)
Что я не правильно сделала?
Оставьте свое сообщение

См. также

Как в торговле 7.7 печатать код ТНВЭД в счет-фактуре

Статья Программист Нет файла v77::ОУ 1С7:ТиС Россия БУ Внешнеэкономическая деятельность (ВЭД) НДС Бесплатно (free) Практика программирования

В данной статье хотел поделиться опытом, как в Торговле 7.7 ( релиз 994) сделать возможность выводить код ТНВЭД в печатную форму счета-фактуры. Сразу скажу, что нужно это только тем, кто осуществляет экспорт в страны таможенного союза. Остальные могут не волноваться.

15.11.2017    9315    AndKovalchuk    0       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

.Net в 1С. На примере использования HTTPClient, AngleSharp. Удобный парсинг сайтов с помощью библиотеки AngleSharp, в том числе с авторизацией аля JQuery с использованием CSS селекторов. Динамическая компиляция

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования WEB

Часто приходится парсить сайты, в том числе с авторизацией, перескакивая со страницы на страницу по ссылкам. Тот, кто занимался вэб программированием, знает, как удобно использовать JQuery и CSS селекторы. На .Net написана очень удобная библиотека AngleSharp. Я покажу, как с её помощью можно значительно облегчить себе труд.

10.03.2016    51185    Serginio    33       

Использование классов .Net в 1С для новичков

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Разработка внешних компонент Универсальные функции

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    67133    Serginio    104       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Хитрости сохранения табличного документа в Excel для дальнейшей работы с ним

Статья Программист Нет файла v7.7 v8 1cv8.cf 1cv7.md Windows Бесплатно (free) Загрузка и выгрузка в Excel Практика программирования

Все пользователи 1С всех версий (начиная с 7-й) сталкиваются с проблемой нормальной работы с данными, сохраненными в Excel файл. Есть некоторые хитрости, которые позволяют облегчить работу с сохраненными данными из 1С в формат Excel.

16.01.2015    77999    shmellevich    35       

Управление ИТ-проектами. Модуль 2: продвинутый онлайн-курс по классическим методам управления проектами. Вебинары проходят с 12 марта по 11 июня 2020 года. Промо

Продвинутый онлайн-курс по классическому управлению ИТ-проектами позволит слушателям освоить инструменты из PMBoK® и 1С:Технологии корпоративного внедрения и научиться их применять для проектов любого масштаба. Курс включает в себя 12 вебинаров и 12 видеолекции, разбор кейсов и рекомендации экспертов по проектам слушателей. Ведущая курса - Мария Темчина.

от 13000 рублей

Скрытие помеченных на удаление в справочнике

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Практика программирования

Корректно скрываем помеченных на удаление в справочнике, с иерархией и без. Вроде простая и нужная вещь, но почему-то нигде не встречалась

08.08.2012    12322    mikukrnet    7       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Ввод остатков по 76.ВА в 1С ПУБ

Статья Программист Нет файла v77::ОУ v77::БУ 1С7:ПУБ Россия БУ Бесплатно (free) Практика программирования

Статья посвящена найденному мной недостатку в конфигурации 1С 7.7 "Производство-услуги-бухгалтерия", связанному с вводом начальных остатков по 76.ВА.

29.04.2012    8778    Пользователь 1С    0       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Обновление базы 1с 7.7. с помощью движка 1с 8.х

Статья Системный администратор Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования Администрирование данных 1С

Если Вас угораздило в стандартную типовую конфу внести правки, причем в самый большой модуль, а именно глобальный. Если к тому же Вы внесли изменение в какую-то стандартную функцию, в которой 1с сама регулярно чего-то меняет, то любое обновление начинает доставать. Используя возможности движка платформы 1с 8.х можно существенно сэкономить себе время и нервы.

28.04.2012    16976    Valerich    31       

Ошибка при формировании отчета Авансы по налогу на имущество. В 1С:Предприятие 7.7. Регламентированная отчетность за I квартал 2012 года Обновление 12q1009 от 18.04.2012 г.

Статья Программист Нет файла v77::ОУ v77::БУ 1cv7.md Россия Бесплатно (free) Практика программирования

При формировании отчета NIMAVP1.ERT Авансы по налогу на имущество (версия 5.03) в разделе № 1-3 не сохраняет номера Страниц при выборе, что ведет к не сохранению и выводу печати двухмерного кода.

24.04.2012    8103    leo072    7       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

v77. Робот

Инструменты и обработки no Внешняя обработка (ert,epf) v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

Исполнитель Робот. Учебное пособие по программированию для детей дошкольного возраста. Без внешних компонент.

09.04.2012    11079    54    item    18       

Запуск внешней обработки по расписанию v7.7

Статья Программист Нет файла v7.7 1cv7.md Россия Windows Бесплатно (free) Практика программирования Администрирование данных 1С

Неоднократно возникали задачи организовать, например ежедневную выгрузку и отправку отчетов по эл.почте, и вот…

20.03.2012    41470    Yury1001    17       

1C:Предприятие для программистов: Расчетные задачи (зарплата). Онлайн-интенсив с 01 по 17 июня 2020 г. Промо

Данный онлайн-курс предусматривает изучение механизмов платформы “1С:Предприятие”, которые предназначены для автоматизации периодических расчетов, а именно - для расчета зарплаты. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей прикладного решения “1С:Зарплата и управление персоналом” и прочих прикладных решений, в которых реализован функционал расчета зарплаты.

4900 рублей

Быстрый отбор в журнале на конкретную дату

Статья Программист Нет файла v77::ОУ 1cv7.md Россия Бесплатно (free) Практика программирования

Лень - двигатель прогресса. Полезная фича для быстрого отбора документов в любом журнале на конкретную дату.

27.02.2012    10030    avers007    16       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

ЗиК 321, в отчетах пропадает проводка по ПФР_страховая

Статья Программист Нет файла v77::ОУ v77::Расчет 1С7:ЗиК Россия ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

При формировании отчета "Свод проводок" с галкой "Учет начисления налогов с ФОТ, включаемых в состав расходов" в отчет не выходит ПФР_страх

10.02.2012    5661    filh    19       

Как уменьшить количество заблокированных объектов

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

История о том как я решил пересобрать форму справочника клиентов и чем это все закончилось...

12.01.2012    14212    ShEvOvIcH    18       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

Прямые запросы: ускорение получения цен для типовой ТиС 7.7

Статья Программист Нет файла v77::ОУ 1С7:Комплекс 1С7:ТиС Россия Бесплатно (free) Практика программирования Разработка внешних компонент

Первая статья из цикла статей "Прямые запросы:...". Рассказывается о применении класса ПрямойЗапрос и компоненты 1С++ для ускорения функции глВернутьЦену() в типовой конфигурации Торговля и склад. Платформа 7.7.

15.11.2011    14197    leshik    21       

1С:Торговля и Склад - ошибка во всех релизах, При использовании нескольких фирм и префиксов номеров документов.

Статья Программист Нет файла v77::ОУ 1С7:ТиС Россия Бесплатно (free) Практика программирования

Собственно сегодня обнаружил ошибку, которая присутствует во всех релизах конфигурации Торговля и Склад 7.7 вплоть до текущего 7.70.969, при использовании нескольких фирм и префиксов документов для некоторых из них.

04.11.2011    14282    twilight5023    8       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

7.7.: Готовим md-файл для публикации. В картинках.

Статья Программист Нет файла v7.7 1cv7.md Россия Бесплатно (free) Практика программирования

Вы доработали типовую конфигурацию: скажем, добавили новый Документ, и хотите им поделиться с обществом ИС. Но нельзя же выложить МД-шник целиком, это будет нарушением правил. И как тут быть?

14.09.2011    16069    Арчибальд    21       

Транспортная накладная с 25.07.11 для 1С Предприятие 7.7 (Комплексная конфигурация)

Отчеты и формы Бухгалтер no Внешняя обработка (ert,epf) v77::ОУ v77::БУ 1С7:Комплекс Россия Учет ТМЦ Бесплатно (free) Печатные формы документов

Печатная форма включенная в 7.70.508 релиз Комплексной конфигурации. Правом использования обладают подписчики диска ИТС. Изменён интерфейс под разрешение экрана 1024х768.

24.06.2011    14609    426    Kurt    24       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Кнопка обновления версии внешнего отчета

Статья Программист Нет файла v77::ОУ v77::БУ v77::Расчет Россия Бесплатно (free) Практика программирования

После исправления внешнего отчета вместо рекомендации пользователю: "Закрой отчет и открой его заново", говорим: "Нажми на кнопку".

18.06.2011    12643    Shaman100M    8       

Особенности сортировки в 1С:Предприятие 7.7

Инструменты и обработки Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Windows Бесплатно (free) Практика программирования

Подобная "разработка" использовалась для анализа/сравнения порядка индексов таблиц БД в различных СУБД: "родные" DBF, MS SQL, CodeBase 6.5, Advantage 7.x/8.x/9.x. Тогда было выяснено, что в этих СУБД разный порядок сортировки индекса.

29.05.2011    16138    68    hogik    4       

Голосование за доклады на INFOSTART MEETUP Kazan - до 25 февраля. Промо

Выбирайте и голосуйте за самые интересные доклады! Лучшие из лучших попадут в окончательную программу казанского митапа. Оставить свой голос можно до 25 февраля 2020 года.

Учет переплаты за прошлый период (персонифицированный учет в ПФР)

Статья Программист Нет файла v77::ОУ 1С7:ЗиК Россия БУ Зарплата ФОМС, ПФ, ФСС Бесплатно (free) Практика программирования

Для того, чтобы в отчетности за текущий период учитывалась переплата по страховой/накопительной части, произведенная в прошлых отчетных периодах.

06.05.2011    4797    pavel_vrn    8