Создание базы данных Firebird (при небольших доработках любой sql базы) на основании метаданных 1С. Заполнение данными. Выгрузка в JSON

Публикация № 1343647 18.12.20

Разработка - Системная интеграция - Внешние источники данных

Firebird JSON метаданные обработка

Создание базы SQL на основании существующей базы 1С. Для разработчиков. Создается база и заполняется данными из нее. Имена таблиц берутся из метаданных 1С. Наименования таблиц, реквизитов переводятся на английский язык. Делается выгрузка данных в формате JSON. Выгружаются справочники, документы с табличными частями, перечисления. Для каждой табличной части создается своя таблица в SQL. Дополнительно создаются таблицы с описанием таблиц, реквизитов, перечислений.

1С:Предприятие 8.3 (8.3.18.1208)  64 

Firebird Server 3.07 64

Возникла необходимость сделать базу данных не в 1с. Выбрал Firebird.

	СтрокаСоединения ="DRIVER={Firebird/InterBase(r) driver};CHARSET=utf8;UID=SYSDBA;PWD=masterkey;DBNAME=" + объект.ИмяФайлаБазы;
	// Создаем соединение
	мСоединение=Новый COMОбъект("ADODB.Connection");
	мСоединение.ConnectionString=СтрокаСоединения; 
	Попытка
		мСоединение.Open(мСоединение.ConnectionString);
		ПоказатьОповещениеПользователя("ОК",,"Соединение успешно установлено!");
	Исключение
		Сообщить("Ошибка при установке соединения: "+ОписаниеОшибки());
		мСоединение=Неопределено;
	КонецПопытки;
	Command    = Новый COMОбъект("ADODB.Command");
	RecordSet  = Новый COMОбъект("ADODB.RecordSet");

Имена в БД английские. Сделал соответствие русских названий и английских(Имена таблиц и реквизитов).

// Перевод метаданных на английский язык для создания БД
&НаКлиенте
Процедура ТаблицаДобавить(Англ, Рус)
	стр         = Объект.ТаблицыБДшаблон.Добавить();
	стр.ИмяАнгл = Англ;
	стр.ИмяРус  = Рус;
КонецПроцедуры

&НаКлиенте
Процедура РеквизитДобавить(Англ, Рус)
	стр         = Объект.РеквизитыШаблон.Добавить();
	стр.ИмяАнгл = Англ;
	стр.ИмяРус  = Рус;
КонецПроцедуры

&НаКлиенте
Процедура ИнициализацияДанных() Экспорт
	// Таблицы для создания БД порядок играет роль на загрузку в другие базы 1С. 
	// Сперва выгружаются простые таблицы. 
	ТаблицаДобавить( "Departments"     , "Подразделения");
	ТаблицаДобавить( "Employees"       , "Сотрудники");
	ТаблицаДобавить( "Posts"           , "Должности");
	ТаблицаДобавить( "Employment"      , "ПриемНаРаботу");
	ТаблицаДобавить( "TransferEmployee", "ПереводСотрудника");
	
	
	// Реквизиты для создания БД
	стр         = Объект.РеквизитыШаблон.Добавить();
	стр.ИмяАнгл = "ID";
	стр.ИмяРус  = "Ссылка";
	стр.тип     = "строка(36)";
	
	РеквизитДобавить("Cod"          , "Код");
	РеквизитДобавить("DateDoc"      , "Дата");
	РеквизитДобавить("NumberDoc"    , "Номер");
	РеквизитДобавить("Name"         , "Наименование");
	РеквизитДобавить("Department"   , "Подразделение");
	РеквизитДобавить("Post"         , "Должность");
	РеквизитДобавить("Period"       , "Период");
	РеквизитДобавить("Summa"          , "Сумма");
КонецПроцедуры

Вывел на основании метаданных таблицы и реквизиты для генерации SQL запроса на создание таблиц, индексов, внешних ключей.

// Создадим запрос на создание таблицы в БД
&НаКлиенте
Функция СоздатьSQL(таблица, Реквизиты)
	sql = "RECREATE TABLE " + таблица.ИмяАнгл +"(";
	Для каждого стрРеквизит из Реквизиты Цикл
		тип = стрРеквизит.тип;
		Если  Найти(стрРеквизит.тип, "VARCHAR")+  Найти(стрРеквизит.тип, "DATE")+
			Найти(стрРеквизит.тип, "DOUBLE PRECISION") + Найти(стрРеквизит.тип,  "BOOLEAN NOT NULL") = 0 Тогда
			тип = "VARCHAR(36)";  
			стрРеквизит.SQL_indexFK="";
			Если стрРеквизит. ИмяАнгл <> "ID" тогда 
				стрРеквизит.SQL_indexFK = "ALTER TABLE " + таблица.ИмяАнгл + " add FOREIGN KEY (" +стрРеквизит. ИмяАнгл+") REFERENCES " + стрРеквизит.ТИП + " (ID);" ;
			Конецесли;	
		Конецесли;	
		sql =sql +	"
		|	" + стрРеквизит. ИмяАнгл + " " + тип +","; 	
		Если  стрРеквизит.индексировать  и стрРеквизит. ИмяАнгл <> "ID"  Тогда
			стрРеквизит.SQL_index = "CREATE INDEX " +таблица.ИмяАнгл + "_" + стрРеквизит. ИмяАнгл+ "_IDX ON " +таблица.ИмяАнгл + " (" + стрРеквизит. ИмяАнгл+ ");"
		КонецЕсли;		
	КонецЦикла;
	sql =sql +"
	|	CONSTRAINT """ + таблица.ИмяАнгл + "_PK"" PRIMARY KEY (ID)
	|);";
	таблица.SQL_Create = sql;
КонецФункции

 

Сделал выгрузку в JSON сгенерированных таблиц. 


&НаСервере
Функция ВыгрузкаЗапрос(имятаблицы, Тип, имяТЧ, имявладельца)
	ПараметрыОтбора = Новый Структура;
	ПараметрыОтбора.Вставить("Таблица", имятаблицы);
	ПараметрыОтбора.Вставить("отметка", Истина);
	реквизиты = Объект.Реквизиты.НайтиСтроки(ПараметрыОтбора);
	Запрос = Новый Запрос;
	//реквизиты
	Если тип = "Справочник" или тип = "Документ" Тогда
		Запрос.Текст =" 
		|ВЫБРАТЬ 
		|	" +  тип + имятаблицы + ".Ссылка" +",";
		Для каждого стрРеквизит из Реквизиты Цикл
			Запрос.Текст = Запрос.Текст  +	"
			|	" +  тип +имятаблицы + "." +стрРеквизит.ИмяРус  + ","; 	
		КонецЦикла;
	ИначеЕсли тип = "ТабличнаяЧасть" Тогда
		//	имятаблицы = Стрзаменить(имятаблицы,имяТЧ,"");
		Запрос.Текст =" 
		|ВЫБРАТЬ 
		|	" +  имятаблицы + ".Ссылка" +",";
		Для каждого стрРеквизит из Реквизиты Цикл
			если стрРеквизит.ИмяРус  = "ключ" Тогда продолжить конецесли;
			Запрос.Текст = Запрос.Текст  +	"
			|	" + имятаблицы + "." +стрРеквизит.ИмяРус  + ","; 	
		КонецЦикла;

	КонецЕсли;
	
	Запрос.Текст = лев(Запрос.Текст, стрдлина(Запрос.Текст)-1);
	
	//таблица
	Если тип = "Справочник" или тип = "Документ" Тогда
		
		Запрос.Текст =  Запрос.Текст +" 
		|ИЗ
		|	" + Тип+"." + имятаблицы + " КАК " + тип + имятаблицы  + "
		|ГДЕ";
	ИначеЕсли тип = "ТабличнаяЧасть" Тогда
		имятаблицы1 = Стрзаменить(имятаблицы,имяТЧ,"");

		Запрос.Текст =  Запрос.Текст +" 
		|ИЗ
		|	" + имявладельца+"." + имяТЧ + "." + имятаблицы1 +" КАК " + имятаблицы  + "
		|ГДЕ";
	КонецЕсли;	
	// отборы
	Если тип = "Справочник"  Тогда
		Запрос.Текст =  Запрос.Текст +"
        |	   " + тип + имятаблицы +".ПометкаУдаления = ЛОЖЬ";
	ИначеЕсли тип = "Документ"  Тогда
		Запрос.Текст =  Запрос.Текст +" 
		|      " + тип + имятаблицы +".Проведен >= Истина 
		|	и  " + тип + имятаблицы +".Дата >= &ДатаНачало 
		|	и  " + тип + имятаблицы +".Дата <= &ДатаОкончание";
	ИначеЕсли тип = "ТабличнаяЧасть" Тогда
		Запрос.Текст =  Запрос.Текст +" 
		|      "  + имятаблицы + ".Ссылка.Проведен >= Истина 
		|	и  " + имятаблицы + ".Ссылка.Дата >= &ДатаНачало 
		|	и  "  + имятаблицы + ".Ссылка.Дата <= &ДатаОкончание";

	КонецЕсли;	
	Запрос.Параметры.Вставить("ДатаНачало",Объект.ДатаНачало);
	Запрос.Параметры.Вставить("ДатаОкончание",КонецДня(Объект.ДатаОкончание));
	РезультатЗапроса = Запрос.Выполнить();
	ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
	мас1 = новый Массив;
	Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
		струк = Новый Структура;
		Для каждого стрРеквизит из Реквизиты Цикл
			Если    Найти(стрРеквизит.тип, "DATE") >0  Тогда
				струк.Вставить(стрРеквизит.ИмяРус,Формат(ВыборкаДетальныеЗаписи[стрРеквизит.ИмяРус],"ДФ=dd.MM.yyyy"));
			ИначеЕсли Найти(стрРеквизит.тип, "DOUBLE PRECISION")+  Найти(стрРеквизит.тип, "BIGINT")  >0 Тогда
				струк.Вставить(стрРеквизит.ИмяРус,  стрзаменить(строка(ВыборкаДетальныеЗаписи[стрРеквизит.ИмяРус]),Символы.НПП,""));
			ИначеЕсли Найти(стрРеквизит.тип, "перечисление")  > 0 Тогда
				струк.Вставить(стрРеквизит.ИмяРус,  строка(ВыборкаДетальныеЗаписи[стрРеквизит.ИмяРус]));
			ИначеЕсли Найти(стрРеквизит.тип, "VARCHAR") + Найти(стрРеквизит.тип,  "BOOLEAN NOT NULL") = 0 Тогда
				струк.Вставить(стрРеквизит.ИмяРус, строка(ВыборкаДетальныеЗаписи[стрРеквизит.ИмяРус].УникальныйИдентификатор()));
			Иначе
				если   стрРеквизит.ИмяРус="ключ" Тогда продолжить КонецЕсли;
				струк.Вставить(стрРеквизит.ИмяРус, ВыборкаДетальныеЗаписи[стрРеквизит.ИмяРус]); 
			КонецЕсли;
		КонецЦикла;
		мас1.Добавить(струк);
	КонецЦикла;
	возврат мас1;
КонецФункции

&НаКлиенте
Процедура ВыгрузкаJSON(Таблица)
	параметрыЗаписиJSON = Новый ПараметрыЗаписиJSON(,символы.Таб);
	мас1 = ВыгрузкаЗапрос(Таблица.Имярус, Таблица.Тип,  Таблица.ВладелецРус, таблица.типвладельца);
	ЗаписьJSON = Новый ЗаписьJSON;
	ЗаписьJSON.ОткрытьФайл(Объект.Каталог + строка(Таблица.НомерСтроки)+ Таблица.Имярус + ".json","UTF-8",,параметрыЗаписиJSON);
	ЗаписьJSON.ЗаписатьНачалоОбъекта();
	ЗаписьJSON.ЗаписатьИмяСвойства(Таблица.Имярус);
	ЗаписатьJSON(ЗаписьJSON,мас1);
	ЗаписьJSON.ЗаписатьКонецОбъекта();
	ЗаписьJSON.Закрыть();	
КонецПроцедуры	

 

В Firebird создал описания таблиц(mdTable) и реквизитов(mdrekvizit)

&НаКлиенте
Функция СоздатьМетаданныеТаблица()

	возврат    "
	|RECREATE TABLE MDTABLE (
	|	NAMEENGL VARCHAR(100),
	|	NAMERUS VARCHAR(100),
	|	SYNONYM VARCHAR(100),
	|	TIP VARCHAR(100),
	|	OWNER VARCHAR(100),
	|	ID VARCHAR(36) NOT NULL,
	|   COMMENT VARCHAR(100),
	|   HINT VARCHAR(100),
	|	CONSTRAINT MDTABLE_PK PRIMARY KEY (ID)
	|);";
	
КонецФункции

&НаКлиенте
Функция СоздатьМетаданныетРеквизиты()
	sql =    "
	|RECREATE TABLE MDREKVIZIT (
	|	NAMEENGL VARCHAR(100),
	|	NAMERUS VARCHAR(100),
	|	SYNONYM VARCHAR(100),
	|	TIP VARCHAR(100),
	|	TABL VARCHAR(100),
	|	ID VARCHAR(36) NOT NULL,
	|   COMMENT VARCHAR(100),
	|   HINT VARCHAR(100),
	|   FORMAT VARCHAR(100),
	|	CONSTRAINT MDREKVIZIT_PK PRIMARY KEY (ID)
	|);";
	возврат sql;
КонецФункции

Заполнил их метаданными из 1С.

	
	Если Объект.Метаданные Тогда
		Command.ActiveConnection = мСоединение;
		Command.CommandText = СоздатьМетаданныеТаблица();
		Попытка
			RecordSet = Command.Execute();
		Исключение
			Сообщить("Ошибка при выполнении запроса. Текст запроса:"+Символы.ПС+стр.SQL_index+Символы.ПС+"Описание ошибки: "+ОписаниеОшибки());	
		КонецПопытки;
		Command.CommandText = СоздатьМетаданныетРеквизиты();
		Попытка
			RecordSet = Command.Execute();
		Исключение
			Сообщить("Ошибка при выполнении запроса. Текст запроса:"+Символы.ПС+стр.SQL_index+Символы.ПС+"Описание ошибки: "+ОписаниеОшибки());	
		КонецПопытки;
		Для каждого стр из Объект.ТаблицыБД Цикл
			Если стр.Отметка Тогда
				Command.CommandText = "INSERT INTO MDTABLE (NAMEENGL,OWNER, NAMERUS, SYNONYM, TIP, ID, COMMENT, HINT) 
				| VALUES('" + стр.ИмяАнгл+ "', '" + стр.Владелец+ "', '" + стр.ИмяРус+ "', '" + стр.Синоним+ "', '" + стр.Тип+ "', '" +строка(стр.НомерСтроки)+ "', '" + стр.Комментарий+ "', '" + стр.Подсказка+ "');";
				RecordSet = Command.Execute();
				Для каждого стрР из Объект.Реквизиты Цикл
					Если стрР.Отметка Тогда
						Если стрР.Таблица =  стр.ИмяРус Тогда
							Command.CommandText = "INSERT INTO MDREKVIZIT (NAMEENGL, NAMERUS, SYNONYM, TIP, TABL, ID, COMMENT, HINT, FORMAT) 
							| VALUES('" + стрР.ИмяАнгл+ "', '" + стрР.ИмяРус+ "', '" + стрР.Синоним+ "', '" + стрР.Тип+ "', '" +строка(стрР.НомерСтроки)+ "', '"+ строка(стрР.НомерСтроки)+ "', '"  + стрР.Комментарий+ "', '" + стрР.Подсказка+"', '"   "');";
							RecordSet = Command.Execute();
						КонецЕсли;
					КонецЕсли;
				КонецЦикла;
			КонецЕсли;
		КонецЦикла;
	КонецЕсли;	
	

Результат работы:

   1. В качестве создания БД использую привычный мне инструмент 1С.

   2. Создаю SQL базу данных.

   3. Заполняю их данными из 1с.

   4. Делаю выгрузку JSON.  Что дает мне интеграцию с 1С. 

   5. Метаданные дают мне возможность использовать синонимы, подсказки, сделанные в 1С.

Скачать файлы

Наименование Файл Версия Размер
Создание БД Firebird(при не больших доработках в любую sql базу) на основании метаданных 1С. Заполнение данными. Выгрузка в JSON.:

.epf 20,53Kb
1
.epf 20,53Kb 1 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. SerVer1C 402 18.12.20 09:49 Сейчас в теме
для чего это вообще нужно?
2. user1045404 156 22.12.20 00:33 Сейчас в теме
Делаю программу на другом языке программирования. На основании метаданных генерируется код (структуры и доступ к данным) . Остается написать логику приложения. У меня есть задача с использованием отпечатка пальца. Другая задача с загрузкой достаточно большого объема данных csv, xml, html. В 1с это медленно. И ещё с лицензированием, много работающих в разных регионах... На первом плане скорость загрузки, выгрузки..
Оставьте свое сообщение

См. также

Конвертация данных Парус 7, 10 - ЗУП 2.5, ЗИКБУ 1.0, КА 1.1, УПП Промо

Внешние источники данных Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 КА1 ЗУП2.5 УПП1 БГУ Россия БУ Госбюджет Абонемент ($m)

Перенос данных Парус 7, 10 - ЗУП 2.5, ЗИКБУ 1.0, КА 1.1, УПП Переносит данные сотрудника, физического лица и начисления за произвольный период

1 стартмани

10.06.2014    39445    67    kns77    87    

Пример обмена данными через XDTO

Внешние источники данных Интеграция v8 УНФ БП3.0 УТ11 КА2 Абонемент ($m)

Пример обмена данными между 1С и сторонним приложением посредством механизма XDTO.

1 стартмани

01.03.2021    4231    7    user925427    2    

Улучшенная обработка универсального обмена данными в формате XML (УФ)

Универсальные обработки Внешние источники данных Обмен через XML v8 v8::УФ 1cv8.cf Абонемент ($m)

Улучшенная обработка "Универсальный обмен данными" с полноценными возможностями СКД для выборки данных (не только для отборов).

1 стартмани

23.06.2020    11647    130    Lem0n    1    

И еще раз о HTTP-сервисах

WEB Внешние источники данных Интеграция v8 БП3.0 ЗУП3.x Россия Абонемент ($m)

Как разработать  подсистему обмена  с сильно ограниченными правами доступа к базе вопрошающего субъекта с использованием различных вариантов маршрутизации.

10 стартмани

28.04.2020    7514    8    zavsom    2    

Загрузка данных из М-Аптеки+ в 1С:Бухгалтерия 8 (ред. 3.0) Промо

Внешние источники данных Файловые протоколы обмена, FTP v8 v8::БУ БП3.0 Фармацевтика, аптеки БУ Абонемент ($m)

Обработка для загрузки файлов выгрузки из программы для автоматизации аптек и аптечных сетей М-Аптека+ в 1С:Бухгалтерия 8, редакция 3.0.

11.07.2014    41194    72    1C_MApteka    42    

Взаимодействие HTML (COM объект, WebKit) с 1С (обычные и управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Показан пример использования HTML (COM объект, WebKit) в 1С (8.3).

2 стартмани

18.01.2020    12278    30    Deniskinr83    0    

Google drive - менеджер файлов

WEB Внешние источники данных v8 1cv8.cf Россия Абонемент ($m)

Синхронизация с гугл диском легко и просто!

10 стартмани

05.12.2019    21711    35    zykov_vitaliy    26    

Использование хранимых процедур MS SQL Server в 1С

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Потребовалось мне как-то построить сложный запрос к внешнему источнику данных, на что платформа радостно послала меня в гугл. Немного подумав, решил написать в SQL процедуру, которая принимала бы какие-то параметры и возвращала какую-то таблицу значений с данными.

1 стартмани

03.12.2019    16508    12    Dedushka    27    

Менеджер загрузки данных из весов с печатью этикеток Промо

Внешние источники данных Весы Учет ТМЦ Учет ТМЦ v8 УТ10 УПП1 Абонемент ($m)

Программное обеспечение "Менеджер загрузки данных из весов с печатью этикеток" предназначено для автоматического получения данных по сети Ethernet из весов МАССА-К моделей ВПМ и ТВ_Р3 (модификация MF) в режиме On-Line.

1 стартмани

20.12.2011    28151    81    hrip    10    

Обновление расширений с Google Drive

Расширения Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Предлагаемое расширение содержит обработку, которая считывает информацию с диска Google и при наличии новой версии производит обновление текущих расширений конфигурации.

1 стартмани

03.10.2019    6771    3    Sedaiko    4    

Получение изображения с IP-камеры

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Получение изображения JPG с IP-камеры в виде двоичных данных. В 1С может применяться для фотографирования объектов.

1 стартмани

10.09.2019    15297    42    sivin-alexey    10    

Чтение файлов PDF из 1С

Внешние источники данных Универсальные обработки v8 1cv8.cf Абонемент ($m)

Насколько мне известно, у платформы 1С нет встроенных средств чтения на лету файлов PDF для их последующего анализа, и приходится использовать внешние инструменты. Об одном из таких вариантов и пойдет речь.

1 стартмани

09.09.2019    18262    53    da_1c    5    

Что нам стоит Push построить Промо

Внешние источники данных v8 v8::Mobile Абонемент ($m)

Попробовал некоторое время назад, push сообщения, реализованные в платформе. Понравилось, но есть несколько минусов, на примере одной программы сообщений (не буду показывать пальцем), спустя некоторое время, сообщения переставали приходить онлайн, а на компьютере приходили моментально, при этом сами смартфоны звались флагманами. Читал позднее статью, где описывалось, что проблема на стороне смартфонов, что-то вроде технологий энергосбережения, но точно не помню. Также немалый минус доступно только для смартфонов.

1 стартмани

08.09.2016    31561    17    PloAl    8    

Согласование задач из Outlook

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Согласование задач непосредственно из почтовой программы, в моем случае Outlook 2013 без каких-либо дополнительных настроек. Из почты отправляется GET запрос к HTTP-сервису 1С, который в свою очередь выполняет задачу.

1 стартмани

06.09.2019    12172    18    duhh    17    

Телеграм 1С – почти коробка

Внешние источники данных v8 Абонемент ($m)

Почему это решение называется «почти коробка»? Потому, что это почти коробочное решение. С его помощью, просто добавив подсистему в конфигурацию, уже можно начинать взаимодействовать с мессенджером Telegram.

10 стартмани

20.08.2019    18979    38    zfilin    68    

Расширение Бром для интеграции с 1С

Внешние источники данных WEB v8 Абонемент ($m)

Из этой статьи вы узнаете, как можно быстро и просто синтегрироваться с любой конфигурацией 1С при помощи расширения Бром.

1 стартмани

06.08.2019    9889    5    itworks    23    

Конфигурация для обмена данными (интеграционная шина)

Внешние источники данных WEB v8 1cv8.cf Абонемент ($m)

Система позволяет организовать обмен данными, как с базами 1С, так и любыми другими приложениями. Система представляет собой отдельную конфигурацию. Система позволяет организовать гибкие возможности по настройке обмена. В качестве брокера сообщений, для передачи данных, используется отдельная самостоятельная конфигурация на 1С. Комплект поставки содержит файл расширения для "клиентской" части шины, данное расширение позволяет без снятия "ключа" организовать гибкий механизм обмена данными.

4 стартмани

08.07.2019    19769    35    miha-28    17    

Почта России - отправка и отслеживание, интеграция с Документооборот 8; УНФ

Внешние источники данных Документооборот и делопроизводство Документооборот и делопроизводство v8 ДО Россия УУ Абонемент ($m)

Выгрузка почтовых отравлений в личный кабинет отправки Почты России; отслеживание почтовых отправлений через Почту России; расширение для интеграции Документооборот 8, УНФ с Почтой России

5 стартмани

04.06.2019    17068    119    wtlz    71    

Пример работы с viber из 1С, отправка сообщений из 1С в viber

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Обработка разработана для примера отправки сообщений в viber из 1С.

1 стартмани

16.05.2019    21812    105    Isa816    24    

Выгрузка и подготовка данных для программы "Перечень льготных профессий" для 1С: ЗУП 2.5 (ОТКРЫТЫЙ КОД) Промо

Рабочее место Внешние источники данных Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 Россия БУ ФОМС, ПФ, ФСС Абонемент ($m)

Обработка для формирования и редактирования данных для перечня льготных профессий. В связи с прекращением поддержки ЗУП 2.5 и отсутствием времени на доработку для сдачи годовой отчетности открыл код модуля. Не очередная выгрузка стажей, а практически полный аналог перечня для 1С. Формирование и редактирование стажей с последующей выгрузкой в формат перечня, но только ГОРАЗДО удобнее и быстрее. В общем, смотрите видео. Где-то половина времени на написание обработки ушла именно на удобство и скорость работы. Внимание: код модуля обработки открыт

5 стартмани

09.11.2015    56962    63    Black-fog    62    

Шаблон http-сервиса для вашего проекта

Внешние источники данных WEB Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

3 стартмани

04.05.2019    25837    88    MarkoSokolov    48    

WhatsApp чат для 1С

Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

WhatsApp чат для 1С. Расширение конфигурации, подходит для любых конфигураций 1С (управляемые формы).

5 стартмани

15.04.2019    15033    41    ManyakRus    22    

Доработка функционала отправки дополнительных реквизитов 1С: ЭДО для Татнефть

Внешние источники данных Документооборот и делопроизводство Документооборот и делопроизводство v8 ERP2 БУ Абонемент ($m)

Подключаемое расширение к конфигурации ERP с функционалом отправки дополнительных реквизитов 1С ЭДО для Татнефть (№ и дата договора, подразделение, автор, примечание) в электронных документах Счет-фактуры и ТОРГ-12 Проверялось на 1С:ERP Управление предприятием 2.4.6.160.

2 стартмани

07.04.2019    13514    17    sapervodichka    12    

Подсистема обмена данными с порталом ИМНС по электронным счетам-фактурам (автоматический обмен) Промо

Внешние источники данных WEB Инструментарий разработчика v8 1cv8.cf Беларусь БУ НДС Абонемент ($m)

Подсистема включает документы и обработки для автоматического обмена данными с порталом ИМНС через web-сервис. Присутствует возможность заполнения данными типовых операций за период, учёта входящих документов, учёта произвольных исходящих документов. Приложены обработки для запуска задания планировщика на автоматический обмен данными.

1 стартмани

28.07.2016    37861    20    c1nil    4    

Формирование xml файла ЭДО (СБИС, Диадок, Такском и т.п.) для типовых документов (счета-фактуры, накладные)

Внешние источники данных Обмен через XML Документооборот и делопроизводство Документооборот и делопроизводство v8 1cv8.cf Абонемент ($m)

Не все типовые документы типовых конфигураций 1С можно выгрузить в файл формата xml ЭДО. Например счет-фактуру, на текущий момент момент это не предусмотрено. Обработка позволяет сделать это.

4 стартмани

30.03.2019    68913    416    capitan    136    

Генерация схемы xsd из файла xml

Инструментарий разработчика Внешние источники данных v8 Абонемент ($m)

Утилита, генерирующая xsd схему на основании xml файла.

1 стартмани

25.03.2019    22222    43    nbeliaev    11    

Работа с Active Directory из 1С (загрузка / выгрузка данных)

Внешние источники данных v8 1cv8.cf Россия Абонемент ($m)

Загрузка данных из Active Directory / Изменение информации пользователя в AD из 1С.

1 стартмани

26.02.2019    16374    118    Смешной 1С    7    

 Интеграция 1С и C#. Обращение к 1С через COM. Создание номенклатуры и выполнение запроса к 1С из C# на примере интеграции с Союз-PLM (система информационной поддержки жизненного цикла изделий). Обработка «Загрузка заказа на сборку». (ERP) Промо

Загрузка и выгрузка в Excel Внешние источники данных Интеграция v8 ERP2 Абонемент ($m)

Союз-PLM представляет собой полнофункциональный программный комплекс для решения  широкого спектра задач управления инженерной технической информацией наукоемких изделий и сложных инженерных объектов в области машиностроения, приборостроения, архитектуры, строительства. На практике, это управление конструкторской документацией, интегрированное с САПР, бизнес-процессы, файловый архив. Все это работает в SQL и шевелится с помощью скриптов на C#. Скрипты свободно  отлаживаются в MS Visual Studio. Подробнее смотрите на их сайте: http://www.programsoyuz.ru/products/system-soyuz-plm.html  Редактирование, конструирование и использование бизнес-процессов на порядок лучше систем на базе 1С из тех, что я изучил.

1 стартмани

25.07.2016    53247    5    milkers    2    

HTTP API Диадок. Загружаем в Диадок любой документ. Посредством POST и GET запросов

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Поставили задачу через HTTP API Диадок (diadoc-api.kontur.ru) отправить любой файл в Диадок и подписать его (например, служебную записку в формате пдф). Посредством POST и GET запросов.

2 стартмани

14.01.2019    16914    47    John_d    13    

JSON-RPC. Удалённый вызов процедур

Инструментарий разработчика Внешние источники данных v8 Абонемент ($m)

Реализация спецификации JSON-RPC.

1 стартмани

04.01.2019    8245    25    berezdetsky    1    

Интеграция WhatsApp в 1С (botcorp.io и api-messenger.com)

Внешние источники данных v8 Абонемент ($m)

Сейчас у WhatsApp более 1 млрд. пользователей во всём мире. В России мессенджер держится на верхних строчках по популярности среди всех мессенджеров. Из чего следует, что WhatsApp является самым желанным мессенджером для интеграции с 1С.

3 стартмани

22.11.2018    30101    63    17808849    51    

Импорт из EXCEL и других источников (xls, xlsx, xlsb, ods, sxc, dbf, mxl, csv, clipboard, sql) в 1С Промо

Загрузка и выгрузка в Excel Внешние источники данных Обработка справочников Практика программирования Обработка документов v8 КА1 БП2.0 УТ10 Розница Беларусь Украина Россия БУ Абонемент ($m)

-Наглядная, контролируемая загрузка иерархической номенклатуры с различными атрибутами и картинками из прайсов, файлов табличного вида xls,xlsx,xlsb,ods,sxc,dbf,mxl,csv произвольной структуры по указанному диапазону строк, а также из буфера обмена и внешнего SQL-источника данных в основные, дополнительные и пользовательские реквизиты. -Вариантный поиск номенклатуры. -Создание сопутствующей справочной информации. -Создание документов в национальной/иностранной валюте. -Обычное и управляемое приложение. Файл и Клиент-Сервер.

1 стартмани

16.03.2012    389339    7670    StepByStep    736    

Исправление ошибки универсального обмена Бухгалтерия предприятия, редакция 3.0 (3.0.65.х, расширение конфигурации)

Внешние источники данных Адаптация типовых решений v8 БП3.0 Абонемент ($m)

Уже у третьего клиента вижу ошибку Ошибка проверки данных XDTO: Структура объекта не соответствует типу: {http://www.1c.ru/SSL/Exchange/Message}Header Значит, как говаривал Винни-Пух - это неспроста. Ну и точно неспроста, 1С что-то подшаманили в обмене через универсальный формат.

1 стартмани

19.10.2018    25771    49    capitan    15    

Загрузка чека онлайн-касс (загрузка товаров из чека)

Внешние источники данных WEB Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) из почтового сообщения, отправленного из приложения ФНС проверка чеков.

2 стартмани

08.10.2018    28610    42    echo77    73    

Мониторинг показателей систем 1С 8.3 с помощью Zabbix

Внешние источники данных Zabbix v8 1cv8.cf Абонемент ($m)

Опишу свой опыт мониторинга наших систем 1С с помощью Zabbix и ту пользу, которую можно извлечь из этого.

1 стартмани

05.10.2018    54591    70    akimych    49    

Самый простой клиент ЕГАИС УТМ для розницы. $m Промо

Внешние источники данных Рабочее место Розничная торговля Розничная торговля v8 1cv8.cf Россия УУ Абонемент ($m)

Данная обработка позволяет обеспечить приходную часть магазина розничной торговли алкоголем(ЕГАИС розница), или прочего предприятия. Эти действия становятся обязательными для розничного звена в городских поселениях с 01.01.2016 и будут достаточными до 01.07.2016. Предлагаю Вашему вниманию простое и доступное решение, которое позволяет отсрочить проблему интеграции ЕГАИС в розничное звено до указанной даты. (открытый код). Реализовано на открытой модели http://infostart.ru/public/402052/.

2 стартмани

14.12.2015    42310    8    Terrain25    47    

В Telegram из 1С: сообщения с эмодзи (смайлы, пиктограммы, иконки) пользователям и группам

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка отправляет сообщения с эмоджи (смайлы, иконки, пиктограммы) пользователю или группе в Телеграм. Она также показывает список пользователей и групп, которые связывались с Вашим ботом, из этого списка можно выбрать получателя сообщения.

1 стартмани

20.08.2018    19665    72    uno-c    28    

Отправка сообщений через Telegram (через прокси)

Внешние источники данных v8 v8::УФ 1cv8.cf Абонемент ($m)

Простая обработка для отправки сообщений из 1с в Телеграм конкретному пользователю. Используя прокси-сервер: jqlwb.teletype

1 стартмани

20.07.2018    25365    24    Deda    14    

Обмен 1С:Управление Торговлей 11 и Frontol 5

Внешние источники данных Розничная торговля Розничная торговля v8 УТ11 КА2 Розничная и сетевая торговля (FMCG) Абонемент ($m)

Обработка обмена для 1С Управление Торговлей 11 и фронт-кассовой системы Frontol. Отличия от типовой: выгрузка дисконтных карт с накоплениями. Выгрузка категорий товаров.

3 стартмани

14.07.2018    28948    133    Kutuzov    166    

Модуль для работы 1С (платформа 8.2 и выше) с внешними SOAP Web-сервисами Промо

Внешние источники данных WEB Интеграция v8 1cv8.cf Абонемент ($m)

Модуль для работы 1С (платформа 8.2 и выше) с внешними Web-сервисами, реализованными по протоколу SOAP.

2 стартмани

15.02.2016    43799    85    lunjio    15    

RabbitMQ + 1С. Быстрый старт

Внешние источники данных v8 1cv8.cf Абонемент ($m)

Внешняя компонента для отправки сообщения из 1С в кролика. Сервис прослушивания и перенаправления сообщений из кролика в http или web-сервис.

1 стартмани

10.06.2018    42088    119    Goleff74    43    

Экономим время на ввод операций в 1С: Деньги

Внешние источники данных Обработка документов Банковские операции Банковские операции v8 1cv8.cf Домашние учет и финансы Абонемент ($m)

Рабочее решение автоматического создания операций в 1С: Деньги. Основано на анализе СМС.

1 стартмани

14.05.2018    17857    17    vsbronnikov    29    

Битрикс24. Работаем с оффлайн событиями

Внешние источники данных v8 1cv8.cf Россия Абонемент ($m)

Появление оффлайн событий упростило синхронизацию Битрикс24 -> 1С. Теперь, например, можно загрузить только измененные между сеансами обмена сделки. А не тащить все незавершенные. В статье описание, как это можно сделать.

1 стартмани

11.05.2018    13416    44    user662672_explorer2000    29    

7 причин, почему интеграция стала приятной. Не упускайте ряд потрясающих возможностей Промо

Внешние источники данных Интеграция Мобильная разработка v8 1cv8.cf Абонемент ($m)

В статье показаны примеры получения данных без программирования на стороне «1С:Предприятие 8». Вам нужно проверить гипотезу и проанализировать данные, почему бы не интегрироваться с Excel? Используете технологии .NET и «1С:Предприятие 8», процесс связывания систем движется катастрофически медленно? Хотите native Android приложение с вашими данными всегда под рукой?

1 стартмани

01.10.2015    61764    48    pbazeliuk    23    

Интеграция с Redmine (Rest-API)

Внешние источники данных v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Интеграция с Redmine (Rest API). Тестировалось на 1С:Предприятие 8.3.12.1412 1. Получение списков Проектов, Трекеров, Статусов, Версий, Пользователей 2. Отбор задач по дополнительным полям (произвольные поля добавляемые пользователями в Redmine) 3. Получение Учета времени с отбором по пользователю и диапазону дат 4. Получение задач с различными отборами (гибкая настройка)

1 стартмани

28.04.2018    17616    57    lastpioneer    7    

Интеграция между Atlassian Jira и 1С:Предприятие 8.3 используя Jira REST API (выборка, создание и изменение запросов, чтение, создание и удаление записей о работах, чтение комментариев и другие возможности)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка на управляемой форме для 1С:Предприятие 8.3 по интеграции с Atlassian Jira используя Jira REST API. Ключевые функции: выборка запросов с использованием JQL; добавление и изменение запросов; добавление, изменение и удаление записей о работах; чтение комментариев к запросам; сохранение всех ключевых параметров между сеансами работы. Тестирование проводилось на платформе 1С (8.3.11.2954) совместно с JIRA Server platform (7.3.7)

1 стартмани

24.04.2018    42818    248    Ko1t    87    

Чтение и запись из таблиц гугл (google sheets) в табличный документ 1С (8.3, управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка на управляемой форме для 1С версии 8.3 для доступа к сервисам Google Sheets c использованием протокола авторизации OAuth 2.0. Выполняет получение списка листов таблицы гугл, чтение таблицы гугл в табличный документ 1С и запись из табличного документа 1С в таблицу гугл. Тестирование проводилось на платформе 1С:Предприятие 8.3 (8.3.11.2954).

1 стартмани

09.04.2018    52822    363    Ko1t    84    

Загрузка документов из системы Emex через веб-сервисы (Коммерция-Автологистика) Промо

Внешние источники данных WEB v8 v8::ОУ УТ10 УУ Абонемент ($m)

Обработка предназначенная для дилеров системы Emex, для загрузки документов из программы Коммерция(Автологистика) в 1С 8.2 Управление торговлей 10. Для загрузки используются веб-сервисы программы Автологистика.

10 стартмани

11.08.2014    23758    1    desarz    1    

Чат бот в 73 строки на 1С - ИИ наступает

Практика программирования Внешние источники данных v8 1cv8.cf Абонемент ($m)

Интеграция с уже готовой системой чат-бота для различных случаев жизни. Используется API от DialogFlow Google. Обработка тестировалась на 1С:Предприятие 8.3 (8.3.10.2252) Должно работать на всех 8.3 версиях.

1 стартмани

09.04.2018    15988    31    Lapitskiy    7    

Загрузка чеков из ФНС (Налоговой), отсканированных с помощью QR-кода, в 1С:Деньги

Внешние источники данных WEB Банковские операции Банковские операции v8 1cv8.cf Домашние учет и финансы УУ Абонемент ($m)

Расширение для получения чеков со всеми товарами в чеке с сайта ФНС (Налоговой).

1 стартмани

19.03.2018    17860    22    semen_2008    4    

Оповещения из ЗУП и ERP в TELEGRAM

Внешние источники данных v8 ERP2 ЗУП3.x Абонемент ($m)

Начитался статей про интеграцию 1С -> Telegram, решил аккумулировать опыт и попробовать сделать какую-нибудь полезную обработку. Как результат - внешняя обработка, уведомляющая ответственных сотрудников по расписанию о необходимости оплаты отпусков, материальной помощи, премий. Данные посылаются в виде PDF файла (Отчет, созданный на основании макета). Можно использовать обработку как обучающую. Тестировалось на ERP 2.4.2.139, на ЗУП 3.X тоже должно работать.

1 стартмани

01.03.2018    17939    57    khabibullin.tu    15    

Подписка на события, преобразование объекта в JSONAPI, отправка в RabbitMQ

Внешние источники данных Универсальные функции v8 1cv8.cf Абонемент ($m)

Обработка содержит функции: - сериализация объекта 1с в JSONAPI - отправка в RabbitMQ по HTTP

1 стартмани

26.02.2018    15114    22    yaxinr    7