Исправление ошибки релиза Бухгалтерии 3.0.95.6: при отключенном контроле остатков не проводит документ

Публикация № 1477673 11.07.21

Администрирование - Администрирование данных 1С - Тестирование и исправление

Ошибка релиз 3.0.96.5 исправление

В программе отключен контроль остатков, но при этом при проведении документов программа выдает ошибку, и документ не проводится. Ошибка в релизе! Как в общем модуле УчетТоваров забыли передать переменную КонтролироватьОстаток, в результате чего документ, например, ОтчетОРозничныхПродажах не проводится. В предыдущем релизе всё было в порядке.

При проведении документа Отчет о розничных продажах программа выдает ошибку 
 

Некорректно заполнена колонка "Количество" в строке 1 списка "Товары". Указанное количество превышает остаток. Остаток: 0; Не хватает: N.

Далее документ не проводится. Возможно возникает при проведении на других видах документов.

Описание ошибки :

Общий модуль УчетТоваров содержит процедуру

Процедура СписатьОстаткиТоваровИСообщитьОбОшибке(ТаблицаСписаниеПоОстаткам, ТаблицаОстатки, ТаблицаСписанныеТовары, ТаблицаВыпущеннаяПродукция, СпособОценкиМПЗПоСредней, КонтролироватьОстаток, Реквизиты, Отказ)
	
	ТаблицаОшибок = ТаблицаОшибокСписанияТоваров();
	
	ПараметрыСписания = НовыйПараметрыСписанияТоваров();
	ПараметрыСписания.Регистратор = Реквизиты.Регистратор;
	ПараметрыСписания.Организация = Реквизиты.Организация;
	ПараметрыСписания.Период = Реквизиты.Период;
	ПараметрыСписания.Подразделение = Реквизиты.Подразделение;
	ПараметрыСписания.СпособОценкиМПЗПоСредней = СпособОценкиМПЗПоСредней;
	
	СписатьОстаткиТоваров(ТаблицаСписаниеПоОстаткам, ТаблицаОстатки, ТаблицаСписанныеТовары, ТаблицаВыпущеннаяПродукция, ТаблицаОшибок, ПараметрыСписания);
	
	Если ТаблицаОшибок.Количество() = 0 Тогда
		Возврат;
	КонецЕсли;
	
	Для Каждого СтрокаОшибки Из ТаблицаОшибок Цикл
		Если Не КонтролироватьОстаток И Не БухгалтерскийУчетПовтИсп.СчетУчетаКомиссионногоТовара(СтрокаОшибки.СчетУчета) Тогда
			Продолжить;
		КонецЕсли;
		
		Если БухгалтерскийУчетПереопределяемый.ДокументЯвляетсяРазукомплектацией(Реквизиты.Регистратор) Тогда
			
			ВывестиСообщениеОбОшибке(
				ТаблицаОшибок.Итог("Количество"), 
				ТаблицаОшибок.Итог("КоличествоОсталосьПогасить"), 
				Реквизиты.Регистратор,,,,Отказ);
			
		Иначе
			
			Для Каждого СтрокаТаблицыОшибок Из ТаблицаОшибок Цикл
				
				ВывестиСообщениеОбОшибке(
					СтрокаТаблицыОшибок.Количество, 
					СтрокаТаблицыОшибок.КоличествоОсталосьПогасить, 
					Реквизиты.Регистратор, 
					СтрокаТаблицыОшибок.ИмяСписка, 
					СтрокаТаблицыОшибок.СинонимСписка, 
					СтрокаТаблицыОшибок.НомерСтроки, 
					Отказ);
			
			КонецЦикла;
			
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры

 как видно параметр КонтролироватьОстаток присутствует, далее по тексту идет вызов процедуры СписатьОстаткиТоваров

СписатьОстаткиТоваров(ТаблицаСписаниеПоОстаткам, ТаблицаОстатки, ТаблицаСписанныеТовары, ТаблицаВыпущеннаяПродукция, ТаблицаОшибок, ПараметрыСписания);

но при этом параметр КонтролироватьОстаток почему то не передается ! И это приводит к возникновению ошибки. В более ранних релизах передавался.

Для исправления ситуации необходимо внести исправление в процедуру СписатьОстаткиТоваров . 

Текст исправленой процедуры :

Процедура СписатьОстаткиТоваров(ТаблицаСписаниеПоОстаткам, ТаблицаОстатки, ТаблицаСписанныеТовары, ТаблицаВыпущеннаяПродукция, ТаблицаОшибок, ПараметрыСписания)
	
    // Исправление 3.0.96.35 
	ИспользуетсяОтложенноеПроведение = ПроведениеСервер.ИспользуетсяОтложенноеПроведение(ПараметрыСписания.Организация, ПараметрыСписания.Период);
	КонтролироватьОстаток = НЕ БухгалтерскийУчетПереопределяемый.ОтключитьКонтрольОтрицательныхОстатков()	
	И НЕ ИспользуетсяОтложенноеПроведение;
    // Исправление 3.0.96.35 
	
	ЕстьКолонкаВозвратПоТекущемуДокументу = ТаблицаСписаниеПоОстаткам.Колонки.Найти("ВозвратПоТекущемуДокументу") <> Неопределено;
	
	ПустойСклад = Справочники.Склады.ПустаяСсылка();
	
	УчетВыпускаПродукцииПоДаннымПродаж = УчетнаяПолитика.УчетВыпускаПродукцииПоДаннымПродаж(
		ПараметрыСписания.Организация, ПараметрыСписания.Период);
	СчетаУчетаПродукцииДляВыпуска = РасчетВыпускаПоДаннымПродаж.СчетаУчетаПродукцииДляВыпуска();
	
	Для каждого СтрокаДокумента Из ТаблицаСписаниеПоОстаткам Цикл
		
		КоличествоОсталосьПогасить = СтрокаДокумента.Количество;
		
		ЭтоПродажаПоКоторойБылВозврат = Ложь;
		// Если по этой продаже был возврат, то пометим это
		Если ЕстьКолонкаВозвратПоТекущемуДокументу
			И СтрокаДокумента.ВозвратПоТекущемуДокументу Тогда
			ЭтоПродажаПоКоторойБылВозврат = Истина;
		КонецЕсли;
		
		Если ТаблицаОстатки.Количество() <> 0 Тогда
		
			ПараметрыОтбора = Новый Структура;
			ПараметрыОтбора.Вставить("Номенклатура", СтрокаДокумента.Номенклатура);
			ПараметрыОтбора.Вставить("СчетУчета", СтрокаДокумента.СчетУчета);
			
			Если ЗначениеЗаполнено(СтрокаДокумента.ДокументОприходования) Тогда
				Если (НЕ ПараметрыСписания.СпособОценкиМПЗПоСредней ИЛИ БухгалтерскийУчетПовтИсп.СчетУчетаКомиссионногоТовара(СтрокаДокумента.СчетУчета))
					И БухгалтерскийУчет.НаСчетеВедетсяПартионныйУчет(СтрокаДокумента.СчетУчета) Тогда
					ПараметрыОтбора.Вставить("ДокументОприходования", СтрокаДокумента.ДокументОприходования);
				КонецЕсли;
			КонецЕсли;
			
			ПартииОстатков = ТаблицаОстатки.Скопировать(ПараметрыОтбора);
			ПартииОстатков.Сортировать("ДокументОприходованияДата, ДокументОприходования", Новый СравнениеЗначений);
			
			Для каждого СтрокаПартии Из ПартииОстатков Цикл
				
				Если КоличествоОсталосьПогасить <= 0 Тогда
					Прервать;
				КонецЕсли;
				
				Если СтрокаПартии.КоличествоПоСкладу <= 0
					ИЛИ СтрокаПартии.Количество <= 0 Тогда
					Продолжить;
				КонецЕсли;
				
				Если БухгалтерскийУчет.ВедетсяУчетПоСкладам(СтрокаДокумента.СчетУчета) Тогда
					Если СтрокаПартии.Склад <> СтрокаДокумента.Склад
						И НЕ СтрокаПартии.Склад = ПустойСклад Тогда // пустые склады могут остаться со времени, когда не было учета по складам
						Продолжить;
					КонецЕсли;
				КонецЕсли;
				
				Количество = Мин(СтрокаПартии.КоличествоПоСкладу, КоличествоОсталосьПогасить);
				
				Стоимость	= Окр(СтрокаПартии.Стоимость * Количество / СтрокаПартии.Количество, 2, 1);
				СтоимостьНУ	= Окр(СтрокаПартии.СтоимостьНУ * Количество / СтрокаПартии.Количество, 2, 1);
				СтоимостьПР	= Окр(СтрокаПартии.СтоимостьПР * Количество / СтрокаПартии.Количество, 2, 1);
				СтоимостьВР	= Окр(СтрокаПартии.СтоимостьВР * Количество / СтрокаПартии.Количество, 2, 1);
				
				Если (СтрокаПартии.Стоимость = СтрокаПартии.СтоимостьНУ + СтрокаПартии.СтоимостьВР + СтрокаПартии.СтоимостьПР)
						И (Стоимость <> СтоимостьНУ + СтоимостьВР + СтоимостьПР) Тогда
						
						СтоимостьВР = Стоимость - СтоимостьНУ - СтоимостьПР;
						
				КонецЕсли;
				
				КоличествоОсталосьПогасить = КоличествоОсталосьПогасить - Количество;
				
				Если НЕ ЭтоПродажаПоКоторойБылВозврат Тогда
					
					СтрокаТаблицыОстатки = ТаблицаОстатки.Найти(СтрокаПартии.НомерСтроки, "НомерСтроки");
					СтрокаТаблицыОстатки.Количество         = СтрокаТаблицыОстатки.Количество - Количество;
					СтрокаТаблицыОстатки.Стоимость          = СтрокаТаблицыОстатки.Стоимость - Стоимость;
					СтрокаТаблицыОстатки.СтоимостьНУ        = СтрокаТаблицыОстатки.СтоимостьНУ - СтоимостьНУ;
					СтрокаТаблицыОстатки.СтоимостьПР        = СтрокаТаблицыОстатки.СтоимостьПР - СтоимостьПР;
					СтрокаТаблицыОстатки.СтоимостьВР        = СтрокаТаблицыОстатки.СтоимостьВР - СтоимостьВР;
					СтрокаТаблицыОстатки.КоличествоПоСкладу = СтрокаТаблицыОстатки.КоличествоПоСкладу - Количество;
					
				КонецЕсли;
				
				СписаннаяПартия = ТаблицаСписанныеТовары.Добавить();
				ЗаполнитьЗначенияСвойств(СписаннаяПартия, СтрокаДокумента);
				СписаннаяПартия.Подразделение       = СтрокаПартии.Подразделение;
				СписаннаяПартия.Партия              = СтрокаПартии.ДокументОприходования;
				СписаннаяПартия.Склад               = СтрокаПартии.Склад;
				СписаннаяПартия.Количество          = Количество;
				СписаннаяПартия.СуммаСписания       = Стоимость;
				СписаннаяПартия.СуммаСписанияНУ     = СтоимостьНУ;
				СписаннаяПартия.СуммаСписанияПР     = СтоимостьПР;
				СписаннаяПартия.СуммаСписанияВР     = СтоимостьВР;
				СписаннаяПартия.СуммаКорСписанияНУ  = СтоимостьНУ;
				СписаннаяПартия.СуммаКорСписанияПР  = СтоимостьПР;
				СписаннаяПартия.СуммаКорСписанияВР  = СтоимостьВР;
				
				Если НЕ ТаблицаСписанныеТовары.Колонки.Найти("РассчитатьСебестоимостьПоТекущимПродажам") = Неопределено
						И СписаннаяПартия.РассчитатьСебестоимостьПоТекущимПродажам Тогда
						
					СписаннаяПартия.РассчитатьСебестоимостьПоТекущимПродажам = Ложь;
					
				КонецЕсли;
				
			КонецЦикла;
		КонецЕсли;
		
		Если УчетВыпускаПродукцииПоДаннымПродаж
			И ТаблицаВыпущеннаяПродукция <> Неопределено
			И КоличествоОсталосьПогасить > 0
			И МожноВыпуститьПродукциюПриСписании(ПараметрыСписания.Регистратор, СтрокаДокумента, СчетаУчетаПродукцииДляВыпуска) Тогда
			
			СведенияОПродукции = СведенияОПродукцииДляВыпуска(СтрокаДокумента.Номенклатура, КоличествоОсталосьПогасить, ПараметрыСписания.Период);
			Если ЗначениеЗаполнено(СведенияОПродукции.Спецификация) Тогда
				ВыпуститьПродукциюИСписать(СтрокаДокумента, СведенияОПродукции, ТаблицаСписанныеТовары, ТаблицаВыпущеннаяПродукция, ПараметрыСписания);
				КоличествоОсталосьПогасить = 0;
			КонецЕсли;
			
		КонецЕсли;
		
		// Несписанное количество добавим отдельной строкой в таблицу списанных партий.
		Если КоличествоОсталосьПогасить > 0  Тогда
			
			СписаннаяПартия               = ТаблицаСписанныеТовары.Добавить();
			ЗаполнитьЗначенияСвойств(СписаннаяПартия, СтрокаДокумента);
			СписаннаяПартия.СчетУчета     = СтрокаДокумента.СчетУчета;
			СписаннаяПартия.Подразделение = ПараметрыСписания.Подразделение;
			СписаннаяПартия.Количество    = КоличествоОсталосьПогасить;
			
		КонецЕсли;
		
		// Если не хватает товара для списания, то зарегистрируем ошибку в таблице ошибок.
		// Будет ли продолжено выполнение или пользователю будет выдано сообщение решит код, который вызвал эту процедуру.
		// Например, сообщения об ошибке может и не быть, если включена возможность списания без остатков.
		// Исправление 3.0.96.35 
		// добавлена проверка на контроль остатков, условие (И КонтролироватьОстаток)
		Если КоличествоОсталосьПогасить > 0 И КонтролироватьОстаток Тогда
			
			ЗарегистрироватьОшибку = Истина;
			
			Если НЕ ТаблицаСписаниеПоОстаткам.Колонки.Найти("ВозвратПоТекущемуДокументу") = Неопределено
				И СписаннаяПартия.ВозвратПоТекущемуДокументу Тогда
				ЗарегистрироватьОшибку = Ложь;
			КонецЕсли;
			
			Если ЗарегистрироватьОшибку Тогда
					
				СтрокаТаблицыОшибок = ТаблицаОшибок.Добавить();
				ЗаполнитьЗначенияСвойств(СтрокаТаблицыОшибок, СтрокаДокумента);
				СтрокаТаблицыОшибок.КоличествоОсталосьПогасить = КоличествоОсталосьПогасить;
			
			КонецЕсли;
			
		КонецЕсли;
		
	КонецЦикла;
	
КонецПроцедуры

Чтобы не менять конфигурацию, берем текст процедуры, добавляем в расширение с аннотацией &Вместо("СписатьОстаткиТоваров") и после этого программа работает исправно. 

Готового решения данной проблемы не нашёл, поэтому набросал расширение для исправления данной ситуации.

Все исправления обозначены комментарием // Исправление 3.0.96.35

Ошибка воспроизводится на релизе 3.0.96.5. Надеюсь, в следующем релизе ситуацию исправят.

Скачать файлы

Наименование Файл Версия Размер
Исправление ошибки релиза Бухгалтерии 3.0.95.6 при отключенном контроле остатков не проводит документ.:

.cfe 7,49Kb
0
.cfe 7,49Kb Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Финансовый план. Расширение конфигурации (дополнение) Промо

Финансовый учет и бюджетирование (FRP) Бухгалтерский учет v8 1cv8.cf Украина Россия БУ Абонемент ($m)

Система позволяет создать произвольную структуру линейного отчета (таблица: показатели / стандартные периоды). Зафиксировать по ним факт. И в произвольный момент формировать отчет, показывающий: план / факт / отклонение. Финансовый план, Бюджет доходов и расходов, Бюджет движения денежных средств и пр. Данные факта "собираются" из данных бухгалтерского отчета - Сальдо начальное / конечное / дебетовое / кредитовое, Оборот по счету... Возможна настройка по субконто: статьи движения денежных средств, статьи затрат и статьи доходов. Другая аналитика легко подключается.

2 стартмани

13.12.2020    4477    16    AnryMc    23    

Проверка настройки заполнения для скриптов 1С:Документооборот

Документооборот и делопроизводство Тестирование и исправление v8 ДО Абонемент ($m)

Доброго времени суток, коллеги. После обновления базы 1С:Документооборот , при проверке заполнения файла по шаблону вылезла ошибка "Следующие реквизиты или скрипты настройки заполнения файла заданы не корректно:...". Захотел узнать, какие ещё скрипты заполнены не корректно. Написал обработку для проверки и исправления всех скриптов.

1 стартмани

19.09.2021    678    3    Andrei_Ivanov    6    

Автозаполнение "Кому и за что уплачено" в Авансовых отчетах

Бухгалтерский учет Обработка документов v8 v8::БУ БГУ БУ Госбюджет Абонемент ($m)

Расширение для БГУ 2.0 для автоматического заполнения поля "Кому и за что уплачено" по данным бухгалтерской записи.

1 стартмани

16.03.2021    2354    0    the1    0    

Превращение доработанной конфигурации в типовую или исправление ошибки "Имеются записи с одинаковыми измерениями"

Чистка базы Тестирование и исправление v8 1cv8.cf Абонемент ($m)

Помогает решить проблему связанную с дублями в регистрах сведений при возвращении к типовой конфигурации. Ошибка "Имеются записи с одинаковыми измерениями".

1 стартмани

12.02.2021    8321    78    pyrkin_vanya    36    

Расчет Тарификации и зарплаты в средних общеобразовательных школах для ЗКГУ - 3.1 (релиз 3.1.18.216) Промо

Зарплата Зарплата Бухгалтерский учет v8 v8::СПР ЗКГУ3.0 Государственные, бюджетные структуры Россия БУ Госбюджет Абонемент ($m)

Данная настройка конфигурации предназначена для расчета Тарификации педработников и расчета зарплаты в средних общеобразовательных учреждениях. Настройка сделана на базе Типовой конфигурации "Зарплата и кадры государственного учреждения" редакции 3.1.

2 стартмани

05.09.2018    38189    61    ivnik    24    

Решения билетов экзамена 1С:Специалист-консультант по Бухгалтерии (спец-конс по БП)

Решение задач на 1С:Специалист Бухгалтерский учет v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

Представлены скрины с пошаговым решением (пояснениями) билетов.

1 стартмани

27.12.2020    6137    78    user1514921    16    

Восстановление базы 1С из бэкапа SQL при помощи Python

Тестирование и исправление v8 1cv8.cf Абонемент ($m)

Скрипт для создания копии базы на сервере SQL и добавления базы в кластер 1С.

1 стартмани

16.12.2020    4556    1    user1287977    1    

Решение задач к экзамену Специалист-консультант БГУ ред. 2.0

Бухгалтерский учет Решение задач на 1С:Специалист v8 v8::БУ БГУ Государственные, бюджетные структуры Россия БУ Абонемент ($m)

Решения билетов из первого раздела к сборнику задач для подготовки к экзамену 1С:Специалист-Консультант по внедрению прикладного решения 1С:БГУ ред. 2.0 (арт. 4601546128331).

1 стартмани

16.12.2020    5830    31    Eramas    29    

[x1c.ru] 1CDBin: Работа с файлами *.1CD на низком уровне средствами языка 1С с возможностью чтения таблиц (поддерживается формат 8.3.8.0) Промо

Тестирование и исправление Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Обработка позволяет просматривать файловые базы 1CD на низком уровне средствами встроенного языка. Реализована часть функциональности Tool_1CD, но на языке 1С Предприятия. Показываются таблицы, параметры таблиц, поля таблиц, записи таблиц, значения полей BLOB, есть 16-ричный просмотр страниц базы и консоль кода. Можно использовать для изучения структуры файлов 1CD, просмотра баз 1CD для выявления повреждений, создания своих обработок для выгрузки данных без открытия исследуемой базы в 1С:Предприятии.

1 стартмани

07.10.2014    62622    392    GusevNA    78    

Принудительное выполнение отложенного обновления информационной базы для БП 3.0

Тестирование и исправление v8 БП3.0 Абонемент ($m)

Обработка выполняет отложенное обновление информационной базы.

1 стартмани

19.11.2020    4551    16    300_po_vstrechke    4    

Просмотр и восстановление любых таблиц БД для компоненты 1CDLib + Быстрая очистка регистра "Замеры времени"

Тестирование и исправление v8 1cv8.cf Абонемент ($m)

Доработанная обработка для компоненты 1CDLib для просмотра и восстановления любых таблиц БД из БД донора. Тестировалось на версии платформы 8.3.17.1549.

1 стартмани

09.11.2020    5284    66    sxp    2    

Тестирование любых конфигураций

Тестирование и исправление v8 v8::УФ 1cv8.cf Абонемент ($m)

Расширение для тестирования любых конфигураций на управляемых формах, в том числе тестируется запись, проведение и другие стандартные операции.

1 стартмани

29.10.2020    3038    16    ManyakRus    20    

Восстановление битой ссылки на раз-два Промо

Тестирование и исправление v8 1cv8.cf Абонемент ($m)

Простой способ восстановить битую ссылку типа " (20:94b81c6f65428d5911e2a8bebc48d793)".

1 стартмани

26.04.2013    36860    708    Vin_Tik    36    

Универсальная корректировка регистров

Администрирование данных 1С Тестирование и исправление v8 1cv8.cf Абонемент ($m)

Универсальная корректировка регистров (обработка для заполнения документа "Корректировка регистров")

3 стартмани

06.08.2020    4133    34    Pashka_SV    7    

Доработка путевых листов для спец.техники в БП 3.0 (в расширении)

Учет ТМЦ Бухгалтерский учет v8 v8::БУ БП3.0 Россия БУ Абонемент ($m)

В типовой БП 3.0 имеется возможность вводить и печатать Путевые листы только по форме 3 для легковых автомобилей. Данное расширение позволяет добавить к имеющемуся Путевой лист для спец.техники. Для этого в справочнике Транспортные средства необходимо указать норму расхода ГСМ для спец.техники.

2 стартмани

22.06.2020    4916    14    ivnik    8    

Установка имени предопределенных данных

Тестирование и исправление v8 1cv8.cf Абонемент ($m)

Обработка для установки имени предопределенных данных для исправления ошибки "Предопределенный элемент отсутствует в данных".

1 стартмани

20.06.2020    4468    3    simon_sidoruk    0    

Поиск, восстановление битой ссылки, 8.3, v 0.2 Промо

Поиск данных Тестирование и исправление v8 1cv8.cf Абонемент ($m)

Обработка для работы с битой ссылкой, 8.3, v 0.1 Позволяет быстро найти и восстановить битую ссылку.

1 стартмани

24.10.2014    39944    323    infostart user    14    

Выгрузка (обмен) ведомостей и отражение зарплаты (проводки) в бухучете из ЗУП 3.1 в КА 1 (УПП)

Зарплата Бухгалтерский учет Перенос данных из 1C8 в 1C8 v8 v8::СПР КА1 ЗУП3.x Россия БУ Абонемент ($m)

Выгрузка(обмен) ведомостей и отражение зарплаты(проводки) в бухучете из ЗУП 3.1 в КА1(УПП)

1 стартмани

03.05.2020    7089    57    VAAngelov    12    

Включение режима "Учет по подразделениям" в конфигурации БП 3.0

Бухгалтерский учет v8::БУ БП3.0 Россия БУ Абонемент ($m)

Данная публикация является готовым решением поднимавшихся ранее пабликов о том: как включить учет по подразделениям в конфигурации БП3.0 (Проф). Предлагаю расширение к типовой конфигурации (начиная с 3.0.75.98, на данный момент поддерживает актуальную конфигурацию БП3.0 (ПРОФ) 3.0.96).

2 стартмани

30.03.2020    6528    57    danilo.skiman    14    

Длина ключа индекса превышает максимально допустимую. Решение с использованием технологического журнала

Тестирование и исправление Технологический журнал v8 1cv8.cf Россия Абонемент ($m)

При разработке конфигурации в клиент-серверном варианте могут возникнуть проблемы при загрузке конфигурации в файловый вариант. В статье описан один из вариантов решения проблемы.

1 стартмани

28.01.2020    6409    3    newtraveller    0    

Лекарство на случай, если перестала работать форма списка для сделок. (ERP). Промо

Тестирование и исправление v8 ERP2 Абонемент ($m)

Форма списка справочник сделки стала выпадать с ошибкой?  Или все еще в порядке, но хочется спокойно съездить в отпуск, без паники, что менеджеры устроят бунт.

1 стартмани

28.07.2016    25731    0    milkers    2    

Исправление ошибки "Для одного ссылочного кода существует более одной таблицы в базе данных" в БД SQL

Тестирование и исправление v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка позволяет исправить схему имен базы данных, схема которой была испорчена и из-за этого возникают ошибки при обновлении конфигурации или при сервисной процедуре тестирования и исправления. Ошибка SDBL: Ошибка обновления конфигурации базы данных. Для одного ссылочного кода существует более одной таблицы в базе данных. Имена таблиц с кодом .... Далее перечисляются пары таблиц, которые имеют одинаковый номер. Обработка таблице находит новый номер, заменяет на него все ссылки в схеме, переименовывает таблицу SQL

3 стартмани

23.01.2020    16444    195    rokhin    58    

Поиск и Восстановление битых ссылок (Объект не найден) (обычные и управляемые формы)

Поиск данных Тестирование и исправление v8 v8::УФ 1cv8.cf Абонемент ($m)

Обработка для поиска и восстановления данных по битой ссылке (Объект не найден). Вы можете узнать информацию по удаленному объекту (его уникальный идентификатор, где используется), чтобы в бэкапной базе найти и восстановить этот объект. Данные битой ссылки восстанавливаются по COM соединению с копии базы.

1 стартмани

21.12.2019    6838    91    Denr83    0    

Исправление ошибки платформы 8.3.16 - разворота группы подписей в формах документов. ЗУП 3.1

Тестирование и исправление v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

После обновления платформы на релиз 8.3.16 в документах, где используются подписи ответственных лиц, при развороте группы аварийно закрывалось приложение.

1 стартмани

02.12.2019    18965    12    skudnovv    11    

Замена конфигурации в правилах переноса данных. Промо

Тестирование и исправление Обмен через XML Перенос данных из 1C8 в 1C8 v8 КД Абонемент ($m)

Те, кто часто занимается созданием правил конвертации данных в конфигурации «Конвертация данных” (речь о редакции 2.1 (2.1.5.1)), знают, что после замены в правилах конвертации одной конфигурации (приемник или источник) все правила конвертации свойств и объектов закрашиваются красным цветом и требуют утомительной ручной правки.

1 стартмани

24.01.2012    48115    559    milkers    68    

Ошибка при обновлении "Для одного ссылочного кода существует более одной таблицы в базе данных"

Инструментарий разработчика Тестирование и исправление v8 1cv8.cf Абонемент ($m)

После перехода на новую платформу поменялась (появилась) проверка на дублирование внутренних идентификаторов объектов метаданных. Возможная ошибка при обновлении "Для одного ссылочного кода существует более одной таблицы в базе данных". Лечится изменением идентификатора объекта метаданных.

1 стартмани

30.10.2019    12518    19    user646807_kazako.a911    15    

Должно быть NULL в регистре бухгалтерии Хозрасчетный

Тестирование и исправление Инструментарий разработчика v8 v8::БУ 1cv8.cf БУ Абонемент ($m)

Обработка проверяет наличие и решает проблему с ошибкой развернутого сальдо в Оборотно-сальдовой ведомости (регистр бухгалтерии Хозрасчетный) из-за ошибки Универсального редактора реквизитов или кода программиста, устанавливающего пустые ссылки в значениях Валюты, Подразделения, Направления деятельности не равными NULL. И пересчёт итогов тут точно не поможет...

2 стартмани

21.10.2019    18121    74    sapervodichka    33    

Свертка 60, Свертка 62, Исправление ошибок взаиморасчетов, Исправление 60, Исправление 62 Промо

Свертка базы Тестирование и исправление Анализ учета Дебиторская и кредиторская задолженность Оборотно-сальдовая ведомость, Анализ счета Дебиторская и кредиторская задолженность Оборотно-сальдовая ведомость, Анализ счета v8 БП2.0 Россия БУ Абонемент ($m)

Исправляет все возможные ошибки по счетам расчетов с контрагентом, делает дебетовое сальдо на активном счете и кредитовое на пассивном. кроме того зачитывает все суммы по контрагенту и договору. Сворачивает 60 и 62 счета. Умеет работать с документами взаиморасчетов или без них.

1 стартмани

21.10.2010    41171    680    GoodWinSpr    37    

Ошибка SDBL: Ожидается имя таблицы (pos=6). Причины, лечение, обход. Поиск отсутствующих таблиц изменений

Тестирование и исправление v8 1cv8.cf Россия Абонемент ($m)

Получили ошибку Ошибка SDBL: Ожидается имя таблицы (pos=6) ? Надеюсь, мой опыт борьбы с этим явлением Вам поможет.

1 стартмани

04.09.2019    15103    62    burmsergey    6    

Методика использования характеристик номенклатуры для снижения на порядок количества ресурсных спецификаций в ERP

Производство готовой продукции (работ, услуг) Пользователю системы Бухгалтерский учет Производство готовой продукции (работ, услуг) v8 ERP2 Россия УУ Абонемент ($m)

Представлена оригинальная методика использования характеристик номенклатуры для снижения на порядок количества ресурсных спецификаций в ERP, опробованная на предприятии радиоэлектронной продукции с количеством изделий в несколько тысяч наименований. Данная методика использует кодирование конструкторской документации и использование этих кодов для формирования правильной структуры изделия (раскомплекта). Эта методика подойдет для построения любых спецификаций, основанных на конструкторской документации по ГОСТ 2.103-2013 Дополнено 08.08.2019: Устранение "бесконечных рекурсий" в ресурсных спецификациях...

1 стартмани

23.07.2019    8779    20    rechvladmir    2    

Проверка работы расширений после обновлений

Тестирование и исправление v8 1cv8.cf Абонемент ($m)

Иногда бывает, что после обновления конфигурации некоторые расширения перестают работать и часто такие ошибки выявляются только в процессе тестирования или рабочем режиме. При правильной разработке и проектировании расширения можно свести к минимуму такие ошибки, но иногда их не избежать. Если в базе расширений не более 5-10, то проверить каждое после обновления не составляет труда, а вот если их больше 50 - проверка отнимает слишком много времени Поэтому была написана обработка, которая в автоматическом режиме проверяет расширения, подключенные в программе. Обработка универсальная и будет работать в любой программе, в которой есть расширения.

3 стартмани

19.07.2019    18795    31    77dream77    4    

ЧеКист (Чистка Кэша) - универсальное средство очистки локального кэша 1С Промо

Сервисные утилиты Тестирование и исправление v8 1cv8.cf Абонемент ($m)

Простое в эксплуатации и универсальное в применении средство для исправления ошибок, возникающих с локальным кэшем на клиенте. Легко устанавливается и быстро развертывается в сети. Имеет мобильное исполнение в виде внешней обработки. Понятная любому пользователю логика работы.

1 стартмани

08.08.2013    88668    614    mbreaker    58    

Поиск и удаление "битых" ссылок () в регистрах (сведений/накоплений)

Тестирование и исправление v8 v8::УФ 1cv8.cf Кыргызстан Абонемент ($m)

Иногда случается так, что в движениях регистров, подчиненных регистратору, теряется ссылка на регистратор "".

1 стартмани

24.06.2019    9200    42    Vyacheslide    5    

Проверка обновления. Автоматический поиск ошибок

Сервисные утилиты Тестирование и исправление v8 v8::УФ 1cv8.cf Абонемент ($m)

Мы обновляем конфигурацию, и у нас более 100 пользователей. Конфигурация сильно переписана, обновление нетривиальное. Если после обновления находится критическая ошибка, приходится выгонять всех пользователей и исправлять. Поэтому перед выпуском в рабочую базу, обновление тестируют наши специалисты. Большинство ошибок находится при открытии форм. Появилась идея написать программу, которая бы автоматически открывала формы всех объектов, а найденные ошибки записывала в журнал регистрации. Получилась программа простейшего сценарного тестирования. Не требует настройки. Запускать в тестовой базе. Чтобы найти реквизиты, не добавленные на форму в процессе обновления или синтаксические ошибки, достаточно запустить тест под полными правами. Тестировали на УТ 11.4.1.271, должно работать на всех программах УФ. У нас тест работает пять минут.

1 стартмани

10.06.2019    8193    8    Mari_Kuznetzova    3    

Исправление ошибки "Записи регистра сведений стали не уникальными"

Тестирование и исправление v8 1cv8.cf Россия Абонемент ($m)

Обработка исправления ошибки "Записи регистра сведений стали не уникальными"

1 стартмани

02.06.2019    16828    237    Sholl    0    

Регистрация <объект не найден> на узлах обмена или перерегистрация Ссылок. Промо

Тестирование и исправление Перенос данных из 1C8 в 1C8 v8 1cv8.cf Абонемент ($m)

С помощью этой обработки можно зарегистрировать объекты (документы и их движения, справочники, <Объект не найден>) на узлах обмена.

1 стартмани

15.02.2013    34499    99    logarifm    6    

Расширение для исправления структуры подчиненности

Тестирование и исправление v8 1cv8.cf Россия Абонемент ($m)

Расширение для исправления связанных документов (структура подчиненности).

1 стартмани

06.05.2019    8888    4    PROGRAM1S    4    

Передача товаров между организациями в УНФ или эффективность фиктивности

Учет ТМЦ Обработка документов Бухгалтерский учет Учет ТМЦ v8 УНФ Россия УУ Абонемент ($m)

Реализация схемы передачи товаров между организациями в УНФ.

2 стартмани

12.03.2019    18191    35    user925427    35    

Восстановление структуры DBSchema

Тестирование и исправление v8 БП3.0 Абонемент ($m)

Обработка для анализа ошибок в структуре DBShema, восстановление структуры объектов, перенос данных из выгруженных в XML таблиц базы, при помощи "Tool 1CD".

10 стартмани

11.03.2019    16463    78    spawn_a    29    

Открывашка (для отладки) Промо

Сервисные утилиты Инструментарий разработчика Практика программирования Универсальные обработки Тестирование и исправление v8 1cv8.cf Россия Абонемент ($m)

Упрощает отладку и экономит время - позволяет открыть отлаживаемый объект конфигурации путем пары кликов (Файл - Последний файл №N) или пары нажатий клавиш (Alt - Стрелка вниз - N последнего открытого файла на клаве).

1 стартмани

12.12.2012    24629    73    nastrou1c    11    

Небольшая доработка функционала отладчика c использованием DynamicWrapperX

Тестирование и исправление v8 1cv8.cf Абонемент ($m)

Получение методов 1С-х объектов во время отладки.

1 стартмани

15.02.2019    8358    2    chessman    9    

Ошибки, предупреждения и прочее из журнала регистрации на почту и в Telegram автоматически (БП 3, ЗУП 3.1, УТ 11.4, ERP 2.4, Розница 2.2)

Журнал регистрации Поиск данных Тестирование и исправление Email v8 Розница УНФ ERP2 ЗКГУ3.0 БП3.0 УТ11 ЗУП3.x Абонемент ($m)

Данная обработка позволяет анализировать журнал регистрации с пользовательским отбором (4 критерия отбора) и высылать отчет пользователю с заданной периодичностью на электронную почту или в Телеграм. Возможно использовать как регламентное задание (автоматическая отправка отчетов по времени), непосредственно запускать из клиента, а также выгружать в форму обработки отфильтрованные данные из журнала регистрации без отправки.

2 стартмани

28.01.2019    14955    43    Redinternational    3    

Замена конфигурации в правилах обмена

Обработка справочников Тестирование и исправление Перенос данных из 1С7.7 в 1C8.X Обмен через XML Перенос данных из 1C8 в 1C8 1С7.7<->1C7.7 v8 КД Абонемент ($m)

С помощью этой внешней обработки для конфигурации 1С:Конвертация данных, ред. 2.1 вы легко замените конфигурацию приемника или источника в правилах конвертации объектов.

2 стартмани

08.01.2019    11965    66    tomvlad    9    

Автоформатирование кода Промо

Сервисные утилиты Обработки Чистка базы Справки Производительность и оптимизация (HighLoad) Инструментарий разработчика Практика программирования Универсальные обработки Решение задач на 1С:Специалист Математика и алгоритмы Администрирование данных 1С Разработка Тестирование и исправление Стартеры 1С v8 1cv8.cf Абонемент ($m)

Как часто приходится работать в режиме аврала, когда на оформление кода не хватает времени? И как лениво порой бывает, возвращаться к уже рабочему коду, что бы отформатировать его и привести в порядок. Данная обработка позволяет автоматически форматировать текст кода, в соответствии с настройками пользователя. Это позволит привести ваш код, как уже написанный так и будущий к единому оформлению.

1 стартмани

19.12.2012    45046    182    Sibars    57    

Исправление справочника Идентификаторы объектов метаданных, обновление вспомогательных данных

Обработка справочников Тестирование и исправление v8 1cv8.cf Абонемент ($m)

Когда возникают следующие ошибки в 1С "Не найден идентификатор в справочнике идентификаторы объектов метаданных" "Не открывается какой-нибудь отчёт или внешняя обработка и ругается на справочник идентификаторы объектов метаданных" "Требуется воспользоваться обработкой "Обновление вспомогательных данных" "Запустить программу с параметром командной строки "/С ЗапуститьОбновлениеИнформационнойБазы" "либо увеличить номер версии конфигурации" "После десяти попыток в справочнике идентификаторы объектов метаданных остались дубликаты".

1 стартмани

26.12.2018    8853    83    AlexandrN    9    

Проверка актуальности итогов регистров накоплений

Тестирование и исправление v8 1cv8.cf Абонемент ($m)

Иногда возникают ситуации, когда с остатками происходит что-то непонятное. Остаток на начало + Оборот != Остаток на конец. После пересчета итогов проблема уходит. Но как узнать вовремя, что что-то не так?

1 стартмани

11.12.2018    9494    19    dmt    17    

[Расширение] Бухгалтерия государственного учреждения 2.0 (с версии 2.0.78.32)

Рабочее место Бухгалтерский учет v8 v8::БУ БГУ Государственные, бюджетные структуры Россия Госбюджет Абонемент ($m)

Расширение конфигурации для программного продукта 1С Бухгалтерия государственного учреждения 2.0. Расширение содержит более 20 различных дополнений для справочников, документов, отчетов и обработок, не требует изменения конфигурации. Протестировано на версии 2.0.78.32 (на предыдущих релизах работа не гарантируется).

1 стартмани

29.10.2018    11775    23    scanner1980    6    

Универсальный загрузчик XML-Uniloader Промо

Обмен через XML Распределенная БД (УРИБ, УРБД) Тестирование и исправление v8 1cv8.cf Абонемент ($m)

Этот универсальный инструмент обязан входить в джентельменский набор любого специалиста по обмену данными. Он позволяет загрузить данные в базу из файла выгрузки, созданного типовой обработкой «Выгрузка-загрузка данных». Он позволяет загрузить данные из файла выгрузки РИБ. При этом используется развитая система работы с ошибками, ведется протокол, процесс загрузки не мешает работать другим пользователям.

1 стартмани

24.07.2012    35155    259    fixin    34    

Нестандартные подсистемы: Живая вода

Поиск данных Тестирование и исправление v8 1cv8.cf Абонемент ($m)

В БСП есть все, чтобы справиться с проблемой «Битых ссылок», но почему-то так и не реализовали возможность сохранять версию объекта перед удалением. Решил исправить эту досадную несправедливость и создать подсистему с кодовым названием «Живая вода».

1 стартмани

11.10.2018    14945    3    dsdred    14    

Кое-что простое о сложных штрих-кодах

Сканер штрих-кода Бухгалтерский учет Розничная торговля Розничная торговля v8 1cv8.cf УУ Абонемент ($m)

На просторах и-нета часто встречаю публикации, в которых авторы с энтузиазмом рассказывают о том, как в штрих-код внести информацию о нескольких сущностях: например, как сделать, чтобы при сканировании одного штрих-кода на ярлыке товара, 1С определяла что это за товар, его качество и приходную накладную по которой этот товар поступил. Увы, но делается это "в лоб". Я предлагаю более разумный способ. Он очевиден - так что не претендую на лавры первооткрывателя.

1 стартмани

28.09.2018    21477    10    torch    15