Легкое добавление формы печати через *.docx Word в документы, 1С:ERP

Публикация № 1519552 21.09.21

Разработка - Печать - Универсальные печатные формы

ERP *.doc word печать форм БСП

Очень лаконичная, простая, короткая обработка позволяет легко добавить печать через использование Word *.doc.

Тестировалось в 1С:ERP Управление предприятием 2 (2.4.13.227) 1С:Предприятие 8.3 (8.3.18.1289)

Как я понимаю, в основе БСП и работать много где должно.

Убил выходные, чтобы с 0 разобраться, как напечатать небольшой документ, с одной таблицей, примеры, которые находил очень громоздки, и не очевидны, да, возможно, для удовлетворения сложных потребностей и требуется так делать, но для понимания базового функционала мой пример очень простой, минимум необходимых функций и процедур.

1. Создаём шаблон в Word *.docx, при этом колонтитулы сами по себе являются областями, вся другая информация должна быть помещена в области, и заменяемые части вставляем в нужные места. В коде нужно будет указать тип области 

  • СтрокаТаблицы – используется для вывода множества строк таблицы;
  • Список – используется для вывода множества строк маркированного списка;
  • Общая – используется для вывода простых областей;
  • ВерхнийКолонтитул – используется для вывода верхнего колонтитула;
  • НижнийКолонтитул – используется для вывода нижнего колонтитула;
  • ВерхнийТитульныйКолонтитул – используется для вывода верхнего титульного колонтитула;
  • НижнийТитульныйКолонтитул – используется для вывода нижнего титульного колонтитула;
  • ВерхнийЧетныйКолонтитул – используется для вывода верхнего колонтитула четных страниц;
  • НижнийЧетныйКолонтитул – используется для вывода нижнего колонтитула четных страниц;
{v8 Область.НаименованиеОбласти}
{v8 НаименованиеЗаменяемойПеременной}
{/v8 Область.НаименованиеОбласти}
	// Создаем структуру областей формируемой печатной формы OpenXМL
	ОписаниеОбластей = Новый Структура;
	УправлениеПечатью.ДобавитьОписаниеОбласти(ОписаниеОбластей, "ВерхнийКолонтитул", "ВерхнийКолонтитул");
	УправлениеПечатью.ДобавитьОписаниеОбласти(ОписаниеОбластей, "Шапка", "Общая");
	УправлениеПечатью.ДобавитьОписаниеОбласти(ОписаниеОбластей, "СтрокаТаблицы", "СтрокаТаблицы");
	УправлениеПечатью.ДобавитьОписаниеОбласти(ОписаниеОбластей, "НижнийКолонтитул", "НижнийКолонтитул");

2. Загружаем документ в макет, двоичные данные

 

 

3. Полный листинг: прописываем в какие документы прикрепить печать, запрос на выгрузку данных, и собственно редактирование данных единичных в общую структуру, а табличные данные собираем в массиве структур, добавляем необходимые области и заменяем там текст.

Функция СведенияОВнешнейОбработке() Экспорт
	ПараметрыРегистрации = Новый Структура;	
	ПараметрыРегистрации.Вставить("Вид", "Печатнаяформа");
	ПараметрыРегистрации.Вставить("Назначение", ПолучитьНазначениеОбработки());
	ПараметрыРегистрации.Вставить("Наименование", "Печать документа Word"); //Наименование обработки 
	ПараметрыРегистрации.Вставить("Версия", "1.0.0");
	ПараметрыРегистрации.Вставить("Информация", "Печать документов Word"); //Поле дополнительной информации в описании обаботки
	ПараметрыРегистрации.Вставить("БезопасныйРежим", Ложь);
	
	Команды = ПолучитьТаблицуКоманд();
	ДобавитьКоманду(Команды, 	"Печать документа Word", //Надпись в отображении печати документа
								"ДокументWordName",
								"ВызовСерверногоМетода");								
	ПараметрыРегистрации.Вставить("Команды", Команды);	
	Возврат ПараметрыРегистрации;	
КонецФункции

//Список документов использования
Функция ПолучитьНазначениеОбработки()
	Назначение = Новый Массив;
	Назначение.Добавить("Документ.ВнутреннееПотреблениеТоваров");	
	Возврат Назначение;
КонецФункции

Функция ПолучитьТаблицуКоманд()	
	Команды = Новый ТаблицаЗначений;
	Команды.Колонки.Добавить("Представление", Новый ОписаниеТипов("Строка"));
	Команды.Колонки.Добавить("Идентификатор", Новый ОписаниеТипов("Строка"));
	Команды.Колонки.Добавить("Использование", Новый ОписаниеТипов("Строка"));
	Возврат Команды;
КонецФункции

Процедура ДобавитьКоманду(ТаблицаКоманд, Представление, Идентификатор, Использование)
	НоваяКоманда = ТаблицаКоманд.Добавить();
	НоваяКоманда.Представление = Представление;
	НоваяКоманда.Идентификатор = Идентификатор;
	НоваяКоманда.Использование = Использование;
КонецПроцедуры

Процедура Печать(МассивОбъектов, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт  		
	ПечатнаяФорма = УправлениеПечатью.СведенияОПечатнойФорме(КоллекцияПечатныхФорм, "ДокументWordName"); //Идентификатор формы в команде
	Если ПечатнаяФорма <> Неопределено Тогда
	    ОфисныеДокументы = НапечататьАктСписания(МассивОбъектов);
		ПечатнаяФорма.ТабличныйДокумент = Новый ТабличныйДокумент;
		ПечатнаяФорма.СинонимМакета    = НСтр("ru = 'Печать документа Word'");
		ПечатнаяФорма.ОфисныеДокументы = ОфисныеДокументы;
	КонецЕсли;  		
КонецПроцедуры

Функция НапечататьАктСписания(МассивОбъектов) Экспорт
	//Запрашиваем документы для печати
	ЗапросПоДокументам = Новый Запрос;
	ЗапросПоДокументам.УстановитьПараметр("МассивОбъектов", МассивОбъектов);
	ЗапросПоДокументам.Текст =
	"ВЫБРАТЬ
	|	Документ.Ссылка КАК Ссылка,
	|	Документ.Номер КАК Номер,
	|	Документ.Дата КАК Дата,
	|	Документ.Товары.(
	|		Номенклатура.НаименованиеПолное КАК Наименование,
	|		Характеристика.НаименованиеПолное КАК Характеристика,
	|		НомерСтроки КАК НомерСтроки,
	|		Количество КАК Количество,
	|	) КАК Товары
	|ИЗ
	|	Документ.ВнутреннееПотреблениеТоваров КАК Документ
	|ГДЕ
	|	Документ.Ссылка В(&МассивОбъектов)
	|УПОРЯДОЧИТЬ ПО
	|	Дата,
	|	Ссылка,
	|	НомерСтроки";	
	
	// Создаем пустое соответствие для размещения печатных форм OpenXМL – результат функции
	ОфисныеДокументы = Новый Соответствие;	
	//Находим макет в обаботчике
	МакетДокумента = ЭтотОбъект.ПолучитьМакет("ПФ_DOC_ПечатьДокументWord"); // Наименование макета	
	
	// Создаем структуру областей формируемой печатной формы OpenXМL
	ОписаниеОбластей = Новый Структура;
	УправлениеПечатью.ДобавитьОписаниеОбласти(ОписаниеОбластей, "ВерхнийКолонтитул", "ВерхнийКолонтитул");
	УправлениеПечатью.ДобавитьОписаниеОбласти(ОписаниеОбластей, "Шапка", "Общая");
	УправлениеПечатью.ДобавитьОписаниеОбласти(ОписаниеОбластей, "СтрокаТаблицы", "СтрокаТаблицы");
	УправлениеПечатью.ДобавитьОписаниеОбласти(ОписаниеОбластей, "НижнийКолонтитул", "НижнийКолонтитул");
	
	//Вышрузка документов
	ВыборкаДокументы = ЗапросПоДокументам.Выполнить().Выбрать();
	Пока ВыборкаДокументы.Следующий() Цикл
		ОбщиеДанные = Новый Структура ("Дата, Номер");
		ОбщиеДанные.Дата = Формат(ВыборкаДокументы.Дата, "ДФ='''«''dd''»'' MMMM yyyy ''г.'''");   
		ОбщиеДанные.Номер = ВыборкаДокументы.Номер;
	

		//Строки в таблице должы быть массивом коллекций, запрашиваем номенклатуру в списке таблице Товары
		ДанныеСтрок = Новый Массив;		
		ВыборкаСтроки = ВыборкаДокументы.Товары.Выбрать();
		Пока ВыборкаСтроки.Следующий() Цикл			
			СтрокаТаблицы = Новый Структура ("НомерСтроки, Наименование");
			СтрокаТаблицы.НомерСтроки = ВыборкаСтроки.НомерСтроки;
			СтрокаТаблицы.Наименование = НоменклатураКлиентСервер.ПредставлениеНоменклатурыДляПечати(
			ВыборкаСтроки.Наименование,
			ВыборкаСтроки.Характеристика);				
			СтрокаТаблицы.Количество = ВыборкаСтроки.Количество;
			ДанныеСтрок.Добавить(СтрокаТаблицы);	
		КонецЦикла;
		
		//Закрузка макета, печатной фармы
		Макет = УправлениеПечатью.ИнициализироватьМакетОфисногоДокумента(МакетДокумента, Неопределено);
		ПечатнаяФорма = УправлениеПечатью.ИнициализироватьПечатнуюФорму(Неопределено, Неопределено, Макет);		
		
		//Печать колонтитула с подстановкой данных
		Область = УправлениеПечатью.ОбластьМакета(Макет, ОписаниеОбластей["ВерхнийКолонтитул"]);	
		УправлениеПечатью.ПрисоединитьОбластьИЗаполнитьПараметры(ПечатнаяФорма, Область, ОбщиеДанные);		
		
		// Печать обаластей
		Область = УправлениеПечатью.ОбластьМакета(Макет, ОписаниеОбластей["Шапка"]);	
		УправлениеПечатью.ПрисоединитьОбластьИЗаполнитьПараметры(ПечатнаяФорма, Область, ОбщиеДанные);
		
		// Печать табличной части
		Область = УправлениеПечатью.ОбластьМакета(Макет, ОписаниеОбластей["СтрокаТаблицы"]);	
		УправлениеПечатью.ПрисоединитьИЗаполнитьКоллекцию(ПечатнаяФорма, Область, ДанныеСтрок);

		//Печать колонтитула с подстановкой данных
		Область = УправлениеПечатью.ОбластьМакета(Макет, ОписаниеОбластей["НижнийКолонтитул"]);	
		УправлениеПечатью.ПрисоединитьОбластьИЗаполнитьПараметры(ПечатнаяФорма, Область, ОбщиеДанные);

		// Помещаем сформированную печатную форму в соответствие ОфисныеДокументы
		// Наименоние формировать желательно с изменяющимся параметром
		АдресХранилищаПечатнойФормы = УправлениеПечатью.СформироватьДокумент(ПечатнаяФорма);
		ОфисныеДокументы.Вставить(АдресХранилищаПечатнойФормы, "ДокументWordName " + ВыборкаДокументы.Номер);
		УправлениеПечатью.ОчиститьСсылки(ПечатнаяФорма);
		УправлениеПечатью.ОчиститьСсылки(Макет);
	КонецЦикла;
	Возврат ОфисныеДокументы;
	
КонецФункции;

4. Добавляем наш обработчик и радуемся легко печати. В документах при выборе печати появляется наш вариант

 

 

5. Получившийся документ

 

Скачать файлы

Наименование Файл Версия Размер
Печать Документа в *.doc

.epf 25,54Kb
7
.epf 1.0.0 25,54Kb 7 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. AnryMc 807 30.09.21 15:04 Сейчас в теме
Добрый день!

Не могу сообразить как вывести без "привязанных" документов...

Т.е. при открытии сделать произвольный запрос и вывести форму в Ворд, типа "Внешний отчет" -
2. vPikalov 5 01.10.21 23:03 Сейчас в теме
(1) Я не силён в 1С. Поищите в других статьях.
Но моё виденье: Нужно в любом случае указать место, т.е. документ/отчет/т.п. в котором можно будет выпустить на печать.
А привязка идёт в данном случае к документу в котором вызывается, либо через список документов через:
ЗапросПоДокументам = Новый Запрос;
ЗапросПоДокументам.УстановитьПараметр("МассивОбъектов", МассивОбъектов); (т.е. это ссылка на текущий документ, либо список документов)

По сути если вам нужно произвольная печать из любого места, то в любом случае как я понимаю указать из какого документа/отчета вы будете выводить. И собственно делать произвольный запрос.

И если брать произвольные запрашиваемые параметры, я пока не вникал, но на очереди стоит, вариант когда перед печатью идёт запрос каких либо параметров, которые можно использовать в запросе, как это сделать не подскажу.
Оставьте свое сообщение

См. также

Мастер печатных форм v 3.3 (+English version) Промо

Универсальные печатные формы v8 v8::УФ v8::СКД 1cv8.cf Абонемент ($m)

Создание печатных форм "с нуля" за несколько минут. Моментальная отладка. Не требует знания встроенного языка 1С. Работает в толстом, тонком и вэб-клиентах.

1 стартмани

07.03.2014    98580    1203    kser87    225    

Печать этикеток из табличного документа QR, DataMatrix, EAN8, EAN13, EAN128, Code39, Code128, PDF417

Универсальные печатные формы v8 1cv8.cf Абонемент ($m)

Печать всех распространенных типов штрихкодов из табличного документа.

2 стартмани

08.09.2021    505    2    vladnet    0    

Сохранение данных печатных форм

Универсальные печатные формы Печатные формы документов Адаптация типовых решений v8 БП3.0 Россия Абонемент ($m)

Расширение для сохранения данных, которые пользователи вводят в печатных формах. В состав расширения входит справочник "Настройка сохранения данных ПФ", в котором настраивается, какие ячейки ПФ сохранять.

1 стартмани

02.09.2021    690    2    aldor188    0    

Печать WORD из тонкого клиента с доступом по вэб адресу (управляемые формы)

Универсальные печатные формы v8::УФ 8.3.14 УТ11 Абонемент ($m)

Вариант печати файлов WORD из 1С из-под тонкого клиента, подключенного по вэб адресу. В файле показан вариант печати динамических таблиц, то есть таблиц с изменяемым количеством строк. Обработка печати довольно простая. Опробована на Управление торговлей, редакция 11 (11.4.13.155), версия платформы 1С:Предприятие 8.3 (8.3.18.1334)

1 стартмани

10.06.2021    1667    1    user810754    1    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП Промо

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    33188    60    kwazi    6    

Отладка внешних печатных форм, когда не открывается даже временный файл

Универсальные печатные формы Прочие инструменты разработчика v8 1cv8.cf Абонемент ($m)

Отладка с помощью формы обработки, на форме добавляем реквизит Документ, для которого предназначена внешняя обработка. Затем командой вызываем нужный обработчик и отлаживаем в свое удовольствие. Написали и открываем как обычную внешнюю обработку, ставим точку остановки и жмем кнопку команды.

2 стартмани

20.04.2021    2009    5    Miracle180882    0    

Универсальная печать кадровых документов в формате Word для ЗУП 3

Универсальные печатные формы Печатные формы документов Зарплата v8 v8::СПР v8::УФ ЗУП3.x Россия БУ УУ Абонемент ($m)

Внешняя обработка для печати кадровых документов: Приказов, Приемов на работу, Кадровых перемещений, Договоров о материальной ответственности и прочих кадровых документов. Документы печатаются из шаблонов, созданных в формате docx из внешних файлов, размещенных в любой внешней папке. Шаблоны без особого труда могут быть созданы работниками кадровых служб предприятия. Создание шаблона не сложнее создания соответствующего документа в формате docx. Предназначена для ЗУП 3.1 на управляемых формах.

1 стартмани

14.04.2021    2278    13    user810754    0    

Вывод на печать табличной части заказа и своих параметров в УНФ 1.6 с помощью встроенного механизма шаблонов КП и договоров

Универсальные печатные формы v8 УНФ Россия Абонемент ($m)

Фирма 1С предоставила нам в конфигурации УНФ удобный механизм печати шаблонов договоров и коммерческих предложений в форматах docx и odt. Достаточно указать нужный Word документ в настройках шаблонов раздела CRM, отметить необходимые реквизиты для подстановки их значений в Ваш договор, и пользоваться печатью. НО... мы не нашли возможности вывода в шаблон содержимого табличных частей документов, а также произвольных реквизитов, значения которых являются переменными, и наряду с типовыми реквизитами заданных документов (заказа покупателя, счета на оплаты, заказ наряда), также могут потребовать своего вывода.

1 стартмани

25.03.2021    2263    1    Rabin    1    

Конструктор внешних печатных форм NEW beta (обычные и управляемые приложения!) Промо

Универсальные печатные формы Инструментарий разработчика v8 1cv8.cf Абонемент ($m)

Версия NEW beta=) "Конструктор внешних печатных форм" максимально автоматизирует процесс создания внешних печатных форм на основе типовых. Создание внешней печатной формы займет от секунд до пары минут! Теперь и на управляемых приложениях =)

1 стартмани

18.11.2012    73857    1975    SeiOkami    185    

Шаблоны договоров. Для конфигурации "Бухгалтерия для Беларуси, редакция 2.1"

Универсальные печатные формы Печатные формы документов v8 1cv8.cf Беларусь БУ Абонемент ($m)

Механизм создания шаблонов договоров, сделанный по аналогии из конфигурации Бухгалтерия предприятия, редакция 3.0.

1 стартмани

23.03.2021    1630    1    burni4    1    

Универсальная печатная форма для справочника и документа по своему шаблону, сделанному в ms word: Кадровые, Торговые, Делопроизводственные, Бухгалтерские, Управляющие

Универсальные печатные формы Печатные формы документов v8 1cv8.cf Розница УНФ ERP2 БП3.0 УТ11 КА2 ЗУП3.x Россия Абонемент ($m)

Создавайте дополнительные печатные формы для печати из 1С по своему усмотрению без помощи программиста. Например можно прямо из справочника Физические лица или Сотрудники - напечатать не стандартный документ, например карточку Физического лица по своим полям, прикрепить к нему свой специфичный договор или какую-нибудь расписку. Трудовой договор прямо из списка сотрудников и ещё много свободных бланков. Из контрагента - специально оформленный по вашему требованию договор в который подставятся нужные данные из базы 1С.

5 стартмани

02.02.2021    4289    70    user1479207    11    

Печать комплекта произвольных (внешних) печатных форм, добавление, изменение печатных форм пользователем в формате word для ЗУП 3.1

Зарплата Универсальные печатные формы Пакетная печать v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Расширение решает следующие задачи: 1) Печать комплекта произвольных печатных форм в формате word 2) Добавление, изменение печатных форм пользователем 1С, без участия программиста. Разработано на базе БСП

3 стартмани

16.12.2020    3456    9    vanessa    0    

Универсальная печатная форма для ЗУП, ред.3.1 с использованием пользовательских макетов в формате Word, mxl из справочника Файлы

Универсальные печатные формы v8 v8::СПР ЗУП3.x Россия Абонемент ($m)

Универсальная печатная форма для ЗУП, ред.3.1. Макеты в формате Word (doc,docx) или mxl создают сами пользователи, используя так называемые "теги" из инструкции. Макеты загружаются в справочник Файлы. При печати пользователем выбирается необходимый макет, макеты Word, mxl.

1 стартмани

26.11.2020    2736    15    fannur    4    

Внешние печатная форма и отчет для 1С DRIVE

Универсальные печатные формы v8 1cv8.cf Абонемент ($m)

Внешняя печатная форма и внешний отчет, подключаемые в дополнительные отчеты для 1С DRIVE.

1 стартмани

02.11.2020    2483    0    hamsar    0    

Печать данных контрагента для 1С:Бухгалтерии ред. 3

Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Дополнительная обработка с авторегистрацией для справочника "Контрагенты". Присутствует возможность выбора разделов выводимой информации. Печатная форма аналогична отчету по данным контрагента в 1С:Бухгалтерии ред. 2.

1 стартмани

29.10.2020    2264    3    kore    0    

Новый взгляд на старое. Внешняя печатная форма – НАСТРАИВАЕМАЯ

Универсальные печатные формы Печатные формы документов Оптовая торговля v8 ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Печатная форма, которую можно за 1 минуту изменить до неузнаваемости. Включены основные хотелки пользователей. Настраивается в режиме предприятия, без конфигурирования.

2 стартмани

21.10.2020    5285    25    user1209971    19    

Шаблон ВПФ (внешней печатной формы) для вывода в Word

БСП (Библиотека стандартных подсистем) Универсальные печатные формы v8 1cv8.cf Абонемент ($m)

Шаблон для разработки ВПФ для БСП версии 3.1. Основные возможности: 1. Описание требуемых для вывода данных при помощи СКД. 2. Вывод в документ средствами БСП (не используется COM-соединение с word) 3. Реализована форма для тестирования без подключения обработки к БСП и без помещения документа-макета в обработку.

1 стартмани

10.10.2020    4172    12    Gladkov_Anton    4    

Печать без префикса базы в УТ 11.4 и КА 2.4

Универсальные печатные формы v8 УТ11 КА2 Абонемент ($m)

Расширение конфигурации для печати документов без префикса информационной базы.

1 стартмани

06.10.2020    2796    14    serg_art    8    

Печать WORD из 1С, управляемого приложения (еще один вариант)

Универсальные печатные формы v8 v8::СПР ЗУП3.x Россия Абонемент ($m)

Вариант произвольный для печати кадровых и прочих документов, где много слов и мало данных. Минимальное использование БСП. Предназначен для ленивых программистов типа меня, кому лень набирать много текста в печатных формах и которые предпочитают брать готовые документы в формате WORD у кадровиков и юристов и делать из них с минимальными изменениями печатные формы.

1 стартмани

02.10.2020    4995    20    user810754    2    

Шаблон внешней печатной формы с вводом параметров

Универсальные печатные формы v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

В ряде случаев, перед тем как послать документ на печать, требуется внести некоторые параметры. Именно это позволяет сделать данный шаблон печатной формы.

1 стартмани

01.10.2020    4183    14    LamerSoft    0    

Отладочная форма для внешней печатной формы

Универсальные печатные формы v8 Розница УНФ ERP2 ЗКГУ3.0 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Форму возможно подцепить (просто скопировав в вашу печатку и назначив формой обработки), подходит под управляемый интерфейс конфигурации на базе БСП 2.2 и выше с типом команды вызова серверного метода. С легкими модификациями подойдет под любой вызов.

1 стартмани

22.09.2020    3258    12    LamerSoft    0    

Генератор внешних печатных форм

Инструментарий разработчика БСП (Библиотека стандартных подсистем) Консоль запросов Прочие инструменты разработчика Универсальные печатные формы v8 1cv8.cf Абонемент ($m)

Генератор печатных форм - инструмент для создания внешних печатных форм в режиме предприятия с минимальным написанием кода

3 стартмани

18.09.2020    5874    18    andy_zhav    7    

[FREE] Универсальная команда печати элемента (карточки справочника)

Универсальные печатные формы v8 1cv8.cf Абонемент ($m)

На основе данных формы объекта, с учетом группировок, заголовков и порядка вывода на форму получаем построчный вывод макета.

1 стартмани

03.09.2020    3047    0    pridecom    0    

Дополнительная система формирования подписей и печатей. Располагает картинки под текстом

Универсальные печатные формы v8 1cv8.cf Россия Абонемент ($m)

Позволяет организовать дополнительную систему печатей и подписей в существующих печатных формах. Также умеет преобразовывать ячейки под картинками в объекты для правильного отображения картинок

7 стартмани

28.06.2020    3658    1    JackGamer_    2    

Пользовательские макеты внешних печатных форм и настраиваемый комплект документов по договорам

БСП (Библиотека стандартных подсистем) Универсальные печатные формы v8::БУ БП3.0 Абонемент ($m)

- Расширение стандартной подсистемы печати, позволяющее редактировать макеты внешних печатных форм и сохранять их по аналогии с встроенными печатными формами - подсистема настраиваемых комплектов печатных форм с привязкой к договору контрагента.

2 стартмани

08.06.2020    4891    4    andy_zhav    0    

Печать конвертов для УТ-11, КА-2 и ERP

Универсальные печатные формы v8 ERP2 УТ11 КА2 Абонемент ($m)

Печать конвертов для УТ-11, КА-2 и ERP реализована внешней обработкой - вызывается в качестве дополнительной обработки заполнения из справочников "Партнеры" и "Контрагенты". Протестировано для УТ-КА-ERP релизов 2.4.10 и 2.4.11 любых сборок. Обработку можно установить в справочник "Дополнительные отчеты и обработки".

1 стартмани

16.04.2020    4514    32    ab_initio    7    

Шаблон для разработки внешних печатных форм с возможностью тестирования и отладки программного кода, печати непроведенных документов и открытия формы обработки перед печатью (на примере печати Расходной накладной)

Универсальные печатные формы Печатные формы документов v8 УТ11 Россия УУ Абонемент ($m)

Внешняя печатная форма печати Расходной Накладной из документа "Реализация Товаров и Услуг" с возможностью тестирования и отладки программного кода, печати непроведенных документов и открытия формы обработки перед печатью . Обработка полезна программистам, можно использовать как шаблон для создания собственных внешних печатных форм с отладкой кода при разработке.

3 стартмани

26.02.2020    4276    2    putnikvp    3    

Печать штрихкода для любой конфигурации на платформе 8.3

Универсальные печатные формы v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Платформы младше 8.3.12.1313 использовали ActivX для печати ШтрихКода, сейчас технология изменилась. Эта обработка - замена старого механизма на новый.

1 стартмани

07.11.2019    22518    98    ah7777777    9    

Файл *.ODT в качестве шаблона для заполнения данными из базы

Универсальные печатные формы Внешние источники данных v8 1cv8.cf Абонемент ($m)

Вариант использования файла OpenOffice в качестве шаблона для своих целей, например как печатная форма, договоры и т.п. заполняя данными с базы 1С, любой конфигурации

1 стартмани

25.10.2019    6271    6    iones    2    

Вывод QR-кода типовыми средствами.

Универсальные печатные формы Сканер штрих-кода Универсальные функции v8 КА1 УТ10 УПП1 Абонемент ($m)

Вывод QR-кода типовыми средствами. На данный момент очень часто нужно вывести в печатную форму QR-код. Показываю как на примере типового кода из УТ11 это сделать. Можно использовать в любых конфигурациях с обычными формами.

1 стартмани

21.10.2019    38102    71    Емельянов Алексей    52    

Печать табличного документа через типовой механизм печати БСП (3.0) ОбщаяФорма.ПечатьДокументов

Универсальные печатные формы БСП (Библиотека стандартных подсистем) v8 1cv8.cf Россия Абонемент ($m)

Для чего нужна: у вас есть табличный документ и вы хотите его вывести точно так же ,как и выводите любую печатную форму, т.е. через форму "Печать документов. Обработка позволяет, используя штатные механизмы печати, выводить любой табличный документ, по такому же механизму.

1 стартмани

16.10.2019    12368    7    IncomeGroup    6    

Редактор-конструктор визиток

Универсальные печатные формы v8 Издательство, полиграфия, упаковка Абонемент ($m)

Интерактивный редактор-конструктор визиток / персональных карточек на основании макетов.

5 стартмани

16.06.2019    7042    5    eugenevk    6    

Подсистема справок (ЗУП 3.х)

Универсальные печатные формы Справки Зарплата Управление персоналом (HRM) Зарплата Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Подсистема справок внешней печатной формой для 1C: Зарплата и Управление Персоналом, редакция 3.х.

1 стартмани

25.04.2019    16897    25    🅵🅾️🆇    17    

Шаблон внешней печатной управляемой формы с возможностью передачи параметров из клиентской формы в стандартную общую форму печати документов

Универсальные печатные формы v8::УФ ERP2 Абонемент ($m)

Шаблон внешней печатной управляемой формы с возможностью передачи параметров из клиентской формы в стандартную общую форму печати документов (проверено на 1С:ERP Управление предприятием 2 (2.4.6.230)).

1 стартмани

14.04.2019    13518    27    user995537    4    

Формирование WORD документов на основании шаблонов

Универсальные печатные формы v8 1cv8.cf Абонемент ($m)

Очередное решение формирования word документов на основании шаблонов. Отличие данного решение, что 1с работает не напрямую с WORD, а через приложение, что увеличивает скорость работы.

4 стартмани

13.12.2018    9027    3    MaxxiMiliSan    2    

Вывод QR-кода типовыми средствами. Управляемое и обычное приложение

Универсальные печатные формы v8 v8::УФ 1cv8.cf Россия Абонемент ($m)

Печать QR кода с использованием лишь одной обработки. Подойдет как при разработке своей конфигурации, так и при использовании типовой. Тестировал на 1С: Реестр государственного и муниципального имущества, редакция 3.0 (3.0.2.9), 1С: УНФ 1.6.19.203

1 стартмани

12.12.2018    7595    16    user785225    2    

Шаблон внешней печатной формы (УФ) с формой для отладки

Универсальные печатные формы v8 v8::УФ 1cv8.cf Украина Абонемент ($m)

Шаблон внешней печатной формы (УФ) с формой для отладки, выводом макета на всех языках конфигурации.

1 стартмани

12.12.2018    8930    14    agressor    11    

Универсальный печатный шаблон WORD

Печатные формы документов Универсальные печатные формы v8::УФ 1cv8.cf Россия Абонемент ($m)

Было это в УПП 1.3, кадровики достали с печатками (здесь запятой не хватает, здесь ошибка и т.д.). Сделал обработку, научил. К сожалению,  эта обработка была глубоко интегрирована в УПП, поэтому простой перенос не подошёл. Поэтом перенес на УФ в расширение.

1 стартмани

13.08.2018    11954    14    SanyMaga    4    

Конструктор Word для типовой конфигурации 1C: Зарплата и управление персоналом 3.1.6

Универсальные печатные формы Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗКГУ3.0 ЗУП3.x Россия БУ Абонемент ($m)

Внешняя печатная форма Для создания Word документов практически для всех документов и даже белее. ЗиК 3.1.6, 3.1.7.

2 стартмани

09.06.2018    14553    43    nkp14108    13    

Печать непроведённых документов

Универсальные печатные формы Печатные формы документов Зарплата Зарплата v8 v8::СПР ЗКГУ3.0 ЗУП3.x Абонемент ($m)

Расширение добавляет возможность печатать любой документ, не проверяя его на проведённость.

1 стартмани

12.04.2018    12275    18    the1    8    

Пользовательские макеты для внешних печатных форм (обработок)

Практика программирования Универсальные печатные формы v8 v8::СКД 1cv8.cf Россия Абонемент ($m)

Расширение БСП по реализации механизма пользовательских макетов для обработок внешних печатных форм.

2 стартмани

05.03.2018    25161    28    simy4    15