Несколько табличных частей в документе в 1С 7

Публикация № 15672

Программирование - Работа с интерфейсом

29
Бывают случаи, когда необходимо, для удобства, подставить в 1 документ несколько табличных частей, но 7мерка не позволяет этого сделать. Но если нельзя, но очень хочется, то можно!
Также позволяет добавить любое количество закладок в документ автоматически.
Бывают случаи, когда необходимо, для удобства, подставить в 1 документ несколько табличных частей, но 7мерка не позволяет этого сделать. Суть в том, что все, необходимые нам табличные части, хранятся в специальном справочнике (довольно громоздко, но эффективно и быстро).
29

Скачать файлы

Наименование Файл Версия Размер
Закладки
.1206601787 58,50Kb
25.09.09
315
.1206601787 58,50Kb 315 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. limbo 28.03.08 22:53 Сейчас в теме
УдалитьСтроки<<?>>();
{\БУХ\TABL_DOCS.ERT(12)}: Процедура не обнаружена (УдалитьСтроки)
НоваяСтрока<<?>>();
{\БУХ\TABL_DOCS.ERT(17)}: Процедура не обнаружена (НоваяСтрока)
ВыбратьСтроки<<?>>();
{\БУХ\TABL_DOCS.ERT(30)}: Процедура не обнаружена (ВыбратьСтроки)
Пока ПолучитьСтроку<<?>>()=1 Цикл
{\БУХ\TABL_DOCS.ERT(31)}: Функция не обнаружена (ПолучитьСтроку)
Г=0<<?>>;
{\БУХ\TABL_DOCS.ERT(40)}: Ожидается ключевое слово 'Тогда' ('Then')
<<?>>КонецЕсли;
{\БУХ\TABL_DOCS.ERT(41)}: Ожидается ключевое слово 'КонецЦикла' ('EndDo')
<<?>>КонецЦикла;
{\БУХ\TABL_DOCS.ERT(51)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
КонецЦикла<<?>>;
{\БУХ\TABL_DOCS.ERT(51)}: Ожидается ключевое слово 'КонецПроцедуры' ('EndProcedure')
ТЗ.Сортировать("ЗначСорт");<<?>>
{\БУХ\TABL_DOCS.ERT(52)}: Обнаружено логическое завершение исходного текста модуля
2. ded00786 346 29.03.08 12:45 Сейчас в теме
Это не внешняя обработка, а просто алгоритм, его необходимо подставлять в модуль документа
3. Jenya78 02.04.08 15:13 Сейчас в теме
Автар я тоже экономист. Как варианты есть еще:
Первый вариант реализации через список значений. Второй вариант через таблицу значений и документ. :)
4. andyid 24.10.08 14:53 Сейчас в теме
Кто мог запустить эту обработку???:)))))))))))))))Там же инструкция!!!!
5. Abadonna 3824 24.10.08 14:58 Сейчас в теме
>но 7мерка не позволяет этого сделать
Вопрос решен лет сто назад. На проклабе, кажись, еще в году 2000-ом. И хранить лучше в документе с неопределенными реквизитами.
6. Abadonna 3824 24.10.08 15:00 Сейчас в теме
+(5) Почему именно в документе? Да потому, что там уже есть готовая табличная часть, ничего особенно и мудрить не надо.
12. lobodaeva 2 28.04.18 11:59 Сейчас в теме
(7) ссылка на миста недоступна
8. ded00786 346 27.10.08 11:27 Сейчас в теме
9. GenTay 12.01.13 22:58 Сейчас в теме
я реализовал, то что на форуме миста - работает!
13. lobodaeva 2 28.04.18 12:06 Сейчас в теме
(9)
поделитесь примером реализации?
15. Gkmy 24 30.04.18 19:35 Сейчас в теме
10. German_Tagil 6 10.09.17 12:47 Сейчас в теме
А кто реализовал подобное для 8.2
11. alxarz 29 11.09.17 03:11 Сейчас в теме
18. lobodaeva 2 02.05.18 09:43 Сейчас в теме
(14) у меня пишет страница "404 NOT FOUND"
16. Gkmy 24 02.05.18 08:44 Сейчас в теме
"2. Хранение дополнительной информации путем "сворачивания" данных в строку. Никаких плюсов метод не имеет. "
Имеет. Минимализм. "Не плоди сущностей сверх необходимого"
___
2. bulpi bulpi (bulpi) 126 01.05.18 11:52 // https://forum.infostart.ru/forum9/topic191695
17. Gkmy 24 02.05.18 08:48 Сейчас в теме
(16) имеет/не имеет - суждение спорное, к тому же не моё; и в зависимости от поставленной задачи имеет свои как плюсы, так и минусы
Оставьте свое сообщение