Печать фискального чека WebCheck для 1с7.7 ТиС, Бух

Публикация № 1581151 10.01.22

Бухгалтерский учет - Кассовые операции

обработка вебчек webchek

Доработанный пример обработки для печати фискального чека для 1с7.7 ТиС, Бух. Возможности обработки: Открытие кассовой смены (автоматически предлагается сделать служебный внос). Регистрация продаж. X-отчет. Z-отчет (перед закрытием смены проверяется сумма наличных, предлагается сделать служебный вынос). Проверить текущий статус фискального регистратора. Печать последнего чека, последнего Z-отчета.

Доработан пример обработки для 77, оригинальная обработка Вебчек

Проверялась на ТиС (7.70.013), Бух (7.70.286), платформа 7.70.027.

Обработку загрузить в конфигурацию с именем "ВебЧекПРРО".

Для вызова обработки можно добавить в пункт меню


Возможности обработки:

  • Открытие кассовой смены (автоматически предлагается сделать служебный внос)
  • Регистрация продаж (кнопка на форме документа, см. дальше)
  • X-отчет
  • Z-отчет (перед закрытием смены проверяется сумма наличных, предлагается сделать служебный вынос)
  • Проверить текущий статус фискального регистратора
  • Печать последнего чека, последнего Z-отчета.

 


Для работы в конфигурацию нужно добавить справочник "ФискальныеРегистраторы" с двумя реквизитами:
 - "ИДУстройства", Строка, 10
 - "ИдКассира", Строка, 10
В справочник "Пользователи" добавить реквизит "ФискальныйРегистратор", Тип "Спавочник.ФискальныеРегистраторы"
Пользователю, работающему с ФР заполнить данные.




В глобальный модуль добавить процедуры, вызываемые кнопкой на форме документов:
 

//======================================================================
Процедура глОтправитьДокументНаФискальныйРегистратор(Конт, ФискальныйНомер = "", СсылкаДФС = "") Экспорт
	
	СпПарам = СоздатьОбъект("СписокЗначений");
	СпПарам.ДобавитьЗначение(Конт.ТекущийДокумент(), "Документ");
	
	ОткрытьФормуМодально("Обработка.ВебЧекПРРО", СпПарам);
	
	Попытка
		// устанавливаю возвращенные значения
		Конт.ФискальныйНомерЧека = СпПарам.Получить("ФискальныйНомерЧека");
		Конт.ЧекСсылкаДФС 		= СпПарам.Получить("ЧекСсылкаДФС");
	Исключение
	КонецПопытки;
	
	
КонецПроцедуры // глОтправитьДокументНаФискальныйРегистратор

//======================================================================
Процедура глПечатьДокументаНаФР(Конт) Экспорт
	
	Если Конт = 0 Тогда
		Конт = СоздатьОбъект("Документ.РасходнаяНакладная");
	КонецЕсли;
	
	Если (Конт.ТекущийДокумент().Проведен() = 0) или (Конт.Модифицированность() = 1) Тогда
		Предупреждение("Документ должен быть записан и проведен", 10);
		Возврат;
	КонецЕсли;
	
	Если ПустаяСтрока(Конт.ФискальныйНомерЧека) = 0 Тогда
		Предупреждение("Документ уже зарегистрирован в ДФС", 10);
		Возврат;
	КонецЕсли;
	
	ФискальныйНомер = "";
	СсылкаДФС 		= "";
	
	глОтправитьДокументНаФискальныйРегистратор(Конт);
	
КонецПроцедуры // ПечатьДокументаНаФР

//======================================================================
Функция глДоступностьКнопкиЧекККМ(Конт) Экспорт
	
	Возврат Пользователь.ФискальныйРегистратор.Выбран() * Конт.Выбран() * (1 - Конт.Модифицированность());
	
КонецФункции // глДоступностьКнопкиЧекККМ

В конфигурации Бухгалтерия также добавить в глобальный модуль еще 2 функции:

 

// ===============================
Функция глЕстьРеквизитШапки(ИмяРеквизита, ВидДокумента) Экспорт
	Перем Реквизит;
	Если (ПустоеЗначение(ВидДокумента) = 1) ИЛИ
	     (ПустоеЗначение(ИмяРеквизита) = 1) Тогда
		Возврат Нет;
	КонецЕсли;
	Реквизит=Метаданные.Документ(ВидДокумента).РеквизитШапки(ИмяРеквизита);
	Возврат ?(Реквизит.Выбран()=1, Да, Нет );
КонецФункции

// ===============================
Функция глЕстьРеквизитМнЧ(ИмяРеквизита,ВидДокумента) Экспорт
	Перем Реквизит;    // 
	Если (ПустоеЗначение(ВидДокумента) = 1) ИЛИ
	     (ПустоеЗначение(ИмяРеквизита) = 1) Тогда
		Возврат Нет;
	КонецЕсли;
	Реквизит=Метаданные.Документ(ВидДокумента).РеквизитТабличнойЧасти(ИмяРеквизита);
	Возврат ?(Реквизит.Выбран()=1, Да, Нет );
КонецФункции

В документы РасходнаяНакладная, ПриходнаяНакладная (для бухгалтерии - ВозвратнаяНакладная) добавить реквизиты шапки:
 - "ЧекСсылкаДФС" - "Строка", 256
 - "ФискальныйНомерЧека" - Строка, 20

При желании вывести реквизиты на форму документа, запретить редактирование

Для печати фискального чека на формы документов РасходнаяНакладная, ПриходнаяНакладная (для бухгалтерии - ВозвратнаяНакладная) добавить кнопку с именем "кнЧекККМ" и формулой "глПечатьДокументаНаФР(Контекст)". 




 

По нажатию кнопки происходит фискализация чека на портале ДФС.



 

В функцию "УстДоступность" модуля формы документов добавить строку (кнопка будет доступна тем пользователям, у которых выбран ФискальныйРегистратор в справочнике "Пользователи", см. выше):
 

Форма.кнЧекККМ.Доступность(глДоступностьКнопкиЧекККМ(Контекст));


Установить, настроить сервер webchek, можно работать.

По результатам тестирования: Сервис Webchek показал более стабильную работу по сравнению с другими (Кашалот, чекбокс, Вчасно.каса). Простая интеграция, простая настройка сервера webchek, быстрая реакция техподдержки по любым вопросам.

На момент написания публикации обработка проработала на указанных конфигурациях порядка двух недель, проблем пока не выявлено.

Скачать файлы

Наименование Файл Версия Размер
Обработка печати фискального чека WebCheck для 1с77 ТиС, Бух:

.ert 44,50Kb
3
.ert 44,50Kb 3 Скачать

Специальные предложения

Оставьте свое сообщение

См. также

Карточка с QR кодом для ввода e-mail при расчете на кассе

Кассовые операции ККМ v7.7 1cv7.md Россия Абонемент ($m)

Ввод электронной почты покупателя сканированием QR кода.

1 стартмани

21.03.2022    1398    1    M_W_W    5    

Обработка печати чеков для кассы Штрих Онлайн (1С 7.7 Торговля и Склад)

Кассовые операции Розничная торговля ККМ v7.7 1С7:ТиС БУ УУ Абонемент ($m)

Обработка позволяет печатать чеки для кассы Штрих Online из 1С 7.7 (Торговля и склад). Есть возможность печать чеков из разных касс. Также можно подставить функционал в любую конфигурацию.

1 стартмани

18.02.2021    5822    4    Drfreeman    9    

Выгрузка товаров из 1С:Предприятия 7.7 "Торговля и Склад 9.2" в файл CSV для онлайн кассы МТС

Кассовые операции Оптовая торговля Розничная торговля Загрузка и выгрузка в Excel v77::ОУ 1С7:ТиС БУ УУ Абонемент ($m)

Данная обработка предназначена для выгрузки файла из программы 1С: Предприятие 7.7 Конфигурации «Торговля и Склад 9.2» в файл CSV для загрузки в кассу МТС. Тестирование проводилось на релизах 937 и 998. В теории должна работать на всех типовых релизах конфигурации «Торговля и Склад 9.2».

1 стартмани

07.02.2021    5651    3    Kuzya_brаtsk    1    

Загрузка товаров в ККТ "Меркурий" из 1С:Торговля и склад 9.2

Кассовые операции Розничная торговля ККМ v77::ОУ 1С7:ТиС Розничная и сетевая торговля (FMCG) Россия БУ УУ Абонемент ($m)

Обработка для загрузки базы кодов цен в ККТ "Меркурий" с помощью программы-конфигуратора MercConfig из базы Торговля и склад 9.2 1С: Предприятие 7.7.

1 стартмани

25.01.2021    5495    1    aleksandr_leiman    0    

Взаимодействие с ТАКСКОМ API 2.8 из 1с7.7

WEB Кассовые операции Розничная торговля v7.7 1cv7.md Россия УУ Абонемент ($m)

Взаимодействие с ТАКСКОМ через API 2.8 из 1с7.7. Получение Кассовых смен.

2 стартмани

06.10.2020    5528    5    serpent    0    

Выставление счета ссылкой на оплату через платежный шлюз Сбербанка из интерфейса 1С

Банковские операции Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 1cv8.cf 1cv7.md Россия Абонемент ($m)

Внешняя обработка для выбора документа и формирования ссылки на оплату, которую можно скопировать в буфер обмена и отправить любыми средствами. Решение позволяет повысить автоматизацию процесса выставления счетов на оплату через интерфейс 1С8.х, 1С7.7. Совместимо с интернет-эквайрингом Сбербанк.

1 стартмани

14.01.2020    30833    145    etmarket    63    

Обработка для ККТ Атол 10.Х

ККМ Кассовые операции v77::ОУ 1С7:ТиС Оптовая торговля, дистрибуция, логистика Россия БУ Абонемент ($m)

Обработка обслуживания ККТ Атол версии 10.Х в среде 1С 7.7 в ТиС релиз 7.70.998

10 стартмани

24.07.2019    8285    5    _s_y_a_    2    

1С 7.7: Обработка для печати чеков на ККМ ШТРИХ формата ФДД 1.05

ККМ Кассовые операции Розничная торговля v7.7 1cv7.md Россия БУ Абонемент ($m)

Обработка позволяет печатать чеки формата ФДД 1.05 на кассовом аппарате ШТРИХ. Проверялась на версиях драйвера 4.14.721 - 749.

1 стартмани

03.04.2019    11107    11    user872794    1    

Штрих-М Онлайн-кассы для 1С 7.7 для новых прошивок с НДС20%

ККМ Кассовые операции v77::ОУ 1С7:ТиС Россия НДС Абонемент ($m)

Обработка работает с новыми прошивками касс Штрих-М с НДС20%.

1 стартмани

20.02.2019    12130    26    fugitiveLDN    9    

Обработка обслуживания торгового оборудования. 1С: 7.7 ТиС

ККМ Кассовые операции v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработка обслуживания для 1с 7.7 ТиС. Версия драйвера ККТ Атол 8.16.5.9221 Обработка предназначена для корректной передачи СНО при пробитии чека.

1 стартмани

18.01.2019    17527    31    artmaks1988    49    

1С 7.7 ARCUS2 Эквайринговые Терминалы Ingenico (iPP320, iCT250 и т.п.)

POS терминал Кассовые операции Розничная торговля v7.7 1cv7.md Россия Абонемент ($m)

Использование внешней компоненты для терминалов Ingenico в 1С 7.7. Демо-база с функциями в глобальном модуле и обработкой, демонстрирующей возможности работы с терминалом. Глобальная функция управления терминалом подходит для любой базы данных, предназначенной для расчетов с клиентами. Тестировалась на конфигурациях: Торговля и склад 7.7, Бухгалтерия 7.7 и Упрощенное налогообложение 7.7.

1 стартмани

28.11.2018    15263    58    e-rogov    20    

Работа с пробитыми чеками по БД Атол

Разработка внешних компонент Кассовые операции ККМ v7.7 1cv7.md Абонемент ($m)

Получение данных о пробитых чеках по ККМ Атол драйверов версии 8 на ОФД СБИС.

1 стартмани

13.07.2018    13161    1    pakko    7    

Поддержка Онлайн ККМ АТОЛ. Доработка ТиС 7.7 (Бюджетное решение) v 1.0

Кассовые операции ККМ v77::ОУ 1С7:ТиС Россия УУ Абонемент ($m)

Релиз ТиС 7.70.987. Комплекс позволяет быстро и бюджетно подключить клиенту печать чеков на технике АТОЛ: АТОЛ 30Ф, АТОЛ 55Ф, АТОЛ 22Ф, АТОЛ 52Ф, АТОЛ 11Ф, АТОЛ 90Ф.

1 стартмани

09.07.2018    14643    18    zoeh    9    

Работа 1С: 7.7 с ККТ АТОЛ ДТО10 (JSON задания)

ККМ Кассовые операции Розничная торговля v7.7 v77::ОУ 1cv7.md Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Пробитие чеков через web сервер (JSON задания) ДТО10 АТОЛ.

1 стартмани

03.07.2018    20447    53    rasta.ayaks    8    

54-ФЗ/Онлайн-кассы: Работа с фискальным регистратором на 1С: 7.7

Кассовые операции Розничная торговля ККМ v7.7 Абонемент ($m)

Конфигурация содержит минимальный функционал для работы с фискальными регистраторами на платформе 1С: 7.7. Если у Вас нет учетной системы, но необходимо соответствовать 54-ФЗ, с минимальными затратами, то эта конфигурация для Вас. Код полностью открыт и распространяется как есть.

10 стартмани

09.06.2018    12309    1    Atom74    0    

Загрузка в 1С 7.7 УСН 1.3 и БУХ 4.5 и Предприниматель 1.2 данных из ОФД о денежных поступлениях (чеках)

Обработка документов Загрузка и выгрузка в Excel Кассовые операции v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

Если Ваша торговая точка (ККМ) отделена от 1С 7.7 УСН, а вносить поступление наличных за день в 1С:Бухгалтерию надо, то автоматизировать процесс оформления наличных в 1С:Бухгалтерию можно!

2 стартмани

02.12.2017    16930    9    AlexHelmer    2    

Групповая печать ПКО и РКО для 1С:Бухгалтерии 7.7

Пакетная печать Кассовые операции Печатные формы v77::БУ 1С7:Бух БУ Абонемент ($m)

Обработка групповой печати ПКО и РКО в 7.7 (2 шт. на одном листе).

1 стартмани

08.11.2017    13650    4    Юлия69    0    

Формирование документов реализации из ККМ "ЭВОТОР"

Обработка документов ККМ Кассовые операции Розничная торговля Склад и ТМЦ v77::ОУ v77::БУ 1С7:Бух 1С7:ТиС Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Обработка для получения печатной формы отчета о продажах и документов реализации из онлайн-кассы "ЭВОТОР"

8 стартмани

04.10.2017    18512    0    Юстас    0    

Оболочка для работы с последними драйверами ККМ АТОЛ для 1С 7.7, 8.1

Разработка внешних компонент ККМ Кассовые операции v77::ОУ 1С7:ТиС Абонемент ($m)

Внешняя компонента - оболочка для работы в среде 1С 7.7 или 1С 8.1 с последними версиями драйверов ККМ от АТОЛ. Поддерживаются драйвера x32 начиная с версии 9.11. Присутствует внешняя обработка для полноценной работы с данными драйверами (поддержка ревизий 2.0, 2.1, 2.2, поддержка протокола ОФД 1.0, 1.0.5, 1.1).

1 стартмани

09.08.2017    48678    336    asdfghgghjdhg    127    

54-ФЗ: Онлайн-касса (кассы). 1С 7.7 + Атол 55Ф ДТО8/10

ККМ Кассовые операции v7.7 1cv7.md БУ Абонемент ($m)

Обработка ККМ-онлайн для нетиповой 1С:7.7 с печатью на несколько касс. Поддержка тегов 1227,1228. Поддержка версий драйверов ККТ: ДТО8, ДТО10 для Атол. Исходный код открыт.

2 стартмани

23.06.2017    26777    51    vakham    11    

Обработка подключения онлайн-кассы к 1С 7.7 (ПОЛУФАБРИКАТ)

ККМ Кассовые операции v7.7 1С7:Бух Россия БУ Абонемент ($m)

Обработка обслуживания торгового оборудования для печати чеков ККМ. Протестирована на Конфигурации бухгалтерский учет (7.70.634) с кассой АТОЛ 30 Ф, Печать ПКО и РКО. Также работает на Торговля + Склад.

2 стартмани

31.05.2017    45283    112    Di_Denis    47    

Пример кода 1С 7.7 для ККТ "Атол" под 54-ФЗ (онлайн касса)

ККМ Кассовые операции Розничная торговля v7.7 1cv7.md Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Пример кода 1С 7.7 для ККТ "Атол" под 54-ФЗ (онлайн касса).

1 стартмани

29.05.2017    23871    77    Vitaly    5    

Подключение Онлайн кассы Штрих М к 1С 7.7

Разработка внешних компонент ККМ Кассовые операции Розничная торговля v7.7 1cv7.md Абонемент ($m)

Подключение онлайн кассы Штрих М к любой конфигурации 1С 7.7. Показаны основные приемы работы с драйвером. Обработка представляет из себя набор готовых функций для встраивания в свою конфигурацию: ИнициализироватьФР(); ПодключитьФР(); ОтключитьФР(); ОткрытьСмену(); ЗакрытьСмену(); НапечататьЧек(); АннулироватьЧек(); СнятьХОтчет().

1 стартмани

08.05.2017    30064    81    crimeait    2    

Обработка обслуживания для ККТ ШтрихОнлайн, 1С:7.7

Кассовые операции Розничная торговля ККМ v7.7 1С7:Бух 1С7:Комплекс 1С7:ТиС Россия Абонемент ($m)

Данная обработка содержит основные команды для работы с ККТ Штрих онлайн

10 стартмани

22.02.2017    38797    52    AlexY    17    

Печать штрих-кодов из 1С: 7.7 Комплексная конфигурация

Рабочее место Кассовые операции Печатные формы v7.7 1С7:Комплекс 1С7:ТиС Абонемент ($m)

Для тех кто работает на 7 платформе, и не собирается с неё переходить. Стандартная печать этикеток по одной шт за раз совсем даже не интересна. Мне при внедрении штрих кодирования мне помогла обработка

1 стартмани

21.06.2016    29767    8    agent00mouse    7    

Рабочее место кассира

Рабочее место Кассовые операции Розничная торговля v77::ОУ 1С7:ТиС Розничная и сетевая торговля (FMCG) Россия Абонемент ($m)

Уникальная внешняя обработка "Рабочее место кассира" для конфигурации Торговля и склад.

3 стартмани

16.09.2015    19487    17    PitMal    3    

Обработка для 1С ТиС 9.2 для работы с ККМ Offline под РМК Штрих-М Кассир 1.*\2.*\5.*

ККМ Кассовые операции Розничная торговля v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработки предназначены для 1С: Предприятие 7.7 типовой конфигурации Торговля и Склад 9.2. Сделано несколько существенных изменений по отношению к стандартной обработке Off_spos. И доработана обработка "Загрузка ККМ Off-Line".

1 стартмани

28.08.2015    33432    35        4    

Подключение фискального регистратора MG N707TS, MG-T777TL, MG-T787TL по http (TCP/IP) протоколу JSON

Кассовые операции Розничная торговля ККМ v7.7 v8 1cv8.cf 1cv7.md Украина Абонемент ($m)

Тестовая конфигурация и пример работы по общению с фискальным регистратором MG N707TS, MG-T787TL, MG-T777TL по HTTP протоколу командами в формате JSON. Обратите внимание, что аппарат может работать и классическим методом по RS232 - подробнее тут http://infostart.ru/public/317286/, но производитель уделяет больше внимания протоколу HTTP JSON (TCP/IP) Добавили еще обработку по работе с кассовым аппаратом MG-V545T по схожему принципу детальнее ... http://infostart.ru/public/530619/ Добавил обработку обслуживания для подключения торгового оборудования. Огромное спасибо ВСЕМ КТО ПОМОГ , участвовал в создании этой обработки.

1 стартмани

09.07.2015    50600    120    mar_a    31    

Обработка для регламентных работ с ФР MG-T808TL

Кассовые операции ККМ v7.7 1cv7.md Украина Абонемент ($m)

Обработка для выполнения регламентных операций с фискальным регистратором MG-T808TL

1 стартмани

01.07.2015    14913    1    maxy3d    2    

Изменение банковского счета в документах - 1С Бухгалтерия 7.7

Обработка документов Банковские операции Кассовые операции v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

Иногда случается, что в справочнике дублируются записи. Это легко поправимо, если дублирующая запись не была использована в документах. В противном случае надо вручную выбирать во всех документах нужный элемент. А если количество документов тысячи - уйдет уйма времени... Данная обработка решает эту проблему! Просто выбрать старый счет (который планируем заменить) и новый (на который заменяем). Полезно.

1 стартмани

02.04.2015    12284    0    program345    9    

Печать чеков на Штрих-М-ФР-К в RDP (Удаленные филиалы)

Печатные формы Кассовые операции ККМ v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Печать на Штрих-М-ФР-К через "Удаленный рабочий стол" RDP в филиалах. При печати через RDP в филиалах столкнулись с проблемой медленной печати и подключение Фискальных регистраторов к 1С. Эта обработка автоматически находит к какому порту подключен ФР и подключает его со всеми установленными настройками.

1 стартмани

28.02.2014    36193    62    Ronin    5    

Внешняя компонента для работы с ККМ Искра "Прим-07К"

Кассовые операции ККМ v7.7 1cv7.md БУ Абонемент ($m)

Бесплатная внешняя компонента для 1С7.7, позволяющая работать с фискальными регистраторами производства Искра, такими как ПРИМ-07К, ПРИМ-08ТК и пр.

1 стартмани

18.06.2013    26406    64    sandyanf    3    

Обработка автоматической разноски денег по Кассе\Банку для сетевых (и не только) контрагентов для ТиС 7.7

Обработка документов Банковские операции Кассовые операции Рабочее место v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Обработка позволяет в несколько кликов разнести деньги (касса или банковская выписка) по контрагенту, папке контрагентов либо по сетевому контрагенту (анализ по ИНН). Предварительно формируется список долговых документов с указанием суммы долга.

1 стартмани

11.06.2013    14008    20    iDim    2    

Перенумерация Расходных Ордеров

Кассовые операции Обработка документов v7.7 1cv7.md Россия Абонемент ($m)

Перенумерует РКО.

1 стартмани

22.10.2012    6301    21    BloodElf    4    

Перенумерация Приходных Ордеров

Обработка документов Кассовые операции v7.7 1cv7.md Россия БУ Абонемент ($m)

Перенумерует все приходных ордера.

1 стартмани

22.10.2012    6203    18    BloodElf    1    

Универсальный групповой приход по кассе

Обработка документов Кассовые операции v77::БУ 1С7:Бух Россия БУ Абонемент ($m)

Данная обработка создана для облегчения ввода документа Приходный кассовый ордер (УСН и Бухгалтерия 7.7.)

1 стартмани

01.09.2012    11157    11    malev    4    

Печать идентификационного знака контрольно-кассовой техники для ЦТО

ККМ Кассовые операции v7.7 1cv7.md Россия Абонемент ($m)

Печать идентификационного знака контрольно-кассовой техники для ЦТО.

1 стартмани

02.08.2012    20084    29    ta-so    6    

Печать РКО и ПКО за период

Печатные формы Кассовые операции Пакетная печать v77::БУ 1С7:Бух 1С7:Комплекс Россия БУ Абонемент ($m)

Пакетная печать приходных и расходных кассовых ордеров за период. Возможность отправить документы на просмотр или сразу на печать

1 стартмани

25.04.2012    10190    38    Leannet    7    

Перенумератор кассовых ордеров

Обработка документов Кассовые операции v77::БУ 1С7:Бух Россия Абонемент ($m)

Перенумерация кассовых ордеров

1 стартмани

06.04.2012    3523    21    toshibav    3