INFOSTART EVENT 2018 EDUCATION

Второй тур голосования за доклады.
Окончание 5 сентября.

Коробов Алексей | Генеральный директор | ООО "Корус Баланс"

«Управление бизнес-процессами предприятия и организация работы сотрудников»

Общие вопросы * Проблемы при автоматизации бизнес-процессов. * Проблемы при эксплуатации бизнес-процессов. * Человеческий фактор или может ли лень стать стимулом для внедрения и развития системы управления. * Как охватить весь спектр проблем предприятия и не захлебнуться. Взгляд на проблему со стороны разработчиков * Проблемы разработчиков при эксплуатации сложных гибко настраиваемых систем. Разработка в режиме предприятия? Возможно? Зачем? * Коллективная разработка ключ к развитию. * Проблемы оптимизации и скорости работы при универсальном подходе разработки. Программа автоматизации как живой организм. Сколько сил нужно чтобы вдохнуть в него жизнь? * Общее описание получившейся системы и взаимодействия ее подсистем. Описание потенциала подобных систем. Будут озвучены проблемы и вопросы автоматизации бизнес-процессов предприятия по каждому из тезисов, с которыми пришлось столкнуться на личном опыте. Описаны удачные способы решения или обходы проблем, примененные у клиентов.

Cпецификация на товар к договору с контрагентом - Бухгалтерия предприятия 3.0

Печать - Печатные формы документов

21
Внешняя печатная форма спецификации на товар к договору с контрагентом для документа Счет на оплату покупателю для Бухгалтерии предприятия 3.0.

Содержит возможность регистрации или обновления в справочнике "Дополнительные отчеты и обработки". 
Для регистрации/обновления печатной формы в справочнике открыть обработку в режиме предприятия (Меню "Файл"), по завершении процесса при необходимости указать нужную группу.

Заполнение выходной формы
При формировании печатной формы используются следующие реквизиты:

  1. Номер, дата, наименование элемента договора, указанного в документе. 
  2. Реквизиты поставщика выбираются из организации документа. 
     

Практическое применение вряд ли найдёт, разработана как пример обработки с авторегистрацией и формой для отладки печати в не зависимости от используемого в конфигурации релиза БСП (Библиотеки стандартных подсистем).

 

Вторая обработка демонстрирует открытие формы и выбор значений для передачи в процедуру Печать() модуля обработки. Подробнее смотрите Передача параметров/значений во внешнюю печатную форму для конфигураций на БСП

После вывода сообщения об успешной регистрации в пункте меню «Печать» формы документа появляется команда «Спецификация и цена товара к договору с покупателем (с выбором представителя заказчика)».

Заполнение выходной формы
При формировании печатной формы используются следующие реквизиты:
Номер, дата, наименование элемента договора, указанного в документе.
Реквизиты поставщика выбираются из организации документа.
Фамилия, имя, отчество и должность представителя покупателя выбираются в форме перед печатью документа.

21

Скачать файлы

Наименование Файл Версия Размер
СпецификацияНаТоварБП30_82.epf
.epf 24,66Kb
09.09.17
111
.epf 1.0.6 24,66Kb 111 Скачать
СпецификацияНаТоварБП30_82 - с диалогом выбора.epf
.epf 25,70Kb
09.09.17
142
.epf 25,70Kb 142 Скачать

См. также

Комментарии
Сортировка: Древо
1. Roby 30 18.06.14 09:54 Сейчас в теме
СпецификацияНаТоварБП30_82 - с диалогом выбора.epf
Пишет "Печатная форма недоступна"
2. Поручик 4113 18.06.14 12:30 Сейчас в теме
(1) У вас не заполнена табличная часть Товары. В любом случае спасибо, что напомнили. В БСП 2.2.3 поменялись некоторые процедуры для печати.
3. Divanoff 21 10.05.17 15:40 Сейчас в теме
По вашему образцу делаю для ЗУП 3.1.2.213 КОРП внешнюю обработку.
Вылезает сообщение:

Поле объекта не обнаружено (ДополнительнаяОбработкаСсылка)

Что это может быть?

&НаКлиенте
Процедура ВыполнитьОткрытиеПечатнойФормы(Команда)
	
	ВыполняемаяКоманда = Параметры;
	
	СтандартнаяОбработка = Истина;
	
	//Определение и заполнение штатных параметров для общей формы ПечатьДокументов
	ПараметрыОткрытия = Новый Структура("ИсточникДанных, ПараметрыИсточника");
	ПараметрыОткрытия.ИсточникДанных     = ВыполняемаяКоманда.ДополнительнаяОбработкаСсылка;
	ПараметрыОткрытия.ПараметрыИсточника = Новый Структура("ИдентификаторКоманды, ОбъектыНазначения");
	ПараметрыОткрытия.ПараметрыИсточника.ИдентификаторКоманды = ВыполняемаяКоманда.ИдентификаторКоманды;
	
	//Здесь передаём наши значения в модуль обработки.
	//Структура для передачи параметров или значений в процедуру Печать обработки
	//В процедуре печати она будет доступна в качестве первого элемента массива МассивОбъектовНазначения
	ДополнительныеПараметры = Новый Структура();
	//Значения для передачи
	МассивСотрудников = Новый Массив;
	Для каждого Стр Из Элементы.Сотрудники.ВыделенныеСтроки Цикл
		МассивСотрудников.Добавить(Сотрудники[Стр].Сотрудник);		
	КонецЦикла; 
	ДополнительныеПараметры.Вставить("МассивСотрудников", МассивСотрудников);	
	
	//Еще какие-то значения
	//ДополнительныеПараметры.Вставить("РеквизитФормы1", РеквизитФормы1); 
	//ДополнительныеПараметры.Вставить("РеквизитФормы2", РеквизитФормы2); 
	
	//В массиве ОбъектыНазначения будут содержаться ссылки на вызвавший форму объект (документ, справочник)
	// и наши значения из реквизитов формы или обработки
	ОбъектыНазначения = Новый СписокЗначений;
	ОбъектыНазначения.Добавить(ДополнительныеПараметры);
	
	//Ссылки на вызвавшие форму объекты
	Для каждого ОбъектНазначения Из ВыполняемаяКоманда.ОбъектыНазначения Цикл
		ОбъектыНазначения.Добавить(ОбъектНазначения);
	КонецЦикла; //Для каждого ОбъектНазначения Из   
	ПараметрыОткрытия.ПараметрыИсточника.ОбъектыНазначения = ОбъектыНазначения;
	
	//Вывод сформированного табличного документа в штатную форму.
	ОткрытьФорму("ОбщаяФорма.ПечатьДокументов", ПараметрыОткрытия);	
	
КонецПроцедуры

Показать
4. Divanoff 21 10.05.17 15:41 Сейчас в теме
И объекты назначения по-новому передаются, пока не понял как.
6. Поручик 4113 10.05.17 22:53 Сейчас в теме
(4) Не знаю, что там в ЗУП, но в БП 3.0 последних релизов версия БСП 2.3.5., то есть подсистема печати практически та же, что и год назад. И передача объектов назначения не изменилась.
5. Поручик 4113 10.05.17 16:35 Сейчас в теме
И никто не хочет говорить используемую версию БСП в ЗУПе.
7. user816558 19.06.18 15:41 Сейчас в теме
Для "Зарплата и управление персоналом, редакция 3.1 (3.1.6.6)"
БСП -2.4.6.12
Оставьте свое сообщение