Процедура-плагин: Выгрузка в Йоксель для Новейшего отчета 7.7

Публикация № 18398

Разработка - Разработка внешних компонент

Процедура дополняет Новейший отчет 7.7 с возможностью выгрузки созданного отчета в Йоксель (Excel) с группировками по строкам.

Одна из самых лучших систем отчетов Новейший Отчет 7.7 не имеет возможности выгрузки в Йоксель, в результате этого, после сохранения отчета в Excel группировки теряются. Приведенная процедура исправляет это досадное упущение.

Работает и с Демо-версией и с Коммерческой версией Новейшего отчета (если у Вас полная версия Новейшего отчета процедуру можно добавить непосредственно в NR_Navigator.ert).

Для работы требует Внешниюю компоненту:  Йоксель. (домашняя страница автора: http://yoksel.net.ru).

Порядок внедрения: процедуру добавляем в Глобальный модуль 1С, во внешнюю обработку Новейшего отчета NR_Navigator.ert добавляем кнопку Йоксель с формулой глВыгрузитьНовейшийОтчетВЙоксель(Таб)

Обновление от 19/12/08: не определялись группировки в кросс-таблицах.


Процедура глВыгрузитьНовейшийОтчетВЙоксель(Таб) Экспорт
	Перем Документ;
Перем ТЗ;
Перем Область;

Попытка
Документ = СоздатьОбъект ("ТабличныйДокумент");
Исключение
Если ЗагрузитьВнешнююКомпоненту("SpreadSheet.dll")=0 Тогда
Сообщить("Не удалось загрузить ВК Йоксель! Выгрузка невозможна.");
Возврат;
Иначе
Документ = СоздатьОбъект ("ТабличныйДокумент");
КонецЕсли;
КонецПопытки;


Документ.ЗагрузитьИзТаблицы(Таб);

ТЗ=СоздатьОбъект("ТаблицаЗначений");
ТЗ.НоваяКолонка("Уровень");
ТЗ.НоваяКолонка("Начало");
ТЗ.НоваяКолонка("Конец");

НачалоТаблицы=1;
ВысотаТаблицы=Документ.ВысотаТаблицы();

// Определяем начало группировок
Для СтрИнд=НачалоТаблицы По ВысотаТаблицы Цикл
Область=Документ.Область(СтрИнд,1);
Если Область.Текст="1" Тогда
НачалоТаблицы=СтрИнд;
Прервать;
КонецЕсли;
КонецЦикла;

Если НачалоТаблицы>1 Тогда
// Загоняем все начала группировок в ТЗ
Для СтрИнд=НачалоТаблицы По ВысотаТаблицы Цикл
Для КолИнд=2 По 8 Цикл
Область=Документ.Область(СтрИнд,КолИнд);
Если (Область.Текст="-") Тогда
ТЗ.НоваяСтрока();
ТЗ.Уровень = КолИнд-1;
ТЗ.Начало = СтрИнд;
ТЗ.Конец = 0;
Прервать;
ИначеЕсли ПустоеЗначение(Документ.Область(СтрИнд,КолИнд).Текст)=0 Тогда
Если ПустоеЗначение(Документ.Область(СтрИнд-1,КолИнд).Текст)=1 Тогда
Если ПустоеЗначение(Документ.Область(СтрИнд-1,КолИнд+1).Текст)=0 Тогда
ТЗ.Конец = СтрИнд-1;
Прервать;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;
Если ПустоеЗначение(Документ.Область(СтрИнд,1).Текст)=1 Тогда
ТЗ.НоваяСтрока();
ТЗ.Уровень = 1;
ТЗ.Начало = СтрИнд;
ТЗ.Конец = 0;
Прервать;
КонецЕсли;
КонецЦикла;

// Определяем окончания группировок
КолВоСтрок=ТЗ.КоличествоСтрок();
Для инд1=1 По КолВоСтрок-1 Цикл
Уровень=ТЗ.ПолучитьЗначение(инд1,"Уровень");
Если ТЗ.ПолучитьЗначение(инд1,"Конец")=0 Тогда
Для инд2=(инд1+1) По КолВоСтрок Цикл
Если Уровень>=ТЗ.ПолучитьЗначение(инд2,"Уровень") Тогда
ТЗ.УстановитьЗначение(инд1,"Конец",ТЗ.ПолучитьЗначение(инд2,"Начало")-1);
Прервать;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЦикла;
ТЗ.УдалитьСтроку(КолВоСтрок);

// Устанавливаем группировки строк в Йокселе
ТЗ.ВыбратьСтроки ();
Пока ТЗ.ПолучитьСтроку() = 1 Цикл
Документ.ДобавитьГруппуСтрок(ТЗ.Начало+1,ТЗ.Конец);
КонецЦикла;

// Свертка всех группировок Йоксель
Для инд = -Документ.КоличествоУровнейГруппировкиСтрок() По -1 Цикл
Документ.ПоказатьУровеньГруппировокСтрок (-инд);
КонецЦикла;

КонецЕсли;

// Без СокрЛП Йоксель не распознает цифры
Для инд1=1 По Документ.ВысотаТаблицы() Цикл
Для инд2=1 По Документ.ШиринаТаблицы() Цикл
Область=Документ.Область(инд1,инд2);
Область.Текст=СокрЛП(Область.Текст);
КонецЦикла;
КонецЦикла;

Документ.Область().Расшифровка(,2);

Фрейм=Документ.Показать(Документ.Область(1,2).Текст);
Фрейм.ОтображатьСтруктуру(1);
Фрейм.ОтображатьКнопкиУровней(1);

КонецПроцедуры

 

Скачать файлы

Наименование Файл Версия Размер
Процедура для добавления в Глобальный модуль 1С

.1228827140 6,87Kb
31.12.14
134
.1228827140 6,87Kb 134 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. АЛьФ 09.12.08 16:36 Сейчас в теме
2. support 4520 09.12.08 16:42 Сейчас в теме
Вот это новость, неожиданно!
Прикольно!
3. JohnyDeath 299 09.12.08 17:12 Сейчас в теме
(1,2) Даёшь полные версии Новейшего отчета Ужасту и Djelf!
4. CheBurator 09.12.08 17:38 Сейчас в теме
5. support 4520 09.12.08 18:01 Сейчас в теме
6. Djelf 242 09.12.08 18:18 Сейчас в теме
Есть, спасибо. Я про "Таб" иначе наверное не догадался бы ;)
7. alexandrlevitsky 11.12.08 18:34 Сейчас в теме
Полезная вещица.
Только просьба быть более толерантным к пользователям, которые ищут выгрузку в Excel, а не "Йоксель". Ну это так, вредничаю))
8. Djelf 242 11.12.08 22:12 Сейчас в теме
Да нет, все логично, Йоксель действительно пока еще не настолько популярен, чтоб его каждый знал. Добавил в заголовок "(Excel)" ;)
9. serpent 56 15.12.08 11:49 Сейчас в теме
Спасибо...
Ждем внедрения в основную поставку.
10. astvit15 07.10.11 16:30 Сейчас в теме
20. ARTEM123456 05.03.12 08:25 Сейчас в теме
21. ARTEM123456 05.03.12 08:26 Сейчас в теме
Оставьте свое сообщение

См. также

Использование сборок .NET в 1С 7. и 8.x. Создание внешних Компонент. Промо

Разработка внешних компонент v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Данная разработка создана для использования сборок .Net в 1С через преобразование объектов и классов в COM-объекты, которые можно использовать в 1С. Достигается это путем создания класса, реализующего методы интерфейса IReflect public class AutoWrap: IReflect.

1 стартмани

28.11.2013    83236    237    Serginio    71    

Криптография: внешняя компонента для 1С 7.7

Разработка внешних компонент Защита и шифрование v7.7 Абонемент ($m)

Цифровые подписи, шифрование, просмотр сертификатов ключей ЭЦП, работа с различными криптопровайдерами (в т.ч. КриптоПРО ГОСТ 2012) в 1С 7.7.

1 стартмани

08.06.2020    1795    4    mdbruyfn    5    

Протокол UDP: внешняя компонента для 1С 7.7

Разработка внешних компонент v7.7 Абонемент ($m)

Обмен сообщениями и небольшими файлами по протоколу UDP с 1С и внешними приложениями в локальной сети или сети VPN.

1 стартмани

23.05.2020    1529    0    mdbruyfn    0    

Загрузка данных из файла XLS в Штрих-М Торговое предприятие 4.17.01

Розничная торговля Загрузка и выгрузка в Excel v7.7 1cv7.md Розничная и сетевая торговля (FMCG) Россия БУ Абонемент ($m)

Заполнение справочника номенклатуры и документа приходной накладной. Будет полезно для товароведов или менеджеров.

5 стартмани

20.02.2020    3407    0    Ignatov_mu    0    

Компоненты распознавания и печати штрих-кодов Промо

Разработка внешних компонент Сканер штрих-кода v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Комплект программного обеспечения для реализации функций оптического распознавания штрих-кодов различных систем при помощи обычной web-камеры, а также их отображения в печатных формах. Программы могут работать в составе конфигураций, созданных на базе платформ «1С-Предприятие» версий 7.7, 8.2, 8.3. Компонент чтения кодов реализован в виде внешней компоненты 1С с COM-интерфейсом. Компонент отображения создан по стандартной технологии ActiveX для Windows, и может быть встроен в любое приложение, поддерживающее встраивание ActiveX элементов управления, например в документ Word или Excel, или форму VBA. P.S. Добавлена новая версия программы распознавания. Новые функции: обработка видео в реальном режиме (а не по таймеру, как раньше), добавлена возможность распознавания штрих-кодов из графических файлов JPEG, PNG, GIF, BMP, а также передавать для распознавания картинки из 1С, теперь можно получить в 1С захваченное с камеры или файла изображение, как с выделением мест, содержащих коды, так и без, а также отдельные фрагменты изображений, содержащие код. Добавлены новые свойства и методы для программирования. Обновлена документация.

10 стартмани

10.07.2015    69325    84    igorberezhnov    95    

Клиент HTTP(S): внешняя компонента для 1С 7.7

Разработка внешних компонент WEB v7.7 Абонемент ($m)

Компонента позволит использовать различные веб-сервисы интернет-ресурсов, например работать с онлайн-кассой через API, предоставленное ее разработчиком. Тестировалась только на платформе 1С релиза 7.70.027.

1 стартмани

14.11.2019    4841    13    mdbruyfn    25    

Дополнение реквизитов номенклатуры из Эксель в 7.7. Групповое редактирование реквизитов номенклатуры 7.7 в списке

Обработка справочников Загрузка и выгрузка в Excel v7.7 1С7:Комплекс УУ Абонемент ($m)

Обработки группового дополнения данных о номенклатуре. Ввод веса и объема существующих товаров вручную в форму таблицы значений и затем запись в справочник Номенклатуры и Единиц. Закачка весов и объемов существующих товаров из Эксель в справочник Номенклатуры и Единиц. Загрузка внешних кодов товаров из Эксель в справочник Номенклатуры. Редактирование внешних кодов товаров в форме списка. Дозаполнение реквизитов существующих товаров из Эксель (ключевые поля - штрихкод, наименование, внешний код).

1 стартмани

11.10.2019    4840    2    ksnik    2    

Оптовая торговля. Обработки дистрибьютора для обмена с поставщиками и покупателями через Excel в 1С 7.7

Оптовая торговля Загрузка и выгрузка в Excel Оптовая торговля v7.7 1cv7.md Оптовая торговля, дистрибуция, логистика УУ Абонемент ($m)

В данной публикации приведены примеры обработок обмена дистрибьютора с поставщиками и покупателями через Эксель. Создание товаров-новинок. Автоматическое формирование Заказа поставщику по продажам. Заполнение бланка заказа поставщику. Загрузка приходной накладной от поставщика. Загрузка любых справочников из Эксель, например товарных сертификатов. Выгрузка прайслиста в бланк заказа (создание бланка заказа). Загрузка заявки покупателя из произвольного файла Эксель. Загрузка заявки покупателя из бланка заказа.. Для работы требуется установленный MS Excel.

1 стартмани

08.09.2019    7681    7    ksnik    0    

Методы для группировки данных по полю,полям в Таблице Значений на примере универсального метода списания по партиям, а также отбора строк в ТЗ по произвольному условию. Для 8.x и 7.7 Промо

Универсальные функции Практика программирования v7.7 v8 1cv8.cf 1cv7.md Абонемент ($m)

Я очень часто использую группировку данных по полю и полям, как в восьмерке, так и в семерке. Это аналог запроса Итоги, но там строится дерево, а в большинстве случаев нужны "плоские данные". Да и делать запрос в большинстве случаев более накладный процесс, чем работа с ТЗ. Все достоинства такого подхода приведены на примере метода универсального списания по париям, а так же отбора строк в ТЗ по произвольному условию. Для 7.7 еще отчеты сравнения двух ТЗ. Работая с различными базами для упрощения сравнения номенклатуры, или как аналог джойнов(join), сделал сравнение двух таблиц значений по нескольким полям. Пока группировки полей должны быть уникальны. Часто приходится искать дубли, для универсального поиска есть ДублиВТзПоПолю и пример в Тест.ert.

1 стартмани

25.06.2015    28139    3    Serginio    1    

Загрузка адресов произвольного формата (КЛАДР и нестандартных "грязных" адресов) в ФИАС современных конфигураций из 1С 7.7

Обработка справочников Перенос данных из 1С7.7 в 1C8.X Загрузка и выгрузка в Excel v7.7 v8 1cv8.cf 1cv7.md ERP2 Абонемент ($m)

Описание технологии загрузки любых адресов из 1С 7.7 с разложением по ФИАС в современные конфигурации 1C 8.3 на примере ERP. Предлагаемый способ просто чудо, он гарантирует результат, он очень простой и качественный! Моя обработка является синтаксическим анализатором, который подставляет в строку грязного адреса выражение "Дом №" и "Корпус", благодаря чему грязные адреса 7.7 сами очень хорошо раскладываются по значимым полям ФИАС - заполняется область, город, улица, дом, корпус.. все раскладывается само с помощью встроенного механизма современных конфигураций 1С 8.3, который написали сами сотрудники фирмы 1С!

1 стартмани

16.08.2019    7708    4    ksnik    12    

ФФД 1.05 с драйверами Атол v10

Разработка внешних компонент Розничная торговля Розничная торговля v7.7 1cv7.md Абонемент ($m)

Подключение кассы / фискального регистратора к 1С 7.7 через драйвер Атола v10.

1 стартмани

02.08.2019    9351    18    phsin    23    

Пример переноса справочников, документов и движений через Эксель и "Конвертацию данных 2" из оптовой учетной системы 1С 7.7 Комплексной 4.2 и розничной учетной системы Рарус Торговый комплекс -> в 1С 8.3 ЕРП 2.4 (расширение и дополнительные реквизиты)

Перенос данных из 1С7.7 в 1C8.X Загрузка и выгрузка в Excel Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v7.7 v8 УТ10 1С7:Комплекс ERP2 УУ Абонемент ($m)

Описание практического опыта переноса данных из двух устаревших учетных систем в одну современную с обобщением справочников (например номенклатуры, контрагентов, партнеров) и объединением учетных данных устаревших систем в единую новую УС применяя комбинацию стандартной загрузки из Эксель и КД2. Данная публикация является примером переноса данных из сильно устаревших и сильно переписанных конфигураций 1С:Предприятия 7.7 и 8 в современную 1С 8.3 своими силами при условии невозможности или нежелания пользоваться обновлением релизов и типовой функциональностью универсального обмена данными типовых мастеров переноса данных. Отличительной особенностью публикации является устранение зависимости от версий релиза конфигураций, отказ от обновлений устаревших конфигураций.

1 стартмани

29.07.2019    9167    5    ksnik    0    

Обработка для формирования классов для прямого доступа к файлам 1С через курсоры BDE. И многого другого Промо

Разработка внешних компонент v7.7 1cv7.md Абонемент ($m)

Обработка формирует классы для прямого доступа к файлам 1С через курсоры BDE. Исходник ВК, которая загружает Объект Автоматизации, поддерживающий ITypeInfo и выполняет все его свойства и методы через IlanguageExtender. Обработка для формирования диспинтерфейсов к объектам 1С (таблицаЗначений, справочники, документы, перечисления). Обработки для группировки данных Таблицы Значений в виде ТЗ, где колонками являются ключи и ТзПоГруппе вида ТЗ с детальными записями. Вывод иерархии из ТЗ элементов, поиск дублей, сравнение 2 ТЗ

1 стартмани

14.04.2015    19913    2    Serginio    1    

Внешняя компонента Game.dll (таймер, ГСЧ, захват клавиатуры)

Разработка внешних компонент v7.7 Абонемент ($m)

Внешняя компонента для 1С 7.7 для работы с таймером, генератором случайных чисел и для захвата клавиатуры.

1 стартмани

29.04.2019    5026    1    Palmer1976    0    

Поддержка выгрузки в Excel 2007 для 1С 7.7 в одну строку

Разработка внешних компонент Загрузка и выгрузка в Excel v7.7 1cv7.md Абонемент ($m)

Внешняя компонента 1С 7.7. для сохранения таблиц в формате Excel 2007.

1 стартмани

21.03.2019    10173    16    MadDAD    85    

Доступ из 1С 7.7 к файлу Excel из Dropbox

Загрузка и выгрузка в Excel v7.7 1cv7.md Абонемент ($m)

Рассматривается технология организации доступа из 1С версии 7.7 к данным из файла Excel, расположенного в Dropbox. Тестировалось на релизе платформы 7.70.027, конфигурация "Моя бухгалтерия" от Хьюмен Системс.

2 стартмани

25.02.2019    5323    1    kiba    0    

Универсальная загрузка данных : Прыг-Скок...или из MS EXCEL в 1С (7.7) или как "забить товар" Промо

Загрузка и выгрузка в Excel Обработка документов v7.7 v77::ОУ v77::БУ v77::Расчет 1cv7.md Абонемент ($m)

Предыстория: постоянно на форуме спрашивают - "как загрузить из EXCEL в 1С нужную информацию?" и начинается... Готовый пример КАК...

1 стартмани

19.04.2010    54229    106    Tatitutu    96    

Работа с пробитыми чеками по БД Атол

Разработка внешних компонент Кассовые операции ККМ Кассовые операции v7.7 1cv7.md Абонемент ($m)

Получение данных о пробитых чеках по ККМ Атол драйверов версии 8 на ОФД СБИС.

1 стартмани

13.07.2018    9102    1    pakko    7    

Разработка игр на языке 1С с использованием Active-X компоненты (собственная разработка)

Разработка внешних компонент v7.7 v8 Россия Абонемент ($m)

Написанная Active-X компонента встраивается на форму обработки 1С (тестировалось на 1С 8.0, 8.1, 8.2, 8.3 не управляемые формы, 1С 7.7.). Компонента предназначена для моделирования игрового поля (вывод, движение спрайтов - фреймов, обработка коллизий, управление спрайтами-фреймами и т.д.) при разработки логики игры на встроенном языке 1С. Приложен пример обработки в которой реализована игра "Бита".

5 стартмани

04.01.2018    14886    2    protexprotex    34    

Оболочка для работы с последними драйверами ККМ АТОЛ для 1С 7.7, 8.1

Разработка внешних компонент ККМ Кассовые операции Кассовые операции v77::ОУ 1С7:ТиС Абонемент ($m)

Внешняя компонента - оболочка для работы в среде 1С 7.7 или 1С 8.1 с последними версиями драйверов ККМ от АТОЛ. Поддерживаются драйвера x32 начиная с версии 9.11. Присутствует внешняя обработка для полноценной работы с данными драйверами (поддержка ревизий 2.0, 2.1, 2.2, поддержка протокола ОФД 1.0, 1.0.5, 1.1).

1 стартмани

09.08.2017    37861    292    asdfghgghjdhg    118    

Загрузка в 1С 7.7 входящих налоговых накладных (ЗКП) из Медок и Сонаты

Загрузка и выгрузка в Excel Обработка документов Оптовая торговля Производство готовой продукции (работ, услуг) Оптовая торговля Производство готовой продукции (работ, услуг) v7.7 1cv7.md Украина БУ НУ Абонемент ($m)

Инструмент для групповой загрузки в 1С 7.7 (бухгалтерия, ПУБ, комплексная) входящих налоговых накладных (создание документов Запись книги приобтетения (ЗКП)) из Медок или Сонаты. Обработка внешняя - не требует изменения конфигурациии. В архиве есть детальная инструкция по установке и работе.

1 стартмани

09.08.2017    18163    5    AlexRAA.1C    0    

Подключение Онлайн кассы Штрих М к 1С 7.7

Разработка внешних компонент ККМ Кассовые операции Розничная торговля Кассовые операции Розничная торговля v7.7 1cv7.md Абонемент ($m)

Подключение онлайн кассы Штрих М к любой конфигурации 1С 7.7. Показаны основные приемы работы с драйвером. Обработка представляет из себя набор готовых функций для встраивания в свою конфигурацию: ИнициализироватьФР(); ПодключитьФР(); ОтключитьФР(); ОткрытьСмену(); ЗакрытьСмену(); НапечататьЧек(); АннулироватьЧек(); СнятьХОтчет().

1 стартмани

08.05.2017    24827    76    crimeait    2    

Загрузка табеля из Excel. v 7.7 Комплексная автоматизация

Обработка документов Загрузка и выгрузка в Excel Зарплата Учет рабочего времени Зарплата Учет рабочего времени v7.7 1С7:Комплекс Россия БУ Абонемент ($m)

Обработка предназначена для загрузки табелей отработанного времени из excel-файла.

1 стартмани

16.02.2017    10462    3    swk_swetlana    0    

Прыг-Скок...или из MS EXCEL в 1С (7.7) TiS* (открытый код - бесплатно) Промо

Загрузка и выгрузка в Excel v77::ОУ 1С7:ТиС Россия Абонемент ($m)

Универсальная загрузку данных из Microsoft Office Excel загрузку из любых по форме документов с очень удобным редактором. Данная обработка загружает почти все в конфигурацию "Торговля и Склад" с возможность "откатить" до первоначального вида.

22.03.2011    37271    66    Tatitutu    39    

1sqlite reborn

Разработка внешних компонент v7.7 1cv7.md Россия Абонемент ($m)

Обновленная версия внешней компоненты для работы с базами данных SQLite и прямыми запросы в ДБФ-базах 1С.

1 стартмани

07.11.2016    25263    21    Djelf    39    

Как создать индикатор в 1С:Предприятии 7.7

Универсальные функции Работа с интерфейсом v7.7 1cv7.md Россия Абонемент ($m)

В статье дано описание создания индикатора на форме в среде разработки 1С:Предприятие 7.7 исключительно типовыми средствами.

1 стартмани

27.09.2016    12693    2    HAMMER_59    6    

Метод загрузки данных из таблиц Excel в 1С без установки Office

Загрузка и выгрузка в Excel v7.7 1cv7.md Абонемент ($m)

Импорт данных в 1С:Предприятие 7.7 из Excel через JET.OLEDB или ACE.OLEDB. Данный метод позволяет загружать данные из файлов на ПК, на которых не установлен MS Office.

1 стартмани

20.09.2016    18160    7    aserg    5    

Загрузка поступлений из Excel Промо

Обработка документов Загрузка и выгрузка в Excel Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v77::ОУ 1С7:ТиС Россия УУ Абонемент ($m)

Обработка для загрузки документов поступлений из накладных в формате Excel.

5 стартмани

19.12.2012    30545    24    @lexandr    11    

Полноценное использование Drag&Drop в 1С 7.7

Работа с интерфейсом Разработка внешних компонент v7.7 1cv7.md Абонемент ($m)

Несмотря на то, что кое-какие функции Drag&Drop были заложены авторами 1cpp, моё дополнение позволяет сделать этот функционал законченным. Дело в том, что средствами 1cpp можно было таскать файлы ТОЛЬКО в 1С, а из 1С - невозможно. Теперь Вы можете сделать работу с файлами на порядок удобнее и эффективнее.

1 стартмани

19.09.2016    14300    14    DasIsFantastich    4    

Выгрузка остатков по счетам учета ОС в Excel и загрузка из таблицы Excel в документ "Бухгалтерская справка" 1С: Комплексная конфигурация 7.7

Обработка документов Загрузка и выгрузка в Excel Учет ОС и НМА Учет ОС и НМА v7.7 1С7:Комплекс Россия БУ Абонемент ($m)

Эта обработка написана была очень давно и использовалась при обрезке базы. Тестировалась только на Комплексной конфигурации 7.7

1 стартмани

01.03.2016    9828    9    Most    1    

Загрузка номенклатуры в 1С: 7.7 из Excel

Обработка справочников Загрузка и выгрузка в Excel v7.7 1С7:Комплекс Россия Абонемент ($m)

Обработка предназначена для автоматической загрузки номенклатуры в справочник из внешнего Excel файла.

1 стартмани

15.02.2016    12799    23    adamych8    1    

Универсальный конвертер DBF -> CSV (dbf2csv) Промо

Универсальные обработки Файловые протоколы обмена, FTP Загрузка и выгрузка в Excel v7.7 1cv7.md Абонемент ($m)

В данной обработке "dbf2csv" представлена переведенная мной на платформу 1С:Предприятие 7.7 Обработка "Экспорт ТЗ в CSV формат (пратформа 8.0/8.1)", и созданая мной функция ЭкспортТЗвCSV() для 1С:Предприятие 7.7

1 стартмани

08.09.2012    103024    5    ksnik    2    

Универсальная загрузка из файла Excel в табличную часть документа

Загрузка и выгрузка в Excel Обработка документов v7.7 1cv7.md Абонемент ($m)

Загрузка остатков, инвентаризаций, заявок, требований из произвольных файлов формата Excel. Загрузка строк из файла Excel, в любой документ конфигурации по выбору, имеющий табличную часть. Установка на ПК MS Excel не требуется.

1 стартмани

11.02.2015    14896    26    LavinVadik    12    

Обработка отправки документов по почте напрямую из 1С7.7 в файле EXCEL

Загрузка и выгрузка в Excel Email Документооборот и делопроизводство Документооборот и делопроизводство v7.7 1cv7.md Россия Абонемент ($m)

Данная внешняя обработка предоставляет функционал для быстрой выгрузки документа в файл Excel и отправки электронного письма с вложенным документом напрямую из интерфейса 1С Предприятие 7.7.

1 стартмани

16.11.2014    30783    68    etmarket    20    

Внешняя обработка выгрузки остатков товаров в Еxcel, с синхронизацией по артикулу. 1С 7,7.

Загрузка и выгрузка в Excel v7.7 1cv7.md Абонемент ($m)

Обработка в выбранном файле эксель ищет в указанной колонке артикул товара из справочника номенклатура. В случае если артикул найден в соответствующие колонки той же строки заполняются значения остатков найденного товара и цены.

1 стартмани

16.11.2014    10163    7    Smile_D    2    

Запуск php програм в 1С 7.7

Универсальные функции v7.7 1cv7.md Абонемент ($m)

Запуск программ PHP на сервере по прямому адресному запросу. Дополнительная возможность - передавать параметры методом GET-запросов.

1 стартмани

15.09.2014    7142    3    kwadro    1    

Перевод десятичного числа в HEX, BIN, OCT, _IdToStr и другие системы

Инструментарий разработчика Практика программирования Универсальные функции v7.7 1cv7.md Абонемент ($m)

Два алгоритма перевода десятичного числа в другую систему исчисления от 2 до 36 только средствами 1С (без ВК)

1 стартмани

05.06.2014    13973    8    kos    3    

Шаблон внешней компоненты для Lazarus (FreePascal)

Инструментарий разработчика Разработка внешних компонент v7.7 v8 Абонемент ($m)

Шаблон внешней компоненты COM для Lazarus (FreePascal)

1 стартмани

16.05.2014    16503    19    v77    5    

Сохранение печатной формы в Excel

Загрузка и выгрузка в Excel v7.7 1cv7.md Абонемент ($m)

Обработка позволяет сохранить любую открытую печатную форму в Excel

1 стартмани

28.01.2014    14908    4    brunet    9    

1C7.7 парсер JSON

Универсальные функции v7.7 1cv7.md Россия Абонемент ($m)

РАБОТОСПОСОБНЫЙ парсер JSON встраивается в глобальный модуль в виде 3х функций. Для достижения положительного результата активно используется regexp.

1 стартмани

23.01.2014    17173    54    pit201201    16    

Компонента "Быстрый регистр" для 1С 7.7 (на прямых запросах SQL 1c++)

Универсальные функции v7.7 Абонемент ($m)

Ускорение операций с регистрами 1с 7.7 через объектную модель, за счет доступа через прямые запросы SQL (1c++). Существует возможность добавления произвольных подзапросов соединений c другими таблицами и отборов WHERE, гибкой настройки вывода полей в результат

1 стартмани

13.01.2014    12642    2    victor_goodwill    7