Клиентское приложение (Толстый клиент) для сервиса изучения методов платформы 1С:Предприятие 8 (+ конструктор запросов)

Публикация № 192076

Разработка - Практика программирования

124
Клиентское приложение для работы с веб-сервисом
IT-Решение: Консоль изучения методов платформы 1С:Предприятие 8
в режиме толстый клиент.
Подготовка к аттестации 1С:Специалист on-line!
Тестовые задания по различным видам учета!
Подсказки для оптимального решения!

Уважаемые коллеги!

Представляем вашему вниманию клиентское приложение для бесплатного веб-сервиса "Консоль изучения методов платформы 1С:Предприятие 8" - конфигурацию, разработанную на платформе 8.2 и предназначенную для интерактивного обучения методам и приемам разработки в среде 1С.

Страница сервиса на infostart.ru: //infostart.ru/public/192077/ 


Работа с веб-сервисом возможна с использованием конструктора запросов 1С (аналогично Клиентскому приложению для самоучителя языка запросов 1С 8).

При входе в конфигурацию произоводится аутентификация на веб-сервисе под логином пользователя.

Для регистрации нового пользователя на веб-сервисе необходимо использовать логин: guest, пароль пустой.

Информацию о составе учебной конфигурации, ее объектах и их взаимосвязях можно посмотреть на "Схеме базы данных" (кнопка в левом верхнем углу консоли).

Решение задачи пользователь представляет в поле "Ваше решение". В процессе решения задач для написания запросов может быть использован Конструктор запросов. В поле "Результат" отображается результат проверки решения задачи. Так же в форме основной обработки представлена персональная статистика и общий рейтинг участников (ТОП 100). Все задачи должны решатся последовательно. Переход к следующей задаче, не решив предыдущую, невозможен.

 

Важно! 
Для получения навыков написания простых и сложных запросов рекомендуем воспользоваться бесплатным сервисом Консоль изучения языка запросов 1С:Предприятие 8).

 

124

Скачать файлы

Наименование Файл Версия Размер
Дистрибутив поставки
.exe 422,36Kb
02.07.13
187
.exe 422,36Kb 187 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. bpc222 2117 27.06.13 18:40 Сейчас в теме
Уважаемые разработчики.

Начал работу новый сервис: Консоль изучения методов платформы 1С:Предприятие 8.
Месяц будет "крутиться" в тестовом режиме, ваши решения будут сохранены.
Задания второго раздела будут опубликованы на днях.
Это клиентское приложение - клиент для сервиса. Его задача - предоставить Вам возможность использования Консоли запросов для разработки прикладных решений.

Ждем Ваших отзывов и предложений. Спасибо.
2. ivanov660 1624 28.06.13 09:01 Сейчас в теме
А что в веб варианте не сделали консоль запросов? Взяли хот-бы Больсунова. Не удобно онлайн сервисом пользоваться, по крайней мере подсказки какие-нибудь выдали?
3. bpc222 2117 28.06.13 09:16 Сейчас в теме
(2) ivanov660,

рассмотрим возможность, спасибо.
4. Egor.ZenNoches 28.06.13 14:55 Сейчас в теме
5. kuza_87 25 01.07.13 08:29 Сейчас в теме
Дошел до 6-го задания. Пишет что неверное решение. Не могу понять где ошибка. Выполнено всё верно
Вот код
ЗапросЦены = Новый Запрос;
ЗапросЦены.Текст =
"ВЫБРАТЬ
| ЦеныНоменклатуры.Номенклатура,
| ЦеныНоменклатуры.Цена,
| ЦеныНоменклатуры.Период КАК Период
|ИЗ
| РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры
|
|УПОРЯДОЧИТЬ ПО
| Период УБЫВ";
ТЗЦены = ЗапросЦены.Выполнить().Выгрузить();

ВыборкаДоков = Документы.Приходнаянакладная.Выбрать();
Пока ВыборкаДоков.Следующий() цикл
Если ВыборкаДоков.Ссылка.Проведен = Ложь Тогда
Док = ВыборкаДоков.Ссылка.ПолучитьОбъект();
НаборЗаписей = РегистрыСведений.ЦеныНоменклатуры.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.Регистратор.Установить(Док.Ссылка);
НаборЗаписей.Прочитать();
Для Каждого строка из Док.Товары Цикл
НайденнаяСтрока = ТЗЦены.Найти(строка.Номенклатура, "Номенклатура");
Если НайденнаяСтрока = Неопределено Тогда
Движение = НаборЗаписей.Добавить();
Движение.Период = Док.Дата;
Движение.Номенклатура = Строка.Номенклатура;
Движение.Цена = строка.Цена;
ИначеЕсли НайденнаяСтрока<>Неопределено и
НайденнаяСтрока.Цена<>Строка.Цена Тогда
Движение = НаборЗаписей.Добавить();
Если КонецДня(НайденнаяСтрока.Период) = КонецДня(Док.Дата) Тогда
Движение.Период = КонецДня(Док.Дата)+1;
Иначе
Движение.Период = Док.Дата;
КонецЕсли;
Движение.Номенклатура = Строка.Номенклатура;
Движение.Цена = строка.Цена;

КонецЕсли;

КонецЦикла;
НаборЗаписей.Записать();

КонецЕсли;

КонецЦикла;
7. bpc222 2117 01.07.13 09:54 Сейчас в теме
(5) kuza_87,


Одно из условий задания: "Следует учесть, что записывать в регистр нужно лишь изменившиеся на дату документа цены, учитывая периодичность регистра "В пределах дня"

Скажите, Ваше решение удовлетворяет этому условию?
6. kuza_87 25 01.07.13 08:30 Сейчас в теме
Я нигде не усмотрел ошибку
8. kuza_87 25 01.07.13 11:11 Сейчас в теме
Разобрался, извините. Делал спросони)))
11. bpc222 2117 01.07.13 12:55 Сейчас в теме
(8) kuza_87,

Отлично.
не нужно извиняться.
Консоль для этого и предназначена - научиться решать прикладные задачи различного уровня.
9. kuza_87 25 01.07.13 11:39 Сейчас в теме
А в следующем задании что не так? Задание элементарное. Вот текст кода

ВыборкаДоков = Документы.ПриходнаяНакладная.Выбрать();
Пока ВыборкаДоков.Следующий() Цикл
Если ВыборкаДоков.Проведен = Истина Тогда
Док = ВыборкаДоков.ПолучитьОбъект();
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| ПриходнаяНакладнаяТовары.Номенклатура,
| ПриходнаяНакладнаяТовары.Ссылка КАК Партия,
| ПриходнаяНакладнаяТовары.Количество,
| ПриходнаяНакладнаяТовары.Сумма,
| ПриходнаяНакладнаяТовары.Ссылка.Дата КАК Период
|ИЗ
| Документ.ПриходнаяНакладная.Товары КАК ПриходнаяНакладнаяТовары
|ГДЕ
| ПриходнаяНакладнаяТовары.Ссылка = &Ссылка";

Запрос.УстановитьПараметр("Ссылка", Док.Ссылка);
Результат = Запрос.Выполнить().Выгрузить();

НаборЗаписей = РегистрыНакопления.ОстаткиНоменклатуры.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.Регистратор.Установить(Док.Ссылка);
НаборЗаписей.Прочитать();
НаборЗаписей.Загрузить(Результат);

КонецЕсли;
Конеццикла;
12. bpc222 2117 01.07.13 12:58 Сейчас в теме
(9) kuza_87,

1. А где у Вас запись набора?
2. Решите задачу так, как считаете нужным, а затем посмотрите что можно предпринять, чтобы исключить запросы в цикле.
10. kuza_87 25 01.07.13 11:52 Сейчас в теме
13. bpc222 2117 01.07.13 13:02 Сейчас в теме
(10) kuza_87,


и еще... Если Вам все нравится в нашем сервисе, ставьте лайки.
Это очень нам поможет в продвижении публикаций.

Лайкнуть:
- сервис изучения методов платформы: http://infostart.ru/public/192077/?rate=1
- сервис изучения языка запросов 1С: http://infostart.ru/public/184350/?rate=1
- консоль сервиса изучения методов: http://infostart.ru/public/192076/?rate=1
- консоль сервиса изучения запросов: http://infostart.ru/public/188639/?rate=1

Спасибо.
14. kuza_87 25 01.07.13 13:12 Сейчас в теме
Метод "Загрузить" насколько я знаю записывает данные в регистр, т.е потом не нужно писать "Записать"
17. bpc222 2117 01.07.13 13:22 Сейчас в теме
(14) kuza_87,

проверьте это утверждение, а то у меня возникает желание пойти и сжечь все свои сертификаты 1С:Специалист и закусить все это 1С:Экспертом.
15. kuza_87 25 01.07.13 13:13 Сейчас в теме
Так тоже говорит что неверно (лайкну все статьи сегодня)


ВыборкаДоков = Документы.ПриходнаяНакладная.Выбрать();
Пока ВыборкаДоков.Следующий() Цикл
Если ВыборкаДоков.Проведен = Истина Тогда
Док = ВыборкаДоков.ПолучитьОбъект();
НаборЗаписей = РегистрыНакопления.ОстаткиНоменклатуры.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.Регистратор.Установить(Док.Ссылка);
НаборЗаписей.Прочитать();

Для Каждого Строка из Док.Товары Цикл

Движение = НаборЗаписей.Добавить();
Движение.период = Док.Дата;
Движение.Партия = Док.Ссылка;
Движение.Номенклатура = Строка.Номенклатура;
Движение.Количество = Строка.Количество;
Движение.Сумма = Строка.Сумма;
КонецЦикла;



НаборЗаписей.Записать();

КонецЕсли;
Конеццикла;
16. bpc222 2117 01.07.13 13:21 Сейчас в теме
(15) kuza_87,

Измерение склад тоже нужно заполнять. Пользуйтесь схемой данных (кнопка сверху слева).
18. kuza_87 25 01.07.13 13:31 Сейчас в теме
я тоже про склад думал. просто в вашей конфигурации у этого документа нету склада
20. bpc222 2117 01.07.13 14:07 Сейчас в теме
(18) kuza_87,


спасибо, исправим.
19. kuza_87 25 01.07.13 13:35 Сейчас в теме
да, проблема была в складе
21. kuza_87 25 02.07.13 11:19 Сейчас в теме
8-е задание пишет что неверно.

ВыборкаДоков = Документы.ПриходнаяНакладная.Выбрать();
Пока ВыборкаДоков.Следующий() Цикл
Если ВыборкаДоков.Проведен Тогда
Док = ВыборкаДоков.Ссылка.ПолучитьОбъект();
НаборЗаписей = РегистрыНакопления.ОстаткиНоменклатуры.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.Регистратор.Установить(Док.Ссылка);
НаборЗаписей.Прочитать();

Для Каждого Строка из Док.Товары Цикл
Строка.ЕдиницаИзмерения = Строка.Номенклатура.ОсновнаяЕдиницаизмерения;
Строка.Сумма = Строка.Количество*Строка.Цена;
КонецЦикла;
Док.Записать();
Для Каждого Строка из Док.Товары Цикл
Движение = НаборЗаписей.Добавить();
Движение.Период = Док.Дата;
Движение.Партия = Док.Ссылка;
Движение.Склад = Док.Склад;
Движение.Номенклатура = строка.Номенклатура;
Движение.Количество = (Строка.Количество*Строка.Номенклатура.ЕдиницаХраненияОстатков.Коэффициент);
Движение.Сумма = Строка.Сумма;
КонецЦикла;
НаборЗаписей.Записать();

КонецЕсли;


КонецЦикла;
22. echo77 1090 02.07.13 13:40 Сейчас в теме
В толстом клиенте не работает Сообщить() - это неудобно, т.к. других способов отладки результата нет.
В веб-клиенте Сообщить() работает.

Почему требуется расширение для работы с файлами при нажатии на гиперссылки в правой части окна программы?
23. adapter 513 04.09.13 17:34 Сейчас в теме
Идея хороша, но вот реализация..... Скачал толстого клиента а там только cf. А почему нет базы с данными? заполненными спр, регистрами сведений? Хотел дать практиканту потренироваться, а в таком виде теперь вряд ли. Надо бы добавить данные и кнопку "выполнить запрос" чтобы сначала хотя бы посмотреть что выдается а потом уже жать "проверить"
25. bpc222 2117 05.09.13 05:16 Сейчас в теме
(23) adapter,

Даже не знаю, что Вам ответить.
26. adapter 513 05.09.13 09:42 Сейчас в теме
(25) промахнулся с публикацией, камент относился к "самоучитель языка запросов", очень они похожи, даже файлы для скачивания одинаково называются

вот повторил там http://infostart.ru/public/184350/#comm

хотя сейчас посмотрел "изучении методов платформы" та же проблема - только cf без данных. почему бы не заполнить справочники, регистры и раздавать dt ?
27. bpc222 2117 05.09.13 11:47 Сейчас в теме
(26) adapter,

Уважаемый, adapter. ПРОБЛЕМЫ нет. Есть описанная функциональность и представленная.

>почему бы не заполнить справочники, регистры и раздавать dt?
Извините, что вопросом на вопрос: зачем?

Вам чем текущая реализация-то не нравится? Если Вас не устраивает надпись на кнопке "Проверить", то можно ее залепить жвачкой на мониторе.
24. adapter 513 04.09.13 21:08 Сейчас в теме
28. dtripleh 05.03.15 10:54 Сейчас в теме
Не могу решить 6 задачу, уже много времени с ней бьюсь.
Вот мой код:
Запрос = Новый Запрос; 
Запрос.Текст = 
"ВЫБРАТЬ 
|	ЦеныНоменклатуры.Номенклатура, 
|	ЦеныНоменклатуры.Цена, 
|	НачалоПериода(ЦеныНоменклатуры.Период,День) КАК Период 
|ИЗ 
|	РегистрСведений.ЦеныНоменклатуры КАК ЦеныНоменклатуры 
| 
|УПОРЯДОЧИТЬ ПО 
|	Период УБЫВ"; 
Цены = Запрос.Выполнить().Выгрузить(); 

ВыборкаДоков = Документы.Приходнаянакладная.Выбрать(); 
Пока ВыборкаДоков.Следующий() цикл 
	Если НЕ ВыборкаДоков.Ссылка.Проведен Тогда 
		ДокОбъект = ВыборкаДоков.Ссылка.ПолучитьОбъект(); 
		НаборЗаписей = РегистрыСведений.ЦеныНоменклатуры.СоздатьНаборЗаписей(); 
		НаборЗаписей.Отбор.Регистратор.Установить(ДокОбъект.Ссылка); 
		НаборЗаписей.Прочитать(); 
		Для Каждого СтрокаТЧ из ДокОбъект.Товары Цикл 
			НайденныеСтроки = Цены.НайтиСтроки(Новый Структура("Номенклатура, Период", СтрокаТЧ.Номенклатура, НачалоДня(ДокОбъект.Дата)));
			Если НайденныеСтроки.Количество() = 0 Тогда 
				Движение = НаборЗаписей.Добавить(); 
				Движение.Период = ДокОбъект.Дата; 
				Движение.Номенклатура = СтрокаТЧ.Номенклатура; 
				Движение.Цена = СтрокаТЧ.Цена; 
			Иначе
				НайденнаяСтрока = НайденныеСтроки[0];
				Если НайденнаяСтрока.Цена <> СтрокаТЧ.Цена Тогда 
					Движение = НаборЗаписей.Добавить();
					Движение.Период = ДокОбъект.Дата + 24*60*60; 
					Движение.Номенклатура = СтрокаТЧ.Номенклатура; 
					Движение.Цена = СтрокаТЧ.Цена;
				КонецЕсли;	
			КонецЕсли; 
		КонецЦикла; 
		НаборЗаписей.Записать();	
	КонецЕсли; 
КонецЦикла;
Показать

Подскажите пожалуйста решение
29. user592024_rzane 07.07.16 11:39 Сейчас в теме
Добрый день.

Вот такая ошибка. Подскажите как можно решить?
Прикрепленные файлы:
30. bpc222 2117 07.07.16 14:49 Сейчас в теме
(29) user592024_rzane,

Убедитесь в том, что ваше подключение к сети Интернет не ограничено
31. user592024_rzane 07.07.16 14:59 Сейчас в теме
(30) у нас прокси-сервер. Подскажите как в таком случае подключиться.
32. lenafV 16.02.17 08:36 Сейчас в теме
Не могу понять в чем проблема в решении 6 задачи....
Код прикладываю:

Запрос = Новый Запрос; 

Запрос.Текст = 
"ВЫБРАТЬ 
|	 ЦеныНоменклатурыСрезПоследних.Номенклатура, 
|    ЦеныНоменклатурыСрезПоследних.Цена, 
|    НАЧАЛОПЕРИОДА(ЦеныНоменклатурыСрезПоследних.Период, ДЕНЬ) КАК Период 
|ИЗ 
|    РегистрСведений.ЦеныНоменклатуры.СрезПоследних КАК ЦеныНоменклатурыСрезПоследних
| 
|УПОРЯДОЧИТЬ ПО 
|    Период УБЫВ";

ТЗЦены = Запрос.Выполнить().Выгрузить(); 

ВыборкаДоков = Документы.Приходнаянакладная.Выбрать(); 

Пока ВыборкаДоков.Следующий() цикл
	
	Если НЕ ВыборкаДоков.Ссылка.Проведен Тогда
		
        ДокОбъект = ВыборкаДоков.Ссылка.ПолучитьОбъект(); 
		
        НаборЗаписей = РегистрыСведений.ЦеныНоменклатуры.СоздатьНаборЗаписей(); 
        НаборЗаписей.Отбор.Регистратор.Установить(ДокОбъект.Ссылка); 
        НаборЗаписей.Прочитать();
		
		Для Каждого СтрокаТЧ из ДокОбъект.Товары Цикл 
			
            НайденныеСтроки = ТЗЦены.НайтиСтроки(Новый Структура("Номенклатура, Период", СтрокаТЧ.Номенклатура, НачалоДня(ДокОбъект.Дата)));

            Если НайденныеСтроки.Количество() = 0 Тогда 
				Движение = НаборЗаписей.Добавить(); 
				Движение.Период = ДокОбъект.Дата;
				Движение.Регистратор = ДокОбъект.Ссылка;
				Движение.Номенклатура = СтрокаТЧ.Номенклатура; 
				Движение.Цена = СтрокаТЧ.Цена;        
				
			ИначеЕсли НайденныеСтроки.Количество() > 0 Тогда
				
                НайденнаяСтрока = НайденныеСтроки[0];
				
				Если НайденнаяСтрока.Цена <> СтрокаТЧ.Цена Тогда 
                    Движение = НаборЗаписей.Добавить();
                    Движение.Период = ДокОбъект.Дата;
					Движение.Регистратор = ДокОбъект.Ссылка;
                    Движение.Номенклатура = СтрокаТЧ.Номенклатура; 
                    Движение.Цена = СтрокаТЧ.Цена;    
				КонецЕсли;  
				
			КонецЕсли;
			
		КонецЦикла;
		
        НаборЗаписей.Записать();
		
	КонецЕсли;
	
КонецЦикла;
Показать


Подскажите пожалуйста в чем моя ошибка? Спасибо!
34. imh9305 8 19.04.17 23:33 Сейчас в теме
идея хорошая. на запросах хорошо рука набивается. но почему же не доделали так же, как и самоучитель запросов?
35. bpc222 2117 25.04.17 07:24 Сейчас в теме
(34)
но почему же не доделали так же, как и самоучитель запросов?


Добрый день, не понял :)

Что значит "не доделали"? И почему "как"... это и есть клиентское приложение от самоучителя... что-то не работает у Вас?
36. imh9305 8 25.04.17 09:15 Сейчас в теме
(35)добрый день! в запросах и в скд у вас есть подсказки и решения, ну и заданий много.
37. goodron 10.01.19 12:51 Сейчас в теме
Добрый день!

если возможно, залейте "Дистрибутив поставки" на yandex.disk, а то у меня 0 (ноль) SM

Спасибо!
Оставьте свое сообщение

См. также

Описание формата внутреннего представления данных 1С в контексте обмена данными 143

Статья Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных Разработка

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    4142    4    Dementor    27       

Вам нравятся запросы в 1С? 12

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования Разработка

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    8833    1    m-rv    70       

1С:Ассемблер. Немного летнего веселья! 282

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Разработка

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    12087    37    Evil Beaver    108       

Простые примеры сложных отчетов на СКД 229

Статья Программист Архив с данными v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования Разработка

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    10731    9    Hatson    21       

Безопасная работа с транзакциями во встроенном языке 183

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Разработка

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    13034    7    tormozit    35       

Баг или фича? Неожиданное поведение платформы 164

Статья Системный администратор Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Разработка Тестирование и исправление

Рассмотрим несколько случаев неожиданного поведения платформы 1С, а также что с этим можно cделать.

18.02.2019    11860    30    YPermitin    88       

HTML в новой версии 8.3.14 на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX 167

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Практика программирования Разработка

Тестируем возможности HTML в новой версии 8.3.14 платформы на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX.

1 стартмани

29.01.2019    12526    62    Synoecium    33       

Отладка сложных отчетов на СКД 137

Отчеты и формы Программист Расширение (cfe) v8 v8::СКД 1cv8.cf Россия Абонемент ($m) Практика программирования

Расширение для отладки сложных отчетов на СКД (в т.ч. для собираемых программно "на лету") и быстрого перехода к отладке таких отчетов в консоли запросов и отчетов на СКД.

1 стартмани

28.12.2018    12815    53    maxx    42       

Реализация простого http-сервиса "Просмотр карточки номенклатуры(товара) в браузере" 144

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Практический пример реализации простого http-сервиса средствами 1С Предприятие 8.3. Обеспечивает просмотр списка товаров и просмотр данных товара в браузере.

1 стартмани

07.12.2018    12535    10    dmitry1975    31       

Использование подсистемы БСП "Заполнение объектов" 133

Статья Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем)

Применение механизмов БСП для добавления новых команд заполнения к формам различных объектов. Использование расширений конфигурации для доработки. Шаблоны для реализации собственных команд заполнения.

1 стартмани

23.11.2018    12764    8    ids79    14       

Работа с публикациями "Инфостарт" 13

Инструменты и обработки Программист Архив с данными v8 УУ Абонемент ($m) Практика программирования О сообществе WEB

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    8045    10    RocKeR_13    12       

HTTP Сервисы: Путь к своему сервису. Часть 3 133

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Практика программирования

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    14569    29    dsdred    13       

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции 62

Инструменты и обработки Программист Бизнес-аналитик Приложение (apk) v8 Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    14584    23    informa1555    26       

Работа с данными выбора 38

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    19361    13    kalyaka    15       

HTTP Сервисы: Путь к своему сервису. Часть 1 256

Статья Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования WEB

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    34435    15    dsdred    22       

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") 105

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    18862    86    m-rv    57       

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному 236

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования БСП (Библиотека стандартных подсистем)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    25898    24    dsdred    34       

Как выполнить отчет на СКД через COM и получить данные отчета? 85

Статья Программист Архив с данными v8 УПП1 Россия Windows Абонемент ($m) Практика программирования

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    17089    10    wowik    3       

Работа со схемой запроса 169

Статья Программист Конфигурация (md, cf) v8 v8::Запросы Абонемент ($m) Инструментарий разработчика Практика программирования

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    26932    70    kalyaka    34       

Асинхронная запись и чтение файла без использования модальных методов и временных файлов 130

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования

В статье рассмотрено решение задачи формирования и записи файла на основе данных информационной базы. Формирование происходит на стороне сервера с помощью механизма потоков. Используются асинхронные методы передачи файлов между клиентом и сервером. Также рассмотрено решение обратной задачи - чтение файла и запись его данных в информационную базу. Статья ориентирована прежде всего на новичков, также приведенный код может использоваться в качестве шаблона.

1 стартмани

10.04.2018    17824    17    Alxby    23       

Заполняем по шаблону (по умолчанию) 68

Инструменты и обработки Программист Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    17297    20    mvxyz    17       

Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов 122

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

1 стартмани

01.02.2018    24163    61    rpgshnik    46       

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула 8

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Печатные формы документов Практика программирования Универсальные функции

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    21219    21    agent00mouse    0       

Практика доступа в базу 1С через протокол oData. Чтение данных 273

Статья Системный администратор Программист Бизнес-аналитик Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Сервисные утилиты Практика программирования Администрирование данных 1С

Для чего нужен доступ в базу 1С через REST-интерфейс по протокол oData? Как его организовать? Как не будучи гуру в JavaScript и .NET получить быстрый визуальный доступ к данным базы 1С? Попробую дать ответ на эти вопросы и прокомментирую некоторые нюансы, с которыми я столкнулся.

1 стартмани

11.12.2017    54424    229    Dementor    42       

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП 26

Инструменты и обработки Программист Расширение (cfe) v8 БП3.0 Абонемент ($m) Практика программирования Универсальные печатные формы

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    17710    52    kwazi    6       

Простой бесплатный DashBoard с помощью http сервиса 256

Статья Программист Конфигурация (md, cf) v8 Абонемент ($m) Практика программирования

Как создать свой DashBoard без дополнительных затрат и сложных технических доработок.

1 стартмани

25.11.2017    43271    58    dewersia    32       

Полезный код для программистов 1С (часть 1). Управление свойствами элементов формы. Хранение копии данных реквизитов 141

Статья Программист Архив с данными v8 Абонемент ($m) Инструментарий разработчика Практика программирования

У каждого программиста за время работы накапливается полезный инструментарий, которым он привык пользоваться. Естественно и у меня он тоже имеется. И вот решено было немного поделиться с сообществом. Возможно идеи не новые. Более того, допускаю, что реализованы они не самым оптимальным образом. Но ведь для этого сообщество и существует, чтобы делиться с ним, получая обратную связь.

1 стартмани

24.09.2017    31227    17    vandalsvq    79       

Telegram-боты 147

Инструменты и обработки Программист Архив с данными v8 Абонемент ($m) Практика программирования

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    21627    118    PLAstic    45       

Макеты СКД 282

Статья Программист Внешний отчет (ert,erf) v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования

Рассмотрены некоторые типовые задачи, которые решаются с помощью предопределенных макетов, а также перечислены несколько случаев, для которых макеты не подходят

1 стартмани

25.07.2017    67571    106    json    24       

Расширения конфигураций 1С: учимся перехватывать методы 110

Инструменты и обработки Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    81222    14    signum2009    45       

Многопоточность. Универсальный «Менеджер потоков» (фреймворк) с отслеживанием зависимости объектов 175

Статья Программист Архив с данными v8 1cv8.cf Россия Абонемент ($m) Практика программирования Математика и алгоритмы Универсальные функции Производительность и оптимизация (HighLoad)

Восстановление партий, расчет зарплаты, пакетное формирование документов или отчетов - теперь все это стало доступнее. * Есть желание повысить скорость работы медленных алгоритмов! Но... * Нет времени думать о реализации многопоточности? * о запуске и остановке потоков? * о поддержании потоков в рабочем состоянии? * о передаче данных в потоки и как получить ответ из потока? * об организации последовательности? Тогда ЭТО - то что надо!!!

26.05.2017    38187    166    DarkAn    86       

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений 181

Инструменты и обработки Программист Архив с данными v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Практика программирования

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    22162    112    romasna    47       

Оптимизация запросов 1С:Предприятие – от теории к практике 114

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Математика и алгоритмы

Я давно отметил достаточно серьезный интерес сообщества к вопросам оптимизации и повышения производительности высоконагруженных систем. Общаясь с различными специалистами, обслуживающими малые и большие предприятия (торговые и производственные), я пришел к выводу, что вопросы повышения производительности интересны почти всем, вне зависимости от того, какую конфигурацию они обслуживают – большую или маленькую, измененную или без значительных изменений. В связи с этим я пришел к выводу, что стоит посвятить данный материал вопросам оптимизации запросов, поскольку именно запросы являются основным инструментом извлечения данных из системы.

07.10.2016    30878    bpc222    20       

Несколько шаблонов для доработки типовых конфигураций 172

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::УФ Абонемент ($m) Практика программирования Инструментарий разработчика

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    27321    99    json    23       

Простой способ индексирования интервалов 180

Статья Программист Конфигурация (md, cf) v8 Абонемент ($m) Практика программирования

Предлагается простой способ индексирования интервалов для решения задач выборки записей, включающих заданный момент времени, пересекающихся с заданным интервалом или множеством интервалов. Способ основан на добавлении к исходной таблице особого числового индексированного поля, рассчитываемого по специальной формуле. Приведен код функций, необходимых для расчетов поля поиска и параметров поисковых запросов. Приведены также результаты тестирования метода, доказывающие его высокую эффективность.

1 стартмани

28.09.2016    31505    39    ildarovich    22       

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут 61

Инструменты и обработки Системный администратор Программист Компонента, плагин (dll, vbs,..) v8 Windows Абонемент ($m) Практика программирования

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    37937    35    Demanoidos    60       

Хранение файлов в томах на диске (для УПП 1.3) 76

Инструменты и обработки Программист Архив с данными v8 УПП1 Windows Абонемент ($m) Практика программирования

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    43287    4    wowik    27       

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения) 185

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    45363    136    rozer    52       

Остатки на каждый день в запросе 33

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf УУ Windows Учет ТМЦ Абонемент ($m) Практика программирования

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    33605    19    arakelyan    16       

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии 149

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Россия Windows Абонемент ($m) Практика программирования

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    59693    132    igo1    49       

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом 28

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 Абонемент ($m) Практика программирования

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    11860    1    Alexander.Shvets    5       

Простые радости жизни программиста 1С: выбор типа значения 51

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Работа с интерфейсом

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    38421    45    yuraos    17       

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе. 159

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Практика программирования БСП (Библиотека стандартных подсистем)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    39987    143    balanton    20       

Яндекс.Деньги "Благотворительность" 17

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    16925    9    Tatitutu    5       

Мастер рассылки e-mail 2.2 для управляемых форм 9

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m) Практика программирования Email

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    30279    20    milkers    4       

Нечеткий поиск одним запросом 37

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    18926    57    vasvl123    9       

Передача больших пакетов через веб-сервисы 136

Инструменты и обработки Системный администратор Программист Конфигурация (md, cf) v8 Абонемент ($m) Практика программирования Администрирование данных 1С Внешние источники данных

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    40488    44    YPermitin    19       

Пример связи 1С и мессенджера Telegram. Получение данных из 1С запросом из Telegram 242

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных

В результате чтения публикации Вы получите готовую внешнюю обработку, позволяющую получать из 1С данные, запрашиваемые через Telegram. В данной статье рассмотрим следующее: Использование HTTPСоединение; Чтение JSON для версии 1С 8.3.6 и выше, а также аналог JSON для версии 1С ниже 8.3.6; Подключение обработчика ожидания; Некоторые основные возможности API Telegram; Как создать бота для Telegram; Программное создание колонок дерева на управляемой форме;

1 стартмани

19.11.2015    69100    417    Luchik    199