Автоматическая DOS-печать из-под Windows

Публикация № 19382

Разработка - Печать - Пакетная печать

1
Автоматическая DOS-печать из-под Windows. Бывает очень нужна.

Программа ставится в TRAY и автоматически печатает DOS-задания на Windows-принтере. Можно делать предпросмотр печати.

 

1

Скачать файлы

Наименование Файл Версия Размер
-
.1237436129 382,17Kb
25.09.09
135
.1237436129 382,17Kb 135 Скачать бесплатно

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. v.l. 25.03.09 10:04 Сейчас в теме
А как она работает из-под сервера? В смысле, я к серверу подключаюсь в терминале и посылаю на печать на свой компьютер (по сети).
Есть описание и пример использования?
2. victuan 3445 26.03.09 14:41 Сейчас в теме
(0) Что-то знакомое...
Лет 5 назад я использовал программу с похожим названием и функционалом, но она ломалась крэком...
А чем не походит бесплатная программа Sprint, зачем изобретать велосипед?
И интересно, кто еще пользуется ДОС-программами?
3. sttt 113 26.03.09 20:14 Сейчас в теме
Я год назад фокспрошную базу подключал. Бывают случаи :0)
the.jarr; +1 Ответить
4. mast2 1 30.03.09 04:56 Сейчас в теме
Программа печатает на текущий (по умолчанию) Windows-принтер. Исходя из этого и получаются все возможности печати.
5. chetirepda 8 01.02.12 13:52 Сейчас в теме
День добрый.
Собственно сабж. Несколько групп справочника "Контрагенты" были созданы (причем мной) ручками в Центре. Затем ручками же в них были перенесены уже существующие группы, в которых содержаться элементы. Сами элементы были зарегистрированы в 2-х узлах (не записаны, принудительно зарегистрированы). Примерно так:

Создана папка "КАЗАНЬ", в нее перенесена папка "Контрагенты Нижн. Новогород", "Контрагенты Самара", их элементы были зарегистрированы в плане обмена "Самара", "Нижн. Новгород".

Пссле обмена оказалось, что в Периферийки "Нижн. Новгород" GUID папки "КАЗАНЬ" не совпадает с GUID этой же папки центра..
1) Повторить данный подвиг не удается
2) Отладчиком прошел всю выгрузку, загрузку - нигде идентификатор не меняется
3) В ЖР центра - одна запись - добавление мной элемента, в ЖР периферии - одна запись - добавление автообменом элемента
4) XML файла обмена - нет, так уж через ЖПО устроен автообмен.
5) Платформа 8.1.11.67

Есть идеи?
6. chetirepda 8 01.02.12 13:53 Сейчас в теме
Если вам нужно заменить ссылки в объекте или наборе записей, можно выгрузить его в XML и там в виде строки заменить GUID первой ссылки на GUID второй ссылки. ;-)

Функция обЗаменаСсылки(Объект, ИсхСсылка, РезСсылка)
ХМЛ=обОбъектВXML(Объект);
ИсхГУИД=ИсхСсылка.УникальныйИдентификатор();
РезГУИД=РезСсылка.УникальныйИдентификатор();
Если Найти(ХМЛ, ИсхГУИД)=0 Тогда
Возврат Неопределено;
Иначе
ХМЛ=СтрЗаменить(ХМЛ, ИсхГУИД, РезГУИД);
Возврат обОбъектИзXML(ХМЛ);
КонецЕсли;
КонецФункции


Юзайте, пока я добрый!
7. chetirepda 8 01.02.12 13:56 Сейчас в теме
Изменение папки, повторный обмен и "задвоение" записсей подтвердит что "это" Вам не приснилось :)

А если сравнить время записей из ЖР и из гуид - может "Иде я" появится...

Функция ДатаСозданияСсылки(Ссылка)
ГУИД = Ссылка.УникальныйИдентификатор();
Строка16 = Сред(ГУИД, 16, 3) + Сред(ГУИД, 10, 4) + Сред(ГУИД, 1, 8);
Разрядность = СтрДлина(Строка16);
ЧислоСек = 0;
Для Позиция = 1 По Разрядность Цикл
ЧислоСек = ЧислоСек + Найти("123456789abcdef",Сред(Строка16,Позиция,1))*Pow(16,Разрядность - Позиция);
КонецЦикла;
ЧислоСек = ЧислоСек / 10000000;
Возврат Дата(1582, 10, 15, 04, 00, 00) + ЧислоСек;
КонецФункции
8. chetirepda 8 01.02.12 13:56 Сейчас в теме
Процедура ПередЗаписью(Отказ)
Перем мСсылкаНового;
Если НЕ ОбменДанными.Загрузка ИЛИ НЕ Загрузка77 Тогда //ЗДЕСЬ НУЖЕН "И"

Если НЕ ОбщегоНазначения.ЗначениеНеЗаполнено(ОсновнойВидДеятельности) И ВидыДеятельности.Найти(ОсновнойВидДеятельности, "ВидДеятельности") = Неопределено Тогда
ОсновнойВидДеятельности = Справочники.ВидыДеятельностиКонтрагентов.ПустаяСсылка();
КонецЕсли;
ПрошлыйИзмененныйРодительОбъектаДоступа = ?(Не ЭтоНовый() и Не Ссылка.Родитель = Родитель, Ссылка.Родитель, Неопределено);
НастройкаПравДоступа.ПередЗаписьюНовогоОбъектаСПравамиДоступаПользователей(ЭтотОбъект, Отказ, Родитель, мСсылкаНового);
Если НЕ ЭтоГруппа Тогда
Если ОбщегоНазначения.ЗначениеНеЗаполнено(ГоловнойКонтрагент) Тогда
Если ЭтоНовый() Тогда
ГоловнойКонтрагент = мСсылкаНового;
Иначе
ГоловнойКонтрагент = Ссылка;
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЕсли;

При загружке - создается новый элемент, и ему случайная ссылка назначается типовым механизмом.. Счаст я товарисчу напишу обработку, она найдет все вновь созданные с даты обновления его суперкода - ну а дальше - ХЗ, что ему посоветовать, глянем, сколько новых контров наколбасили юзвери в перифериях..
Оставьте свое сообщение

См. также

Пакетная печать в строго заданном порядке 6

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Пакетная печать

В силу различных особенностей ПО, ОС, драйверов и т.д. порядок печати документов не всегда совпадает с порядком их отправки на печать. Данный метод позволяет всегда получать на выходе нужный порядок документов.

19.09.2018    5344    crazycat    17       

Печать внешних форм документов для 7.7 80

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v7.7 1cv7.md Россия БУ Бесплатно (free) Пакетная печать

Печать внешних форм документов за выбранный период. Для ТиС/Комплексной/Бухии

15.10.2009    24208    960    Ёпрст    95       

Пакетная печать документов "Реализация товаров и услуг" 38

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 БП2.0 УТ10 Россия БУ УУ Windows Оптовая торговля Розничная торговля НДС Бесплатно (free) Пакетная печать

Обработка позволяет распечатать пакет отгрузочных документов для конфигураций УТ и БП, должна выдерживать обновления конфигураций. Что она позволяет распечатать 2 торг12, 2 счет фактуры , 2 ттн за два нажатия кнопки. + Встроен универсальный отбор по документам реализации товаров и услуг (н-р можно распечатать все документы за опред период по опред. контрагенту) + Возможность отсылки сразу на принтер и распределения по копиям + все общие модули вынесены в модуль обработки) + Печатает пакетно также и внешние печатные формы для документов реализация товаров и услуг и счетов фактур + при печати использует типовые модули печати документов в конфигурации (как будто вы сами отправляете на печать из формы документов) проверялась УТ 10.3.3.3 и БП 1.6.10.6

02.09.2009    22160    846    y22-k    33       

Универсальная настраиваемая печать документов 56

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Пакетная печать

Универсальная настраиваемая печать документов. Умеет печатать реестр документов, сформированный согласно произвольному отбору а также сами документы по любой доступной печатной форме.

05.07.2009    14836    981    Magister    39       

Групповая печать карточек 1-НДФЛ 25

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 ЗУП2.5 Россия БУ Зарплата НДФЛ Бесплатно (free) Пакетная печать

В 2009 не нашла в типовой печати 1-НДФЛ по всем сотрудникам. Сделала групповую печать карточек 1-НДФЛ по документу "Сведения о доходах физлиц", подготовленному для передачи в ИФНС. Может быть кому-нибудь пригодится. В 2010 году обработку посчитала уже неактуальной, так как в типовой появилась возможность групповой печати в стандартном отчете. Но расчетчица попросила и на последнем релизе (2.5.20) сделать печать по документу "Сведения о доходах физлиц". Поэтому выкладываю обновленную обработку, так как предыдущая версия не работает на более ранних релизах.

06.02.2009    12658    210    Ирка    12       

Пакетная печать документов 32

Отчеты и формы no Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Россия Бесплатно (free) Пакетная печать

Пакетная печать документов. Ограничение версии - печать только при помощи зарегистрированных внешних печатных форм

25.11.2008    15849    724    UrbSI    17       

Обработка для печати регистра налоговых накладных 4

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Украина НУ Оптовая торговля Бесплатно (free) Пакетная печать

Обработка сама выводит на печать налоговые накладные (за укр. законодательством - неплательщик НДС (два экземпляра) и плательщик НДС(вариант организации)...

04.06.2008    6777    17    mut_mut    1       

Помощник печати 5

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Россия Бесплатно (free) Пакетная печать

Помощник печати с выбором печатных форм, подключенных к документу.

21.12.2007    11100    28    Legavaz    1       

Пакетная печать документов 8

Отчеты и формы Программист Внешняя обработка (ert,epf) v77::ОУ v77::БУ 1С7:Бух 1С7:Комплекс Россия Бесплатно (free) Пакетная печать

Список в одном окне, любого вида, только необходимо раз поменять конфигурацию.

26.11.2007    8102    275    MatveyIgor    13       

Универсальный редактор реквизитов документов и справочников из УПП 8.0 3

Инструменты и обработки Системный администратор Программист Внешняя обработка (ert,epf) v8 УПП1 Бесплатно (free) Обработка документов Пакетная печать Обработка справочников

Обработка не моя. Добавил пару строк и процедур. Но чтоб никто больше не пыхтел зря, рекомендую воспользоваться. Если бы кто-нибудь написал DLL-ку, которая вытаскивала бы из 8.0 тексты процедур во внешние текстовые файлы, тогда и групповую печать для встроенных печатных форм можно было бы сделать универсальной. Потому что макет-то доступен, а вот процедура печати должна быть только в модуле объекта, да еще и с директивой "Экспорт". Конечно можно все документы конфигурации снабдить такими процедурами, но увы, это будет уже не универсально... Призываю крутых помочь! См. идею в дополнительно.

13.08.2007    10771    110    ge_ni    3       

Групповая печать документов 14

Отчеты и формы no Внешняя обработка (ert,epf) v8 1cv8.cf Бесплатно (free) Пакетная печать

"Множественная" печать документов из любой типовой конфигурации. "Сканирует" виды документов конфигурации, общие макеты и макеты документов. Выбираете вид документов и макет на основании которого будет формироваться печатная форма. К примеру: документы - "Перемещение товаров", макет - "ТОРГ13". Можно настроить непосредственную печать на принтер без предварительного просмотра, количество копий и др. Если для выбранных документа и макета не существует печатных форм, то выдаётся сообщение при попытки печати. Обработка писалась "на скорую руку", поэтому не судите строго. Рабочая, быстронастраиваемая программулина.

11.05.2007    8373    380    yalex9    14       

Групповая обработка документов v1.0: копирование, печать, ввод на основании. 95

Инструменты и обработки no Внешняя обработка (ert,epf) v77::ОУ v77::БУ v77::Расчет 1cv7.md Windows Бесплатно (free) Обработка документов Пакетная печать

Обработка будет полезна для тех организаций, где периодически повторяются одни и те же документы, с незначительными изменениями, в больших количествах. Обработка позволяет копировать (все конфигурации), вводить на основании (бух), печатать (бух) документы группой.

24.11.2006    20518    1226    svsrus    40       

Печать наклеек на конверты 20

Отчеты и формы Бухгалтер Внешняя обработка (ert,epf) v77::БУ БП2.0 Россия Бесплатно (free) Пакетная печать

Печать наклеек с адресами и индексами на почтовые конверты

20.10.2006    11076    224    Звездочет    8