Еникеев Марат | Руководитель проектов 1С | ГК «Комплексная автоматизация»

«Структурно-независимые базы данных в 1С»

В докладе расскажу об идеях построения гибких (содержащих в БД структуру данных) систем на платформе 1С. Рассмотрим: - варианты развития функциональности известных подсистем БСП "Дополнительные реквизиты/сведения"; - как они соотносятся с конфигурациями "Конвертация данных (2 и 3)" и "Система проектирования прикладных решений"; - причем здесь паттерн программирования Модель-Представление-Контроллер (MVC) и расширение “Характеристики” языка запросов СКД; - по-новому посмотрим на периодические независимые регистры сведений и возможности их использования. Коснемся вопросов интеграции такого рода систем с внешними, в частности использование пакетов\фабрик XDTO, проведём аналогии с пакетом EnterpriseData (универсальный формат обмена данными). Обозначим области применения таких систем и их ограничения, в частности возможные подходы к решению проблем версионирования, производительности, обеспечения целостности данных и специфику формирования отчетов. Рассмотрим практический опыт разработки/внедрения/сопровождения подобной структурно-независимой формации на примере запатентованного продукта учета ресурсов системы здравоохранения и его механизмов интеграции с федеральным сервисом Единой Государственной Информационной Системы Здравоохранения в разрезе Федерального Регистра Медицинских Работников и других регистров. Поговорим об использовании этих идей в целях: - прототипирования информационных систем на этапе сбора/анализа требований, - построения экспертных систем поддержки принятия решений (ЭСППР) на базе описанной архитектуры.

Акт сверки взаиморасчетов для ТиС 7.7

Отчеты - Бухгалтерские

Формирование и печать акта сверки взаиморасчетов с контрагентами по данным учета конфигурации "Торговля и склад" 7.7.

Краткое описание: формирование и печать акта сверки взаиморасчетов с контрагентами.
Параметры:
-    установка периода;
-    выбор контрагента;
-    печать отчета.
Описание функционала:
-    по умолчанию при открытии отчета заполняются поля:
 ×    организация: наша организация;
 ×    валюта: рубль;
 ×    дата подписания акта: текущая дата;
 ×    место подписания акта;
 ×    ФИО руководителя (с нашей стороны);
 ×    должность руководителя (с нашей стороны): Директор.
-    контрагент для сверки – выбирается из справочника «Контрагенты»;
-    если акт сверки согласован с контрагентом – нужно установить соответствующую «галочку». Заполняются колонки «Дебет» и «Кредит» по данным учета контрагента;
-    можно заполнить поля для подписи со стороны контрагента – ФИО и должность;
-    реализовано 2 печатные формы: стандартная и не стандартная.

Обрабатывается 2 регистра (в зависимости от признака контрагента):

- для поставщика - "Поставщики";

- для покупателя - "Покупатели".

В обработке используется самописная функция глобального модуля:

Функция глУдалениеВедущихНулей(мКод) Экспорт

Пока Лев(мКод, 1) = "0" Цикл
мКод = Сред(мКод, 2);
КонецЦикла;

Возврат мКод;

КонецФункции // глУдалениеВедущихНулей
Функция глКонтрагентПоставщик(мКонтрагент) Экспорт

СпрКонтрагенты = СоздатьОбъект("Справочник.Контрагенты");

СпрКонтрагенты.НайтиПоНаименованию("Поставщики");

ГруппаПоставщиков = СпрКонтрагенты.ТекущийЭлемент();

Если мКонтрагент.ПринадлежитГруппе(ГруппаПоставщиков) = 1 Тогда
Возврат 1;
Иначе
Возврат 0;
КонецЕсли;

КонецФункции //

Скачать файлы

Наименование Файл Версия Размер
АктСверкиВзаиморасчетов.ert
.ert 226,00Kb
23.12.16
63
.ert 226,00Kb 63 Скачать

См. также

Комментарии
Сортировка: Древо
1. join2us 8 08.09.14 10:10 Сейчас в теме
Ошибки.... ТИС 9.2 (7.70.949). Что делать-то?

Поставщик = глКонтрагентПоставщик<<?>>(СписокКлиентов);
{R:\TORGS\EXTFORMS\АКТСВЕРКИВЗАИМОРАСЧЕТОВ.ERT(6)}: Функция не обнаружена (глКонтрагентПоставщик)
ПечДокумент = СокрЛП(мДокумент) + " № " + глУдалениеВедущихНулей<<?>>(НомерДок);
{R:\TORGS\EXTFORMS\АКТСВЕРКИВЗАИМОРАСЧЕТОВ.ERT(125)}: Функция не обнаружена (глУдалениеВедущихНулей)
ПечДокументПолностью = СокрЛП(глНазваниеДокументаВЖурнале(Запрос.Док)) + " № " + глУдалениеВедущихНулей<<?>>(НомерДок);
{R:\TORGS\EXTFORMS\АКТСВЕРКИВЗАИМОРАСЧЕТОВ.ERT(128)}: Функция не обнаружена (глУдалениеВедущихНулей)
СокрЛП(глУдалениеВедущихНулей<<?>>(ДокОснование.НомерДок)) + " от " + ДатаСчета;
{R:\TORGS\EXTFORMS\АКТСВЕРКИВЗАИМОРАСЧЕТОВ.ERT(136)}: Функция не обнаружена (глУдалениеВедущихНулей)
СтрокаДопДок = глНазваниеДокументаВЖурнале(СФ) + " № " + глУдалениеВедущихНулей<<?>>(СФ.НомерДок);
{R:\TORGS\EXTFORMS\АКТСВЕРКИВЗАИМОРАСЧЕТОВ.ERT(147)}: Функция не обнаружена (глУдалениеВедущихНулей)
2. АннаШ 103 08.09.14 18:28 Сейчас в теме
(1) join2us,
Функция глУдалениеВедущихНулей(мКод) Экспорт

Пока Лев(мКод, 1) = "0" Цикл
мКод = Сред(мКод, 2);
КонецЦикла;

Возврат мКод;

КонецФункции // глУдалениеВедущихНулей
Функция глКонтрагентПоставщик(мКонтрагент) Экспорт

СпрКонтрагенты = СоздатьОбъект("Справочник.Контрагенты");

СпрКонтрагенты.НайтиПоНаименованию("Поставщики");

ГруппаПоставщиков = СпрКонтрагенты.ТекущийЭлемент();

Если мКонтрагент.ПринадлежитГруппе(ГруппаПоставщиков) = 1 Тогда
Возврат 1;
Иначе
Возврат 0;
КонецЕсли;

КонецФункции // глКонтрагентПоставщик

Функции глобального модуля.
Можно и в обработку вставить.
Оставьте свое сообщение