Расширенная настройка прав пользователей

Публикация № 20129 26.05.09

Системное администрирование - Информационная безопасность

Гибкая настройка прав пользователей в режиме Предприятие.
Подобных разработок много, но из существующих полностью не удовлетворила ни одна, поэтому изобрел свой "велосипед".
Позволяет ограничить доступ для отдельных пользователей (и групп пользователей) к конкретным видам метаданных (константы, справочники, документы) по различным видам доступа (дата запрета редактирования для каждого вида документа, ввод нового, редактирование, проведение/отмена проведения, пометка на удаление/снятие пометки и т.д.) с использованием иерархии.
Есть возможность назначить ответственных пользователей, которые могут редактировать права других пользователей. Отредактированные права начинают действовать немедленно - не требуется выход и повторный вход в базу 1С.
Возможно внедрение с минимальными изменениями конфигурации: одна новая константа, один новый справочник, изменение функций глобального модуля (без изменения кода модулей объектов метаданных)
Не использует никаких ВК.

Наиболее подходящая по идеологии оказалась эта разработка: //infostart.ru/projects/1034 (за что спасибо ее автору!)

Для доработки используемой вами конфигурации необходимо использовать выложенную здесь демо-конфигурацию. Демо-конфигурация сделана на базе типовой бухгалтерии 77, но легко внедряется в любые другие типовые и нетиповые конфигурации.

Порядок внедрения:

1) добавьте в используемую конфигурацию справочник Пользователи (рекомендуется его добавить через режим объединение конфигурации с моей демкой, чтобы импортировать картинки кнопок)

2) добавьте константу ПраваПользователяПоУмолчанию (можно копи-пастом)

3) Добавьте общие реквизиты документов Автор и ДатаСоздания. Внимание! После добавления переставьте имеющиеся общие реквизиты типа Строка неогр. длины (напр., "Комментарий") в конец списка общих реквизитов - это критично, если база SQL.

4) в глобальном модуле добавьте (измените, если уже существуют) следующие функции и процедуры (возьмите их из глоб. модуля моей демки):

глУстановкаТекущегоПользователя,
глНаборПравОбъекта,
глПолучитьПраво,
ПравоИзмененияДокумента,
глМожноЗаписатьЭлемент,
ПриУдаленииЭлемента,
глМожноПроводить,
ПриИзмененииВремениДокумента,
ДатаЗапретаРедактирования,
глПроверкаРазрешенияРедактирования,
глМожноЗаписатьДокумент,
ПриУдаленииДокумента,
ПриОтменеПроведенияДокумента,
ПриВыклВклПроводокОперации,
ПриЗаписиКонстанты,
ПриЗаписиИстории,
глДействия.

5) проверьте, что во всех документах есть процедуры ПриОткрытии и ПриЗаписи, в которых содержится следующий код (в типовой бух 77 он есть обязательно), в качестве примера см. документ Новый1 в моей демке:

Процедура ПриОткрытии()
ПриЗаписиПерепроводить(1);
глПроверкаРазрешенияРедактирования(Контекст); //<- используется с целью проверки Прав доступа

Если Форма.ТолькоПросмотр() = 1 Тогда
Форма.КнопкаОК.Доступность(0);
КонецЕсли;
//...
КонецПроцедуры

//_____________________________________________________________________________
Процедура ПриЗаписи() //предопределенная
Если глМожноЗаписатьДокумент(Контекст) = 0 Тогда //<- используется с целью проверки Прав доступа
СтатусВозврата(0);
Возврат;
КонецЕсли;

//....
КонецПроцедуры

6) в форме документа Операция измените процедуры ПриЗаписи и ПриОткрытии, руководствуясь примером документа Операция моей демки

7) в интерфейсе пользователей предусмотрите вызов справочника Пользователи

В принципе, это всё, что необходимо для минимальной доработки конфигурации, чтобы запустить Расширенную настройку прав доступа. Но при этом будет недоступна настройка некоторых прав, а именно:
для справочников: Ввод нового, Редактирование, Перенос в другую группу;
для документов: Проведение
(В коде модуля формы списка справочника Пользователи эти права у меня отмечены: //*)

Для того чтобы эти права стали доступными необходимо произвести более глубокие изменения конфигурации:

8) во всех формах списков всех справочников добавить (изменить) предопределенные процедуры ПриЗаписи и ПриПереносеВДругуюГруппу (в качестве примера см. в моей демке справочники Пользователи и Банки):

Процедура ПриЗаписи() //<- добавлено с целью проверки Прав доступа
Если глМожноЗаписатьЭлемент(Контекст) = 0 Тогда
СтатусВозврата(0);
Возврат;
КонецЕсли;
КонецПроцедуры

Процедура ПриПереносеЭлементаВДругуюГруппу(Элем, Группа) //<- добавлено с целью проверки Прав доступа
Если глМожноЗаписатьЭлемент(Контекст,"ПереносВДругуюГруппу") = 0 Тогда
СтатусВозврата(0);
Возврат;
КонецЕсли;
КонецПроцедуры

9) во всех формах элемента и группы всех справочников добавить (изменить) процедуры ПриЗаписи (тот же пример в моей демке)

Процедура ПриЗаписи()
Если глМожноЗаписатьЭлемент(Контекст) = 0 Тогда //<- добавлено с целью проверки Прав доступа
СтатусВозврата(0); //<- добавлено с целью проверки Прав доступа
Возврат; //<- добавлено с целью проверки Прав доступа
КонецЕсли; //<- добавлено с целью проверки Прав доступа
КонецПроцедуры // ПриЗаписи()

10) В модулях проведения всех документов в начале процедуры ОбработкаПроведения() добавить код (см. документ Новый1 в моей демке):

Если глМожноПроводить(Контекст) = 0 Тогда //<- добавлено с целью проверки Прав доступа
СтатусВозврата(0);
Возврат;
КонецЕсли;

11) Для большей красивости можно во всех журналах документов добавить графу Автор (см. пример Журналы документов - Общий), а на форме всех документов добавить надпись Автор (см. диалог формы документов Новый1 и Операция)

12) Во всех обработках, изменяющих объекты программно (например, в типовой бух 77 это обработки ОбработкаДокументов и ФормированиеНалоговыхДокументов) предусмотреть проверку расширенных прав пользователей (у меня такого примера пока не предусмотрено).
В частности, в типовых конфигурациях необходимо изменить обработку "ЗначенияПериодическихРеквизитов" - предусмотреть проверку прав пользователей при попытке удаления значений периодических реквизитов. Для этого в начале процедуры УдалитьЗначения() нужно добавить код:

 НаборПрав = глНаборПравОбъекта(глПользователь,"Справочник."+ТекущийОбъект.Вид());//начало //<- добавлено с целью проверки Прав доступа
 Если глПолучитьПраво(НаборПрав,"Редактирование")="-" тогда //запрещено
  Предупреждение("Нет прав редактировать это значение!");
  СтатусВозврата(0);
  Возврат  
 КонецЕсли; //конец //<- добавлено с целью проверки Прав доступа

Порядок использования:

Настройка прав пользователей осуществляется через вызов справочника Пользователи. При первом входе в систему создается новый элемент справочника, реквизиты Код и Наименование которого заполняются именем пользователя, заданным в конфигураторе. При этом если задана константа ПраваПользователяПоУмолчанию, то ему присваивается набор прав, заданных пользователю в этой константе.

Права пользователей можно настраивать иерархически, т.е. можно завести группы пользователей по определенному критерию (напр., повторить названия прав, заданных в конфигураторе) и на эти группы назначить права. Права групп, распространяются на пользователей группы, если они не переопределены правами, заданными для конкретных пользователей группы. Права групп пользователей действуют согласно уровням групп (которые можно назначить сколь угодно вложенными, я в конфигураторе задал - 3, можно изменить). Приоритет имеют права, заданные для более вложенной группы или конкретного пользователя. Перемещая пользователя из группы в группу, можно менять его права.

Для каждого пользователя (группы пользователей) задан список объектов и права этих объектов.
Список объектов:
Общие, Константа, Справочник, Документ.

Объекту Общие соответствует только одно право (пока): Редактирование прав пользователей. Оно определяет, может ли данный пользователь системы заниматься установкой и редактированием прав пользователей (себя и других)

Объекту Константа соответствует право: Редактирование. Оно определяет право доступа сразу ко всем константам. Для того чтобы, это право установить для конкретных констант, надо развернуть объект Константа и кнопкой "+" добавить нужные имена констант. Т.о. права можно устанавливать в целом на объект и на виды данного объекта.

Объекту Справочник соответствуют права (знаком * отмечены права, которые недоступны при минимальной доработки конфигурации):
Ввод нового //*
Редактирование //*
Перенос в другую группу //*
Пометка на удаление
Снятие пометки на удаление.

Также как и для констант, можно задавать права и для конкретных видов справочников, добавляя их кнопкой "+". Установка этих прав для справочника Пользователи, по сути, дублирует право "Общие.РедактированиеПравПользователей".

Объекту Документ соответствуют права:
Дата запрета редакт.
Дней доступа
Доступ к чужим документам (автором которых Вы не являетесь)
Ввод нового
Редактирование проведенного
Редактирование непроведенного
Изменение времени
Проведение документа //*
Отмена проведения документа
Пометка на удаление
Снятие пометки на удаление.

Также как и для справочников, можно задавать права и для конкретных видов документов, добавляя их кнопкой "+".

Установка всех прав (кроме "Дата запрета редакт." и "Дней доступа") сводится к установке одного из трех значений "+", "-" и "пусто".
"+" - разрешено данное действие (если оно конечно не запрещено правами на уровне конфигуратора);
"-" - запрещено данное действие;
"пусто" - действие не определено, оно будет определяться правом, заданном для данного действия на других уровнях иерархии прав (права объектов/видов, права пользователей/групп пользователей).

Приоритет имеют права, заданные для конкретных видов, перед правами, заданными в целом на объект.
Права, определенные для конкретного пользователя имеют приоритет над правами, заданными для группы пользователей.
В случае если на объект действуют несколько противоречащих прав, то в итоге действовать будет наиболее запрещающее.
Отдельно стоит отметить о действии даты запрета редактирования документов. Для конкретного вида документа она вычисляется с использованием трех параметров:
1) Константа.ДатаЗапретаРедактирования
2) право "Дата запрета редакт."
3) право "Дней доступа".
Права "Дата запрета редакт." и "Дней доступа" имеют приоритет перед значением константы ДатаЗапретаРедактирования, даже если ее значение более запрещающее.
Если на объект не заданы никакие права, то действует права, заданные в конфигураторе (Говоря другими словами, расширенная настройка прав пользователей может лишь ограничить права, заданные в конфигураторе, но никак не может их расширить).

В форме списка Пользователей существует возможность:
1) очистить набор прав пользователей;
2) задать набор прав пользователей, используя в качестве образца права другого пользователя (группы пользователей) - скопировать
3) распечатать полный набор прав с учетом иерархии, действующий на выделенного пользователя (группу пользователей)

В форме журналов документов и в самих документах в типовых конфигурациях есть кнопка Действия. В список действий добавлен новый пункт "Автор документа". Выбор этого пункта покажет автора текущего документа, дату создания документа и набор прав, действующих на данный вид документов для этого автора.

-----------------------------------------------------------------------------------
Более подробно опишу систему правил позже, сейчас нет времени.

Планы доработок на будущее:
1) избежать сильного изменения конфигурации при внедрении системы прав (видимо, буду использовать ВК 1С++);
2) расширить иерархию прав доступа (например, создавая произвольные группы, объединяющие список справочников, документов);
3) увеличить объекты прав, добавив права на действия над счетами ПланаСчетов, права на запуск встроенных Отчетов, Обработок;
4) добавить возможность установки прав на изменение конкретных реквизитов объектов (справочников, документов);
5) создать менеджер внешних отчетов, настраивающий права использования внешних отчетов (заменив Сервис - Дополнительные возможности).

 

Скачать файлы

Наименование Файл Версия Размер
-

.1243311325 40,47Kb
806
.1243311325 40,47Kb 806 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. Romarius 15 26.05.09 10:34 Сейчас в теме
2. Свой 164 26.05.09 12:17 Сейчас в теме
Спасибо за разработку, если можно, задам вопросы по внедрению этой системы:
1. кто значально был постановщиком задачи ? (руководство, отдельный ответственный работник), в каком виде ставлась задача - кратком или подробном?
2. как восприняли работу системы те, кого ограничивают - операторы, менеджеры?
3. сложно ли осваивалась система руководством, настраивают ли они сами доступы ?
4. каков уровень удовлетворенности заказчиков этой системы в вашем случае ?
3. victuan 4132 26.05.09 13:45 Сейчас в теме
(2):
1) По совместительству на этом предприятии я не только программист, но и постановщик учета. Задачу поставил я.
2) Пока об этом говорить рано. Разработка системы началась 22.05.09 (4 дня назад), закончена сегодня и внедрена на предприятии (т.е. это бета-версия). Поэтому никто еще ничего не почувствовал. Следующим шагом будет тотальное ужесточение всех прав, чтобы методом проб и ошибок вычислить оптимальный набор прав пользователей (принип прост, если пользователю дать лишние права изначально, он промолчит, если забрать, он прибежит и начнет их (права) качать)
3) инструкцию по настройке я отдал сегодня гл. бухгалтеру, время покажет как она справится
4) об этом говорить еще рано. Но думаю результат удовлетворит многих: и постановщика учета и потребителей системы.
Stеls; Свой; +2 Ответить
4. Shaman342 26.05.09 13:58 Сейчас в теме
(3) можно ли инструкцию по настройке в студию? ... чтобы не изобретать велосипед ;)
6. victuan 4132 26.05.09 14:02 Сейчас в теме
(4) Инструкция по настройке в описании сабжа (начиная со слов "Настройка прав пользователей осуществляется через вызов справочника Пользователи...").
Другой пока нет ;)
5. artbear 1414 26.05.09 14:02 Сейчас в теме
>>Планы доработок на будущее:
>>1) избежать сильного изменения конфигурации при внедрении системы прав
>>(видимо, буду использовать ВК (формекс?))
Рекомендую юзать ВК 1С++.

В этой ВК я специально для подобных задач реализовал класс Перехватчик - универсальный перехват практически любых событий 1С и различных ВК без переписывания кучи кода в конфигурации.

Читай доку на 1С++ 3.0.1.ХХХ и форум компоненты на 1cpp.ru

ЗЫ я специально делал этот объект, потому что надоело для каждого метаданного прописывать спец.код в модуле формы и модуле документа.

Очень рекомендую.
8. victuan 4132 26.05.09 14:04 Сейчас в теме
(5) Спасибо за рекомендации, наверное, я так и сделаю. И даже, наверное, класс ВыполняемыйМодуль задействую, чтобы можно было задавать в пользовательском режиме произвольное условие на право доступа.
9. artbear 1414 26.05.09 15:13 Сейчас в теме
(8) Да, для произвольных условий ВМ весьма удобен.
14. artbear 1414 27.05.09 09:05 Сейчас в теме
15. victuan 4132 27.05.09 09:13 Сейчас в теме
(14) Попозже посмотрю. Блиц-вопрос по перехватчику: он позволяет перехватить метода объекта, выполнить код, а затем продолжить выполнение перехваченного метода?
16. Ёпрст 1057 27.05.09 09:14 Сейчас в теме
18. victuan 4132 27.05.09 09:22 Сейчас в теме
(14) Посмотрел доку, что-то лениво разбираться, примерчик бы живой.
19. Ёпрст 1057 27.05.09 09:25 Сейчас в теме
(18) смотри Undo в моём профиле, например.
21. artbear 1414 27.05.09 10:09 Сейчас в теме
(18) Или юзай поиск в форуме 1cpp.ru по слову Перехватчик, примеров там море + ! разбор ошибок использования Перехватчика ! :)
7. artbear 1414 26.05.09 14:04 Сейчас в теме
(5+) Перехватчик как раз позволяет избежать "идиотского" для подобных задач встраивания спец.кода во все формы :(
10. alexk-is 6556 26.05.09 18:59 Сейчас в теме
(0) Может быть текст процедур раскрасить?
11. victuan 4132 27.05.09 05:58 Сейчас в теме
(11) В описании разработки? Раскрасил.
12. Ёпрст 1057 27.05.09 08:57 Сейчас в теме
13. victuan 4132 27.05.09 09:03 Сейчас в теме
(12) Набор прав пользователя: [Вася]:*
Звездочка (*) дает мне право утверждать, что набор прав не записан для текущего пользователя, следовательно, не действует.
Для того, чтобы записать изменения набора прав нужно нажать кнопку с изображением дискеты.
20. victuan 4132 27.05.09 09:59 Сейчас в теме
А перехватчик умеет перехватывать события, не объявленные в форме объекта (напр., проц. ПриЗаписи используется не во всех справочниках, а интерактивную запись нужно перехватывать везде)
23. Ёпрст 1057 27.05.09 10:15 Сейчас в теме
(20) Конечно! Перехватывает не их, но еще и все события формекса...
25. artbear 1414 27.05.09 10:17 Сейчас в теме
(20) Да, в этом вся прелесть/фича Перехватчика - что для нормальной работы универсальной механизмов совершенно не нужно прописывать обработчики событий в каждой форме, а достаточно определить их на верхнем уровне.
Любое перехваченное событие в Перехватчике можно отменить, не пропустив на следующий уровень, например, в модуль конкретной формы - т.е. полное управление на разработчике.
22. artbear 1414 27.05.09 10:11 Сейчас в теме
(0) Кстати, на этом сайте уже вроде выкладывался пример работы с правами для 77 на базе Перехватчика.
Правда, ссылку не помню.
На форуме 1С++ в разделе Репозитарий точно есть.
24. Ёпрст 1057 27.05.09 10:16 Сейчас в теме
26. artbear 1414 27.05.09 10:19 Сейчас в теме
(23+) Перехватчик перехватывает не только штатные события 1С, как форм, так и глобальника, но и все события ФормЕкс, а также события других ВК, реализованные аналогично событиям 1С и ФормЕкс - например, события ВК RIK_SQL, RWidjets.
Причем код классов перехватчиков совершенно не зависит от этих ВК, все универсально.
27. Alex1c 21 27.05.09 10:35 Сейчас в теме
"5) создать менеджер внешних отчетов, настраивающий права использования внешних отчетов (заменив Сервис - Дополнительные возможности)."
Рекомендую ознакомиться с http://www.infostart.ru/profile/1723/projects/615/
использую уже давно, полностью устраивает. Решение весьма продумано и оригинально
29. victuan 4132 27.05.09 10:43 Сейчас в теме
(27) Спасибо за ссылку! Вещь, судя по описанию, хорошая!
Я же хотел просто интегрировать нечто подобное с моим справочником пользователей.
28. artbear 1414 27.05.09 10:41 Сейчас в теме
(27+) Ага, Навигатор рулит, очень удобно.
30. victuan 4132 28.05.09 05:17 Сейчас в теме
Обновил демо-конфигурацию: исправил ошибки:
1) не учитывались мгновенно изменения прав пользователя при переносе в другую группу
2) При создании нового пользователя он автоматически помещается в группу пользователя Константа.ПраваПользователяПоУмолчанию
31. victuan 4132 29.05.09 08:10 Сейчас в теме
Обновил демо-конфигурацию: исправил ошибку:
3) При вводе нового документа копированием неверно устанавливались Автор и Дата создания документа
32. victuan 4132 01.06.09 08:03 Сейчас в теме
Обновил демо-конфигурацию: исправил ошибки:
4) глюки интерфейса (ошибки отображения при редактировании дерева набора прав)
5) при удалении проведенного документа проверяется дополнительно право "ОтменаПроведения"
33. victuan 4132 24.06.09 06:11 Сейчас в теме
Обновил демо-конфигурацию: исправил ошибку:
6) для новых документов не проверялось право "Дата запрета редактирования".

ЗЫ: как видите на практике обработка активно используется. Но руки прикрутить 1с++ пока не доросли, т.к. в моей деятельности достаточно уже имеющегося функционала.
34. DeepDiver 5 29.07.09 17:56 Сейчас в теме
Рарус Администратор не смотрели?
35. victuan 4132 30.07.09 09:39 Сейчас в теме
(34) Нет, и почему-то не хочется что-либо от Раруса смотреть.
36. DeepDiver 5 30.07.09 14:35 Сейчас в теме
А зря! Отличная администрилка для 77 не защищённая никакими ключами...
37. rosalin 13.10.09 22:37 Сейчас в теме
Спасибо! Отличная обработка давно ищу что то подобное , возможно ли доработать что бы можно было выставлять ограничение прав на группу или строку справочника :?:

38. anig99 2815 13.10.09 23:49 Сейчас в теме
(37) перейдите на 8.1 Там есть RLS (;
39. rosalin 14.10.09 09:10 Сейчас в теме
(38) Спасибо конечно но ищу более радикальное решение на 8.1 нет технической возможности перейти
40. victuan 4132 27.10.09 16:42 Сейчас в теме
(37) Да, у меня в планах стоит контроль прав с точностью до групп и элементов справочника, а также с точностью до реквизитов объектов.
Вопрос в том, когда руки найдут свободное время это реализовать.
41. yanis 28.10.10 13:59 Сейчас в теме
(40) Эту идею удалось реализовать? Если да - то можете выложить?
42. victuan 4132 28.10.10 16:31 Сейчас в теме
(41) Пока не реализовал. Возможно займусь этим в межотчетное время.
43. Timson1234 17.01.12 17:20 Сейчас в теме
Спасибо большое, очень помогло)
44. пользователь 29.01.12 23:09
Сообщение было скрыто модератором.
...
45. victuan 4132 30.01.12 04:28 Сейчас в теме
(44)Это что? Клоны тупым копипастом моих сообщений набирают себе балы? Модераторов прошу обратить внимание!
46. das58 19.11.13 12:31 Сейчас в теме
Отлично! Еще бы инсталлятор к ней, чтоб прописывал все эти процедуры сам. Где-то недавно попадалась разработка, которая во внешние отчеты засовывает необходимый код.
47. JuliettT 10 21.07.15 08:39 Сейчас в теме
Нужен такой же для 8.2 Ут, может есть у кого на сайте?
48. victuan 4132 12.01.22 20:11 Сейчас в теме
(0) Кстати, в форме списка справочника Пользователи, в функции ДобавитьПозицию() - ошибка.
Правильный вариант должен быть таким:

// ----------------------------------------------------
Процедура ДобавитьПозицию()
	Если глМожноЗаписатьЭлемент(Контекст) = 0 Тогда
		Возврат;
	КонецЕсли;

	НомСтр = 0; ВыбКод = лев(ВыбКод,3)+"000000";
	Если ВремТаблица.НайтиЗначение(ВыбКод,НомСтр,"Код")=1 тогда    
		Вид = ВремТаблица.ПолучитьЗначение(НомСтр,"Название");
		НомСтр = 0; ДобТЗ = Вид_Загр_Все(Вид);
		Если ДобТЗ.ВыбратьСтроку(НомСтр)=1 тогда
			Ид = ДобТЗ.ПолучитьЗначение(НомСтр,"Идентификатор");
			НомСтр = 0;
			Если ВремТаблица.НайтиЗначение(ВыбКод, НомСтр, "Код") > 0 Тогда 
				КолвоЭлемГруппы = КоличествоЭлементовГруппы(ВремТаблица, ВыбКод, НомСтр)-1;
				//ПослКод=ВремТаблица.ПолучитьЗначение(НомСтр+КолвоЭлемГруппы,"Код" );
				СпНом = СоздатьОбъект("СписокЗначений"); //составим список задействованным номеров по порядку
				Для й = НомСтр+1 по НомСтр+КолвоЭлемГруппы Цикл
					СпНом.ДобавитьЗначение(число(Сред(ВремТаблица.ПолучитьЗначение(й,"Код"),4,3)))
				КонецЦикла;
				ПослКод = 0;
				Для й = 1 по 999 Цикл
					Если СпНом.НайтиЗначение(й) = 0 Тогда
						ПослКод = й;
						Прервать
					КонецЕсли
				КонецЦикла;
				Если ПослКод = 0 Тогда
					сообщить("Нет возможности добавить строку!");
					Возврат
				КонецЕсли;
				//НовКод = лев(ВыбКод,3)+Формат(КолвоЭлемГруппы+1,"Ч(0)3")+"000";
				НовКод = лев(ВыбКод,3)+Формат(ПослКод,"Ч(0)3")+"000";
				ВремТаблица.НоваяСтрока(НомСтр+КолвоЭлемГруппы+1);
				ВремТаблица.Код = НовКод;
				ВремТаблица.Уровень = 2;
				ВремТаблица.ЭтоГруппа = 0;
				ВремТаблица.Статус = 3;
				ВремТаблица.Название = Вид+"."+Ид;
				ВремТаблица.Параметры = ""; 
				ДобавитьСтрокуВТаблицу(НомСтр+КолвоЭлемГруппы+1); 
				НаборПрав.ТекущаяСтрока(НаборПрав.КоличествоСтрок());
				ДоступностьЭлементов();                              
				
				ТекИзм = 1;
				
			КонецЕсли;
		КонецЕсли;
	КонецЕсли;
КонецПроцедуры // ДобавитьПозицию()
Показать
Оставьте свое сообщение

См. также

Мониторинг учетных записей пользователей Windows Server 2008/2012 Промо

Разработка внешних компонент Информационная безопасность Россия Абонемент ($m)

Программа позволяет отслеживать журнал событий безопасности действий над учетными записями пользователей (удаление, создание, блокировка, смена пароля и т.д.), и отправлять на E-mail уведомление системному администратору в случае изменения конфигурации пользователей Windows Server.

3 стартмани

10.09.2020    5369    0    ClickUp    0    

Двухфакторная аутентификация (8.3.21)

Информационная безопасность Пароли Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Недавно в 1С появилась возможность двухфакторной аутентификации. Пример такой аутентификации можно увидеть при входе в клиент-банках (когда вначале пользователь вводит логин-пароль, а затем ему прилетает смс). Как это все настроить, мы и разберем. Кроме настройки авторизации приложил простенькую конфигурацию с http-сервисом и telegram-ботом, который будет присылать коды доступа.

1 стартмани

18.05.2022    4096    15    vov4ik1212    19    

Снятие блокировки на редактирование справочников в типовых конфигурациях

Информационная безопасность Платформа 1С v8.3 1С:ERP Управление предприятием 2 Абонемент ($m)

В процессе работы с типовыми решениями от 1С приходится постоянно разблокировать реквизиты справочников и некоторых ПВХ. Это, прямо скажем, утомляет, когда работа идет в тестовой базе. Публикация позволяет снять ограничение либо совсем, либо в рамках сеанса. Работает полноценно платформе версии не ниже 8.3.16 и конфигурации ERP 2.5. Работает также на 8.3.14 и ERP 2.4 с ограничениями.

1 стартмани

28.03.2022    4797    12    kser87    18    

Локальная файловая система из 1С, как это работает.

Информационная безопасность Универсальные обработки Файловые протоколы обмена (TXT, XML, DBF), FTP Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Внешняя обработка для работы с файлами из 1С по типу FAR или Norton Commander, Total Commander и немного занудной философии. Работает 8.3.15 и выше. Работает в тонком, толстом, Web и мобильном клиенте. Поставляется отдельным файлом можно включить куда угодно, зависит только от платформы 1С.

1 стартмани

17.09.2020    30897    11    Patriot1S    10    

Просмотр прав пользователей Промо

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка наглядно показывает права доступа конкретного пользователя или роли к конкретному объекту метаданных.

1 стартмани

19.10.2012    38652    308    NILS2009    17    

Автоматическая блокировка интерфейса 1С при простое в работе пользователя

Информационная безопасность Управляемые формы Конфигурации 1cv8 Россия Абонемент ($m)

Простой способ реализации автоматической временной блокировки интерфейса программы при низкой активности пользователя некоторое время.

1 стартмани

28.08.2019    14149    17    shalex5    0    

PowerShell из 1С: создание пользователя Active Directory

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Пример создания пользователя Active Directory с помощью PowerShell из 1С.

3 стартмани

27.08.2019    17763    36    wowik    14    

Копирование настроек профилей группы доступа из одной базы в другую. 1С: Предприятие 8.3 БП 3.0, ЗУП 3.1, ЕРП 2.4 и т.д.

Информационная безопасность Платформа 1С v8.3 1С:ERP Управление предприятием 2 1С:Бухгалтерия 3.0 1С:Зарплата и Управление Персоналом 3.x Россия Абонемент ($m)

Иногда необходимо состав ролей профиля группы доступа перенести из одной базы 1С в другую быстро, а если таких баз 20-30, то сидеть и выбирать нужные роли руками это проблематично и долго. Для этого была разработана данная обработка. Проверялось на релизах: Платформа 1С: Предприятие 8.3.14.1630; 1С: ЗУП 3.1.9.229 и выше; 1С: ERP 2.4.5.54.

1 стартмани

02.08.2019    9914    122    mityushov.vv    10    

Отключение доступа уволенным пользователям Промо

Информационная безопасность Обработка справочников Инструменты администратора БД Платформа 1С v8.3 Управление правами 1С:Бухгалтерия 2.0 1С:Управление производственным предприятием Абонемент ($m)

Давно хотели навести порядок в пользователях? Надоело, что в списке мешаются давно уволенные сотрудники? Тогда эта обработка для Вас!

3 стартмани

15.10.2013    59701    114    VBod    17    

Вход в программу под нужным пользователем из карточки пользователя [Расширение]

Информационная безопасность Управляемые формы Управление правами Конфигурации 1cv8 Абонемент ($m)

При проверке прав пользователей и тестировании требуется быстро войти в программу под пользователем (не меняя пароль пользователю). Для этого в карточку пользователя добавлена кнопка "Запустить сеанс".

1 стартмани

03.07.2019    7661    26    WinnerOnLine    3    

Доступ пользователей только к собственным документам/сделкам

Информационная безопасность Оптовая торговля Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Абонемент ($m)

Расширение блокирует доступ менеджеров по продажам к чужим документам. Ограничивает работу менеджера только собственными сделками, не позволяя просматривать сделки других менеджеров. Действует на счета, счета-фактуры и реализации.

2 стартмани

25.05.2019    14848    27    denmax    13    

БСП: Быстрая проверка прав доступа на объект метаданных (УФ)

Информационная безопасность Платформа 1С v8.3 Управляемые формы Управление правами Конфигурации 1cv8 Абонемент ($m)

Чем старше и новее становятся конфигурации на базе платформы 1С, тем больше в них ролей. Плюс к этому, к типовым ролям зачастую прибавляются нетиповые. Обработка позволяет быстро посмотреть, каким ролям выдано то или иное право на указанный объект метаданных.

1 стартмани

18.04.2019    7542    24    Skin123    0    

Подсистема динамических прав

Информационная безопасность Управление правами Конфигурации 1cv8 Абонемент ($m)

Подсистема прав, позволяющая в реальном времени (без назначения ролей, перезапуска 1с, изменения конфигурации) менять права пользователя: Просмотр, Создание, Изменение, Проведение, Отмена проведения, Изменение проведенных, Неоперативное проведение. Существенно упрощает управление правами в базах с большим количеством пользователей. Версия платформы 8.3.12.1685.

2 стартмани

10.04.2019    13713    21    itmind    53    

PasswordHashViewer - просмотр хэшей пользовательских паролей

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Программа для просмотра хэшей паролей пользователей в файловых и клиент-серверных базах 1С. Зачем это нужно? Для их проверки на криптостойкость.

1 стартмани

25.02.2019    10957    16    GeraltSnow    6    

Обезличивание базы ЗУП 3.1.*

Информационная безопасность Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и Управление Персоналом 3.x Абонемент ($m)

Обработка по перемешиванию/скрытию конфиденциальной информации в базе ЗУП.

1 стартмани

05.02.2019    16933    105    Skin123    19    

Права пользователей Промо

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Кросс-таблица прав пользователей (подсистема "Управление доступом")

1 стартмани

10.05.2016    34368    107    inspam    4    

Наводим порядок в Active Directory с помощью ЗУП / ЗИКГУ 3.1 (идентификация, отключение и актуализация учетных записей пользователей)

Информационная безопасность Инструменты администратора БД Платформа 1С v8.3 Сложные периодические расчеты 1С:Зарплата и кадры бюджетного учреждения 1С:Зарплата и Управление Персоналом 3.x Россия Абонемент ($m)

Продолжаем использовать ЗУП 3.1 совместно с LDAP во имя автоматизации работы системного администратора. В этот раз займемся аудитом учетных записей. Обработка производит сопоставление учетной записи с данными сотрудников из ЗУП, причем с учетом недавних событий (для перехода на ЗУП 3.1 чаще всего используется рекомендованный перенос, не включающий уволенных сотрудников) есть возможность использовать объединенные с помощью COM-соединения данные ЗУП 2.5 и ЗУП 3.1. Также в данной обработке есть возможность массовой корректировки, заполнения данных и отключения учетных записей. Перед использованием обработки для душевного спокойствия необходимо сделать резервную копию Active Directory любым удобным способом. Протестировано на ЗУП 3.1.6 - 3.1.8.

5 стартмани

01.02.2019    16884    63    Туки Туки    15    

1С: Документооборот. Роли, использующие объекты адресации. Конфигурация остается типовой (используется расширение)

Информационная безопасность Платформа 1С v8.3 1С:Документооборот Абонемент ($m)

Расширение функционала документооборота. Реализована возможность использования ролей с объектами адресации. Конфигурация остается типовой (используется расширение)

5 стартмани

10.01.2019    22689    44    sulig    29    

Обработка запуска под пользователем без смены пароля на управляемых формах

Информационная безопасность Управляемые формы Конфигурации 1cv8 Россия Абонемент ($m)

Вариант обработки запуска сеанса под выбранным пользователем без смены пароля на управляемых формах. Может использоваться в целях отладки.

1 стартмани

08.12.2018    8702    35    user834357    7    

Права по ролям Промо

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Отчет выводит установленные права

2 стартмани

16.09.2015    28743    75    nad11    1    

Открытие проведенных документов только на чтение

Информационная безопасность Платформа 1С v8.3 Бухгалтерский учет 1С:Бухгалтерия 3.0 Абонемент ($m)

Расширение проверяет - проведен ли документ, и если он проведен - открывает документ только на чтение. Требуется внести в документ изменение - отмените проведение из списка документов и затем уже изменяйте. Предназначено для дополнительной защиты от случайного проведения документов и смещения даты последовательности проведения документов.

1 стартмани

19.11.2018    7034    11    xan333    0    

Особенность при создании своих ролей в конфигурациях на управляемых формах

Информационная безопасность Платформа 1С v8.3 Управляемые формы Управление правами Конфигурации 1cv8 Россия Абонемент ($m)

Столкнулся с небольшой проблемкой при создании "своих" ролей в конфигураторе и добавлении их пользователям. Пользователю не добавляются созданные в конфигураторе роли, 1С 8.3, Управляемые формы. Гуглил много, ответа толкового не нашёл, поэтому пришлось разбираться самому и как результат, решил поделиться опытом. Возможно, кому-то пригодится.

1 стартмани

29.10.2018    26028    19    dmitriy_saladin    18    

Программа для управления Bitlocker

Информационная безопасность Россия Абонемент ($m)

Управление Bitlocker Windows 7-10 (x32-x64), работает в WindowsPE.

1 стартмани

26.10.2018    8094    0    gortrex    0    

Анализ ролей доступа (обычная и УФ) Промо

Информационная безопасность Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Анализ ролей доступа. Определяет доступность к справочникам, документам, отчетам и т.д. Не нужно пересматривать кучу ролей, чтобы понять, что Вам нужно.

1 стартмани

25.08.2015    33354    200    fugu    9    

Запуск платформы под любым пользователем без смены пароля

Информационная безопасность Управляемые формы Конфигурации 1cv8 Россия Абонемент ($m)

Обработка позволяет запускать 1С от любого пользователя без смены пароля.

1 стартмани

12.09.2018    11374    32    bmk74    9    

Запрет на запуск более одного сеанса для одного пользователя в 1С: Предприятие 8.3 ЗУП, БП, КА, ERP, УАТ и т.д.

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Ограничение запуска 1С: Предприятие нескольких сеансов под одним пользователем. Функционал разработан через расширение, конфигурацию с поддержки снимать НЕ НУЖНО. Функционал работает в файловом и клиент-серверном варианте работы конфигурации. Платформа 8.3.12.1529 Конфигурации КА 2.4.5.71; ERP 2.4.5.54; БП 3.0.64.21; ЗУП 3.1.7.87 (это релизы на которых была произведена проверка, так же будет работать на всех стандартных конфигурациях 1С с режимом совместимости Версия 8.3.10)

1 стартмани

29.08.2018    31226    154    mityushov.vv    58    

[Расширения] Управление видимостью разделов для разных пользователей

Работа с интерфейсом Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Как скрыть/показать раздел в управляемом приложении используя расширение, на примере БП 3.0

1 стартмани

05.07.2018    21286    23    Alex_E    10    

Запуск 1С под пользователем без сброса пароля Промо

Информационная безопасность Платформа 1С v8.3 Россия Абонемент ($m)

Обработка позволяет запустить пользовательский режим 1С, не сбрасывая полностью пароль пользователя. Что очень удобно при отладке прав и RLS. Также есть возможность быстро установить пароль 123, и вернуть старый пароль вручную.

1 стартмани

18.11.2013    54019    728    mylogin    38    

Анализ и редактирование прав пользователей (управляемые формы)

Информационная безопасность Платформа 1С v8.3 Управляемые формы Управление правами Конфигурации 1cv8 Россия Абонемент ($m)

В обработке реализовано два отчета - матрица ролей (пересечение ролей и пользователей), и анализ прав на объекты в разрезе пользователей / ролей. Также есть запуск под пользователем с временной подменой пароля и редактирование прав непосредственно в матрице.

2 стартмани

03.07.2018    16092    81    axelerleo    4    

Обновление профилей доступа. БСП 2.x

Информационная безопасность Управление правами 1С:Бухгалтерия 3.0 Абонемент ($m)

Обработка, позволяющая синхронизировать роли обновляемого профиля по исходному профилю, после обновления релиза конфигурации (когда обновляемый профиль создан на основе исходного профиля).

1 стартмани

12.03.2018    12556    31    Darklight    0    

Запуск ИБ 1С под любым пользователем (только для разработчиков/администраторов)

Информационная безопасность Платформа 1С v8.3 Управление правами Конфигурации 1cv8 Россия Абонемент ($m)

Когда ведете разработку нового функционала, то есть необходимость протестировать алгоритмы под разными правами. Тогда Вам нужна данная обработка, которая ускорит процесс входа в базу под нужным пользователем.

1 стартмани

28.11.2017    14464    41    Diagnostiks    7    

Внимание! Будь осторожен - "макет" возможен. Промо

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Это не программа - это статья. И она не для руководства к действию , а как концетраптив (средство для предотвращения нежелательной головной боли). Как говорится - "Кто предупрежден - тот вооружен"

1 стартмани

18.05.2011    24519    105    Tatitutu    108    

Права на таблицы запроса у пользователя с ограниченными правами

Информационная безопасность Платформа 1С v8.3 Управляемые формы Управление правами 1С:ERP Управление предприятием 2 1С:Управление торговлей 11 Россия Абонемент ($m)

Есть ошибка у пользователя с ограниченными правами? Не знаете какие давать права на таблицы пользователям? Тогда Вам сюда!

2 стартмани

17.10.2017    12738    16    ZhokhovM    4    

Как в УТ 11 в интерфейс кассира вставить отчет о продажах

Информационная безопасность Работа с интерфейсом Кассовые операции Склад и ТМЦ Платформа 1С v8.3 Управление правами 1С:Управление торговлей 11 Россия Управленческий учет Абонемент ($m)

Как в Управление торговлей, редакция 11 (11.3.2.157), в интерфейс кассира вставить отчет о продажах. Настройка Групп доступа и прав пользователей.

1 стартмани

11.10.2017    17742    3    AlexHelmer    2    

Аутентификация под пользователем, у которого неизвестен пароль в 1С

Информационная безопасность Платформа 1С v8.3 Управление правами Конфигурации 1cv8 Абонемент ($m)

Обзор обработки, которая позволяет проходить аутентификацию без знания пароля.

1 стартмани

15.08.2017    19149    32    rybakov_ae    7    

Отчет для анализа прав доступа в разрезах Право/Объект/Роль/Профиль/Пользователь Промо

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Удобный анализ прав доступа в различных разрезах, с промежуточным кэшированием набора данных. Только для конфигураций на БСП.

1 стартмани

16.04.2015    34289    395    unichkin    16    

Создание и удаление пользователей в конфигурациях с БСП

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Быстрое создание пользователей с заранее известными правами в интерактивном режиме и из файла. По одному и списком. Быстрое удаление списком пользователей ИБ и пометка на удаление элементов справочника Пользователи.

1 стартмани

20.06.2017    14269    37    user768334    1    

Отключение защиты от опасных действий для конфигураций с БСП (управляемый и обычный режим)

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка предоставляет администратору информационной базы возможность установки и снятия защиты от опасных действий на уровне пользователей ИБ в режиме Предприятие. Требуется платформа 8.3.9 и выше

1 стартмани

18.05.2017    7821    5    ufedor    1    

Отключение/включение защиты от опасных действий пользователей

Информационная безопасность Платформа 1С v8.3 Управляемые формы Конфигурации 1cv8 Абонемент ($m)

Обработка позволяет управлять настройкой "Защита от опасных действий" пользователей информационной базы.

1 стартмани

16.05.2017    16638    35    Brawler    8    

Загрузка пользователей в Документооборот 2.х из Active Directory

Документооборот и делопроизводство Информационная безопасность Управляемые формы 1С:Документооборот Управленческий учет Абонемент ($m)

Обработка облегчит заведение новых пользователей в документооборот, в случае, если у вас есть доменный сервер (Active Directory).

2 стартмани

06.03.2017    18028    70    odineskin2    14    

Просмотр лицензий и сеансов пользователей

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Просмотр лицензий и сеансов пользователей (тонкий, толстый клиент, управляемого или обычного приложения).

1 стартмани

01.03.2017    11401    24    diletant    7    

Сравнение ролей по выгруженным из конфигураций файлам (XML). Промо

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Сравнение ролей по выгрузкам из конфигурации в файлы (XML). Для платформа 8.3, обычных и управляемых форм.

1 стартмани

05.02.2014    27050    59    KapasMordorov    8    

Отключение предупреждения безопасности при запуске внешних обработок для платформы 8.3

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

После обновления платформы на 8.3.9.2016 при запуске любого .epf файла получаем предупреждение "Предупреждение безопасности ",обработка отключает это предупреждение для удобства работы пользователей

1 стартмани

27.01.2017    32266    150    zhivil    10    

Обработка, снимающая галку "Защита от опасных действий" пользователям ИБ в платформе с 8.3.9.2033

Информационная безопасность Управление правами Конфигурации 1cv8 Россия Абонемент ($m)

Обработка группового регулирования галки "Защита от опасных действий". Если обновились на новую платформу. Если выдаются такие сообщения, как: "Рекомендуется обращать внимание на источник, из которого был получен данный файл. Если с источником нет договоренности о разработке дополнительных модулей, или есть сомнения в содержимом файла, то его не рекомендуется открывать, поскольку это может нанести вред компьютеру и данным. Разрешить подключать исполнимые бинарные файлы для данного модуля?" и так далее...

1 стартмани

23.01.2017    25288    40    snikers44    16    

"Защита от опасных действий" или как снять галочку у всех пользователей

Информационная безопасность Управление правами Конфигурации 1cv8 Абонемент ($m)

В новых версиях платформы 1С:Предприятие 8.3 (8.3.9.2033) появилась очень замечательная фишка. Реквизит у пользователя "Защита от опасных действий"

1 стартмани

17.01.2017    34609    122    Tatitutu    12    

Генератор паролей и GUID'ов универсальный (8.xx) Промо

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Лучший генератор паролей (и не только) для 1С:8

1 стартмани

15.01.2014    24706    68    ddens    0    

Копирование и редактирование пользовательских настроек

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Абонемент ($m)

Обработка используется для копирования общих настроек, настроек форм, вариантов отчетов одного пользователя другим. Также позволяет удалять и редактировать настройки. Работает в управляемом и обычном режиме на любых конфигурациях.

1 стартмани

29.09.2016    18593    145    smirnov0ser    11    

Управление доступом к документам и справочникам

Информационная безопасность Платформа 1С v8.3 1С:Бухгалтерия государственного учреждения 1С:Документооборот Абонемент ($m)

Расширение, позволяющее управлять доступом к справочникам и документам в Бухгалтерии 3.0 без изменения конфигурации информационной базы.

1 стартмани

16.09.2016    15979    70    sikvel2012    9    

Настройка прав пользователей

Информационная безопасность Платформа 1С v8.3 Конфигурации 1cv8 Россия Абонемент ($m)

Настройка прав пользователей в УТ 11.2

1 стартмани

26.08.2016    33304    35    shetill    3