Журнал кассовых операций, форма КО-3

Отчеты - Бухгалтерские

Отчет "Журнал кассовых операций, форма КО-3" с разделением по подразделениям.

Посмотрел на сайте несколько таких Отчетов, но все они были не доработанными.
Поэтому предлагаю свой отчет "Журнал кассовых операций, форма КО-3" с разделением по подразделениям.

Скачать файлы

Наименование Файл Версия Размер
Изменённая КО-3
.ert 61,50Kb
09.11.09
98
.ert 61,50Kb 98 Скачать
-
.1253693821 61,00Kb
09.11.09
42
.1253693821 61,00Kb 42 Скачать

См. также

Комментарии
1. Александр Рытов (Арчибальд) 2661 23.09.09 13:13 Сейчас в теме
... были недоработанными.
В чем?
Вот http://infostart.ru/projects/260/ Автор - Мастер. Объясните, в чем Вы его превзошли?
10. Михаил Сысоев (Ghost171184) 4 09.11.09 13:15 Сейчас в теме
В цикле "Пока Запрос.Группировка(1) = 1 Цикл " после строки "Док = Запрос.Документы;" добавить следующее:
Если Метаданные.РазделительУчета.Выбран() = 1 Тогда
Если ПоВсемРУ=0 Тогда
Если Лев(Строка(Док.НомерДок),1)<>ПрИБ Тогда
Продолжить;
КонецЕсли;
КонецЕсли;
КонецЕсли;
И в начале добавить переменную "ПрИБ"
11. Вячеслав (kras) 28 12.03.10 11:49 Сейчас в теме
А чего так позорно сделана группировка по дням... :evil:
Запрос выполняется в цикле!!!

перепиши запрос:
...
|Период с ВыбНачПериода по ВыбКонПериода;
|ОбрабатыватьДокументы Проведенные;
|
|Документы = Документ.ПриходныйОрдер.ТекущийДокумент,
| Документ.ПриходныйОрдерТорг.ТекущийДокумент,
| Документ.РасходныйОрдер.ТекущийДокумент,
| Документ.РасходныйОрдерТорг.ТекущийДокумент;
|ДатаДок = Документ.ПриходныйОрдер.ДатаДок,
| Документ.ПриходныйОрдерТорг.ДатаДок,
| Документ.РасходныйОрдер.ДатаДок,
| Документ.РасходныйОрдерТорг.ДатаДок;
|
|Группировка ДатаДок;
|Группировка Документы упорядочить по Документы.НомерДок;
...

И циклы маленько поменяй, вместо
...
Пока перДатаНач <= ВыбКонПериода Цикл
Запрос.Выполнить(ТекстЗапроса);
Пока Запрос.Группировка(1) = 1 Цикл
...
напиши
...
Пока Запрос.Группировка(1) = 1 Цикл

Пока Запрос.Группировка(2) = 1 Цикл
...
Ghost171184; +1 Ответить
2. Михаил Сысоев (Ghost171184) 4 23.09.09 13:30 Сейчас в теме
У него есть один недочет. Формирование идет отдельными списками ПКО и РКО без разбивки по дням. Я добавил его отчет и сформировал, все нормально, но на контроле в банке сказали это грубая ошибка. Поэтому переделал отчет с разбивкой по дням.
P.S. А по поводу контроля того отчета - может так и должно быть а в банке просто докопались, а может и должна быть разбивка списка первички по дням, а не отдельными списками.
3. Александр Рытов (Арчибальд) 2661 23.09.09 13:38 Сейчас в теме
(2) Будь эта информация в описании, разве я приставал бы? Теперь ясно.
4. Михаил Сысоев (Ghost171184) 4 23.09.09 13:40 Сейчас в теме
Просто я первый раз выкладываю файлы. На будущее учту. Большое СПАСИБО.
5. kalitwa kalitwa (kalitwa) 11 30.09.09 10:02 Сейчас в теме
6. Петр Петров (Adoms) 148 30.09.09 10:46 Сейчас в теме
да, действительно не работает :( пишет приходных кас.ор. - ноль, расходных - ноль
7. Ден (lion11) 139 09.10.09 08:12 Сейчас в теме
А для 8-ки не планируется?
8. Михаил Сысоев (Ghost171184) 4 09.11.09 12:17 Сейчас в теме
Проверенно, у меня в 4 отделениях и в центральном офисе работает
9. Михаил Сысоев (Ghost171184) 4 09.11.09 12:17 Сейчас в теме
12. Михаил Сысоев (Ghost171184) 4 16.03.10 06:58 Сейчас в теме
Возможно это и выглядит позорно, но сделано по необходимости.
Согласен, что запрос выполняется быстрее и меньше кода используется, но это дополнительная нагрузка на сервак, т.к. все запросы выполняются на нём. Вот как поменяю серверную машину, так доработаю не позорно.
13. Вячеслав (kras) 28 17.03.10 06:47 Сейчас в теме
Михаил, Вы ничего не перепутали? ;) Или может я чего-то не понимаю.

Формирую ваш отчет за квартал, делаю замер производительности вашего отчета, время выполнения 17 секунд, при этом запрос вызывается 92 раза!!!
Не это ли называется дополнительной нагрузкой на сервак?

Тебе код нужно изменить всего то в двух местах, поменять запрос и оператор первого цикла. Это займет времени меньше, чем время за которое ты писал предыдущее сообщение. При этом отчет, за тот-же период, теперь формируется за 0,2 секунды, в 85 раз быстрее!!!! На два порядка быстрее, задумайтесь!!!

Запрос выполняется 1 раз, и это вместо 92, чем не подмога вашему многострадальному серверу?
14. Елена Кукушкина (KEVE) 13.05.10 18:49 Сейчас в теме
не увидела смысла в этой обработке. За многолетний период не один банк не потребовал для проверки такого журнала. Если уж хочется проявить себя в кассовой дисциплине, то ещё ни разу не видела обработки для спецрежимников "кассовая книга" на одном листе по дням (как вкладной лист или лист кассира), ведь в стандартной обработке тратится много бумаги. Для "малышей" это накладно.
15. Михаил Сысоев (Ghost171184) 4 03.06.10 06:35 Сейчас в теме
Кассиры просто обленились, писать не желают.
16. 4103 (Soikalv) 15.07.12 19:03 Сейчас в теме
С нового года проверять будет не банк, а налоговая. И уж они-то, наверняка придерутся - отсутствие регистров учета и пр.
17. Дониэла Иванова (Доня) 267 17.02.16 13:51 Сейчас в теме
Скачала, но долго открывается
Спасибо!
Оставьте свое сообщение