До старта конференции

Загрузка данных из табличного документа

Обмен - Загрузка и выгрузка в Excel

Добавил возможность загрузки иерархического справочника .

ЗагрузкаДанныхИзТабличногоДокумента из ИТС - отличній инструмент для загрузки данніх в 1с из других источников но есть одно "но" - при загрузке справочников загружает только элементы  , добавил строку "Этогруппа"  в ней указывается колонка с признаком группы "1" , при других значениях создается  элемент. Если нет необходимости создвать группы строка все равно должна быть активна , указывать на столбец с нулевыми значениями.

Скачать файлы

Наименование Файл Версия Размер
ЗагрузкаДанныхИзТабличногоДокумента.epf
.epf 60,79Kb
15.11.13
47
.epf 60,79Kb 47 Скачать

См. также

Вознаграждение за ответ
Показать полностью
Комментарии
1. Сергей Радченко (Rad90210) 11 20.11.13 10:21 Сейчас в теме
Должно быть удобно, действительно в типовом не хватает ... Правда сам раза 3-4 дописывал в типовой такое, когда нуна было (строчек совсем чуть-чуть).
2. Анна Зверева (Dirol-ka) 20.11.13 10:32 Сейчас в теме
под управляемыми формами работает?
Прикрепленные файлы:
3. Igor qwerty (igo12345) 16 20.11.13 11:30 Сейчас в теме
нет, запускался в обычном режиме чтобы ей воспользоваться
4. Престиж Полякова (prestige) 03.12.13 00:57 Сейчас в теме
5. Igor qwerty (igo12345) 16 03.12.13 10:22 Сейчас в теме
Спасибо , приятно , сам удивляюсь почему в типовой обработке этого нет .
6. gges 30.01.14 14:22 Сейчас в теме
Спасибо ! Очень пригодилось !
Прикрепленные файлы:
7. Евгений Чекушкин (check2) 20 07.02.16 22:12 Сейчас в теме
Наверное туплю, но не работает. Не создаёт группы. В колонке ЭтоГруппа поставил 1 для групп, для элементов 0. Все группы выше элементов. Группы не создаёт, ругается что не найдена группа при загрузке элементов, и все элементы лепит в корень.
8. Евгений Чекушкин (check2) 20 07.02.16 22:23 Сейчас в теме
Разобрался, проблема была в том, что некоторые реквизиты были не доступны для группы, и до записи группы дело не доходило.
Закомментировал строку:
Для каждого КлючИЗначение Из ТекущаяСтрока Цикл
				Если КлючИЗначение.Ключ="ЭтоГруппа"	тогда
					Продолжить;
				КонецЕсли;	
				Если Не ОбъектНайден или Колонки[КлючИЗначение.Ключ].Пометка  Тогда
					Попытка
						Объект[КлючИЗначение.Ключ] = КлючИЗначение.Значение;
					Исключение
						мСообщитьОбОшибке("Ошибка при установки значения реквизита """ + КлючИЗначение.Ключ + "" + ОписаниеОшибки());
						//Отказ = Истина;// комментарий
						Прервать;
					КонецПопытки;
				КонецЕсли;
				
			КонецЦикла;
...Показать Скрыть

Всё получилось
Оставьте свое сообщение