Перенос таблицы значений между клиентом и сервером

Публикация № 240022

Разработка - Инструментарий разработчика

Мутабельные Клиент Сервер Перенос таблицы значений

50
Всем привет.
Бывают такие моменты, когда необходимо таблицу значений передать с сервера на клиент, увы, Мутабельные значения и т.д.
В тоже время есть возможность перекидывать все это добро через Хранилище, чем собственно разработчики часто пользуются.
Но сегодня я бы хотел вынести на Вашу критику вот такой пример переноса.

Сильно не пинайте.

Все мы сталкивались с ситуацией, когда необходимо с сервера передать данные на клиент. И далеко не всегда это примитивные типы.

Об одном из таких типов я бы сегодня и хотел поговорить.

Речь сегодня о таблицы значений.

Данный тип является мутабельным и при попытке выполнить это действия мы получим ошибку:

{Справочник.НастройкиЗаполненияОбъектов1СДокументооборота.МодульОбъекта(33)}: Ошибка при вызове метода контекста (ПолучитьПрокси)
Прокси = ИнтеграцияС1СДокументооборотВызовСервера.ПолучитьПрокси();
по причине:
Попытка передачи мутабельного значения результата метода ПолучитьПрокси ().

(текст ошибки в каждом случае свой)

 

Сегодня я выношу на Вашу критику и обозрение один из вариантов решения этой проблемы, а именно преобразование в Массив(может передаваться) из структур и обратно в таблицу.

 

Функция "ПреобразоватьТаблицуЗначенийВМассив" выполняется на сервере перед передачей данных, а "ПреобразоватьМассивВТаблицуЗначений" уже на клиенте соответственно.

 

Код этих функций:

 

// Функция преобразует ТаблицуЗначений в Массив из структур.
//
Функция ПреобразоватьТаблицуЗначенийВМассив(тзДанные) Экспорт
	
	мсДанные = Новый Массив;
		
	// Запишем в массив
	Для Каждого СтрокаТЗ Из тзДанные Цикл
		
		стСтрокаТаблицы = Новый Структура;
		Для Каждого ИмяКолонки Из тзДанные.Колонки Цикл
			стСтрокаТаблицы.Вставить(ИмяКолонки.Имя, СтрокаТЗ[ИмяКолонки.Имя]);
		КонецЦикла;
		
		мсДанные.Добавить(стСтрокаТаблицы);
		
	КонецЦикла;
	
	Возврат мсДанные;
	
КонецФункции // ПреобразоватьТаблицуЗначенийВМассив()

// Функция преобразует Массив из структур в ТаблицуЗначений.
//
Функция ПреобразоватьМассивВТаблицуЗначений(мсДанные) Экспорт
	
	тзДанные = Новый ТаблицаЗначений;
	
	Для Каждого ЭлементМассива Из мсДанные Цикл
		// Рисуем колонки для таблицы
		Если тзДанные.Колонки.Количество() = 0 Тогда
			Для Каждого ЗначениеСтруктуры Из ЭлементМассива Цикл
				тзДанные.Колонки.Добавить(ЗначениеСтруктуры.Ключ);
			КонецЦикла;
		КонецЕсли;
		
		// Добавляем данные в таблицу
		НоваяСтрока = тзДанные.Добавить();
		Для Каждого ЗначениеСтруктуры Из ЭлементМассива Цикл
			НоваяСтрока[ЗначениеСтруктуры.Ключ] = ЗначениеСтруктуры.Значение;
		КонецЦикла;
	КонецЦикла;
	
	Возврат тзДанные;
	
КонецФункции // ПреобразоватьМассивВТаблицуЗначений()
50

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. AlX0id 10.12.13 19:18 Сейчас в теме
ОбщегоНазначения.ТаблицаЗначенийВМассив(Таблица)
не? )
user1090556; sergio199; Gorus; kar911; Gang031; vovaikilko; Огонек; NN2P; Silenser; roman77; altek; roofless; elga666; qwed557; tehas; elian; dim369; Draconus; freezetron; KonstB; +20 Ответить
4. Draconus 63 11.12.13 08:58 Сейчас в теме
(1) AlX0id, опять велосипед изобретаю))
А в обратку кстати какой метод? "МассивВТаблицуЗначений" не нашел...
8. AlX0id 11.12.13 10:16 Сейчас в теме
(4)
А обратно лично я не нашел ) Пришлось писать )
10. Draconus 63 11.12.13 10:41 Сейчас в теме
(8) AlX0id, тогда половина кода не "велосипед" :)
12. Bukaska 131 11.12.13 10:52 Сейчас в теме
(4) Мутабельные значения - немножко другая тема..
если у вас модуль серверный и не стоит галка вызов сервера и наоборот... то конечно будет эта тема..
А так для тонкого клиента есть функционал: ДанныеФормыВЗначение и ЗначениеВДанныеФормы
Об этом даже рассказывает Андрей Габец в тестовом доступе УЦ3 , отрывок из курса Оперативных задач
31. AlexeyPapanov 01.09.18 13:42 Сейчас в теме
Коллеги, я сейчас решаю озвученную в теме задачу.
Пишу обработку заполнения табличной части (с вызовом клиентского метода).
Юзер указывает ссылку на документ, по которой я на сервере собираю ТЗ, а потом эту ТЗ возвращаю на клиент, чтобы заполнить ТЧ своего документа.

Понимаю, что можно тупо упаковать строки в структуры,, а их в массив, и этот массив вернуть на клиент.

но тут в (12) сказано
А так для тонкого клиента есть функционал: ДанныеФормыВЗначение и ЗначениеВДанныеФормы

это применимо в моей задаче или проще массив из структур швырнуть на клиент?
34. azhilichev 149 03.12.18 09:21 Сейчас в теме
(31) ДанныеФормыВЗначение и ЗначениеВДанныеФормы нельзя открывать от контекста формы. Бесконтекстные вызовы не отработают.
2. KonstB 173 10.12.13 21:48 Сейчас в теме
1. Автор посмотри (0) - сравни. У тебя не оптимально.
2. Функция ПреобразоватьМассивВТаблицуЗначений(мсДанные) - не будет работать в тонком клиенте
rpgshnik; +1 Ответить
3. AnryMc 720 10.12.13 21:53 Сейчас в теме
Функция "ПреобразоватьТаблицуЗначенийВМассив" выполняется на сервере перед передачей данных, а "ПреобразоватьМассивВТаблицуЗначений" уже на клиенте соответственно.


&НаСервереБезКонтекста

&НаКлиентеБезКонтекста

5. soap 56 11.12.13 09:22 Сейчас в теме
Попробовал можно воспользоваться, но при большой таблице чертовски медленно
6. gaglo 11.12.13 09:57 Сейчас в теме
А почему не ЗначениеВСтрокуВнутр ?
jONES1979; myALKleon; +2 Ответить
7. Draconus 63 11.12.13 10:10 Сейчас в теме
(6) gaglo, никто не говорил, что данный вариант - это универсальные методы, которые должны быть у каждого и пользоваться надо только ими)
Это всего лишь один из возможных подходов к решению задач. Кстати как упоминалось в (5) далеко не самый оптимальный. Однако есть вероятность, что кто-то сочтет его полезным для себя.
17. gaglo 12.12.13 10:37 Сейчас в теме
(7) - не ответ, а вот (14) - ответ. Спасибо.
14. kg_am 128 11.12.13 12:01 Сейчас в теме
(6) gaglo,
ЗначениеИзСтрокиВнутр() на тонком клиенте не работает.
METAL; lsnr; vvvalera; gaglo; +4 Ответить
35. user659124_s.kostina 29.07.19 13:37 Сейчас в теме
(6) Пыталась сравнивать этой функций две тз, одна была выгружена из результата запроса, другая сформирована в цикле, и они НЕ были одинаковыми. Сравнила полученный текст, разница, как я поняла в индексах. А вот сравнив массивы, полученные из этих тз, я получила верный результат сравнения.
9. Гость 11.12.13 10:41
если не ошибаюсь, ТаблицаЗначений прекрасно передается на сервер
вот СписокЗначений - не передается
Прикрепленные файлы:
tranay; Трактор; +2 4 Ответить
11. Draconus 63 11.12.13 10:43 Сейчас в теме
(9) barankin, таблица значений с сервера не передается, а вот список значений передаваться должен.
Хотя недавно у меня тоже не передавался, что странно, так как точно помню, что можно было... так же пришлось делать через массив.
13. zarucheisky 11.12.13 10:56 Сейчас в теме
Передача массива структур с клиента на сервер в общем-то очевидна и давно известна.
А вот подобный код в статье публиковать не стОит.

Вложенные циклы по колонкам внутри перебора таблицы выглядят несколько неразумно.

На самом деле, если конечно подумать, и посмотреть как ТЗ отображается в XML, то и решение придет как бы само :)
18. Yashazz 2883 12.12.13 12:50 Сейчас в теме
(13) Верно, хотя сериализация тоже не всякая прокатывает, особенно если в таблице разности и хитрости понапиханы. Да и городить огород иногда нерационально.
19. zarucheisky 12.12.13 14:14 Сейчас в теме
(18) Понапихай всего разного и посмотри как сериализуется
Грубо говоря, сериализуется ВСЕГДА одинаково, как прописано в xsd-схеме ядра платформы.
21. Yashazz 2883 20.12.13 22:36 Сейчас в теме
(19) Некоторые вещи просто НЕ сериализуются. Иногда - противореча СП, например, "РазмерКартинки". А схему самой 1С я видел, так вот, теоретически должное иногда практически не выходит. Ну, xsd 1С - вообще отдельная история, здесь это оффтоп )))
15. peterxx 19 11.12.13 15:50 Сейчас в теме
Нормально работает, сам пользуюсь, правда преобразую ТЗ в структуру массивов. Массив тоже можно пинать между клиентом и сервером.
16. nixel 799 12.12.13 01:31 Сейчас в теме
Вот если бы кто написал функции по переводу тз в массив структур с двумя требованиями:
1) обход данного массива так же как и ТЗ (есть)
2) преобразование данного массива в ТЗ с сохранением типов колонок

А то в крайних случаях приходится проходиться по колонке, смотреть все типы и строить ОписаниеТипов для конструктора ТЗ по собранным данным... Медленно и не всегда верно. Особенно если таблица пустая. Колонки потеряли, типы потеряли. Ну это так, мысли о высоком.
20. wunderland 199 13.12.13 13:31 Сейчас в теме
скользкая тема, если в таблице есть значения Null - в этом случае в тонком клиенте и WEB-клиенте код отрабатывает по разному.
22. realEvgenius 17.02.15 11:09 Сейчас в теме
А в чем соль, так сказать?

Функция ПреобразоватьМассивВТаблицуЗначений(мсДанные)

Всеравно передает ТЗ с сервера и всеравно вызывает ошибку...

Или я деревянный или чушь какая-то
23. Draconus 63 17.02.15 14:07 Сейчас в теме
(22) realEvgenius

Вариант 1.
1. С помощью ПреобразоватьТаблицуЗначенийВМассив() делаем массив, который гоняем между клиентом и сервером.
2. Обрабатываем его (это уже сами выбираете как)
3. Передаете на клиент обратно МАССИВ, который затем преобразуете в Таблицу значений с помощью ПреобразоватьМассивВТаблицуЗначений().

Вариант 1,5.
1. Делаем массив с помощью ПреобразоватьТаблицуЗначенийВМассив()
2. Получаем на сервере, преобразуем в Таблицу значений с помощью ПреобразоватьМассивВТаблицуЗначений()
3. Работаем с Таблицей значений

З.Ы. Мне надо было для второго варианта.
24. realEvgenius 17.02.15 16:17 Сейчас в теме
(23) Вопрос Как в процедуре, которая идет после &НаКлиенте Использовать Таб значений как её туда передать? Ответ - никак. ПреобразоватьМассивВТаблицуЗначений() Это на сервере запускать? Оно возвращает Таб значений (Возврат тзДанные), которую нельзя передать в мою процедуру, которая выполняется на клиенте. Ибо система ругается.
Смысл этих обработок? Таб значений передать на клиента нельзя. Преобразовываем её в массив, передаем массив на клиента, предаем массив функции ПреобразоватьМассивВТаблицуЗначений(), которая по идее должна дать таб знач и получаем туже ошибку. Наверное, я - деревянный, что-то не понимаю
25. Draconus 63 17.02.15 16:42 Сейчас в теме
(24) realEvgenius

Обе функции кладутся в общий модуль, где проставлены галочки "Клиент" и " Сервер", назовем его "ОбщегоНазначенияКлиентСервер"

&НаКлиенте
Процедура ЧтотоДелаю1()
   
   //Есть уже таблица надо ее подправить на сервере
   ЧтотоДелаюНаСервере1(ОбщегоНазначенияКлиентСервер.ПреобразоватьТаблицуЗначенийВМассив(<НашаБеднаяТаблица>));

КонецПроцедуры

&НаСервере
Процедура ЧтотоДелаюНаСервере1(НашБедныйМассив)
   НашаБеднаяТаблица = ОбщегоНазначенияКлиентСервер.ПреобразоватьМассивВТаблицуЗначений(НашБедныйМассив).Скопировать();
   // Мучаем нашу бедную таблицу, что-то из нее берем, что-то добавляем
   
   // Если надо вернуть отбратно, то делаем не процедуру, а функцию и возвращаем
   // ОбщегоНазначенияКлиентСервер.ПреобразоватьТаблицуЗначенийВМассив(<НашаБеднаяПЕРЕДЕЛАННАЯТаблица>)

КонецПроцедуры
Показать


Я не знаю что тут еще можно добавить
realEvgenius; +1 Ответить
27. svad1 10 21.04.16 13:37 Сейчас в теме
(25) как у вас получилось?
//Есть уже таблица надо ее подправить на сервере 

Если на клиенте написать 
тзДанные = Новый ТаблицаЗначений; 


то сразу ошибка.

Как таблица значений может быть на клиенте? Нечего передавать по сути, так как сразу возникает ошибка... Я так понял таблица значений не может существовать на клиенте

Тип не определен (ТаблицаЗначений)
тзДанные = Новый <<?>>ТаблицаЗначений; (Проверка: Тонкий клиент)
afrodit; bow; +2 Ответить
26. realEvgenius 17.02.15 17:04 Сейчас в теме
Аааа.... В общий модуль... А я ж в томже модуле мучаю...
попробую
28. logos 145 27.06.16 20:44 Сейчас в теме
Вот ведь парадокс.... Тип таблица значений на клиенте не определен, а реквизит формы типа "таблица значений" возможен и работает. Сдается мне это вопрос религиозного характера!
rpgshnik; +1 Ответить
29. nixel 799 28.06.16 00:54 Сейчас в теме
(28) logos, посмотрите отладчиком, какой тип у этого реквизита. Удивитесь.
30. It-developer 20 23.03.17 14:28 Сейчас в теме
Они ограничили передачи ТаблицыЗначений, потому что хз что туда можно напихать. Было бы лучше не ограничивать таблицу, а ограничивать типы передаваемых данных
32. chukawata 10 23.10.18 05:00 Сейчас в теме
33. komanch75 28.11.18 09:29 Сейчас в теме
Можно передавать массив, элементы которого - массивы выгруженных колонок таблицы.
Правда таблица значений доступна только на толстом клиенте.
&НаКлиенте
Процедура ЧтоТо(Команда)
	Мсс=ПередачаНаСервере();
	ТЗ=Новый ТаблицаЗначений;
	Для йй=0 по Мсс.Количество()-1 цикл
		ИмяКолонки=СокрЛП(Мсс[йй][0]);
		ТЗ.Колонки.Добавить(ИмяКолонки);
		Мсс[йй].Удалить(0);
		Если йй=0 тогда //на первом проходе добавим в ТЗ строки
			Для цц=1 по Мсс[йй].Количество() цикл
				ТЗ.Добавить();
			КонецЦикла;
		КонецЕсли;
		ТЗ.ЗагрузитьКолонку(Мсс[йй], ТЗ.Колонки[ИмяКолонки]);
	КонецЦикла;
КонецПроцедуры

&НаСервере
Функция ПередачаНаСервере()
		ТЗ = КадровыйУчет.КадровыеДанныеСотрудников(Ложь, Объект.Сотрудник, ЗапрашиваемыеКадровыеДанные, ТекущаяДата()); //формирует ТЗ
		Мсс=Новый Массив;
		Для йй=0 по ТЗ.Колонки.Количество()-1 цикл
			кл=ТЗ.ВыгрузитьКолонку(ТЗ.Колонки[йй]);
			кл.Вставить(0, СокрЛП(ТЗ.Колонки[йй].Имя)); //первой строкой имя колонки
			Мсс.Вставить(йй,кл);
		КонецЦикла;
		Возврат Мсс;
КонецФункции
Показать
36. hobi 551 09.10.19 12:52 Сейчас в теме
Гораздо эффективнее будет работать так (нет двойных циклов и меньше объем данных при сериализации):

Функция ТзВКоллекцию(ТЗ) Экспорт
	
	Коллекция = Новый Структура;
	Для каждого Колонка Из ТЗ.Колонки Цикл
	    Коллекция.Вставить(Колонка.Имя, ТЗ.ВыгрузитьКолонку(Колонка.Имя));
	КонецЦикла;
	Возврат Коллекция;
	
КонецФункции	

Функция КоллекцияВТЗ(Коллекция) Экспорт
	
	ТЗ = Новый ТаблицаЗначений;
	// добавим пустые строки
	Для каждого Эл Из Коллекция Цикл
		КоличествоСтрок = Эл.Значение.Количество();
		Для Индекс = 1 По КоличествоСтрок Цикл
		    ТЗ.Добавить();
		КонецЦикла;
		Прервать;
	КонецЦикла;
		
	// загрузим колонки
	Для каждого Эл Из Коллекция Цикл
	    ТЗ.Колонки.Добавить(Эл.Ключ);
		ТЗ.ЗагрузитьКолонку(Эл.Значение, Эл.Ключ);
	КонецЦикла;
	
	Возврат ТЗ;
	
КонецФункции	
Показать
Оставьте свое сообщение

См. также

Полезные процедуры и функции для программиста 135

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Практика программирования Универсальные функции

Все мы пишем программный код и часто используем процедуры, облегчающие его написание. Ниже приведена выборка таких полезных процедур и функций.

07.10.2019    8439    HostHost    23       

Агрегатные функции СКД, о которых мало кто знает 338

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    12454    ids79    44       

Отслеживание выполнения фонового задания 139

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    10035    ids79    16       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 250

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    13235    ids79    30       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 129

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    12002    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 139

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    10399    ids79    24       

"Меньше копипаста!", или как Вася универсальную процедуру писал 181

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    7373    SeiOkami    49       

Создание отчетов с помощью СКД - основные понятия и элементы 208

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    20295    ids79    17       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 178

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    12549    dmurk    134       

Регистры накопления. Структура хранения в базе данных 175

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    18544    YPermitin    27       

Выполнение внешней обработки в фоновом задании 149

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    10889    Eret1k    23       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    5609    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    8304    m-rv    16       

О расширениях замолвите слово... 193

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    17596    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 202

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    13567    ellavs    83       

Трюки с внешними источниками данных 166

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    13927    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 165

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    17009    ids79    9       

Git + 1С. Часть 2. Реализация Git workflow в 1С-разработке по шагам 129

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Инструментарий разработчика Управление проектом

В этой части мы рассмотрим наиболее распространённую схему workflow при групповой разработке с использованием Git. Как приступить к доработке по поставленной задаче; исправить ошибку, обнаруженную на этапе тестирования; отправить свой код на слияние в предстоящий релиз; и т.д. Постараемся охватить большинство задач, составляющих основной цикл разработки

28.01.2019    10419    stas_ganiev    18       

Новый подход к обмену данными EnterpriseData 207

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    22793    ids79    72       

КопиПастаМер v.2 (универсальный) 37

Инструменты и обработки Системный администратор Программист Стажер Внешний отчет (ert,erf) v8 v8::УФ 1cv8.cf Россия Windows Абонемент ($m) Инструментарий разработчика

Обработка находит набор одинаковых строк в разных текстовых файлах и ранжирует результат по количеству таких повторов. Поиск по всем файлам и под-каталогам, фильтр по типу файла, выбор кодировки, удобное открытие файлов в одно нажатие...

1 стартмани

30.11.2018    6243    31    Serg O.    13       

[8.3] Анализ планов запросов (Управляемая консоль отчетов) 134

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Консоль запросов

Новый инструмент! Позволяет удобно работать с планами запросов, анализ планов в файловой базе.

19.11.2018    14512    Evg-Lylyk    6       

Программное заполнение пользовательских параметров и отборов СКД 136

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    21682    Unk92    19       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 127

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    22039    ids79    40       

Git + 1С. Часть 1. Как подключиться к команде разработки и начать использовать Git 277

Статья Системный администратор Программист Нет файла v8 1cv8.cf Бесплатно (free) Инструментарий разработчика Управление проектом

Первая статья из цикла инструкций по работе с Git в 1С-разработке. Рассмотрим, как настроить рабочее место, как получить свою "копию" проекта для разработки и приступить к полезным действиям. Все примеры будут изложены в рамках трёх практических кейсов: 1. Моя команда дорабатывает типовую конфигурацию, использует приватный репозиторий на BitBucket, в котором версионируются внешние отчеты/обработки, расширения конфигураций и правила обмена; 2. Я участвую в стартап-команде, которая разрабатывает свою конфигурацию с использованием Git и GitLab; 3. Я принимаю участие в развитии OpenSource-продукта на GitHub как заинтересованный разработчик (контрибьютор).

18.10.2018    36287    stas_ganiev    72       

Вспомогательные инструкции в коде 1С 105

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    21352    tormozit    100       

Произвольный код в фоновом режиме 165

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    15441    nikita0832    42       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 147

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    22570    Rain88    42       

Практика применения инструментов продвинутого разработчика 1С 155

Статья Программист Нет файла v8 Бесплатно (free) Инструментарий разработчика

Статья адресована разработчикам. Будет чуть-чуть теории, будут воспоминания, и потом пойдет практика.

23.07.2018    20171    artbear    22       

Повышаем эффективность разработки правил обмена 124

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19921    olegtymko    47       

Введение в механизм представлений в ЗУП ред. 3 155

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    25374    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21911    m-rv    21       

Строим графы средствами 1С (без GraphViz) 43

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    17728    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11887    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 129

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    26072    avfed@rambler.ru    19       

Минимализмы 3 354

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    36828    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 109

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    26372    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21859    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 731

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    141946    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    23491    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 67

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    21780    unichkin    18       

Разбираемся с настройками компоновки данных 160

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    24858    json    9       

Легкий способ обновления измененной конфигурации 41

Статья Системный администратор Программист Нет файла v8 Бесплатно (free) Инструментарий разработчика

Легкий способ обновления измененной конфигурации. Сервис подготовки расширения конфигурации

25.10.2017    18967    avk72    63       

Работа с Excel 297

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    26629    arakelyan    39       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    48465    bugtester    43