IE2017

Решение "проблемы" с сообщением о несовместимости версии драйвера торгового оборудования

Администрирование - Системное

Если вам знакомы подобные сообщения:

"СБ РФ: Эквайринговая система":
Внимание! Невозможно определить версию драйвера.
Требуемая версия: 1.0.0.1
Корректная работа драйвера не гарантируется

есть очень простое решение!

В приведенном примере показано решение "проблемы" с эквайринговой системой Сбербанка, но такую же технологию можно использовать и для задания версии соместимой с заложенной разработчиками внешней обработки обслуживания - просто не выбирайте как в приведенном примере "Не определена" а впишите нужные вам цифры, напрмер при установке драйверов от АТОЛ будет указана версия "6.4.1.359" а обработка требует версию "6.5", для отключения надоедливого предупреждения в окне сообщений достаточно просто добавить в список совместимых версий "6.4.1.359".

Скачать файлы

Наименование Файл Версия Размер
Драйверы торгового оборудования ATOL v6 от 09.02.2009
.7z 18,98Mb
29.01.14
22
.7z 18,98Mb 22 Скачать

См. также

Комментарии
1. Александр Куклин (alexandr851c) 21 28.01.14 20:23 Сейчас в теме
Отлично. Спасибо за статью. Замучило сообщение вы просто спаситель. )))
2. Андрей Старченко (dr.death) 49 29.01.14 06:47 Сейчас в теме
А ларчик то просто открывался :) А я в обработке обслуживания комментил вывод этого сообщения)))
3. Алексей (LeXXeR) 40 29.01.14 07:49 Сейчас в теме
Стоит отметить, что этот способ работает не везде. Потестировал сейчас - атоловский драйвер ТСД заработал, а вот 1С сканер штрихкода (общий) - все равно не хочет. Версия драйвера в список добавляется, а при повторном входе в эту форму - ее там уже нет...
4. Евгений (Berrimor) 194 29.01.14 11:33 Сейчас в теме
(3) Советую использовать комплект драйверов от АТОЛ намного меньше проблем всяческого рода. Архив с комплектом последних бесплатных драйверов от АТОЛ включил в публикацию
5. Евгений (Berrimor) 194 29.01.14 12:03 Сейчас в теме
(4) к слову, многие отказываются от использования от использования приведенного комплекта от АТОЛ именно по причине вывода именно таких сообщений о якобы существующих проблемах совместимости
6. Алекс Свк (sancho86) 1 29.01.14 12:39 Сейчас в теме
С "1С сканер штрихкода (общий)" - не прокатывало. Добавлял поддерживаемую версию в код обработки по аналогии с остальными.
7. cio2005 29.01.14 13:43 Сейчас в теме
Также указывание совместимого драйвера с терминалами сбора данных CipherLAB 8001 при использовании драйвера от "SCAN CITY" не помогает...
8. Евгений (Berrimor) 194 29.01.14 14:52 Сейчас в теме
(6) в код обработки очевидно рабочее решение, но метода добавления совместимой версии не требует АБСОЛЮТНО никаких знаний больших чем у рядового пользователя

(7) возможно что найдется еще масса оборудования с которым данная метода не работает, цель была указать на существующее, и помогающее в большинстве случае, решение, к слову драйверы от АТОЛ именно с этой целью прицепил - с ними метода работает
9. Антон Собейко (sobeyko2008) 6 05.02.14 12:17 Сейчас в теме
Может кто подскажет: Перенесли базу на новый сервер. После это Принтер ЕНВД отказывается печатать. Пишет Ошибка при попытке открыть форму параметров модели:
Ошибка загрузки обработки обслуживания:
Проверьте корректность указания обработки обслуживания и ее версию:

Что и где я сделал не так?
10. Антон Собейко (sobeyko2008) 6 05.02.14 12:18 Сейчас в теме
и еще вот как от такой ошибки избавиться?
FPrint-22K: Ошибка загрузки обработки обслуживания.
Проверьте корректность указания обработки обслуживания и ее версию.
Произошла ошибка при подключении торгового оборудования
11. Донат Каверин (Donat) 05.02.14 12:49 Сейчас в теме
12. Антон Собейко (sobeyko2008) 6 05.02.14 15:18 Сейчас в теме
Оставьте свое сообщение