INI-Файлы

Публикация № 263425

Разработка - Практика программирования

ИНИ INI INI-Файл

Да, устарели. Морально и физически.
Не пинайте, просто понадобилось.

Перед публикацией прочитал статью "Работа с INI-файлами"  //infostart.ru/public/85150/

Подумал: "Ну хоть не я один мамонтов реинкарнирую" :)

Хотя даже скептики признают удобство и простоту редактирования этих файлов.

 

Поддержка INI-файлов выполнена в виде функций общего модуля.

При открытии инифайла создается структура, где ключи - это названия секций, а значения - структуры с парами ключ-значение из соответствующей секции файла.

Структуру я выбрал из-за удобства работы с ней, несмотря на ограничения, что ключи должны удовлетворять требованиям, предъявляемым к именованию переменных встроенного языка.

Вот функции открытия и записи INI файла

 

// Читает INI файл в структуру и возвращает ее.
// При отсутствии файла возвращает пустую структуру
//  по умолчанию - КодировкаТекста.ANSI
//  показывает в какой строке произошла ошибка чтения
Функция Открыть(Файл, Кодировка = Неопределено, Отладка = Истина) Экспорт
	СтруктураИни = Новый Структура;
	Если Кодировка = Неопределено Тогда
		Кодировка = КодировкаТекста.ANSI;
	КонецЕсли;
	Попытка
		Текст = Новый ЧтениеТекста(Файл, Кодировка);
	Исключение
		Возврат Новый Структура;//Неопределено;
	КонецПопытки;
	
	Группа = Неопределено;
	Стр = Текст.ПрочитатьСтроку();
	НомерСтр = 1;
	Пока Стр <> Неопределено Цикл 		// строки читаются до символа перевода строки
		Стр = СокрЛП(Стр);
		Если Лев(Стр, 1) = ";" Или ПустаяСтрока(Стр)  Тогда		//Игнорируем комментарий
			//Перейти ~Следующий;
		ИначеЕсли Лев(Стр, 1) = "[" Тогда	//Нашли секцию
			Если Прав(Стр, 1) <> "]" Тогда
				Если Отладка Тогда
					Сообщить ("Ошибка синтаксиса формата INI: Строка " + НомерСтр);
				КонецЕсли;
				Возврат Неопределено;
			КонецЕсли;
			Группа = Сред(Стр, 2, СтрДлина(Стр) - 2);
			СтруктураИни.Вставить(Группа, Новый Структура);
		Иначе								//Параметр
			ПозицияРавно = Найти(Стр, "=");
			Если Группа = Неопределено ИЛИ ПозицияРавно = 0 Тогда
				Если Отладка Тогда
					Сообщить ("Ошибка синтаксиса формата INI: Строка " + НомерСтр);
				КонецЕсли;
				Возврат Неопределено;
			КонецЕсли;
			Значение = Сред(Стр, ПозицияРавно + 1);
			СтруктураИни[Группа].Вставить(Лев(Стр, ПозицияРавно - 1), ?(ПустаяСтрока(Значение), Неопределено, Значение));
		КонецЕсли;
		
		//~Следующий:
    	Стр = Текст.ПрочитатьСтроку();
		НомерСтр = НомерСтр + 1;
	КонецЦикла;
	Возврат СтруктураИни;
КонецФункции

// Сохраняет структуру в ини файл. Ключи структуры сохраняются как названия секций,
// Если значением структуры является структура, то ее ключи сохраняются в эту секцию как
// названия параметров, значения как значения параметров.
// Если элемент структуры не строка или не структура, он будет пропущен
//  - Задает расширение файла для резервного копирования INI файла перед записью (Можно сточкой или без)
Функция Сохранить(Ини, Файл, Знач Резерв = Неопределено, Кодировка = Неопределено) Экспорт
	Если Не ПустаяСтрока(Резерв) Тогда
		ВыводИни = Новый  Файл(Файл);
		Если ВыводИни.Существует() Тогда
			Если Лев(Резерв, 1)  <> "." Тогда
				Резерв = "." + Резерв;
			КонецЕсли;
			КопироватьФайл(Файл, ВыводИни.Путь + ВыводИни.ИмяБезРасширения + Резерв);
		КонецЕсли;
		ВыводИни = Неопределено;
	КонецЕсли;
	
	Если Кодировка = Неопределено Тогда
		Кодировка = КодировкаТекста.ANSI;
	КонецЕсли;
	ВыводИни = Новый ЗаписьТекста(Файл, Кодировка);
	Для Каждого Секция Из Ини Цикл
		Если ТипЗнч(Секция.Значение) <> Тип("Структура") Тогда
			Продолжить;
		КонецЕсли;
		ВыводИни.ЗаписатьСтроку("[" + Секция.Ключ + "]");
		Для Каждого Параметр Из Секция.Значение Цикл
			Если ТипЗнч(Параметр.Значение) <> Тип("Строка") Тогда
				Продолжить;
			КонецЕсли;
			ВыводИни.ЗаписатьСтроку(Параметр.Ключ + "=" + Параметр.Значение);
		КонецЦикла;
		ВыводИни.ЗаписатьСтроку("");
	КонецЦикла;
	ВыводИни.Закрыть();
КонецФункции

 

Пример работы со структурой 

Ини = ИниФайл.Открыть("С:\ИниФайл.ini"); 
Значение = Ини.Секция.Параметр;

Так же есть возможность работы со структурой в стиле Delphi

// Базовая функция чтения строки.  Ини (Структура) - Структура INI файла,
//  Секция (Строка) - Имя секции,  Ключ (Строка) - Имя параметра,
//  Данные (Произвольный) - Будет возвращено, если секции или параметра
// не существует или значение параметра пустая строка
Функция ПолучитьСтроку(Ини, Секция, Ключ, Данные = Неопределено) Экспорт

// Базовая функция записи строки.  Ини (Структура) - Структура INI файла,
//  Секция (Строка) - Имя секции,  Ключ (Строка) - Имя параметра,
//  Данные (Произвольный) - в структуру будет записано строковое представление.
// Если секция или параметр не существует, то он будет создан.
Процедура ЗаписатьСтроку(Ини, Секция, Ключ, Данные) Экспорт 

Остальные функции работы с ключами структуры используют эти две функции и имеют те же основные параметры.

ПолучитьБулево, ЗаписатьБулево - Работает с разными представлениями записи логических переменных, можно задать своё.

ПолучитьЦелое, ЗаписатьЦелое - Целые так же могут быть в двоичном, шестнадцатеричном и восьмиричном представлении.

ПолучитьВещественное, ЗаписатьВещественное - Поддерживаются числа в полулогарифмической (нормальной) форме.

ПолучитьДатуВремя, ЗаписатьДатуВремя - В каноническом или локальном формате

ПолучитьДвоичныеДанные, ЗаписатьДвоичныеДанные - Пришлось записать картинку в одну строку, интересно, когда строка треснет?

Не реализованы Получить/Записать Дату, Время

Так же есть функции для работы с секциями.

 

// Возвращает число - количесво секций
Функция КоличествоСекций(Ини) Экспорт
	Возврат Ини.Количество();
КонецФункции

// Проверка существования секции, возвращает булево
Функция СекцияСуществует(Ини, Секция) Экспорт
	Возврат Ини.Свойство(Секция);
КонецФункции

// Удаляет секцию
Процедура УдалитьСекцию(Ини, Секция) Экспорт
	Ини.Удалить(Секция);
КонецПроцедуры

// Возвращает список секций в виде списка значений или в виде массива
Функция ПолучитьСекции(Ини, Массив = Ложь) Экспорт
	Секции = ?(Массив, Новый Массив, Новый СписокЗначений);
	Для Каждого Секция Из Ини Цикл
		Секции.Добавить(Секция.Ключ);
	КонецЦикла;
	Возврат Секции;
КонецФункции

// Возвращает список параметров в секции и их значений
// в виде Списка значений(Значение Функция ПолучитьСекцию(Ини, Секция) Экспорт
СтруктураСекция = Неопределено;
Если Не Ини.Свойство(Секция, СтруктураСекция) Тогда
Возврат Неопределено;
КонецЕсли;
Параметры = Новый СписокЗначений;
Для Каждого Параметр Из СтруктураСекция Цикл
Параметры.Добавить(Параметр.Ключ, Параметр.Значение);
КонецЦикла;
Возврат Параметры;
КонецФункции

// Возвращает список значений параметров в секции в виде
// списка значений (Значение Функция ПолучитьЗначенияСекции(Ини, Секция, Массив = Ложь) Экспорт
СтруктураСекция = Неопределено;
Если Не Ини.Свойство(Секция, СтруктураСекция) Тогда
Возврат Неопределено;
КонецЕсли;
Значения = ?(Массив, Новый Массив, Новый СписокЗначений);
Для Каждого Параметр Из СтруктураСекция Цикл
Значения.Добавить(Параметр.Значение);
КонецЦикла;
Возврат Значения;
КонецФункции

// Возвращает количество параметров в секции или Неопределено, если секция не существует
Функция КоличествоПараметров(Ини, Секция) Экспорт
СтруктураСекция = Неопределено;
Если Не Ини.Свойство(Секция, СтруктураСекция) Тогда
Возврат Неопределено;
КонецЕсли;
Возврат СтруктураСекция.Количество();
КонецФункции
Вобщем смотрите демку. Тестовый INI файл поместите в папку с базой.

Скачать файлы

Наименование Файл Версия Размер
Демо конфа

.cf 14,80Kb
04.09.15
7
.cf 14,80Kb 7 Скачать
Демо INI-Файл

.ini 342,89Kb
04.09.15
2
.ini 342,89Kb 2 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. baton_pk 407 11.03.14 13:26 Сейчас в теме
Поддержка INI-файлов выполнена в виде функций общего модуля.

Хм. А поддержка XML выполнена в виде встроенных механизмов платформы.

Единственное оправдание - если INI-файл нужен внешней программе (или клиенту, начальнику...), как например для файла nethasp.ini. Да и в этом случае лично я сделал бы чтение из INI-файла в структуру и запись, соответственно, структуры в INI-файл.
3. gruk 4 11.03.14 17:41 Сейчас в теме
(1) baton_pk,
Да и в этом случае лично я сделал бы чтение из INI-файла в структуру и запись, соответственно, структуры в INI-файл.


я так и сделал, просто статья на скорую руку,может не очень понятно.
Сейчас поправлю.
4. gruk 4 11.03.14 18:35 Сейчас в теме
(2) the1,
пользую IniEdit - плагин для тотал коммандера

Пользую Far Colorer для Far manager :)
5. baton_pk 407 11.03.14 21:16 Сейчас в теме
Вот навернёте потом работу с булями, датами, числами, экранирование символов в строках, плюнете и начнёте использовать XML.

Структуру я выбрал из-за удобства работы с ней, несмотря на ограничения, что ключи должны удовлетворять требованиям, предъявляемым к именованию переменных встроенного языка.

Ещё можно воспользоваться Соответствием. Удобств не сильно меньше, просто вместо Ини.Секция.Параметр будет Ини["Секция"]["Параметр"].
6. gruk 4 12.03.14 04:08 Сейчас в теме
(5) baton_pk,
Вот навернёте потом работу с булями, датами, числами, экранирование символов в строках

вы невнимательно читаете статью. були, даты, числа (в разных форматах) и даже двоичные данные (моя инициатива, просто хотел попробовать) сделаны. Просто не оформленны в статье в виде кода. На весь модуль у меня ушло несколько часов
плюнете и начнёте использовать XML.

XML пользую, серьезный обмен данными или сохранение большой кучи настроек без него трудоемко. Но, как вы правильно заметили в (1)
Единственное оправдание - если INI-файл нужен внешней программе (или клиенту, начальнику...)

поэтому не всегда так просто от него откреститься.
7. gruk 4 12.03.14 04:45 Сейчас в теме
Вообще согласен, что поддержка INI на такой мощной и современной платформе выглядит рудиментарно. Правильно, что разработчики ее не сделали (хотя INI парсер есть почти во всех средах разработки), ведь за кажущейся простотой есть куча проблем в виде ограниченности уровней дерева параметров (хотя както был проектик, где пришлось это сделать. Несложно. Получился какойто недоXML), несовместимости и неоднозначности типа хранимых данных. А то пошли бы 1С-ники кто влес, кто по дрова.

Не по 1С:
А лично я до сих пор использую INI файлы для конфигурации устройств на микроконтроллерах собственной разработки.
Плюсы:
1. Парсер пишется просто, занимает мало места в (не резиновой) памяти (по сравнению с XML, или тем более WWW конфигом).
2. Не нужен какойто спец. софт для конфигурирования устройства (как в случае с конфигом в виде бинарника).
3. Редактирование любым подручным средством. Понятная конечному пользователю простая структура.
Минусы:
На слабеньких микроконтроллерах (типа AT90S1200 with 1K Byte of In-System Programmable Flash and 64 Bytes of In-System Programmable EEPROM) парсер и сам INI файл хранить практически не где. Тут только бинарный конфиг.
baton_pk; +1 Ответить
9. donhenru 01.12.15 13:41 Сейчас в теме
Зачем пытаться загружать ini-файл в тип данных Структура?! ДеревоЗначений больше подходит. Из-за этого ваш алгоритм спотыкается если группа параметров с пробелами или с точками.

Вот, переделал:

СтруктураИни = Новый ДеревоЗначений;
	СтруктураИни.Колонки.Добавить("Параметр");
	СтруктураИни.Колонки.Добавить("Значение");
	
	Если Кодировка = Неопределено Тогда
		Кодировка = КодировкаТекста.ANSI;
	КонецЕсли;
	Попытка
		ТекстДок = Новый ЧтениеТекста(Файл, Кодировка);
	Исключение
		Возврат Неопределено;
	КонецПопытки;
	
	Группа = Неопределено;
	ВремСтр = ТекстДок.ПрочитатьСтроку();
	НомерСтр = 1;
	Пока ВремСтр <> Неопределено Цикл
		ВремСтр = СокрЛП(ВремСтр);
		Если Лев(ВремСтр, 1) = ";" Или ПустаяСтрока(ВремСтр)  Тогда
			//Закомментированная строка, пропускаем
		ИначеЕсли Лев(ВремСтр, 1) = "[" Тогда
			Если Прав(ВремСтр, 1) <> "]" Тогда
				Если Отладка Тогда
					Сообщить ("Ошибка синтаксиса формата INI: Строка " + НомерСтр);
				КонецЕсли;
				Возврат Неопределено;
			КонецЕсли;
			Группа = Сред(ВремСтр, 2, СтрДлина(ВремСтр) - 2);
			НовГруппа = СтруктураИни.Строки.Добавить();
			НовГруппа.Параметр = Группа;
		Иначе
			ПозицияРавно = Найти(ВремСтр, "=");
			Если Группа = Неопределено ИЛИ ПозицияРавно = 0 Тогда
				Если Отладка Тогда
					Сообщить("Ошибка синтаксиса формата INI: Строка " + НомерСтр);
				КонецЕсли;
				Возврат Неопределено;
			КонецЕсли;
			Значение = Сред(ВремСтр, ПозицияРавно + 1);
			НовПараметр = НовГруппа.Строки.Добавить();
			НовПараметр.Параметр = Лев(ВремСтр, ПозицияРавно - 1);
			НовПараметр.Значение = ?(ПустаяСтрока(Значение), Неопределено, Значение);
		КонецЕсли;
		
		ВремСтр = ТекстДок.ПрочитатьСтроку();
		НомерСтр = НомерСтр + 1;
	КонецЦикла;
	Возврат СтруктураИни;
Показать
10. gruk 4 02.12.15 08:03 Сейчас в теме
(9) donhenru, Спасибо
У меня тоже как-то попался файл с именем параметра не "ВСтилеИмен1С", переделывал структуру на соответствие. А с деревом работать неудобно, нельзя обратиться ИНИ.ИмяСекции.ИмяПараметра
Оставьте свое сообщение

См. также

Вам нравятся запросы в 1С? Промо

Практика программирования Разработка v8 v8::Запросы 1cv8.cf Абонемент ($m)

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    21159    5    m-rv    88    

Интерактивная справка по объектам 1С (автономное расширение)

Практика программирования Работа с интерфейсом v8 ERP2 Абонемент ($m)

База знаний, подключаемая к объектам основной базы. Ведётся интерактивно, формируется в виде статей прямо в 1С (текст, картинки, таблицы, ссылки). Есть возможность прикрепления файлов, привязки к объектам 1С, возможности рейтинга и комментирования пользователями.

3 стартмани

29.09.2020    6588    33    sapervodichka    33    

Конвейер проверки качества кода

Инструментарий разработчика Практика программирования Математика и алгоритмы v8 1cv8.cf Абонемент ($m)

Jenkinsfile для выполнения проверки качества кода. Собирает информацию с АПК, EDT и BSL-LS. Сопоставляет ошибки с гит-репозиторием, выгруженным ГитКонвертором. Отправляет в Сонар.

3 стартмани

04.09.2019    25523    22    Stepa86    46    

Алгоритмы поиска пути в графе

Практика программирования Разработка v8 1cv8.cf Абонемент ($m)

Реализуем алгоритмы поиска пути в графе на платформе 1С 8.3, такие как алгоритм А*, поиск в ширину, жадный поиск, алгоритм Дейкстры и вконце волновой.

1 стартмани

09.07.2019    17931    12    RonX01    10    

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") Промо

Практика программирования v8 v8::Запросы 1cv8.cf Абонемент ($m)

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    30864    86    m-rv    57    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    22107    13    RocKeR_13    16    

HTTP Сервисы: Путь к своему сервису. Часть 3

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    38681    56    dsdred    17    

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции

Инструментарий разработчика Практика программирования v8 Абонемент ($m)

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    28619    26    informa1555    26    

Заполняем по шаблону (по умолчанию) Промо

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    28692    19    mvxyz    17    

Работа с данными выбора

Практика программирования Работа с интерфейсом v8 Россия Абонемент ($m)

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    48996    17    kalyaka    16    

Полезные примеры составления схемы компоновки данных #2

Практика программирования v8 v8::СКД 1cv8.cf Абонемент ($m)

Еще один набор примеров как решить частные задачи в СКД

1 стартмани

22.05.2018    31670    11    SITR-utyos    13    

Печатная форма, сделанная как расширение конфигурации для БП 3.0. Новые возможности БСП

Практика программирования Универсальные печатные формы v8 БП3.0 Абонемент ($m)

Печатные формы на внешних обработках скоро канут в лету. На смену им приходят ПФ, реализованные в виде расширений конфигурации. Не нашел на сайте примеров таких расширений. Привожу пример подобного расширения для БП 3.0.

1 стартмани

06.12.2017    27403    54    kwazi    6    

Нечеткий поиск одним запросом Промо

Практика программирования v8 1cv8.cf Абонемент ($m)

Использование механизма полнотекстового поиска в 1С не всегда оправдано, т.к. построение индекса и поддержание его в актуальном состоянии может значительно нагружать систему. Предлагаемая реализация нечеткого поиска методом N-грамм выполняется одним запросом, что позволяет производить поиск в любой таблице и не требует предварительного построения индекса.

1 стартмани

28.12.2015    28209    71    vasvl123    9    

Паузы при исполнении кода (Sleep для 1С)

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Решил проверить все найденные варианты паузы для 1С. В результате получилась обработка для тестирования и небольшая статья с итогом.

1 стартмани

28.11.2017    47010    12    swimdog    42    

Макет в СКД - пример всех возможных типовых вариантов

Практика программирования Инструментарий разработчика v8 v8::СКД 1cv8.cf Абонемент ($m)

Макет СКД: наглядное представление того, что, как и куда выводится при типовых настройках.

1 стартмани

09.11.2017    22252    76    freelancer    4    

Telegram-боты

Практика программирования v8 Абонемент ($m)

Описание теории, разбор архитектуры и пример реализации telegram-ботов. Сразу скажу, со структурированием изложения мало что могу поделать. :) редакция от 18.07.2018 Правки последней редакции выделены жирным.

1 стартмани

01.09.2017    33217    132    PLAstic    59    

1С: Предприятие + корпоративный чат, как наладить оперативные уведомления за 10 минут Промо

Практика программирования v8 Абонемент ($m)

Как сделать автоматические уведомления о разных событиях из 1С в корпоративный чат MyChat для сотрудников компании

1 стартмани

14.08.2016    48568    36    Demanoidos    60    

Умный дом на 1С + ардуино

Практика программирования v8 Абонемент ($m)

Конфигурация для автоматизации быта программиста 1C и не только. В данной статье будет рассказано, как можно использовать 1С для задач, не входящих в стандартные рамки этой платформы. Например, управление домом. В качестве периферии для подключения будет использован микроконтроллер (МК) Ардуино, но на нём не будет никакой логической нагрузки, весь процесс будет проходить на сервере 1С. Работа с пинами ввода/вывода происходит напрямую из 1С.

1 стартмани

07.08.2017    23160    21    sasha777666    63    

Расширения конфигураций 1С: учимся перехватывать методы

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

В этой статье я на примерах разберу некоторые механизмы расширений конфигураций 1С. А именно «перехваты» методов модуля объекта и «перехваты» событий формы и элементов формы. Данная статья написана с учебными целями, чтобы показать, как при помощи расширений конфигурации можно делать такие доработки, ради которых раньше приходилось снимать конфигурацию с поддержки.

1 стартмани

30.05.2017    132447    13    signum2009    48    

Регулярные выражения – это просто. Построитель и отладчик регулярных выражений

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагается к использованию построитель регулярных выражений. Выполненный в виде внешней обработки, он позволит строить сложно-структурированные выражения на основе параметрического описания, тестировать их, и в результате получить программный код 1С.

1 стартмани

13.03.2017    31910    113    romasna    49    

Быстрое определение интервалов в запросе Промо

Практика программирования v8 Абонемент ($m)

В статье описывается новый метод определения интервалов между данными различных записей в запросе. В отличие от общеизвестного метода, время работы предлагаемого метода зависит от объема данных ЛИНЕЙНО. Это обеспечивает ему значительный выигрыш по быстродействию на больших объемах данных. В качестве иллюстрации возможностей метода приведен отчет, показывающий гистограмму распределения времени между продажами.

1 стартмани

01.10.2015    52140    35    ildarovich    41    

Распознавание текста с помощью нейросетей Google Cloud Vision и 1С

Практика программирования v8 1cv8.cf Абонемент ($m)

Возможности Google Cloud Vision в распознавании текста.

1 стартмани

08.02.2017    30056    127    kiv1c    18    

Графическая схема. Управление при помощи XDTO.

Практика программирования v8 Абонемент ($m)

В статье описывается методика программного управления элементами графической схемы при помощи механизма XDTO. Приложена готовая к использованию библиотека функций для создания и удаления графических объектов, а также для связи элементов схемы соединительными линиями.

2 стартмани

16.01.2017    22774    105    Alxby    23    

Простой редактор плана помещения JavaScript

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

На ресурсе сейчас очень много решений, которые позволяют редактировать карты, используя географические схемы. Так же много решений, которые позволяют редактировать объекты онлайн веб-карт. Мне же нужно было простое решение, для того чтобы расставить квадратные объекты на плане, показать их пользователю. Ну и распечатать, опять же. Я решил написать простенький редактор на JavaScript с использованием библиотеки Raphael.

1 стартмани

23.11.2016    21444    96    igel9780    22    

Хранение файлов в томах на диске (для УПП 1.3) Промо

Практика программирования v8 УПП1 Абонемент ($m)

Доработка типовой УПП 1.3 в плане хранения присоединенных файлов вне базы данных

2 стартмани

05.06.2016    58189    10    wowik    32    

Работа с двоичными данными на примере чтения файлов изображений. Новые возможности 8.3.9

Практика программирования WEB v8 1cv8.cf Россия Абонемент ($m)

В статье приводятся новые функции по работе с двоичными данными, появившимися в версии платформы 8.3.9 , на примере анализа формата и размера изображений. А также пример отправки изображения через API ВКонтакте с помощью новых объектов (без использования ОбъединитьФайлы())

1 стартмани

14.11.2016    26575    16    Anton64    22    

Загрузка файлов на сервер с прогрессом и докачкой

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример использования новых возможностей платформы 8.3.9 по низкоуровневой работе с двоичными данными для инкрементальной передачи файлов на сервер.

1 стартмани

04.10.2016    13582    53    mrstomak    21    

Несколько шаблонов для доработки типовых конфигураций

Практика программирования Инструментарий разработчика v8 v8::УФ Абонемент ($m)

Предлагаю несколько каркасов для создания новых объектов в типовых конфигурациях. Это выжимка из кода нескольких конфигураций, которая позволит быстро и красиво создавать и дорабатывать объекты метаданных с соблюдением идеологии исходной системы

1 стартмани

03.10.2016    37047    95    json    25    

HTTP-сервис: отчеты [Расширение]

Практика программирования Работа с интерфейсом v8 1cv8.cf Абонемент ($m)

Это HTTP-сервис, который возвращает почти любой отчет в HTML, XLSX или в JSON. Сохраните вариант отчета, получите на него ссылку и можно получить данные без захода в 1С. Работает в конфигурациях на основе БСП 2.3.3+, для отчетов на СКД и в 1С 8.3.8+

2 стартмани

30.08.2016    27237    137    Stepa86    15    

Недокументированное использование стандартных форм Upd.

Практика программирования v8 v8::УФ 1cv8.cf Абонемент ($m)

Вам не хватает возможностей в платформе 1С или у Вас нет времени на углубленное изучение платформы 1С? Рассмотрены возможности использования стандартных форм, вызываемых из платформы.

1 стартмани

26.07.2016    28671    77    ZhokhovM    60    

БСП 2.3 и БСП 3.0: Просто про выполнение внешней обработки в фоне (c индикацией прогресса выполнения)

Инструментарий разработчика Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Простое пояснение о том, как сделать внешнюю обработку с фоновым выполнением и индикацией процесса для любой конфигурации на основе БСП 2.3.2. UPDATE 20/09/19: добавлен вариант обработки с индикацией процента выполнения и статусом выполнения для БСП 3.0.

1 стартмани

18.05.2016    62587    184    rozer    65    

Остатки на каждый день в запросе

Практика программирования Учет ТМЦ Учет ТМЦ v8 1cv8.cf УУ Абонемент ($m)

Запрос формирует остатки товаров на каждый день в пределах выбранного периода.

1 стартмани

26.04.2016    59833    19    arakelyan    19    

Еще один способ расчета остатков на каждый день в запросе

Математика и алгоритмы Практика программирования v8 Абонемент ($m)

Предлагается новый способ расчета остатков на каждый день (час, минуту, секунду) в запросе. Способ не требует предварительного формирования таблицы дат и также подходит для расчета курсов валют, цен номенклатуры и других периодических сведений на каждую дату периода. На больших объемах данных предлагаемый способ может превосходить по быстродействию ранее известные методы из-за линейной (в лучшем случае) зависимости трудоемкости от длины периода.

1 стартмани

24.04.2016    34983    49    ildarovich    23    

Вывод печатных форм с запросом данных в форму "Печать документов" из подсистемы БСП "Печать".

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Все не раз видели, как в типовых конфигурациях, построенных на основе БСП (Библиотека стандартных подсистем), печатные формы, построенные на основе Табличного документа, выводятся в специальную форму "ПечатьДокументов". Эта форма входит в состав подсистемы "Печать" из БСП. При разработке своих печатных форм, иногда необходимо запросить у пользователя дополнительные данные необходимые для печати. Тут встает вопрос, как в этом случае вывести печатную форму в форму "Печать документа". В этой статье я рассмотрю, как реализовать вывод печатной формы в упомянутую форму из подсистемы "Печать", в случае если мы хотим перед выводом печатной формы запросить у пользователя дополнительные данные. Здесь будут рассмотрены два случая: когда реализуется печатная форма с использованием подсистемы "Дополнительные отчеты и обработки" и когда печатная форма добавляется в конфигурацию в режиме конфигуратора, т.е. вносятся изменения в типовую конфигурацию.

1 стартмани

29.03.2016    91493    181    lopatin    14    

Выполнение JavaScript кода из 1С в объекте Поле HTML Документа (HTML 5) и вызов события в 1С ПриНажатии

Практика программирования v8 1cv8.cf Россия Абонемент ($m)

Пример выполнения JS кода из 1С в Поле HTML Документа под управляемыми формами, с удобным получением результата в 1С(С помощью вызова привязанного события ПриНажатии к элементу ПолеHTMLДокумента)

1 стартмани

22.03.2016    82140    160    igo1    54    

Количество дней недели (понедельников/вторников/...) в заданном диапазоне одним запросом

Практика программирования v8 Абонемент ($m)

При реализации периодического авто-заполнения маршрутных листов по графику (недельному) необходимо было просчитать стоимость всего периода, с условием выездов только по определенным дням. Заморачиваться с обходом результата не хотелось. Пришлось написать "Небольшой" запрос.

1 стартмани

03.03.2016    18564    1    Alexander.Shvets    5    

Простые радости жизни программиста 1С: выбор типа значения

Работа с интерфейсом Практика программирования v8 1cv8.cf Абонемент ($m)

Предлагаемая в работе обработка включает обычную и управляемую формы, которые максимально точно реализуют функциональность системного диалога выбора типа в толстом клиенте обычное приложение (включая оформление диалога). Эти формы имеют дополнительные интерфейсные удобства и могут быть использованы в качестве альтернативных диалогов выбора типа.

1 стартмани

17.02.2016    50631    53    yuraos    17    

Отображение прогресса выполнения длительных операций в БСП и их отладка в текущем сеансе.

Практика программирования БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

В статье описан способ исполнения длительных операций в конфигурациях, в которых используется библиотека стандартных подсистем, с визуализацией прогресса исполнения и отображения хода обработки данных. Также дается краткое описание процесса отладки длительных операций в текущем сеансе.

1 стартмани

17.02.2016    56117    179    balanton    23    

Яндекс.Деньги "Благотворительность"

Инструментарий разработчика Практика программирования v8 1cv8.cf Абонемент ($m)

Яндекс.Деньги теперь в 1С. Форма для приема благотворительных взносов. Форму легко сделать и вставить на любую страницу сайта или блога. Платежи будут приходить на ваш кошелек. На форме есть три способа платежа: из кошелька, с банковской карты, с баланса мобильного.

1 стартмани

16.02.2016    23636    8    Tatitutu    5    

Мастер рассылки e-mail 2.2 для управляемых форм

Практика программирования Email v8 v8::УФ ERP2 БП3.0 УТ11 Абонемент ($m)

Для пользователей: переделанный из старый разработки под 8.2 с использованием библиотеки Мастер рассылки e-mail 2.2 (ERP, УТ, БП) (Только управляемые формы), который теперь может запускаться под любой версией платформы с разрешенными или запрещенными модальными/синхронными вызовами в конфигурации. Также удобный выбор e-mail и их владельцев с помощью отбора динамического списка по любым критериям и галочки исключения.

1 стартмани

29.12.2015    37362    20    milkers    4    

Передача больших пакетов через веб-сервисы

Практика программирования Администрирование данных 1С Внешние источники данных v8 Абонемент ($m)

Реализация механизма передачи больших пакетов через веб-сервисы. С его помощью передать файл размером в несколько гигабайт не составит проблем.

1 стартмани

06.12.2015    57591    48    YPermitin    19