Простые алгоритмы численного интегрирования

Публикация № 314372

Разработка - Универсальные функции

интегрирование метод прямоугольников метод трапеций метод Симпсона

19
Представлены программы (без теории) на языке 1С8 для вычисления определенных интегралов по методам левых, правых и средних прямоугольников, методу трапеций и Симпсона. Статья может быть интересной для тех, кто не знал или подзабыл простые способы вычисления интегралов.

Подробное изложение теоретической части алгоритмов и численного интегрирования вообще, можно найти практически в любой книге о численных методах, например - Е. А. Волков "Численные методы", ну или в Википедии -"https://ru.wikipedia.org/wiki/Численное_интегрирование". Особое внимание нужно уделить вопросам выбора узлов и шага интегрирования, обеспечения требуемой точности вычислений, а также применимости и целесообразности выбора того или другого метода.  

 

В качестве подинегральной функции рассмотрим "обычную" гладкую и непрерывную функцию (одного аргумента):

Функция Функция_1(х)
	Возврат х*х;
КонецФункции	

Так будет выглядеть вызов расчетных функций:

Процедура ВыполнитьРасчет()
	Число_шагов = 100; 	
	Х_нач 	= 0; 
	Х_кон 	= 5; 
	Сообщить("Метод левых прямоугольников	= " + РассчитатьЛевымиПрямоугольниками(Х_нач, Х_кон, Число_шагов));
	Сообщить("Метод правых прямоугольников	= " + РассчитатьПравымиПрямоугольниками(Х_нач, Х_кон, Число_шагов));
	Сообщить("Метод средних прямоугольников	= " + РассчитатьСреднимиПрямоугольниками(Х_нач, Х_кон, Число_шагов));
	Сообщить("Метод трапеций				= " + РассчитатьТрапециями(Х_нач, Х_кон, Число_шагов));
	Сообщить("Метод Симпсона				= " + РассчитатьСимпсона(Х_нач, Х_кон, Число_шагов));
КонецПроцедуры	

Таким образом, функция F(x)=x^2 интегрируется на интервале от Х_нач до Х_кон, число шагов фиксировано и равно 100 (вообще, для различных методов с целью обеспечения требуемой точности можно рассчитать минимально необходимое число шагов, но для наших ознакомительных целей берем именно фиксированное значение).

Важно также помнить, что при расчетах могут получаться числа с длинной дробной частью, работа с которыми занимает у 1С много времени и сильно тормозит вычисления. Поэтому, например, при определении функции имеет смысл вместо "Возврат F(X)" писать "Возврат Окр(F(X), 16)".

 

 

1) Метод левых прямоугольников:

Функция РассчитатьЛевымиПрямоугольниками(Х_нач, Х_кон, Число_шагов)
	Сумма = 0;
	h = (Х_кон-Х_нач)/Число_шагов;
	х = Х_нач;
	Для й=0 По Число_шагов-1 Цикл
		Сумма = Сумма + h*Функция_1(х);
		х = (х + h);
	КонецЦикла;	
	Возврат Сумма;
КонецФункции

2) Метод правых прямоугольников:

Функция РассчитатьПравымиПрямоугольниками(Х_нач, Х_кон, Число_шагов)
	Сумма = 0;
	h = (Х_кон-Х_нач)/Число_шагов;
	х = Х_кон;
	Для й=1 По Число_шагов Цикл
		Сумма = Сумма + h*Функция_1(х);
		х = (х - h);
	КонецЦикла;	
	Возврат Сумма;
КонецФункции

3) Метод средних прямоугольников:

Функция РассчитатьСреднимиПрямоугольниками(Х_нач, Х_кон, Число_шагов)
	Сумма = 0;
	h = (Х_кон-Х_нач)/Число_шагов;
	х = Х_нач;
	Для й=1 По Число_шагов Цикл
		Сумма = Сумма + Функция_1(х + 0.5*h);
		х = (х + h);
	КонецЦикла;	
	Возврат h*Сумма;
КонецФункции

4) Метод трапеций:

Функция РассчитатьТрапециями(Х_нач, Х_кон, Число_шагов)
	Сумма = 0;
	h = (Х_кон-Х_нач)/Число_шагов;
	х = Х_нач;
	Для й=0 По Число_шагов Цикл
		Если й=0 или й=Число_шагов Тогда
			Сумма = Сумма + 0.5*Функция_1(х);
		Иначе
			Сумма = Сумма + Функция_1(х);
		КонецЕсли;
		х = х + h;
	КонецЦикла;
	Возврат h*Сумма;
КонецФункции

5) Метод Симпсона:

Функция РассчитатьСимпсона(Х_нач, Х_кон, Число_шагов)
	Сумма = 0;
	h = (Х_кон-Х_нач)/Число_шагов;
	х = Х_нач;
	СуммаЧетных	= 0;
	СуммаНеЧетных = 0;
	Для й=0 По Число_шагов Цикл
		Если й=0 или й=Число_шагов Тогда
			Сумма = Сумма + Функция_1(х);
		Иначе
			Если й % 2 = 0 Тогда
				СуммаЧетных = СуммаЧетных + Функция_1(х);
			Иначе
				СуммаНеЧетных = СуммаНеЧетных + Функция_1(х);
			КонецЕсли;
		КонецЕсли;
		х = х + h;
	КонецЦикла;
	Возврат (h/3)*(Сумма + 2*СуммаЧетных + 4*СуммаНеЧетных);
КонецФункции

Итак, для рассматриваемого примера получились вот такие результаты:

Метод левых прямоугольников = 41,04375
Метод правых прямоугольников = 42,29375
Метод средних прямоугольников = 41,665625
Метод трапеций = 41,66875
Метод Симпсона = 41,6666666666666667

Точное же значение интеграла = 125/3 ~ 41,6(6). Чтож, неплохо. 

В завершении нужно отметить, что вообще различных методов интегрирования существует довольно много, тем не менее, на практике большинство задач можно с успехом решать и этими.

19

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. Taktic 48 26.11.14 08:21 Сейчас в теме
О-да... незаменимая для 1С вещь - интегралы.
davay2000; +1 Ответить
4. DrAku1a 1300 27.11.14 02:36 Сейчас в теме
6. Gotcha 5 24.12.14 14:41 Сейчас в теме
(1) Taktic,
Спасибо, хоть вспомнил численные методы
10. eugeniezheludkov 32 26.12.14 03:00 Сейчас в теме
(1) Taktic, а чего вы смеетесь ? мне как то понадобилось реализовывать задачу где со слов заказчика "цена б/у товара меняется каждый день в зависимости от лежания на витрине, в сторону уменьшения, но не плавно, а сначала быстро, затем замедляется и совсем останавливается в течении полугода"... так вот Арктангенс решил эту задачку в одну строчку, а если-б понадобилось решать её в запросе то думаю через подаваемую таблицу рассчитанных арктангенсов в запрос, ну край если загрузить проц на сервере через ряды Макларена. думаю гдето могут и интегралы пригодиться, на вскидку: рассчитывать площади стекол для эксклюзивных оконных рам , изогнутых и тд., если это оконное предприятие. ПС 1/pow(х,2) не подошел
11. Идальго 120 26.12.14 08:12 Сейчас в теме
(10) eugeniezheludkov, почему не подошел f(x)=B + А/x^2 (где В - цена, ниже которой уже не опустится, А - влияет на изогнутость (скорость) уменьшения)? А почему арктангенс подошел я не понял, тогда уж 1/арктангенс, который в первой четверти как раз и напоминает предыдущую функцию. Или м.б. вообще что-то вроде f(x)=B+A/exp(x)
2. Михаил Козлов 106 26.11.14 10:53 Сейчас в теме
По поводу длинных дробных частей при арифметических операциях. Имеет смысл типизировать результат вычисления. Например, вместо массива лучше оперировать таблицей значений с одним типизированным столбцом.
И до кучи: проверял как-то метод Жордана-Гаусса для плохо обусловленной матрицы (система Горбунова). В свое время на Паскале для вещ. число с одинарной точностью получил, что метод давал правильное решение для размера матрицы = 18, для двойной точности - 23. В 1С метод был устойчив для размеров до 70.
3. Идальго 120 26.11.14 13:32 Сейчас в теме
(2) Михаил Козлов,
1. Да, именно из-за типизации такая штука.
2. Ну, если в 1с получалось точнее, то там наверно не одинарная точность была у чисел. А то, не совсем тогда ясна причина этого результата.
mr.Samuelson; +1 Ответить
5. Михаил Козлов 106 27.11.14 11:54 Сейчас в теме
(3) Идальго, Т.к. матрица было таб. частью обработки, то максимальная длина мантиссы - 32. Если через таблицу значений, то, вроде бы, - 64.
7. jobkostya1c8 24.12.14 20:26 Сейчас в теме
Все публикации говорят что раз автор разбирается в высшей математике и не поленился переписать алгоритмы на 1С то в остальном разберется. Может, заодно и курсовой проект (лабу, зачет, экзамен) сдал :)
Потом только предметную область изучать не отвлекаясь на язык 1С.
8. Идальго 120 24.12.14 20:34 Сейчас в теме
(7) kostyaomsk, да нее ))) Давно это всё изучали, сейчас уже подзабыл, вот и решил освежить в памяти.
9. so-quest 130 25.12.14 14:19 Сейчас в теме
Одежды на тетке много. А так - плюс.
12. jobkostya1c8 26.12.14 20:19 Сейчас в теме
Это уже из военного юмора. Слова отставного полковника или генерала "Мне, вашу мать, интеграл понадобился только чтоб из металла согнуть загогулину и что-то подцепить". Тут хоть куда-то арктангенс пригодился.
Оставьте свое сообщение

См. также

Полезняшки по СКД и построителям. Просто код 34

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Универсальные функции

Полезные процедуры и функции для работы с построителями и СКД. Просто исходник.

10.10.2019    1764    Yashazz    31       

Отслеживание выполнения фонового задания 133

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    7892    ids79    14       

Сохранение запроса со всеми параметрами и временными таблицами 20

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Универсальные функции

Функция сохранения запроса со всеми параметрами и временными таблицами в формате *.q1c для открытия в консоли запросов с диска ИТС.

13.05.2019    2358    Serge R    5       

Иерархия справочника Сверху Вниз. Получаем произвольное количество родителей "верхнего" уровня 7

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Иерархия справочника Сверху Вниз. Функция для получения произвольного количества родителей "верхнего" уровня. На примере справочника "Номенклатура".

28.03.2019    1973    obsfromekb    11       

Доработка проведения типовых документов в УТ 11.4, КА 2.4, ЕРП 2.4 100

Статья Программист Нет файла v8 v8::УФ ERP2 УТ11 КА2 Россия УУ Бесплатно (free) Практика программирования Универсальные функции Разработка

Различные варианты корректировки типовых механизмов проведения документов, без корректировки основной конфигурации. Использование расширений, подписок на событие и механизма локализации типовых документов.

22.03.2019    8619    ids79    14       

Добавление отчетов в типовые конфигурации 1С 200

Статья Программист Нет файла v8::УФ v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем)

Описание различных способов добавления общих и контекстных отчетов в конфигурации 1С, построенные на базе БСП. Основные моменты и нюансы.

07.03.2019    22772    ids79    32       

Расширение конструктора мобильного рабочего места для варианта "клиент 1С+RDP" (для любых wi-fi терминалов). Экосистема решений Simple WMS 20

Статья Программист Бизнес-аналитик Руководитель проекта Нет файла v8::УФ УУ Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Бесплатно (free) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Универсальные функции Мобильная разработка

Развитие проекта «Конструктор мобильного клиента на Android» https://infostart.ru/public/976636/ для устройств не на Андроиде (работающих в режиме RDP). В отличие от варианта Android работа на терминалах происходит в режиме 1С:Предприятие через RDP а конфигурации мобильных клиентов полностью совместимы для обоих версий. Т.е. конфигурация единая, создается один раз и ее может читать как Android -устройство, так и 1С-клиент на RDP без необходимости какой либо переделки.

05.02.2019    5775    informa1555    0       

Работа со строками: от простого к сложному 25

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Простые примеры работы со строками, в конце более читаемый разбор сложных текстов.

14.01.2019    7324    Evg-Lylyk    17       

Нумерация колонок субконто при выгрузке набора записей регистра бухгалтерии в таблицу значений 6

Статья Программист Нет файла v8 Бесплатно (free) Универсальные функции

Решение проблемы несовпадения номеров колонок с номерами субконто на счете при выгрузке в таблицу значений.

14.01.2019    2247    The Ded    3       

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке 458

Статья Программист Нет файла v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Зарплата Управление персоналом (HRM) Бесплатно (free) Универсальные функции

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    31155    GeterX    93       

Кадровые данные сотрудников в ЗУП 3.1 в отчетах 38

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Россия Управление персоналом (HRM) Бесплатно (free) Универсальные функции

Параметры используемые для получения данных сотрудников в ЗУП 3.1. Пригодится для разработки отчетов как напоминалка.

07.11.2018    12712    fromlion    12       

Добавление расшифровки в стандартные и добавленные внешние отчеты со стандартной формой отчета на СКД 72

Статья Программист Нет файла v8::УФ v8::СКД ERP2 УТ11 Россия Бесплатно (free) Универсальные функции

Описан способ добавления расшифровки отчета на СКД как встроенного в систему, так и добавленного внешнего отчета.

27.09.2018    6469    bmk74    2       

Функция НайтиФайлы() в каталоге netshare на Linux - обход ошибки работы 6

Статья Программист Нет файла v8 Linux Бесплатно (free) Практика программирования Универсальные функции

Решение проблемы применения функции НайтиФайлы() в каталоге с netshare на Linux-сервере - не работает поиск файлов по указанной маске (шаблону)

19.09.2018    3203    drmaxart    1       

Простой способ программно открыть заполненную форму нового (незаписанного) документа в тонком клиенте 15

Статья Программист Нет файла v8 Бесплатно (free) Универсальные функции

В этой публикации я поделюсь своим способом открывать программно новый незаписанный документ в тонком клиенте. Для использования этого способа потребуется немного модифицировать конфигурацию. Добавив универсальные процедуру и функцию, можно будет использовать их для любых документов/справочников.

09.06.2018    7328    Serge R    12       

Генерация временного ряда запросом 7

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Универсальные функции

Способ генерации последовательности дат средствами языка запроса 1С.

07.05.2018    5813    dim_zal    6       

Минимализмы 3 350

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35309    ildarovich    44       

Таблица значений в Таблицу HTML - функция с возможностью настройки цвета шапки, заголовков, выравнивания и размера колонок 83

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции

Если вам нужно быстро получить таблицу значений в виде строкового типа 1С в формате HTML, вам поможет эта функция, включена возможность автоматического вывода столбца пункт по порядку.

22.12.2017    18759    rpgshnik    21       

Пример преобразования двоичных данных в строку 26

Статья Программист Нет файла v8 Бесплатно (free) Универсальные функции

Доброго всем времени суток. Хочу поделиться маленьким решением маленькой проблемы. Думаю, будет интересно новичкам. Я не раз встречал на форумах вопрос: как преобразовать двоичные данные в строку? В частности, к примеру, частенько нужно получить хэш файла MD5 в текстовом виде, но как мы знаем 1С возвращает его в виде двоичных данных.

08.12.2017    12309    frkbvfnjh    19       

Функция сохранения картинок из книги Excel в каталог с определением координат на листе 8

Статья Программист Нет файла v8 Бесплатно (free) Загрузка и выгрузка в Excel Универсальные функции

Разбор файла *.xlsx как Web-архива, выгрузка изображений без потери качества, с определением положения изображений.

12.11.2017    7082    user634820_zergemoth    1       

Определяем контекст сеанса 1С программно (Тонкий/Толстый клиенты/HTTP-Сервис/Фоновое задание и т.д.) 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции

Иногда возникает необходимость программно определить контекст сеанса в 1С. Скажем вам надо понять что этот сеанс запущен и используется HTTP-Сервисом и не регламентным заданием или толстым клиентом. Порывшись в интернете я нашел только два способа которые не позволяли отличить регламентное задание от HTTP-Сервиса, стандартная функция ТекущийРежимЗапуска() тоже не позволяет определить запуск HTTP-Сервиса. Но в 1С есть стандартные средства которые позволяют решить эту задачу.

08.11.2017    15270    azubar    9       

Правила округления 5

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Универсальные функции

Округление числовых значений по трём правилам математики

30.10.2017    7634    dakork    4       

#Область ВНЕШНИЕ_ВЫЗОВЫ или MVC в 1С, библиотечность и упрощение интеграции кода 43

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Математика и алгоритмы Универсальные функции

Зачастую почти любой модуль в 1С содержит от одного до несметного множества вызовов других модулей. Как с этим бороться, чтобы было проще куда-то что-то переносить - в этом посте.

12.10.2017    14423    for_sale    58       

Получение даты, зная день недели и его порядок в месяце 10

Статья Программист Нет файла v8 Бесплатно (free) Универсальные функции

Иногда бывает необходимость получить "Первый понедельник месяца" или "Вторую пятницу месяца". Есть несколько способов решения вопроса. Опишу один из них.

12.09.2017    8061    987ww765    10       

Разность дат 21

Статья Программист Нет файла v8 Бесплатно (free) Универсальные функции

Иногда требуется получить разность дат в виде типа: 5 дней 6 месяцев 4 года. Это можно сделать с помощью запроса, получив на выходе сразу 3 нужных числа, без последующих вычислений.

11.08.2017    9688    jun-ko    24       

Простой способ преобразовать UNICODE в строку или в структуру 23

Статья Программист Нет файла v8 Россия Windows Бесплатно (free) Практика программирования Универсальные функции

Первая функция получает Строку, которая содержит строчки вида «Ключ=Значение». Вторая функция получает Структуру.

07.07.2017    7122    dimasts    5       

"Распределение в запросе" или "избавляемся от перебора" 182

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Математика и алгоритмы Универсальные функции

Хороший перебор - это отсутствие перебора. Рассмотрим пример замены полного перебора запросом.

16.12.2016    27709    alexandersh    45       

Пример работы с шаблоном Word через ole (клиент - сервер, тонкий клиент) - установка значений и заполнение таблицы 17

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

В примере показывается заполнение строк готовой таблицы, добавление новой таблицы, объединение ячеек, установка значений в "параметр".

09.11.2016    9967    gortrex    8       

Парсер JSON (Штатные средства 1С 8.3.6) 59

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Хочу поделиться функцией чтения json, реализованной с помощью штатных средств платформы.

29.09.2016    46156    dour-dead    21       

Программное создание графических схем (v.2): API для ГрафическойСхемы 73

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Работа с интерфейсом Универсальные функции

Пример динамического создания графических схем, добавления элементов любых видов. Любые схемы без бизнес-процессов. Программная работа со схемой. Отличие от существующей статьи в том, что здесь используется объектная модель. Исправил и упростил некоторые моменты - результат соответствует схеме, созданной руками. Добавил возможность рисования произвольных форм для существующих фигур.

27.09.2016    16833    serg_infostart    15       

Вычитание рабочих дней от текущей даты 7

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования Универсальные функции

Функция возвращает дату, которая меньше указанной даты на количество рабочих дней по выбранному графику

08.09.2016    9565    semenich_b    7       

Используем механизмы обмена данными БСП для произвольного обмена 147

Статья Программист Нет файла v8 Бесплатно (free) Универсальные функции Внешние источники данных БСП (Библиотека стандартных подсистем)

Механизм БСП заточен на обмен XML по правилам обмена. Чтобы использовать его для любого другого обмена, коих в мире немало, требуются доработки. В статье описан вариант, как из положения выйти.

23.08.2016    27586    Патриот    22       

Склонение числа прописью 25

Статья Программист Нет файла v8 Бесплатно (free) Универсальные функции

Склоняет число прописью до 999999 Пример: до склонения "Не позднее 3 (Три) дней", после - "Не позднее 3 (Трех) дней"

18.08.2016    15802    maxvcb    27       

Отборы в отчётах. Нюансы работы компоновщика настроек. 132

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Открытие отчёта с предустановленным отбором, показанным пользователю. Изменение любых настроек в процессе работы отчёта. Взаимосвязи настроек.

15.08.2016    59011    Yashazz    23       

Автоматическое добавление новых реквизитов на форму (УФ) 38

Статья Программист Нет файла v8 v8::УФ Бесплатно (free) Работа с интерфейсом Универсальные функции

Идея такая: Программист добавил реквизит в объект. В комментарии этого реквизита прописал некое спец. слово (можно не матерное). На форму объекта новый реквизит далее попадает автоматом в спец. группу "Дополнительно".

03.08.2016    16140    Патриот    23       

HOWTO: создание и отладка HTTP-сервиса в 1С:Предприятие 123

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) WEB Практика программирования Универсальные функции

Статья о том, как можно быстро создать HTTP-сервис в 1С:Предприятие и как выполнять его отладку.

25.07.2016    39280    serg_infostart    19       

Цикл ввода данных, пример решения 41

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Отказ от модальности создает проблему организации последовательного ввода данных в рамках одной пользовательской операции. Цепочки процедур, обрабатывающих введенные данные и вызывающие следующий диалог - головная боль даже для самостоятельной поддержки или изменения логики ввода, не говоря о том уже, чтобы разбираться в чужом коде. Предлагаемое решение является некой заготовкой и может быть любым образом улучшено.

12.07.2016    11125    botokash    7       

Поиск несериализуемых значений при помещении в хранилище 12

Статья Программист Нет файла v8 Windows Бесплатно (free) Инструментарий разработчика Практика программирования Универсальные функции

В статье разобран пример, как найти несериализуемые значения в случае помещения в хранилище коллекций, содержащих вложенные элементы. В качестве хранилищ рассмотрены временное хранилище значений и переменные типа ХранилищеЗначения.

02.03.2016    19991    balanton    2       

Универсальные функции с примерами использования 241

Статья Программист Нет файла v8 Бесплатно (free) Универсальные функции

14 универсальных функций, с примерами использования - для обычного и управляемого интерфейса

26.02.2016    35309    unichkin    36       

Преобразование числа в строку в запросе 1С 8.x 21

Статья Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Универсальные функции

В запросах 1С предприятие 8.x есть ограничение: нельзя преобразовывать число в строку.

23.02.2016    32848    lastcontra    19       

Изменения параметра или отбора типа Дата в форме отчета 6

Статья Программист Нет файла v8 Бесплатно (free) Универсальные функции

Иногда в отчетах стандартных периодов (Начало текущего месяца, начало следующего месяца и т.д.) недостаточно. Приходится ставить произвольную дату и устанавливать периоды вручную (конец месяца, конец недели и т.д.). В публикации выложен листинг кода, который должен ускорить установку параметров и отборов с типом Дата.

08.02.2016    9764    dj_serega    3       

Использование классов .Net в 1С для новичков 147

Статья Программист Нет файла v7.7 v8 Windows Бесплатно (free) Практика программирования Разработка внешних компонент Универсальные функции

Руководство для новичков. Написав статью http://infostart.ru/public/238584/, я понял, что многие не понимают того, что написано. Поэтому в этой статье постараюсь более подробно остановиться на азах и без кода на вражеском языке (C#)

27.01.2016    62575    Serginio    104       

Быстрое визуальное сравнение двух таблиц значений 18

Статья Программист Нет файла v8 Windows Бесплатно (free) Универсальные функции

Предлагаю простой способ сравнить две таблицы значений.

13.11.2015    11855    Mi4man    14       

Перебор всех строк дерева значений в глубину 2

Статья Программист Нет файла v8 Windows Бесплатно (free) Универсальные функции

Процедура и функция перебора всех строк дерева значений в глубину.

11.11.2015    11370    kosmo0    6       

Три приёма, позволяющие сделать интерфейс конфигураций 1С на управляемых формах удобнее при большом шрифте 52

Статья Программист Нет файла v8 УНФ ERP2 БП3.0 Windows Бесплатно (free) Работа с интерфейсом Универсальные функции

С появлением управляемых форм вообще и БП 3.0 в частности пользователи, которые не хотят портить своё зрение рассматриванием мелкого шрифта, оказались в невыгодном положении. Многих элементов на экране в "тяжёлых" документах вообще оказалось не видно. Все попытки решить вопрос штатными средствами настройки предприятия оказались неэффективны. Вот несколько приёмов, которые буквально в два щелчка мышкой и парой строк кода помогут решить проблему.

05.11.2015    14939    H-Labs    11