IE2017

Подсистема проверки контрагентов через сервис ГосРеестра для объединения с любой конфигурацией (или автономной работы)

Обработки - Универсальные обработки

Еще один вариант для проверки контрагентов через сервис ФНС. Механизм аналогичен проверке в типовой  БП 3.0 и полностью автономен, можно объединить с любой конфигурацией. При первом запуске просит ввести логин и пароль для доступа к сайту поддержки 1С.

В конфигурации добавлены справочники, перечисления и регистр сведений, которые необходимы для работы подсистемы. Если вы собираетесь объединять с любой типовой конфигурацией - эти объекты метаданных там наверняка есть. В таком случае лучше убрать их объединение и добавить только те, которых нет. После объединения, возможно, надо будет дать права на новые объекты тем ролям, которым это необходимо. В справочнике контрагентов в формах списка и элемента есть примеры работы с запросами к сервису проверки, их можно будет вернуть вручную после объединения, там всего пара кнопок и процедур.

За основу для разработки взят механизм из типовой БП 3.0. При загрузке в пустую конфигурацию запускается и работает, проверено. Но делалась быстро, поэтому возможны ошибки, если что не так - пишите.

Есть 2 версии файла конфигурации, для движка 8.3.5.1383 и 8.2.19.106. В версии для 8.2 форма отчета обычная, не управляемая.

Скачать файлы

Наименование Файл Версия Размер
ПодсистемаПроверкиКонтрагентовЧерезГосРеестр83
.cf 655,92Kb
20.04.15
26
.cf 655,92Kb 26 Скачать
ПодсистемаПроверкиКонтрагентовЧерезГосРеестр82
.cf 643,60Kb
20.04.15
17
.cf 643,60Kb 17 Скачать

См. также

Комментарии
1. Михаил Коваль (mihey) 13 06.04.15 22:33 Сейчас в теме
Можете еще выложить скрин самого досье?
2. Сергей Каберов (Foxes82) 12 06.04.15 22:57 Сейчас в теме
3. Сергей (seermak) 656 07.04.15 06:11 Сейчас в теме
(0) только в БП3 написано что сервис тестовый и бесплатен до.... точно не помню(((((
4. Разве это имеет значение (-fox-) 07.04.15 08:49 Сейчас в теме
А ограничения на количество проверяемых КА за день есть?
5. Сергей Каберов (Foxes82) 12 07.04.15 09:24 Сейчас в теме
По поводу вопросов 3 и 4 сказать ничего не могу, не изучал эту тему досконально.
Пока тестировал никаких ограничений не видел, и по поводу того что он тестовый тоже. Надо читать на офф. сайте.
6. Айрат Саттаров (kwazi) 177 07.04.15 09:28 Сейчас в теме
надо бы в карточку контрагента выводить результат проверки и сделать заполнение по инн. а еще из БП можно выдернуть хранение истории КПП.
7. Сергей Каберов (Foxes82) 12 07.04.15 09:50 Сейчас в теме
(6) kwazi, Это возможно в перспективе, сейчас пока нет времени свободного совсем..
Желающие могут доработать сами под себя, для программиста это не сложно должно быть )
8. Сергей Ожерельев (Поручик) 3591 21.04.15 23:20 Сейчас в теме
(3) После 31.05.2015 условия изменятся. Так написано в форме подключения к сервису в БП 3.0.
9. Сергей Каберов (Foxes82) 12 21.04.15 23:24 Сейчас в теме
А что именно изменится, не подскажете?

P.S. Вообще, если честно, они и БП 2.0 уже 3-й год как с поддержки снимают, так что любят товарищи попугать народ.. для профилактики наверное :)
10. Сергей Ожерельев (Поручик) 3591 22.04.15 22:26 Сейчас в теме
(9) Открываете досье контрагента и читаете
После 31.05.2015 условия получения сервиса будут изменены. Подробнее: https://portal.1c.ru/applications/3#conditions
11. Сергей Каберов (Foxes82) 12 23.04.15 11:07 Сейчас в теме
(10) Поручик, Так там кроме того что договор ИТС должен быть заключен ничего не написано вроде, читал уже как-то. А про какие-то изменения с начала лета вообще ни слова.
12. Peter Metelkin (iiceberg) 78 09.08.17 11:53 Сейчас в теме
ЕСли обработка не работает и выдает ошибку, то читаем в журнале сообщение.
там ссылка ПДФ. В ПДФе написано
... "С 1 января 2017 года планируется отключение старого источника данных. Чтобы сервис
«1С:Контрагент» продолжил работу, необходимо либо перейти на релиз конфигурации, в которой
используется версия БСП 2.3.2.51 и выше, либо самостоятельно настроить подключение к новому
источнику данных, перейдя в конфигурации на интерфейс
https://api.orgregister.1c.ru/orgregister/v7?wsdl." ...
Соответственно нам надо внести небольшие корректировки в модули.
В общем модуле "СервисДанныхЕдиныхГосРеестров" заменяем процедуры на ;

Функция ПроксиСервиса(ОписаниеОшибки)
	
	Прокси = Неопределено;
	ПараметрыАутентификации = ПараметрыАутентификацииВСервисе();
	
	Если ПараметрыАутентификации = Неопределено Тогда
		
		// Служебный текст. Должен быть обработан на клиенте.
		ОписаниеОшибки = "НеУказаныПараметрыАутентификации"; 
		
	Иначе
		
		Попытка
			Прокси = сдегрНеободимыеСвязанныеПроцедуры.WSПрокси(
				АдресСервиса(),                             // АдресWSDL
				ПространствоИмен(),                         // URIПространстваИмен
				//{[-](фрагмент удален)Администратор3 09.08.2017 11:32:24
				//"RequisitesWebServiceEndpointImpl3Service", // ИмяСервиса
				//"RequisitesWebServiceEndpointImpl3Port",    // ИмяТочкиПодключения
				//}Администратор3 09.08.2017 11:32:24
				// с 01-01-2017
				//{[+](фрагмент добавлен), Администратор3 09.08.2017 11:32:38
				"RequisitesWebServiceEndpointImpl7Service",
				"RequisitesWebServiceEndpointImpl7Port",
				//}Администратор3 09.08.2017 11:32:38
				ПараметрыАутентификации.login,              // ИмяПользователя
				ПараметрыАутентификации.password,           // Пароль
				60);                                        //Таймаут
			Исключение
			ИнформацияОбОшибке = ИнформацияОбОшибке();
			ОписаниеОшибки = ПодробноеПредставлениеОшибки(ИнформацияОбОшибке);
		КонецПопытки; 
		
	КонецЕсли;
	
	Возврат Прокси;
	
КонецФункции

Функция ПараметрыАутентификацииВСервисе()
	
	ДанныеАутентификации = ДанныеАутентификацииПользователяИнтернетПоддержки();
	Если ДанныеАутентификации <> Неопределено Тогда
		Возврат Новый Структура("login,password", 
		ДанныеАутентификации.Логин, 
		ДанныеАутентификации.Пароль);
	Иначе
		Возврат Неопределено;
	КонецЕсли;
	
КонецФункции

Функция ДанныеАутентификацииПользователяИнтернетПоддержки() Экспорт
	
	СохраненныеПараметры = Константы.ПараметрыПодключенияКСервисуГосРеестра.Получить().Получить();
	Если СохраненныеПараметры = Неопределено Тогда
		ФормаПараметровПодключения = ПолучитьОбщуюФорму("НастройкиПодключенияКСервисуГосРеестра");
		СохраненныеПараметры = ФормаПараметровПодключения.ОткрытьМодально();
	КонецЕсли;
	
	Возврат СохраненныеПараметры;
	
КонецФункции

Функция АдресСервиса()
	
	//{[-](фрагмент удален)Администратор3 09.08.2017 11:32:54
	//Возврат "https://api.orgregister.1c.ru/orgregister/v3?wsdl";
	//}Администратор3 09.08.2017 11:32:54
	// с 01-01-2017
	//{[+](фрагмент добавлен), Администратор3 09.08.2017 11:33:05
	Возврат "https://api.orgregister.1c.ru/orgregister/v7?wsdl";
	//}Администратор3 09.08.2017 11:33:05
КонецФункции

Функция ПространствоИмен()

	//{[-](фрагмент удален)Администратор3 09.08.2017 11:33:16
	//Возврат "http://ws.orgregister.company1c.com/";
	//}Администратор3 09.08.2017 11:33:16
	//{[+](фрагмент добавлен), Администратор3 09.08.2017 11:33:25
	Возврат "http://ws.orgregister.company1c.com/";
	//}Администратор3 09.08.2017 11:33:25

КонецФункции

...Показать Скрыть


проверяем. Работает.
Оставьте свое сообщение