Универсальный отчет по метаданным

Программирование - Инструментарий

В основе - универсальный отчет из БП 3.0, все, что ему необходимо для работы из общих объектов, модулей и форм, родной конфигурации перенесено в "тело" самого отчета. Таким образом отчет запускается и работает полностью автономно, под любой конфигурацией, в т.ч. пустой.

В ходе одного из проектов пользователям понадобился универсальный отчет на упр. формах для просмотра данных по регистрам (остатки, обороты в различных группировках и т.п.)..

Универсальный отчет из БП 3.0 был очень кстати, кроме одного НО - большая часть его функциональности находится в общих модулях. В нашей же конфе этих модулей нет. Не переносить же их теперь.

На инфостарте, конечно же, есть подобные отчеты, но полностью независимых не нашел. В том числе здесь //infostart.ru/public/281400/ При попытке запустить не в "родной среде" лезут ошибки, "Переменная не определена" и т.п.,  Потому решил запостить свой, может кому пригодится.

Результат здесь - уничерсальный отчет, работающий в любой конфигурации, в том числе пустой

ЗЫ: Хотелось еще причесать код, но ввиду отсутствия времени, пока выкладываю так. Критика приветствуется.

 

ЗЫЫ: Исправлена ошибка при формировании в серверном варианте ИБ

Скачать файлы

Наименование Файл Версия Размер
Универсальный отчет по метаданным
.erf 74,04Kb
28.04.15
72
.erf 1 74,04Kb 72 Скачать

См. также

Комментарии
1. Armando Armando (Armando) 1382 20.04.15 02:48 Сейчас в теме
Мне в бухе 2.0 универсальный больше нравился. Там расширенные настройки есть, в в этом нет(
2. Вадим Загородный (v.zagorodniy) 23.04.15 14:07 Сейчас в теме
Выдает ошибку: "Метод объекта не обнаружен (Вставить)".
3. Sergey Dikov (DikovSV) 8 24.04.15 07:18 Сейчас в теме
(2) v.zagorodniy, чуть подробнее, плз. В какой момент?
4. Вадим Загородный (v.zagorodniy) 24.04.15 12:43 Сейчас в теме
(3) DikovSV, После выбора объекта метаданных при нажатии на кнопку "Сформировать". 1С:Предприятие 8.3 (8.3.5.1383)
5. Sergey Dikov (DikovSV) 8 24.04.15 16:17 Сейчас в теме
(4) v.zagorodniy, Установил себе 8.3.5.1383. Ошибка не воспроизводится ни на толстом, ни на тонком клиенте, в т.ч. на пустой конфе.
6. Вадим Загородный (v.zagorodniy) 27.04.15 15:34 Сейчас в теме
(5) DikovSV, а в серверном варианте?
7. Sergey Dikov (DikovSV) 8 28.04.15 18:06 Сейчас в теме
(6) v.zagorodniy, Согласен. Поправил. :)
8. yamawa yamawa (yamawa) 49 26.06.15 12:09 Сейчас в теме
Работает в ЗУП 3.0, релиз 3.0.22.219.
Спасибо.
9. Иван Иванов (p.shakotko) 10.11.15 13:55 Сейчас в теме
Работает ли данный отчет под 8.2.19.130? И работает ли он для регистров сведений?
10. игорь Бельский (igori3333) 12 07.01.16 10:20 Сейчас в теме
Не выдаёт корректно остатки на дату, только на день формирования отчёта.
11. Андрей Суворов (AndroidRu) 1 19.07.17 15:29 Сейчас в теме
В УТ 11 ошибки в блоке кода при расшифровке данных в ячейках сформированного отчета:
		Если ВычислитьНаКлиенте Тогда
				СуммаВЯчейках = 0;
				Для ИндексСтрока = СтруктураАдресВыделеннойОбласти.Верх По СтруктураАдресВыделеннойОбласти.Низ Цикл
					Для ИндексКолонка = СтруктураАдресВыделеннойОбласти.Лево По СтруктураАдресВыделеннойОбласти.Право Цикл
						Попытка
							Ячейка = Результат.Область(ИндексСтрока, ИндексКолонка, ИндексСтрока, ИндексКолонка);
							Если Ячейка.Видимость = Истина Тогда
								Если Ячейка.СодержитЗначение И ТипЗнч(Ячейка.Значение) = Тип("Число") Тогда
									СуммаВЯчейках = СуммаВЯчейках + Ячейка.Значение;
								ИначеЕсли ЗначениеЗаполнено(Ячейка.Текст) Тогда
//Ошибка тут: (преобразование значения к типу число не может быть выполнена) 									
ЧислоВЯчейке  = Вычислить("Число(СтрЗаменить(Ячейка.Текст, Символ(32), Символ(0)))");
									СуммаВЯчейках = СуммаВЯчейках + ЧислоВЯчейке;
								КонецЕсли;
							КонецЕсли;
						Исключение
						КонецПопытки;
					КонецЦикла;
				КонецЦикла;
	
Показать
12. Дамир Закиров (Dzenn) 60 25.08.17 13:30 Сейчас в теме
Отличная вещь, благодарю. Ровно то, что нужно.
Оставьте свое сообщение