Перемещение на определенную позицию (в табличной части документа)

Публикация № 357674

Разработка - Практика программирования

Перемещение позиция табличная часть

1
Иногда необходимо перемещать элемент табличной части документа в КОНКРЕТНУЮ позицию чтобы не кликать по 100 раз на кнопку "Переместить вниз (Ctrl+Shift+Down)" или "Переместить вверх (Ctrl+Shift+Up)". Для этого случая я и добавил в панель еще одну кнопку.

По просьбам трудящихся создал кнопку в панели табличной части документа, которая перемещает выделенную строку на определенную позицию. В скриншотах, для наглядности, приведены картинки. А ниже описание, как это сделать, с картинками.

1) Добавляем кнопку на панель и прописываем ей процедуру.


 

 

2) Вставляем в процедуру текст.

Процедура с_КоманднаяПанельТоварыДействиеПереместитьНаПозицию(Кнопка)
    //Проверим чтоб выбрали строку для перемещения
    Если ТипЗнч(ЭтаФорма.ТекущийЭлемент) <> Тип("ТабличноеПоле") Тогда
        Предупреждение("Вы не выбрали строку которую необходимо переместить.");
        Возврат;
    КонецЕсли;
    
    Рез = ОткрытьФормуМодально("ОбщаяФорма.с_ФормаДляПеремещения");
    //Сначала проверим адекватность требуемого номера строки
    Если Рез>=1 И Рез<=Товары.Количество() Тогда
        
        Табл = новый ТаблицаЗначений;
        Если Табл.Колонки.Количество()>0 Тогда
            Табл.Очистить();                
        Иначе   
            Табл = Товары.Выгрузить();
            Табл.Очистить();
        КонецЕсли;         
        
        ТекНом = ЭтаФорма.ТекущийЭлемент.ТекущаяСтрока.НомерСтроки;
        ТекСтрок = ЭтаФорма.ТекущийЭлемент.ТекущаяСтрока;
        Если Рез>ТекНом Тогда //Перемещаем вниз    
            ПеремСтр = ТекНом-1;
            Для й=0 по ТекНом-2 Цикл
                НовСтрТабл = Табл.Добавить();
                Для й1=0 По Табл.Колонки.Количество()-1 Цикл
                    Если (СокрЛП(Табл.Колонки[й1].имя) <> "НомерСтроки") Тогда
                        НовСтрТабл[Табл.Колонки[й1].Имя] = Товары[й][Табл.Колонки[й1].Имя];
                    КонецЕсли;                    
                КонецЦикла;
            КонецЦикла;
            Для й=ТекНом по Рез-1 Цикл
                НовСтрТабл = Табл.Добавить();
                Для й1=0 По Табл.Колонки.Количество()-1 Цикл
                    Если (СокрЛП(Табл.Колонки[й1].имя) <> "НомерСтроки") Тогда
                        НовСтрТабл[Табл.Колонки[й1].Имя] = Товары[й][Табл.Колонки[й1].Имя];                        
                    КонецЕсли;                    
                КонецЦикла;
            КонецЦикла;
            
            НовСтрТабл = Табл.Добавить();
            Для й1=0 По Табл.Колонки.Количество()-1 Цикл
                Если (СокрЛП(Табл.Колонки[й1].имя) <> "НомерСтроки") Тогда
                    НовСтрТабл[Табл.Колонки[й1].Имя] = Товары[ПеремСтр][Табл.Колонки[й1].Имя];                        
                КонецЕсли;                    
            КонецЦикла;                 
            
            Для й=Рез по Товары.Количество()-1 Цикл
                НовСтрТабл = Табл.Добавить();
                Для й1=0 По Табл.Колонки.Количество()-1 Цикл
                    Если (СокрЛП(Табл.Колонки[й1].имя) <> "НомерСтроки") Тогда
                        НовСтрТабл[Табл.Колонки[й1].Имя] = Товары[й][Табл.Колонки[й1].Имя];                    
                    КонецЕсли;                    
                КонецЦикла;
            КонецЦикла;
            
            Товары.Очистить();
            //Теперь перекинем из Табл в табличную часть
            Для каждого стрТабл Из Табл Цикл
                НовСтрТов = Товары.Добавить();
                Для й2=0 По Табл.Колонки.Количество()-1 Цикл
                    Если (СокрЛП(Табл.Колонки[й2].имя) <> "НомерСтроки") Тогда
                        НовСтрТов[Табл.Колонки[й2].имя] = СтрТабл[й2];                        
                    КонецЕсли;
                КонецЦикла;            
            КонецЦикла;
            
            
        ИначеЕсли Рез<ТекНом Тогда  //Перемещаем вверх
            ПеремСтр = ТекНом-1;
            Для й=0 по Рез-2 Цикл
                НовСтрТабл = Табл.Добавить();
                Для й1=0 По Табл.Колонки.Количество()-1 Цикл
                    Если (СокрЛП(Табл.Колонки[й1].имя) <> "НомерСтроки") Тогда
                        НовСтрТабл[Табл.Колонки[й1].Имя] = Товары[й][Табл.Колонки[й1].Имя];                        
                    КонецЕсли;                    
                КонецЦикла;
            КонецЦикла;
            
            НовСтрТабл = Табл.Добавить();
            Для й1=0 По Табл.Колонки.Количество()-1 Цикл
                Если (СокрЛП(Табл.Колонки[й1].имя) <> "НомерСтроки") Тогда
                    НовСтрТабл[Табл.Колонки[й1].Имя] = Товары[ПеремСтр][Табл.Колонки[й1].Имя];                        
                КонецЕсли;                    
            КонецЦикла;
            
            Для й=Рез-1 по ТекНом-2 Цикл
                НовСтрТабл = Табл.Добавить();
                Для й1=0 По Табл.Колонки.Количество()-1 Цикл
                    Если (СокрЛП(Табл.Колонки[й1].имя) <> "НомерСтроки") Тогда
                        НовСтрТабл[Табл.Колонки[й1].Имя] = Товары[й][Табл.Колонки[й1].Имя];                        
                    КонецЕсли;                    
                КонецЦикла;
            КонецЦикла;
            
            Для й=ТекНом по Товары.Количество()-1 Цикл
                НовСтрТабл = Табл.Добавить();
                Для й1=0 По Табл.Колонки.Количество()-1 Цикл
                    Если (СокрЛП(Табл.Колонки[й1].имя) <> "НомерСтроки") Тогда
                        НовСтрТабл[Табл.Колонки[й1].Имя] = Товары[й][Табл.Колонки[й1].Имя];                    
                    КонецЕсли;                    
                КонецЦикла;
            КонецЦикла;
            
            
            
            Товары.Очистить();
            //Теперь перекинем из Табл в табличную часть
            Для каждого стрТабл Из Табл Цикл
                НовСтрТов = Товары.Добавить();
                Для й2=0 По Табл.Колонки.Количество()-1 Цикл
                    Если (СокрЛП(Табл.Колонки[й2].имя) <> "НомерСтроки") Тогда
                        НовСтрТов[Табл.Колонки[й2].имя] = СтрТабл[й2];                        
                    КонецЕсли;
                КонецЦикла;            
            КонецЦикла;
        Иначе //Ничего не делаем        
        КонецЕсли;
    Иначе
        Предупреждение("Нет такого числа, попробуйте еще раз.");
    КонецЕсли;    
    
КонецПроцедуры

 

3) В общих формах рисуем форму.

 

Кнопке "Ок" прописываем процедуру с текстом:

Процедура ОсновныеДействияФормыОк(Кнопка)
    ЭтаФорма.Закрыть(ПолеВвода1);
КонецПроцедуры

 

Вот и все.

Запускаете и работаете.

1

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. binex 262 23.05.15 12:28 Сейчас в теме
Я может что-то недопонял, но не проще ли было использовать метод табличной части Сдвинуть(<Строка>, <Смещение>) ?!

PS и ВвестиЗначение, до кучи...
Sintson; корум; TMV; +3 Ответить
2. Lyns_owner 340 23.05.15 16:14 Сейчас в теме
Зачем рисовать отдельную форму, когда есть стандартная процедура "ВвестиЧисло"? Публикация не о чем. Минус ставить не буду, автор старался))
3. WKBAPKA 211 24.05.15 08:40 Сейчас в теме
4. genayo 24.05.15 09:05 Сейчас в теме
Ни разу никто не просил сделать перемещение элемента в определенную позицию, приведите пример, зачем это может понадобиться?
5. TMV 14 24.05.15 10:52 Сейчас в теме
(4) genayo, вот уж точно, а тут прям "зачастую", серьезно?!
14. корум 311 03.05.17 11:05 Сейчас в теме
(4) например, в случае, когда заявка привязана к плану помещения в проекте, и каждое оборудование обязано иметь свой неизменный номер.
6. Serg23ru 47 27.05.15 23:42 Сейчас в теме
Не буду спорить, "зачастую" - громко сказано, (исправлю чтоб не резало слух), но я это внедрил уже в 3-х фирмах. Для одной из них писал по заказу, двум другим предложил это внедрить, когда увидел как они мучаются и мое предложение встретили на УРА.

Для чего на фирме работники в табличной части документа гоняют позиции то вверх, то вниз - не знаю, но могу узнать (как узнаю - напишу).

7. karapuzzzz 63 29.05.15 12:47 Сейчас в теме
А все потому что не умеете пользоваться синтакс-помощником. Дохрена кода можно вместить в 2 строчки без необходимости рисования отдельной формы:
8. OVladius 32 15.03.17 23:53 Сейчас в теме
Понимаю что данной теме уже 2 года, но все же, может кому то пригодится более разумный вариант перемещения строки :)


	Значение = 0;
	
	Если ВвестиЧисло(Значение, "Введите номер строки...") Тогда
		ТекущаяСтрока 		= ЭлементыФормы.Товары.ТекущаяСтрока;
		
		Если Значение > ТекущаяСтрока.НомерСтроки Тогда
			// Перемещаем вверх
			Товары.Сдвинуть(ТекущаяСтрока, Число(Значение - ТекущаяСтрока.НомерСтроки) );
		Иначе	
			// Перемещаем вниз
			Товары.Сдвинуть(ТекущаяСтрока, Число(Число(Значение * -1) - Число(ТекущаяСтрока.НомерСтроки * -1)) * -1);
		КонецЕсли; 
	КонецЕсли;
Показать
88wau24ru; +1 Ответить
9. ResetAtreides 16.03.17 09:15 Сейчас в теме
(8) Чет вы с функцией "Число()" увлеклись и забыли правила раскрытия скобок со знаком. Если бы скобки раскрыли, или просто минус за скобки вынесли, то увидели бы что условия никакого не надо и обе функции "Сдвинуть" выполняются с одинаковыми параметрами.
10. OVladius 32 16.03.17 23:28 Сейчас в теме
(9)А ну ка объясните, про какие правила раскрытия скобок я забыл)))) интересно)

Я умножаю на минус что бы число отрицательно получить что бы сдвинуть строку назад.
16. 88wau24ru 18 23.04.18 11:31 Сейчас в теме
(8)
кобки домножается на ещё один (-1). А эти все "Число" и "-1" вместо простого минуса только мешают увидеть что за выражение получается

Спасибо! дополню
	ТекДан = ЭлементыФормы.Товары.ТекущиеДанные;
		Если ТекДан = Неопределено Тогда
			Сообщить("Не выбрана номенклатура");
			Возврат;
		КонецЕсли;
		
	Значение = ТекДан.НомерСтроки;
    
    Если ВвестиЧисло(Значение
Показать
17. 88wau24ru 18 23.04.18 15:56 Сейчас в теме
(8)
Работает без вызовов исключений.
	ТекДан = ЭлементыФормы.Товары.ТекущиеДанные;
	Если ТекДан = Неопределено Тогда Сообщить("Не выбрана номенклатура"); Возврат; КонецЕсли;
	
	НаСтр = ТекДан.НомерСтроки;
	
	Если ВвестиЧисло(НаСтр, "Перенести на строку ...") Тогда НаСтр = ?(НаСтр>ЭтотОбъект.Товары.Количество(), ЭтотОбъект.Товары.Количество(), ?(НаСтр=0, 1, Макс(НаСтр, -НаСтр))); ЭтотОбъект.Товары.Сдвинуть(ТекДан, НаСтр-ТекДан.НомерСтроки); КонецЕсли;
18. 88wau24ru 18 16.05.18 17:25 Сейчас в теме
(17)
Работает без вызовов исключений.

Процедура КоманднаяПанельТоварыПеренестиНаEpartner(Кнопка)
	
	КоличСтр = ЭтотОбъект.Товары.Количество();
	Если Не КоличСтр>1 Тогда Возврат; КонецЕсли;
	
	ТекДан = ЭлементыФормы.Товары.ТекущиеДанные;
	Если ТекДан = Неопределено Тогда Сообщить("Не выбрана номенклатура"); Возврат; КонецЕсли;
	НаСтр = ТекДан.НомерСтроки;
	
	Если ВвестиЧисло(НаСтр, "Перенести на строку №...") Тогда НаСтр = ?(НаСтр>КоличСтр, КоличСтр, ?(НаСтр<1, 1, НаСтр)); ЭтотОбъект.Товары.Сдвинуть(ТекДан, НаСтр-ТекДан.НомерСтроки); КонецЕсли;
	
КонецПроцедуры
Показать
11. ResetAtreides 17.03.17 08:46 Сейчас в теме
Число(Число(Значение * -1) - Число(ТекущаяСтрока.НомерСтроки * -1)) * -1) =
(Значение*(-1) - ТекущаяСтрока.НомерСтроки(*-1)) * (-1) =
(-1)*Значение*(-1) - (-1)*ТекущаяСтрока.НомерСтроки*(-1) =
(-1)*(-1)*Значение - (-1)*(-1)*ТекущаяСтрока.НомерСтроки =
Значение - ТекущаяСтрока.НомерСтроки

Меньше ненужных функций используйте, тогда это сразу бы видно было. Уже во втором упрощении видно, что вынесенный (-1) за скобки домножается на ещё один (-1). А эти все "Число" и "-1" вместо простого минуса только мешают увидеть что за выражение получается
12. pafftis 12 03.05.17 10:29 Сейчас в теме
Подскажите как мне вставить перемещение по товарам вверх вниз:
13. pafftis 12 03.05.17 10:29 Сейчас в теме
Маленькое изображение сменил на большое
Прикрепленные файлы:
15. Mogilnikova 52 06.02.18 16:04 Сейчас в теме
УФ 8.3.10

Столкнулась с этой функцией и была неприятно удивлена качеством описания:

ДанныеФормыКоллекция (FormDataCollection)
Сдвинуть(<Индекс>, <Количество>)
Параметры:
<Индекс> (необязательный)
Тип: Число.
Расположение элемента в коллекции.
<Количество> (необязательный)
Тип: Число.
Количество элементов, на которое нужно сдвинуть указанный элемент. Положительное смещение обозначает сдвиг в конец, отрицательное - в начало коллекции.


Если опираться на опыт прошлых релизов платформы, можно было бы логично предположить что Индекс - Идентификатор строки, но нет. Судя по поведению функции, Индекс в данном случае - текущий номер строки.
Оставьте свое сообщение

См. также

Агрегатные функции СКД, о которых мало кто знает 314

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    9191    ids79    42       

Отслеживание выполнения фонового задания 133

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    7718    ids79    14       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 238

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    9521    ids79    22       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 125

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    8624    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 134

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования Разработка

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    8179    ids79    24       

"Меньше копипаста!", или как Вася универсальную процедуру писал 170

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    6060    SeiOkami    48       

Создание отчетов с помощью СКД - основные понятия и элементы 188

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    16760    ids79    16       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 174

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    11198    dmurk    134       

Подсистема "Варианты отчетов". Используете ли Вы ее правильно? 206

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Работа с интерфейсом БСП (Библиотека стандартных подсистем)

Небольшая история про использование подсистемы "Варианты отчетов" из БСП. Используете ли Вы ее правильно?

04.06.2019    13543    YPermitin    49       

Регистры накопления. Структура хранения в базе данных 172

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    16772    YPermitin    27       

Выполнение внешней обработки в фоновом задании 147

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    9446    Eret1k    22       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4627    m-rv    2       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7134    m-rv    16       

О расширениях замолвите слово... 192

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    15979    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 199

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    12445    ellavs    83       

Трюки с внешними источниками данных 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    12525    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 161

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    14992    ids79    9       

EnterpriseData – часть 2. Процесс выгрузки данных 125

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    12420    ids79    27       

Новый подход к обмену данными EnterpriseData 202

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    20888    ids79    72       

Программное заполнение пользовательских параметров и отборов СКД 135

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    19007    Unk92    18       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 125

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20502    ids79    40       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20148    tormozit    100       

Произвольный код в фоновом режиме 163

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    14332    nikita0832    41       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 144

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    20816    Rain88    42       

Повышаем эффективность разработки правил обмена 122

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19068    olegtymko    43       

Введение в механизм представлений в ЗУП ред. 3 152

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    24029    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    20973    m-rv    21       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    16784    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11188    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 126

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    23852    avfed@rambler.ru    19       

Минимализмы 3 350

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35196    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 108

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    25633    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21126    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 716

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    136133    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    22445    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 65

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    20884    unichkin    17       

Разбираемся с настройками компоновки данных 159

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    23820    json    9       

Работа с Excel 287

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24163    arakelyan    39       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    46230    bugtester    43       

Отказ от работы с временными файлами при работе с двоичными данными или Потоки как простая замена ADODB.Stream и временным файлам 126

Статья Программист Нет файла v8 Россия Бесплатно (free) Практика программирования

В платформе начиная с версии 3.8.9 (как я понял по документации) появился расширенный функционал средств работы с двоичными данными. Если раньше простой и очевидный способ преобразования данных строился на использовании временных файлов, то теперь благодаря новым средствам можно уйти от их использования.

12.09.2017    17996    vardeg    31       

Как сделать из &НаКлиентеНаСервереБезКонтекста почти &НаКлиентеНаСервере 124

Статья Программист Нет файла v8 1cv8.cf Россия Бесплатно (free) Практика программирования

Как сделать метод формы, доступный на клиенте и на сервере одновременно, и сохранить при этом удобство разработки

10.09.2017    33994    tormozit    72       

Ускоряем 1С: модули с повторным использованием возвращаемых значений 136

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

По роду своей деятельности, мне часто приходится обсуждать с программистами детали реализации той или иной функциональности. Очень часто, разговаривая даже с квалифицированными специалистами я сталкиваюсь с незнанием сути платформенной функциональности Повторного использования возвращаемых значений общих модулей. В данной статье я постараюсь дать краткий обзор и основные особенности этой функциональности.

04.09.2017    42823    m-rv    60       

Как просто запомнить алгоритм программного вывода в СКД 205

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования

Порой нужно быстро вывести на экран таблицу значений, используя СКД \ получить данные отчета в таблицу значений.. Несмотря на очевидность алгоритма - раньше мне проще было загуглить программный вывод, благо эта инфа есть везде. Но постепенно понял как его можно быстро вспомнить, и лишний раз ничего не искать. Конечно эта статья не для Гуру :) Но я думаю - что любой неопытный в СКД программист сделает для себя небольшое открытие...

01.09.2017    41260    unichkin    15       

Как формируется GUID? 459

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

"Коллеги, есть идеи, как получить последнюю созданную характеристику? Реквизиты полностью идентичны(код, наименование, и т.п.)."(c) "Насколько я знаю, ссылка не обеспечивает последовательность, а только уникальность."(c) "Я сделал по Максимум(Ссылка). Но, чета, мне кажется, это неправильно."(c) "Слышал что в ГУИд содержится как раз время создания и по всей логике вещей сортировка по ссылке должна сортировать по моменту создания объекта"(c) Сколько раз вы слышали такие фразы? На удивление я не обнаружил информации по этой теме, пришлось разбираться самому...

16.06.2017    51687    kuzyara    55