Преобразование правил обмена "на лету"

Публикация № 363564

Разработка - Практика программирования

обмен синхронизация конвертация данных правила обмена

26
Изменение правил обмена из кода конфигурации, без необходимости ручного обновления (внесения изменений/доработок) типовых правил при обновлении на новые релизы.

Буду краток. Ситуация:

Заказчику нужно дописать типовые правила обмена.

Для кого: статья подразумевает, что вы хорошо знакомы с программированием и имеете опыт работы с КД.

 

Дилемма: использовать КД, модифицировать правила, загрузить их как актуальные, поддерживать эти измененные правила актуальными при каждом обновлении на новый релиз (иначе однажды обмен может перестать работать).

 

Альтернатива (решение): написать код, который при нажати кнопки сам модифицирует типовые правила. Таким образом, для поддержания актуальности правил при очередном обновлении на релиз достаточно нажать эту кнопку.

 

Как это работает: любая типовая конфигурация - Синхронизация - Настройка синхронизации - Загрузить правила - "Из конфигурации" - кнопка "Записать и закрыть". В момент нажатия в регистр загружаются типовые правила обмена и далее используются как актуальные.

Данный код загрузки типовых правил мы и будем менять. В результате при нажатии на кнопку "Записать и закрыть" мы получим типовые правила обмена, но модифицированные согласно заложенному коду.

 

Реализация: Конфигуратор - обработки - КонвертацияОбъектовИнформационныхБаз - модуль объекта - процедура ЗагрузитьПравилаОбмена():

 

Процедура ЗагрузитьПравилаОбмена(Источник="",
ТипИсточника="XMLФайл",
СтрокаСообщенияОбОшибке = "",
ЗагружатьТолькоЗаголовокПравил = Ложь
) Экспорт
//...

СоздатьСтруктуруКонвертации();

ТаблицаПравилКонвертацииСвойств = Новый ТаблицаЗначений;
ИнициализацияТаблицыПравилКонвертацииСвойств(ТаблицаПравилКонвертацииСвойств);

// Возможно выбраны встроенные правила обмена (один из макетов).

ИмяВременногоФайлаПравилОбмена = "";
Если ПустаяСтрока(Источник) Тогда

Источник = ИмяФайлаПравилОбмена;

КонецЕсли;


//+изменения
Если ЭтотОбъект.ИмяПланаОбменаВРО = "ОбменУправлениеНебольшойФирмойБухгалтерия30" Тогда 
ПреобразоватьПравилаОбмена(Источник); 
КонецЕсли;
//-изменения

Если ТипИсточника="XMLФайл" Тогда

//...
КонецПроцедуры
 

Конструцией //... обозначен некий участок кода, который в данном листинге пропущен.

Изменения в типовом коде помечены //+изменения и //-изменения

Комментарий по коду: после того, как мы проинициализировали типовые правила (Источник = ИмяФайлаПравилОбмена), мы эти правила модифицируем: ПреобразоватьПравилаОбмена(Источник)

Теперь код процедуры ПреобразоватьПравилаОбмена:


//+изменения
Процедура ПреобразоватьПравилаОбмена(Источник)
// Чтение XML в дерево
Чтение = Новый ЧтениеXML;
ПараметрыЧтения = Новый ПараметрыЧтенияXML(,,,,Ложь,,,Ложь);
Чтение.ОткрытьФайл(Источник,ПараметрыЧтения);

СтруктураУзла = Новый ДеревоЗначений;
СтруктураУзла.Колонки.Добавить("Имя");
СтруктураУзла.Колонки.Добавить("Значение");
СтруктураУзла.Колонки.Добавить("Атрибуты");
СтруктураУзла.Колонки.Добавить("Тип");

СтрокаУзла = СтруктураУзла.Строки.Добавить();
СтрокаУзла.Значение = СокрЛП(Источник);
СтрокаУзла.Атрибуты = Новый Структура;

ПрочитатьОбъектXMLВДерево(Чтение,СтрокаУзла);

Чтение.Закрыть();



// !!!
ПравилоПослеЗагрузкиДанных = СтруктураУзла.Строки.Найти("ПослеЗагрузкиДанных","Имя",Истина);
Если ПравилоПослеЗагрузкиДанных <> Неопределено Тогда 
ПравилоПослеЗагрузкиДанныхСПроведением = "Объект.Записать(РежимЗаписиДокумента.Проведение);";
ПравилоПослеЗагрузкиДанныхБезПроведения = "//Объект.Записать(РежимЗаписиДокумента.ПравилоПослеЗагрузкиДанныхСПроведением); //-изменения";
ПравилоПослеЗагрузкиДанных.Значение = СтрЗаменить(ПравилоПослеЗагрузкиДанных.Значение,ПравилоПослеЗагрузкиДанныхСПроведением,ПравилоПослеЗагрузкиДанныхБезПроведения);
КонецЕсли;

// !!!
ПравилаКонвертацииОбъектов = СтруктураУзла.Строки.Найти("ПравилаКонвертацииОбъектов","Имя",Истина);
ПреобразоватьСтрокиПравил(ПравилаКонвертацииОбъектов);



// Запись XML из дерева
ИмяВременногоФайла = ПолучитьИмяВременногоФайла("xml");
ЗаписьXML = Новый ЗаписьXML;
ЗаписьXML.ОткрытьФайл(ИмяВременногоФайла);
ПрочитатьОбъектXMLИзДерева(ЗаписьXML,СтруктураУзла.Строки[0]);
ЗаписьXML.Закрыть();

Источник = ИмяВременногоФайла;
КонецПроцедуры // ПреобразоватьПравилаОбмена()
Процедура ПреобразоватьСтрокиПравил(ПравилаКонвертацииОбъектов)
Если Ложь Тогда ПравилаКонвертацииОбъектов = Новый ДеревоЗначений; КонецЕсли;

Для Каждого ПравилоКО Из ПравилаКонвертацииОбъектов.Строки Цикл
Источник = ПравилоКО.Строки.Найти("Источник","Имя");

Если Источник <> Неопределено Тогда 
// Номенклатуру синхронизируем по наименованию
Если Источник.Значение = "СправочникСсылка.Номенклатура" Тогда 
Для Каждого РеквизитОбъекта Из ПравилоКО.Строки.Найти("Свойства","Имя").Строки Цикл
ИмяРеквизита = РеквизитОбъекта.Строки.Найти("Источник","Имя");
Если ИмяРеквизита.Атрибуты.Имя <> "Наименование" И ИмяРеквизита.Атрибуты.Имя <> "ЭтоГруппа" Тогда 
РеквизитОбъекта.Атрибуты.Удалить("Поиск");
КонецЕсли;
КонецЦикла;
КонецЕсли;

// Банковские счета
Если Источник.Значение = "СправочникСсылка.БанковскиеСчета" Тогда
ПравилоПоискПоПолямПоиска = ПравилоКО.Строки.Найти("ПродолжитьПоискПоПолямПоискаЕслиПоИдентификаторуНеНашли","Имя");
Если ПравилоПоискПоПолямПоиска = Неопределено Тогда 
ПравилоПоискПоПолямПоиска = ПравилоКО.Строки.Добавить();
ПравилоПоискПоПолямПоиска.Имя = "ПродолжитьПоискПоПолямПоискаЕслиПоИдентификаторуНеНашли";
ПравилоПоискПоПолямПоиска.Тип = ТипУзлаXML.Текст;
КонецЕсли;
ПравилоПоискПоПолямПоиска.Значение = "true";
КонецЕсли;

Если Источник.Значение = "СправочникСсылка.ДоговорыКонтрагентов" Тогда
ПравилоПоискПоПолямПоиска = ПравилоКО.Строки.Найти("ПродолжитьПоискПоПолямПоискаЕслиПоИдентификаторуНеНашли","Имя");
Если ПравилоПоискПоПолямПоиска = Неопределено Тогда 
ПравилоПоискПоПолямПоиска = ПравилоКО.Строки.Добавить();
ПравилоПоискПоПолямПоиска.Имя = "ПродолжитьПоискПоПолямПоискаЕслиПоИдентификаторуНеНашли";
ПравилоПоискПоПолямПоиска.Тип = ТипУзлаXML.Текст;
КонецЕсли;
ПравилоПоискПоПолямПоиска.Значение = "true";

Для Каждого РеквизитОбъекта Из ПравилоКО.Строки.Найти("Свойства","Имя").Строки Цикл
ИмяРеквизита = РеквизитОбъекта.Строки.Найти("Источник","Имя");
Если ИмяРеквизита.Атрибуты.Имя = "Организация" Тогда 
РеквизитОбъекта.Атрибуты.Удалить("Поиск");
КонецЕсли;
КонецЦикла;
КонецЕсли;

// Контрагентов синхронизируем по ИНН/КПП
Если Источник.Значение = "СправочникСсылка.Контрагенты" Тогда
//ПравилоПоискПоПолямПоиска = ПравилоКО.Строки.Найти("СинхронизироватьПоИдентификатору","Имя");
//Если ПравилоПоискПоПолямПоиска = Неопределено Тогда 
// ПравилоПоискПоПолямПоиска = ПравилоКО.Строки.Добавить();
// ПравилоПоискПоПолямПоиска.Имя = "СинхронизироватьПоИдентификатору";
// ПравилоПоискПоПолямПоиска.Тип = ТипУзлаXML.Текст;
//КонецЕсли;
//ПравилоПоискПоПолямПоиска.Значение = "false";

ПравилоПоискПоПолямПоиска = ПравилоКО.Строки.Найти("ПродолжитьПоискПоПолямПоискаЕслиПоИдентификаторуНеНашли","Имя");
Если ПравилоПоискПоПолямПоиска = Неопределено Тогда 
ПравилоПоискПоПолямПоиска = ПравилоКО.Строки.Добавить();
ПравилоПоискПоПолямПоиска.Имя = "ПродолжитьПоискПоПолямПоискаЕслиПоИдентификаторуНеНашли";
ПравилоПоискПоПолямПоиска.Тип = ТипУзлаXML.Текст;
КонецЕсли;
ПравилоПоискПоПолямПоиска.Значение = "true";

ПравилоНеЗамещать = ПравилоКО.Строки.Найти("НеЗамещать","Имя");
Если ПравилоНеЗамещать = Неопределено Тогда 
ПравилоНеЗамещать = ПравилоКО.Строки.Вставить(0);
ПравилоНеЗамещать.Имя = "НеЗамещать";
ПравилоНеЗамещать.Тип = ТипУзлаXML.Текст;
КонецЕсли;
ПравилоНеЗамещать.Значение = "true";

ПравилоПоляПоиска = ПравилоКО.Строки.Найти("ПоследовательностьПолейПоиска","Имя");
Если ПравилоПоляПоиска = Неопределено Тогда 
ПравилоПоляПоиска = ПравилоКО.Строки.Добавить();
ПравилоПоляПоиска.Имя = "ПоследовательностьПолейПоиска";
ПравилоПоляПоиска.Тип = ТипУзлаXML.Текст;
КонецЕсли;

ПравилоПоляПоиска.Значение = "//+изменения
|Если НомерВариантаПоиска = 1 Тогда
| Если СвойстваПоиска[""ЭтоГруппа""] = Истина Тогда
| СтрокаИменСвойствПоиска = ""Наименование,ЭтоГруппа"";
| Иначе
| Если ЗначениеЗаполнено(СвойстваПоиска[""ИНН""]) Тогда
| СтрокаИменСвойствПоиска = ""ИНН,КПП,ЭтоГруппа"";
| Иначе
| СтрокаИменСвойствПоиска = ""Наименование,ИНН,КПП,ЭтоГруппа"";
| КонецЕсли;
| КонецЕсли;
|КонецЕсли;
|//-изменения";
КонецЕсли;


// Документы выгружаем непроведенными
Если Найти(Источник.Значение,"ДокументСсылка.") > 0 Тогда

Для Каждого РеквизитОбъекта Из ПравилоКО.Строки.Найти("Свойства","Имя").Строки Цикл
ИмяРеквизита = РеквизитОбъекта.Строки.Найти("Источник","Имя");
Если ИмяРеквизита.Атрибуты.Имя = "Проведен" Тогда 
ПравилоПередВыгрузкой = РеквизитОбъекта.Строки.Добавить();
ПравилоПередВыгрузкой.Имя = "ПередВыгрузкой";
ПравилоПередВыгрузкой.Значение = "Значение = Ложь; //+изменения";
ПравилоПередВыгрузкой.Тип = ТипУзлаXML.Текст;

//ПравилоНеЗамещать = РеквизитОбъекта.Строки.Найти("НеЗамещать","Имя");
//Если ПравилоНеЗамещать = Неопределено Тогда 
// ПравилоНеЗамещать = РеквизитОбъекта.Строки.Вставить(0);
// ПравилоНеЗамещать.Имя = "НеЗамещать";
// ПравилоНеЗамещать.Тип = ТипУзлаXML.Текст;
//КонецЕсли;
//ПравилоНеЗамещать.Значение = "true";
КонецЕсли;

ИмяРеквизита = РеквизитОбъекта.Строки.Найти("Приемник","Имя");
Если ИмяРеквизита.Атрибуты.Имя = "СпособЗачетаАвансов" Тогда 
ПравилоПередВыгрузкой = РеквизитОбъекта.Строки.Найти("ПередВыгрузкой","Имя");
Если ПравилоПередВыгрузкой <> Неопределено Тогда 
Если Найти(ПравилоПередВыгрузкой.Значение,"Выражение = ""Перечисления.СпособыЗачетаАвансов.") > 0 Тогда 
ПравилоПередВыгрузкой.Значение = ПравилоПередВыгрузкой.Значение + "
|
|Выражение = ""Перечисления.СпособыЗачетаАвансов.Автоматически""; //+изменения";
КонецЕсли;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЕсли;

Если Найти(Источник.Значение,"ДокументСсылка.ПоступлениеНаСчет") > 0 Тогда
ПравилоПередВыгрузкой = ПравилоКО.Строки.Найти("ПередВыгрузкой","Имя");
Если ПравилоПередВыгрузкой = Неопределено Тогда 
ПравилоПередВыгрузкой = ПравилоКО.Строки.Добавить();
ПравилоПередВыгрузкой.Имя = "ПередВыгрузкой";
ПравилоПередВыгрузкой.Тип = ТипУзлаXML.Текст;
КонецЕсли;
ПравилоПередВыгрузкой.Значение = "Отказ = Истина;";
КонецЕсли;
Если Найти(Источник.Значение,"ДокументСсылка.РасходнаяНакладная") > 0 Тогда
Для Каждого РеквизитОбъекта Из ПравилоКО.Строки.Найти("Свойства","Имя").Строки Цикл
ИмяРеквизита = РеквизитОбъекта.Строки.Найти("Источник","Имя");
Если ИмяРеквизита.Атрибуты.Имя = "Предоплата" Тогда 
ПравилоПередВыгрузкой = РеквизитОбъекта.Строки.Найти("ПередВыгрузкой","Имя");
Если ПравилоПередВыгрузкой = Неопределено Тогда 
ПравилоПередВыгрузкой = РеквизитОбъекта.Строки.Добавить();
ПравилоПередВыгрузкой.Имя = "ПередВыгрузкой";
ПравилоПередВыгрузкой.Тип = ТипУзлаXML.Текст;
КонецЕсли;
ПравилоПередВыгрузкой.Значение = ПравилоПередВыгрузкой.Значение + "
|
|Отказ = Истина; //+изменения";
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЕсли;

ПреобразоватьСтрокиПравил(ПравилоКО);
КонецЦикла;
КонецПроцедуры // ПреобразоватьСтрокиПравил()

Функция ПрочитатьОбъектXMLВДерево(ЭлементЧтениеXML, Дерево)
текСтрока = Дерево;
Пока ЭлементЧтениеXML.Прочитать() Цикл

Если ЭлементЧтениеXML.ТипУзла = ТипУзлаXML.НачалоЭлемента Тогда

НоваяСтрока = текСтрока.Строки.Добавить();
НоваяСтрока.Имя = ЭлементЧтениеXML.Имя;
Атрибуты = Новый Структура;
Пока ЭлементЧтениеXML.ПрочитатьАтрибут() Цикл

Атрибуты.Вставить(ЭлементЧтениеXML.Имя, ЭлементЧтениеXML.Значение);

КонецЦикла;
НоваяСтрока.Атрибуты = Атрибуты;
НоваяСтрока.Тип = ТипУзлаXML.НачалоЭлемента;
ПрочитатьОбъектXMLВДерево(ЭлементЧтениеXML, НоваяСтрока);

ИначеЕсли ЭлементЧтениеXML.ТипУзла = ТипУзлаXML.Текст Тогда

текСтрока.Значение = ЭлементЧтениеXML.Значение;
текСтрока.Тип = ТипУзлаXML.Текст;


ИначеЕсли ЭлементЧтениеXML.ТипУзла = ТипУзлаXML.Комментарий Тогда

НоваяСтрока = текСтрока.Строки.Добавить();
Атрибуты = Новый Структура;
НоваяСтрока.Значение = ЭлементЧтениеXML.Значение;
НоваяСтрока.Атрибуты = Атрибуты;
НоваяСтрока.Тип = ТипУзлаXML.Комментарий;

ИначеЕсли ЭлементЧтениеXML.ТипУзла = ТипУзлаXML.ОбъявлениеXML Тогда

НоваяСтрока = текСтрока.Строки.Добавить();
Атрибуты = Новый Структура;
НоваяСтрока.Значение = "<?xml version=""" + ЭлементЧтениеXML.ВерсияXML + """" + ?(ПустаяСтрока(ЭлементЧтениеXML.КодировкаXML), "", " encoding=""" + ЭлементЧтениеXML.КодировкаXML + """") + " ?>";
НоваяСтрока.Атрибуты = Атрибуты;
НоваяСтрока.Тип = ТипУзлаXML.ОбъявлениеXML;
ПрочитатьОбъектXMLВДерево(ЭлементЧтениеXML, НоваяСтрока);


ИначеЕсли ЭлементЧтениеXML.ТипУзла = ТипУзлаXML.КонецЭлемента Тогда

Прервать;

КонецЕсли;

КонецЦикла;

Возврат Дерево;

КонецФункции
Процедура ПрочитатьОбъектXMLИзДерева(ЗаписьXML, Дерево) Экспорт
Если Дерево.Тип = ТипУзлаXML.ОбъявлениеXML Тогда
ЗаписьXML.ЗаписатьОбъявлениеXML();

Для Каждого текСтрока Из Дерево.Строки Цикл
ПрочитатьОбъектXMLИзДерева(ЗаписьXML, текСтрока);
КонецЦикла;

ИначеЕсли Дерево.Тип = ТипУзлаXML.Комментарий Тогда
ЗаписьXML.ЗаписатьКомментарий(Дерево.Значение);
Для Каждого текСтрока Из Дерево.Строки Цикл
ПрочитатьОбъектXMLИзДерева(ЗаписьXML, текСтрока);
КонецЦикла;

ИначеЕсли Дерево.Тип = ТипУзлаXML.НачалоЭлемента Тогда
ЗаписьXML.ЗаписатьНачалоЭлемента(Дерево.Имя);
Если ЗначениеЗаполнено(Дерево.Атрибуты) Тогда 
Для Каждого текАтрибут Из Дерево.Атрибуты Цикл
ЗаписьXML.ЗаписатьАтрибут(текАтрибут.Ключ, текАтрибут.Значение);
КонецЦикла;
КонецЕсли;

Для Каждого текСтрока Из Дерево.Строки Цикл
ПрочитатьОбъектXMLИзДерева(ЗаписьXML, текСтрока);
КонецЦикла;

ЗаписьXML.ЗаписатьКонецЭлемента();

ИначеЕсли Дерево.Тип = ТипУзлаXML.Текст Тогда
ЗаписьXML.ЗаписатьНачалоЭлемента(Дерево.Имя);
Если ЗначениеЗаполнено(Дерево.Атрибуты) Тогда 
Для Каждого текАтрибут Из Дерево.Атрибуты Цикл
ЗаписьXML.ЗаписатьАтрибут(текАтрибут.Ключ, текАтрибут.Значение);
КонецЦикла;
КонецЕсли;
ЗаписьXML.ЗаписатьТекст(Дерево.Значение);
ЗаписьXML.ЗаписатьКонецЭлемента();

Для Каждого текСтрока Из Дерево.Строки Цикл
ПрочитатьОбъектXMLИзДерева(ЗаписьXML, текСтрока);
КонецЦикла;

Иначе
Для Каждого текСтрока Из Дерево.Строки Цикл
ПрочитатьОбъектXMLИзДерева(ЗаписьXML, текСтрока);
КонецЦикла;
КонецЕсли;
КонецПроцедуры
//-изменения




Комментарий по коду:

Приведен полностью листинг одного реально модифицированного набора правил. Вначале производится чтение правил и помещение их в дерево значений, затем дерево значений преобразуется (добавляются/удаляются/модифицируются правила), затем дерево обратно собирается в xml и выдается обратно в вызывающую функцию.

В листинге есть примеры:

- как в справочнике Номенклатура оставить синхронизацию только по Наименованию и Группе (см. РеквизитОбъекта.Атрибуты.Удалить("Поиск"))

- как включить синхронизацию по полям поиска, если по внутреннему идентификатору объект не найден (см. ПравилоКО.Строки.Найти("ПродолжитьПоискПоПолямПоискаЕслиПоИдентификаторуНеНашли","Имя");)

- как задать алгоритм поиска объектов (см. ПравилоКО.Строки.Найти("ПоследовательностьПолейПоиска","Имя");)

- как включить режим "Не замещать свойства если объект найден" (см. ПравилоКО.Строки.Найти("НеЗамещать","Имя");)

- как изменить значения реквизитов выгружаемых объектов (см. Если ИмяРеквизита.Атрибуты.Имя = "Проведен" Тогда )

- и некоторые другие примеры (по аналогии с приведенными выше будет понятно, для чего они предназначены).

 

И последнее: не забывайте, что иногда в конфигурации-приемнике поиск объектов по полям поиска может не сработать, т.к. в конфигурацию-приемник могут быть загружены правила корреспонденции. Если хотим, чтобы заработали правила поиска по полям поиска в этом случае, можем просто загрузить в приемник пустые правила корреспонденции.

26

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. insurgut 187 03.06.15 08:57 Сейчас в теме
А если сущности какой не станет, или названия реквизитов изменятся... Чета как-то, грабли :-/
2. Mopo3 289 03.06.15 10:18 Сейчас в теме
(1) Этот же вопрос должен возникать, если модифицировать через КД типовые правила обмена и загружать их как актуальные. Поэтому считаю его общим и не имеющим отношения к методике.

Т.е. если рассуждать абстрактно над таким вопросом, то ответ банально такой: при каждом обновлении релиза нужно проверять доработки типовой :)
3. Светлый ум 236 03.06.15 10:19 Сейчас в теме
Может и грабли, а для расширения кругозора XML - самое то.
4. d@ncer 34 03.06.15 10:55 Сейчас в теме
5. Mopo3 289 03.06.15 12:17 Сейчас в теме
Каждый имеет право на собственное мнение :)

Как по мне, то я лучше нажму одну кнопку (проверив неизменность реквизитов), чем буду загружать в КД измененные автором правил обмена типовые правила из нового релиза и заново накатывать свои доработки. Конечно, этот процесс можно автоматизировать разными методами (как всегда все ограничивается только фантазией) - мой метод лишь один из возможных.
6. jan27 695 04.06.15 11:32 Сейчас в теме
в типовых конфигурациях есть возможность использовать нетиповые правила КД, которые хранятся в базе
проще использовать такой механизм
7. Mopo3 289 04.06.15 14:42 Сейчас в теме
(6) Механизм есть, но что вы будете делать когда после обновления релиза и изменения правил поставщиком, система выдаст сообщение что правила устарели и необходимо обновить правила до актуальных?
8. jan27 695 24.06.15 10:59 Сейчас в теме
(7) обновлю конфигурацию в КД и выгружу правила
Оставьте свое сообщение

См. также

[СКД] Программное создание схемы компоновки данных 266

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Сделаем отчет на СКД полностью программно, без использования макета "схема компоновки данных".

15.01.2020    3379    John_d    14       

Сдача регламентированной отчетности из программ 1С Промо

Сдача регламентированной отчетности из программ "1С" во все контролирующие органы без выгрузок и загрузок в другие программы. Для групп компаний действуют специальные предложения.

от 1500 руб.

Перенос данных УТ 10.3 => УТ 11 / КА 2 / ERP 2 (ЕРП 2) (документы, остатки и справочная информация из "1С:Управление торговлей, ред. 10.3" в УТ 11 / КА 2 / ERP 2). Обновлен до УТ 10.3.56.х, УТ 11.4.10.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Уже более 100 компаний приобрели перенос и выполнили переход на УТ 11 / КА 2 / ERP 2 с помощью нашей разработки! Обработка перехода с УТ 10.3 на УТ 11 / КА 2 / ERP 2 позволяет перенести не только остатки на указанную дату (как типовой перенос), но и все возможные документы за выбранный период. При выходе новых релизов этих программ оперативно выпускаем обновление обработки. Предоставляем техническую поддержку. Можем сделать бесплатный тестовый перенос!

29700 руб.

Агрегатные функции СКД, о которых мало кто знает 391

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    20432    ids79    45       

Три костыля. Сказ про фокусы в коде 130

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Три интересных (или странных) костыля в коде, которые могут помочь в повседневных и не очень задачах.

03.09.2019    12832    YPermitin    69       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Отслеживание выполнения фонового задания 154

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    16051    ids79    16       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 294

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    25824    ids79    34       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

Фоновое выполнение кода в 1С - это просто 149

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Как легко запускать выполнение в фоне, не прибегая к долгому описанию фоновых процедур.

02.08.2019    16097    avalakh    21       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 153

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    22060    ids79    8       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 160

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    16887    ids79    27       

Регистры сведений. За кулисами 134

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Небольшие заметки по внутреннему устройству регистров сведений.

09.07.2019    13227    YPermitin    12       

PgConf.Russia 2020. 3-5 февраля 2020 г. Москва. Промо

PGConf.Russia – международная техническая конференция по открытой СУБД PostgreSQL, ежегодно собирающая более 700 разработчиков, администраторов баз данных и IT-менеджеров для обмена опытом и профессионального общения. Для участников сообщества infostart.ru скидка 5% на участие в конференции.

от 12350 рублей

"Меньше копипаста!", или как Вася универсальную процедуру писал 185

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    11396    SeiOkami    49       

Создание отчетов с помощью СКД - основные понятия и элементы 226

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    28363    ids79    17       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 180

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    15641    dmurk    144       

Регистры накопления. Структура хранения в базе данных 180

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    24654    YPermitin    27       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 17 февраля по 13 марта 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Выполнение внешней обработки в фоновом задании 153

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    15669    Eret1k    23       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    8754    m-rv    2       

22 января состоится вебинар "Использование технологии блокчейн в 1С" Промо

На вебинаре вы узнаете как использовать современную технологию блокчейн при проектировании и создании учетных систем, почему эту технологию следует рассматривать как одну из базовых. Ведущий Михаил Калимулин поделится своими знаниями основ технологии и опытом внедрения.

990 рублей

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    11701    m-rv    16       

О расширениях замолвите слово... 200

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    21226    ellavs    125       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 206

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    17283    ellavs    83       

RabbitMQ + Конвертация Данных 3.0 184

Статья Системный администратор Программист Бизнес-аналитик Руководитель проекта Нет файла v8 КД Бесплатно (free) Внешние источники данных Обмен через XML Интеграция Перенос данных из 1C8 в 1C8

Предлагаем ознакомиться с хронологией проекта, проследить ход мыслей от снятия потребностей до реализации, и решить, удалось ли проектной команде найти оптимальное архитектурное решение под конкретный кейс заказчика путем совмещения двух известных, но до сих пор не пересекавшихся технологий, и получилось ли сложить плюсы и устранить минусы каждой из них.

21.03.2019    16952    barelpro    82       

Базовый курс по разработке мобильных 1C-приложений для Android-устройств. Третий поток. Онлайн-интенсив с 11 февраля по 05 марта 2020 г. Промо

Данный онлайн-курс предусматривает изучение базовых принципов создания приложений для операционной системы Android, работающих на мобильной платформе “1С:Предприятие”. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие” при разработке прикладных решений для “обычных” компьютеров, но пока ещё не занимался разработкой 1С-приложений, предназначенных для работы на мобильных устройствах.

7500 рублей

Трюки с внешними источниками данных 169

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    18839    YPermitin    53       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 178

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    22228    ids79    9       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

EnterpriseData – часть 2. Процесс выгрузки данных 130

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    17072    ids79    27