Закрытие регистров накопления [управляемые формы] УТ 11, ЗУП 3.0 + Бухгалтерия предприятия 3.0

Обработки - Обработка документов

Обработка позволяет обнулить (закрыть) остатки на регистрах накопления на определенную дату

Внешняя обработка позволяет обнулить (закрыть) остатки по регистрам накопления.

Работает в  конфигурации Бухгалтерия предприятия 3.0 (тестировал на 3.0.41.56)

В БП 3.0  создается документ "Операция, введенная вручную" с движениями по выбранному регистру.

Закрывать регистры возможно полностью, либо наложив условия отбора.

Работает и в других конфигурациях на управляемых формах.

За идею спасибо: //infostart.ru/public/334090/

Скачать файлы

Наименование Файл Версия Размер
Закрытие регистров накопления
.epf 12,73Kb
23.05.17
156
.epf 1 12,73Kb 156 Скачать

См. также

Комментарии
1. Михаил Подкопаев (amigo667) 4 21.10.15 12:13 Сейчас в теме
Если выбрать способ закрытия регистра приход, то вылетает с ошибкой
Платформа: 1С:Предприятие 8.3 (8.3.6.2152)
Конфигурация: Бухгалтерия предприятия, редакция 3.0 (3.0.42.33) (http://v8.1c.ru/buhv8/)
Copyright (С) ООО "1C", 2009 - 2015. Все права защищены
(http://www.1c.ru)
Режим: Серверный (сжатие: усиленное)
Приложение: Тонкий клиент
Локализация: Информационная база: русский (Россия), Сеанс: русский (Россия)
Вариант интерфейса: Такси

Ошибки:
--------------------------------------------------------------------------------
21.10.2015 12:11:47
Ошибка создания источника доступных настроек компоновки данных
2. Михаил Заозерский (MikZ) 40 21.10.15 20:56 Сейчас в теме
3. Москвитин Сергей (Doomer) 02.11.15 12:16 Сейчас в теме
В обработке косяк. Выбираю регистр накопления. Указываю отбор. Нажимаю получить остатки. Нажимаю "Ввести корректировку записей регистров". Открывается документ в котором регистр закрывается полностью без учета наложенного фильтра.
Прикрепленные файлы:
4. Москвитин Сергей (Doomer) 02.11.15 12:19 Сейчас в теме
Фильтр по огранизации то же не накладывается. Конфигурация БП 3.0 (Почти)
5. Михаил Заозерский (MikZ) 40 02.11.15 22:06 Сейчас в теме
(3) Doomer, спасибо за замечание. Ошибка исправлена. Отборы работают.
6. Александр (Aleksandtmt) 16 14.02.16 14:40 Сейчас в теме
Спасибо за обработку, очень пригодилась.
Использовал обработку для закрытия регистров накопления в конфигурации ЗУП 3.0 (3.0.25.69). При формировании документа для некоторых регистров, например «Взаиморасчеты с сотрудниками» выдается ошибка: «Поле объекта не обнаружено (Статья финансирования)». Добавил проверку и документ сформировался.
7. Екатерина Тутубалина (kalaratra) 8 17.02.16 08:56 Сейчас в теме
Не работает на ЗУП 3.0. "Переменная не определена (Бухгалтерский учет переопределяемый)". Зря потратила 2 стартмани. Уберите из описания, что поддерживается ЗУП 3.0
8. Александр (chea06) 130 17.02.16 09:47 Сейчас в теме
(7) kalaratra, даже если закомментировать эту строку, то все равно не работает в ЗУП для тех регистров, использование измерений которых завязано на функциональных опциях. Например, если попытаться закрыть регистр ВзаиморасчетыССотрудниками, у которого использование измерения СтатьяФинансирования выключено через ФО, то при попытке создать документ вываливается ошибка

{Форма.ФормаУпр.Форма(372)}: Поле объекта не обнаружено (СтатьяФинансирования)
НоваяЗапись[Измерение.Имя] = СтрокаТаблицы[Измерение.Имя];

подозреваю что эта ошибка актуальная не только для ЗУП
9. Екатерина Тутубалина (kalaratra) 8 20.02.16 10:35 Сейчас в теме
(8) chea06,
Первая строка с ошибкой при получении организации, заменила
БухгалтерскийУчетПереопределяемый.ПолучитьЗначениеПоУмолчанию("ОсновнаяОрганизация"); 

на
РегламентированнаяОтчетность.ПолучитьЗначениеПоУмолчанию("ОсновнаяОрганизация"); 

А статью финансирования решила так:
Для каждого Измерение Из РегистрНакопления.Измерения Цикл
			Если НЕ Измерение.Имя = "СтатьяФинансирования" И НЕ Измерение.Имя = "СтатьяРасходов" Тогда
				НоваяЗапись[Измерение.Имя] = СтрокаТаблицы[Измерение.Имя];
			КонецЕсли;
		КонецЦикла;
...Показать Скрыть


Знаю, что костыль, но мне надо было быстро решить)
ssfedkin; milov.aleksey; +2 Ответить 1
10. svegl 15 17.06.17 21:17 Сейчас в теме
Спасибо! Обработка супер!
11. alexbur (alexbur) 9 28.06.17 09:19 Сейчас в теме
Слушайте, ну это ж вообще ужас. Если вы не знаете, как в запросе задавать период, чтобы получить правильные остатки на конец периода при использовании таблицы .Остатки, то выкладывать такие обработки просто безответственно.
12. alexbur (alexbur) 9 29.06.17 08:57 Сейчас в теме
Для тех, кто захочет воспользоваться данной обработкой советую исправить код обработки.
Исправить (в 3х местах):
	ПараметрПериод.Значение		= КонецДня(Объект.ДатаКонца);

На
	ПараметрПериод.Значение		= КонецДня(Объект.ДатаКонца) + 1;


И
	Запрос.УстановитьПараметр("Период",КонецДня(Объект.ДатаКонца));

На
	Запрос.УстановитьПараметр("Период",КонецДня(Объект.ДатаКонца)+1);
13. Екатерина Кашапова (Evangelina) 06.07.17 16:43 Сейчас в теме
(9)
Для каждого Измерение Из РегистрНакопления.Измерения Цикл
Если НЕ Измерение.Имя = "СтатьяФинансирования" И НЕ Измерение.Имя = "СтатьяРасходов" Тогда
НоваяЗапись[Измерение.Имя] = СтрокаТаблицы[Измерение.Имя];
КонецЕсли;
КонецЦикла;


А куда это вставить в код? А то у меня выходит такая запись:
{ВнешняяОбработка.ЗакрытиеРегистровНакопления.Форма.ФормаУпр.Форма(301,17)}: Переменная не определена (НоваяЗапись)
<<?>>НоваяЗапись[Измерение.Имя] = СтрокаТаблицы[Измерение.Имя]; (Проверка: Сервер)
{ВнешняяОбработка.ЗакрытиеРегистровНакопления.Форма.ФормаУпр.Форма(301,46)}: Переменная не определена (СтрокаТаблицы)
НоваяЗапись[Измерение.Имя] = <<?>>СтрокаТаблицы[Измерение.Имя]; (Проверка: Сервер)

Помогите, а то там таких делов по остаткам в ЗУП 3.0 наворотили, за три предыдущих года НДФЛ не отражали на удержание, не уволили сотрудников, а по уволенным вообще суммы к оплате вылазят.
14. alexbur (alexbur) 9 17.07.17 08:30 Сейчас в теме
(13)
Это нужно вставлять в процедуру ЗаполнитьНовыйДокументКорректировки для конфигураций отличных от Бух3.0 (ниже текста "Иначе //Если НЕ БП 3.0")
Оставьте свое сообщение