Получение доступа к скачиванию гугл-таблицы

Публикация № 425046

Разработка - Системная интеграция - Интеграция с WEB

spreadsheet гугл гугл-таблицы загрузка работа с гугл google google spreadsheet доступ к гугл таблице гугл таблица

Стояла задача считать данные с гугл-таблицы и загрузить эти данные в 1С. В этой статье описан механизм получения доступа к скачиванию нужной гугл-таблицы во временный файл .xlsx. Решил поделиться опытом работы. Может, кому-то немного сократит время поиска решения.

В общем, когда начинал гуглить, ничего толком не находил. Статьи в основном старые, а так как недавно гугл изменил способ авторизации, то грош теперь таким статьям цена. Решил копать глубже. Наткнулся на несколько интересных ссылок и разобрался.

Немного теории:

Все приложения, получающие доступ к GoogleAPI, должны быть зарегистрированы разработчиком через API-консоль. Для этого необходимо авторизоваться под учетной записью. Для авторизации нужно использовать протокол OAuth 2.0. Другие протоколы авторизации не поддерживаются гуглом.
Все запросы к Google Analytics API должны быть разрешены пользователем, прошедшим аутентификацию.

В общих чертах процедура аутентификации выглядит так:

  1. Создавая приложение, вы регистрируете его в Google Developers Console. (https://console.developers.google.com)
  2. Вы включаете Drive API в Google Developers Console
  3. Когда приложению потребуются пользовательские данные, оно запрашивает у Google определенную область доступа.
  4. Google показывает пользователю диалоговое окно с предложением авторизовать приложение для запроса этих данных.
  5. Если пользователь соглашается, Google предоставляет приложению токен доступа с коротким сроком действия.
  6. Приложение запрашивает пользовательские данные, указывая токен доступа.
  7. Получив действительный запрос и токен, Google возвращает необходимые данные.

Перейдем к практике.

Скачивать будем эту тестовую гугл таблицу:

https://docs.google.com/spreadsheets/d/1QvjMLjBK3HJrJbcuY16Ihwve2B-AgHdEMpiu9SKrkMQ/edit#gid=0&vpid=A1

Сначала включим  Drive API в Google Developers Console

Переходим по ссылке https://console.developers.google.com, и создаем новый проект

После этого выбираем в списке сервис Drive API (к нему необходимо получить доступ приложению)

Далее переходим по ссылке Credentials, чтобы создать идентификаторы приложения

Задаем имя приложения, которое будет видно пользователю при запросе разрешений.

Затем создаем ID пользователя, еще раз нажав на поле Credentials. 

 

После завершения получаем

Подготовительные действия завершены. Все дальнейшие действия будут выполняться в среде 1С:Предприятие.

Создаем обработку и добавляем на форму элемент ПолеHTMLДокумента. 

 

В процедуре-обработчике события для кнопки “Авторизация” надо написать код, формирующий адрес страницы авторизации и в последней строке открывающий эту страницу на экране для пользователя.

Процедура КнопкаВыполнитьНажатие(Кнопка)
	ПолучитьОсновыеЗначениеПеремменных();
	ПройтиАвторизацию();	
КонецПроцедуры
Процедура ПолучитьОсновыеЗначениеПеремменных()
	redirect_uri = "http://localhost";
	client_id = "158908578317-u84j5fap070ib8o5jtuvgei0m6d6gsv8.apps.googleusercontent.com";
	client_secret = "w-x-FHvuwtjd7yDygCYi4vqB";
	ID_Файл	= "1QvjMLjBK3HJrJbcuY16Ihwve2B-AgHdEMpiu9SKrkMQ";		
КонецПроцедуры
Процедура ПройтиАвторизацию()
	Параметры = "response_type=code"+"&";
	Параметры = Параметры + "client_id="+ client_id + "&";
	Параметры = Параметры + "redirect_uri=" + redirect_uri + "&";
	Параметры = Параметры + "scope=https://www.googleapis.com/auth/drive.file https://www.googleapis.com/auth/drive https://spreadsheets.google.com/feeds";
	АдресАвторизации = "https://accounts.google.com/o/oauth2/auth" + "?";
	ПолныйАдресАвторизации = АдресАвторизации + Параметры;
	ЭлементыФормы.Браузер.Перейти(ПолныйАдресАвторизации);
КонецПроцедуры

Таким образом, при нажатии кнопки «Авторизация» пользователю будет выведена страница для выполнения авторизации и выдачи разрешения для доступа к данным таблицы.

Разрешаем доступ приложению. 

Итак, перейдем к скачиванию таблицы. В обработчике действия кнопки "Скачать таблицу" пишем:

Процедура ОсновныеДействияФормыСкачатьТаблицу(Кнопка)
	
	//код доступа берем с заголовка браузера
	//код доступа нужен чтоб получить маркер
	//пишут что код доступа доступен 8 часов. не проверял
	ПолучитьКодДоступа();	
	
	//маркер доступен 1час
	Маркер = ПолучаемМаркер();
	
	Если Найти(Маркер, "Code was already redeemed") = 0 Тогда
		ПолучитьМетаданные();	
	Иначе	
	
	КонецЕсли;
	
	ВременнаяТаблица = ПолучитьИмяВременногоФайла(".xlsx");
	КопироватьФайл(СсылкаДляСкачивания, ВременнаяТаблица);
	
	#Если Клиент Тогда
		Сообщить("Таблица сохранена во временный файл: " + ВременнаяТаблица);
	#КонецЕсли	
	
КонецПроцедуры

Разберем эту процедуру. Сначала нам нужно получить код доступа из заголовка браузера.

Процедура ПолучитьКодДоступа()
	СтрокаСКодом = ЭлементыФормы.Браузер.документ.URLUnencoded;
	Если СтрокаСКодом = "about:blank" Тогда
		#Если Клиент Тогда
			Сообщить("Пройдите авторизацию для получения кода доступа!");	
		#КонецЕсли
		КодДоступа = Неопределено;
	Иначе
		НачалоКода = Найти(ЭлементыФормы.Браузер.документ.URLUnencoded, "=")+1;	
		КодДоступа = Сред(СтрокаСКодом,НачалоКода,СтрДлина(СтрокаСКодом)-1);
	КонецЕсли;
КонецПроцедуры

Далее получаем маркер доступа:

Функция ПолучаемМаркер()
	
	XTTPЗапрос = Новый COMОбъект("WinHttp.WinHttpRequest.5.1");
	Скрипт = Новый COMОбъект("MSScriptControl.ScriptControl");
	Скрипт.language = "javascript";
	Скрипт.AddObject("XTTPЗапрос", XTTPЗапрос);
	Скрипт.Eval("XTTPЗапрос.Option(4)=13056");
	
	XTTPЗапрос.Open("Post", "https://accounts.google.com/o/oauth2/token", 0);
	XTTPЗапрос.setRequestHeader("Content-Type", "application/x-www-form-urlencoded");
	
	ПараметрыPOST = "grant_type=authorization_code" + "&";
	ПараметрыPOST = ПараметрыPOST + "code=" + КодДоступа + "&";
	
	ПараметрыPOST = ПараметрыPOST + "client_id=" + client_id + "&";
	ПараметрыPOST = ПараметрыPOST + "client_secret=" + client_secret + "&";
	ПараметрыPOST = ПараметрыPOST + "redirect_uri=" + redirect_uri;
	
	XTTPЗапрос.send(ПараметрыPOST);
		
	ТекстОтвета = XTTPЗапрос.responsetext();
	
	//парсим строку. вытаскиваем значение маркера
	НачалоТокена = Найти(ТекстОтвета, "access_token")+17;
	КонецТокена  = Найти(ТекстОтвета, "token_type")-6;
	пМаркер = Сред(ТекстОтвета,НачалоТокена, КонецТокена-НачалоТокена);
	
Возврат пМаркер;
КонецФункции

Получив маркер, можем получить доступ к метаданным нашей таблицы. В метаданных есть много чего интересного, в том числе и ссылка на скачивание (в форматах csv, pdf, xlsx). Итак, получим метаданные нашей таблицы.

Процедура ПолучитьМетаданные()
	ФайлМетаданных = ПолучитьИмяВременногоФайла(".txt");
		XTTPЗапрос = Новый COMОбъект("WinHttp.WinHttpRequest.5.1");
	Скрипт = Новый COMОбъект("MSScriptControl.ScriptControl");
	Скрипт.language = "javascript";
	Скрипт.AddObject("XTTPЗапрос", XTTPЗапрос);
	Скрипт.Eval("XTTPЗапрос.Option(4)=13056");
	
	XTTPЗапрос.Open("GET", "https://www.googleapis.com/drive/v2/files/"+ID_Файл);
	XTTPЗапрос.setRequestHeader("Authorization", "Bearer " + Маркер);
	XTTPЗапрос.send();
		ТекстОтвета = XTTPЗапрос.responsetext();
		СсылкаДляСкачивания = ПолучитьСсылкуДляСкачивания(ТекстОтвета);
КонецПроцедуры

Далее дело за малым. Нужно обработать полученный ответ. Вытягиваем от туда ссылку на скачивание. (В нашем примере в формате .xlsx).

Функция ПолучитьСсылкуДляСкачивания(ТекстОтвета)
	
	СтрокаПоиска = "application/vnd.openxmlformats-officedocument.spreadsheetml.sheet"": """;
	НачалоСсылки = Найти(ТекстОтвета, СтрокаПоиска)+СтрДлина(СтрокаПоиска);	
	КонецСсылки  = Найти(ТекстОтвета, "userPermission")-8;
	Результат = Сред(ТекстОтвета, НачалоСсылки, КонецСсылки-НачалоСсылки);
	
	Возврат Результат;
	
КонецФункции // ()

И финалочка. Скачиваем таблицу во временный файл
Пример кода:       

ВременнаяТаблица = ПолучитьИмяВременногоФайла(".xlsx");
КопироватьФайл(СсылкаДляСкачивания, ВременнаяТаблица);
#Если Клиент Тогда
Сообщить("Таблица сохранена во временный файл: " + ВременнаяТаблица);
#КонецЕсли	

В результате получим временную .xlsx таблицу

Скачать файлы

Наименование Файл Версия Размер
Обработка гугл-таблицы.epf

.epf 11,48Kb
17
.epf 11,48Kb 17 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. kao_andi 20 01.12.15 07:18 Сейчас в теме
Вопрос, а почему HTTP-запросы реализованы через COM-объект, чем не устроили типовые?
2. softgarant 60 06.12.15 21:10 Сейчас в теме
(1) kao_andi, чесно говоря не пробовал использовать типовые http-запросы. нашел пример реализации через COM, по этому выбор чисто субъективный
3. kashafeev 17.03.16 11:34 Сейчас в теме
А как добавлять данные, в уже имеющуюся Гугл-таблицу (Например для обновления цен). И как сделать это в авто режиме, чтобы не проходить каждый раз авторизацию?
4. viktor2008 16.02.17 08:43 Сейчас в теме
Все прекрасно работает. Файл получил, исправил. А теперь самое главное - как отправить обратно его на гугл-диск?
5. Mirared 10.09.17 14:37 Сейчас в теме
(4) присоединюсь к вопросу. Как обратно сконвертировать Excel в таблицу Google? Подскажите, пожалуйста
6. kyzma-kyzmi4 3 27.04.18 16:48 Сейчас в теме
Добрый день!

Не срабатывает копирование Файла
КопироватьФайл(СсылкаДляСкачивания, ВременнаяТаблица);

Подскажите, на текущий момент код рабочий или Google изменил API?
8. Serj1C 480 20.03.19 12:52 Сейчас в теме
(6) Копирование файла сломалось после массового перехода с HTTP на HTTPS
По умолчанию копирование ломится без шифрования, сервер его редиректит на защищенный протокол и тут получается казус.
softgarant; +1 Ответить
7. softgarant 60 04.05.18 17:12 Сейчас в теме
Скорее всего дело в сервисе Google, проект мы разработали и продали, поддержку не осуществляем, потому как оно сейчас работает не могу знать, к сожалению.
Оставьте свое сообщение

См. также

Интеграция с бонусной программой лояльности ManyBonus Промо

Управление взаимоотношениями с клиентами (СRM) Розничная торговля WEB v8 Розница УУ Абонемент ($m)

ManyBonus.com - бонусная программа лояльности на базе мессенджеров. Позволяет регистрировать клиента в программе лояльности через Telegram, Viber, VK, отправлять коды скидок в мессенджеры, получать уведомления при списании/начислении бонусных баллов, альтернатива сообщениям СМС.

3 стартмани

07.01.2021    2757    4    Anton64    0    

Расширение конфигурации для Web-доступа к 1С (1С в роли back-end)

WEB v8 1cv8.cf Россия Абонемент ($m)

Для реализации того, чтобы 1С формировала и отдавала страницу, которую можно было бы открыть через браузер было написано расширение, которое позволяет публиковать из 1С произвольные ресурсы, будь то API, сайт или изображения / прочие файлы.

1 стартмани

01.04.2021    2767    4    SaschaG    3    

Работа с картами в 1С на примере бесплатной библиотеки Leaflet

Практика программирования Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

Разработка функционала отображения и выбора пунктов доставки на карте прямо в 1С с помощью бесплатной библиотеки Leaflet. Тестирование производилось на платформе 8.3.15.1534 на тонком клиенте.

1 стартмани

31.03.2021    2250    6    Parsec1C    7    

Генератор маршрута по "документам отгрузки" в Google.Maps

Оптовая торговля Розничная торговля WEB v8 v8::ОУ УТ11 Россия УУ Абонемент ($m)

Данная обработка будет полезна для построения маршрута по документам реализаций за выбранный период.

7 стартмани

08.11.2020    4467    9    quazare    16    

BIM: взаимодействие с платформой Autodesk Forge Промо

WEB v8 1cv8.cf Строительство Абонемент ($m)

Предлагаемый пример демонстрирует широкие возможности для взаимодействия «1С:Предприятие» с платформой Autodesk Forge и позволяет вам получить базовые представления о применения технологий информационного моделирования в строительстве. Поддерживаются все версии платформы от 8.3.12 и выше до 8.3.18.

1 стартмани

25.11.2020    15014    4    kandr    2    

Продажи со склада поставщика WildBerries. Взаимодействие с АПИ из 1С

WEB Розничная торговля v8 УТ11 УУ Абонемент ($m)

Взялся я тут делать интеграцию с АПИ нового проекта Диких Ягод - Продажи со склада поставщика (ПССП). Это было нелегко. Никто же не читает инструкцию (уже аж 7 версии!), а зря! Для начала сделал получение списка товаров и обмен остатками.

5 стартмани

06.11.2020    13852    116    kiv1c    115    

Чатбот WhatsApp

WEB v8 1cv8.cf Абонемент ($m)

Внешняя обработка для написания чат-бота WhatsApp

1 стартмани

21.10.2020    5952    23    ripreal1    20    

1С + react native

WEB v8 1cv8.cf Абонемент ($m)

Пример реализации клиента для 1С на react native.

1 стартмани

09.10.2020    6403    6    van_za    6    

Односторонний файловый обмен с сайтом по ftp (1C 2 Web) Промо

Обмен данными 1С Файловые протоколы обмена, FTP WEB v8 Розница УНФ ERP2 БП3.0 УТ11 КА2 ЗУП3.x Абонемент ($m)

Подходит под любую конфигурацию на управляемом интерфейсе на базе БСП 2.4.4 и выше. Позволяет гибко настроить выгрузку, практически любых, данных по расписанию на сервер ftp вашего ресурса. Ведение лога процесса выгрузки также предусмотрено.

3 стартмани

09.12.2019    6549    8    LamerSoft    0    

Учимся создавать http сервис (часть третья). Передача нескольких параметров в http сервис

WEB Практика программирования v8 1cv8.cf Абонемент ($m)

Пошаговое руководство по созданию http сервиса (часть третья). Передача нескольких параметров в http сервис, a также формирование сложных JSON строк.

1 стартмани

02.10.2020    7400    2    hpi    16    

Подключаем WhatsApp к 1С

WEB v8 1cv8.cf Абонемент ($m)

Обработка для быстрого подключения WhatsApp к любой конфигурации 1С.

1 стартмани

30.09.2020    6870    35    andrew_shamin    58    

HTTP сервисы по OpenAPI спецификациям

Практика программирования WEB v8 1cv8.cf Абонемент ($m)

Начинаем путь разработки HTTP сервисов с создания спецификаций OpenAPI. Автодокументация сервисов формата Swagger UI без зависимостей. Настройка сервисов в режиме предприятия.

1 стартмани

29.06.2020    10603    9    shmalevoz    20    

"Учет штрафов ГИБДД" с возможной загрузкой из открытых источников в интернет Расширение конфигурации 1С: Предприятие 8.3 Промо

Обработка документов WEB v8 v8::УФ 1cv8.cf Россия БУ УУ Абонемент ($m)

Расширение конфигурации Бухгалтерия предприятия, редакция 3.0 (при минимальных изменениях любой типовой конфигурации), позволяющее вести историю данных по штрафам ГИБДД для справочника транспортных средств компании. Бонусом поставляется внешняя обработка, способная загружать эти данные из открытых источников в интернет.

4 стартмани

30.12.2019    12039    17    capitan    11    

Конструктор HTTP-соединений в 1С (обычные и управляемые формы)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Иногда возникают мысли о том, чтобы прикрутить сервисы, связанные с HTTP-соединениями, в 1С. Необходимо писать обработку и анализировать результат.

1 стартмани

02.06.2020    6092    25    Denr83    0    

DaJet QL - расширяемый язык запросов

Интеграция WEB v8 Абонемент ($m)

DaJet QL поддерживает практический полный синтаксис SQL Server 2005-2016. Кроме этого это расширяемый язык запросов. Обращение к объектам СУБД выполняется в терминах метаданных 1С. Доступ к возможностям этого языка запросов реализован в виде web api сервиса. Результаты запросов возвращаются в виде JSON.

1 стартмани

20.04.2020    8891    11    zhichkin    16    

Обмен данными между OZON и 1С

Оптовая торговля WEB v8 v8::ОУ УТ11 УУ Абонемент ($m)

Данная подсистема позволяет загружать отправления «с моего склада» из OZON (в статусе «Ожидают сборки») в 1с Управление торговлей 11 по API. Так же есть возможность выгружать статусы отправлений «awaiting_deliver, т.е. Ожидает отгрузки» и «cancelled, т.е. Отменен» из 1с в OZON по API.

10 стартмани

09.04.2020    19985    188    vex2865    122    

Внешняя компонента для работы по Web-socket протоколу x32 x64 Промо

Разработка внешних компонент WEB v8 Абонемент ($m)

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

1 стартмани

30.03.2018    30260    38    Ditron    90    

Пример работы с Trello из 1С

WEB v8 1cv8.cf Россия УУ Абонемент ($m)

Небольшая конфигурация содержит примеры обмена с онлайн-сервисом Trello.

1 стартмани

15.02.2020    13413    47    terrorion    14    

Взаимодействие HTML (COM объект, WebKit) с 1С (обычные и управляемые формы)

Внешние источники данных WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Показан пример использования HTML (COM объект, WebKit) в 1С (8.3).

2 стартмани

18.01.2020    10041    28    Deniskinr83    0    

Google drive - менеджер файлов

WEB Внешние источники данных v8 1cv8.cf Россия Абонемент ($m)

Синхронизация с гугл диском легко и просто!

10 стартмани

05.12.2019    12017    35    zykov_vitaliy    26    

Работа с релизами 1С и договорами ИТС Промо

WEB БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Работа с релизами 1С и партнерским кабинетом.

2 стартмани

15.08.2019    16669    52    RocKeR_13    35    

Автозаполнение адреса по КЛАДР в УПП при выгрузке контрагента с портала компании (API dadata)

WEB v8 1cv8.cf Абонемент ($m)

Заведение, согласование контрагентов организовано на портале компании. Далее по web-сервису контрагенты выгружаются в УПП (юр.адрес и факт.адрес выгружаются строкой). Задача автоматизировать заполнение адреса в УПП по КЛАДР.

1 стартмани

03.12.2019    8225    1    John_d    10    

Работа с Яндекс-картами в 1С (вывод меток, прокладка маршрута, отображение балуна, вывод меток в кластеры) (обычное и управляемое приложение)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Работа с Яндекс-картами в 1С (управляемое приложение). Обработка показывает, как можно найти адреса на карте Яндекс, проложить маршрут.

2 стартмани

20.11.2019    14965    134    Denr83    0    

Пример взаимодействия HTML (COM объект, WebKit) с 1С (динамический отбор) (обычные и управляемые формы)

WEB v8 v8::УФ 1cv8.cf Абонемент ($m)

Показан пример использования WebKit в 1С (8.3).

2 стартмани

18.11.2019    11570    16    Denr83    0    

Проверка VAT номеров Промо

WEB v8 1cv8.cf Абонемент ($m)

Обработка для вызова сервиса проверка VAT номера.

1 стартмани

26.11.2018    14826    3    wtlz    1    

Яндекс сервисы [Расширение]

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

Расширение для работы с Яндекс-сервисами (предиктор,переводчик,проверка орфографии)

1 стартмани

24.10.2019    12942    10    noprogrammer    12    

Telegram бот на 1С

WEB v8 1cv8.cf Абонемент ($m)

Telegram бот на 1С в виде внешней обработки, встраиваемой в типовые 1С 8.3.

1 стартмани

24.09.2019    19384    40    budidich    19    

Выгрузка номенклатуры в социальную сеть Вконтакте

WEB Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

2 стартмани

14.08.2019    17565    56    kaliuzhnyi    48    

Трекинг номеров РПО в Почте России Промо

WEB Оптовая торговля Оптовая торговля v8 Оптовая торговля, дистрибуция, логистика Абонемент ($m)

Относительно недавно Почта России стандартизировала и описала сервисы получения информации о регистрируемом почтовом отправлении (РПО). Представляю вашему вниманию конфигурацию-обертку над сервисами Почты России. Она позволяет просто (http-запросы) и без изменений конфигурации подключить сервисы отслеживания к своим информационным системам.

2 стартмани

28.03.2016    29244    38    Smaylukk    3    

Путеводитель по истории релизов

WEB v8 1cv8.cf Абонемент ($m)

Отчет по истории выпуска релизов и анализа информации по обновлениям.

5 стартмани

13.08.2019    15706    13    YPermitin    18    

Подключение к сайту и отправка или получение данных по API (POST, GET...) (с описанием кода)

WEB v8 1cv8.cf Абонемент ($m)

Простая обработка по отправке или получение данных с любого сервера главное знать ресурс (выполняемую функцию) и тело запроса.

1 стартмани

12.08.2019    19516    37    MaxPowerr    5    

Конфигурация для обмена данными (интеграционная шина)

Внешние источники данных WEB v8 1cv8.cf Абонемент ($m)

Система позволяет организовать обмен данными, как с базами 1С, так и любыми другими приложениями. Система представляет собой отдельную конфигурацию. Система позволяет организовать гибкие возможности по настройке обмена. В качестве брокера сообщений, для передачи данных, используется отдельная самостоятельная конфигурация на 1С. Комплект поставки содержит файл расширения для "клиентской" части шины, данное расширение позволяет без снятия "ключа" организовать гибкий механизм обмена данными.

4 стартмани

08.07.2019    15598    33    miha-28    17    

Работа с картой. Кадастровый учет (Росреестр). Тематические карты Промо

WEB Рабочее место v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка для работы с картами в 1С. Получения изображения с публичной кадастровой карты России, построения тематических карт

5 стартмани

31.08.2017    20981    8    vipchep    0    

Шаблон http-сервиса для вашего проекта

Внешние источники данных WEB Мобильная разработка v8 v8::Mobile 1cv8.cf Абонемент ($m)

Http-сервис для обмена данными в формате JSON. Обработчики этого сервиса находятся во внешней обработке, что позволяет дорабатывать его без изменения конфигурации. Также прилагаю пример мобильного приложения для работы с данным сервисом (получает номенклатуру и остатки на складе). Сервис очень быстро разворачивается и масштабируется под ваши задачи.

3 стартмани

04.05.2019    22033    81    MarkoSokolov    48    

1С и WebKit. Вариант взаимодействия

WEB v8 1cv8.cf Абонемент ($m)

В результате перехода на WebKit тип свойства Документ у поля, имеющего вид ПолеHTMLДокумента, изменился с COMОбъект на ВнешнийОбъект. Также изменилась DOM модель документа, доступная через это свойство.

2 стартмани

23.02.2019    34362    83    mi1man    58    

Строим маршруты на картах в 1С с помощью OpenStreetMap, OSRM и Leaflet

WEB v8 1cv8.cf Транспорт, автопарки, такси Абонемент ($m)

Краткая статья о том как вывести на карту (в 1С) маршруты с помощью OpenStreetMap, OSRM и Leaflet. По данной системе очень мало примеров, но так как OpenStreetMap является бесплатным сервисом и не требует никаких ключей и регистраций, и является довольно мощным механизмом, решил написать небольшую статью "как это сделать?". В первую очередь скажу, все намного проще, если вы используете последнюю версию платформы (8.3.14), где есть поддержка практически всех браузеров (IE 11, EDGE, Mozilla), но что делать если у нас не самая свежая платформа, где поддержка только IE 9?

2 стартмани

12.02.2019    30236    115    Ditron    94    

Работа с картами 1С 4 в 1: Яндекс, Google , 2ГИС, OpenStreetMap(OpenLayers) Промо

Универсальные обработки WEB v8 1cv8.cf Абонемент ($m)

С каждым годом становится все очевидно, что использование онлайн-сервисов намного упрощает жизнь. К сожалению по картографическим сервисам условия пока жестковаты. Но, ориентируясь на будущее, я решил показать возможности API выше указанных сервисов: Инициализация карты Поиск адреса на карте с текстовым представлением Геокодинг Обратная поиск адреса по ее координатами Взаимодействие с картами - прием координат установленного на карте метки Построение маршрутов по указанным точками Кластеризация меток на карте при увеличении масштаба Теперь также поддержка тонкого и веб-клиента

1 стартмани

28.12.2012    111083    2696    Smaylukk    365    

Яндекс карта в документе "Заказ клиента" на закладке "Доставка". (Расширение) УТ 11.4

Обработка документов WEB Оптовая торговля Оптовая торговля v8 УТ11 Россия УУ Абонемент ($m)

Показ яндекс карты в документе "Заказ клиента" на закладке "Доставка" и печать карты для курьера с контактными данными. (Расширение)

3 стартмани

05.02.2019    12603    12    ret    7    

Яндекс карты 2.1. Построение маршрута. Передача длины маршрута в реквизит формы

WEB v8 1cv8.cf Абонемент ($m)

Пригодится как пример использования Яндекс карты 2.1 для построения маршрута.

1 стартмани

24.01.2019    16547    82    John_d    33    

Веб-форма авторизации/регистрации/восстановления пароля для веб-клиента 1С с помощью HTML/CSS/PHP/HTTP-сервисов 1С

WEB v8 1cv8.cf Абонемент ($m)

Пришла в голову идея создать универсальную веб-форму входа в веб-клиент 1С на HTML/CSS/PHP/HTTP-сервисы 1С. Чтобы прямо как на нормальных сайтах. Заодно и для ознакомления с 1С с новой, для себя, стороны. Интересно было попробовать интеграцию PHP - 1С.

1 стартмани

08.11.2018    21069    28    Бэнни    22    

Пример использования REST API Яндекс Диска Промо

WEB v8 1cv8.cf Абонемент ($m)

Пример использования REST API Яндекс Диска: чтение диска, добавление каталога, загрузка файла, скачивание файлов или каталогов, удаление файлов или каталогов.

1 стартмани

26.06.2018    28824    46    MKFreeUser    15    

Загрузка чека онлайн-касс (загрузка товаров из чека)

Внешние источники данных WEB Кассовые операции Розничная торговля Кассовые операции Розничная торговля v8 1cv8.cf Абонемент ($m)

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) из почтового сообщения, отправленного из приложения ФНС проверка чеков.

2 стартмани

08.10.2018    24440    40    echo77    73    

SOAP для чайников

Обмен через XML WEB v8 1cv8.cf Абонемент ($m)

Немножко про SOAP сервис. И пример работы с подключением и получением данных по SOAP за 5 минут.

1 стартмани

05.09.2018    63429    51    dusha0020    19    

Класс-обработка “Работа с картами Яндекс”

Разработка внешних компонент WEB v8 Абонемент ($m)

Как показать точку или маршрут на карте Яндекс. Как получить координаты по строке адреса (геокодирование).

1 стартмани

01.08.2018    28947    220    RSConsulting    17    

Работа с публикациями "Инфостарт" Промо

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    24273    13    RocKeR_13    16    

Конфигурация для просмотра публичных телеграм каналов Промо

WEB v8 Абонемент ($m)

Просмотр и каталогизация в более удобном виде публичных телеграм каналов, групп и чатов.

1 стартмани

02.06.2018    19871    13    DO_WHILE_LOOP    7