Поиск товаров по штрихкоду на сайте www.ean13.info

Публикация № 442259

Администрирование - Администрирование данных 1С - Обработка справочников

штрихкоды ean13.info

Описание товаров, имеющих штрихкод, с некоторой вероятностью можно найти на www.ean13.info. Обработка выполняет этот поиск. Немного доработав, можно использовать для наполнения справочника "Номенклатура" с помощью сканера штрихкодов. (UPD: С недавних пор перестало работать из-за перевода сайта на https, требует соответствующей доработки)

Принцип действия очень простой.

http://www.ean13.info/4604290001691.htm - пример описания товара по его штрихкоду. Т.е. в форме обработки задаем список желаемых штрихкодов, на каждый из них запрашивается соответствующая страница.

Далее страница парсится по этому алгоритму: //infostart.ru/public/308253/.

Обработка на обычных и управляемых формах одновременно. Выполняет только поиск описания товаров, при желании можно доработать для создания элементов справочника "Номенклатура" по найденным результатам.

Для использования обработки не требуется регистрация. Однако при активном употреблении через какое-то время сайт начинает выдавать капчу вместо привычного описания товаров. В каталоге также имеется платный API (5000 запросов за 10 USD). 

UPD:

Если же ключ API у вас есть, то достаточно передать его вторым параметром в метод "ЗаполнитьТаблицуТоваров" (или указать в форме, если вы скачали обработку полностью), после чего получение данных о товарах пойдет живее и без неизбежного бана. При "боевом" использовании (более 50-100 запросов) это рекомендованный вариант работы.

Тестовый ключ xccvg55kh43jjf указан здесь http://www.mpk.dn.ua/ean13_info_platnoje_api.html и дает доступ только к одному товару: 4603172600007, Сигареты "Прима люкс" без фильтра.

P.S. Выкладываю исходники модуля объекта (в формах кода почти нет). В комментариях ниже есть альтернативный метод парсинга.

Перем СоединениеССервером;//кэш

Функция getXPathElement(sXPath, objElement )
	//взял здесь: //infostart.ru/public/308253/
	
     // Split the xpath statement
    лМассивХР = СтрЗаменить(sXPath, "/",Символы.ПС);
    лИндексНоды = СтрПолучитьСтроку(лМассивХР,1); //лИндексНоды
    Если Найти(лИндексНоды, "@id") > 0 Тогда
        лИмя = СтрЗаменить(лИндексНоды,"[","");
        лИмя = СтрЗаменить(лИмя,"]","");
        лИмя = СтрЗаменить(лИмя,"=",Символы.ПС);
        лИмя = СтрПолучитьСтроку(лИмя,2);
        лИмя = СтрЗаменить(лИмя,"""","");
        ЛobjElement = objElement.ПолучитьЭлементПоИдентификатору(лИмя); 
        лМассивХР = СокрЛП(СтрЗаменить(лМассивХР,СтрПолучитьСтроку(лМассивХР,1),""));
        лИндексНоды = СтрПолучитьСтроку(лМассивХР,1);
    Иначе 
        ЛobjElement = objElement;
    КонецЕсли;    
    
    If Not Найти(лИндексНоды, "[") > 0 Then
        sNodeName = лИндексНоды;
        lNodeIndex = 1;
    Else
        лИндексНоды = СтрЗаменить(лИндексНоды, "[",Символы.ПС);
        лИндексНоды = СтрЗаменить(лИндексНоды, "]",Символы.ПС);
        sNodeName =  СтрПолучитьСтроку(лИндексНоды,1);
        lNodeIndex = Число(СтрПолучитьСтроку(лИндексНоды,2));
    EndIf;
    sRestOfXPath ="";
    Для Сч =2 По СтрЧислоСтрок(лМассивХР) Цикл
        sRestOfXPath = sRestOfXPath + ?(Сч=2,"","/")+СтрПолучитьСтроку(лМассивХР,Сч);        
    КонецЦикла;
     
    getXPathElement = Неопределено;
    
    лСчЭлементов = 0;
    For lCount = 0 To ЛobjElement.ДочерниеУзлы.Количество() - 1 Цикл
        If ВРег(ЛobjElement.ДочерниеУзлы.Item(lCount).ИмяУзла) = ВРег(sNodeName) Then
            лСчЭлементов = лСчЭлементов + 1;
            If lNodeIndex = лСчЭлементов Then
                If sRestOfXPath = "" Then
                    getXPathElement = objElement.ДочерниеУзлы.Элемент(lCount);
                    Прервать;
                Else
                    getXPathElement = getXPathElement(sRestOfXPath, ЛobjElement.ДочерниеУзлы.Элемент(lCount));
                    Прервать;
                EndIf;
            EndIf;
        EndIf;
    КонецЦикла;
    Возврат getXPathElement;
КонецФункции

Функция ПолучитьРезультатПарсингаWWW(ЛокальноеИмяФайла)
	
	РезультатПарсинга = Новый Структура;
	
	ЧтениеHTML = Новый ЧтениеHTML;
	ЧтениеHTML.ОткрытьФайл(ЛокальноеИмяФайла,"UTF8");
	ПостроительДом = Новый ПостроительDOM;
	Документ = ПостроительДом.Прочитать(ЧтениеHTML);
	ЧтениеHTML.Закрыть();
	
	//теперь XPATH, который не совсем XPATH
	ТекстЗапроса = "html[2]/body/div[1]/div/div[3]/div[2]";
	
	СекцияОписания = getXPathElement(ТекстЗапроса,Документ);
	
	Попытка
		РезультатПарсинга.Вставить("Наименование",	getXPathElement("h1/span",СекцияОписания).ТекстовоеСодержимое);
		РезультатПарсинга.Вставить("Успешно",		НЕ (РезультатПарсинга.Наименование = "Товар не найден в базе данных"));
	Исключение	
		//неправильный формат штрихкода или еще какая беда
		РезультатПарсинга.Вставить("Успешно",		Ложь);
	КонецПопытки;	
	
	Если РезультатПарсинга.Успешно Тогда
		РезультатПарсинга.Вставить("ТипШтрихКода",	getXPathElement("ul/li[2]/span",СекцияОписания).ТекстовоеСодержимое);
		РезультатПарсинга.Вставить("Страна",		getXPathElement("ul/li[3]/span",СекцияОписания).ТекстовоеСодержимое);
		РезультатПарсинга.Вставить("Производитель",	getXPathElement("ul/li[4]/span",СекцияОписания).ТекстовоеСодержимое);
		РезультатПарсинга.Вставить("Бренд",			getXPathElement("ul/li[5]/span",СекцияОписания).ТекстовоеСодержимое);
		РезультатПарсинга.Вставить("Категория",		getXPathElement("ul/li[6]/span",СекцияОписания).ТекстовоеСодержимое);
		РезультатПарсинга.Вставить("Описание",		СокрЛП(getXPathElement("ul/li[7]/span/#text",СекцияОписания).ТекстовоеСодержимое));
	КонецЕсли;	
	
	Возврат РезультатПарсинга;
	
КонецФункции

Функция ПолучитьРезультатПарсингаXML(ЛокальноеИмяФайла)
	
	РезультатПарсинга = Новый Структура;
	
	ЧтениеXML = Новый ЧтениеXML;
	ЧтениеXML.ОткрытьФайл(ЛокальноеИмяФайла,,,"UTF8");
	
	ПостроительДом = Новый ПостроительDOM;
	Попытка
		Дерево = ПостроительДом.Прочитать(ЧтениеXML);
	Исключение
		//Вместо XML сервер может вернуть текст "Отсутствует ключ для доступа к API" (видимо, если лимит запросов ключа исчерпан)
		РезультатПарсинга.Вставить("Успешно",Ложь);
		Возврат РезультатПарсинга;
	КонецПопытки;
		
	ЧтениеXML.Закрыть();
	
	Попытка
		РезультатПарсинга.Вставить("Успешно",		getXPathElement("ean13/valid",Дерево).ТекстовоеСодержимое="1");
		РезультатПарсинга.Вставить("Наименование",	getXPathElement("ean13/name",Дерево).ТекстовоеСодержимое);
	Исключение	
		//неправильный формат штрихкода или еще какая беда
		РезультатПарсинга.Вставить("Успешно", Ложь);
	КонецПопытки;	
	
	Если РезультатПарсинга.Успешно Тогда
		//РезультатПарсинга.Вставить("ТипШтрихКода",			getXPathElement("ean13/name",Дерево).ТекстовоеСодержимое);
		РезультатПарсинга.Вставить("Страна",					getXPathElement("ean13/contry",Дерево).ТекстовоеСодержимое);
		РезультатПарсинга.Вставить("Производитель",				getXPathElement("ean13/man",Дерево).ТекстовоеСодержимое);
		РезультатПарсинга.Вставить("Бренд",						getXPathElement("ean13/brand",Дерево).ТекстовоеСодержимое);
		РезультатПарсинга.Вставить("Категория",					getXPathElement("ean13/cat",Дерево).ТекстовоеСодержимое);
		РезультатПарсинга.Вставить("Описание",					getXPathElement("ean13/desc",Дерево).ТекстовоеСодержимое);
		РезультатПарсинга.Вставить("ДатаПоследнегоИзменения",	ДатаXMLВ1С(getXPathElement("ean13/lastmod",Дерево).ТекстовоеСодержимое));
		РезультатПарсинга.Вставить("ОсталосьЗапросовAPI",		Число(getXPathElement("ean13/yourlimit",Дерево).ТекстовоеСодержимое));
	КонецЕсли;	
	
	Возврат РезультатПарсинга;
	
КонецФункции

Функция ДатаXMLВ1С(ЗНАЧ ДатаСтрокой)
	
	//Пример: 2014-09-05T19:03:38+04:00
	
	Перем Результат;
	
	ДатаСтрокой = Лев(ДатаСтрокой,19);
	ДатаСтрокой = СтрЗаменить(ДатаСтрокой,"-","");
	ДатаСтрокой = СтрЗаменить(ДатаСтрокой,":","");
	ДатаСтрокой = СтрЗаменить(ДатаСтрокой,"T","");
	
	Попытка
		Результат = Дата(ДатаСтрокой);
	Исключение
		//не критично
	КонецПопытки;
	
	Возврат Результат;
	
КонецФункции

Функция ПроверитьШтрихкод(Штрихкод,КлючAPI)
	
	//можно еще кэширование добавить
	
	Если НЕ ЗначениеЗаполнено(КлючAPI) Тогда
		//ЛокальноеИмяФайла = "c:\pricat\Doc\ean13.info\Капот 2107-8401012, штрих-код_ 4604290001363 - Ean13.info, информация о товаре.html";
		ЛокальноеИмяФайла = ПолучитьФайлHTTP("/"+Штрихкод+".htm");
		Результат = ПолучитьРезультатПарсингаWWW(ЛокальноеИмяФайла);
	Иначе
		ЛокальноеИмяФайла = ПолучитьФайлHTTP("/api.php?code="+Штрихкод+"&key="+КлючAPI); // /api.php?code=4603172600007&key=xccvg55kh43jjf
		Результат = ПолучитьРезультатПарсингаXML(ЛокальноеИмяФайла);
	КонецЕсли;
	
	УдалитьФайлы(ЛокальноеИмяФайла);
	Возврат Результат;
	
КонецФункции

Функция ПолучитьФайлHTTP(АдресЗапроса)
	
	Если СоединениеССервером=Неопределено Тогда
		Сервер = "www.ean13.info";
		СоединениеССервером = Новый HTTPСоединение(Сервер);
	КонецЕсли;	
	ИмяФайлаОтвета = ПолучитьИмяВременногоФайла();
	СоединениеССервером.Получить(АдресЗапроса,ИмяФайлаОтвета);
	Возврат ИмяФайлаОтвета;
	
КонецФункции	

Функция ПолучитьТестовыеДанные() Экспорт
	
	Возврат 
	
	"4603172600007
	|4604290001363
	|
	|4690449004650
	|штрихкод, который должен свалиться
	|4690449004651";
	
КонецФункции	

Процедура ЗаполнитьТаблицуТоваров(СписокШтрихкодов,КлючAPI="") Экспорт
	
	Товары.Очистить();
	
	Для Сч=1 по СтрЧислоСтрок(СписокШтрихкодов) Цикл
		ТекШтрихкод = СтрПолучитьСтроку(СписокШтрихкодов,Сч);
		Если СокрЛП(ТекШтрихкод)<>"" Тогда
			
			НовСтрока = Товары.Добавить();
			НовСтрока.Штрихкод = ТекШтрихкод;
			
			Попытка
				РезультатПарсинга = ПроверитьШтрихкод(СокрЛП(ТекШтрихкод),КлючAPI);
				ЗаполнитьЗначенияСвойств(НовСтрока,РезультатПарсинга);
			Исключение
				_Ошибка = ОписаниеОшибки();
				Сообщить("Не найден штрихкод "+ТекШтрихкод+" по причине:
				|"+_Ошибка);
			КонецПопытки;	
			
		КонецЕсли;	
	КонецЦикла;	
	
КонецПроцедуры	

Скачать файлы

Наименование Файл Версия Размер
Поиск товаров в ean13.info

.epf 17,72Kb
22
.epf 17,72Kb 22 Скачать

Специальные предложения

Комментарии
В избранное Подписаться на ответы Сортировка: Древо развёрнутое
Свернуть все
1. webester 34 09.01.16 10:49 Сейчас в теме
Прошу прощения, что мешаю зарабатывать мани, но там же несколько строк.
			Соединение = Новый HTTPСоединение("www.ean13.info");
			Ответ = Соединение.Получить(Новый HTTPЗапрос(""+КакойТоШтрихКод+".htm"));
			
			РезультатПоиска = Новый Структура("Статус, Товар,Страна,Производитель,Штрихкод", СтрокаСообщения);

			Если Ответ.КодСостояния = 200 Тогда
				ЧтениеХТМЛ = Новый ЧтениеHTML;
				ЧтениеХТМЛ.УстановитьСтроку(Ответ.ПолучитьТелоКакСтроку());
				ПостроительДОМ = Новый ПостроительDOM;
				
				ДокументХТМЛ = ПостроительДОМ.Прочитать(ЧтениеХТМЛ);
				ЭлементыДОМ = ДокументХТМЛ.ПолучитьЭлементыПоИмени("span");
				Если ЭлементыДОМ[1].ТекстовоеСодержимое = "Товар не найден в базе данных" Тогда
					//может будем как то обрабатывать
				Иначе
					РезультатПоиска.Статус = "Найдено в интернете";
					РезультатПоиска.Товар = ЭлементыДОМ[1].ТекстовоеСодержимое;
					РезультатПоиска.Страна = ЭлементыДОМ[4].ТекстовоеСодержимое;
					РезультатПоиска.Производитель = ЭлементыДОМ[5].ТекстовоеСодержимое;
					РезультатПоиска.Штрихкод = ТекКод;
				КонецЕсли; 
			Иначе
				//может будем как то обрабатывать
			КонецЕсли; 


Показать
2. skif47 333 09.01.16 12:08 Сейчас в теме
(1) webester, зарабатывание мани не является моей основной целью. Так что нет, не мешаете. Кажется странным, что вместо того, чтобы оформить свой код в публикацию, вы пишете его в комментариях к чужой публикации.
Теперь по существу. Вы часто ищете штрихкоды на этом сайте? С какой целью - проверить существующие в вашей базе товары или добавить новые? Имеет смысл добавить в обработку поддержку API и попробовать пообщаться с хозяевами базы на тему "дайте тарифы попроще и с оплатой не через сбербанк"? Создание номенклатуры по найденному стоит добавлять?
4. webester 34 09.01.16 12:23 Сейчас в теме
(2)
Кажется странным, что вместо того, чтобы оформить свой код в публикацию, вы пишете его в комментариях к чужой публикации

Мне показалось излишним делать публикацию на каждые 10 строк кода. Слишком простая штука. Поэтому добавил когда увидел ваш пост, раз вы все таки сочли нужным делать для этого пост. Мне кажется вам надо было сразу выкладывать код, раз вам не нужны мани.Что бы мог воспользоваться любой даже без аккаунта на ИС.

Вы часто ищете штрихкоды на этом сайте?

Нет.

С какой целью - проверить существующие в вашей базе товары или добавить новые?

Запускаю работающую аптеку, неохота руками все набирать. по макс убрать ручной труд, насколько возможно. Будем искать названия в файлах поставщиков, если не найдется, то в базе, если и там не будет, то наберет фармацевт название ручками.

Имеет смысл добавить в обработку поддержку API и попробовать пообщаться с хозяевами базы на тему "дайте тарифы попроще и с оплатой не через сбербанк"?
Вам виднее, но мне кажется добавлять апи которое работает с апи, какой то перебор.

Создание номенклатуры по найденному стоит добавлять?
Слишком щепетильный вопрос, для аптеки критичен производитель, для вас наверно нет, где то должны характеристики заполняться, а к ним уже штрихкод, где то не должны. В разных конфигурациях по разному это должно происходить, если вам хочется этим заниматься, то почему бы и нет? Я честно сказать практический смысл нахожу с трудом. Кому надо тот себе напишет, а кто не может, может заказать за недорого, создание номенклатуры опять же несколько строк кода если под конкретное решение.
komatoza; +1 Ответить
5. skif47 333 10.01.16 00:34 Сейчас в теме
(4) webester, Согласен, исходники выложил.
6. skif47 333 10.01.16 01:23 Сейчас в теме
(4) webester,
Будем искать названия в файлах поставщиков

Если не секрет, что вообще в этом случае предоставляют поставщики? Прайсы, накладные, CommerceML? В моем представлении, фармацевтика - достаточно прокачанная отрасль в плане IT.

добавлять апи которое работает с апи, какой то перебор.
речь шла о том, чтобы запрашивать инфу о товарах не парсингом страниц, а через предназначенный для этого API. Это может пригодиться при необходимости запросить 50-100 и больше штрихкодов (у меня капча вылезла примерно после 50 запросов). Вам действительно ни к чему, если редко туда ходите.
7. webester 34 10.01.16 18:04 Сейчас в теме
(6)
Если не секрет, что вообще в этом случае предоставляют поставщики?

Кто, во что горазд. txt, xls, xml последнее прилетело в html.Какой то бред честное слово.Настолько все строго с этими ценами, условиями и тд такой бардак в поставке накладных.
3. skif47 333 09.01.16 12:11 Сейчас в теме
Эти вопросы ко всем читающим, кстати )
8. sfs1981 04.02.16 14:02 Сейчас в теме
Добрый день.
Как представитель ean13.info, добавлю от себя:
1. Тарифы попроще у нас есть, для тех кто берет доступ оптом, существуют скидки. Если нужно меньше чем 5000 запросов - пиште, договоримся.
2. Мы реализовали обратное АПИ. Теперь, при передаче нам данных о товарах, которых у нас нет , вы получаете бесплатные запросы к базе (1 новый товар = 10 бесплатных запросов).
Ну и похвастаемся: размер базы приближается к 10 млн. товаров.
9. skif47 333 18.01.17 17:53 Сейчас в теме
Новости на всякий случай:сайт ean13.info перешел на https.
По запросам вроде http://ean13.info/4600171016044.htm
возвращается текст:

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>301 Moved Permanently</title>
</head><body>
<h1>Moved Permanently</h1>
<p>The document has moved here.</p>
</body></html>

Соответственно, функция ПолучитьФайлHTTP потребует изменения в способе создания http соединения: должно быть создано безопасное соединение. Параметры конструктора объекта, насколько я помню, различаются в платформах 8.2 и 8.3, также могут потребоваться танцы с бубном вокруг сертификатов.

Увы, заниматься всем этим времени нет.
Оставьте свое сообщение

См. также

Рабочее место менеджера по продажам УТ 11.3, 11.4, ERP 2.4 Промо

Рабочее место Оптовая торговля Оптовая торговля v8 v8::ОУ ERP2 УТ11 УУ Абонемент ($m)

Рабочее место менеджера по продажам УТ, ЕРП. Удобный инструмент в 1С для менеджеров по продажам для повседневной работы с клиентами. Все самое необходимое под рукой для оперативного создания заказа или реализации!

10 стартмани

17.08.2018    14456    45    Ivan90    35    

Интеграция с бонусной программой лояльности ManyBonus

Управление взаимоотношениями с клиентами (СRM) Розничная торговля WEB v8 Розница УУ Абонемент ($m)

ManyBonus.com - бонусная программа лояльности на базе мессенджеров. Позволяет регистрировать клиента в программе лояльности через Telegram, Viber, VK, отправлять коды скидок в мессенджеры, получать уведомления при списании/начислении бонусных баллов, альтернатива сообщениям СМС.

3 стартмани

07.01.2021    1927    2    Anton64    0    

BIM: взаимодействие с платформой Autodesk Forge

WEB v8 Строительство Абонемент ($m)

Предлагаемый пример демонстрирует широкие возможности для взаимодействия «1С:Предприятие» с платформой Autodesk Forge и позволяет вам получить базовые представления о применения технологий информационного моделирования в строительстве. Поддерживаются все версии платформы от 8.3.12 и выше до 8.3.18.

1 стартмани

25.11.2020    12336    4    kandr    0    

[Расширение] БП 3.0. Список счетов от поставщиков / Список поступлений + Связанные документы

Оптовая торговля Рабочее место v8 v8::БУ БП3.0 БУ УУ Абонемент ($m)

Список счетов от поставщиков и список поступлений товаров и услуг + Структура подчиненности в одном окне. Расширение для программы БП 3.0.

3 стартмани

20.05.2020    4156    2    Rustig    13    

Список заказов покупателей (новый взгляд) Промо

Рабочее место Монитор заказов Оптовая торговля Монитор заказов Оптовая торговля v8 v8::ОУ КА1 УТ10 УУ Абонемент ($m)

Внешняя обработка "Список заказов покупателей". Фишка в том, что на одной форме отображается структура связанных документов с указанием контрагента. В этом окне также есть список товаров по заказу. Видны статусы заказов: исполнен, выполняется, черновик.

4 стартмани

16.08.2017    30093    68    Rustig    60    

"Учет штрафов ГИБДД" с возможной загрузкой из открытых источников в интернет Расширение конфигурации 1С: Предприятие 8.3

Обработка документов WEB v8 v8::УФ 1cv8.cf Россия БУ УУ Абонемент ($m)

Расширение конфигурации Бухгалтерия предприятия, редакция 3.0 (при минимальных изменениях любой типовой конфигурации), позволяющее вести историю данных по штрафам ГИБДД для справочника транспортных средств компании. Бонусом поставляется внешняя обработка, способная загружать эти данные из открытых источников в интернет.

4 стартмани

30.12.2019    10601    17    capitan    11    

Аналоги номенклатуры для УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Расширение

Рабочее место Оптовая торговля Розничная торговля Управление торговлей Оптовая торговля Розничная торговля v8 Розница ERP2 УТ11 КА2 Автомобили, автосервисы Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Расширение для работы с аналогами номенклатуры. Отлично подходит для работы с кроссами запчастей и товаров с аналогичными свойствами. Поддерживаемые конфигурации: УТ 11.4, КА 2.4, ERP 2.4, Розница 2.2, Розница 8. Магазин автозапчастей. Лёгкое подключение, без изменения конфигурации.

1 стартмани

30.08.2019    22777    33    AleSSandre    26    

Работа с релизами 1С и договорами ИТС

WEB БСП (Библиотека стандартных подсистем) v8 1cv8.cf Абонемент ($m)

Работа с релизами 1С и партнерским кабинетом.

2 стартмани

15.08.2019    16030    51    RocKeR_13    34    

Правильные аналоги номенклатуры (кроссы запчастей) для 1С / Управляемые формы Промо

Обработка справочников Оптовая торговля Учет ТМЦ Оптовая торговля Учет ТМЦ v8 v8::УФ 1cv8.cf УУ Абонемент ($m)

По опыту работы с запчастями много раз сталкивался с проблемой организации кроссов в разных 1С - от записи артикулов через запятую в текстовом поле до хранения кроссов в документах. Предлагаю одну из простейших и функциональных на мой взгляд схем "одноуровневого" хранения кроссов.

5 стартмани

29.07.2015    38246    3    taurus__    22    

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019)

Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ v8 v8::Mobile БУ УУ Абонемент ($m)

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    48886    259    informa1555    234    

Выгрузка изображений из справочника на диск

Учет ТМЦ Универсальные обработки Учет ТМЦ v8 УТ11 Оптовая торговля, дистрибуция, логистика Россия Абонемент ($m)

Обработка позволяет записать изображения из справочка Номенклатура на диск в указанное место.

1 стартмани

30.11.2018    19594    8    wrooom    8    

[Расширение] Контроль отрицательных остатков по регистру бухгалтерии при проведении Промо

Универсальные функции Инструментарий разработчика Учет ТМЦ Учет ТМЦ v8 1cv8.cf Россия БУ Абонемент ($m)

Расширение позволяет без изменений конфигурации проверять остатки по регистру бухгалтерии при проведении каждого документа и запрещает проведение при появлении отрицательных остатков после проведения.

1 стартмани

17.08.2015    49047    167    ekaruk    32    

Проверка VAT номеров

WEB v8 1cv8.cf Абонемент ($m)

Обработка для вызова сервиса проверка VAT номера.

1 стартмани

26.11.2018    14176    3    wtlz    1    

Универсальный инструмент для переноса данных через табличный документ (УФ)

Обработка документов Универсальные обработки Обработка справочников v8 v8::УФ 1cv8.cf Абонемент ($m)

Для опытных пользователей, разработчиков, администраторов, консультантов

5 стартмани

15.10.2018    37142    139    json    42    

Работа с публикациями "Инфостарт"

Практика программирования О сообществе WEB v8 УУ Абонемент ($m)

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    23488    13    RocKeR_13    16    

Менеджер загрузки данных из весов с печатью этикеток Промо

Внешние источники данных Весы Учет ТМЦ Учет ТМЦ v8 УТ10 УПП1 Абонемент ($m)

Программное обеспечение "Менеджер загрузки данных из весов с печатью этикеток" предназначено для автоматического получения данных по сети Ethernet из весов МАССА-К моделей ВПМ и ТВ_Р3 (модификация MF) в режиме On-Line.

1 стартмани

20.12.2011    24225    81    hrip    10    

Пример использования REST API Яндекс Диска

WEB v8 1cv8.cf Абонемент ($m)

Пример использования REST API Яндекс Диска: чтение диска, добавление каталога, загрузка файла, скачивание файлов или каталогов, удаление файлов или каталогов.

1 стартмани

26.06.2018    27900    43    MKFreeUser    15    

Обмен файловыми базами данных через Yandex диск

WEB v8 Россия Абонемент ($m)

Выполнение операций обмена с Yandex диском для файловых БД, по протоколу WebDav, в автоматическом или ручном режимах.

1 стартмани

11.06.2018    18471    7    slimper    1    

Конфигурация для просмотра публичных телеграм каналов

WEB v8 Абонемент ($m)

Просмотр и каталогизация в более удобном виде публичных телеграм каналов, групп и чатов.

1 стартмани

02.06.2018    19324    11    DO_WHILE_LOOP    7    

Автоматическая рассылка прайс-листов Промо

Ценообразование, прайсы Email Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 УТ10 Абонемент ($m)

Устали от утомительной рассылки прайс-листов своим клиентам? Тогда эта обработка как раз для вас, она сделает полностью все сама! Сформирует прайс с нужными настройками и отправит его по электронной почте, как, куда и когда надо.

1 стартмани

24.03.2014    41595    14    skyadmin    20    

Автоматическое заполнение графиков в ЗУП 3.1

Зарплата Учет рабочего времени Обработка справочников Зарплата Учет рабочего времени v8 v8::СПР ЗУП3.x Россия БУ Абонемент ($m)

Данная разработка будет актуальна для организаций с большим количеством графиков (несколько десятков/сотен).

1 стартмани

05.05.2018    26015    18    notserioussam    2    

Добавление возможности в конфигурации ЗУП 3.1 работать с фотографиями сотрудников (Зарплата и Управление Персоналом, редакция 3.1)

Обработка справочников Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП3.x БУ Абонемент ($m)

Добавление возможности в ЗУП 3.1 работать с фотографиями сотрудников (физических лиц). Расширение тестировалось на релизе ЗУП 3.1.5.129.

1 стартмани

09.04.2018    32684    77    charivnick    4    

Внешняя компонента для работы по Web-socket протоколу x32 x64

Разработка внешних компонент WEB v8 Абонемент ($m)

Кто когда-нибудь сталкивался с обменом данными по Web-Socket (wss) протоколу из 1С, тому известно, что в платформе отсутствуют данные механизмы (не путать с HTTP запросами и WebServices). Предлагается использовать внешнюю компоненту, написанную по технологии NativeAPI, для подключения и обмена с серверами из 1С-Предприятия, работающими по протоколу Web-Socket.

1 стартмани

30.03.2018    29291    36    Ditron    86    

Построение маршрута доставки с расчётом расстояния для любой базы УФ

Универсальные обработки WEB Оптовая торговля Оптовая торговля v8 v8::УФ 1cv8.cf Абонемент ($m)

Графическое изображение маршрутного листа по картам гугл. Работает на любой конфигурации с управляемыми формами. Использует новую версию api google-карт от 13.02.2018 года под IE11.

10 стартмани

24.02.2018    37852    45    KorotkovRV    16    

Давно обещанная автовесовая 8.Х

Производство Учет ТМЦ Учет ТМЦ v8 Россия УУ Абонемент ($m)

Финальная версия автовесовой без оператора.

10 стартмани

02.01.2018    21940    7    Арчибальд    1    

Сервер push сообщений “Push0k“ 18.05

WEB v8 1cv8.cf Абонемент ($m)

Аналог других “мессенджеров“. Позволяет практически все то же самое, что и другие решения. За исключением смайлов, эмодзи, голосовой и видео связи. Основное отличие от других решений, открыта и доступна для изменения серверная и клиентская часть месенджера. Общедоступной серверной части нет, за серверную часть отвечаете вы сами.

1 стартмани

19.12.2017    19800    12    PloAl    20    

Подсистема Вики - интеграция 1С и сайта под управлением MediaWiki

WEB v8 Абонемент ($m)

Редактирование статей сайта Mediawiki из 1С. Формирование функционального описания конфигурации на сайте Вики.

1 стартмани

19.09.2017    30310    35    shmalevoz    20    

Android беспроводной Bluetooth сканер 1D/2D штрихкода и терминал сбора данных для 1С

Сканер штрих-кода Оптовая торговля Розничная торговля Оптовая торговля Розничная торговля v8 1cv8.cf УУ Абонемент ($m)

Бесплатное приложение, превращающее Android-смартфон в беспроводной 1D/2D Bluetooth сканер и терминал сбора данных для 1С и прочих POS систем. Не требует драйверов и доработки конфигураций.

1 стартмани

12.09.2017    44358    25    kuld    45    

Работа с картой. Кадастровый учет (Росреестр). Тематические карты

WEB Рабочее место v8 v8::УФ 1cv8.cf Абонемент ($m)

Внешняя обработка для работы с картами в 1С. Получения изображения с публичной кадастровой карты России, построения тематических карт

5 стартмани

31.08.2017    20227    7    vipchep    0    

Список заказов поставщикам (новая форма) + два ноу-хау для разработчиков

Рабочее место Дебиторская и кредиторская задолженность Оптовая торговля Дебиторская и кредиторская задолженность Оптовая торговля v8 v8::ОУ КА1 УТ10 УУ Абонемент ($m)

Представлена внешняя обработка - "Список заказов поставщикам (новая форма)". Удобство заключается в том, что в одном окне списка отображается структура всех связанных документов с указанием контрагента (заказ поставщику - поступление товаров - заказ покупателя - реализация товаров - оплата товара покупателем). В этом же окне отображается список товаров с заказанным количеством и ценами. Имеется возможность видеть статусы заказов по цветам (исполнен, выполняется, черновик). Форму легко встроить в типовую конфигурацию.

4 стартмани

31.08.2017    23610    15    Rustig    18    

Загрузка дополнительных реквизитов и сведений справочника Номенклатура из Excel и таблиц УТ 11, ERP 2

Обработка справочников Загрузка и выгрузка в Excel Учет ТМЦ Учет ТМЦ v8 v8::ОУ ERP2 УТ11 Россия УУ Абонемент ($m)

Внешняя обработка "Загрузка дополнительных реквизитов и сведений справочника Номенклатура"

1 стартмани

07.08.2017    44273    286    Windyhead    42    

54-ФЗ: Онлайн-кассы для 1С 8.1 УТ 10.2. Поддержка Native драйверов Атол

Кассовые операции Оптовая торговля Розничная торговля ККМ Кассовые операции Оптовая торговля Розничная торговля v8 v8::ОУ УТ10 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m)

Доработан и адаптирован функционал работы ККТ по 54_ФЗ на УТ 10.2 платформы 8.1. Поддержка драйверов Атол версии 9 (native) и эмулятора ККТ. Код полностью открыт и внесены комментарии для самостоятельной доработки. Протестировано на Атол 11Ф. Распространяется как есть.

10 стартмани

18.04.2017    56647    127    Atom74    69    

Печать чеков для ККМ АТОЛ и ШТРИХ на основании текстового файла, где содержится описание товаров, цен, НДС (все требования 54-ФЗ, поддержка изменений от 01/07/19). Для 1С (7.7 и 8 УФ, обычных форм) есть готовые обработки

ККМ Фискальный регистратор Кассовые операции Оптовая торговля Розничная торговля Кассовые операции Оптовая торговля Розничная торговля v7.7 v8 v8::УФ 1cv8.cf 1cv7.md Россия Абонемент ($m)

Это программа печати чеков, которая читает обычный текстовый файл, где перечислено, что надо распечатать на ФР - описание содержимого чека. Такой механизм позволяет использовать комплект для WEB сайтов, для не типовых или сильно измененных 1с7 или 1с8. Для любых программ которые умеют работать с текстовыми файлами (будь то CLIPPER,FOXPRO,JAVA, WSH, VBS итд). Внутри комплекта лежат готовые внешние печатные формы для печати из документов Реализация товаров и услуг 1с8 УТ10, БП2, БП2Базовая, БП2Корп, УТ11, БП3, БП3Базовая, БП3Корп, Для 1с:ТиС 7.7 Реализация ТМЦ, Бух4.5, Бух1.3 и Печать из ПКО Подключать ФР к 1С не надо! Не надо открывать смену. Подходит для любой конфигурации, для любого документа. Более 300 внедрений на ккм Штрих-Мини-ФР-К, Штрих ОнЛайн Атол 11Ф, 55Ф, 30. Возможна пробитие оплаты наличным или VISA  (Электронные деньги). Поддерживает передачу в ОФД имени кассира, телефон или email покупателя. Для каждого чека можно поменять ОСН (ЕНВД, Доходы-расходы итд). Возможна печать чека с выровненными колонками, Наименование,Количество Цена, Сумма, в этом случае фискализация будет одной строкой с общей суммой. Можно пробить не фискальный чек. (чек будет, но в налоговую не уйдет). Добавлена расшифровка длинных наименований, что актуально для Штрих (программа сама переносит длинные наименования на след строку). Есть внесение и выплата денег. 29.06.17 добавлено пробитие 2 видов оплат в одном чеке.

10 стартмани

11.04.2017    75374    222    ah7777777    575    

Загрузка номенклатуры по штрихкоду: Управление Торговлей 11.3; Розница 2.2; Розница для Казахстана 2.2

Обработка справочников Оптовая торговля Розничная торговля Ценообразование, анализ цен Ценообразование, прайсы Оптовая торговля Розничная торговля Ценообразование, анализ цен v8 v8::ОУ v8::УФ Розница УТ11 Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Абонемент ($m)

Розница 2.2, Управление Торговлей 11.3. Создание номенклатуры из интернета с помощью сканера штрихкодов либо терминала сбора данных. Варианты создания, автовыбор наилучшей позиции, источники, цены, загрузка картинки - всё это очень гибко и просто настраивается. Текущие открытые источники: barcode-list.ru(на текущий момент не работает); goodsmatrix.ru; ean13.info(может не работать капча); barcodes.olegon.ru. Автор программы не несёт ответственность за информацию, предоставляемую перечисленными выше открытыми источниками, так же не отвечает за их работоспособность. Данные источники принадлежат не автору программы. Данная программа нужна лишь для автоматизированного поиска информации на них.

10 стартмани

30.03.2017    62198    55    myALKleon    46    

Определение ИНН Сотрудника (service.nalog.ru). ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

Обработка справочников Управление персоналом (HRM) Управление персоналом (HRM) v8 v8::СПР ЗУП2.5 Россия БУ Абонемент ($m)

Внешняя печатная форма для справочника "Сотрудники организаций". ЗУП, редакция 3.1 и 2.5 (Проф и Корп)

1 стартмани

03.02.2017    74280    50    Indgo    34    

Настройка рекламной кампании Яндекс.Директ на 30000 ключевых фраз за 60 минут - теперь это реально!

WEB v8 Реклама, PR и маркетинг Россия Абонемент ($m)

Конфигурация для настройки Яндекс.Директа.

10 стартмани

20.10.2016    30546    51    avalakh    10    

Конструктор-тестер http запросов в 1С

WEB Инструментарий разработчика v8 1cv8.cf Россия Абонемент ($m)

Данная обработка позволяет в несколько кликов конструировать http запросы на языке 1С и просматривать результаты их выполнения.

3 стартмани

19.08.2016    44211    305    hlopik    18    

Легкий интернет-магазин из УТ 11.2

WEB Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля Управление взаимоотношениями с клиентами (СRM) Оптовая торговля Розничная торговля v8 УТ10 УУ Абонемент ($m)

Обработка создания интернет-магазина из УТ 11. Создается единственный файл html, который содержит все выгруженные товары. Клиент составляет и отправляет заказ вам на e-mail прямо из браузера, не прибегая к использованию стороннего ПО.

11.08.2016    33092    0    hlopik    36    

Подсистема обмена данными с порталом ИМНС по электронным счетам-фактурам (автоматический обмен)

Внешние источники данных WEB Инструментарий разработчика v8 1cv8.cf Беларусь БУ НДС Абонемент ($m)

Подсистема включает документы и обработки для автоматического обмена данными с порталом ИМНС через web-сервис. Присутствует возможность заполнения данными типовых операций за период, учёта входящих документов, учёта произвольных исходящих документов. Приложены обработки для запуска задания планировщика на автоматический обмен данными.

1 стартмани

28.07.2016    35089    19    c1nil    4    

Проверка заполнения штрихкодов для УТ 11.2/11.3 и Розница 2.2

Оптовая торговля Розничная торговля Рабочее место Анализ учета Оптовая торговля Розничная торговля v8 Розница УТ11 Розничная и сетевая торговля (FMCG) Россия УУ Абонемент ($m)

Новое поступление товаров? Хотите быстро и просто проверить, на все ли товары заданы штрихкоды и быстро? Тогда эта обработка для вас!

1 стартмани

27.07.2016    36077    84    RocKeR_13    37    

Рабочее место менеджера по продажам

Оптовая торговля Рабочее место Оптовая торговля v8 1cv8.cf Украина УУ Абонемент ($m)

Каждый день менеджеры создают кучу документов. Это и заказы покупателей и сопутствующие документы, которые создаются на основании. Менеджеру всегда необходимо иметь под рукой наиболее эффективный инструмент для формирования заявки от покупателя. Таковым я постарался сделать и эту обработку. Обработка "Рабочее место менеджера продаж" позволяет быстро узнать информацию о товарах на складах, цены товара в различных типах цен номенклатуры, узнать какие цены у поставщиков по выбранному товару и так далее. Много месяцев текущая обработка работает на благо сотрудников и приносит действительно большую пользу. Правда, она более внедрена в работу организации, но даже её модифицированная часть для общества должна принести не менее выгоды в работе с товарами и и заказами покупателей. Так что вот она.

5 стартмани

16.07.2016    35369    52    yarsort    9    

Исправление ошибок при закрытии месяца. Управление Торговлей 11.х, ERP 2.x, КА 2.4 для 1С Предприятие 8.3

Закрытие периода Закрытие периода Оптовая торговля Закрытие периода Оптовая торговля v8 v8::ОУ ERP2 УТ11 КА2 Россия УУ Абонемент ($m)

В при работе обработки: Закрытие месяца возникают ошибки расчета себестоимости. Постепенно ошибки накапливаются и при дальнейшей эксплуатации системы количество ошибок лавинообразно растет. Обработка помогает исправить ошибки расчета себестоимости. Полный доступ к коду обработки.

3 стартмани

21.06.2016    46501    110    Ликреонский    28