Функции работы из 1с 8.х с EXCEL (объекная модель)

Публикация № 57401

Разработка - Практика программирования

120
Надоели вопросы по ошибкам при работе с екселем, даю базовые функции, для работы.
Постю, что-бы удобнее было давать ссылку, а не искать каждый раз в конфе.

расмотрена только часть функционала, нету блочного чтения и т.д. (типа для чайников), зато обработаны большенство "грабель"


// функция устанавливает связь с EXCEL
// в качестве параметра требуется имя открываемого файла
// в случае удачи возвращает соответствие из обьектов ОЛЕ, в случае не удачи - неопределено
Функция   EXCEL_УстановитьСвязь (ИмяФайла)Экспорт
	
	Результат = Неопределено;
	#Если Клиент Тогда
		Состояние("Идет установка связи, ждите.....");
	#КонецЕсли
	
	Попытка
		Результат = Новый Соответствие();
		
		BaseOLE = Новый COMОбъект("Excel.Application");
		Результат.Вставить("EXCEL", BaseOLE);
		
		ExcelФайл = BaseOLE.WorkBooks.Open (ИмяФайла);
		Результат.Вставить("ExcelФайл", ExcelФайл);
		                		
		МассивЛистов = Новый Массив();
		КоличествоЛистов = ExcelФайл.Sheets.Count;
		Для е = 1 по КоличествоЛистов Цикл
			МассивЛистов.Добавить(ExcelФайл.Sheets(е));			
		КонецЦикла;
		
		Результат.Вставить("Листы", МассивЛистов);

	Исключение
		Результат = Неопределено;
		#Если Клиент Тогда
			Сообщить("Ошибка создания обьекта Microsoft Excel" + ОписаниеОшибки());
		#КонецЕсли
	КонецПопытки;
	
	Возврат Результат;
КонецФункции

// функция разрывает связь с 1с 7.7
// в качестве параметра требуеться структура созданая при установке соединения 
Процедура EXCEL_РазорватьСвязь (Соответстие) Экспорт
	Попытка
		Соответстие["EXCEL"].DisplayAlerts = 0;
		Соответстие["ExcelФайл"].Close();
		Соответстие["EXCEL"].DisplayAlerts = 1;
		Соответстие["EXCEL"].Quit(); 
		Соответстие["EXCEL"] = Неопределено;
	Исключение
		#Если Клиент Тогда
			Сообщить(ОписаниеОшибки());
		#КонецЕсли
	КонецПопытки;                  
КонецПроцедуры


// функция получает данные ячейки и возвращаеть структуру соответствий, или неопределено в случае неудачи
//
// В любом случае возвращаем соостветствие "Значение" и "ЭтоФормула", остальное по флагам
//
Функция EXCEL_ПолучитьЗначениеЯчейки (ExcelЛист, НомерСтроки, НомерКолонки, ПолучатьТекстФормулы = ложь, ПолучатьОформление = ложь) 
	Результат = Новый Соответствие();
	
	Попытка
		ТекущееЗначениеФормулы = ExcelЛист.Cells(НомерСтроки, НомерКолонки).Formula;
		Если ТекущееЗначениеФормулы <> "" Тогда
			Если Лев(ТекущееЗначениеФормулы, 1) <> "=" Тогда 
				Результат.Вставить("ЭтоФормула", Ложь);
				Результат.Вставить("ЗначениеЯчейки", ExcelЛист.Cells(НомерСтроки, НомерКолонки).value);
			Иначе
				Результат.Вставить("ЭтоФормула", Истина);
				Если Лев(СокрЛП(ExcelЛист.Cells(НомерСтроки, НомерКолонки).text),1) = "#" Тогда 
					Результат.Вставить("ЗначениеЯчейки", Неопределено);
				Иначе
					Результат.Вставить("ЗначениеЯчейки", ExcelЛист.Cells(НомерСтроки, НомерКолонки).value);
				КонецЕсли;

				Если ПолучатьТекстФормулы Тогда  
					Результат.Вставить("ТекстФормулы", СокрЛП(ТекущееЗначениеФормулы));
				КонецЕсли;
			КонецЕсли; 
		Иначе
			Результат.Вставить("ЭтоФормула", Ложь);
			Результат.Вставить("ЗначениеЯчейки", ExcelЛист.Cells(НомерСтроки, НомерКолонки).value);
		КонецЕсли;    
		
		Если ПолучатьОформление Тогда
			Результат.Вставить("ЦветЯчейки", СокрЛП(ExcelЛист.Cells(НомерСтроки, НомерКолонки).Interior.ColorIndex));
			// здесь можно добавить и другие....
		КонецЕсли;
		
	Исключение
		Результат = Неопределено;
	КонецПопытки;
	
	Возврат Результат;
КонецФункции

// функция получает данные ячейки и значение
//
// В любом случае возвращаем соостветствие "Значение" и "ЭтоФормула", остальное по флагам
//
Функция EXCEL_ПолучитьЗначениеЯчейки2 (ExcelЛист, НомерСтроки, НомерКолонки) 
	Результат = EXCEL_ПолучитьЗначениеЯчейки (ExcelЛист, НомерСтроки, НомерКолонки);
	
	Если Результат = Неопределено Тогда
		Возврат Неопределено;
	КонецЕсли;
	
	Возврат Результат["ЗначениеЯчейки"];
КонецФункции


//
// пример использования:
//


// будем подключаться
СоответстиеЗагрузки = EXCEL_УстановитьСвязь (ТекущийФайл.ПолноеИмя);
		
Если СоответстиеЗагрузки = Неопределено тогда
	Возврат;
КонецЕсли;
		
Для каждого ТекущаяСтраница из СоответстиеЗагрузки["Листы"] Цикл
	Значение_X1Y1 = EXCEL_ПолучитьЗначениеЯчейки2 (ТекущаяСтраница, 1, 1);
КонецЦикла;

// теперь отключаемся...
EXCEL_РазорватьСвязь (СоответстиеЗагрузки);




120

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. maljaev 19.11.08 14:04 Сейчас в теме
Аффтар, добавь еще это к своем примерам (только код с 7.7 на 8.х переведи): http://infostart.ru/blogs/738/
Я правда не уверен, что данная проблема существует в 8.х - заодно и расскажешь как оно там.
12. Pro-tone 130 12.12.13 16:40 Сейчас в теме
Функция   EXCEL_УстановитьСвязь (ИмяФайла)Экспорт
	
	Результат = Неопределено;
	#Если Клиент Тогда
		Состояние("Идет установка связи, ждите.....");
	#КонецЕсли
	
	Попытка
		Результат = Новый Соответствие();
		
		BaseOLE = Новый COMОбъект("Excel.Application");
		Результат.Вставить("EXCEL", BaseOLE);
		
		ExcelФайл = BaseOLE.WorkBooks.Open (ИмяФайла);
		Результат.Вставить("ExcelФайл", ExcelФайл);
		                		
		МассивЛистов = Новый Массив();
		КоличествоЛистов = ExcelФайл.Sheets.Count;
		Для е = 1 по КоличествоЛистов Цикл
			МассивЛистов.Добавить(ExcelФайл.Sheets(е));			Результат.Вставить("КоличествоКолонокЛиста"+Строка(е),ExcelФайл.Sheets.Item(1).UsedRange.Columns.Count());   //Количество колонок           Результат.Вставить("КоличествоСтрокЛиста"+Строка(е),ExcelФайл.Sheets.Item(1).UsedRange.Rows.Count());      //Количество строк   
		КонецЦикла;
				
		Результат.Вставить("Листы", МассивЛистов);

	Исключение
		Результат = Неопределено;
		#Если Клиент Тогда
			Сообщить("Ошибка создания обьекта Microsoft Excel" + ОписаниеОшибки());
		#КонецЕсли
	КонецПопытки;
	
	Возврат Результат;
КонецФункции

Показать
13. Pro-tone 130 12.12.13 16:45 Сейчас в теме
100й пылюс от меня)

Модернизирую твою функцию, замени)
В соответствие довесил подсчет кол-ва колонок и строк на листах
Пример:
СоответстиеЗагрузки["КоличествоКолонокЛиста"+Строка(НомерЛиста)] //покажет кол-во колонок листа
СоответстиеЗагрузки["КоличествоСтрокЛиста"+Строка(НомерЛиста)] //покажет кол-во строк листа

В тег CODE не оформлял, т.к. он отсебятину какую-то вставляет в текст.


Функция EXCEL_УстановитьСвязь (ИмяФайла)Экспорт

Результат = Неопределено;
#Если Клиент Тогда
Состояние("Идет установка связи, ждите.....");
#КонецЕсли

Попытка
Результат = Новый Соответствие();

BaseOLE = Новый COMОбъект("Excel.Application");
Результат.Вставить("EXCEL", BaseOLE);

ExcelФайл = BaseOLE.WorkBooks.Open (ИмяФайла);
Результат.Вставить("ExcelФайл", ExcelФайл);

МассивЛистов = Новый Массив();
КоличествоЛистов = ExcelФайл.Sheets.Count;
Для е = 1 по КоличествоЛистов Цикл
МассивЛистов.Добавить(ExcelФайл.Sheets(е));
Результат.Вставить("КоличествоКолонокЛиста"+Строка(е),ExcelФайл.Sheets.Item(1).UsedRange.Columns.Count()); //Количество колонок
Результат.Вставить("КоличествоСтрокЛиста"+Строка(е),ExcelФайл.Sheets.Item(1).UsedRange.Rows.Count()); //Количество строк

КонецЦикла;

Результат.Вставить("Листы", МассивЛистов);

Исключение
Результат = Неопределено;
#Если Клиент Тогда
Сообщить("Ошибка создания обьекта Microsoft Excel" + ОписаниеОшибки());
#КонецЕсли
КонецПопытки;

Возврат Результат;
КонецФункции
2. vde69 908 19.11.08 14:23 Сейчас в теме
вроде как не должно быть проблеммы,
но я не выложил и 1/10 всего модуля по работе с екселем, просто этот блог должен давать повод задуматься, а не давать готовое решение.

Если-бы я хотел выложить библиотеку, я-бы выложил в "программах" а тут именно блог, можно пообсуждать, и т.д.
3. maljaev 19.11.08 14:35 Сейчас в теме
(2) Попробуй проверь плиз, и правда интересно поддерживает ли 8.х тип "Variant" или все так же как и в 7.7?
4. vde69 908 19.11.08 15:02 Сейчас в теме
(3) 1с8 вариант для сомов не поддерживает, приходиться изголяться, типа:
м = Новый Массив();
м.Добавить("domain");
м2 = Новый COMSafeArray(м, "VT_VARIANT");

но PageSetup.Zoom показывает как тип воолеан, но менять не дало "Произошла исключительная ситуация (Microsoft Office Excel): Нельзя установить свойство Zoom класса PageSetup"
5. maljaev 19.11.08 15:09 Сейчас в теме
(4) Вот про эту ошибку я и говорил. Скриптом - прокатывает!
7. Fuego 438 13.12.08 13:46 Сейчас в теме
(4) тип VARIANT - это STRUCT с вложенным UNION. SafeArray и так хранит элементы как тип VARIANT, а указание "VT_VARIANT" указывает, какой тип будут содержать эти элементы. Для булевских значений вместо "VT_VARIANT" нужно указать "VT_BOOL"... А ещё для всех скажу, что 1С насковзь пропитана OLE/COM. И все её переменные, которые мы описываем в коде, есть ни что иное как VARIANT. Например "Неопределено" - это VARIANT с типом VT_EMPTY, и т.д.
14. ronhard 24.10.14 15:51 Сейчас в теме
(7) Fuego, Исходя из приведенной Вами информации и кода http://infostart.ru/public/57421/ получается можно сделать следующим образом:
Перем Зум;
	Зум = Ложь;
	Эксель = Новый COMОбъект("Excel.Application");
	Книга = Эксель.WorkBooks.Add();
	ПарамСтр = Эксель.ActiveSheet.PageSetup;
	ПарамСтр.Zoom = Зум;


Вроде работает.
6. maljaev 19.11.08 15:11 Сейчас в теме
(4+) Да нифига он не булевый, в нете говорят что вариант он, потому и не прокатывает прямое присвоение. Булен бы прокатил с полпинка.
8. m2d3 19.04.12 08:02 Сейчас в теме
всё в одной кучке, спасибо
9. internetname 08.02.13 13:01 Сейчас в теме
Спасибо большое, пригодилось.
10. yuraos 955 08.02.13 13:05 Сейчас в теме
Плюс за полезный обмен опытом!

Лень великая вешь ... говорят прогрессом движет.

Одним лень читать мануал и лезут с вопросами на форум.
Другим лень на эти вопросы отвечать и они пишут статьи, чтоб "отстали".

Самое интересное все из-за лени не остаются без дела.
:)
Вот такой диалектика получается.
11. yuraos 955 08.02.13 13:20 Сейчас в теме
PS:
Я тоже от лени задурился и собрал во едино
функционал для работы с COM в одной подсистеме.
Там можно работать с Excel примерно так:
УзелXLS = ПланыОбмена.ОбменДаннымиCOM.НайтиПоКоду("Excel").ПолучитьОбъект();
Опции = Новый Структура("Путь",ИмяФайлаXLS);  // если имя не указать, его 1С-ка запросит в диалоге выбора файла
ExcelApp = Null;
WorkBook = Null;
УзелXLS.Connect(ExcelApp,WorkBook,Опции);
//... что-то делаем
УзелXLS.Disconnect(ExcelApp,WorkBook,Опции);


Показать
15. ronhard 24.10.14 15:56 Сейчас в теме
Кстати и
ПарамСтр.Zoom = Ложь;
тоже работает.
Оставьте свое сообщение

См. также

Агрегатные функции СКД, о которых мало кто знает 315

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Пользуетесь ли Вы всеми возможными агрегатными функциями, которые предоставляет система компоновки данных? Если Вы используете только: СУММА, КОЛИЧЕСТВО, МИНИМУМ, МАКСИМУМ, СРЕДНЕЕ, то эта статья для Вас.

05.09.2019    9606    ids79    42       

Отслеживание выполнения фонового задания 133

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Универсальные функции Разработка

Запуск фонового задания из модуля внешней обработки. Отслеживание выполнения задания в виде прогресса, расположенного на форме.

17.08.2019    7970    ids79    14       

Функции СКД: ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив 240

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Подробное описание и использование внутренних функций системы компоновки данных: Вычислить, ВычислитьВыражение, ВычислитьВыражениеСГруппировкойМассив, ВычислитьВыражениеСГруппировкойТаблицаЗначений.

08.08.2019    9978    ids79    22       

СКД - наборы данных и связи между ними, создание собственной иерархии, вложенные отчеты 126

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Набор данных объект. Использование в схеме компоновки нескольких наборов данных. Различные варианты связи наборов: объединение, соединение. Использование иерархии в отчетах на СКД. Создание собственной иерархии, иерархия детальных записей. Использование вложенных схем в отчетах на СКД.

26.07.2019    8982    ids79    6       

СКД - использование расширений языка запросов, секция ХАРАКТЕРИСТИКИ 134

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Инструментарий разработчика Практика программирования Разработка

Автоматическое и не автоматическое заполнение полей компоновки данных. Использование расширений языка запросов для СКД «{…}», секция ВЫБРАТЬ, секция ГДЕ, параметры виртуальных таблиц. Автоматизированное использование дополнительных данных в запросе: секция ХАРАКТЕРИСТИКИ.

17.07.2019    8461    ids79    24       

"Меньше копипаста!", или как Вася универсальную процедуру писал 170

Статья Программист Стажер Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования Разработка

Программист Вася разбирает подход создания универсальных методов на примере программного вывода СКД.

04.07.2019    6129    SeiOkami    48       

Создание отчетов с помощью СКД - основные понятия и элементы 190

Статья Программист Нет файла v8 v8::СКД Бесплатно (free) Практика программирования Математика и алгоритмы

Основные принципы работы СКД. Понятия схемы компоновки и макета компоновки. Описание основных элементов схемы компоновки: наборы данных, поля, вычисляемые поля, ресурсы, параметры.

25.06.2019    17088    ids79    16       

Многопоточное ускорение однопользовательских нагрузок в 1С + Microsoft SQL Server 2017 175

Статья Программист Нет файла v8 v8::Запросы Бесплатно (free) Практика программирования Разработка

Взаимодействие с Microsoft SQL Server нередко вызывает трудности у 1С-ников, а потому интересны любые моменты, связанные с его использованием. О своем опыте работы с новым SQL Server 2017 участникам конференции Infostart-2018 рассказал директор ООО «Аналитика софт» Дмитрий Дудин.

11.06.2019    11367    dmurk    134       

Регистры накопления. Структура хранения в базе данных 174

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Структура хранения регистров накопления в базе данных для платформы 1С:Предприятие 8.x. Первая часть в серии публикаций.

16.05.2019    17035    YPermitin    27       

Выполнение внешней обработки в фоновом задании 147

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Подробное описание подхода к созданию длительной операции на основе внешней обработки. Реализация протестирована на 1С 8.3.12.1714 (x64).

11.05.2019    9645    Eret1k    22       

Выгрузка документа по условию 5

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Разработка

Что делать, если документы нужно выгружать не все подряд, а по какому-то фильтру: статусу, дате, набору условий... А что если он соответствовал этим условиям, а потом перестал? А если потом опять начал? Такие ситуации заставили попотеть не одного программиста.

25.04.2019    4713    m-rv    2       

Преобразование EXCEL в таблицу значений без COM и других извращений 208

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Получение таблицы значений из excel в 1С v8, без COM, внешних источников данных и т.д. EXCELВТаблицуЗначений() - За 10 строчек кода! Реализация протестирована на 1С 8.3.12.1714 (x64).

18.04.2019    11973    9    Eret1k    43       

Как прикрутить ГУИД к регистру сведений 23

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8 Разработка

... и немного теории обмена данными. В частности, разберем боль всех, кто пишет небанальные обмены данными: как набору записей регистра сведений назначить гуид и далее использовать его в обмене для идентификации этого набора.

16.04.2019    7225    m-rv    16       

О расширениях замолвите слово... 192

Статья Программист Стажер Нет файла v8 Бесплатно (free) Практика программирования Разработка

О чём стоит задуматься при принятии решения о создании расширения конфигурации…

07.04.2019    16174    ellavs    122       

Git-репозитории для 1С-кода (опыт использования при небольших проектах) 200

Статья Программист Стажер Нет файла v8 Windows Бесплатно (free) Практика программирования Разработка

Инструкции по взаимодействию с Git-репозиторием, которые писались для тех наших программистов, которые вообще никогда не работали с Git (руководства в духе "Как получить код из git-репозитория?", "Как отправить код в git-репозиторий")...

28.03.2019    12571    ellavs    83       

Трюки с внешними источниками данных 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования Разработка

Некоторые трюки для преодоления ограничений внешних источников данных.

14.03.2019    12686    YPermitin    52       

Возможности типовых шаблонов ограничения доступа на уровне записей (RLS) 162

Статья Программист Нет файла v8 v8::Права Бесплатно (free) Практика программирования БСП (Библиотека стандартных подсистем) Роли и права

Краткий обзор применения типовых шаблонов ограничения доступа на уровне записей в конфигурациях, созданных на базе БСП: #ПоЗначениям, #ПоНаборамЗначений, #ПоЗначениямРасширенный, #ПоЗначениямИНаборамРасширенный

03.02.2019    15235    ids79    9       

Копирование числовых ячеек из 1С в Excel 26

Статья Системный администратор Программист Нет файла v8 1cv8.cf Windows Бесплатно (free) Загрузка и выгрузка в Excel Администрирование данных 1С

Решение проблемы, когда значения скопированных ячеек из табличных документов 1С в Excel воспринимаются последним как текст, т.е. без дополнительного форматирования значений невозможно применить арифметические операции. Поводом для публикации послужило понимание того, что целое предприятие с более сотней активных пользователей уже на протяжении года мучилось с такой, казалось бы на первый взгляд, тривиальной проблемой. Варианты решения, предложенные специалистами helpdesk, обслуживающими данное предприятие, а так же многочисленные обсуждения на форумах, только подтвердили убеждение в необходимости описания способа, который позволил мне качественно и быстро справиться с ситуацией.

15.01.2019    10327    itriot11    21       

Запись одной книги Excel на нескольких листах средствами 1С (без внешних компонент) 139

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

Пользователи часто просят сохранить им стопиццот отчетов в один файл Excel, чтобы отчеты были в одном файле. Ну или клиент хочет счет, накладную и счет-фактуру получить в одном документе. 1С умеет это делать без всяких там COM-объектов. Давайте разберемся, куда нажимать и что крутить.

14.01.2019    11586    starik-2005    23       

EnterpriseData – часть 2. Процесс выгрузки данных 127

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Основные этапы выгрузки данных через ED, обработчики событий выгрузки, правила обработки данных, правила конвертации объектов, конвертация свойств первого и второго этапов, процедуры БСП, используемые при выгрузке данных, структура «КомпонентыОбмена».

26.12.2018    12559    ids79    27       

Новый подход к обмену данными EnterpriseData 202

Статья Программист Нет файла v8 v8::УФ Россия Бесплатно (free) Практика программирования Обмен через XML

Хочу предложить Вашему вниманию цикл статей, посвященных обмену данными через универсальный формат (EnterpriseData или ED).

14.12.2018    21154    ids79    72       

Универсальные функции ЗУП 3.1 / ЗКГУ 3.1, которые помогут в разработке 462

Статья Программист Нет файла v8 v8::СПР ЗКГУ3.0 ЗУП3.x БУ Зарплата Управление персоналом (HRM) Бесплатно (free) Универсальные функции

В статье размещен список стандартных процедур и функций с примерами, которые могут помочь при разработке (доработке) конфигураций Зарплата и управление персоналом ред. 3.1 и Зарплата и кадры государственного учреждения 3.1. Иногда бывает довольно сложно правильно получить данные или долго, поэтому лучшим вариантом будет использование стандартных процедур. Буду очень признателен, если Вы поделитесь своим опытом и предложите свои варианты стандартных процедур которые помогают в работе. Или предложите, как дополнить имеющиеся процедуры.

14.11.2018    31339    GeterX    93       

Программное заполнение пользовательских параметров и отборов СКД 135

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Публикация представляет из себя краткие примеры того, как можно заполнять параметры СКД программно так, чтобы все параметры и отборы были доступны в быстрых настройках и в обычных (типовых) настройках параметров и отборов СКД.

13.11.2018    19323    Unk92    18       

Автоматические и управляемые блокировки применительно к типовым конфигурациям 1С 125

Статья Программист Нет файла v8 v8::blocking 1cv8.cf Бесплатно (free) Математика и алгоритмы Практика программирования

Основные принципы работы с режимами автоматических и управляемых блокировок в 1С Предприятие 8. Теория и применение в типовых конфигурациях: БП, УТ, ЕРП

10.11.2018    20671    ids79    40       

Вспомогательные инструкции в коде 1С 104

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Помогаем редактору кода 1С помогать нам писать и анализировать код.

15.10.2018    20320    tormozit    100       

Произвольный код в фоновом режиме 164

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Задача: реализовать выполнение произвольного кода в фоновом режиме без изменения конфигурации, т.е. во внешней обработке.

03.09.2018    14449    nikita0832    41       

Основные понятия и механизмы оптимизации клиент-серверного взаимодействия в 1C 144

Статья Программист Нет файла v8 Россия Бесплатно (free) Математика и алгоритмы Практика программирования

У многих начинающих 1С программистов часто возникают вопросы про клиент-серверное взаимодействие в 1С и чтобы разобраться в непростых механизмах платформы, необходимо понять, что же такое контекст, для чего предназначены директивы компиляции, что представляют собой контекстные/внеконтекстные вызовы и как наиболее оптимально описывать прикладные задачи в модулях управляемых форм.

23.08.2018    21016    Rain88    42       

Из Excel в 1С запросом 33

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Загрузка и выгрузка в Excel

... ну, конечно, не прям так типовым языком запросов, а расширенным языком запросов. Речь пойдет о том, как "залить" данные в таблицы 1С и не пилить при этом бесконечного количества наколеночных обработок.

14.08.2018    13461    m-rv    5       

Повышаем эффективность разработки правил обмена 122

Статья Программист Нет файла v8 КД ОС Бесплатно (free) Практика программирования Перенос данных из 1C8 в 1C8

Как повысить скорость и качество разработки правил обмена? Как вести групповую разработку правил обмена? Как облегчить сопровождение правил обмена после передачи в эксплуатацию? Об этом и многом другом вы можете узнать из этой статьи.

25.06.2018    19171    olegtymko    43       

Введение в механизм представлений в ЗУП ред. 3 152

Статья Программист Нет файла v8 v8::СПР ЗУП3.x Бесплатно (free) Практика программирования

В нашей организации на первом же телефонном собеседовании на должность разработчика по ЗУП ред. 3 вас обязательно спросят о том, что такое "Представления".

04.06.2018    24184    xrrg    82       

Как сделать запрос на изменение данных 75

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

В статье приведены особенности внутренней архитектуры и примеры работы с расширением языка запросов 1С.

01.06.2018    21071    m-rv    21       

Строим графы средствами 1С (без GraphViz) 42

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Множество статей на Инфостарте описывают, как работать с компонентой GraphViz, чтобы построить ориентированный граф. Но практически нет материалов, как работать с такими графами средствами 1С. Сегодня я расскажу, как красиво строить графы с минимальным пересечением. Нам этот метод пригодился для отрисовки алгоритмов в БИТ.Финансе, т.к. типовой механизм не устраивал. Еще это может быть полезно для визуализации различных зависимостей: расчета себестоимости, графы аффилированности компаний и т.д. Надеюсь, эта статья поможет сделать мир 1С красивее и гармоничней:) Итак, поехали...

23.05.2018    16836    slozhenikin_com    19       

Распределение расходов пропорционально продажам 9

Статья Программист Пользователь Нет файла v8 v8::ОУ УТ10 УУ Финансовый учет и бюджетирование (FRP) Учет доходов и расходов Бесплатно (free) Практика программирования

Финансовая модель. Распределение административных расходов по подразделениям пропорционально продажам за месяц. Дополнительные реквизиты против бизнес-процессов!

13.05.2018    11242    Rustig    9       

Просмотр временных таблиц запроса в отладчике без изменения кода 126

Статья Программист Нет файла v8 v8::Запросы 1cv8.cf Бесплатно (free) Практика программирования

Данный способ можно использовать для просмотра содержимого временных таблиц запросов (менеджеров временных таблиц) без внесения изменений в код.

24.04.2018    24108    avfed@rambler.ru    19       

Минимализмы 3 350

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Универсальные функции

Очередная серия "минимализмов" [http://infostart.ru/public/306536/, https://infostart.ru/public/460935/]. Также, как и в предыдущих статьях, здесь приведена подборка коротких оригинальных авторских решений некоторых задач. Ранее эти решения были разбросаны по моим комментариям к чужим публикациям.

19.02.2018    35365    ildarovich    44       

Этюды по программированию. Взаимодействие с Microsoft Word 108

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Часто приходится заниматься созданием сложных документов Word с таблицами, вложенными фрагментами, хитрым оформлением и прочими радостями жизни. Это - попытка как-то структурировать полученный опыт, чтобы не приходилось перерывать ворох старых обработок в поисках крупиц истины. Надеюсь, эта статья будет полезна и Вам.

11.12.2017    25726    milkers    23       

Метод формирования движений в типовых регистрах нетиповыми регистраторами 31

Статья Программист Нет файла v8 1cv8.cf Бесплатно (free) Практика программирования

Вариант решения задач с проведением по типовым регистрам нетиповыми регистраторами. Зачем - чтобы при сравнении конфигурации не обращать внимание на свойства регистров и исключить вероятность допущения горькой оплошности при обновлении информационных баз, заменив типы регистраторов основной конфигурации типами конфигурации поставщика. Для программных продуктов, имеющих в своем составе метаданных документ "Корректировка регистров"("Корректировка записей регистров").

05.12.2017    21219    itriot11    34       

1С: Конвертация данных 3. Инструкции и примеры. EnterpriseData (универсальный формат обмена) 718

Статья Программист Нет файла v8 КД Бесплатно (free) Перенос данных из 1C8 в 1C8 Практика программирования Обмен через XML

Что такое КД3? Как начать использовать? Полезные дополнения к документации. Что нужно исправить в типовых обработках и конфигурации. Как изменить правила обмена не снимая конфигурацию с поддержки. Как отлаживать правила обмена?

19.11.2017    136889    MaxS    251       

Заполнение данных по ИНН контрагента с помощью альтернативного сервиса огрн.онлайн 131

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Код для заполнения данных по ИНН контрагента из ЕГРЮЛ с сайта огрн.онлайн.

01.11.2017    22553    slava_1c    49       

Программные перечисления, ч.2: приемы кэширования при разработке 66

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования

Все знают, что такое кэш, и зачем он нужен. Но в 1С разработчик обычно использует кэширование только на уровне конфигурации, а в какой-нибудь обработке скорее ломает голову над запросом - как получить все данные за один заход... Хочется рассказать о том, как можно добиться хороших результатов с стратегией "разделяй и властвуй".

30.10.2017    20948    unichkin    17       

Разбираемся с настройками компоновки данных 159

Статья Программист Нет файла v8 v8::СКД 1cv8.cf Бесплатно (free) Практика программирования

Краткая шпаргалка по программной работе с настройками СКД

29.10.2017    23900    json    9       

Работа с Excel 287

Статья Программист Нет файла v8 Бесплатно (free) Практика программирования Загрузка и выгрузка в Excel

Собрал различные полезности для работы с Excel из 1С. Иногда приходится форматировать документ Excel программно из 1С. Так вот, чтобы не искать постоянно на просторах интернета как сделать левое выравнивание в ячейке Excel из 1С и т.п. решил опубликовать это...

23.10.2017    24422    arakelyan    39       

Добавление команд печати в конфигурациях на БСП 2.4.3 (в частности, в самописных документах в Бухгалтерии 3.0 после релиза 3.0.52.35) 143

Статья Программист Нет файла v8 v8::БУ БП3.0 Россия Бесплатно (free) Печатные формы документов Практика программирования БСП (Библиотека стандартных подсистем)

В статье https://infostart.ru/public/237013/ пользователя nick max рассматривался список действий для подключения команд печати в Бухгалтерии 3.0, работающей на БСП 2.3.6. В новом релизе Бухгалтерии 3.0.52.35 от 15.09.2017г. стала использоваться БСП 2.4.3, из-за чего произошли изменения в процедурах общих модулей, связанных с механизмом печати, и в процедурах их вызова в формах документов и в формах списков. Рассмотрим их.

18.09.2017    46486    bugtester    43