Консоль выполнения произвольных текстов модуля

Публикация № 61601

Администрирование - Сервисные утилиты

консоль модуль

241
Обработка "Консоль выполнения произвольных текстов модуля" предназначена для разработки шаблонов, отладки, визуального конструирования текстов модулей системы 1С:Предприятие.

При администрировании информационной базы программисты вынуждены тратить время на создание обработок, которые будут запущены только один раз. А уже через день после использования найти их бывает сложно - часто ли мы задумываемся, прежде чем дать осмысленное название заведомо временному файлу.

Эта обработка хранит дерево текстов модулей, помогает их систематизировать, модифицировать и использовать по мере необходимости.

Для того, чтобы автоматизировать наиболее трудоемкие действия программиста, она включает вспомогательные инструменты:

  1. Визуальные конструкторы:
    1. Конструктор запроса (системный)
    2. Конструктор таблицы значений
    3. Конструктор объекта ссылочного типа универсальный
    4. Конструктор документа
    5. Конструктор справочника
    6. Конструктор набора записей регистров (любых)
  2. Дерево метаданных текущей конфигурации, механизм drag'n'drop
  3. Возможность произвольной обработки данных с использованием встроенных обработок.

Вы все еще создаете разовые обработки (для обычного приложения)? Попробуйте использовать консоль модулей - уверен, Вам понравится.

241

Скачать файлы

Наименование Файл Версия Размер
Консоль исполнения произвольных текстов модулей (8.2)
.epf 191,42Kb
02.09.13
900
.epf 191,42Kb 900 Скачать
Консоль исполнения произвольных текстов модулей (8.1)
.epf 196,23Kb
02.09.13
1070
.epf 196,23Kb 1070 Скачать

См. также

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
1. alexer 1005 26.11.09 09:41 Сейчас в теме
наверно так встали звезды, что всех на подобные разработки потянуло :)
2. tomvlad 3751 26.11.09 09:48 Сейчас в теме
(1) Ага, посмотрел на это http://www.infostart.ru/public/61535/ и подумал, что моя наверное не хуже, полгода уже активно используется, и, возможно многим пригодится. Аналогичных конструкторов, например, ни у кого не видел.
7. WiseSnake 1783 26.11.09 11:08 Сейчас в теме
(2) Да 100 лет уже тут лежит :)
Ну Ваши наверно подобротей будут сделаны, хотя я к своей привык, юзаю активно уже больше года...
8. tomvlad 3751 26.11.09 11:13 Сейчас в теме
(7) Цели у разработок разные. Тут - универсальный комбайн, здесь - простота использования и помощь в написании за счет применения конструкторов. Ни о каких отчетах в принципе речи не идет, если не формировать их программно из встроенного языка, но это наверное было бы уже извращение.
3. alexer 1005 26.11.09 09:51 Сейчас в теме
может в скором будущем воще от конфигуратора откажемся :D
4. tomvlad 3751 26.11.09 10:00 Сейчас в теме
(3) А и правда, зачем для написания какой-нибудь ерундовой обработки лезть в конфигуратор?
5. Арчибальд 2709 26.11.09 10:16 Сейчас в теме
(0) Ага, с одноразовыми обработками - беда :(

Мне для обучения/экспериментирования - самое то 8-)
6. tomvlad 3751 26.11.09 10:22 Сейчас в теме
(5) Буду рад, если пригодится. Файл с примером лежит отдельно (если нужно).
9. NDM 26.11.09 12:08 Сейчас в теме
;) Нужно переименовать функции и процедуры которые уже есть в типовых, иначе:

ПриОткрытии:
{ВнешняяОбработка.КонсольТекстовМодулей(527,9)}: Процедура или функция с указанным именем уже определена (ПолучитьОписаниеТиповСтроки)
Функция <<?>>ПолучитьОписаниеТиповСтроки(ДлинаСтроки) Экспорт
{ВнешняяОбработка.КонсольТекстовМодулей(545,9)}: Процедура или функция с указанным именем уже определена (ПолучитьОписаниеТиповЧисла)
Функция <<?>>ПолучитьОписаниеТиповЧисла(Разрядность,РазрядностьДробнойЧасти=0) Экспорт
{ВнешняяОбработка.КонсольТекстовМодулей(559,9)}: Процедура или функция с указанным именем уже определена (ПолучитьОписаниеТиповДаты)
Функция <<?>>ПолучитьОписаниеТиповДаты(ЧастиДаты) Экспорт
10. tomvlad 3751 26.11.09 12:16 Сейчас в теме
(9) Странно, нигде в актуальных типовых ЗУП,БП,КА,УПП,РТ не нашел такую функцию глобальных модулей. Что за конфигурация, релиз?
46. NDM 27.11.09 14:55 Сейчас в теме
(9) конфа на базе УПП для Украины (старая)
11. Mortal 80 26.11.09 12:57 Сейчас в теме
Скачал. "+". Пока не смотрел (не успел), но, имхо, будет удобно для тренировок: сравнивать модули обработок и т.д. Спасибо.
12. tomvlad 3751 26.11.09 13:21 Сейчас в теме
Всем пардон, вкралась досадная ошибка, приводившая к невозможности сформировать новый файл шаблонов. Ошибку исправил, обновил.
13. marsohod 121 26.11.09 13:23 Сейчас в теме
После перепроведения документов на закладке "Результат выполнения" она присоединила снизу еще кусок формы с "Доступные обработки" и "Выбранные обработки". Выбираю "Отменить проведение документов" и получаю предупреждение "Данная обработка недоступна для типа <Документы>".
Что бы это значило? :o
14. tomvlad 3751 26.11.09 14:01 Сейчас в теме
15. tomvlad 3751 26.11.09 14:02 Сейчас в теме
Может кто-то выскажется о работе конструкторов?
16. e.kogan 1848 26.11.09 14:52 Сейчас в теме
Просьба всё-таки переформулировать пункты "Конструктор документа" и "Конструктор справочника" :?: :?: :?: Я-то уж разогналась, что кто-то нашёл, как из предприятия конфигурацию на лету менять... :D
17. tomvlad 3751 26.11.09 14:56 Сейчас в теме
(16) И на что переформулировать? "Конструктор формирования кода создания нового документа / поиска существующего"? Пусть уж лучше так остается.
20. e.kogan 1848 26.11.09 17:34 Сейчас в теме
(17) Ну хоть вставить слово "экземпляра" 8-)
18. Ivon 640 26.11.09 15:11 Сейчас в теме
Поставил плюс, но есть некоторые НО:
1) иногда при составлении кода обработка впихивает в код процедуры и функции, которых нет в конфигурации, такие как ПолучитьОписаниеТиповСтроки и т.п.;
2) вот если бы еще реализовать точки останова - тогда было бы самое оно. Просто написать код и посмотреть, как он выполняется - конечно хорошо, но когда результат не тот, который ожидался - требуется отладка промежуточных итогов. А их нет.
19. D!m 26.11.09 15:49 Сейчас в теме
21. direktorSan 258 26.11.09 19:27 Сейчас в теме
Неплохая разработка. Нашел много хороших идей!
Надо будет применить их в своей. ;)
22. den_vladimir 94 26.11.09 19:57 Сейчас в теме
Чета я походу не в теме как из режима предприятия выполнять модули! Буду смотреть! +1!
23. Русский 27.11.09 08:41 Сейчас в теме
24. mini_root 145 27.11.09 10:32 Сейчас в теме
Посмотрел, плюсую

Конфигуратор не заменит - нету отладки, нельзя модифицировать метаданные и пр. Но для мелких вещей пойдет: прототипирование, тестирование.... Кстати, на основе этой идеи можно сделать систему юнит тестов для эски....

Ты там где в коде вызывается "Выполнить" добавь еще набор функций типа assert* (ЭтоИстина, ЭтоРавно, ЭтоНеПусто), если условие не выполняется - выбрасывается исключение.

Пример:

Функция ЭтоИстина(<результат некоего выражения типа boolean>, <название проверки>)
....
КонецФункции

И добавь возможность задавать код, который будет выполняться перед каждым выполнением текста, и после каждого выполнения (только с корректной обработкой исключений и прочее).

И собственно система внешних юнит тестов готова, причем конфигурацию менять не надо - все будет делаться внешними средствами.

Еще можно переработать систему вставки готового кода для типовых случаев в расширяемую макросистему.

25. mini_root 145 27.11.09 10:51 Сейчас в теме
(24) Нашел шаблоны, вопрос с макросистемой снят :)
26. tomvlad 3751 27.11.09 10:52 Сейчас в теме
(25) Шаблоны пока не работают так как нужно, буду дорабатывать.
27. mini_root 145 27.11.09 11:00 Сейчас в теме
(26) Не возражаешь, если я чуть-чуть ее доработаю, в плане использования для тестирования?
28. tomvlad 3751 27.11.09 11:03 Сейчас в теме
(27) Да ради бога, вот если бы еще доработал контекстную подсказку и шаблоны .... А то пока совершенно нет времени ими заниматься.
32. mini_root 145 27.11.09 11:31 Сейчас в теме
(28) http://slil.ru/28260688 чуть-чуть исправленная версия

Добавлены функции-assert'ы (ЭтоИстина, ЭтоРавно). Добавлена возможность задавать код, который будет выполняться перед выполнением основного кода, и после него (может использоваться например, для создания, удаления тестовых записей). Все сохраняется/загружается.
34. mini_root 145 27.11.09 11:51 Сейчас в теме
(32) Чегой-то я не подумал, тут же новая система с метриками и бонусами планируется... В общем, кто скачает исправленную версию со slil.ru - скачайте также оригинальную с этой страницы.
35. mini_root 145 27.11.09 12:00 Сейчас в теме
(28) на выходных может и поковыряю шаблоны, туда бы еще консоль запросов прикрутить какую-нибудь и с учетом шаблонов будет вообще замечательно.
57. artbear 1128 13.02.10 19:50 Сейчас в теме
(35) Что-нибудь получилось с новой версией?
63. mini_root 145 14.02.10 21:23 Сейчас в теме
(57) Не, я щас кроме основной работы занимаюсь время от времени только этим

http://code.google.com/p/one-c-connectors/
29. Трактор 1187 27.11.09 11:07 Сейчас в теме
Прикольно. Практического применения пока не вижу, подумаю.
30. tomvlad 3751 27.11.09 11:18 Сейчас в теме
(29) Пример практического применения:

1. Имелось около сотни различных мелких обработок для различных типовых (и не очень конфигураций). Т.к. конфигурации периодически изменялись, обновлялись обработки также было необходимо держать в актуальном состоянии. Иногда лезь в конфигуратор приходилось из-за изменения вызовов общих модулей или разной прочей ерунды. В результате систематизации имеем несколько файлов модулей для каждой конфигурации для упорядоченного хранения нужных текстов + возможность изменения их на лету.
2. Составление текстов - просто ли вспомнить имя нужного реквизита при составлении кода? А дерево метаданных тут же. :)
3. Просто ли создать документ / справочник? Вспомнить названия реквизитов, табличных частей? Конструктор облегчит Вам жизнь. Функции, вызываемые с помощью конструктора успешно используются более 2-лет в нашей коммерческой разработке "Помощник перехода на использование подсистем расчета заработной платы и кадрового учета в прикладных решениях фирмы «1С» на технологической платформе «1С:Предприятие 8» с конфигураций «Камин:Расчет заработной платы (все версии)»". Весь процесс создания документа (справочника) сводится к созданию структуры полей поиска данного объекта, структуры реквизитов и табличных частей, причем большую часть работы Конструктор документа (Конструктор справочника) сделает за Вас.

P.S. Достаточно?
33. Трактор 1187 27.11.09 11:41 Сейчас в теме
>> Достаточно?
Достаточно.

Тут мне вспоминаются примочки к 7.7. Народ пользовал их и пищал от них. Я как-то обходился штатными средствами. Здесь ситуация похожа.

Конструктор таблицы значений да, полезен. Я всего дважды создавал тз для помещения во временную таблицу, но эти два раза были тоскливыми. Наверное в следующий раз воспользуюсь твоей обработкой.

Обработка прикольная. Но для начала её использования нужно отойти от некоторых привычек. И не факт что скорость сильно увеличится. Для меня, например, заполнение перечня реквизитов документов не самая сложная задача. Труднее понять чем их заполнять. Откуда брать данные. Составить запрос, да так чтобы конструктором запроса не покоцать комментарии.

Буду размышлять о том как в неё перетащить свои одноразовые обработки. И много ли их у меня.
36. stasyan 27.11.09 13:01 Сейчас в теме
Писал себе подобную вещь, иногда пользуюсь. А вот твою, на первый взгляд, с более профессиональным подходом написанную сейчас посмотрю. Люблю такие вещи, спасибо!
37. stasyan 27.11.09 13:15 Сейчас в теме
В "Управление торговлей" падает на имена процедур общего модуля при открытии:
{ВнешняяОбработка.КонсольТекстовМодулей(527,9)}: Процедура или функция с указанным именем уже определена (ПолучитьОписаниеТиповСтроки)
Функция <<?>>ПолучитьОписаниеТиповСтроки(ДлинаСтроки) Экспорт
{ВнешняяОбработка.КонсольТекстовМодулей(527,9)}: Процедура или функция с указанным именем уже определена (ПолучитьОписаниеТиповСтроки)
Функция <<?>>ПолучитьОписаниеТиповСтроки(ДлинаСтроки) Экспорт
{ВнешняяОбработка.КонсольТекстовМодулей(527,9)}: Процедура или функция с указанным именем уже определена (ПолучитьОписаниеТиповСтроки)
Функция <<?>>ПолучитьОписаниеТиповСтроки(ДлинаСтроки) Экспорт

Поправь, пожалуйста!
38. chang 27.11.09 13:57 Сейчас в теме
39. tomvlad 3751 27.11.09 14:01 Сейчас в теме
(38) Так напиши, я разве против. У tormozit'a есть замечательная контекстная подсказка. Остается попросить его разрешения использовать. Прикрутишь, выложишь - тебе столько народа спасибо скажет...
42. chang 27.11.09 14:09 Сейчас в теме
(39) я не хаю, вы молодец! Но вижу смысл применения только один: поднялся в кабинет к глав.буху на пять этажей по лестнице, она мне показывает ошибки в программе, ну а пофигуратор забыл выключить у себя, а проверить надо.. эх, если бы еще он внешние обработки править мог! :)
40. chang 27.11.09 14:05 Сейчас в теме
41. tomvlad 3751 27.11.09 14:06 Сейчас в теме
(40) Суровым челябинским одинэсникам отладчик не нужен :)
43. Арчибальд 2709 27.11.09 14:11 Сейчас в теме
(41) Чуточку флуда: вот ни разу отладчиком не пользовался за 40 лет :D
44. Трактор 1187 27.11.09 14:20 Сейчас в теме
(43) Ого! Служебными сообщениями задолбаешься отлаживать.
45. Арчибальд 2709 27.11.09 14:29 Сейчас в теме
(44) а что делать, если первые 20 лет их просто не было. 8-)
47. akama2001 27.11.09 15:22 Сейчас в теме
Прошу добавить кнопочку для разбиения запросов по вложенным подзапросам, очень пригодилось бы !!!
48. AntiL 27.11.09 15:31 Сейчас в теме
Обработка написано добро...
Очень нехватает функции подбора кода при вводе кода по комбинации клавиш "Ctrl+ПРОБЕЛ"
49. NDM 27.11.09 16:01 Сейчас в теме
Не все "Классы" метаданных корректно занесены, см.
Прикрепленные файлы:
50. tormozit 5423 27.11.09 23:02 Сейчас в теме
Мое разрешение на подсказку не нужно. Я ее же и писал для всех. Вот только ее легко подключить можно только в рамках конфигурации, но не внешней обработки.
51. Tsprogrammist1 83 01.12.09 08:56 Сейчас в теме
52. liouria 01.12.09 23:22 Сейчас в теме
Не работает цикл "Для счетчик = 0 ПО ... " - не происходит изменения значения счетчика.
Тот же самый кусок кода в составе конфигурации - работает без проблем.
53. tomvlad 3751 01.12.09 23:29 Сейчас в теме
(52) Юрий, у Вас ошибка в коде. Приведите фрагмент целиком.
54. Stepa86 982 12.12.09 10:53 Сейчас в теме
(0) А почему шаблоны текста не *.st используются, а вшитые в обработку? или используются???
55. Alex_Smolensky 104 16.12.09 16:46 Сейчас в теме
отличная штука, спасибо!
56. artbear 1128 13.02.10 19:34 Сейчас в теме
(0) Опиши последние изменения, плиз.
Вижу, что сейчас версия 2.0.0.18 от 30.12.09, а описана только 2.0.0.15
65. tomvlad 3751 15.02.10 09:06 Сейчас в теме
(56) В релизах старше 2.0.0.15 изменения касаются только исправления выявленных ошибок.
68. artbear 1128 15.02.10 13:37 Сейчас в теме
(65) По (61) что можешь сказать?
Не хочешь превратить свою консоль в еще и в инструмент юнит-тестирования :) ?
58. artbear 1128 13.02.10 20:12 Сейчас в теме
(0) В связи с обращением к запросам и алгоритмам невозможно давать произвольное имя запроса или алгоритма, разрешено только имя в формате идентификатора 1С.

ИМХО либо запрети создавать "плохие" имени, либо в доке/справке/подсказке опиши подобное поведение
64. tomvlad 3751 15.02.10 09:01 Сейчас в теме
66. artbear 1128 15.02.10 12:32 Сейчас в теме
(64) Просьба писать данные по текущему релизу - хотя бы версию и дату.
ИМХО Для этого идеально подходит блог :)
67. artbear 1128 15.02.10 13:37 Сейчас в теме
(64) Спасибо.
Но еще ошибки есть:
при переносе элемента в другую группу у этого элемента исчезают и алгоритмы, и запросы :(
Поправишь?
69. tomvlad 3751 16.02.10 07:56 Сейчас в теме
(67) Исправил
(68) Нет, пока не хочу, да и времени нет
59. artbear 1128 13.02.10 20:21 Сейчас в теме
(0) Баг - при копировании в дереве текстов модулей не копируются алгоритмы и запросы :(
Текст и параметры копируются, а остальное нет.
Совсем не гуд.
версия 2.0.0.18
60. artbear 1128 13.02.10 20:26 Сейчас в теме
(0) Еще баг - действия по нажатию кнопки Выполнить сверху рядом с кнопкой Параметры отличаются от действия F7 или контекстное меню на имени текста и выборе Выполнить.
По Выполнить - алгоритмы и запросы работают, а по Ф7 нет :( - выдаются синтаксические ошибки.
61. artbear 1128 13.02.10 22:05 Сейчас в теме
Текущую редакцию довольно легко можно превратить в простую среду по созданию, отладке и тестированию юнит-тестов в 1С.


Принимаем следующие предположения:
1. если код/текст/юнит-тест не работает, он выбрасывает исключение
2. несколько юнит-тестов могут быть объединены в группы
при этих предположениях легко сделать исправления в модуле основной формы браузера блоков кода
и по кнопке Выполнить будут выполняться целые группы тестов.
.
Код ниже вставляем вместо процедуры КоманднаяПанельФормыВыполнить(Кнопка) в модуле основной формы
.
// Артур
Функция ВыполнитьОдинБлокКода(текстМодуля, ДанныеДляКода)
//Процедура КоманднаяПанельФормыВыполнить(Кнопка)

    // Поместим параметры, алгоритмы и запросы в структуры,
    // чтобы к ним можно было обратиться, например Алгоритмы.ОбработкаСправочника

    Параметры = Новый Структура;
    Для каждого ПараметрСтрока Из ДанныеДляКода.ТаблицаПараметров Цикл
        Параметры.Вставить(ПараметрСтрока.Параметр, ПараметрСтрока.ЗначениеПараметра);
    КонецЦикла;

    Алгоритмы = Новый Структура;
    Для каждого АлгоритмСтрока Из ДанныеДляКода.ТаблицаАлгоритмов Цикл
        Алгоритмы.Вставить(АлгоритмСтрока.АлгоритмИмя, АлгоритмСтрока.Алгоритм);
    КонецЦикла;

    Запросы = Новый Структура;
    Для каждого ЗапросСтрока Из ДанныеДляКода.ТаблицаЗапросов Цикл
        Запросы.Вставить(ЗапросСтрока.ЗапросИмя, Новый Запрос(ЗапросСтрока.Запрос));
    КонецЦикла;

    // Выполнение текста

    ТаблицаРезультат.Очистить();

    Если НЕ ДанныеДляКода.ЭтоГруппа Тогда
        Выполнить(текстМодуля); //Выполнить(ЭлементыФормы.ТекстМодуля.ПолучитьТекст());
        Возврат Истина;
    Иначе
        Попытка
            Выполнить(текстМодуля);
            Возврат Истина;
        Исключение
            Сообщить("Код "+ДанныеДляКода.ТекущаяСтрока.ИмяТекста + " неверно отработал - <"+ОписаниеОшибки()+">");
            Возврат Ложь;
        КонецПопытки;
    КонецЕсли;

КонецФункции

// Артур
Процедура КоманднаяПанельФормыВыполнить(Кнопка)
    ДанныеДляКода = Новый Структура;

    текущаяСтрока = ЭлементыФормы.ДеревоТекстов.ТекущаяСтрока;
    подчиненныеСтроки = текущаяСтрока.Строки;
    количествоПодчиненныхСтрок = подчиненныеСтроки.Количество();
    этоГруппаБлоковКода = количествоПодчиненныхСтрок <> 0;

    Если НЕ этоГруппаБлоковКода Тогда
        код = ЭлементыФормы.ТекстМодуля.ПолучитьТекст();

        ДанныеДляКода.Вставить("ЭтоГруппа", Ложь);

        ДанныеДляКода.Вставить("ТаблицаПараметров", ТаблицаПараметров);
        ДанныеДляКода.Вставить("ТаблицаАлгоритмов", ТаблицаАлгоритмов);
        ДанныеДляКода.Вставить("ТаблицаЗапросов", ТаблицаЗапросов);
        ДанныеДляКода.Вставить("ТекущаяСтрока", текущаяСтрока);

        ВыполнитьОдинБлокКода(код, ДанныеДляКода);
    Иначе
        количествоПлохихТестов = 0;
        Для каждого строка Из подчиненныеСтроки Цикл
            код = строка.ТекстМодуля;

            ДанныеДляКода.Вставить("ЭтоГруппа", Истина);

            ДанныеДляКода.Вставить("ТаблицаПараметров", строка.Параметры);
            ДанныеДляКода.Вставить("ТаблицаАлгоритмов", строка.ТаблицаАлгоритмов);
            ДанныеДляКода.Вставить("ТаблицаЗапросов", строка.ТаблицаЗапросов);
            ДанныеДляКода.Вставить("ТекущаяСтрока", строка);

            успешно = ВыполнитьОдинБлокКода(код, ДанныеДляКода);
            Если НЕ успешно Тогда
                количествоПлохихТестов = количествоПлохихТестов + 1;
            КонецЕсли;
        КонецЦикла;

        Если количествоПлохихТестов = 0 Тогда
            Сообщить("ОК");
        Иначе
            Сообщить("Не выполнено <"+количествоПлохихТестов+"> тестов/блоков кода из <"+количествоПодчиненныхСтрок+">");
        КонецЕсли;
    КонецЕсли;
КонецПроцедуры
// завершение
Показать


ИМХО очень удобно использовать для тестирования.

ЗЫ в данной редакции кода возможна редакция только на 2-х уровнях иерархии - код и группа кодов. но доработать на любую иерархию несложно.
62. artbear 1128 13.02.10 23:45 Сейчас в теме
(59+) Еще очень серьезный баг: иногда алгоритмы и запросы просто пропадают, в основном это происходит после простых переключений/активаций разных строк в дереве текстов :(
70. Istur 1414 02.08.10 18:55 Сейчас в теме
Если зайти в конструктор запроса, то выдает ошибку. При этом запрос выполняется, с этим проблем нет. В режиме конфигуратора ошибки нет.

В принципе эта ошибка не существенна.
Прикрепленные файлы:
72. feel063 13 05.10.11 23:25 Сейчас в теме
Ещё бы что-нибудь подобное для управляемых форм))
74. Поручик 4273 09.10.11 16:59 Сейчас в теме
73. pmtvv 09.10.11 14:57 Сейчас в теме
молодец, хорошая обработка
75. unknown181538 24 11.11.11 16:46 Сейчас в теме
76. yavedmin 107 17.11.11 18:13 Сейчас в теме
Спасибо! Очень понравилась.
77. AChelentano 28.11.11 12:41 Сейчас в теме
Спасибо. Пользуюсь постоянно.
Статус бар допишите только пожалуйста. Я у себя сделал. Другим тоже может пригодиться.
МимохожийОднако; +1 Ответить
79. МимохожийОднако 122 07.01.12 12:01 Сейчас в теме
(77) AChelentano, сбрось сюда свой вариант. Может, кому пригодится.
78. kirillsas 6 04.01.12 10:20 Сейчас в теме
После перепроведения документов на закладке "Результат выполнения" она присоединила снизу еще кусок формы с "Доступные обработки" и "Выбранные обработки". Выбираю "Отменить проведение документов" и получаю предупреждение "Данная обработка недоступна для типа <Документы>".
Что бы это значило?

при копировании в дереве текстов модулей не копируются алгоритмы и запросы
Текст и параметры копируются, а остальное нет.
Совсем не гуд.
версия 2.0.0.18
80. AlexKoso 17 30.01.12 21:08 Сейчас в теме
судя по скринам - чтото феерическое. Автор берегись, я выхожу на путь тестирования :)
81. tormozit 5423 03.02.12 11:14 Сейчас в теме
83. correct_coding 438 28.02.12 23:37 Сейчас в теме
82. andru_dv 03.02.12 16:01 Сейчас в теме
Попробую в деле этот инструмент. По результатам отпишусь.
84. angy 21.06.12 11:30 Сейчас в теме
Обработка прикольная , только в том плане что конфиг не надо открывать а все остальное можно написать в обычной консоле запросов + куча багов, идея хорошая, когда быстро нужно чего то исправить а в остальном пользы мне кажется мало, это лично мое мнение. Работа проделана колосальная автору респект...
85. fomix 26 04.12.12 11:15 Сейчас в теме
Добрый день! Скачал для 8.1 и 8.2. А есть ли разница в них?!
Пока пробую для 8.2 на толстом клиенте. Запустил конструктор объекта ссылочного типа и на тебе:
1. галочки на всех закладках ставятся, но не снимаются.
2. так и не понял как создается текст модуля заполнения объекта, поиска реквизитов и т.п.
3. не заполняются реквизиты табличных частей.
Это что - бета версия или конструктор доделай сам?! Однаааако....
86. tehas 47 05.12.12 12:44 Сейчас в теме
однозначно плюс, вещь мощная =)
87. ksvd 14.02.13 10:52 Сейчас в теме
Вот спасибо! Пригодилась для выполнения кода по отключению от интернет-поддержки при запуске Бухгалтерии 2.0
88. frc 01.05.13 18:38 Сейчас в теме
(0) не понял - это для создания кода (таблицы-справочники), или для выполнения кода?
89. alonehobo 21.07.13 21:04 Сейчас в теме
90. Vix 24 12.09.13 19:28 Сейчас в теме
91. alext88 3 20.02.14 08:42 Сейчас в теме
92. alex_sear 26.02.14 04:28 Сейчас в теме
93. ShantinTD 86 03.12.15 11:25 Сейчас в теме
странно, куда потерял сие чудо? скачивал же уже! За хорошую вещь не жалко еще один $m отдать.
94. ChessCat 18.01.16 23:19 Сейчас в теме
Подскажите пожалуйста инструмент для решения задач которые легко решала эта обработка только для управляемых форм.

Например стандартная задача.

Есть определенный регистр. Регистраторы сделали по нему движения.
Необходимо получить движения по регистру и что то в них поменять без перепроведения документов.
С помощью этой консоли на обычных формах подобная задача решалась очень легко написанием куска кода и выполнением его через консоль.

А как решить эту задачу на управляемых формах ?

95. hiduk 80 09.08.17 10:49 Сейчас в теме
А я всегда думал, что пост фикс "(8.2)" в имени обработки означает, что она под управляемые формы:(
Оставьте свое сообщение